stewardship-sig
LOGS
15:01:27 <decathorpe> #startmeeting Stewardship SIG Meeting (2019-04-30)
15:01:27 <zodbot> Meeting started Tue Apr 30 15:01:27 2019 UTC.
15:01:27 <zodbot> This meeting is logged and archived in a public location.
15:01:27 <zodbot> The chair is decathorpe. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:27 <zodbot> The meeting name has been set to 'stewardship_sig_meeting_(2019-04-30)'
15:01:36 <mhroncok> hey
15:01:41 <decathorpe> #meetingname stewardship-sig
15:01:41 <zodbot> The meeting name has been set to 'stewardship-sig'
15:01:46 <decathorpe> hi :)
15:01:52 <decathorpe> #topic Roll Call
15:02:35 <decathorpe> #chair mhroncok
15:02:35 <zodbot> Current chairs: decathorpe mhroncok
15:03:27 <decathorpe> I suggest waiting until 17:05 to see if anybody else shows up
15:05:44 <decathorpe> okay, let's start ... there's not much to discuss today, I think
15:05:58 <decathorpe> #topic Review current build failures
15:06:09 <decathorpe> #link https://apps.fedoraproject.org/koschei/groups/stewardship-sig?
15:06:42 <mhroncok> decathorpe: does it make sense?
15:07:18 <decathorpe> there are just 1-2 things I wanted to mention, and I'd end the meeting early
15:07:25 <mhroncok> ok
15:07:51 <decathorpe> regarding gradle, I think you "fixed" the FTBFS issue and removed checkstyle dep already?
15:08:20 <mhroncok> decathorpe: I've managed to build it, but it again doesn't build
15:08:33 <mhroncok> so koschcei will keep complaining etc.
15:08:43 <decathorpe> well, it's fixed for now, and the rest is not really our concern to be honest
15:08:52 <mhroncok> right
15:09:07 <decathorpe> then I will close https://www.pagure.io/stewardship-sig/issue/10
15:10:37 <decathorpe> your PR for fixing aqute-bnd is still pending, do you think we can merge that one?
15:11:20 <mhroncok> decathorpe: honestly, IDK
15:11:27 <mhroncok> is the FTBFS blocking anything?
15:11:44 <decathorpe> I don't think so
15:12:08 <mhroncok> decathorpe: than let's keep it open
15:12:13 <decathorpe> alright
15:12:53 <decathorpe> I've also added some arch overrides to koschei to force x86_64, because of the missing eclipse packages
15:13:04 <decathorpe> and posted the list to our tracking issue
15:13:13 * mhroncok has seen that
15:13:31 * mhroncok has also seacrhed for bcond eclipse, but tehre was just one and it didn't work
15:13:41 * decathorpe frowns
15:13:42 <mhroncok> or wasn't necessary
15:14:33 <decathorpe> well, it's low priority anyway, until we get a report that something is actively broken I guess
15:14:49 <mhroncok> agreed
15:15:32 <decathorpe> alright. I don't think there are noteworthy new RHBZs for the SIG (besides the-new-hotness stuff)
15:16:06 <mhroncok> decathorpe: https://pagure.io/releng/issue/8317
15:16:24 <decathorpe> yeah, I've added him to the SIG
15:17:09 <decathorpe> I haven't regenerated the report for the new packages yet, but will do that tomorrow
15:17:09 <mhroncok> https://src.fedoraproject.org/group/stewardship-sig 201 packages
15:17:14 <mhroncok> good
15:17:44 <decathorpe> alright, moving on
15:17:53 <decathorpe> #topic Review (SIG) Leaf Packages
15:17:56 <decathorpe> #link https://decathorpe.fedorapeople.org/stewardship-sig.html
15:18:21 <decathorpe> there are a few more (including checkstyle now)
15:19:03 <decathorpe> I've sent out an email to devel asking for somebody to take them two weeks ago but got zero responses (other than one bouncing primary maintainer email)
15:19:14 <mhroncok> let's orphan checkstyle, it's easy to get rid of and I guess it is only required by others on buildtime
15:19:41 <mhroncok> Required-By: eclipse-checkstyle
15:19:42 <mhroncok> Required-By: hadoop-common
15:19:42 <mhroncok> Required-By: hibernate-search
15:19:42 <mhroncok> Required-By: maven-checkstyle-plugin
15:19:42 <mhroncok> Required-By: zookeeper
15:19:42 <mhroncok> Required-By: zookeeper
15:19:47 <mhroncok> well, not only buildtime
15:19:50 <decathorpe> yep
15:20:05 <mhroncok> hadoop is laready broken
15:20:41 <decathorpe> probably either someone from eclipse-checkstyle or maven-checkstyle-plugin should take it
15:22:03 <mhroncok> decathorpe: this one is assigned to you. I suggest to write one more e-mail to devel specifically aboyt checkstyle, ccing the depndents
15:22:17 <decathorpe> yep. I will
15:22:18 <mhroncok> decathorpe: remove the sig and orphan in a week
15:22:29 <decathorpe> +1
15:22:42 <decathorpe> #action get rid of checkstyle
15:23:43 <decathorpe> #topic Open Floor
15:24:00 <decathorpe> anything else? I don't think so
15:24:40 <mhroncok> not really
15:24:44 <mhroncok> how are you doing? :)
15:25:02 <decathorpe> pretty good, the easter holidays were important for catching up on stuff
15:25:06 <decathorpe> you?
15:25:37 <mhroncok> I seriously need a longer break :)
15:25:48 <mhroncok> looking forward to when the semester ends
15:26:13 <decathorpe> yeah, me too ...
15:26:18 <mhroncok> but the regular Fedora fun is good. I'm now DOSing Copr https://copr.fedorainfracloud.org/coprs/g/python/python3.8/builds/
15:26:28 <decathorpe> I noticed ;)
15:26:52 <mhroncok> decathorpe: thansk for the meeting
15:26:56 <mhroncok> #endmeeting