f30-final-go_no_go-meeting
MINUTES

#fedora-meeting-1: F30 Final Go/No-Go meeting

Meeting started by bcotton at 17:00:24 UTC (full logs).

Meeting summary

  1. Roll Call (bcotton, 17:00:37)
  2. Purpose of this meeting (bcotton, 17:03:34)
    1. Purpose of this meeting is to check whether or not F30 is ready for shipment, according to the release criteria. (bcotton, 17:03:36)
    2. This is determined in a few ways: (bcotton, 17:03:37)
    3. 1. No remaining blocker bugs (bcotton, 17:03:41)
    4. 2. Release candidate compose is available (bcotton, 17:03:43)
    5. 3. Test matrices are fully completed (bcotton, 17:03:44)

  3. Current status — release candidate (bcotton, 17:04:28)
    1. RC 2 is the current candidate (bcotton, 17:04:45)
    2. https://fedoraproject.org/wiki/Template:Fedora_30_RC_1.1_Download vs. https://fedoraproject.org/wiki/Template:Fedora_30_RC_1.2_Download (adamw, 17:06:24)
    3. The following deliverables are not in RC2 (but were in RC1): design_suite-live-x86_64, scientific-vagrant-libvirt-x86_64, lxqt-raw-xz-armhpf, mate-raw-xz-armhfp, container_base-docker-s390x, python_classroom-live-x86_64, lxde-live-x86_64, scientific-vagrant-virtualbox-x86_64 (bcotton, 17:11:05)
    4. https://koji.fedoraproject.org/koji/taskinfo?taskID=34454818 (LXQt) (adamw, 17:11:28)
    5. The following non-blocking deliverables are not in RC2 (but were in RC1): design_suite-live-x86_64, scientific-vagrant-libvirt-x86_64, lxqt-raw-xz-armhpf, mate-raw-xz-armhfp, container_base-docker-s390x, python_classroom-live-x86_64, lxde-live-x86_64, scientific-vagrant-virtualbox-x86_64 (bcotton, 17:16:45)
    6. several failed due to download failures during build (bcotton, 17:16:48)

  4. Current status — blocker bugs (bcotton, 17:23:13)
    1. https://qa.fedoraproject.org/blockerbugs/milestone/30/final/buglist (bcotton, 17:23:15)
    2. (1670396) KSieve fails to start - fixed in RC2 (bcotton, 17:23:56)
    3. (1703152) initial-setup fails with no network - AttributeError: 'NoneType' object has no attribute 'upper' - fixed in RC2 (bcotton, 17:24:12)
    4. ACTION: adamw to verify if fix for BZ 1688462 is needed for F28 (bcotton, 17:26:50)
    5. ACTION: RelEng to push the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1688462 stable for F29 (and possibly F28) before releasing F30 (bcotton, 17:27:00)

  5. Current status — test matrices (bcotton, 17:29:51)
    1. https://fedoraproject.org/wiki/Category:Fedora_30_Test_Results (bcotton, 17:29:53)
    2. Coverage is complete except for a few non-blocking Xen tests (bcotton, 17:32:53)

  6. Go/No-Go decision (bcotton, 17:35:16)
    1. FESCo is GO (bcotton, 17:35:32)
    2. RelEng is GO (bcotton, 17:35:40)
    3. QA is GO (bcotton, 17:36:09)
    4. AGREED: Fedora 30 is GO (bcotton, 17:36:23)
    5. Fedora 30 will release on 2019-04-30 (bcotton, 17:36:32)
    6. ACTION: bcotton to announce decision (bcotton, 17:36:55)

  7. Open Floor (bcotton, 17:37:10)
    1. ACTION: adamw to request the final stable updates (bcotton, 17:38:16)
    2. ACTION: adamw to file a ticket for pulling in unofficial missing images so everyone can monitor that and make sure it happens (bcotton, 17:39:20)


Meeting ended at 17:42:38 UTC (full logs).

Action items

  1. adamw to verify if fix for BZ 1688462 is needed for F28
  2. RelEng to push the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1688462 stable for F29 (and possibly F28) before releasing F30
  3. bcotton to announce decision
  4. adamw to request the final stable updates
  5. adamw to file a ticket for pulling in unofficial missing images so everyone can monitor that and make sure it happens


Action items, by person

  1. adamw
    1. adamw to verify if fix for BZ 1688462 is needed for F28
    2. adamw to request the final stable updates
    3. adamw to file a ticket for pulling in unofficial missing images so everyone can monitor that and make sure it happens
  2. bcotton
    1. bcotton to announce decision


People present (lines said)

  1. bcotton (81)
  2. adamw (73)
  3. mboddu (32)
  4. nirik (27)
  5. zodbot (19)
  6. sgallagh (14)
  7. coremodule (10)
  8. bowlofeggs (8)
  9. pwhalen (3)
  10. stickster (3)
  11. zbyszek (2)
  12. sumantro (2)
  13. Southern_Gentlem (1)
  14. mkolman (1)
  15. MarkOtaris (1)


Generated by MeetBot 0.1.4.