fpc
LOGS
16:00:12 <geppetto> #startmeeting fpc
16:00:12 <zodbot> Meeting started Thu Apr 18 16:00:12 2019 UTC.
16:00:12 <zodbot> This meeting is logged and archived in a public location.
16:00:12 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:12 <zodbot> The meeting name has been set to 'fpc'
16:00:13 <geppetto> #meetingname fpc
16:00:13 <geppetto> #topic Roll Call
16:00:13 <zodbot> The meeting name has been set to 'fpc'
16:03:32 <mhroncok> hey
16:03:42 <tibbs> Hey, folks.
16:03:46 <tibbs> Just writing up the Lua naming thing.
16:03:47 <geppetto> #chair mhroncok
16:03:47 <zodbot> Current chairs: geppetto mhroncok
16:03:49 <decathorpe> o/
16:03:49 <geppetto> #chair tibbs
16:03:49 <zodbot> Current chairs: geppetto mhroncok tibbs
16:03:52 <geppetto> #chair decathorpe
16:03:52 <zodbot> Current chairs: decathorpe geppetto mhroncok tibbs
16:03:57 <geppetto> Hey
16:05:56 <geppetto> #chair redi
16:05:56 <zodbot> Current chairs: decathorpe geppetto mhroncok redi tibbs
16:06:01 <geppetto> And then there were 5 :)
16:06:02 <redi> hi - got a high priority bug fix I'm working on, so will only half pay attention here today
16:06:10 <geppetto> Fair enough
16:06:58 <geppetto> #topic Schedule
16:07:02 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/IBDGRCJN5D4QF5GHXQQJUDBWVS3CRKMJ/
16:07:24 * limburgher is late
16:07:32 <geppetto> #chair limburgher
16:07:32 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok redi tibbs
16:08:32 <decathorpe> looks like the email got mangled at some point?
16:08:41 <geppetto> yeh
16:08:56 <geppetto> seems to be evolution on my end
16:09:05 <decathorpe> but I think it looked fine locally
16:09:53 <geppetto> Anyway … this one popped back up:
16:09:54 <geppetto> #topic #382 Go Packaging Guidelines Draft.fpc 382
16:09:58 <geppetto> .fpc 382
16:10:01 <zodbot> geppetto: Issue #382: Go Packaging Guidelines Draft - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/382
16:10:04 <decathorpe> I wanted to look at this once I have some time
16:10:11 <decathorpe> since I'm member of the Go SIG as well
16:10:30 <geppetto> Latest draft is: https://pagure.io/packaging-committee/pull-request/883
16:10:46 <mhroncok> https://eclipseo.fedorapeople.org/guidelines/packaging-guidelines/Golang/
16:11:24 <mhroncok> this just adds stuff, so it might be easier to read rendered
16:12:26 <mhroncok> If upstream confused itself...
16:12:33 <mhroncok> go is lovely
16:12:42 <decathorpe> sarcasm?
16:13:32 <geppetto> There are two types of programming languages … those that people hate and those that nobody uses ;)
16:13:43 <mhroncok> yes, I find the entire "import from github master" a very bad idea
16:14:00 <mhroncok> but geppetto has a point :)
16:16:02 <geppetto> A quick search suggests that this says nothing about go modules
16:16:10 <decathorpe> no, those are not covered yet
16:16:13 * geppetto nods
16:16:27 <decathorpe> because they break a whole load of assumptions
16:16:44 <decathorpe> the Go SIG is working in it, though
16:17:20 <ignatenkobrain> hi
16:17:27 <ignatenkobrain> I wonder why I didn't get invitation
16:17:36 <ignatenkobrain> sorry for being late
16:17:41 <geppetto> #chair ignatenkobrain
16:17:41 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher mhroncok redi tibbs
16:18:25 <decathorpe> from what I can tell, these Go Guidelines are pretty good and comprehensive
16:18:37 <decathorpe> (speaking as somebody who maintains ~30 go packages)
16:18:46 <geppetto> ok
16:18:57 <ignatenkobrain> I wish we could have "expandable" text on docs
16:19:15 <ignatenkobrain> so that we could inline some templates with being hidden by default
16:19:38 <mhroncok> Binaries SHOULD set ExclusiveArch ... This is now automatically added by the %gometa macro.
16:19:46 <mhroncok> so packagers should not add it, right?
16:19:50 <decathorpe> yes
16:19:54 <mhroncok> this part confused me
16:19:55 <decathorpe> they should't
16:19:59 <decathorpe> me too
16:20:27 <decathorpe> but some packages might not use %gometa yet, which sets this macro
16:20:58 <ignatenkobrain> these new guidelines look much better than I saw before :)
16:21:13 <mhroncok> You MUST run unit tests.
16:21:22 <mhroncok> wow! we should add this everywhere
16:21:34 <tibbs> Well.... it's always a qualified thing.
16:21:51 <tibbs> Sometimes tests require unpackaged dependencies or take six days to run on ARM or whatever.
16:22:09 <ignatenkobrain> I think I disagree with this one... Given those Fedora CI efforts (which do not involve running them using rpmbuild)
16:22:31 <ignatenkobrain> "
16:22:32 <ignatenkobrain> the import path github.com/gopherjs/gopherjs will become golang-github-gopherjs
16:22:33 <ignatenkobrain> " -- I think I don't understand why this has been done
16:23:29 <mhroncok> I also don't understand this: the import path github.com/DATA-DOG/go-txdb will become golang-github-data-dog-txdb
16:23:30 <decathorpe> paraphrasing here: "to reduce redundancy and produce human-friendly package names"
16:23:48 <ignatenkobrain> "They are automatically generated by the %gogenbr macro in %prep
16:23:48 <ignatenkobrain> " -- No, please no. This is not the way it works. BuildRequires (as of today), have to be specified  manually.
16:24:25 <mhroncok> "If you’re lucky"
16:24:27 <decathorpe> right, that shouldn't be in there
16:25:02 <ignatenkobrain> "Security in Go Language Packages" -- I think this section doesn't belong to FPG
16:25:17 <ignatenkobrain> I will take a look this weekend and comment inline in PR
16:25:26 <decathorpe> well ... would you stick this into the update guidelines?
16:25:34 <geppetto> Yeh, the examples all have explicit BRs
16:26:19 <ignatenkobrain> decathorpe: yes. I think we need to have generic documentation how to detect such things... And moreover, we should automate it on infra level :)
16:26:30 <geppetto> I'm not sure I mind having a %gogenbr … but if so the examples should use it
16:26:42 <decathorpe> but it doesn't work yet, does it?
16:26:45 <ignatenkobrain> geppetto: it simply won't work
16:26:54 <ignatenkobrain> decathorpe: it won't work in future, either
16:27:02 <mhroncok> :)
16:27:07 <mhroncok> not this way anyway
16:27:14 <geppetto> Fair enough
16:27:26 <mhroncok> #action ignatenko will comment inline
16:27:45 <mhroncok> I don't think we have more to decide now, do we?
16:27:58 <ignatenkobrain> probably not now..
16:28:10 <decathorpe> I don't think so
16:28:14 <decathorpe> I'll add a few comments, too
16:28:15 <geppetto> #topic  #876 F31 System-Wide Change: F31 Mass Python 2 Package Removal - policies and exceptions
16:28:21 <geppetto> .fpc 876
16:28:22 <zodbot> geppetto: Issue #876: F31 System-Wide Change: F31 Mass Python 2 Package Removal - policies and exceptions - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/876
16:28:46 <geppetto> mhroncok: You commented
16:28:50 <mhroncok> yes
16:29:23 <mhroncok> latest meeting, it seemed that a part of the process was not received well. we made it optional
16:29:30 <geppetto> So was that our second vote from last meeting?
16:29:37 * geppetto nods
16:29:52 <geppetto> Do we need to discuss anything?
16:29:55 <mhroncok> the second vote was already implemented ina  separate PR
16:30:01 <geppetto> ok
16:30:08 <mhroncok> we'd like explicit FPC approval / ack
16:30:35 <ignatenkobrain> mhroncok: on the way of conditionalizing/changing spec files?
16:30:46 <mhroncok> no
16:31:01 <mhroncok> on the processes described in the change proposal
16:31:16 <mhroncok> and review exceptions
16:31:33 <geppetto> https://fedoraproject.org/w/index.php?title=Changes%2FF31_Mass_Python_2_Package_Removal&type=revision&diff=540278&oldid=540029
16:31:59 <geppetto> Given that it's an optionally … I'm fine to +1 it.
16:32:49 <mhroncok> I it not this diff I'd liek to get acked
16:33:06 <geppetto> Oh, ok … can you link to the diff. you want to get ackd?
16:33:14 <ignatenkobrain> I'm +1 indeed (since I'm actually listed as owner of a change) :)
16:33:15 <mhroncok> it's the change proposal
16:33:22 <ignatenkobrain> https://fedoraproject.org/w/index.php?title=Changes%2FF31_Mass_Python_2_Package_Removal&type=revision&diff=540278&oldid=540029#Process_for_abandoning_Python_2_subpackages
16:33:29 <ignatenkobrain> I think Miro means this part
16:33:41 <ignatenkobrain> and this one 🔗 Removing Requirements
16:33:53 <mhroncok> I'm sorry
16:34:11 <mhroncok> I've explicitly linked 4 parts in the issue description
16:34:11 <mhroncok> I mean those 4 parts
16:34:19 <mhroncok> Process for abandoning Python 2 subpackages https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Process_for_abandoning_Python_2_subpackages
16:34:30 <mhroncok> Claiming Python 2 parts of a package with package review exception https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Claiming_Python_2_parts_of_a_package
16:34:43 <mhroncok> More drastic version of the Policy for nonresponsive package maintainers https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Information_on_Remaining_Packages
16:34:51 <mhroncok> Removing non-installable packages from the distro https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal#Removing_non-installable_packages_from_the_distro
16:35:42 <ignatenkobrain> I don't think that we have to vote on "🔗 Removing non-installable packages from the distro" part since it is more FESCo stuff
16:35:43 <ignatenkobrain> the others look ok for me
16:36:32 <mhroncok> ignatenkobrain: I realize most of this is not in fpc "jurisdiction"
16:36:55 <mhroncok> a simple: "whatever, ok" vote works for me as well
16:37:01 <geppetto> The one part of the abandon process I'm not sure of is the 3-week waiting time
16:37:19 <decathorpe> I'd be comfortable to give this an "ack" vote ;)
16:37:40 <ignatenkobrain> mhroncok: well, yes... but the split of python2 packages and handling whole thing seems prety much FPC business
16:37:49 <geppetto> but in general I'm fine with all of it.
16:37:59 <mhroncok> geppetto: too fast?
16:38:36 <mhroncok> geppetto: let's make it 4?
16:38:37 <geppetto> mhroncok: No, I'm more worried that someone will want to update to a new version and it won't work with py2 … and they can't fix it, so they have to wait 3 weeks.
16:38:49 <mhroncok> oh
16:39:59 <mhroncok> I think the maintainer may just use their best judgement there - breaking the rules on purpose and be extra loud about it
16:40:13 <decathorpe> "rules"
16:40:20 * geppetto nods … I'm fine with that, might be worth saying something though.
16:40:50 <geppetto> Yeh, my guess was that people would either complain loudly that they aren't allowed to update … or just update and immediately break things.
16:41:50 <ignatenkobrain> until we get automation to detect breakages, people will keep breaking things.. so it is okay :)
16:41:58 <mhroncok> I'm ok to deal with this on individual basis
16:42:01 <mhroncok> as ignatenkobrain says
16:42:02 <redi> yeah
16:42:46 <geppetto> fair enough
16:44:52 <mhroncok> should we ack vote?
16:45:00 <geppetto> Sure. +1
16:45:10 <mhroncok> I'm +1 obviously
16:45:13 <redi> +1
16:45:13 <decathorpe> +1 as well
16:45:14 <tibbs> +1
16:45:18 <mhroncok> thanks
16:45:46 <geppetto> #action F31 Mass Python 2 Package Removal - policies and exceptions (+1:5, 0:0, -1:0)
16:47:08 <ignatenkobrain> I was +1 too :)
16:47:16 <geppetto> #undo
16:47:16 <zodbot> Removing item from minutes: ACTION by geppetto at 16:45:46 : F31 Mass Python 2 Package Removal - policies and exceptions (+1:5, 0:0, -1:0)
16:47:24 <geppetto> #action F31 Mass Python 2 Package Removal - policies and exceptions (+1:6, 0:0, -1:0)
16:47:32 <geppetto> Done :)
16:47:37 <geppetto> #topic Open Floor
16:48:10 <decathorpe> I just wanted to mention, the Go SIG is thinking about renaming a lot of packages to have a consistent naming scheme
16:48:36 <geppetto> So we had two other ticket son the schedule, #859 and #845 … but neither has been modified since last meeting.
16:48:49 <ignatenkobrain> Just in case anybody is wondering -- I was working in upstream on https://fedoraproject.org/wiki/Changes/DynamicBuildRequires and it is ready to play with :)
16:49:56 <geppetto> Cool
16:52:43 <geppetto> Ok, I think we are done for this week … enjoy your spring vacation.
16:53:20 <decathorpe> you too!
16:54:00 <decathorpe> and thanks for organizing the meeting every week, geppetto
16:54:13 <geppetto> #endmeeting