fpc
LOGS
16:00:21 <geppetto> #startmeeting fpc
16:00:21 <zodbot> Meeting started Thu Apr 11 16:00:21 2019 UTC.
16:00:21 <zodbot> This meeting is logged and archived in a public location.
16:00:21 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:21 <zodbot> The meeting name has been set to 'fpc'
16:00:21 <geppetto> #meetingname fpc
16:00:21 <geppetto> #topic Roll Call
16:00:21 <zodbot> The meeting name has been set to 'fpc'
16:00:27 <tibbs> Hey, folks.
16:00:32 <geppetto> #chair tibbs
16:00:32 <zodbot> Current chairs: geppetto tibbs
16:00:51 <geppetto> hey
16:00:52 <mhroncok> hey
16:00:52 <tibbs> Another crazy busy week and day for me.  Maybe one day this will let up.
16:01:04 <redi> hi
16:01:05 <geppetto> #chair redi
16:01:05 <zodbot> Current chairs: geppetto redi tibbs
16:01:38 <andi89gi> Hi guys:)
16:02:02 <geppetto> #chair decathorpe
16:02:02 <zodbot> Current chairs: decathorpe geppetto redi tibbs
16:02:08 <decathorpe> hi guys :)
16:02:15 <geppetto> hey
16:02:32 * decathorpe is online on phone only, for now
16:04:48 <andi89gi> It's meeting time isn't it?
16:05:08 <mhroncok> andi89gi: yes
16:05:36 <geppetto> We need 5
16:05:48 <geppetto> mhroncok: ahh, I missed you
16:05:55 <geppetto> #chair mhroncok
16:05:55 <zodbot> Current chairs: decathorpe geppetto mhroncok redi tibbs
16:06:27 <geppetto> #topic Schedule
16:06:32 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/S4HDZPSDOLHCMWXLQF2OXE27KLYTPPG3/
16:06:44 <geppetto> #topic #876 Mass Python 2 Package Removal - policies and exceptions
16:06:49 <geppetto> .fpc 876
16:06:50 <zodbot> geppetto: Issue #876: F31 System-Wide Change: F31 Mass Python 2 Package Removal - policies and exceptions - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/876
16:07:26 <mhroncok> so we'd liek to get some exceptions from package reviews
16:07:35 <mhroncok> fesco approved this, but I don't know if they read it all :D
16:07:55 <tibbs> +1 to exempting these from review.
16:08:29 <geppetto> Sure +1
16:09:01 <mhroncok> FTR I'm +1
16:09:22 <andi89gi> +1
16:09:26 <geppetto> redi: decathorpe: Vote?
16:09:29 <tibbs> Doesn't mean someone shouldn't try to make them clean but I don't see a reason to go all the way through bugzilla.
16:09:30 <decathorpe> yeah, +1 too
16:09:33 <geppetto> andi89gi: Who are you?
16:09:43 <redi> yeah +1
16:10:14 <geppetto> #action Exceptions from full package reviews (+1:5, 0:0, -1:0)
16:10:20 <redi> which rmeinds me I need to make all the boost-python2 stuff conditional
16:10:23 <redi> *reminds
16:10:25 <andi89gi> I'm Andi, new in the developing-list, Fedora maintainer(Telegram chat)
16:11:14 <redi> welcome. this is a meeting of the Fedora Packaging Committee (FPC) so the votes are from committee members
16:11:16 <geppetto> andi89gi: That's cool, feel free to participate but please don't vote … as you aren't an FPC member, and I get confused easily :)
16:11:47 <geppetto> mhroncok: Anything else we want to vote on today?
16:12:06 * mhroncok looks
16:12:08 <geppetto> #3 seems like an easy win
16:12:16 <andi89gi> geppetto: ok thx for the info;)
16:12:24 <andi89gi> How's best way to participate?
16:12:59 <geppetto> andi89gi: If tickets come up that you know things about, you can provide that info. to everyone :)
16:13:09 <mhroncok> geppetto: did we just veot the entire ticket or just the review exceptions?
16:13:23 <geppetto> mhroncok: I thought just the review exception
16:13:52 <mhroncok> so basically there are 4 points where we said we want FPC approval
16:14:04 <mhroncok> all linked formt he ticket
16:14:42 <mhroncok> it's long
16:14:45 <mhroncok> sorry about that
16:14:48 <mhroncok> vote in the ticket?
16:14:52 <tibbs> I believe two of those aren't up to us at all.
16:15:02 <mhroncok> technically, FPC approval is not needed
16:15:16 <mhroncok> I guess an "FPC acks this" is what we really want
16:15:30 <tibbs> The review exceptions are our thing.
16:15:41 <andi89gi> geppetto: ah okay;) thx
16:15:44 <tibbs> The packaging requirements are our thing.
16:15:51 <mhroncok> if the output is FPC does not concern this FPC bussines, that's Ok as well
16:16:11 <tibbs> At least if my summary in the first reply is correct....
16:16:27 <mhroncok> 1 Require specific and explicit conditionalization of python2 support in all specs.
16:16:39 <mhroncok> pretty sure ntoe xactly what we proposed
16:16:44 <mhroncok> *not exactly
16:17:10 <mhroncok> the change says you need to conditionalization python2 if you are about to rip it off (but dependent packages exist)
16:17:21 <tibbs> I took that from step two of "Removing Python 2 parts".
16:17:38 <mhroncok> tibbs: and that's right, except "in all specs"
16:17:49 <mhroncok> it "in specs of packages where this happens"
16:18:11 <decathorpe> IIUC, this means python2 needs to be behind conditionals, so it can be ripped out more easily when it comes to that?
16:18:18 <tibbs> Then I'm unclear on the specs where python2 is to be supported but this wouldn't happen.
16:18:46 <geppetto> mhroncok: ok, that makes more sense … so something that is py2 only doesn't need to change?
16:18:46 <mhroncok> nothing changes there. you can conditionalize, but are not required to do that
16:18:50 <tibbs> I thought the idea was to force either removal or conditionalization.
16:19:30 <mhroncok> nope. the idea is to give maintainers the ability to remove in a documented way where others cans ee what's being removed if they want to adapt it
16:19:51 <tibbs> Oh, OK, then I had completely the wrong impression.
16:20:00 <decathorpe> ah. that makes more sense
16:20:08 <mhroncok> geppetto: somethign that's py2 only will get questions from us, but doesn't need to add any conditionals
16:20:17 * geppetto nods
16:21:33 <mhroncok> packaging guidelines that require conditionalization of python2 would be kinda weird, because it would be only applicable retroactively, since new py2 packages are forbidden
16:21:45 <tibbs> So then change my #1 to "Modify guidelines to prescribe the method for conditionalizing python2 support."
16:21:52 <mhroncok> OTOH it is not sucha  bad idea, once we decide to pull the plug
16:22:18 <decathorpe> so that's for packagers who maintain different branches of fedora / epel with one spec?
16:22:28 <mhroncok> nope
16:22:44 <decathorpe> then I don't understand what it's for 😂
16:22:47 <tibbs> And sure, while are changes aren't _usually_ retroactive, that doesn't mean we can't make a change and then start asking people to follow it.
16:22:57 <mhroncok> in the change proposal... (and I don't know if it so badly written or just too long)...
16:23:11 <mhroncok> we just say: if you maintain py-foo and you want to get rid of py2-foo, here's how
16:23:29 <mhroncok> (assuming that py2-foo is still required - otherwise you have to get rid of it)
16:23:49 <decathorpe> ah, so for moving it to a separate source package
16:24:00 <mhroncok> and one of the requirement is: first, you conditionalize py2, so inetrested other maintainers can clearly see what do you want to remove
16:24:31 <tibbs> Then why bother with conditionalizing the python2 support.  Just coordinate with someone who wants to do the python2 package.  You delete the stuff from your package and they add theirs.
16:25:09 <tibbs> As long as there aren't any circular dependencies, things shouldn't explode though maybe rawhide has broken deps for a little while.
16:25:10 <mhroncok> tibbs: 1. the problem is when there is noone who wants to do the python2 package
16:25:27 <tibbs> Well we can't force anyone.
16:25:40 <mhroncok> the idea here was: the packjager draws a line in the package and says: I'm orphanning this half
16:26:05 <tibbs> I guess I understand the point but don't see how that's really useful.
16:26:13 <mhroncok> and if nobody takes it, it's "retired" (the conditional is flipped and/or the bits are deleted)
16:26:26 * geppetto nods
16:26:35 <tibbs> And I guess you could accomplish the same thing just by sending an email.
16:26:41 <mhroncok> to who?
16:26:57 <tibbs> The devel list.
16:26:58 <mhroncok> (and you send e-mail in the process as well)
16:27:00 <decathorpe> and how would you keep track of orphaned python2-foo subpackages?
16:27:01 <mhroncok> you do
16:27:21 <mhroncok> decathorpe: you don't. you just spam the depndents for a while and then you stop caring
16:27:27 <tibbs> My point is that should be enough.  If we need more then someone can keep a list and post it occasionally.
16:27:38 <geppetto> mhroncok: the best process ;)
16:27:46 <tibbs> "These python2 packages will be removed in X weeks unless someone offers to maintain them."
16:27:51 <mhroncok> yep
16:27:53 <mhroncok> basically
16:28:10 <tibbs> So... why are any changes to the spec required for any of this?
16:28:12 <mhroncok> disclaimer: i also find the conditional parts reduntant
16:28:14 <geppetto> Ok, is there any other bits we feel like we should vote on here or move on to the next ticket?
16:28:22 <tibbs> Seems to me that if you want to keep it simple, just... keep it simple.
16:28:54 <mhroncok> I'Ve decided to stop bikeshedding about this part with the rest of the change owners and just keep it there
16:29:37 * decathorpe shrugs
16:29:41 <limburgher> Oh hi, I was busy and spaced on time.
16:29:42 <mhroncok> so unless you consider this really bad, I suggest the same. but if we want to change the procces by removing that part, I'd support it
16:29:54 <geppetto> #chair limburgher
16:29:54 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok redi tibbs
16:30:13 <decathorpe> if they want to make it more complicated than it needs to be? I don't particularly care about that
16:30:45 <tibbs> I think it's pointless but if we do want to standardize on how the conditionalization would be done ("%if %{with python2}") then we should vote on adding that to the guidelines.
16:30:57 <mhroncok> pviktori: the conditionalization of python2 bits in the specfile seems to be considered as more complicated than it needs to be. are you still around?
16:31:01 <tibbs> Just so that nobody starts making up their own thing.
16:31:19 <tibbs> And that should just be a couple of sentences in the existing python2 page.
16:31:30 <decathorpe> tibbs: I agree, if we do it, it should be the same everywhere
16:31:45 <mhroncok> tibbs: I can agree to that
16:33:11 <decathorpe> it'd just be a short and short-lived addition to the python packaging guidelines
16:35:27 <geppetto> Ok, is there any bits we feel like we should vote on here or move on to the next ticket?
16:35:39 <mhroncok> proposal: conditionalization of python2 (if used) SHOULD be done with %if %{with python2}
16:35:46 <geppetto> +1
16:35:54 <redi> ok +1
16:35:55 <tibbs> +1; I'll trust you to patch that in appropriately.
16:36:33 <mhroncok> +1 FTR
16:37:58 <limburgher> +1
16:38:48 <geppetto> decathorpe: vote?
16:38:59 <decathorpe> +1
16:39:06 <geppetto> #action conditionalization of python2 (if used) SHOULD be done with %if %{with python2} (+1:6, 0:0, -1:0)
16:39:08 <decathorpe> sorry 🙊 distracted
16:39:11 <geppetto> no problem
16:39:57 <mhroncok> as for the mass removal change. anything you feel strongly opposed to?
16:40:17 <geppetto> I kind of put #3 and #4 together
16:40:41 <geppetto> like if py2 packages don't work it should be easy for someone pick them up, but if nobody does then they get removed quickly.
16:40:57 <mhroncok> that the idea
16:41:13 * geppetto nods … +1 on both then :)
16:42:04 <limburgher> Yeah. No sense dragging this out.
16:42:33 * decathorpe nods as well
16:43:22 <geppetto> We want to vote on it … or just assume it's fine?
16:43:42 <redi> i THINK IT'S FINE
16:43:44 <redi> oops
16:43:51 <limburgher> Ow, my ears.
16:43:53 <geppetto> 👍
16:43:54 <limburgher> lol
16:43:57 <redi> VERY FINE
16:43:58 <redi> :)
16:44:11 <mhroncok> https://giphy.com/gifs/form-z9AUvhAEiXOqA
16:44:12 <limburgher> Fine by me.
16:44:21 <redi> lol yeah
16:44:30 <geppetto> redi: FYI it's really easy to remap caps lock to something useful in Fedora.
16:44:49 <redi> caps lock is useful. for shouting ;)
16:44:50 <mhroncok> ARE YOU SAYING CAPSLOCK IS NOT USEFUL?
16:45:00 <decathorpe> :D
16:45:21 <decathorpe> I'll probably drop off the grid in a few seconds, will be back in 5 minutes
16:45:35 <mhroncok> should I try to remove the conditionalize everyhting first part of the process?
16:47:19 <tibbs> I think the only thing it does is hurt your compliance ratio.
16:47:40 <tibbs> Many users would send an email but if they have to mess with the spec and follow guidelines....
16:47:46 <tibbs> But that's not really FPC business.
16:48:13 <mhroncok> makes sense
16:48:28 <mhroncok> ok, enough of this :D
16:49:34 * decathorpe is back
16:49:59 <geppetto> ok
16:50:07 <geppetto> #topic #878 Package Naming Guildelines for lua packages
16:50:11 <geppetto> .fpc 878
16:50:12 <zodbot> geppetto: Issue #878: Package Naming Guildelines for lua packages - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/878
16:50:32 <tibbs> The only comment I had was in the ticket.
16:50:40 <decathorpe> I agree with tibbs
16:51:03 <decathorpe> lua5.2-foo makes the most sense, considering the rest of the guidelines
16:51:28 <geppetto> Yeh, I'm fine with it … +1
16:51:31 <tibbs> I can only guess that they would want the "compat-" prefix to avoid having to set up a whole new set of packages when they want to roll the versions over.
16:51:50 <mhroncok> I assume they just seen compat-foo and foo-compact
16:51:51 <tibbs> But I think that's actually a feature, and allows them to have three or more supported versions if they really want.
16:51:57 <mhroncok> and they tried to make it less confusing
16:52:02 <mhroncok> and we say: change it entirely
16:52:04 <limburgher> +1 also. Interesting that I *just* processed some lua SCM requests. . .
16:52:05 <mhroncok> and they will not
16:52:40 <decathorpe> well, we can't force anything
16:52:45 <tibbs> Note that there's also a lua module called "compat" which might be confusing if you see it.
16:52:52 <mhroncok> :)
16:52:58 <tibbs> So under their scheme you would have compat-lua-compat which....
16:53:06 <geppetto> :)
16:53:21 * limburgher puts vodka in her tea
16:53:45 <decathorpe> limburgher: good idea ...
16:54:26 <geppetto> tibbs: So I assume you are +1 … that gives us +3 atm.
16:54:34 <redi> +1
16:54:40 <tibbs> I'm +1 to the suggestion I made, yes.
16:54:50 * geppetto nods
16:54:56 <tibbs> Not +1 to the scheme that was originally proposed.
16:55:09 <tibbs> And boo to Arch for implying that lua version 51 exists.
16:55:23 <decathorpe> I'm +1 too, FTR
16:55:35 <geppetto> Ok, that's 5
16:55:36 <redi> Arch has a history of doing weird thigns with version numbers
16:55:42 <redi> I made them stop doing it for gcc
16:55:48 <geppetto> Both the the arch users can complain
16:55:52 <limburgher> s/with version numbers//g
16:55:57 <decathorpe> redi++
16:55:58 <zodbot> decathorpe: Karma for jwakely changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:55:58 <mhroncok> https://src.fedoraproject.org/rpms/python-u-msgpack-python
16:56:03 <mhroncok> https://src.fedoraproject.org/rpms/python-into-dbus-python
16:56:04 <mhroncok> :D
16:56:18 <limburgher> OFFS
16:56:22 <geppetto> lol
16:56:31 <geppetto> 💩
16:56:41 <redi> good grief
16:56:45 <mhroncok> +1 for the lua thing
16:56:54 <geppetto> #action Pkg Naming guildelines (for lua), with tibbs change (+1:6, 0:0, -1:0)
16:57:05 <geppetto> #topic Open floor
16:57:06 <limburgher> I have a hard stop in 3 min.
16:57:26 <geppetto> That's fine … I think we are done for the week anyway
16:57:35 <limburgher> So it seems. :)
16:58:10 <mhroncok> https://src.fedoraproject.org/rpms/perl-rpm-build-perl
16:58:22 <limburgher> <facepalm>
16:58:34 <decathorpe> mhroncok: stop making me sad
16:59:36 <geppetto> Ok, see you next week
16:59:39 <geppetto> #endmeeting