fesco
MINUTES

#fedora-meeting-1: FESCO (2019-03-25)

Meeting started by zbyszek at 15:00:10 UTC (full logs).

Meeting summary

  1. init process (zbyszek, 15:00:13)
  2. #2105 F31 Change: Mono 5 (zbyszek, 15:01:36)
    1. https://pagure.io/fesco/issue/2105 (zbyszek, 15:01:37)
    2. https://koji.fedoraproject.org/koji/packageinfo?packageID=30 shows no 5.0 builds even in rawhide... (zbyszek, 15:05:10)
    3. https://pagure.io/fesco/issue/2105#comment-561929 (bowlofeggs, 15:08:46)
    4. AGREED: The Change is approved for F31. It is also approved for F30, as long as the builds can be done and submitted as an update no later than March 31. If this isn't possible, F30 should keep the previous version. (+7, 0, 0) (zbyszek, 15:15:33)

  3. #2104 Delay retiring of java-packages moved to module until a solution for the (Build)Requires has been found (zbyszek, 15:15:44)
    1. https://pagure.io/fesco/issue/2104 (zbyszek, 15:15:50)
    2. https://pagure.io/fesco/issue/2104#comment-560255 (mhroncok, 15:24:08)
    3. AGREED: FESCo asks the Stewardship SIG and other maintainers to take as many packages as possible. Packages which haven't found new owners will be retired according to schedule, but not earlier than April 1st. (+7, 0, 0) (zbyszek, 15:42:51)

  4. #2102 F31 System-Wide Change: Gating Rawhide — Single package updates (zbyszek, 15:43:03)
    1. https://pagure.io/fesco/issue/2102 (zbyszek, 15:43:09)
    2. ACTION: bookwar to write an e-mail to the Stewardship SIG and other maintainers (zbyszek, 15:45:35)

  5. #2027 RFC: Module lifecycles (zbyszek, 15:47:15)
    1. https://pagure.io/fesco/issue/2027 (zbyszek, 15:47:15)

  6. #2109 Policy revamp: Package Removal for Long-standing FTBFS and FTI bugs (zbyszek, 15:50:24)
    1. https://pagure.io/fesco/issue/2109 (zbyszek, 15:50:30)
    2. ACTION: mhroncok to update the proposal (zbyszek, 16:00:13)

  7. #2110 F31 System-Wide Change: Enable Compiler Security hardening flags by default in GCC (zbyszek, 16:00:15)
    1. https://pagure.io/fesco/issue/2110 (zbyszek, 16:00:24)
    2. AGREED: : proposal is rejected (0, 0, -7) (zbyszek, 16:02:27)

  8. #2108 Change release blocking deliverables process (zbyszek, 16:03:10)
    1. https://pagure.io/fesco/issue/2108 (zbyszek, 16:03:10)
    2. AGREED: Proposed change to the process is approved (+6, 0, 0) (zbyszek, 16:06:10)

  9. Next week's chair (zbyszek, 16:06:21)
    1. ACTION: NAME will chair next meeting (zbyszek, 16:06:21)
    2. ACTION: sgallagh to chair next meeting (zbyszek, 16:08:35)

  10. #2027 RFC: Module lifecycles (zbyszek, 16:09:28)
    1. https://pagure.io/fesco/issue/2027 (zbyszek, 16:09:28)
    2. AGREED: The proposal is approved with the additional requirement that the maintainer can update the information at any time, automatically, without releng or any other human involvement, assuming the update is valid based on policy (+6, 0, 0) (zbyszek, 16:21:18)

  11. Open floor (zbyszek, 16:21:44)
    1. AGREED: Two-phase approach for #2048 is approved (+5, 0, 0) (zbyszek, 16:30:25)


Meeting ended at 17:05:59 UTC (full logs).

Action items

  1. bookwar to write an e-mail to the Stewardship SIG and other maintainers
  2. mhroncok to update the proposal
  3. NAME will chair next meeting
  4. sgallagh to chair next meeting


Action items, by person

  1. bookwar
    1. bookwar to write an e-mail to the Stewardship SIG and other maintainers
  2. mhroncok
    1. mhroncok to update the proposal
  3. sgallagh
    1. sgallagh to chair next meeting


People present (lines said)

  1. mhroncok (130)
  2. zbyszek (117)
  3. bowlofeggs (86)
  4. jforbes (54)
  5. nirik (46)
  6. bookwar (31)
  7. contyk (23)
  8. zodbot (22)
  9. asamalik (16)
  10. cverna (15)
  11. otaylor (11)
  12. bcotton (4)
  13. sgallagh (0)


Generated by MeetBot 0.1.4.