council
LOGS
15:00:30 <bcotton> #startmeeting Council (2018-11-28)
15:00:30 <zodbot> Meeting started Wed Nov 28 15:00:30 2018 UTC.
15:00:30 <zodbot> This meeting is logged and archived in a public location.
15:00:30 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:30 <zodbot> The meeting name has been set to 'council_(2018-11-28)'
15:00:31 <bcotton> #meetingname council
15:00:31 <zodbot> The meeting name has been set to 'council'
15:00:41 <bcotton> #chair jonatoni bex contyx dgilmore dperpeet langdon mattdm sumantrom tyll bcotton pbrobinson stickster
15:00:41 <zodbot> Current chairs: bcotton bex contyx dgilmore dperpeet jonatoni langdon mattdm pbrobinson stickster sumantrom tyll
15:00:43 <bcotton> #topic Introductions, Welcomes
15:00:45 <bexelbie> .hello bex
15:00:46 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bexelbie@redhat.com>
15:01:11 <bcotton> whoops, i can't spell contyk
15:01:13 <bcotton> #chair contyk
15:01:13 <zodbot> Current chairs: bcotton bex contyk contyx dgilmore dperpeet jonatoni langdon mattdm pbrobinson stickster sumantrom tyll
15:01:20 <dgilmore> hola
15:01:24 <mattdm> hello!
15:01:25 <contyk> it's difficult
15:01:41 <contyk> .hello psabata
15:01:42 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:01:55 <bcotton> being difficult is my job
15:02:16 <langdon> .hello2
15:02:17 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
15:03:35 <stickster> .hello pfrields
15:03:36 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
15:03:45 <bcotton> we'll give pbrobinson a minute to wander down the hall from the IoT meeting and see if anyone else joins in
15:04:03 * pbrobinson is here now
15:05:05 <bcotton> okay great. short agenda today since a lof of tickets we decided would be addressed in next week's hackfest (or at least we used that as a convenient excuse to put them off)
15:05:13 <bcotton> #topic Today's agenda
15:05:14 <bcotton> 1. Clarify trademark guidelines on modified hosted Fedora images
15:05:16 <bcotton> 2. Telegram as communication channel
15:05:19 <bcotton> 3. Council Hackfest
15:05:21 <bcotton> 4. Other open tickets
15:05:27 <bcotton> #topic Clarify trademark guidelines on modified hosted Fedora images
15:05:28 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/198
15:05:34 <bcotton> #info We are making a full consensus vote on the draft as written
15:05:36 <bcotton> #link https://docs.google.com/document/d/1tfYKaG6ANeEvMYfitA8uRo8Kk9OnC08gcgWE4xbxSyo/edit
15:05:47 <bcotton> bexelbie asked in the ticket to resolve the open comments
15:06:02 <bcotton> but it's been a while. should we just vote on it as it stands?
15:06:24 <bexelbie> I'd like to know that if I vote for this, that comments won't change thigns and edits won't get reverted
15:06:47 * mattdm is reading again
15:07:13 <stickster> mattdm: bexelbie: Has IP counsel looked at this doc?
15:07:33 <bexelbie> I have not requested a legal review of this document
15:07:54 <bexelbie> I also don't think that should block us approving it and then only revisiting if legal raises issues
15:08:01 <mattdm> stickster: no. legal requested we come up with what we want *first*
15:08:05 <bcotton> yeah, i think that's a downstream step of the council deciding what it is we want it to look like
15:08:10 <bcotton> (what he said)
15:08:16 <mattdm> brb dog going crazy for some reason
15:08:17 <stickster> Having spent a major portion of time over several years working on trademark guidelines, I'm surprised at the use of a separate document, vs. updating the trademark guidelines with an appropriate exception.
15:08:37 <stickster> I agree Council should be coming out with what we want first
15:09:03 <dgilmore> stickster: this is just a working place
15:09:06 <contyk> slowly reading the ticket; probably won't be able to comment today
15:09:08 <stickster> ah OK
15:09:09 <mattdm> (ghosts.)
15:09:27 <stickster> I would expect counsel will want to see this subsumed as redline on the guidelines
15:09:29 <dgilmore> stickster: it is intended to be added to the trademark guidelines
15:09:40 * stickster nods and shuts up
15:10:53 <jonatoni> .hello2
15:10:54 <zodbot> jonatoni: jonatoni 'Jona Azizaj' <jonaazizaj@gmail.com>
15:11:07 <bcotton> hi jonatoni!
15:11:13 <dgilmore> stickster: your views on the content are greatly appreciated
15:11:23 <jonatoni> hi bcotton :)
15:11:29 <dgilmore> hi jonatoni
15:11:57 <mattdm> welcome jonatoni!
15:12:23 <mattdm> So, yeah, I think this needs another round of going through comments and making a final document
15:12:32 <dgilmore> mattdm: okay
15:12:49 * jonatoni says hi to dgilmore and mattdm :)
15:13:31 <bcotton> mattdm: agenda item for next week or do we want to wrap it up this week?
15:13:48 <mattdm> bcotton: just thinking about that. let's try to wrap it up *before* next week and send it to legal.
15:14:35 <bcotton> proposed #agreed We will defer the vote for one final round of comments. Comments are due by 30 November, at which time we'll open the proposal for a full consensus vote
15:15:13 <dgilmore> ack
15:15:43 <contyk> ack
15:15:55 <bexelbie> +1
15:16:37 <bcotton> wfm
15:16:41 <bcotton> #agreed We will defer the vote for one final round of comments. Comments are due by 30 November, at which time we'll open the proposal for a full consensus vote
15:16:42 <mattdm> ack
15:16:55 <bcotton> #topic Telegram as communication channel
15:16:57 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/232
15:17:13 <bcotton> x3mboy_: was going to try to stick around, but i think he had to go
15:17:51 <bexelbie> He is unable to use irc at work which is a show stopper for him and others
15:18:12 <bcotton> we talked about it in the FPgM office hours a bit and i think i've come to the position that i want to be convinced why Telegram needs to be an Official™channel and not just left unofficial
15:18:37 <contyk> I feel the same
15:18:39 <dgilmore> I think that we should make telegram an official mechanisim for fedora communications, people are there for various reasons
15:18:45 <mattdm> you want to be convinced or you would need to be convinced?
15:19:07 <bcotton> a little bit of both
15:19:27 <mattdm> But, also, isn't it *already* official in the same sense that the fedora twitter and facebook accounts are official?
15:19:29 <mattdm> https://fedoraproject.org/wiki/Marketing_social_networks
15:19:31 <contyk> making it Official feels like it's a place everyone should watch and participate in the discussions there
15:19:40 <mattdm> I guess  @fedoranews is
15:19:53 <mattdm> I don't want to do that.
15:19:54 <bexelbie> mattdm I think that it isn't official like that at all
15:20:01 <bcotton> yeah, that's my thing. communication methods only ever increase, they don't decrease
15:20:04 <dgilmore> bcotton: users are there,
15:20:26 <bexelbie> users are there, yes - but I think bridges are a good solution until we are ready to really ask people to be present in Telegram
15:20:51 <bexelbie> and bridges don't require being official
15:21:01 <mattdm> i think they should be listed at on the page above like the various community fb pages and google+ accounts and etc.
15:21:07 <langdon> because you are assuming they bridge to somewhere official?
15:21:27 <bexelbie> langdon, yes, otherwise the bridge is not something I am worried about :)
15:21:35 <bexelbie> mattdm, I think that is a good idea
15:21:38 <stickster> I'm not convinced "can't use IRC at work" is a great argument here
15:21:51 <contyk> I don't think that's the argument
15:21:57 <contyk> that's just x3mboy_
15:21:59 <stickster> Soryr, I'm catching up from above
15:22:11 <stickster> Oh, I see, that's just a spurious attendance issue
15:22:14 <stickster> *sigh
15:22:46 <bcotton> my other concern here is that this is one element of a larger picture. it's the same thing as mailing lists vs discourse, etc
15:22:49 * mattdm notes that that page *is* a wiki. we should probably move it to docs :)
15:23:01 * contyk has yet to start using discourse
15:23:03 <bexelbie> +1 for mattdm moving this page to docs
15:23:16 <bcotton> #action mattdm to move the wiki pages to docs ;-)
15:23:25 <mattdm> bexelbie: lol
15:23:25 <bexelbie> bcotton, I agree - I think we need to think through our comm strategy at least in pricipal as this would be a second piece-meal discussion
15:23:27 * stickster chuckles, because he thought Telegram was an official channel
15:23:40 * mattdm puts it on the list
15:23:50 <mattdm> stickster: there is *one* official telegram channel
15:23:54 <bexelbie> We definitely need to get the social media guidelines made clearer to those groups - it just hasn't risen to the top of hte heap
15:23:56 <mattdm> but in practice there are dozens in use.
15:24:09 <bexelbie> I wasn't aware we had any official channels at all
15:24:12 * stickster doesn't use it regularly.
15:24:12 <bexelbie> on Telegram
15:24:19 <bexelbie> the @fedora one isn't, afaik
15:24:29 <contyk> neither was I; which one is it?
15:25:05 <dgilmore> afaik none of them are official
15:25:34 <bexelbie> While I wouldn't mind seeing @fedora bridged to #fedora - I think those particular audiences are so different they aren't going to necessarily merge well
15:25:49 <bexelbie> but, for example, having the meeting channels bridged out would be awesome
15:25:50 * mattdm looks at the link I posted earlier
15:25:57 <mattdm> Telegram @fedoranews telegram.me/fedoranews Justin W. Flory, Jiří Eischmann, Ryan Lerch, Brian Exelbierd
15:26:04 <bexelbie> ditto with gsoc, etc.
15:26:11 <langdon> and there are only 1,883 members in @fedora right now :)
15:26:32 <dgilmore> mattdm: that does look official
15:26:36 <contyk> langdon: how many of them are bridges and bots? :)
15:26:43 <langdon> bexelbie: +100 on bridged meetings to telegram... would make my mobile participation in meetings *much* easier
15:26:47 <bexelbie> looks like a repeater, but sure, it is more like twitter/marketing so you're right
15:26:55 <langdon> contyk: ha
15:27:08 <mattdm> The telegram bridge SUCKS from a UI experience for people on IRC
15:27:19 <bcotton> cosign what mattdm said
15:27:21 <bexelbie> from personal experience, I know that a few subprojects run into problems finding anyone in their group actually on irc to drive zodbot
15:27:27 <bexelbie> so bridging does work for participation in some areas
15:27:29 <langdon> mattdm: true
15:27:42 <bexelbie> yes, it does suck from a UI on the IRC side
15:28:00 <langdon> even irc->telegram is not awesome
15:28:10 <contyk> no bridging is awesome
15:28:14 * langdon should really finish investigating matrix
15:28:26 <langdon> is asamalik around?
15:28:27 <contyk> langdon: use bitlbee
15:28:38 * asamalik is
15:28:39 <langdon> contyk: for telegram+irc?
15:28:40 <bexelbie> langdon, I don't think that matrix solves it as we need to be where the people are - they are on telegram
15:28:43 <asamalik> but in a meeting
15:28:55 <langdon> matrix is supposed to be a bridge across them all .. no?
15:29:06 <langdon> or is it just single client multi server?
15:29:11 <contyk> langdon: it's a multi-client with an irc interface; so you just need irc :)
15:29:12 <bexelbie> I feel like the core of this question is "Do we want to have either two places people should be or to change the one we have"
15:29:47 <asamalik> langdon: why?
15:30:03 <contyk> bexelbie: I do hope it's not the latter
15:30:24 <bexelbie> contyk, there is an unstated (doh!) third of "change nothing"
15:30:44 * mattdm afk for a minute brb
15:31:01 <bexelbie> I mean, if we aren't willing to change unless X, Y, and Z are met then we need to define those and then test for that on proposals like this
15:31:04 <langdon> asamalik: you have been using matrix.. wondering if the bridging of telegram & irc is better through that.. but I think i was thinking matrix was more of a bridge rather than a single client for multiple server types
15:31:26 <bcotton> bexelbie: agreed. my inclination is to have one official chat platform, whatever it is. anything more than 1 and we end up with scattered communication
15:31:33 <bexelbie> I think we are getting distracted in the tech and not hte question
15:31:43 <asamalik> langdon: I only used it for IRC, although I had a few problems with messages disappearing... but it's a long ago
15:32:01 <contyk> bcotton: +1, but the communication is scattered anyway, official or not
15:32:02 <asamalik> langdon: I now pay for irccloud for IRC
15:32:26 <langdon> hmmm
15:32:32 <bexelbie> even if we can find FOO which does some magic, it is still not where hte users/new contributors are (necessarily) and it is just perpetuates the "we use this thing that you don't so you should change you or go play elsewhere"
15:32:34 <bcotton> contyk: we'll never be able to avoid that. but if we at least keep the official comms in one place, that's something
15:33:03 <contyk> yeah
15:33:13 <bexelbie> bridges at least builds on the idea of "show up with your client" .. except this one isn't great on the IRC side
15:33:33 <langdon> well.. if could recommend a client that would let them connect to their "favorite" plus "fedora's favorite" in a single interface.. it might do a lot for solving that problem..
15:33:50 <langdon> "yes you have to switch clients, but the platform you use for your friends is also supported"
15:33:51 <bexelbie> I think that;s mostly the edit message, reply and gif capabilities -- which are actually quite nice given that it is almost 2020
15:34:23 <bexelbie> oh and presence  and mobile phones and ... :D
15:34:52 <bexelbie> so yeah, do we stay on IRC and encourage participation there but make it more prominent these channels exist and encourage bridging where appropriate?
15:35:17 <contyk> that sounds reasonable
15:36:19 <contyk> how do we decide what should be bridged and where?
15:36:24 <langdon> i am not sure where this whole "open source" idea came from.. all this freedom is ... difficult ;)
15:36:29 <contyk> what Telegram/whatnot channel to what IRC channel and such
15:36:46 <bexelbie> contyk, I think we should let the telegram communities decide
15:36:54 <bexelbie> and we should only block the bots that cause problems on the Fedora IRC side
15:37:03 <bcotton> langdon++
15:37:03 <zodbot> bcotton: Karma for langdon changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:37:08 <bexelbie> if there isn't interest in having somethign bridged, we shouldn't force bridge it
15:37:21 <langdon> sidebar: i was reading an article about a new tool to help you choose amongst all the different distros... and, seriously, the article lists ****** 2 ***** tools for helping you choose with no recommendation between them!!!
15:37:22 <bexelbie> I think it is reasonable for us to ask infra to run some of hte bots on an approved basis as a service
15:37:25 <bexelbie> but not as an endorsement
15:37:40 * contyk nods
15:38:02 <bexelbie> I also think we should watch .. as this may indicate where our community is going
15:38:16 <bexelbie> I've been watching a large organization that just adopted a new, second, internal communication tool
15:38:21 * mattdm is back -- sorry
15:38:25 <bexelbie> it is fascinating how much is going on in the new tool
15:38:34 <bexelbie> without killing the old one
15:38:39 <bexelbie> but it has caused attention disorder
15:38:42 <bexelbie> so lets avoid that
15:38:51 <contyk> ;)
15:39:06 <mattdm> langdon: I'm writing a tool to help you decide between linux distro choosers
15:39:09 <langdon> omg.. i can't remember the current name of gaim.. i am super old..
15:39:16 <contyk> pidgin
15:39:18 <langdon> mattdm++
15:39:18 <zodbot> langdon: Karma for mattdm changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:39:18 <bcotton> langdon: pidgin
15:39:25 <langdon> bcotton: ahh right thanks
15:39:38 <bexelbie> mattdm: `echo "Choose Fedora"` -- fixed that for you
15:39:49 <langdon> ha
15:39:57 <mattdm> bexelbie++
15:40:22 * x3mboy dropped the connection just in the conversation he wants to look at
15:40:32 <bcotton> so it seems like we have a lot more discussing to do about the bigger picture before we settle on any implementation details (which is what this ticket is)
15:40:54 <bexelbie> perhaps this is a good council hack agenda item
15:41:00 <bexelbie> <segue> :P
15:41:25 <bcotton> agreed
15:41:52 <bcotton> let's table this for now and keep thinking about it
15:42:01 <bcotton> #topic Council Hackfest
15:42:02 <bcotton> #info Council is meeting next week
15:42:22 <bcotton> hopefully by now everyone who is attending has their logistics arranged
15:42:31 <bcotton> it will be very cold in MSP next week
15:42:46 <bcotton> any last-minute questions or updates from bexelbie?
15:43:09 <langdon> bexelbie: do we have hotel done?
15:43:10 <contyk> will the rooms be heated?
15:43:11 <bexelbie> I have no questions
15:43:16 <mattdm> contyk++
15:43:16 <zodbot> mattdm: Karma for psabata changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:43:22 <bexelbie> the rooms will contain an open barrel... you need to bring your own logs
15:43:26 <bexelbie> hotel contract is signed
15:43:29 <langdon> i don't even know where it is.. and i think i should probably figure out how to get thre from the airport
15:43:33 * bexelbie owes BEOs still
15:43:52 * langdon stumbles on acronym expansion
15:43:52 <bexelbie> there is a tram/train thing from the airport to a short walk to the hotel
15:43:57 <bexelbie> use your map of choice
15:44:08 <bexelbie> BEO == Banquet Event Order
15:44:21 <mattdm> banquet event! swanky!
15:44:38 <bexelbie> Where your serving tux mattdm :P you're on lunch duty to help cover the costs
15:44:41 <bexelbie> :P
15:45:59 <contyk> do we have any agenda for the hackfest?
15:46:20 <mattdm> contyk: we will by the time it starts :)
15:46:24 <bcotton> bexelbie: can you send out a quick logistics reminder to everyone before the end of the week? hotel location, etc, etc
15:46:41 <bexelbie> sure
15:46:45 <bcotton> thanks
15:46:45 <mattdm> I have agenda-ish ideas in my head that i need to formalize
15:47:02 <bcotton> #action bexelbie to send a logistics reminder to attendees by the end of this week
15:47:04 <mattdm> but i don't see myself as having time for that before I get on the plane on Sunday morning :)
15:47:22 <contyk> worst case we can spend the whole time discussing Telegram channels
15:47:28 <bexelbie> via irc
15:47:28 <bcotton> contyk++
15:47:28 <zodbot> bcotton: Karma for psabata changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:47:48 <bcotton> mattdm: i'll make sure the wifi on your flight doesn't work so you'll be able to work distraction-free
15:48:22 <mattdm> bcotton: thanks!
15:48:27 <bexelbie> bcotton, he works in an ssh session from his phone to irc where he directs a bot to edit an etherpad
15:48:48 <bexelbie> it's like watching someone talk in `ed`
15:49:00 <contyk> I like ed
15:49:13 <bexelbie> He's a good engineer
15:49:16 <mattdm> :)
15:49:18 <contyk> I wanted to make it the default editor in Fedora Base Runtime
15:49:24 <bcotton> okay, anything else on the hackfest?
15:49:35 <langdon> contyk: you *did* make it that way
15:49:40 <bexelbie> everyone who needs one should have a hotel confirmation
15:49:45 <bexelbie> if you didn't get it let me know ASAP
15:49:49 <contyk> langdon: nah, we didn't include it, we didn't have any
15:49:51 <langdon> bexelbie: ohh really? /me goes to dig
15:49:57 <bexelbie> you don't need it langdon
15:49:59 <bexelbie> you didn't get it
15:50:12 <bcotton> bexelbie: do i need one? because i didn't get one
15:50:15 <bexelbie> I sent them only to those who will cross a border
15:50:20 <bcotton> okay
15:50:22 <bexelbie> you don't need one bcotton you didn't get one
15:50:30 <bexelbie> use your inter-us passport you'll be fine :P
15:50:44 <langdon> umm.... i will be x-ing in to flyover states
15:50:56 <bexelbie> langdon, that border is still open
15:51:02 <bcotton> oooookay
15:51:06 <bexelbie> and apparently they ahve ground there
15:51:10 <bexelbie> #WhoKnew
15:51:16 <bcotton> #topic Other open tickets
15:51:17 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issues
15:51:22 <bexelbie> brb
15:51:43 <bcotton> anything else that we didn't cover that we really need to cover in the last 8 minutes?
15:52:00 <contyk> not a ticket but I have something; I should open a ticket
15:52:43 <mattdm> contyk: ticket++
15:52:44 <bcotton> you should!
15:52:49 <contyk> the fedocal invites are misleading
15:53:21 <contyk> the text says something different from the metadata; the jitsi meeting says it's on this channel and doesn't say where on jitsi it is
15:53:24 <contyk> things like that
15:53:24 <bcotton> contyk: assign that ticket to me when you open it. i'll update them
15:53:36 <contyk> will do
15:53:52 <bcotton> they've been edited several times over the ...however long they've existed, so i'm not surprised there's divergence
15:54:22 <bcotton> last call!
15:55:00 <bcotton> okay, thanks everyone! see most of you next week
15:55:11 <contyk> thanks all
15:55:24 <bexelbie> ty all
15:55:28 <mattdm> thanks everyone!
15:55:34 <mattdm> thanks bcotton for chairing!
15:55:56 <bexelbie> bcotton++
15:55:56 <zodbot> bexelbie: Karma for bcotton changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:56:02 <bcotton> #endmeeting