fesco
LOGS
15:01:10 <jforbes> #startmeeting FESCO (2018-10-29)
15:01:10 <zodbot> Meeting started Mon Oct 29 15:01:10 2018 UTC.
15:01:10 <zodbot> This meeting is logged and archived in a public location.
15:01:10 <zodbot> The chair is jforbes. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:10 <zodbot> The meeting name has been set to 'fesco_(2018-10-29)'
15:01:10 <jforbes> #meetingname fesco
15:01:10 <jforbes> #chair nirik, maxamillion, jsmith, jforbes, zbyszek, tyll, sgallagh, contyk, bowlofeggs
15:01:10 <jforbes> #topic init process
15:01:11 <zodbot> The meeting name has been set to 'fesco'
15:01:11 <zodbot> Current chairs: bowlofeggs contyk jforbes jsmith maxamillion nirik sgallagh tyll zbyszek
15:01:18 <nirik> morning
15:01:19 <maxamillion> .hello2
15:01:20 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:01:32 <maxamillion> I'm in two meetings but will do my best
15:04:23 <sgallagh> .hello2
15:04:24 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:04:28 <bowlofeggs> .hello2
15:04:29 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <rbarlow@redhat.com>
15:05:10 <jforbes> Well, that at least gives us quorum
15:05:21 <bowlofeggs> i'm only in this meeting but will do my worst
15:05:52 <jforbes> #topic #2003 Ursa Major (modules in buildroot) enablement
15:05:52 <jforbes> .fesco 2003
15:05:52 <jforbes> https://pagure.io/fesco/issue/2003
15:05:54 <zodbot> jforbes: Issue #2003: Ursa Major (modules in buildroot) enablement - fesco - Pagure.io - https://pagure.io/fesco/issue/2003
15:07:52 * nirik wonders if this needs more discussion on list or something...
15:07:56 <jforbes> Do we have any more detail on the buildroot repo? I don't see anything in the releng ticket new either.
15:08:07 <nirik> or a prototype of the repo...
15:08:19 <bowlofeggs> nirik: so the concern is that it will be hard to build locally?
15:08:27 <nirik> yeah.
15:08:42 <bowlofeggs> i do regularly build my packages locally before trying it in koji
15:08:47 <bowlofeggs> so that would be unfun for me
15:09:20 <bowlofeggs> adn this would not just affect module packages right?
15:09:28 <bowlofeggs> because the point is that RPMs will be able to depend on modules now?
15:09:41 <nirik> it would affect anything that built against modular content I think.
15:10:42 <nirik> I think it's important to do this, but we should try and minimize the problem as best we can for local rebuilding.
15:10:53 <maxamillion> same, I always build locally in mock before attempting in koji
15:11:04 <bowlofeggs> i actually don't even use mock
15:11:09 <jforbes> Yes, local building is important
15:11:09 <bowlofeggs> i just use rpmbuild directly
15:11:16 <maxamillion> wait, so things built against modular content can't be built locally?
15:11:19 * jsmith is finally here
15:11:41 <jsmith> (in a data center with spotty wifi, but I'm here)
15:12:24 <nirik> maxamillion: if there are modules enabled in the buildroot, rpm has no way to reflect that in src.rpms
15:13:05 <sgallagh> maxamillion: They can be built locally, assuming you have that module enabled in your local installation
15:13:15 <maxamillion> ah
15:13:17 <nirik> so if you build against say openjdk-21 and thats in a module, we could build it by adding that module to our koji buildroot, but a local user would have to try and figure out where to get that
15:13:19 <maxamillion> alright
15:13:26 <sgallagh> This is about making that content available in the buildroot for mock/koji
15:13:39 <jforbes> So, what I am gathering here is we do not have enough data to really do anything. Perhaps a list discussion would be more helpful?
15:13:40 <nirik> also mock would have no way to know to enable that
15:14:53 <nirik> jforbes: +1
15:15:29 <jforbes> So proposal: Send email to devel list for further discussion and review in 1 week
15:15:36 <bowlofeggs> yeah list discussion seems good
15:15:36 <nirik> +1
15:15:44 <sgallagh> +1
15:15:48 <bowlofeggs> i think we do need a way to build locally, but i don't know what that would be
15:16:03 <bowlofeggs> otherwise debugging is far more difficult
15:16:45 <nirik> if we can make this buildroot repo work, we could enable it in mock at least...
15:17:00 <sgallagh> bowlofeggs: Build a Koji container and install it with `fedora-packager`? *ducks*
15:17:08 <bowlofeggs> hahaha
15:17:37 <bowlofeggs> nirik: requiring mock would not be my fav, but it would be a reasonable solution if we can't think of anything else
15:17:45 <bowlofeggs> i do really like being able to just run rpmbuild directly
15:18:07 <sgallagh> bowlofeggs: Which remains an option if you have the necessary packages installed locally already.
15:18:08 <jforbes> bowlofeggs: still not required as long as you have the build dep installed
15:18:18 <bowlofeggs> sgallagh: oh i guess that's a good point
15:18:26 <bowlofeggs> not sure why i didn't thin of that
15:18:27 <sgallagh> It's just that we have no easy way right now to help you get the deps automatically
15:18:28 <bowlofeggs> haha
15:18:38 <bowlofeggs> yeah so just dnf builddep won't work
15:18:40 <sgallagh> `dnf builddep *.spec` won't work
15:18:42 <nirik> perhaps dnf builddep could be extended too
15:18:56 <bowlofeggs> if we could make dnf builddep work that would be rad
15:19:08 <jforbes> When the dnf team might have cycles again
15:19:18 <sgallagh> That would be the best case, but we have to find some way to inform it what is needed.
15:19:23 <bowlofeggs> yeah they are already overwhelmed it sounds like
15:20:09 <jforbes> So the proposal has 3 votes, bowlofeggs maxamillion jsmith want to vote?
15:20:47 <maxamillion> dnf builddep won't do the thing it's supposed to do?
15:20:54 <bowlofeggs> jforbes: +1
15:21:06 <sgallagh> maxamillion: It won't *right now*
15:21:12 <maxamillion> ...
15:21:24 <sgallagh> Because it doesn't know it has to look for deps in what are effectively disabled repos
15:21:39 <maxamillion> alright
15:21:42 <maxamillion> +1
15:22:00 <sgallagh> It can only find deps in standard repos or modules streams marked as the default stream'
15:22:41 <nirik> it would be tricky to implement without something like the buildroot repo
15:23:17 <jforbes> #agreed an email will be sent to the devel list for further discussion and we will review it again in 1 week (+5,0,0)
15:23:27 <jforbes> Anyone want to send that email?
15:24:11 <jforbes> I will send it then
15:24:20 <jforbes> #topic #2004 Enabling pm_request in fedoraproject koji
15:24:20 <jforbes> .fesco 2004
15:24:20 <jforbes> https://pagure.io/fesco/issue/2004
15:24:22 <zodbot> jforbes: Issue #2004: Enabling pm_request in fedoraproject koji - fesco - Pagure.io - https://pagure.io/fesco/issue/2004
15:24:35 <jforbes> Similar request, though there has been more discussion on this one
15:24:47 <bowlofeggs> this one sounds maybe scary but i don't know enough about it to have an informed opinion
15:25:25 <bowlofeggs> puiterwijk, nirik: you both know a lot about koji - do you have comments on this issue?
15:25:56 <nirik> my inclination is to say no. but I have been on PTO this last week, so I haven't had time to read the latest comments.
15:26:24 <bowlofeggs> mizdebsk does seem to know a lot about koji based on my past interactions, and he seems to think it's unsafe
15:27:06 <bowlofeggs> the idea of packagers being able to set buildrequires based on the %prep step does sound like a good feature, but this implementation of that feature may be unsafe
15:27:09 <sgallagh> Yeah, I'm leaning towards "no" at this point, reserving the right to revisit it if someone comes up with mitigation plans
15:27:28 <nirik> so perhaps this could also use another week...
15:27:29 <bowlofeggs> perhaps there could be another implementation that doesn't have the security concerns?
15:27:45 <nirik> there's a proposed rpm change, but it's not been merged...
15:28:07 <bowlofeggs> i'm not opposed to the feature itself, i'm just concerned about the noted security issues with this particular implementation
15:28:28 <bowlofeggs> yeah another week could be good
15:28:57 <nim-nim> and https://github.com/rpm-software-management/rpm/issues/104#issuecomment-433248114
15:29:33 <jforbes> So it appears that it might not be needed for Fedora though, epel would still need it. Discussion is at least happening though
15:30:27 <jforbes> Proposal: pm_request discussion is still happening in ticket and should be given another week before we address it.
15:30:35 <bowlofeggs> jforbes: +1
15:31:00 <nirik> +1
15:32:28 <jforbes> sgallagh maxamillion jsmith?
15:32:39 <sgallagh> +1, I suppose
15:32:48 <maxamillion> +1
15:32:56 <maxamillion> sorry, I'm joining a third meeting ... because of course I am
15:33:03 <bowlofeggs> i do want this feature, but i want it to not be risky to the build infra
15:33:24 <bowlofeggs> i would use it (i package a rust thing too)
15:33:36 <jforbes> #agreed pm_request discussion is still happening in ticket and should be given another week before we address it. (+5,0,-0)
15:34:00 <jforbes> #topic #2006 No Xfce and LXQT lIve isos in Fedora 29 RC 1.2
15:34:00 <jforbes> .fesco 2006
15:34:00 <jforbes> https://pagure.io/fesco/issue/2006
15:34:02 <zodbot> jforbes: Issue #2006: No Xfce and LXQT lIve isos in Fedora 29 RC 1.2 - fesco - Pagure.io - https://pagure.io/fesco/issue/2006
15:34:23 <jforbes> Really, this and 2007 could probably be addressed together. Similar issues.
15:34:34 <nirik> I'm sorry about the Xfce one... I usually test those, but I was on PTO and didn't specifically hand that off to anyone. ;(
15:35:10 <nirik> proposal: spin these (and astronomy) with fixes needed to compose and make accessable for release tomorrow
15:35:37 <bowlofeggs> nirik: +1
15:35:51 <jforbes> +1
15:36:02 <sgallagh> patch
15:36:04 <bowlofeggs> is that something releng will do?
15:36:20 <nirik> for xfce thats 1 package I think, for lxqt it's a kickstart change, for astronomy I am not sure as it was just hanging and we didn't figure out why
15:36:42 <sgallagh> Proposal: Perform a new spin that can be shipped for release. Ideally ship them alongside the release tomorrow, but a slip of a few days is acceptable if needed.
15:36:43 <nirik> I think it's do-able... perhaps mboddu could chime in if he thinks it's not
15:37:36 <mboddu> sgallagh: If a slip is acceptable then we can do it, but definitely they cannot be ready by the release time tomorrow
15:37:41 * mboddu can try but no promises
15:38:08 * nirik is happy to help
15:38:15 <jforbes> I think a slip is acceptable. The alternative is to skip shipping those spins for this release, which seems much less desirable
15:38:32 <nirik> I think if they aren't there tomorrow we will get a ton of questions about it.
15:38:38 <bowlofeggs> i think a slip has to be acceptable
15:38:40 <maxamillion> +1
15:38:40 <bowlofeggs> haha
15:38:57 <bowlofeggs> sgallagh: +1
15:39:19 <sgallagh> Serious question: could we do Oct 31? If so, I'd suggest actually slipping the standard release to that date as well
15:39:36 <sgallagh> As discussed in Go/No-Go, that would have a good synergy with RHL's original release
15:39:49 <jforbes> nirik: sure, but if they can't be done by tomorrow, better late than never
15:39:50 <nirik> I think that would be pretty hard.
15:39:50 <bowlofeggs> maybe this should be a council decision?
15:40:15 <nirik> because there's a ton of people involved in release and telling them all to change with 1 days notice could be difficult.
15:40:33 <bowlofeggs> without council approval, i'd opt to ship tomorrow as planned, and ship these whent hey are ready even if those are different dates
15:40:40 <nirik> and I think the news cycle is already on.. something else. :)
15:40:42 <sgallagh> nirik: Well, I basically mean "put everything in place as normal, but not send the announcement until a day later"
15:40:50 <jforbes> Right, I would love to have seen an Oct 31 release, but it doesn't seem like something we could change today
15:40:52 <mboddu> Also remember, we wont be syncing them to the place where they should have been, so websites people might have to do some work as well
15:40:56 <sgallagh> Even better; we'll pick up the flagging news cycle in another day
15:41:14 <sgallagh> mattdm: Are you around?
15:41:43 * nirik isn't sure, we might get a lot of questions about that too... since we announced tuesdayas the release date.
15:41:43 <jforbes> sgallagh: Pretty sure that even by Wed, it will be little more than a footnote in the current news cycle
15:41:54 <sgallagh> jforbes: Fair
15:42:19 <nirik> mboddu: yeah. ;(
15:42:32 <sgallagh> OK, then I suppose we Common Bugs the lack of those Spins and send out a separate announcement when they're ready.
15:42:47 <bowlofeggs> sgallagh: yeah that sounds good to me
15:43:09 <mboddu> Or, lets redirect the people to a page "not ready, come back soon" whenever they are ready, people will be able to access them
15:43:52 <mboddu> There are two teams involved, releng and websites
15:43:56 <nirik> if we cannot get them in place sure.
15:44:05 <mboddu> I am +1 if there is a slip, but we need to check with websites as well
15:44:06 * nirik would really like to try and do that.
15:44:30 <mboddu> I would try to get them ready by tomorrow, but as said, no promises
15:44:35 <sgallagh> OK, so there are two different questions here.
15:44:42 <bowlofeggs> what about QA time on the images?
15:44:42 <jforbes> So proposal: If they can't be ready by tomorrow, common Bugs the lack of Xfce, LXQT, and Astronomy Spins and send out a separate announcement when they're ready.
15:45:01 <mboddu> bowlofeggs: Well, they are non blocking, so QA doesn't really matter
15:45:04 <nirik> sure, +1
15:45:18 <sgallagh> jforbes: Implicitly agreeing that, yes, we are shipping them. +1
15:45:22 <nirik> it would be good to do some basic testing on them too yes
15:45:39 <jforbes> sgallagh: yes
15:45:41 <sgallagh> nirik: Bare minimum: someone can successfully boot them in a VM
15:45:48 <mboddu> nirik: Yeah, definitely, whether they are booting or not and then basic dnf tests and stuff like that
15:46:07 <nirik> sure....
15:46:49 <bowlofeggs> jforbes: +1
15:46:58 <jforbes> maxamillion jsmith?
15:47:02 <mboddu> Has anyone talked to websites and see if they can do this?
15:47:10 <maxamillion> +1
15:47:21 <maxamillion> mboddu: oh, good point of note
15:47:26 <nirik> not yet, but I can.
15:47:46 <jforbes> #agreed If they can't be ready by tomorrow, common Bugs the lack of Xfce, LXQT, and Astronomy Spins and send out a separate announcement when they're ready. (+5,0,-0)
15:48:05 <mattdm> sgallagh: I am around but need to go in a few minutes
15:48:13 <mboddu> As I said, they wont be syncing to the place where they generally would be, so people might not be able to find them easily, so websites should definitely have the right link
15:48:13 <jforbes> #action nirik will talk to websites
15:48:30 <sgallagh> mattdm: See current topic; we have an issue with some Spins, we're going to ship them, possibly late.
15:49:06 <jforbes> And that covers 2007 which was the last item on the agenda
15:49:53 <mattdm> sgallagh: +1 shipping them however we can
15:50:05 <mattdm> thanks y'all
15:50:13 <sgallagh> jforbes: Hold up
15:50:23 <sgallagh> We forgot to include the NFS topic on the agenda
15:51:25 <jforbes> sgallagh: right, it was opened 3 days ago, and getting votes in ticket
15:51:40 <jforbes> The only reason I added the spins was because of release timing
15:51:44 <sgallagh> jforbes: Right, but with the level of chatter on it, I'd like us to discuss it today.
15:51:59 <sgallagh> I meant to add the keyword and forgot.
15:52:01 <jforbes> Okay
15:52:06 <sgallagh> (Had other things on my mind this weekend...)
15:52:33 <jforbes> #topic #2005 F30 System-Wide Change: Deprecating /etc/sysconfig/nfs
15:52:40 <jforbes> .fesco 2005
15:52:42 <zodbot> jforbes: Issue #2005: F30 System-Wide Change: Deprecating /etc/sysconfig/nfs - fesco - Pagure.io - https://pagure.io/fesco/issue/2005
15:53:08 <sgallagh> So, I'm slightly of two minds on this topic. I'm firmly in favor of getting this done in F30, however I don't necessarily feel that the current migration approach is correct.
15:53:36 <sgallagh> So I'd like to propose that we accept the Change, but that I'll volunteer to help the Change Owners find a better migration path.
15:53:54 <bowlofeggs> +1 from me
15:54:02 <jforbes> sgallagh: I agree with you on the migration strategy
15:54:06 <jforbes> +1
15:54:31 <nirik> +1 for change and yeah on migration
15:55:13 <jforbes> maxamillion jsmith?
15:56:34 <sgallagh> +1 to my own proposal, to be clear.
15:56:37 <maxamillion> +1
15:57:25 <jforbes> #agreed we accept the Change, but that sgallagh will volunteer to help the Change Owners find a better migration path. (+5,0,-0)
15:57:34 <jforbes> #topic next week's chair
15:57:55 <jforbes> last week zbyszek volunteered to take next week
15:58:36 <jforbes> #action zbyszek will chair next week's meeting
15:58:42 * steved thanks the board and looks forward working with sgallagh on a migration path
15:58:52 <jforbes> #topic Open Floor
15:59:46 <jforbes> Anyone have anything?
16:00:09 * sgallagh sings the blues
16:01:15 <jforbes> If nothing else, I will close in 1 minute
16:01:26 <sgallagh> jforbes: Thanks for chairing
16:02:15 <jforbes> #endmeeting