fesco
LOGS
15:00:05 <jforbes> #startmeeting FESCO (2018-10-22)
15:00:05 <zodbot> Meeting started Mon Oct 22 15:00:05 2018 UTC.
15:00:05 <zodbot> This meeting is logged and archived in a public location.
15:00:05 <zodbot> The chair is jforbes. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:05 <zodbot> The meeting name has been set to 'fesco_(2018-10-22)'
15:00:05 <jforbes> #meetingname fesco
15:00:05 <zodbot> The meeting name has been set to 'fesco'
15:00:05 <jforbes> #chair nirik, maxamillion, jsmith, jforbes, zbyszek, tyll, sgallagh, contyk, bowlofeggs
15:00:05 <zodbot> Current chairs: bowlofeggs contyk jforbes jsmith maxamillion nirik sgallagh tyll zbyszek
15:00:05 <jforbes> #topic init process
15:00:17 <nirik> morning
15:00:30 <jforbes> morning
15:00:48 <maxamillion> .hello2
15:00:48 <zbyszek> .hello2
15:00:48 <tyll> .hello till
15:00:48 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
15:00:51 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:00:55 <zodbot> tyll: till 'Till Maas' <opensource@till.name>
15:02:55 <jforbes> Looks like we have quorum at least and can get started
15:03:14 <jsmith> .hello2
15:03:15 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
15:03:17 <jforbes> Only one topic on the agenda today
15:03:21 <jforbes> #topic #2001  F29 Final: dnf rebase requested post-freeze
15:03:21 <jforbes> .fesco 2001
15:03:21 <jforbes> https://pagure.io/fesco/issue/2001
15:03:23 <zodbot> jforbes: Issue #2001: F29 Final: dnf rebase requested post-freeze - fesco - Pagure.io - https://pagure.io/fesco/issue/2001
15:03:31 <jsmith> (I'm in two concurrent meetings at work, but I'll do my best to multi-task)
15:04:18 <jsmith> On that particular issue, I agree with bowlofeggs... would like to know exactly what we're agreeing to
15:04:27 <jsmith> (what changes are involved, etc.)
15:04:31 <zbyszek> I'm just typing a bit comment in pagure
15:04:37 <jforbes> Technically it could have waited another day for in ticket votes, but it seemed rather urgent
15:04:43 * nirik tried to get github to show a diff, but failed over the weekend
15:04:53 <nirik> it's blocking release.
15:05:19 <nirik> well, 2 accepted blocker bugs anyhow.
15:05:22 <zbyszek> https://pagure.io/fesco/issue/2001#comment-537283
15:06:22 * nirik notes the dnssec thing is off by default, but of course the code is still there.
15:07:55 <jforbes> Right, and as it was posted earlier, it is pretty much bug fixes, the versioning change makes sense in the context posted
15:09:02 <zbyszek> nirik: where do you see that it is off by default? I can't find an explicit switch either way in the code...
15:09:38 <nirik> I think in the orig pr, or perhaps in the infra ticket for adding the keys to dns... can't recall...
15:10:10 <zbyszek> OK, so I'm +1 to accept the rebase too.
15:10:40 <zbyszek> We're at +5 with my vote.
15:11:24 <jforbes> Anyone else want to weigh in either way?
15:11:25 <maxamillion> I mean, the real question is ... do we really have a choice?
15:11:36 <zbyszek> maxamillion: I think yes, we do.
15:11:44 <nirik> sure, it would just be a lot more work
15:11:45 * tyll is also +1
15:12:04 <maxamillion> dnf has historically constantly broken things so I'm a little hesitant but there's a lot of support for it, so I'll leave it alone
15:12:05 <maxamillion> +0
15:12:07 <zbyszek> maxamillion: it is really like 1/2 h of work to prepare a branch with the new features, just bug fixes.
15:12:21 <maxamillion> "just bug fixes" ... famous last words
15:12:25 <nirik> zbyszek: and libdnf and anaconda and dnf-plugins and...
15:12:26 <zbyszek> It's a bit disappointing that the dnf team considers this too onerous.
15:13:37 <jforbes> nirik: did you vote?
15:13:45 <zbyszek> nirik: sure, but the fact that we are in a freeze is well known. Instead of merging new features, it'd be totally OK to just do the bugfixes for a few weeks, and do the new stuff next month.
15:14:01 <nirik> jforbes: yeah, I thought I added a +1 in ticket
15:14:10 <jforbes> Oh, you did, it was mid comment
15:14:17 <nirik> zbyszek: I completely agree... but the ship has sailed now. ;(
15:14:29 <maxamillion> yeah, that's kind of my point
15:14:36 <maxamillion> but whatever
15:14:44 <jforbes> #agreed F29 Final: dnf rebase requested post-freeze is approved (+6,1,-0)
15:14:57 <jforbes> #topic Next week's chair
15:16:04 <jforbes> Bueller?..
15:16:27 <jforbes> I guess if no takers, I will take it again.
15:16:45 <zbyszek> Please do, and then I'll do it next week.
15:16:50 <jforbes> #info jforbes will chair next meeting
15:17:01 <jforbes> #topic Open Floor
15:17:04 <tyll> Thank you both!
15:17:14 * nirik has 1 item for open floor...
15:17:26 * zbyszek has one too
15:17:28 <nirik> yeah, thanks jforbes / zbyszek
15:17:37 <zbyszek> nirik: please go first
15:18:41 <nirik> ok. So, releng has gotten recently 2 tickets that change the way things are built for end users... Just wanted to give fesco a heads up, and I have been thinking that perhaps these should go to fesco instead of releng trying to decide by itself...
15:18:55 <nirik> https://pagure.io/releng/issue/7878 - make pm_request available and working in koji.
15:18:55 <nirik> https://pagure.io/releng/issue/7840 - consider ursa major
15:19:30 <nirik> pm_request would allow go (or anything) to request additional packages be installed as buildrequires during the build.
15:19:46 <nirik> ursa major would allow building against modules
15:20:21 <nirik> for ursa major we thought of a possible fix of making a 'buildroot' repo that has listed the modules in the buildroot...
15:20:32 <tyll> why can go packages not use regular BRs`
15:20:33 <tyll> ?
15:20:41 <nirik> but in any event we need to decide if someone using rpmbuild is something we want to keep always supporting or not
15:21:07 <nirik> tyll: ask nim, or read the wall of text in that ticket.
15:21:49 <zbyszek> Let's not get distracted by the technical/insteresting side.
15:22:03 <zbyszek> I think nirik point is more about policy
15:22:20 <nirik> in any case this doesn't need to be decided today, but likely will come to fesco, so might be good to start thinking about it.
15:22:24 <nirik> yeah exactly.
15:22:58 <jforbes> Yeah, there is a good bit to digest I think on what the policy might mean
15:23:15 <zbyszek> I think that for such complicated questions we need something similar to the Change process — both a fesco ticket and a rel-eng ticket, because the input from both of those groups is useful.
15:23:58 <zbyszek> Fesco is more about "do we want this?", and releng answers "can we do this?".
15:24:10 <jforbes> And also, how might these changes be used outside of the original intent in the request?
15:24:16 <nirik> well, we can do this, but it means end users will see a lot of change in building things
15:25:16 <tyll> Not sure if it is just "do we want this", since we want Go packages and building against modules also sounds like a good idea - the question is IMHO if we like the new workflows/restrictions
15:25:33 <rindolf> i should note my rant/tip here - https://twitter.com/shlomif/status/1053390606758825984
15:25:59 <rindolf> i wasted so much time due to that :(
15:26:08 <nirik> rindolf: note f29 is not actually released yet. ;)
15:26:17 <rindolf> nirik: yes
15:26:20 <jforbes> nirik: I would say file those tickets with a link back to the releng tickets. I am all for discussing the impacts there.
15:26:32 <nirik> and the item we approved earlier moves this change into the compose. ;)
15:26:52 <nirik> jforbes: fesco tickets you mean?
15:26:54 <rindolf> nirik: great, thanks
15:27:27 <jforbes> nirik: I meant file the fesco tickets with a link back to releng tickets, but however works
15:27:49 <jforbes> Just not a whole lot of reason to restate wall of text in a separate ticket
15:27:49 <nirik> jforbes: sure, 2 tickets I guess?
15:28:16 <jforbes> It seems feasible that there might be separate outcomes for each
15:28:50 <nirik> yeah, ok will do
15:29:47 <zbyszek> I'd like to discuss the Enginnering rep vote
15:29:51 <zbyszek> .fesco 2000
15:29:53 <zodbot> zbyszek: Issue #2000: New Council Engineering rep needed - fesco - Pagure.io - https://pagure.io/fesco/issue/2000
15:30:48 <jforbes> Looked like it was just waiting for maxamillion to vote
15:30:53 <zbyszek> Right.
15:31:24 <maxamillion> on it
15:31:24 <zbyszek> dgilmore raised a question whether contyk has enough time to commit, but I think we assume that he does, since he accepted the nomination.
15:31:47 <maxamillion> voted :)
15:31:53 <jforbes> Yes, I took the accepting the nomination as accepting the nomination
15:32:47 <zbyszek> Great. I just wanted to move this along.
15:33:26 <jforbes> #agreed FESCo confirms psabata as the New Council Engineering rep (+8,1,0)
15:33:39 <jforbes> Anyone have anything else for the open floor?
15:34:31 <jforbes> Will close out in 1 minute if not
15:34:51 <zbyszek> Thanks jforbes!
15:35:30 <jforbes> #endmeeting