fpc
LOGS
16:00:22 <geppetto> #startmeeting fpc
16:00:22 <zodbot> Meeting started Thu May 17 16:00:22 2018 UTC.
16:00:22 <zodbot> This meeting is logged and archived in a public location.
16:00:22 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:22 <zodbot> The meeting name has been set to 'fpc'
16:00:23 <geppetto> #meetingname fpc
16:00:23 <geppetto> #topic Roll Call
16:00:23 <zodbot> The meeting name has been set to 'fpc'
16:00:27 <mhroncok> hi
16:00:32 <tibbs> Howdy.
16:00:33 <geppetto> #chair mhroncok
16:00:33 <zodbot> Current chairs: geppetto mhroncok
16:00:35 <decathorpe> .hello2
16:00:36 <geppetto> #chair tibbs
16:00:36 <zodbot> Current chairs: geppetto mhroncok tibbs
16:00:36 <zodbot> decathorpe: decathorpe 'None' <decathorpe@gmail.com>
16:00:39 * limburgher here, fetching food.
16:00:41 <geppetto> #chair decathorpe
16:00:41 <zodbot> Current chairs: decathorpe geppetto mhroncok tibbs
16:00:47 <geppetto> #chair limburgher
16:00:47 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok tibbs
16:01:01 <geppetto> #chair redi
16:01:01 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok redi tibbs
16:01:20 <redi> I'm on a conf call at the moment, so probably not going to be very active here today, sorry
16:01:37 <geppetto> ok
16:02:47 <geppetto> redi: One trick I use is to put a copy of the FPC meeting into my work calendar, so I'm marked as busy for the hour.
16:03:04 <geppetto> ofc. that doesn't work all the time … but it helps. :)
16:03:33 <geppetto> I know ignatenkobrain said he can't make it today
16:03:46 <geppetto> but I'll give the couple of others until 5 path.
16:03:50 <geppetto> *past
16:06:19 <geppetto> #topic Schedule
16:06:20 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/BR5BMNRH7PR2MV7PFCLJU7OO6FKKD2OT/
16:06:30 <geppetto> #topic #767 Clarity for packaging addons for non-fedora applications
16:06:32 <geppetto> .fpc 767
16:06:35 <zodbot> geppetto: Issue #767: Clarity regarding packaging addons for applications outside of the repository. - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/767
16:08:13 <mhroncok> explicit exception for chrome works for me, however the attitude of the maintainer in that bug horrifies me so I'm biased to forbid this :D
16:09:45 <decathorpe> yeah ...
16:09:49 <tibbs> The guy who opened the FPC ticket is certainly doing the right thing and that's great.
16:10:25 <mhroncok> right
16:10:47 <mhroncok> should we allow the location in general or ask the packagers to get exceptions for this on per package basis?
16:10:53 <tibbs> Those new to FPC should get used to that general attitude of people ignoring anything we say because they find working within any constraints to be inconvenient.
16:11:06 <geppetto> So I know debian had a rule that was something like "you couldn't ship anything that was for the sole benefit of something outside the repo." … and I thought we had something similar.
16:11:12 <tibbs> I don't think a per-package exception makes sense.
16:11:27 * decathorpe shrugs
16:11:29 * limburgher is back
16:11:38 <mhroncok> do we have some power at all? :D
16:11:40 <tibbs> We have the following rule: http://fedoraproject.org/wiki/Packaging:Guidelines#Packages_which_are_not_useful_without_external_bits
16:12:06 <mhroncok> and yet we have fedora chrome user agent package :D
16:12:11 <geppetto> yeh, that
16:12:23 <tibbs> But note that these packages also work with chromium; they just have to symlink things into /opt/google because Google's Chrome won't look anywhere else.
16:12:29 <decathorpe> the package is useful for chromium, firefox, and chrome AFAIK. additionally, chrome repo is shipped with Workstation now
16:12:42 <geppetto> tibbs: yeh, that is somewhat relevant
16:12:58 <tibbs> I don't think that runs afoul of anything, especially given that the project has officially endorsed specific pieces of closed source software.
16:13:23 <tibbs> Also, note interestingly that our chromium package generates a subpackage which drops things into /opt/google.
16:13:36 <geppetto> I guess I'm mostly +1 on saying this is fine, although I'm not sure I can justify it generically ;)
16:13:54 <decathorpe> yeah, one could argue that chrome is no longer an external bit, because it's available from an optional, official fedora repo now
16:14:12 <mhroncok> that's just weird
16:14:17 <tibbs> I'm generally in support of a narrow exception.  Can put things into this exact directory in order to support Chrome as long as:
16:14:26 <tibbs> 1) Your package also supports Chromium.
16:14:44 <tibbs> 2) Chrome isn't updated to look at a proper directory outside of /opt/chrome for this purpose.
16:14:57 <mhroncok> does it make any sense to say "only symblinks"?
16:15:13 <tibbs> I honestly do not know if the files need to differ in some way for Chromium.
16:15:25 <tibbs> We can easily ask the person who submitted 767.
16:15:27 <mhroncok> right, "prefer symblinks"?
16:15:41 <geppetto> Yeh, although if they did it would be easy to package them somewhere normal and then just put symlinks in /opt
16:15:48 <geppetto> Which is probably better?
16:15:59 <tibbs> I honestly do not know.
16:16:24 <geppetto> I'm fine with small files too … but then we probably have to define small, *sighs*
16:16:36 <tibbs> That would be sort of declaring a proper location for these things, which might actually end up being different from what Chrome itself might end up choosing if it did so.
16:16:42 <mhroncok> let's say we prefer symblinks if possible
16:16:55 <mhroncok> tibbs: my toughts execatly
16:17:56 <geppetto> tibbs: kind of, except that from the point of view of install/kickstart the filesystem layout has more space in certain parts … and SAs know that roughly.
16:18:19 <geppetto> but it probably doesn't matter because the files will probably be so small that nobody cares
16:18:36 * geppetto adds some more maybes for good measure.
16:18:50 <tibbs> I think in the limited case that matters here, the files will be small.  They are just manifests of some kind.
16:18:58 * geppetto nods
16:19:30 <mhroncok> action?
16:19:32 <geppetto> Do we want to vote on tibbs proposal?
16:19:35 <geppetto> +1
16:19:37 <mhroncok> +1
16:19:40 <limburgher> +1
16:19:43 <decathorpe> +1
16:19:44 <tibbs> +1
16:19:53 <mhroncok> (how much do we need actually?)
16:20:05 <mhroncok> one more?
16:20:21 <tibbs> Five.
16:20:30 <mhroncok> so we'r set
16:20:30 <tibbs> Though that is a fun question.
16:20:39 <geppetto> 5 although we generally wait for everyone who is here to vote.
16:21:08 <mhroncok> redi is busy
16:21:11 <geppetto> redi: which means you :)
16:21:19 <redi> reading ...
16:22:18 <redi> +1
16:22:26 <geppetto> #action Add tibbs proposed exception for chrome plugins that are compat. with chromium. (+1:6, 0:0, -1:0)
16:22:53 <tibbs> The situation is kind of interesting, in addition.
16:23:32 <tibbs> Chrome will look in /etc/opt/chrome but... doesn't the chrome package use "google" as its opt namespace?
16:23:53 <mhroncok> ¯\_(ツ)_/¯
16:23:57 <decathorpe> if so, that looks like a bug
16:23:58 <tibbs> It seems fairly obvious this really is a Chrome bug.
16:24:03 <geppetto> #topic #754 Should py3-foo obsolete py2-foo (when py2-foo is removed)?
16:24:08 <geppetto> .fpc 754
16:24:11 <zodbot> geppetto: Issue #754: Should python3-foo obsolete python2-foo (when python2-foo is removed)? - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/754
16:24:30 <geppetto> tibbs: just wait until they move to /opt/alphabet ;)
16:25:03 <decathorpe> I changed my mind a bit on this one
16:25:12 <tibbs> geppetto: It's basically "we do what we want, for reasons".  Same reason people pretend that packaging guidelines don't exist.
16:25:20 * limburgher smacks geppetto
16:25:49 <tibbs> So for 754, I still think that fedora-obsolete-packages is the right place for general obsoletes.
16:26:13 <geppetto> sure
16:26:22 <geppetto> why does it need deps. on py2 packages?
16:26:45 <tibbs> decathorpe: What opinion do you hold now?
16:26:58 <mhroncok> geppetto: I'm afraid I don't understand the question
16:27:09 <geppetto> the DNF question I assume ignatenkobrain could answer
16:27:31 <tibbs> My point is that we do already have a mechanism for obsoleting things when they need to go away and nothing else obvious would obsolete the package.
16:27:34 <decathorpe> I've briefly looked at the abrt case. AFAIK the python2-abrt packages are only used by abrt internally. in that case I would say obsoleting them is fine
16:27:35 <geppetto> mhroncok: the ticket says people are complaining that fedora-obsolete-packages depends on py2 packages … just wondering why it needs to do that.
16:27:52 <tibbs> Wait, it _depends_ on py2 packages?
16:28:00 <mhroncok> what?
16:28:14 <geppetto> I thought that's what the complaint said … maybe I just need more sleep
16:28:23 <geppetto> it's just obsoleting them then?
16:28:23 <tibbs> Not according to the spec, at least.
16:28:29 <tibbs> It just obsoletes things.
16:28:30 <geppetto> ok, I'll trust the spec :)
16:29:05 <mhroncok> https://bugzilla.redhat.com/show_bug.cgi?id=1578514
16:29:09 <mhroncok> this one actually is broken
16:29:27 <mhroncok> to this breaks upgrades
16:29:37 <mhroncok> as I've told already before
16:30:39 <mhroncok> also https://bugzilla.redhat.com/show_bug.cgi?id=1578134#c3 for that problems it couses
16:30:54 <tibbs> Right, and they filed a ticket to have fedora-obsolete-packages get rid of that, but then for some reason don't want to provide the needed information.
16:31:20 <mhroncok> tibbs: actually, they use bugzilla depednencies
16:31:31 <mhroncok> to you can see the original problem
16:31:34 <mhroncok> and when you asked
16:31:36 <mhroncok> they asked
16:31:47 <mhroncok> and now Adam replied
16:31:50 <tibbs> So someone doesn't have middle button mouse paste or something?
16:32:10 <mhroncok> it just takes a while to propagate the information :D
16:32:46 <tibbs> Two seconds work for someone who is familiar with things.  Far more for fedora-obsolete-packages maintainer.  And far more chance of me getting it wrong, too.
16:32:56 <mhroncok> I get it
16:33:17 <mhroncok> that's why i think we shoudl nto bother you with  fedora-obsolete-packages but use the python3 versions to obsolete the packages :D
16:34:32 <decathorpe> as I said, since the abrt python packages were ~only used internally, I would be fine with abrt obsoleting those itself
16:35:46 <geppetto> mhroncok: In theory obsolting with py3 isn't perfect … but I'm fine with any maintainer just doing it anyway
16:36:01 <tibbs> Thing is, if people just give the packages and versions which need to be obsoleted and a quick description of the dependency problems, I fix it in rawhide in a few minutes and things are done.
16:36:13 <mhroncok> they won't
16:36:15 <tibbs> Then I take care of removing the obsoletes when they are no longer relevant.  All clean and easy.
16:36:30 <mhroncok> except you think they will do it that way
16:36:52 <mhroncok> I'm generally ok with anything obsoleting the packages
16:37:02 <tibbs> That's the way FPC and FESCo decided it would be done.
16:37:03 <mhroncok> I just think thet obsoleting form python3 makes everything easier
16:37:21 <redi> someone in the ticket mentioned the desire to install a hand-rolled py2-foo alongside py3-foo
16:37:31 <mhroncok> that's just nonsense
16:37:36 <redi> wouldn't obsoleting them from fedora-obsolete-packages have the same problem?
16:37:37 <tibbs> redi: Yes, they just bump the release when they do that.
16:37:44 <redi> alrighty
16:37:50 <mhroncok> but if they hand rol legacy cruft, they may as well bump the release / version / epoch
16:37:54 <tibbs> No, that's why I insist on having the exact versions which need to be obsoleted.
16:38:01 <geppetto> redi: the obsoletes (whereever they are) should be versioned so that's possible if the user really knows what they are doing and builds a new package.
16:38:08 <tibbs> Still think everyone who randomly adds obsoletes to the python3 packages will get that right?
16:38:11 <redi> ok works for me
16:38:24 <mhroncok> if they get it wrong
16:38:35 <mhroncok> the might handroller will open a bugzilla
16:38:41 <mhroncok> mighty
16:38:47 <limburgher> This can happen with any package.
16:38:47 <mhroncok> except there will be none
16:38:52 <tibbs> Or, you know, you could just use the existing mechanism for this and get it right the first time....
16:39:04 <geppetto> mhroncok: eh, if I was the handroller I wouldn't bother.
16:39:16 <geppetto> mhroncok: it's mostly too late by then anyway
16:39:16 <mhroncok> geppetto: what would you do instead?
16:39:26 <geppetto> --nodeps ftw :)
16:39:27 <limburgher> Port it to perl4 and be done with it?
16:39:30 <geppetto> Or rename it
16:39:34 <mhroncok> limburgher: :D
16:39:49 <mhroncok> rename it to legacy-python-foo :)
16:39:52 <limburgher> python2-foo-electric-boogaloo
16:39:52 <geppetto> yeh
16:39:59 * decathorpe waits for the mess that will happen when python 4 is released
16:40:09 <limburgher> compat-compat-compat-python2-foo
16:40:19 <mhroncok> I'm looking forward for the flame on python-dev once somebody propsoes that
16:40:20 <geppetto> the-only-decent-python-foo ;)
16:40:52 <geppetto> decathorpe: it's called Golang … I recommend it.
16:41:00 * geppetto ᕕ( ᐛ )ᕗ
16:41:07 <limburgher> geppetto, get out.
16:41:21 * decathorpe 's head explodes
16:41:31 <geppetto> limburgher: hey, it has brackets and everything … backwards incompat is kind worth it this time.
16:41:35 * geppetto keeps running.
16:41:51 <limburgher> dnf install vodka -y
16:41:56 <tibbs> So, basically, is there any support for the python3 packages obsoleting the python2 packages?  I don't see it getting to +5 at this point.
16:42:04 <limburgher> Not from me.
16:42:06 <geppetto> I'm fine with it
16:42:23 <geppetto> it's not the best solution … but it's better than nothing obsoleting them
16:42:28 <limburgher> Oblig. Hamilton Cabinet Battle
16:42:33 <decathorpe> I don't care whether it happens in the python3 package or fedora-obsolete-packages
16:42:36 <tibbs> Well, fedora-obsolete-packages can obsolete them.
16:42:48 <limburgher> I prefer f-o-p. Keep the mess in one spot.
16:42:50 <tibbs> Obviously when there are dependency issues the packages need to go away.
16:43:13 <tibbs> That's why we have the existing mechanism, and it should work fine except that people seem to want to avoid the bureaucracy.
16:43:27 <redi> does stuff get swept out of f-o-p after two releases, as per the policy on keeping Obsoletes: tags in spec files?
16:43:42 <tibbs> Yes, I remove it when the time comes.
16:43:46 <redi> cool
16:43:48 <geppetto> limburgher: I agree … I'm just more "If the packager will either add it to the py3 package, or not bother doing anything … I'd much rather get random py3 stuff."
16:44:16 <tibbs> I can open a single tracking bug for py2 packages which need to go away in F29.  People can just pile on that if they want.
16:44:25 <mhroncok> tehy won't
16:44:37 <geppetto> mhroncok: much optimism
16:44:40 <decathorpe> we can at least try ;)
16:44:42 <geppetto> 👍
16:44:44 <limburgher> geppetto, true, but if we can use a handful of characters and aim people at f-p-o...
16:44:49 <mhroncok> if I make a PR that removes python2-... I want it to be self contained
16:45:02 <limburgher> decathorpe, you can lead a horse to water but you can't make him RTFM.
16:45:36 <mhroncok> let me at least ahve the option to have it in the python3 package and I'll be fine even if we recommend f-o-p
16:45:57 <limburgher> mhroncok, it can't always be anyway, for example where py2 and py3 are separate SRPMS.
16:46:17 <limburgher> mhroncok, I'm ok with CAN, but against MUST.
16:46:21 <tibbs> I don't understand why the existing mechanism we have for this is inadequate.
16:46:32 <geppetto> limburgher: sure
16:46:39 <limburgher> tibbs: <nod>
16:46:56 <decathorpe> I would be OK with "only" strongly recommending f-o-p
16:47:00 <tibbs> That's the thing: We've had a mechanism for this all along.  The entire discussion didn't even need to happen.
16:47:30 <tibbs> The bugs which were raised could have been closed in just a few minutes with me adding a few lines to fedora-obsolete-packages.
16:47:45 <limburgher> tibbs: 100%
16:47:49 <mhroncok> right
16:47:58 <tibbs> I don't understand why all of this effort has been wasted when we have a mechanism and nobody seems to have come up with a reason why it doesn't work.
16:48:10 <geppetto> tibbs: just those pesky users getting in the way of everything being perfect ;)
16:48:16 <mhroncok> :D
16:48:59 <mhroncok> I wonder how a packager know whether removal of the py2 package will cause problems with upgrades
16:49:03 <limburgher> KILL ALL HUMANS
16:49:08 <limburgher> Sorry, wrong window.
16:49:14 <decathorpe> xD
16:49:23 <tibbs> Nobody here but is dogs.
16:49:24 <mhroncok> so he can justify it being obsoleted by f-o-p before a problem actually happens
16:49:30 <geppetto> limburgher: no need to go double thanos
16:50:01 <geppetto> mhroncok: guess?
16:50:15 <tibbs> mhroncok: So the issue is that there might be an instance where nobody knows that it will be an issue, but we need the package to go away anyway?
16:50:21 <mhroncok> becasue when a packager opens a buzgilla for tibbs to obsolete it, tibbs will ask: gimme the error
16:50:43 <tibbs> I mean, if that's the case someone could at least tell me.  Otherwise, why are you removing packages from people's systems?
16:50:55 <mhroncok> when we remove stuff, we need to obsolete it, otherwise it can possibly somehow someday bite us
16:51:09 <tibbs> It's already been established that we don't want that to happen except where it is necessary.
16:51:17 <mhroncok> ok
16:51:39 <mhroncok> I don't honeslty care either way, let's keep the bugs comming
16:52:01 <mhroncok> my motivation was precaution
16:52:33 <tibbs> But I mean, someone could at least articulate what the problem is going to be.  That's all I'm trying to understand.  Just to keep people from needlessly pulling packages from systems.
16:53:05 <tibbs> The only other thing I really need is the version-release that needs to go, because we do always want to do versioned obsoletes.
16:53:15 <geppetto> Ok, did we want to vote on letting people obsolete in py3 packages … even if we'd much prefer they use f-o-p?
16:53:56 <limburgher> geppetto, SPOILERS
16:54:00 <tibbs> I can toss in a -1 if we're voting.
16:54:15 <tibbs> And also, if you want to co-maintain f-o-p, please just let me know.
16:54:27 <geppetto> lol, no … where did you get that from ?:)
16:55:04 <mhroncok> I can help you co-maintain, just tell me exactly what's the criteria to obsolete something from there
16:55:05 <limburgher> geppetto, that's what I heard you say.
16:55:21 <geppetto> limburgher: nice
16:55:31 <tibbs> mhroncok: if you were planning on monitoring the python packages and cleaning up old obsoletes anyway, then you could just join in on the package.  The end result is pretty much the same, with less cleanup in the end and no extra mess in the python guidelines about obsoletes.
16:55:43 <mhroncok> so whta should be the actuall proposal here: when removing py2 package, don't obsolete it from py3, but rather obsoelte it form f-o-p but only if x?
16:56:17 <geppetto> mhroncok: yeh, where x is "is likely to cause problems on upgrades"
16:56:22 <mhroncok> ok
16:56:25 <mhroncok> fine by me
16:56:28 <tibbs> Note that the current guidelines say this: http://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages
16:56:34 <geppetto> ok
16:56:35 <tibbs> "If retired packages need to be removed from end user machines because they cause dependency issues which interfere with upgrades or are otherwise harmful, a packager MAY request that Obsoletes: be added to fedora-obsolete-packages. Simply file a bugzilla ticket here. Please include information on which packages need to be obsoleted, the exact versions which need to be obsoleted, and the reasons why they cannot be allowed to remain installed. "
16:57:21 <decathorpe> for example, "MAIN" depends on "python2-MAIN", and switches to python3 ... then the python2 packages need to be obsoleted, if there are version constraints
16:57:48 <geppetto> #info mhroncok to help tibbs co-maintain fedora-obsolete-packages
16:58:27 * limburgher drags geppetto out from under the bus
16:58:33 <mhroncok> decathorpe: and that is exactly the case where I would just obsoelte it prom the py3 package
16:58:48 <geppetto> #info We acknowledge that there are likely to be a lot of py2 packages added to fedora-obsolete-packages in the near future
16:59:01 <decathorpe> mhroncok:  yeah, that is one exception I would make
16:59:08 <decathorpe> but just as an example that leads to conflicts
16:59:31 <geppetto> decathorpe: yeh, I assumed that would be the common use case.
16:59:59 <geppetto> Anyway … we have 1 minute left … is there anything else we want to do for this ticket?
17:00:07 <mhroncok> please just don't make me remove all the obsoletes I've added when removing python2 django
17:00:07 <tibbs> We all know this is herding cats anyway, and people will still do it wrong.  Someone will have to clean that up eventually.
17:00:29 <geppetto> I vote limburgher does it.
17:00:52 <limburgher> geppetto, I vote she doesn't.
17:00:54 <limburgher> Does what?
17:01:00 <geppetto> :)
17:01:09 <tibbs> I guess we're out of time.  I've been trying to mark tickets that should come back up for discussion so hopefully we can get to them at some point.
17:01:15 <limburgher> Obsolete with Extreme Prejudice.
17:01:30 * geppetto nods
17:01:36 <geppetto> #topic Open Floor
17:01:51 <geppetto> We have -1 minutes for anything that anyone wants to discuss
17:01:53 <limburgher> tibbs, I think you've typed that about 748 times in my time on FPC.
17:02:04 <limburgher> Not I, said the duck.
17:02:08 <tibbs> Such is life.
17:02:24 <geppetto> We are doing pretty well since the new members arrived.
17:02:35 <limburgher> Kudos to people who show up. :)
17:02:41 <tibbs> I wish we had gotten back to 719.
17:02:42 <geppetto> almost all new tickets get dealt with the same week, and the backlog is going down.
17:03:13 <decathorpe> just a general question: Is there a procedure where a maintainer is active in fedora, but seems to neglect a package?
17:03:34 <tibbs> Get comaintainers.
17:03:44 <limburgher> Nag.
17:03:49 <tibbs> And talk to FESCo if the problem is serious.
17:03:51 <decathorpe> I volunteered, but he didn't respond
17:03:58 <geppetto> yeh, if they acknowledge it … co-maintainers … if not, it gets annoying.
17:04:16 <tibbs> the switch to pagure has made this more difficult.
17:04:23 <tibbs> With pkgdb you formally requested privileges.
17:04:24 <sgallagh> decathorpe: See https://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers#Exception_procedure
17:04:53 <tibbs> On occasion I will just add someone as a comaintainer on a package if the maintainer just didn't bother responding.
17:05:10 <limburgher> Maybe the real privileges were the ACLs we granted along the way.
17:05:11 <tibbs> But now we have no obvious record that the request was made, so it gets more difficult.
17:05:25 <decathorpe> well, the package in question is now 2 years out of date, and broken on rawhide ... so I guess those requirements are met
17:05:37 <tibbs> What's the package?
17:05:46 <decathorpe> rubygem-jekyll
17:06:09 <geppetto> Feel free to continue this in #fedora-devel … or even here if there's no other meeting. Just going to close this one.
17:06:14 <geppetto> #endmeeting