f28-final-go-no-go-meeting
LOGS
17:02:24 <jkurik> #startmeeting F28 Final Go/No-Go meeting
17:02:24 <zodbot> Meeting started Thu Apr 26 17:02:24 2018 UTC.  The chair is jkurik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:24 <zodbot> The meeting name has been set to 'f28_final_go/no-go_meeting'
17:02:31 <jkurik> #meetingname F28-Final-Go-No-Go-meeting
17:02:31 <zodbot> The meeting name has been set to 'f28-final-go-no-go-meeting'
17:02:34 <decathorpe> have fun ;)
17:02:37 <lruzicka> .hello2
17:02:39 <jkurik> #topic Roll Call
17:02:39 <zodbot> lruzicka: lruzicka 'None' <lruzicka@redhat.com>
17:02:40 <sgallagh> .hello2
17:02:41 <jsmith> .hello2
17:02:41 <bowlofeggs> .hello2
17:02:41 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:02:42 <nirik> morning
17:02:44 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
17:02:47 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <rbarlow@redhat.com>
17:02:50 <mboddu> .hello mohanboddu
17:02:50 <jkurik> .hello jkurik
17:02:51 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
17:02:53 * satellit_ listening
17:02:54 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
17:02:56 <jkurik> #chair nirik adamw sgallagh mboddu
17:02:56 <zodbot> Current chairs: adamw jkurik mboddu nirik sgallagh
17:03:00 <kparal> .hello
17:03:00 <zodbot> kparal: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:03:05 <kparal> .hello2
17:03:06 <zodbot> kparal: kparal 'Kamil Páral' <kparal@redhat.com>
17:03:07 <jkurik> #topic Purpose of this meeting
17:03:14 <jkurik> #info Purpose of this meeting is to check whether or not F28 Final is ready for shipment, according to the release criteria.
17:03:19 <jkurik> #info This is determined in a few ways:
17:03:25 <jkurik> #info * No remaining blocker bugs
17:03:27 * mattdm is in right channel now. howdy everyone
17:03:30 <jkurik> #info * Release candidate compose is available
17:03:36 <jkurik> #info * Test matrices for Final are fully completed
17:03:46 * kparal pokes adamw
17:03:48 <jkurik> Hi everyone
17:03:53 <jkurik> #topic Current status
17:04:10 <jkurik> As far as I am aware, the RC for F28 Final is ready: ​​http://dl.fedoraproject.org/pub/alt/stage/28_RC-1.1/
17:04:11 <adamw> .hello adamwill
17:04:12 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
17:04:19 <jkurik> Test matrices are ready as well: https://fedoraproject.org/wiki/Test_Results:Fedora_28_RC_1.1_Summary
17:04:33 <jkurik> And we have some blockers to discuss: https://qa.fedoraproject.org/blockerbugs/milestone/28/final/buglist
17:04:42 <jkurik> Anyone wants to add something ?
17:05:11 <jkurik> looks like no
17:05:15 <jkurik> #info The RC for F28 Final is ready
17:05:21 <jkurik> #link ​​http://dl.fedoraproject.org/pub/alt/stage/28_RC-1.1/
17:05:26 <jkurik> #info Test matrices are available
17:05:32 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_28_RC_1.1_Summary
17:05:39 <jkurik> #info There are proposed and accepted blockers we need to go through
17:05:46 <jkurik> #link https://qa.fedoraproject.org/blockerbugs/milestone/28/final/buglist
17:05:58 <jkurik> Let's do Mini-blocker review
17:06:04 <jkurik> adamw: may I ask you please to chair the mini-blocker review ?
17:06:13 <adamw> sure.
17:06:15 <jkurik> #topic Mini-Blocker Review
17:06:25 <jkurik> #link https://qa.fedoraproject.org/blockerbugs/milestone/28/final/buglist
17:06:58 <adamw> #info there's one proposed blocker
17:06:59 <adamw> #topic (1569211) GDM fails first login attempt after reboot
17:06:59 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1569211
17:06:59 <adamw> #info Proposed Blocker, gnome-shell, NEW
17:08:01 <jkurik> hmm.. this looks like a serious one
17:08:01 <adamw> so, we've been poking this one this morning. it seems fairly reproducible: shift (and possibly any modifier key?) isn't applied consistently to the first character entered in the gnome-shell password prompt, the first time it's used for any given password request.
17:08:09 <adamw> it's...kinda weird
17:08:19 <adamw> in that it seems that it always works fine the *second* time
17:08:32 <kparal> or if you use backspace
17:08:36 <adamw> so sgallagh is probably right that _mostly_ people are gonna assume they mistyped, do it again, and it'll work
17:08:37 <adamw> right
17:08:46 <mattdm> Yeah. It looks like *general* thought is that we can live with this if we have a zero day update....
17:08:49 * nirik doesn't think this is a blocker, but definitely a common bug + update fix.
17:08:53 <mattdm> are we likely to have that update?
17:09:06 <sgallagh> mattdm: That discussion is still going on among the Workstation folks
17:09:07 <adamw> i dunno, i'm kinda on the fence. on the one hand it's pretty bad, really. on the other, the practical impact of it is likely to be surprisingly not that big...
17:09:17 <mattdm> adamw: exactly
17:09:31 <puiterwijk> I've been seeing this consistently on Rawhide too. At least good to know I'm not *too* crazy. But yeah, it's survivable
17:09:42 <sgallagh> mattdm: There's some question about it being an ibus issue or a gnome-shell one
17:09:45 <adamw> puiterwijk: do you remember when it showed up on rawhide, by any chance?
17:09:45 <jsmith> Yeah, I thought it was my inability to type my password (on Rawhide)...
17:09:52 <jsmith> ... didn't know it was a real bug until just now :-)
17:10:10 <puiterwijk> adamw: I'm afraid not. I've thought I was ust crazy
17:10:11 <langdon> I was glad of the excuse.. but I still type it wrong ;)
17:10:12 * jsmith is inclined to not make it a blocker, but to document it in Common Bugs
17:10:16 * satellit_ I use a Cap L first letter of password and have experienced this
17:10:17 <lruzicka> I haven't experienced this ever while testing ...
17:10:21 <sgallagh> jsmith, puiterwijk: That lends credence to the "most people will assume they just mistyped" line of thinking
17:10:29 <puiterwijk> sgallagh: yeah, agreed.
17:10:48 <puiterwijk> And if we get a fix at some point, it should be fine. Since installer images tend to not have passwords
17:10:50 * lruzicka has never used a capital letter first, so that might be the issue
17:10:51 <kparal> lruzicka: it only happens when the first password character is capital (so you need to use shift)
17:10:52 <jsmith> sgallagh: While I agree with your sentiment, I don't think you can get away with thinking tha puiterwijk and I are in any way representative of "most people"
17:10:57 <langdon> I like that we are all scoping our password entropy for the public :)
17:11:14 <lruzicka> kparal: Oops.
17:11:20 <mattdm> my password begins with 🦄
17:11:21 <puiterwijk> langdon: I obviously just changed my password fater I told you this :)
17:11:21 <sgallagh> jsmith: Yeah, you're people who are fare more likely to have discovered the truth on your own than the general public :)
17:11:22 <bowlofeggs> a question was raised as to whether this would affect new passwords
17:11:29 <stickster_temp> jsmith: On the other hand, several people in the bug said the same thing :-)
17:11:34 <bowlofeggs> because if it affects new passwords, that would be a blocker imo
17:11:41 <puiterwijk> bowlofeggs: it doesn't affect passwords set during install
17:11:53 <bowlofeggs> what about passwords that are changed after install though?
17:11:58 <puiterwijk> i.e. I recently set a password with uppercase first letter in anaconda, and after the first login it works
17:12:01 <jsmith> What about passwords set using the "Users" section of the Gnome Control Panel?
17:12:07 <puiterwijk> I can try now
17:12:11 <sgallagh> bowlofeggs: And we have confirmation that it doesn't affect the change-password dialog in a negative way.
17:12:17 <jsmith> puiterwijk: Please do :-)
17:12:20 <stickster_temp> If the bug prevented *ever* entering a password correctly this would be +1 blocker clearly. This seems like a minor annoyance and not a showstopper.
17:12:21 <bowlofeggs> sgallagh: ah good
17:12:27 <sgallagh> Or at least, only one of the two fields will have it happen, so they'll fail to match
17:12:33 <sgallagh> So we won't be saving a bad password
17:13:21 <puiterwijk> Huh. It's also when unlocking things in gnome-control-panel
17:13:33 <puiterwijk> But the password I changed is recorded correctly
17:13:40 <bowlofeggs> cool, i'm -1 then
17:13:53 <puiterwijk> So the password change is done correct. But gnome-control-panel has the same bug on first entry
17:14:00 <puiterwijk> So polkit has it too
17:14:19 <puiterwijk> Wow, I'm suddenly finding out I have not suddenly mistrained my fingers!
17:14:27 <mattdm> I'd like to have a reasonable confidence that we will be able to have a zero-day fix
17:14:28 <puiterwijk> I thought I'd been crazy for so long...
17:14:40 <mattdm> puiterwijk: you know these things aren't exclusive :)
17:14:46 <frantisekz> .hello2
17:14:47 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
17:14:50 <puiterwijk> mattdm: oh yeah, I know
17:14:51 <jsmith> mattdm: Do we have the right people in the conversation to have that confidence of a zero-day fix?
17:15:13 <lruzicka> What if not the first, but any other letter is capital? Does it also behave that way? I cannot try right now.
17:15:16 <mattdm> Do we have anyone from gnome here?
17:15:18 <sgallagh> jsmith: The right people are aware of the BZ, but I'm not sure they're present in this meeting
17:15:19 <jsmith> mattdm: As far as I can tell, we haven't even yet identified which component could be causing the issue.
17:15:33 <nirik> it's too early to tell much here I fear.
17:15:59 <adamw> i kinda suspect it'll get figured out, but hard to tell for sure.
17:16:01 <puiterwijk> lruzicka: it's just first character
17:16:40 <lruzicka> puiterwijk: interesting
17:16:45 <sgallagh> While this bug is clearly annoying, I don't think it's enough on its own to stop the release. So -1 from me.
17:16:55 * nirik is -1 on blocker also
17:17:00 <frantisekz> -1
17:17:00 <jkurik> -1 from me as well
17:17:10 * satellit_ -1
17:17:19 <lruzicka> I believe that it only affects passwords with the first capitalized letter, it will not be that many. -1 from me.
17:17:23 <puiterwijk> -1 blocker. +1 happy I've found this, and +50 happy I'm not mistyping my password twenty times a day!
17:17:33 <sumantro> -1
17:17:34 <mboddu> Its annoying but we can live with it, -1 Blocker
17:17:38 <puiterwijk> lruzicka: capitalized and anything that needs shift
17:17:56 <puiterwijk> i.e. it looks like shift is ignored in the first character of a password entry the first time
17:17:59 <mattdm> Okay, my "ship it" bias is leaning me into the consensus
17:18:02 <lruzicka> puiterwijk: but only at the first position, right?
17:18:06 <puiterwijk> lruzicka: correct
17:18:08 <stickster_temp> mattdm++ me too.
17:18:10 <puiterwijk> I was just typing that out :)
17:18:25 * puiterwijk now changes his password away from the tes tvalues to prevent forgetting it....
17:18:31 <adamw> i'm actually curious if it affects any other necessary modifiers too (alt-gr modifies the character typed in some keyboard layouts for e.g., i think) but eh
17:19:08 <lruzicka> adamw: I am using alt gr in passwords, but never at the first position, so I cannot tell here
17:19:17 <sgallagh> adamw: Is "eh" a "-1 blocker" vote?
17:19:20 <puiterwijk> I can probably try that if people want to know
17:19:32 <puiterwijk> I'm now forgetting my password anyway... One more attempt won't make it worse
17:19:41 * sgallagh notes that the GNOME folks in the BZ also voted -1 blocker
17:19:52 <adamw> proposed #agreed 1569211 - RejectedBlocker (Final) - there's a general feeling that this is bad but not *so* bad that it constitutes a serious enough criteria violation to abort the release at this point. most users who run into this will just assume they mistyped, and type again; it's not likely to lock anyone out of anything. We certainly hope that a fix for this can be made available as a 0-day blocker
17:19:54 <stickster_temp> mattdm: As for the "get it fixed soon" part -- I can guarantee you I will be among the people seeking a quick fix here. And I intend to be transparent about the problem in advance, to show the exact tiny corner we cut to make GA. (To be clear, I support -1 blocker 100% and would say that too.)
17:20:09 <sgallagh> adamw: ack
17:20:32 <stickster_temp> I have utmost confidence in mclasen & crew to get this sussed out and a fix ready
17:20:32 <jkurik> adamw: ack
17:20:33 <sumantro> ack
17:20:34 <frantisekz> ack
17:20:35 <mboddu> ack
17:20:38 <sgallagh> stickster++
17:20:38 <zodbot> sgallagh: Karma for pfrields changed to 19 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:20:39 <satellit_> ack
17:20:44 <langdon> puiterwijk just write it down
17:20:46 <jsmith> ACK
17:20:47 <puiterwijk> ack
17:20:47 <lruzicka> ack
17:20:55 <puiterwijk> .fire langdon
17:20:55 <zodbot> adamw fires langdon
17:20:56 * mclasen looks up
17:20:57 <mattdm> stickster_temp: yes, works for me.
17:21:05 <puiterwijk> langdon: no.
17:21:34 <kparal> ack
17:21:34 <adamw> #agreed 1569211 - RejectedBlocker (Final) - there's a general feeling that this is bad but not *so* bad that it constitutes a serious enough criteria violation to abort the release at this point. most users who run into this will just assume they mistyped, and type again; it's not likely to lock anyone out of anything. We certainly hope that a fix for this can be made available as a 0-day blocker
17:21:36 <sgallagh> langdon: How does Russ Doty say it? "A secure environment is one where the password sticky-note is in a drawer and in an ultra-secure environment the drawer is also locked"
17:21:45 * puiterwijk would find the inability to unlock a resumed system worse. But I have only hit that wit hrawhide
17:21:48 <stickster_temp> mclasen: q.v. the password bug we are not blocking GA on ... looking for a zero-day fix but I'm sure you know it already
17:21:54 <stickster_temp> (not the fix, that people are looking) :-D
17:21:55 <langdon> sgallagh: lol.. but the key should be in the lock of course
17:22:00 <adamw> puiterwijk: it affects unlock, we confirmed that in the bug.
17:22:03 <puiterwijk> langdon: I might actually have a sticky note on my display with a password. That passowrd might or might not actually work :)
17:22:08 <adamw> of course, second time you type it works.
17:22:13 <puiterwijk> adamw: right. I just mean that after resume, I cannot unlock *at all*
17:22:21 <puiterwijk> the shield just doesn't go away. But that's entirely different
17:22:23 <stickster_temp> good explanation adamw.
17:22:33 <langdon> puiterwijk: lol
17:22:53 <mclasen> stickster_temp: I saw something in passing, but I haven't looked myself
17:23:03 <sgallagh> puiterwijk: It probably works *somewhere*. There are billions of humans and we're not actually all that imaginative
17:23:23 <adamw> puiterwijk: oh, yeah. that's something else.
17:23:24 <langdon> you can always tell the correct sticky note because it is at the bottom of the pile of sticky notes
17:23:33 <puiterwijk> sgallagh: hah. I think I have a photo of the post-it somewhere. You can try to find where it works :)
17:23:45 <sgallagh> OK, so shall we move on?
17:23:53 <jkurik> adamw: are we going to discuss "#1537253 Add-On Modularity" ?
17:23:58 <stickster_temp> mclasen: I think there is a question as to what subsystem the bug exists in (ibus? gnome-shell?) -- but needs investigation -- BZ 1569211
17:23:59 <adamw> sure.
17:24:02 <stickster_temp> <eof>
17:24:03 <puiterwijk> adamw: yeah. And as said, I've only tried rawhide. Just never got to trying it on f28 yet. Just really, really annoying. (and I'll file it as proposed blocker for f29)
17:24:05 <adamw> #info we have one outstanding accepted blocker
17:24:16 <mclasen> ibus has no role in a password entry
17:24:20 <adamw> puiterwijk: i've been suspending and resuming f28 just fine, but if you want to test it...
17:24:25 <mclasen> at least  in gtk
17:24:36 <adamw> mclasen: this is gnome-shell's password entry, not gtk's.
17:24:37 <puiterwijk> adamw: I don't have f28 here, and I'm !home at the moment. But it's basically after undocking
17:24:42 <adamw> mclasen: we're discussing it in #fedora-desktop
17:24:51 <adamw> mclasen: the ibus possibility was suggested by garnacho
17:24:58 <adamw> puiterwijk: oh, docking fun.
17:24:59 <puiterwijk> So I lock, undock, open lid, and the shield just won't go away
17:25:04 <puiterwijk> adamw: yep!
17:25:12 <puiterwijk> Anyway, as said, unrelated to password entry.
17:25:14 <mattdm> -1 to docking problems. focccusssssss :)
17:25:16 * mclasen moves on and lets the experts handle it
17:25:31 <adamw> #topic (1537253) Add-On Modularity
17:25:31 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1537253
17:25:31 <adamw> #info Accepted Blocker, Changes Tracking, VERIFIED
17:25:44 <jkurik> so, the modularity seems to be working as expected now
17:25:57 <langdon> yep!
17:26:03 <jkurik> -1 to block on this
17:26:15 <mattdm> or rather: blocker resolved!
17:26:15 <adamw> #info once again for the record, FESCo has declared the Add-on Modularity feature as 'blocking' F28 release, this bug is being used to track whether the feature meets FESCo's stated requirements
17:26:35 <langdon> mattdm: yeah.. thats what i was confused about
17:27:25 <zbyszek> sgallagh: should we just make is CLOSED?
17:27:26 <nirik> right. Can close if it's been verified?
17:27:27 <lruzicka> there was a test day for this one, the results seemed pretty promising, as I remember
17:27:35 <lruzicka> sumantro: What do you think?
17:27:47 <sumantro> -1 to block on this one
17:28:01 <sgallagh> With both me and sumantro reporting it as passing the criteria, I'd say this is CLOSED CURRENTRELEASE
17:28:15 <jkurik> sgallagh: ack
17:28:18 <lruzicka> sgallagh: I agree
17:28:21 <nb> ack
17:28:24 <zbyszek> sgallagh: cool
17:28:30 * sumantro nods in agreement
17:28:31 <sgallagh> We're not voting on whether it's a blocker. It is, FESCo said so. We're accepting it as fixed :)
17:28:44 <nirik> right
17:28:44 <lruzicka> sgallagh: Yes, I agree with that.
17:29:10 <bowlofeggs> +1 to close currentrelease
17:29:37 <adamw> #info multiple testers report that Modularity does meet FESCo's requirements, so this blocker is considered addressed.
17:29:56 <langdon> adamw++
17:29:58 <zodbot> langdon: Karma for adamwill changed to 21 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:30:04 <adamw> we don't really need to worry about closing it or whatever (we'd have to check the Change process for when Change bugs are supposed to be closed), it just needs to be on record that it's addressed.
17:30:48 <jkurik> adamw: shall I move on ? That is all from the blockers, right ?
17:30:50 <zbyszek> adamw: I closed it. It seems OK to do that as with any other bug.
17:31:05 <adamw> that's all the blockers, yes.
17:31:13 <jkurik> #topic Test Matrices coverage
17:31:15 <jkurik> #link https://fedoraproject.org/wiki/Test_Results:Fedora_28_RC_1.1_Summary
17:31:15 <jsmith> Yay!
17:31:17 <sumantro> yaay!
17:31:29 <jkurik> so, how do we see the testing coverage ?
17:31:51 <adamw> zbyszek: well, https://fedoraproject.org/wiki/Changes/Policy should really document how and when Change bugs are closed, but it apparently...doesn't.
17:32:01 <adamw> it looks pretty good.
17:32:13 <sgallagh> jkurik: Usually with our eyes, or our fingers if using a braille device.
17:32:46 <nirik> ha. someone did the sas test. Kudos.
17:32:51 <adamw> note, i'm in the middle of re-doing the desktop_menus test for KDE, as i don't think "I  haven't tried all applications" is acceptable (the whole point of the test is to try all the applications)
17:33:11 * satellit_ note notes on my testing https://fedoraproject.org/wiki/Test_Results:Fedora_28_RC_1.1_Summary#Default_boot_and_install_.28x86_64.29
17:33:11 <nirik> FCoE is missing... thats a pretty fringe one tho
17:33:12 * adamw finds a working NNTP server. the things i do for my sins.
17:33:50 <adamw> nirik: we do have a story for FCoE...it's https://bugzilla.redhat.com/show_bug.cgi?id=1557655
17:34:16 <nirik> QA:Testcase_realmd_join_kickstart missing... hopefully that one is ok
17:34:20 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1557655#c28 tends to indicate it actually worked at 2018-04-10, though i should've asked lili to be a bit more explicit.
17:34:27 <adamw> nirik: hum, coconut should test that.
17:34:29 * adamw checks'
17:34:39 <nirik> AD one also
17:34:48 <nirik> QA:Testcase_domain_client_authenticate (Active Directory)
17:34:50 <langdon> adamw: i think microsoft has one :)
17:35:11 <adamw> nirik: it worked, https://openqa.fedoraproject.org/tests/229679 . i'll have to figure out why the result didn't make it to the wiki.
17:35:29 <adamw> nirik: sgallagh usually does the AD tests
17:35:30 <adamw> sgallagh?
17:35:31 <puiterwijk> adamw: maybe token expiry/blanking before you noticed?
17:35:42 <sgallagh> nirik: I can probably run the kickstart one in a few minutes if we're worried about it.
17:35:43 <langdon> you could probably get it from one of the warez news sites
17:35:43 <adamw> puiterwijk: i ran a blanket result report after we fixed that
17:35:49 <adamw> langdon: oh, nntp server :P
17:35:52 <puiterwijk> adamw: ah, okay. Then I don't know :)
17:36:40 <sgallagh> nirik: But in general if the cockpit one works and kickstart isn't otherwise broken, it's going to be fine
17:36:56 <nirik> sgallagh: how about the AD test?
17:37:05 <sgallagh> nirik: I did all of the other AD tests
17:37:09 <sgallagh> Did they not get marked?
17:37:50 <adamw> langdon: for the record, news.mixmin.net appears to work. :P
17:38:12 <adamw> sgallagh: we have had the kickstart test fail where others didn't in the past for...reasons. the installer env can strip files it needs to work, etc.
17:38:14 <sgallagh> Ah, looks like I forgot to mark QA:Testcase_domain_client_authenticate (Active Directory) but it passed
17:38:17 <langdon> adamw: yeah.. i think i mirror that one ...
17:38:25 * langdon kids
17:38:27 <nirik> sgallagh: yeah, that one. cool.
17:38:37 <sgallagh> nirik: That one is also Optional, FWIW
17:38:55 <sgallagh> adamw: OK, do we want to hold up the meeting while I run that test?
17:38:56 <adamw> wow, someone posted to alt.os.linux.fedora on 2017-12-26
17:39:01 <sgallagh> Should take about 10 minutes
17:39:12 <langdon> adamw: did mattdm reply?
17:39:13 <adamw> oh, yeah, anything Optional is ignorable.
17:39:19 <adamw> langdon: heh
17:39:28 <puiterwijk> adamw: did they upload pirated copies of our isos?
17:39:38 * langdon wonders if matrix bridges nntp
17:39:39 <adamw> puiterwijk: no, actual sane message about apper crashing.
17:39:39 <puiterwijk> (I've been told that that's the only use of NNTP these days)
17:39:47 <adamw> you were lied to!
17:39:55 <puiterwijk> Wow!
17:40:12 <adamw> sgallagh: you test, i'll keep them distracted with inane chatter
17:40:13 <langdon> puiterwijk: specifically pirated open source software?!?!
17:40:20 <langdon> adamw: i got you
17:40:25 <puiterwijk> nirik: how about we setup usenet.fedoraproject.org, and move all mailing lists there?
17:40:30 <puiterwijk> langdon: of course!
17:40:34 <langdon> puiterwijk++
17:40:45 <nb> puiterwijk++
17:40:51 <nb> puiterwijk, but, are you going to write basset for nntp?
17:40:53 <nirik> sure. we can use uucp to transfer the posts to other nodes.
17:41:04 <langdon> puiterwijk says to adamw: "here, hold my beer"
17:41:14 <stickster> Are we still meeting or is this now just fun chat? I'm OK either way, just want to know whether I should wander off.
17:41:22 <puiterwijk> stickster: we're waiting for some tests I think.
17:41:27 <jkurik> puiterwijk: shall not we run our own BBS ?
17:41:33 <mboddu> stickster: fun chat until sgallagh comes back with his test results
17:41:48 <stickster> okey doke, back in a few min
17:41:50 <bowlofeggs> if we run a BBS we need to host Exitilus (spelling?)
17:41:51 <bowlofeggs> or LORD
17:41:52 <puiterwijk> jkurik: I have some (bad) memories of phpBB.
17:41:55 <langdon> jkurik: single phone line please..
17:42:02 <adamw> stickster: i'm stalling while i run the kde menus test and sgallagh runs a kickstart test.
17:42:27 * puiterwijk does note that people probably want to be careful with encouraging me to do things... We might actually have usenet.fp.o before the end of the day... You can ask about anyone that I'll do it.
17:42:28 <adamw> oh good, KDE is up to shipping *three* web browsers on the live image now. this is certainly sane.
17:42:29 <nirik> well, openqa did pass the kickstart test I thought?
17:42:39 <adamw> nirik: openqa tests freeipa, not AD
17:42:56 <adamw> testing AD in openqa is kinda tricky because windows
17:43:04 <nirik> but sgallagh already did those?
17:43:07 <puiterwijk> adamw: oh, so workstation is lacking? I guess I'll need to find more browsers to add to it then. I'm sure we can go over 3
17:43:11 * nirik is confused which test sgallagh is doing
17:43:12 <adamw> he didn't do the kickstart one apparently.
17:43:17 <puiterwijk> nirik: kickstart one
17:43:19 <sgallagh> I'm doing the kickstart test right now
17:43:20 * stickster thinks back fondly to PCBoard
17:43:21 <adamw> nirik: kickstart enrolment to an AD server.
17:43:22 <sgallagh> Please hold
17:43:25 <bowlofeggs> puiterwijk: sudo dnf emerge usenet
17:43:27 <bowlofeggs> -y
17:43:34 <stickster> Oh, and WWIV. I liked that one a lot.
17:43:34 <puiterwijk> bowlofeggs: ... yeah. that.
17:43:40 <nirik> [10:38:14] <sgallagh> Ah, looks like I forgot to mark QA:Testcase_domain_client_authenticate (Active Directory) but it passed
17:43:50 <adamw> nirik: we've tested enrolment to an AD server in ways other than kickstart, and we've tested enrolment to a FreeIPA server via kickstart. but we haven't tested AD enrolment via kickstart. :P
17:43:53 <puiterwijk> For those who want something scary: https://github.com/puiterwijk/dnf-plugins-emerge
17:43:58 <adamw> nirik: that's not the kickstart test.
17:44:01 <sgallagh> nirik: That's a different one I forgot to mark
17:44:05 <stickster> puiterwijk: DO. NOT. WANT.
17:44:11 <nirik> ok.
17:44:30 <puiterwijk> stickster: I warned people: be careful with jokes around me. It actually works :)
17:45:19 <langdon> has anyone written a BBS (or nntp server for that matter) in js yet?
17:45:27 <jkurik> puiterwijk: count me in as a volunteer for testing
17:45:29 <bowlofeggs> lol
17:45:34 <bowlofeggs> (at JS bbs)
17:45:56 <puiterwijk> jkurik: Hah. You can file issues :)
17:45:57 <bowlofeggs> langdon: more like, has anyone written and rewritten 10 frameworks in JS for BBS's?
17:46:40 <langdon> we have a linux server in js.... kernel through bash.. i think it is a serious oversight that there is not a BBS or NNTP server for it
17:46:55 <mboddu> puiterwijk: That is something that I think I will never use, but probably test it for fun :)
17:47:11 <puiterwijk> langdon: something like https://nodebb.org/ ?
17:47:35 <langdon> puiterwijk: NICE
17:47:36 <puiterwijk> mboddu: yeah... Please don't use it on any serious system... It is probably somewhat reasonably sane, but you can get a seriously confused system
17:47:54 * puiterwijk gets memories of phpBB and closes that page and part of his memory
17:47:58 <langdon> ha
17:48:22 <mboddu> puiterwijk: Lets test f28 along with that and start filing bugs for adamw :D
17:48:23 <langdon> OMG.. it does not appear to be open sourcE?!?!
17:48:29 <puiterwijk> mboddu: haha.
17:48:38 <adamw> kde also ships a viewer for an ancient proprietary outlook attachment format because of course it does
17:48:53 <puiterwijk> langdon: https://github.com/NodeBB/NodeBB
17:49:15 <langdon> phew..
17:49:17 <stickster> langdon: puiterwijk: you want this, https://www.wwivbbs.org/
17:49:31 <puiterwijk> stickster: I am pretty sure I do not
17:49:35 <stickster> lol
17:49:41 <sgallagh> Test is almost done, looking good so far.
17:49:45 <stickster> I'm sure you want it just as much as nodeBB
17:49:47 * langdon goes to deploy
17:49:59 * puiterwijk waits for "dnf module enable nodebb"
17:50:05 <puiterwijk> or "dnf module enable emerge"
17:50:14 <puiterwijk> langdon: ^ there's your cue
17:50:18 <adamw> dnf module enable yak
17:50:19 <langdon> dnf emerge nodebb?
17:50:45 <stickster> oh, heads up that nirik and I have a meeting in 10 min
17:50:58 * nirik nods
17:51:02 <langdon> is it about deploying a bbs? cause if not, you should just cancel
17:51:07 * adamw checks how many more apps there are in this interminable goddamn list
17:51:17 <mboddu> langdon: haha :)
17:51:24 <stickster> if only
17:51:35 <stickster> adamw needs a bot minion
17:51:52 <adamw> stickster: i have several, they're just not very good at this.
17:51:59 <stickster> need moar minions
17:52:04 <langdon> seriously, who came up with this open source is a good thing idea .... now we have all this software!!
17:52:13 <sgallagh> .fire langdon
17:52:13 <zodbot> adamw fires langdon
17:52:19 <jkurik> nirik: if you go for a meeting, you might propose your Go or No-Go in advance :-)
17:52:20 <nirik> huh, I wonder if we could get somethiing like sellinium in jenkins to do these test
17:52:24 <stickster> langdon: it's for choice
17:52:27 <stickster> http://www.islinuxaboutchoice.com/
17:52:37 * langdon notes he has been fired twice in this meeting.. hmmm
17:52:43 * sgallagh wonders if he can .fire his boss...
17:53:01 <stickster> sgallagh: you can try, it's all about transparency
17:53:05 <sgallagh> haha
17:53:11 <langdon> 360 reviews!
17:53:18 <adamw> nirik: this is fundamentally a difficult test to automate because there are hundreds of apps on the workstation and kde lives, the loadout can and does change without warning, and *any* app can change its behaviour
17:53:18 <puiterwijk> sgallagh: I've had the reverse happen to me on IRC. And then got an explanation that it wasn't serious, just to make sure :)
17:53:24 <adamw> also just testing 'basic functionality' of some apps is tricky
17:53:35 <mattdm> Should we consider dropping the "test all the applications in the menu" criteria for kde in specific, given the large list of apps and the trickiness of testing?
17:53:38 <nirik> jkurik: sure. I see no blockers... if my capacity as fesco person, releng person, infra person I am all go. :)
17:53:38 <stickster> yeah, for sure
17:53:46 <sgallagh> OK, kickstart test has passed
17:53:49 <sgallagh> *phew*
17:53:49 <stickster> sorry, that was in response to adamw, not mattdm
17:53:51 <langdon> why are most of the best rants preserved on the internet by ajax?
17:53:53 <adamw> nirik: basically an 'automated' test which has to run and do some basic thing in 100+ apps is going to break *all the damn time* no matter whether its done in openqa or selenium or dogtail or anything
17:53:56 <stickster> cool, thanks sgallagh
17:54:08 <jkurik> nirik: thanks
17:54:10 <nirik> adamw: true.
17:54:10 <stickster> was that the only one we were waiting on?
17:54:21 <adamw> mattdm: it's a possibility. i would rather we try and get the kde folks to cut down the number of freaking things they ship
17:54:29 <adamw> stickster: i'm still mining through kde menus
17:54:32 <stickster> oh yeah
17:54:37 <stickster> that thing you keep saying sucks
17:54:38 <adamw> i'm about 60% done, haven't come across anything catastrophic yet
17:55:01 <adamw> we can probably just go ahead and sign the damn thing off
17:55:12 <sgallagh> Sounds good to me!
17:55:13 * mboddu cant keep up with the chat here
17:55:18 <adamw> i doubt anyone's going to block on "657th obscure app shipped by kde crashes" at this point anyway
17:55:18 * Southern_Gentlem thinks we need to have the SIGs do this testing in the future
17:55:24 <adamw> Southern_Gentlem: i've been trying that for years.
17:55:29 <langdon> adamw: are you just smoking each? or sometihng more?
17:55:31 <mattdm> adamw: Yeah, because if you come up with anything, it's going to have to be epicly bad for me not to say "SHIP IT ANYWAY"
17:55:45 <adamw> langdon: i run it and try to do at least *something* sane in it. then i quit and move onto the next.
17:55:55 <jkurik> adamw, sgallagh: thanks for the quick testing
17:56:08 <lruzicka> I think we should have a standard set of apps that we will test and forget about the rest.
17:56:20 <langdon> ahh.. yes.. hard to automate..
17:56:25 <smooge> maybe we could call it a core set of applications
17:56:28 <lruzicka> KDE uses many apps, while other desktops hardly use any
17:56:29 <sgallagh> adamw: I think it's time to ask FESCo for a resolution on KDE: "It only gets to be blocking if the criteria have been validated by KDE SIG members"
17:56:33 <adamw> lruzicka: the basic idea is that if anything that's right there in the default menus crashes, that's a bad look
17:56:40 <stickster> mboddu: the good news is, it's mostly irrelevant. one missing test is now verified OK by sgallagh, another is in progress by adamw and looking good
17:56:56 <stickster> this will be the most frustrating log for someone to read about this topic
17:56:57 <adamw> lruzicka: we're particuarly worried about reviewers happening to click the thing that crashes or is utterly broken and going 'oh my god they didn't even test the default apps, this is garbage'
17:57:12 <lruzicka> adamw: Yeah, that is right. But we will never be able to automate if there are variable apps in the menus
17:57:16 <stickster> let's let adamw finish his test :-)
17:57:23 <adamw> stickster: it'll take like another half an hour
17:57:28 <adamw> let's just assume it's gonna be good and move on
17:57:32 <adamw> i'll yell if i find anything hideous
17:57:37 <langdon> stickster: pshaw.. how can you tell mboddu that the discussion of a javascript implemmented bbs and nntp server is *irrelevant*
17:57:37 <jkurik> proposed #agreed Test matrices coverage is considered as sufficient for the F28 Final release.
17:57:42 <mboddu> stickster: Thank you for summerizing it for me :)
17:57:52 <lruzicka> ack
17:57:55 <sumantro> ack
17:58:03 <mboddu> ack
17:58:03 <adamw> ack
17:58:04 <stickster> .fire langdon
17:58:04 <zodbot> adamw fires langdon
17:58:11 <sgallagh> I'm personally okay with "If something in the remaining apps is broken, it's the KDE SIG's fault for not testing their own stuff" as an answer here.
17:58:16 <adamw> heh.
17:58:19 <puiterwijk> stickster: and that dnf-emerge is irrelevant?
17:58:22 <langdon> sgallagh: or 0 day
17:58:25 <mboddu> .hire more and faster minions for adamw
17:58:27 <zodbot> adamw hires more and faster minions for adamw
17:58:45 <sgallagh> langdon: That doesn't work for Live images, but regardless let's move on
17:58:57 * x3mboy is lurking
17:59:05 <langdon> sgallagh: ohh good point
17:59:20 <x3mboy> If we have a go I will need to expect the ISOs to take screenshots
17:59:24 <x3mboy> *sighs*
17:59:27 <Southern_Gentlem> sgallagh, sorry
17:59:46 <jkurik> sgallagh, langdon, puiterwijk ..... ack/patch ?
17:59:50 <puiterwijk> jkurik: ack
17:59:56 <Southern_Gentlem> ack
17:59:57 <sgallagh> jkurik: Oh, missed the proposal. Ack
18:00:05 <jkurik> #agreed Test matrices coverage is considered as sufficient for the F28 Final release.
18:00:11 * puiterwijk wasn't aware he got a vote :)
18:00:19 <sgallagh> Southern_Gentlem: FTR, I didn't mean that to come out as accusatory, just slightly frustrated :)
18:00:21 <jkurik> #topic Go/No-Go decision
18:00:28 * stickster dials into meeting
18:00:33 <langdon> ack
18:00:35 <jkurik> QE, FESCo, RelEng -> we need +1
18:00:44 <sgallagh> Wearing my FESCo hat: +1
18:00:45 <mboddu> ack
18:00:53 <mboddu> RelEng: +1
18:00:55 <langdon> puiterwijk: me either.. but i voted!
18:01:00 <jkurik> kparal, adamw ^^^
18:01:36 * nirik already voted go
18:01:55 <sumantro> +1 from my end
18:02:18 <stickster> PUNCH IT, ETHEL
18:02:29 <kparal> +1 from me, but waiting for adamw
18:03:06 <lruzicka> +1 for go
18:03:25 <adamw> +1
18:03:27 <jkurik> proposed #agreed The Fedora_28_RC_1.1 is considered as GOLD and we are going to ship it on May 1st, 2018
18:03:30 * adamw reads what he just voted for
18:03:32 <adamw> oh, that. okay.
18:03:34 <stickster> lol
18:03:35 <puiterwijk> ack
18:03:37 <mboddu> ack
18:03:40 <lruzicka> ack
18:03:42 <mattdm> ACK!
18:03:43 <sumantro> ack
18:03:44 <bowlofeggs> +1 from me
18:03:53 <sgallagh> ack
18:03:56 <langdon> ackity ack, don't ack back
18:04:11 <sgallagh> and when you're finished doing acks...
18:04:28 <jkurik> #agreed The Fedora_28_RC_1.1 is considered as GOLD and we are going to ship it on May 1st, 2018
18:04:34 * lruzicka is going to open a bottle today evening.
18:04:38 <jkurik> #action jkurik to publish the Go/No-Go result
18:04:48 <jkurik> #topic Open floor
18:04:54 <jkurik> anything else to discuss today on this meeting ?
18:05:18 <sgallagh> High-fives all around?
18:05:19 <jkurik> ... or shall I already finish the bottle of wine ? :-)
18:05:20 <Southern_Gentlem> thank you all for your hardwork and getting f28 out the door before June
18:05:20 <puiterwijk> Congrats everyone. Nice work :)
18:05:35 <puiterwijk> sgallagh: absolutely
18:05:44 <mattdm> Yes. THANK YOU EVERYONE
18:05:46 <mboddu> Nice work everyone
18:05:53 <mboddu> Everyone++
18:05:54 <stickster> mattdm: NOW I GIVE YOU PERMISSION TO DIE
18:05:54 <nirik> many kudos to all involved
18:05:58 <lruzicka> Thank you to all.
18:06:31 <langdon> +1 to everyone.. I certainly appreciate all the hard work!
18:06:31 <puiterwijk> Go, Fedora 28, Go. Take over the world!
18:06:38 <x3mboy> Cool!!!!!!!!!!!!!!!!!!!!
18:06:43 <bt0> Awesome
18:06:46 <jkurik> if there is no topic, I will close the meeting in 1 minute....
18:06:56 <mboddu> puiterwijk: And EOL in 13 months :)
18:07:06 * stickster notes, mattdm has now FPL'd something that no FPL has done in at least 8 years
18:07:13 <puiterwijk> mboddu: sshh. :)
18:07:20 <langdon> stickster: ha
18:07:50 <nirik> well, we did slip a week at beta... even tho we added a planned slip week
18:08:01 <jkurik> #endmeeting