f28-beta-go-no-go-meeting
MINUTES

#fedora-meeting-1: F28 Beta Go/No-Go meeting

Meeting started by jkurik at 17:00:03 UTC (full logs).

Meeting summary

  1. Roll Call (jkurik, 17:00:16)
  2. Purpose of this meeting (jkurik, 17:01:22)
    1. Purpose of this meeting is to check whether or not F28 Beta is ready for shipment, according to the release criteria. (jkurik, 17:01:28)
    2. This is determined in a few ways: (jkurik, 17:01:34)
    3. * No remaining blocker bugs (jkurik, 17:01:41)
    4. * Release candidate compose is available (jkurik, 17:01:46)
    5. * Test matrices for Beta are fully completed (jkurik, 17:01:53)

  3. Current status (jkurik, 17:01:59)
    1. https://qa.fedoraproject.org/blockerbugs/milestone/28/beta/buglist (jkurik, 17:02:25)
    2. The RC for F28 Beta is not yet ready (jkurik, 17:03:25)
    3. https://qa.fedoraproject.org/blockerbugs/milestone/28/beta/buglist - F28 Blockers (jkurik, 17:03:33)
    4. As we have no RC there are subsequently no Test Matrices for the F28 Beta RC (jkurik, 17:03:43)

  4. Mini-Blocker Review (jkurik, 17:04:05)
  5. (1558906) AttributeError: 'DiskDevice' object has no attribute 'isDisk' (adamw, 17:04:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1558906 (adamw, 17:04:54)
    2. Proposed Blocker, anaconda, ON_QA (adamw, 17:04:54)
    3. AGREED: 1558906 - AcceptedBlocker (Beta) - accepted as a violation of "The installer must be able to detect and install to hardware or firmware RAID storage devices" (adamw, 17:09:08)

  6. (1559180) hangs on launch (adamw, 17:09:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1559180 (adamw, 17:09:17)
    2. Proposed Blocker, anaconda, NEW (adamw, 17:09:17)
    3. AGREED: 1559180 - RejectedBlocker (Beta) - no-one else is able to reproduce this in testing on various systems, so it does not appear to be a blocker (adamw, 17:14:08)

  7. (1557659) aacraid: Host adapter abort request (adamw, 17:15:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1557659 (adamw, 17:15:21)
    2. Proposed Blocker, kernel, NEW (adamw, 17:15:21)
    3. AGREED: 1557659 - RejectedBlocker (Beta) - this is specific to one particular type of RAID adapter, and we have a reasonable workaround, so we don't consider this a serious enough violation to be a Beta blocker (adamw, 17:19:07)

  8. (1559174) Locally-changed booleans not preserved on upgrade from F27 to F28, cannot be set permanently after upgrade (adamw, 17:19:15)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1559174 (adamw, 17:19:15)
    2. Proposed Blocker, policycoreutils, MODIFIED (adamw, 17:19:15)
    3. AGREED: 1559174 - AcceptedBlocker (Beta) - accepted as a violation of the upgrade criteria applied to release-blocking server roles (as noted in the bug) (adamw, 17:23:06)
    4. doing proposed freeze exceptions quickly (adamw, 17:25:17)

  9. (1559188) Failed to initialize security module (adamw, 17:25:29)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1559188 (adamw, 17:25:29)
    2. Proposed Freeze Exceptions, abrt, NEW (adamw, 17:25:29)
    3. AGREED: 1559188 - AcceptedFreezeException (Beta) - this would ease reporting of crashes on live images, and immediately after install (adamw, 17:28:45)

  10. (1557511) annobin: failure building wxGTK3 in F28 (adamw, 17:28:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1557511 (adamw, 17:28:53)
    2. Proposed Freeze Exceptions, annobin, ON_QA (adamw, 17:28:54)
    3. AGREED: 1557511 - AcceptedFreezeException (Beta) - this is accepted as a freeze exception on the basis it's needed to build some packages, and pulling it in as an FE rather than using a buildroot override keeps the contents of the composes more consistent (adamw, 17:38:22)

  11. (1466093) Decommissioning domain controller role fails when role deployed on Fedora 25 then system upgraded to Fedora 26 (adamw, 17:38:53)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1466093 (adamw, 17:38:53)
    2. Proposed Freeze Exceptions, firewalld, MODIFIED (adamw, 17:38:53)
    3. AGREED: 1466093 - AcceptedFreezeException (Beta) - decommissioning isn't actually part of the release criteria, but is a significant function of server roles, and pulling this in will improve openQA test coverage (adamw, 17:48:27)

  12. (1546743) gfortran internal compiler error when compiling cp2k-5.1 on ppc64le (adamw, 17:48:35)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1546743 (adamw, 17:48:35)
    2. Proposed Freeze Exceptions, gcc, NEW (adamw, 17:48:35)
    3. AGREED: 1546743 - AcceptedFreezeException (Beta) - accepted on the same principle as the annobin bug (1557511) - buildroot/compose consistency (adamw, 17:59:06)

  13. (1558510) "Star" feature missing in Nautilus (adamw, 17:59:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1558510 (adamw, 17:59:14)
    2. Proposed Freeze Exceptions, nautilus, NEW (adamw, 17:59:14)
    3. AGREED: 1558510 - punt (delay decision) - we suspect there's actually no bug here, but we agreed to just punt it till Monday's meeting, hopefully by then it'll be clear whether there's actually a bug and it merits FE status (adamw, 18:05:21)

  14. Test Matrices coverage (jkurik, 18:05:33)
    1. As there is no RC yet, Test matrices are not ready as well (jkurik, 18:05:37)
    2. We are skipping the Test Matrices coverage check (jkurik, 18:05:43)

  15. Go/No-Go decision (jkurik, 18:05:49)
    1. AGREED: Due to missing RC for the F28 Beta release and presence of blocker bugs, the decision is “No Go”. The Beta release slips for one week to “Target #1” date (April 3rd). We are not going to slip the Final GA yet. (jkurik, 18:07:50)
    2. ACTION: jkurik to publish the Go/No-Go result (jkurik, 18:07:59)
    3. ACTION: jkurik to organize second round of Go/No-Go meeting for F28 Beta on Thursday, March 29th at 17:00UTC (jkurik, 18:08:07)

  16. Open floor (jkurik, 18:08:12)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1559341 (adamw, 18:10:38)

  17. SELinux blocks bluetooth from working (jkurik, 18:11:26)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1559341 (jkurik, 18:11:33)
    2. AGREED: 1559341 - AcceptedFreezeException (Beta) - this is a significant functionality issue that will affect lives etc., would be good to fix it for the compose (adamw, 18:14:08)


Meeting ended at 18:16:25 UTC (full logs).

Action items

  1. jkurik to publish the Go/No-Go result
  2. jkurik to organize second round of Go/No-Go meeting for F28 Beta on Thursday, March 29th at 17:00UTC


Action items, by person

  1. jkurik
    1. jkurik to publish the Go/No-Go result
    2. jkurik to organize second round of Go/No-Go meeting for F28 Beta on Thursday, March 29th at 17:00UTC


People present (lines said)

  1. adamw (158)
  2. jkurik (70)
  3. sgallagh (38)
  4. nirik (38)
  5. mboddu (32)
  6. bowlofeggs (26)
  7. frantisekz (22)
  8. zodbot (16)
  9. kparal (16)
  10. jsmith (8)
  11. x3mboy (6)
  12. mattdm (3)


Generated by MeetBot 0.1.4.