serversig
LOGS
21:00:06 <sgallagh> #startmeeting Fedora Server SIG Weekly Meeting (2018-02-13)
21:00:06 <zodbot> Meeting started Tue Feb 13 21:00:06 2018 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:06 <zodbot> The meeting name has been set to 'fedora_server_sig_weekly_meeting_(2018-02-13)'
21:00:06 <sgallagh> #meetingname serversig
21:00:06 <zodbot> The meeting name has been set to 'serversig'
21:00:06 <sgallagh> #topic Roll Call
21:00:15 <sgallagh> .hello 2
21:00:16 <zodbot> sgallagh: Sorry, but you don't exist
21:00:18 <sgallagh> .hello2
21:00:19 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
21:00:34 <mjwolf> .hello2
21:00:35 <zodbot> mjwolf: mjwolf 'Michael Wolf' <mjw@linux.vnet.ibm.com>
21:02:19 * sgallagh hopes more people show up
21:03:39 <nirik> morning
21:03:45 <sgallagh> Hello nirik
21:04:10 <langdon> .hello2
21:04:11 <sgallagh> jds2001, langdon?
21:04:12 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
21:04:26 <sgallagh> OK, I think that's enough to get started at least.
21:04:30 <sgallagh> #topic Agenda
21:04:34 <sgallagh> #info Agenda Item: Modular Repo By Default
21:04:37 <sgallagh> #info Agenda Item: Module-creator Conscription
21:04:44 * langdon 's prior meeting running a little long but can multitask
21:04:55 <sgallagh> Those are the two items I sent out earlier today. Anyone have other topics they'd like to discuss today>
21:06:58 <sgallagh> I'll take that as a "no"
21:07:02 <sgallagh> #topic Modular Repo By Default
21:07:07 <nirik> +1 to that here.
21:07:21 <sgallagh> I don't expect this to be contentious
21:07:42 <sgallagh> Proposal: Fedora Server Edition will ship the Fedora Modular repository configuration as enabled and available by default.
21:07:45 <sgallagh> +1
21:08:08 <langdon> +1
21:09:03 <mjwolf> +1
21:09:44 <sgallagh> #agreed Fedora Server Edition will ship the Fedora Modular repository configuration as enabled and available by default. (+4, 0, -0)
21:09:53 <sgallagh> #topic Module-creator Conscription
21:10:12 <sgallagh> So, with that decision in mind, I want us to start a recruitment/conscription effort
21:10:42 <sgallagh> I've sent out a straw-man for a message I want to send to devel-announce. I'm sure it needs word-smithing.
21:11:04 <sgallagh> But the gist of it is that I want to try to get as many people to build modules for F28 release as possible.
21:11:23 <sgallagh> The low-hanging fruit is the stuff they'll already be maintaining in some other branch, so I figure that's a good place to start.
21:11:53 <langdon> sgallagh: i think i have recruited a few people (dbs, languages, etc) that should be showing up soon
21:12:01 <mjwolf> so I thought the idea of the modules was to group packages.  If the package maintainers make modules for each is that what you wanted?
21:12:14 <mjwolf> or did I misunderstand things
21:12:17 <nirik> I don't suspect it's going to be super popular, but yeah, packages with multiple stable streams...
21:13:18 <sgallagh> mjwolf: Grouping packages is one benefit, handling multiple stable streams is the other
21:13:33 <mjwolf> ah ok
21:14:28 <sgallagh> In my representative example, it's going to let us ship both LTS streams of Node.js, plus the development stream
21:15:56 <sgallagh> (Sorry, multi-tasking)
21:16:01 * nirik wonders if he will have time to make a Xfce 4.13 one. That might be of interest to some people.
21:16:07 <sgallagh> So my question to the SIG is how we do this right?
21:16:23 <sgallagh> How do we pose the request and get the outcome we desire
21:16:41 <sgallagh> Ideally without the usual participants drowning out the attempt
21:16:49 <nirik> have a well documented process and some examples and sell it to the people who we want to make these.
21:18:01 <sgallagh> langdon: Do I recall you have a (draft?) process document somewhere?
21:19:28 <langdon> sgallagh: no.. i am supposed to be writing one... but progress thus far = 0
21:20:07 <sgallagh> langdon: If we want to have anything meaningful in Fedora 28 by Beta, I think that has to happen this week.
21:20:11 <sgallagh> Agree or disagree?
21:20:51 <langdon> sgallagh: well.. it is just a simplicfication of the existing process, right? so ... would be nice.. but not nec.
21:21:18 <sgallagh> langdon: I think simplification is necessary if adoption is our goal.
21:21:21 <sgallagh> Which it is.
21:23:32 <sgallagh> I don't have time this week to write another one of those instructional blog posts, unfortunately. And I'm on PTO next week.
21:23:50 <sgallagh> (I will, in fact, be skipping this meeting to have dinner with a certain cartoon mouse)
21:24:18 <langdon> well.. i can buckle down on the writing
21:25:16 <sgallagh> Thanks
21:25:38 <sgallagh> I'll attempt to write a blog post about it when I return the following week.
21:26:13 <sgallagh> I was hoping to get an announcement out this week encouraging people to join us, but after this conversation,  I'm not certain if we're ready for the general announcement yet
21:27:22 <sgallagh> So for the moment, perhaps our plan of attack is to go to those teams that langdon identified and get them started (hand-holding included).
21:27:42 <sgallagh> And aim for the general announcement around the end of the month?
21:27:49 * nirik nods. sounds reasonable
21:27:57 <sgallagh> We might not get a ton of contributions in time for the Beta, but we still have some time until Final
21:29:36 <sgallagh> #info Plan of action is to approach targeted groups and assist them with making module streams for F28 Beta. Documentation will be improved in parallel and we will make a general availability announcement for module packaging at the end of February.
21:30:01 * sgallagh is tempted to #action nirik will modularize XFCE 4.13 ... but doesn't
21:30:16 <nirik> ha. yeah not sure I will have time...
21:30:28 <nirik> but if I do I can try
21:31:17 <sgallagh> Thanks. That would be a really compelling one, because it would showcase the grouping aspect too.
21:31:46 <sgallagh> I'd love for KDE to take this approach (/me nudges rdieter), because I think it will actually help make their usual major-upgrade transitions more clean.
21:31:59 <sgallagh> But I recognize that KDE is going to be one of the hardest cases.
21:32:49 <sgallagh> #topic Next Meeting
21:33:28 <sgallagh> So, I've noticed our attendance is pretty far down; is it perhaps time to toss another WhenIsGood out there and see if there is a more optimal meeting time?
21:33:40 <sgallagh> Among other things, this time is garbage for anyone in CZ
21:34:24 <sgallagh> I'm going to be away next week anyway, so it would give us some time to get answers on the WhenIsGood
21:35:33 <nirik> sure we could do that
21:35:50 <mjwolf> sounds fine
21:35:52 <sgallagh> OK, I'll send something out post-meeting. We'll aim for something more Europe-friendly if possible
21:36:16 <sgallagh> #action sgallagh to send out a new meeting time request
21:36:22 <sgallagh> #topic Open Floor
21:36:25 <sgallagh> Anything for open floor?
21:37:10 <langdon> sgallagh: just a note.. i think we have a number of modules building in fedora that just haven''t been added to the compose
21:37:18 <langdon> i have started poking people about that today
21:37:58 <sgallagh> langdon: We don't have a modular compose at all yet (so far as I know)
21:38:23 <langdon> sgallagh: ohh.. not even one off to the side? i thought it was being composed just not integrated
21:38:32 <nirik> yeah, needs a new pungi release + config changes
21:38:46 <sgallagh> langdon: No, the only one I know of is the one I've done manually with ODCS and stuck on my fpeople space
21:39:33 <langdon> ick
21:40:21 <sgallagh> I work with what I have.
21:40:26 <langdon> :(
21:41:34 <sgallagh> OK, anything else?
21:43:06 <sgallagh> Thanks for coming, folks.
21:43:09 <sgallagh> #endmeeting