f27-final-and-server-beta-go-no-go-meeting
MINUTES

#fedora-meeting-1: F27 Final and Server Beta Go/No-Go meeting

Meeting started by jkurik at 17:00:17 UTC (full logs).

Meeting summary

  1. Roll Call (jkurik, 17:00:29)
  2. Purpose of this meeting (jkurik, 17:02:40)
    1. Purpose of this meeting is to check whether or not F27 Final and F27 Server Beta are ready for shipment, according to the release criteria. (jkurik, 17:02:47)
    2. This is determined in a few ways: (jkurik, 17:02:54)
    3. * Release candidate compose is available (jkurik, 17:02:59)
    4. * No remaining blocker bugs (jkurik, 17:03:05)
    5. * Test matrices are fully completed (jkurik, 17:03:09)

  3. Current status (jkurik, 17:03:15)
    1. https://kojipkgs.fedoraproject.org/compose/27/Fedora-27-20171101.0/ RC for the F27 Final (jkurik, 17:05:04)
    2. https://fedoraproject.org/wiki/Test_Results:Fedora_27_RC_1.2_Base Test matrices for the F27 Final (jkurik, 17:05:09)
    3. RC for the F27 Server Beta is not yet ready. (jkurik, 17:05:15)
    4. As we have no RC for F27 Server Beta there are subsequently no Test Matrices for the F27 Server Beta. (jkurik, 17:05:20)

  4. F27-blocker-review (kparal, 17:10:25)
  5. Introduction (kparal, 17:10:42)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (kparal, 17:10:42)
    2. We'll be following the process outlined at: (kparal, 17:10:42)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (kparal, 17:10:42)
    4. The bugs up for review today are available at: (kparal, 17:10:44)
    5. http://qa.fedoraproject.org/blockerbugs/current (kparal, 17:10:46)
    6. The criteria for release blocking bugs can be found at: (kparal, 17:10:48)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (kparal, 17:10:50)
    8. https://fedoraproject.org/wiki/Fedora_27_Beta_Release_Criteria (kparal, 17:10:52)
    9. https://fedoraproject.org/wiki/Fedora_27_Final_Release_Criteria (kparal, 17:10:54)
    10. 7 Proposed Blockers (kparal, 17:11:23)
    11. 5 Accepted Blockers (kparal, 17:11:23)
    12. 0 Accepted 0-day Blockers (kparal, 17:11:23)
    13. 0 Accepted Previous Release Blockers (kparal, 17:11:23)
    14. 2 Proposed Freeze Exceptions (kparal, 17:11:23)
    15. 6 Accepted Freeze Exceptions (kparal, 17:11:23)

  6. (1508706) No longer works with USB webcam 19ff:0103 , error "Tried to capture in BGR3, but device returned format YUYV" (kparal, 17:11:33)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1508706 (kparal, 17:11:33)
    2. Proposed Blocker, cheese, NEW (kparal, 17:11:33)
    3. AGREED: 1508706 - RejectedBlocker AcceptedFreezeException (Final) - this seems to be hardware dependent, so far about 20% of tested cameras were affected. We think this is a low enough failure rate to not consider this a release-blocking issue, but important enough to be worth an FE if the release slips. (adamw, 17:18:42)

  7. (1508808) dbxtool service fails to start - EFI Signature List is malformed (adamw, 17:19:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1508808 (adamw, 17:19:07)
    2. Proposed Blocker, dbxtool, NEW (adamw, 17:19:07)
    3. AGREED: 1508808 - RejectedBlocker RejectedFreezeException (Final) - this seems to only affect a minority of UEFI installs, based on current information. the practical consequences of the failure are not too terrible and can be fixed with a post-release update, so given the limited breadth of impact we don't believe this qualifies as a release blocking issue. (adamw, 17:25:36)

  8. (1508794) systemd/dracut doesn't wait for mediacheck to finish (adamw, 17:25:51)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1508794 (adamw, 17:25:52)
    2. Proposed Blocker, dracut, POST (adamw, 17:25:52)
    3. AGREED: 1508794 - AcceptedBlocker (Final) - this is a conditional violation of the requirement that images boot by default. we believe it will be encountered sufficiently often in the real world, and leave a bad enough impression when it does happen, to accept it as a blocker. (adamw, 17:33:02)

  9. (1469813) [abrt] gnome-shell: _g_log_abort(): gnome-shell killed by signal 5 (adamw, 17:34:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1469813 (adamw, 17:34:56)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 17:34:57)
    3. AGREED: 1469813 - punt (delay decision) - this is a rather complex report with probably multiple different problems bundled up together, we don't yet really have the information to make a determination (adamw, 17:43:02)

  10. (1486002) grub2-mkconfig does not work if xen.gz is installed. (adamw, 17:43:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1486002 (adamw, 17:43:14)
    2. Proposed Blocker, grub2, NEW (adamw, 17:43:14)
    3. AGREED: 1486002 - RejectedBlocker RejectedFreezeException (Final) - best information at present is that Xen UEFI installs have never worked. given this, we don't think it makes sense to treat this as a last-minute release blocking bug, or grant a freeze exception. If this turns out to be incorrect, we will re-evaluate. (adamw, 17:51:03)

  11. (1507931) Missing cursor with latest kernel in QXL+SPICE VM (adamw, 17:51:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1507931 (adamw, 17:51:12)
    2. Proposed Blocker, kernel, NEW (adamw, 17:51:12)
    3. AGREED: 1507931 - RejectedBlocker AcceptedFreezeException (Final) - we agreed that this doesn't really break things enough to constitute a violation of the criteria, navigating gdm with a keyboard is easy and there are workarounds like using a different video adapter. However, it's visible enough to be worth fixing if the fix is not too complex (adamw, 17:58:18)

  12. (1508899) Non-live Fedora 27 installs fail on Macs (adamw, 17:58:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1508899 (adamw, 17:58:24)
    2. Proposed Blocker, mactel-boot, NEW (adamw, 17:58:24)
    3. AGREED: 1508899 - AcceptedBlocker (Final) - accepted as a blocker as a violation of Basic criterion "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces", for installs to Mac (which is a supported platform) using the Workstation and Everything netinst images (which are release-blocking) (adamw, 18:10:28)
    4. that's all the proposed Final blockers (adamw, 18:12:20)
    5. there is one proposed Server Beta blocker (adamw, 18:12:26)

  13. (1508576) freeipa module installation fails (adamw, 18:12:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1508576 (adamw, 18:12:30)
    2. Proposed Blocker, fedora-modular-release, ASSIGNED (adamw, 18:12:30)
    3. AGREED: 1508576 - AcceptedBlocker (Server Beta) - clear violation of Basic criterion "Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried" (adamw, 18:14:11)
    4. that's all proposed blockers (adamw, 18:15:40)

  14. Test Matrices coverage (jkurik, 18:16:20)
    1. https://fedoraproject.org/wiki/Test_Results:Fedora_27_RC_1.2_Base Test matrices for the F27 Final (jkurik, 18:16:28)
    2. The coverage of matrices is considered as sufficient (jkurik, 18:24:33)
    3. As there is no RC For F27 Server Beta Test matrices are not ready as well and we are skipping the Test Matrices coverage check for the F27 Server Beta Release. (jkurik, 18:24:48)

  15. Go/No-Go decision (jkurik, 18:25:00)
    1. https://taiga.fedorainfracloud.org/project/acarter-fedora-docker-atomic-tooling/epic/857 (mattdm, 19:28:00)
    2. AGREED: We keep the meeting open till Friday, November 3rd, 17:00UTC when we re-evaluate status of blockers and we make the final decision. (jkurik, 19:36:35)
    3. Kohane will run the Go/No-Go meeting on the Friday as jkurik is not available (jkurik, 19:36:43)
    4. both the blockers for which RC-1.3 was built - #1508899 and #1508794 - are verified resolved in RC-1.3 (adamw, 17:10:55)
    5. moving onto proposed blockers (adamw, 17:12:27)

  16. (1469813) [abrt] gnome-shell: _g_log_abort(): gnome-shell killed by signal 5 (adamw, 17:12:46)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1469813 (adamw, 17:12:46)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 17:12:46)
    3. https://bugzilla.redhat.com/show_bug.cgi?id=1509086 (adamw, 17:20:12)
    4. AGREED: 1469813 - RejectedBlocker (Final) - turns out that many unrelated crash reports have been marked as duplicates of this one due to a libreport issue (#1509086). the actual original crash here is clearly too rare to constitute a release blocker. for the record, we also have no indication that any of the dupes is important enough to merit blocker status at this time. (adamw, 17:26:31)

  17. (1193590) Allow bash to have a default profile without the 'rootfiles' package (adamw, 17:26:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1193590 (adamw, 17:26:45)
    2. Proposed Blocker, bash, ON_QA (adamw, 17:26:45)
    3. AGREED: 1193590 - AcceptedBlocker (Final) - this is accepted as a critpath bug that "has a severity rating of high or greater and no reasonable workaround" and "cannot be fixed with a future stable update"; we don't see any reasonable way to ship the bash in RC-1.3 and change the behaviour with a post-release update, and we agree that the current behaviour is too problematic and must be reverted. (adamw, 17:50:24)
    4. https://pagure.io/fesco/issue/974 FYI (nirik, 17:55:22)

  18. Open Floor (nirik, 17:57:02)
  19. Formal Go / No Go decision (nirik, 17:58:47)
    1. AGREED: f27 is no-go due to an outstanding blocker bug. We will slip 1 week. (nirik, 18:03:52)

  20. Open Floor (nirik, 18:03:59)
    1. we have some FEs to consider, so let's do a quick FE review (adamw, 18:13:42)

  21. (1469813) [abrt] gnome-shell: _g_log_abort(): gnome-shell killed by signal 5 (adamw, 18:13:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1469813 (adamw, 18:13:48)
    2. Proposed Freeze Exceptions, gnome-shell, NEW (adamw, 18:13:48)
    3. AGREED: 1469813 - RejectedFreezeException (Final) - the actual original reported crash here is quite rare and we have no information on any possible safe fix for it (adamw, 18:17:43)

  22. (1507420) LDB / Samba module version mismatch (adamw, 18:17:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1507420 (adamw, 18:17:50)
    2. Proposed Freeze Exceptions, samba, MODIFIED (adamw, 18:17:50)
    3. AGREED: 1507420 - RejectedFreezeException (Final) - to our best understanding, there is no need for a freeze exception to fix incompatibility between libldb and samba, the versions in stable are consistent. the update is internally consistent and can happily be shipped as a regular post-release update. (adamw, 18:22:13)

  23. (1446934) Failure to import Box2D in Sugar Physics (adamw, 18:22:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1446934 (adamw, 18:22:28)
    2. Proposed Freeze Exceptions, sugar-physics, ON_QA (adamw, 18:22:28)
    3. AGREED: 1446934 - AcceptedFreezeException (Final) - this fixes an issue in a non-blocking spin that would be a blocker in a blocking spin, and the fix is clearly limited to only affecting Sugar, so should be quite safe (adamw, 18:25:14)
    4. now taking a quick look at a couple of accepted freeze exceptions with fixes to get opinions on whether to include them in RC-1.4 (adamw, 18:25:45)

  24. (1506802) glibc: Fix regression in handling of x86_64 subdirectories in the ld.so search path (adamw, 18:25:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1506802 (adamw, 18:25:50)
    2. Accepted Freeze Exceptions, glibc, MODIFIED (adamw, 18:25:50)
    3. we're inclined not to pull this into RC-1.4 because...glibc (adamw, 18:32:47)

  25. (1508706) No longer works with USB webcam 19ff:0103 , error "Tried to capture in BGR3, but device returned format YUYV" (adamw, 18:35:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1508706 (adamw, 18:35:22)
    2. Accepted Freeze Exceptions, v4l-utils, ON_QA (adamw, 18:35:22)
    3. we don't have terribly strong opinions on this, no-one's super enthusiastic about pulling it in or super opposed to it (adamw, 18:46:20)

  26. Open floor redux (adamw, 18:52:36)


Meeting ended at 19:03:15 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (391)
  2. nirik (144)
  3. Kohane (139)
  4. jkurik (114)
  5. mattdm (97)
  6. mboddu (73)
  7. kparal (68)
  8. sgallagh (45)
  9. zodbot (28)
  10. langdon (26)
  11. Kellin (22)
  12. puiterwijk (20)
  13. dustymabe (19)
  14. frantisekz (9)
  15. coremodule (8)
  16. situ (6)
  17. pbrobinson (5)
  18. lailah (5)
  19. mkolman (4)
  20. rdieter (3)
  21. nb (3)
  22. dowdle (3)
  23. smooge (3)
  24. pwhalen (2)
  25. contyk (2)
  26. kalev (2)
  27. Zy3hZ2L8 (2)
  28. rashmi (1)
  29. sumantrom[m] (1)
  30. ignatenkobrain (1)


Generated by MeetBot 0.1.4.