f27-server-beta-go-no-go-meeting
LOGS
17:00:08 <jkurik> #startmeeting F27 Server Beta Go/No-Go meeting - 2nd round
17:00:08 <zodbot> Meeting started Thu Oct 19 17:00:08 2017 UTC.  The chair is jkurik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:08 <zodbot> The meeting name has been set to 'f27_server_beta_go/no-go_meeting_-_2nd_round'
17:00:16 <jkurik> #meetingname F27-Server-Beta-Go-No-Go-meeting
17:00:16 <zodbot> The meeting name has been set to 'f27-server-beta-go-no-go-meeting'
17:00:24 <jkurik> #chair dgilmore nirik adamw sgallagh mboddu tmlcoch rnargund
17:00:24 <zodbot> Current chairs: adamw dgilmore jkurik mboddu nirik rnargund sgallagh tmlcoch
17:00:32 <jkurik> #topic Roll Call
17:00:36 <jkurik> .hello2
17:00:36 <sgallagh> .hello2
17:00:37 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
17:00:40 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:01:10 <mboddu> .hello mohanboddu
17:01:11 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
17:01:11 <mattdm> .hello2
17:01:11 <contyk> .hello psabata
17:01:14 <zodbot> mattdm: mattdm 'Matthew Miller' <mattdm@mattdm.org>
17:01:17 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
17:01:20 <tmlcoch> .hello2
17:01:34 <nirik> morning
17:01:41 <zodbot> tmlcoch: tmlcoch 'Tomas Mlcoch' <tmlcoch@redhat.com>
17:01:45 <jkurik> Hi everybody
17:01:50 * threebean waves
17:02:04 <jkurik> Do we have someone from QA ? adamw, kparal, pschindl ?
17:02:08 <langdon> .hello2
17:02:09 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
17:02:21 <adamw> i'm here
17:02:27 <jkurik> Hi adamw
17:02:30 <jkurik> #topic Purpose of this meeting
17:02:39 <jkurik> #info Purpose of this meeting is to check whether or not F27 Server Beta is ready for shipment, according to the release criteria.
17:02:44 <jkurik> #info This is determined in a few ways:
17:02:48 <jkurik> #info * Release candidate compose is available
17:02:55 <jkurik> #info * No remaining blocker bugs
17:02:59 <jkurik> #info * Test matrices for Beta are fully completed
17:03:05 <jkurik> #topic Current status
17:03:14 <jkurik> As far as I am aware, the RC for F27 Server Beta is not yet ready.
17:03:19 <jkurik> As such, we do not have test matrices for the RC.
17:03:25 <jkurik> The lastest F27 nightly compose is available at https://kojipkgs.fedoraproject.org/compose/Fedora-Modular-27-20171013.n.0/compose/Server/
17:03:30 <jkurik> Anyone wants to add/correct something ?
17:03:46 <adamw> sounds correct to me.
17:03:59 <jkurik> #info The RC for F27 Server Beta is not yet ready.
17:04:09 <jkurik> #info The latest nightly compose, for those who are interested, is available at https://kojipkgs.fedoraproject.org/compose/Fedora-Modular-27-20171013.n.0/compose/Server/
17:04:22 <jkurik> #info As we have no RC there are subsequently no Test Matrices for the F27 Server Beta RC
17:04:29 <jkurik> Adamw: Would you like to do the Mini-blocker review or can we skip ?
17:04:34 * jkurik is proposing to skip
17:04:43 * langdon also
17:04:48 <sgallagh> I was *really* hoping to have an RC today, but last night we had an unanticipated hiccup with PDC
17:05:00 <sgallagh> So I'm hoping for tomorrow now
17:05:21 <jkurik> sgallagh++
17:05:22 <zodbot> jkurik: Karma for sgallagh changed to 17 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:05:28 <adamw> there's one proposed blocker...
17:05:33 <adamw> if folks can vote in bug i guess that'd be fin
17:05:33 <adamw> e
17:05:48 <jkurik> #topic Mini-Blocker Review
17:06:03 <jkurik> #help people are requested to vote in bugs
17:06:17 <mattdm> there arthere are some bugs blocking the Change tracking bug
17:06:19 <mattdm> see
17:06:21 <mattdm> #link https://bugzilla.redhat.com/show_bug.cgi?id=1474931
17:06:26 <mattdm> #undo
17:06:34 <mattdm> #link https://bugzilla.redhat.com/showdependencygraph.cgi?id=1474931
17:06:49 <mattdm> #info hit "change parameters" until bugzilla deigns to show you the graph
17:07:16 <mattdm> some of these seem pretty big
17:07:43 <mattdm> I'm worried about untracked unknowns
17:08:25 <langdon> There are lots of smaller ones.. But I havent been able to map pagure/gh issues to bz yet
17:09:46 <jkurik> mattdm: do you want to discuss it now, or can we move on ?
17:10:25 <mattdm> at this meeting at least, if not at this moment
17:11:04 <jkurik> ok, so lets leave it for the Open Floor section
17:11:27 <mattdm> wfm
17:11:48 <jkurik> mattdm: ok
17:13:28 <jkurik> mattdm: wfm means Wait For a Moment ? or Works For Me ?
17:13:33 <adamw> works for me
17:13:47 <mattdm> yeah sorry. works for me :)
17:13:47 <jkurik> I am always confused by this slang :-(
17:13:59 <jkurik> #topic Test Matrices coverage
17:13:59 * mattdm will try to use less slang
17:14:06 <jkurik> #info As there is no RC yet, Test matrices are not ready as well
17:14:12 <jkurik> #info We are skipping the Test Matrices coverage check
17:14:18 <jkurik> #topic Go/No-Go decision
17:14:24 <jkurik> < QE, FESCo, RelEng - we need +1/-1
17:14:27 <nirik> pretty clearly we are no go.
17:14:37 * mattdm has pre-teen kids and it's kind of all about the abbrevs
17:14:44 <jkurik> right, I am no-go as well
17:14:53 <sgallagh> No go
17:15:07 <tmlcoch> no go
17:15:11 <adamw> obvious no-go.
17:15:16 <jkurik> ok, thanks
17:15:37 <jkurik> proposed #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week. The Go/No-Go meeting for the F27 Server Beta release is going to be combined together with F27 Final Go/No-Go meeting.
17:16:43 <jkurik> do you think we can combine F27 Server Beta and F27 Final together ?
17:17:46 <mattdm> jkurik: combine the meetings or combine the releases?
17:17:52 <langdon> Personally, no
17:17:53 <jkurik> mattdm: the meetings
17:18:01 <langdon> Ohh
17:18:49 <jkurik> proposed #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week. The Go/No-Go meeting for the F27 Server Beta release is going to be combined together with F27 Final Go/No-Go meeting on 2017-Oct-26 at 17:00UTC.
17:19:34 <jkurik> may I have your acks, or comments, please ?
17:19:46 <mattdm> that seems fine.
17:19:59 <mattdm> Are we slipping F27 Server final as well
17:20:29 <nirik> ack
17:20:33 <nirik> yeah, I think we have to...
17:20:38 <adamw> +1
17:20:42 <jkurik> mattdm: I am writing a second part of the proposed agreed, lets agree on the Go/No-Go first
17:20:50 <jkurik> ok
17:20:56 <jkurik> #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week. The Go/No-Go meeting for the F27 Server Beta release is going to be combined together with F27 Final Go/No-Go meeting on 2017-Oct-26 at 17:00UTC.
17:21:08 <jkurik> here we go:
17:21:11 <jkurik> proposed #agreed The slip also affects the F27 Server GA, it moves to 2017-Dec-12. The rain date for the F27 Server GA moves to 2017-Dec-19.
17:22:15 <jkurik> mattdm, langdon: ^^^ ok ?
17:22:36 <langdon> I'm +1 but not happy
17:23:13 * nirik nods. +1
17:23:31 <mattdm> Is Dec 19th feasible?
17:23:40 <mattdm> Or do we need to make that rain date January?
17:23:50 <jkurik> mattdm: do you mean because of Christmas ?
17:24:25 <jkurik> mattdm: that is a second option, I just did not want to delay it more then necesary
17:24:26 <contyk> 12/19 is very doable
17:24:31 <contyk> For GA
17:24:34 <mattdm> yeah, christmas and end-of-year holidays
17:24:41 <mattdm> I don't want to delay more either
17:26:07 <mattdm> I think if we can't hit 12-12, though, we're unlikely to hit 19
17:26:09 <jkurik> perhaps we can leave it on 2017-Dec-19 for now and if we will not be able to have the F27 Server Final released on 2017-Dec-12 (the targed date) we can revisit on Go/No-Go where we will know current status
17:26:25 <langdon> +1
17:26:26 <mattdm> Let's just not miss the first target :)
17:26:47 <jkurik> :-)
17:27:07 <jkurik> ok, so I am considering my second proposed #agreed as agreed :-)
17:27:11 <smooge> wait 12-12 was not possible earlier because it needs infrastructure working from 12-04 -> 12-08
17:27:41 <smooge> however infrastructure will be moving hardware that week
17:27:58 <langdon> I don't think there is a proposal to move in to the hw window..
17:28:11 <langdon> Still the tues after iirc
17:28:43 <langdon> Ohh wait.. Now I'm confused too
17:28:59 <smooge> the final needs to be ready 12-07 for a 12-12 date. However I can't promise you will have working build systems for most of 12-04->12-08
17:29:13 <nirik> right. that week is kind of a dead zone.
17:29:27 <nirik> or if you prefer "relax and do something else" :)
17:29:27 <jkurik> that is the week when we need to work on RC for the Final
17:29:40 <smooge> so if you can't freeze on 11-30 your next freeze date will be 12-14
17:29:53 <smooge> sorry s/freeze/rc-final/
17:29:57 <mattdm> contyk: you seem confident about 12/19... can you help me feel confident? will everyone we need be available?
17:30:35 <mattdm> It sounds like we need to slip to a target of Dec 19, with a rain date of Jan 9, 2018.
17:30:35 <jkurik> ok, so then the proposal for the slip of the F27 Server Final will be like this:
17:30:44 <jkurik> mattdm: you were faster
17:31:24 <mattdm> faster but sad :-/
17:31:27 <langdon> So.. Just to clarify.. The "release" on 12/12 is decided and staged before the outage.. Right after the 11/30 go/no-go
17:31:29 <jkurik> proposed #agreed The slip also affects the F27 Server GA, it moves to 2017-Dec-19. The rain date for the F27 Server GA moves to 2018-Jan-09.
17:31:53 <nirik> yeah, my understanding is that we had the go/nogo so that week didn't matter
17:32:14 <contyk> mattdm: If we get into good enough shape for Beta -- i.e. we have images and usable platform, fixing the remaining content within a month or more seems pretty doable
17:32:15 <langdon> Right.. So.. The q is.. Can we be ready by 11/30
17:32:34 <contyk> mattdm: we have also semi-frozen the buildroot most modules use, which helps
17:32:37 <nirik> if we are go on 11/30, release can be on 12/12. it's already done at that point
17:32:59 <mattdm> I think what I hear langdon saying is "Proposed: We slip to the rain date for final now, and don't plan to have a rain date after that"
17:33:06 <langdon> Contyk.. How do u feel about 11/30?
17:34:00 <langdon> Mattdm not exactly.. I was clarifying what the freeze date is for final if we use the rain date.. I also like a rain date in jan if/when we slip to the existing rain date
17:34:52 <langdon> But.. We could do.. 12/19 as the new final, making freeze the thurs before, with a rain date in jan
17:35:49 * langdon notes contyk seems to be typing :)
17:36:00 <nirik> so: go/no-go on 11/30, if go, release 12/12. If that is no-go, go/no-go on 12/14 and release on 12/19. If that is no go, go-nogo on jan4th, release on 9th?
17:36:19 <langdon> Right
17:36:35 <mattdm> double rain dates!
17:36:50 <langdon> With slickers?
17:36:58 * contyk feels great about any dates between 11/17 and 12/18
17:37:08 * contyk will be on PTO then
17:37:13 <nirik> since it's decemeber, they could be snow dates. ;)
17:37:37 <jkurik> proposed #agreed The slip also affects the F27 Server GA, it moves to 2017-Dec-12 having Go/No-Go meeting on 2017-Nov-30. The rain date for the F27 Server GA moves to 2017-Dec-19 having the Go/No-Go on 2017-Dec-14.
17:37:47 <jkurik> what about this ? ^^^
17:38:00 * langdon wonders why mattdm's basket of fires spilled
17:38:23 <mattdm> I just put it down to rest for a minute!
17:38:39 <langdon> Jkurik +1
17:38:50 <nirik> why is there rain when things are on fire? :)
17:39:01 <langdon> Point
17:39:06 <jkurik> nirik: there is no fire when is a rain
17:39:55 <langdon> We could just start calling then fire dates.. Omg.. Let's stay focused.. I need dinner :)
17:40:14 <mattdm> anyway. yeah. +1 to that proposal
17:40:24 <adamw> it's a rain of fire.
17:40:34 <langdon> Hail perhaps?
17:40:35 <nirik> sounds good to me.
17:40:48 <jkurik> ok, considering as agreed
17:40:49 <nirik> I've seen fire, and I've seen rain...
17:40:54 <mattdm> but let's _really_ not slip to that new rain date, because it's basically destroying any chance for press
17:41:00 <jkurik> #agreed The slip also affects the F27 Server GA, it moves to 2017-Dec-12 having Go/No-Go meeting on 2017-Nov-30. The rain date for the F27 Server GA moves to 2017-Dec-19 having the Go/No-Go on 2017-Dec-14.
17:41:16 <nirik> yeah.
17:41:19 <jkurik> #action jkurik to publish the Go/No-Go result
17:41:32 <jkurik> #topic Open floor
17:41:56 <jkurik> mattdm: would you start the discussion regarding the 1474931 ?
17:42:27 <mattdm> Sure. Well, it's not just that bug -- it's in general that I'm worried because I don't know what's going on
17:42:48 <mattdm> the blocker bug process gives me a pretty good way to keep up and know where to focus attention
17:42:55 <mattdm> but if we don't have bugs, we can't have blocker bugs
17:43:18 <mattdm> It doesn't *necessarily* need to be there, but there needs to be some unified dashboard of all important work remaining
17:44:09 <jkurik> For me is the situation somehow disorganized as some issues are tracked in Bugzilla, sone in Pagure, some in Trello ... and we do not have clear visibility on it
17:44:15 <mattdm> at this point, is it *just* a matter of transfering/linking stuff from pagure and github?
17:44:23 <mattdm> there's stuff in trello? i didn't even know.
17:44:30 <mattdm> also releng stuff in taiga
17:44:39 <nirik> There is now primitive linking in bugzilla for pagure issues.
17:44:40 <jkurik> mattdm: I am not sure about now, but there were in the past
17:44:48 <nirik> ie, you can point to a pagure bug from bugzilla bug
17:45:09 <langdon> No.. Just pagure, gh, and bz for "us"
17:45:18 <mattdm> nirik: that may be sufficient, if we're willing to make a tracker bug be a blocker
17:45:27 <jkurik> nirik: the problem is that you need to manually ensure consistency, which is not an easy thing
17:45:29 <mattdm> that way, less need to duplicate
17:45:31 <nirik> whatever works. ;)
17:45:55 <langdon> But making new bzs for every issue is time consuming and I haven't had it
17:46:17 <mattdm> does it require domain knowledge to do whatever linking work is needed here? I mean, if we had a volunteer with otherwise no idea what's going on, could they do the work?
17:46:24 <mattdm> or does it need to be langdon or contyk?
17:46:41 <langdon> And we don't have a component to put them on because the sync on digital create isn't working for modules.. Which is another bug/rfe I need to file
17:46:50 <langdon> Mattdm no
17:46:58 <nirik> mattdm: it's just the normal bugzilla 'other bug' thing
17:47:24 <langdon> It's pretty much everything linked off the content tracking Readme in gh
17:47:57 <mattdm> langdon: can you link that here for those following along at home?
17:48:20 * langdon on mobile.. So in a min
17:48:35 <mattdm> thanks
17:48:57 <langdon> That was easy https://github.com/fedora-modularity/f27-content-tracking
17:49:20 <langdon> Each of the modules has its own repo linked there with issues.
17:49:49 <langdon> There are a few more on the pagure modularity repo.. But not much
17:50:12 <mattdm> what is "Runtime dependencies (not complete)"?
17:50:50 <langdon> Installs/buidks but doesn't run probably
17:51:35 <mattdm> so *all* of those are beta blockers currently?
17:51:39 * mattdm goes to get a bigger basket
17:52:08 <langdon> Yes.. But they are "easy"
17:52:18 <langdon> Mostly
17:53:29 <jkurik> langdon: do I understant it correctly that the https://github.com/fedora-modularity/f27-content-tracking is the master tracking tool for now ?
17:53:49 <langdon> Essentially yes
17:53:55 <mattdm> Here's my suggestion: let's have one tracker bug for "modular content" and have it link to that page, and make it either beta or final release blocking
17:54:01 <mattdm> then we'll use that as the tracker
17:54:06 <langdon> Some others here and there.. Like bodhi uodate
17:54:13 <jkurik> mattdm: ack
17:54:30 <mattdm> are there blockers that are *outside* of that content plan that are not in bugzilla?
17:55:16 <langdon> Yes.. But sub 10
17:55:25 <mattdm> where are those tracked?
17:56:02 <jkurik> langdon: can these be moved to the github page ?
17:56:42 <mattdm> I'm thinking bugzilla for those?
17:56:46 <langdon> Yeah.. Or bz links
17:57:11 <langdon> Yeah.. That's fine..
17:57:12 <mattdm> langdon: which things are there which are not in https://bugzilla.redhat.com/showdependencygraph.cgi?id=1474931 ?
17:57:37 <mattdm> and would it help if jkurik or me or someone put them there so you have one less thing to stress out about?
17:58:00 <langdon> At least the components in bz is not filed
17:58:09 <langdon> Yes :)
17:58:18 <langdon> The other infra style stuff is there
17:59:09 <mattdm> there where? in bugzilla?
17:59:44 <langdon> Ohh yeah.. And linked.. The last few are on the gh repo itself and here:
18:00:53 <langdon> http://pagure.io/modularity
18:01:10 <mattdm> okay. i will make bugs
18:01:37 <mattdm> can you respond to katec's email about rel-eng needs? or contyk? or someone?
18:01:42 <mattdm> she is getting cranky at me
18:01:46 <langdon> \o/
18:03:02 <langdon> Yeah..
18:03:13 <mattdm> okay, let's move this over to #fedora-modularity and close out the meeting?
18:03:15 * langdon notes one of many cranky at me
18:04:28 <jkurik_mtg> I was disconnected. Did I missed something ?
18:04:45 <jkurik_mtg> langdon: so if we combine the http://pagure.io/modularity with the github README file and with bug 1474931 - do we have it all then ?
18:05:23 <langdon> I think so yes..
18:05:32 <jkurik_mtg> ok
18:06:17 <jkurik> anything else ? mattdm ?
18:06:51 <mattdm> I'm good. but langdon needs to answer my question over in the other channel or I can't help
18:07:04 <langdon> Ha.. Didn't see it yet
18:07:26 <jkurik> Anything else to be discussed on this meeting ?
18:08:45 <jkurik> #info The Modularity is tracked on the following places: http://pagure.io/modularity , https://bugzilla.redhat.com/showdependencygraph.cgi?id=1474931 , https://github.com/fedora-modularity/f27-content-tracking
18:08:50 <langdon> Not from me
18:09:07 <jkurik> Thanks everybody then
18:09:18 <contyk> Thanks
18:09:19 <jkurik> I am going to close the meeting in 1 minute ...
18:10:29 <adamw> langdon: mattdm: btw, i think we may kinda have duplicate blocker bugs now...
18:10:53 <jkurik> #endmeeting