fedora_atomic_wg
LOGS
17:00:14 <dustymabe> #startmeeting fedora_atomic_wg
17:00:14 <zodbot> Meeting started Wed Sep 20 17:00:14 2017 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:14 <zodbot> The meeting name has been set to 'fedora_atomic_wg'
17:00:19 <dustymabe> #topic roll call
17:00:25 <dustymabe> .hello dustymabe
17:00:26 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:00:29 <jbrooks> .fas jasonbrooks
17:00:32 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:00:37 <ksinny> .hello sinnykumari
17:00:38 <zodbot> ksinny: sinnykumari 'Sinny Kumari' <ksinny@gmail.com>
17:01:26 <kushal> .hellomynameis kushal
17:01:27 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:04:44 <dustymabe> one sec and i'll get started
17:06:41 <davdunc> we'll be here.
17:06:59 * dustymabe failing git today
17:07:10 <maxamillion> .hello maxamillion
17:07:14 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:07:20 <maxamillion> sorry, in two meetings
17:07:24 <dustymabe> #topic previous meeting action items
17:07:34 <dustymabe> * jbrooks to submit asciibinder pkg for review
17:07:36 <dustymabe> * jbrooks to create issue for adding examples to container guidelines
17:07:38 <dustymabe> * jberkus to follow up on partial container images from Flock
17:07:40 <dustymabe> * dustymabe to open ticket regarding gluster/ceph packages in FAH
17:07:56 <jbrooks> I opened that issue: https://pagure.io/atomic-wg/issue/338
17:07:59 <yzhang> .hello yzhang
17:08:00 <zodbot> yzhang: yzhang 'Yu Qi Zhang' <jzehrarnyg@gmail.com>
17:08:08 <davdunc> .hello davdunc
17:08:11 <zodbot> davdunc: davdunc 'David Duncan' <davdunc@amazon.com>
17:08:24 <jbrooks> I haven't submitted an asciibinder pkg yet, I've got it building for el7 but not f26, need to figure out what's up w/ that
17:09:40 <dustymabe> #info dustymabe opened a ticket for the ceph/gluster issue: https://pagure.io/atomic-wg/issue/333
17:10:04 <dustymabe> #info jbrooks opened an issue for adding examples to container guidelines: https://pagure.io/atomic-wg/issue/338
17:10:25 <dustymabe> #action jbrooks to submit asciibinder pkg for review
17:10:31 <dustymabe> #action jberkus to follow up on partial container images from Flock
17:10:37 <dustymabe> we miss jberkus :(
17:10:51 <dustymabe> ok moving on
17:11:16 <dustymabe> #topic test day for f27 atomic
17:11:22 <dustymabe> #link https://pagure.io/atomic-wg/issue/322
17:11:43 <dustymabe> how do people feel about a test day on the 29th?
17:11:54 <dustymabe> i know we have the holiday in india
17:12:12 <maxamillion> miss jberkus? where'd he go?
17:12:18 <jbrooks> pto
17:12:22 <dustymabe> he's somewhere without internet :)
17:12:28 <maxamillion> ah
17:12:32 <maxamillion> well good for him
17:12:34 <maxamillion> hope it's fun
17:13:36 <dustymabe> i hear no objections to the 29th
17:13:44 <dustymabe> sound good?
17:13:49 <davdunc> +1
17:13:53 <dustymabe> is roshi around today?
17:14:18 * roshi has few cycles
17:14:24 <dustymabe> ok we'll go with that we need to get a blog post out on the comm blog for this
17:14:30 <roshi> fine with the 29th though
17:14:31 <dustymabe> i can do it but would love a volunteer
17:14:36 <roshi> I won't be able to participate though
17:14:43 <roshi> prior engagement
17:15:15 <dustymabe> roshi: does the 28th work?
17:15:39 <dustymabe> we could push to oct 2nd
17:15:44 <roshi> gonna be out most of that week/end
17:15:54 <roshi> I can still make the wiki pages though :)
17:15:57 <dustymabe> then we would get our indian friends back, but I fear bumping up to close to final freeze
17:16:04 <maxamillion> I'll be at a conference next week but was planning to be back on the 29th
17:16:31 <dustymabe> 2017-09-05  Beta Freeze (*)
17:16:33 <dustymabe> 2017-09-19  Beta Release (Target date)
17:16:35 <dustymabe> 2017-09-26  Beta Release (Rain date)
17:16:37 <dustymabe> 2017-10-10  Final Freeze (*)
17:16:39 <dustymabe> 2017-10-24  Fedora 27 Final Release (GA) (Target date)
17:16:41 <dustymabe> 2017-10-31  Fedora 27 Final Release (GA) (Rain date)
17:16:49 <dustymabe> i guess oct 2nd would work best for everyone
17:16:57 * ksinny will be back on 3rd october
17:17:24 * sayan will be back on 3rd October too
17:17:26 <dustymabe> ksinny: is difficult :)
17:17:30 <dustymabe> sayan: is worse
17:17:45 <ksinny> yeah, no problem :)
17:17:53 <dustymabe> we'll stick with the 29th
17:18:08 <dustymabe> and anyone can feel free to test whenever
17:18:10 <dustymabe> :)
17:18:14 <sayan> dustymabe: yeah, i think go ahead with 29th
17:18:18 <dustymabe> ok what other issues do we have for today
17:18:25 <ksinny> +1
17:18:55 <dustymabe> anybody want to do a blog post for the comm blog?
17:18:59 <dustymabe> something like this: https://fedoramagazine.org/fedora-26-atomiccloud-test-day-june-20th/
17:19:34 <sayan> dustymabe: I can write one
17:19:45 <dustymabe> sayan: are you sure?
17:20:14 <dustymabe> do you mind coordinating with roshi? basically we'd like to have the wiki pages updated before the blog post goes out if possible
17:20:20 <dustymabe> that way we have some stuff to link to
17:20:39 <sayan> dustymabe: I can work on that in next two days
17:20:41 <dustymabe> basically similar links to what I posted in that post
17:20:56 <sayan> btw, I will not be offline.
17:22:18 <dustymabe> ok I updated that ticket
17:22:26 <dustymabe> next ticket
17:22:33 <dustymabe> #topic removing gluster/ceph rpms from base atomic host
17:22:39 <dustymabe> #link https://pagure.io/atomic-wg/issue/333
17:23:19 <dustymabe> after looking at this a bit more it looks like the ceph rpms are pretty tiny while the gluster rpms bring in about 77M worth of stuff (24M compressed)
17:23:43 <dustymabe> i'm definitely +1 on adding gluster stuff back in (especially considering openshift-ansible)
17:24:02 <jbrooks> dustymabe, don't you mean the opposite?
17:24:08 <jbrooks> gluster tiny ceph large
17:24:15 <dustymabe> ahh yes
17:24:19 <dustymabe> gluster tiny, ceph large
17:24:22 <dustymabe> sorry
17:24:27 <jbrooks> I'm +1 to keeping gluster in, ceph layering
17:24:30 <nzwulfin> that sounds better :)
17:24:59 <dustymabe> ok i'll float this in the ticket. I know strigazi was advocating for ceph
17:25:54 <dustymabe> nzwulfin: do you know what we do for this downstream?
17:26:06 <maxamillion> yeah, I'm +1 to that as well
17:26:17 <nzwulfin> waay back when we opened the first ticket, there was a coming feature around root mount propagation that was supposed to "fix" the issues with running as a sidecar
17:26:44 <dustymabe> nzwulfin: did that ever happen?
17:27:10 <jbrooks> dustymabe, Pretty sure they still have ceph and gluster
17:27:20 <nzwulfin> those patches are in (docker / runc / k8s) but i don't know if they change anything
17:27:24 <jbrooks> That's how it was last time I synced up cah, a couple weeks ago
17:27:37 <dustymabe> jbrooks: but kube is out, right?
17:27:45 <jbrooks> dustymabe, just kube master
17:27:52 <jbrooks> Weirdly, node and client are still in
17:27:52 <dustymabe> k
17:27:57 <nzwulfin> what jbrooks said, i think they're still in the host
17:27:58 <jbrooks> And old -- 1.5.x
17:28:11 <jbrooks> Flannel and etcd are still in too
17:28:31 <dustymabe> we'll see if we get anyone advocating for it in the ticket
17:28:57 <miabbott> rhelah does still have ceph and gluster on host
17:29:04 <dustymabe> ok so what else do we have
17:29:28 <dustymabe> #topic f27 issue release tracker
17:29:39 <dustymabe> #link https://pagure.io/atomic-wg/issue/331
17:29:53 <dustymabe> this is the place we'll keep up with big issues with f27 atomic host
17:30:01 <dustymabe> please let us know if you find anything that is not tracked here
17:30:21 <dustymabe> #topic open floor
17:30:27 <dustymabe> davdunc: I saw you open an issue
17:30:32 <davdunc> #link https://pagure.io/atomic-wg/issue/339
17:30:35 <dustymabe> did you want to bring that up?
17:30:39 <davdunc> yea.
17:31:13 <dustymabe> go for it
17:31:21 <davdunc> so after our discussions at Flock, it was decided that I could publish the Atomic and Cloud Images to AWS Marketplace with a personal account.
17:31:39 <jbrooks> davdunc, Is the listing a giant spreadsheet?
17:31:57 <jbrooks> I've been putting off filling out one of those for centos atomic :/
17:32:06 <davdunc> That way we can remove the legal obstacles that are preventing us from publishing today.
17:32:23 <davdunc> @jbrooks  it's one in the same.
17:32:40 <dustymabe> davdunc: so when I do a new FAH 2 week release, like I did today
17:32:44 <dustymabe> what needs to happen?
17:33:05 <dustymabe> also, is it possible to still have the non marketplace AMIs ?
17:33:24 <davdunc> I don't want anything to change about the non-marketplace AMIS.
17:33:27 <sayan> dustymabe: yes, those will be still there
17:33:33 <gholms> Thank you
17:33:43 <davdunc> this will just be in addition to those.
17:33:53 <sayan> I would like to bring a email that came in the security list: https://lists.fedoraproject.org/archives/list/security@lists.fedoraproject.org/thread/ACYZ5LIEBTFTWQUFKZISQGTW23QTBMMR/
17:33:54 <gholms> Marketplace images require a web UI click-through, even when they're free.
17:34:24 <gholms> sayan: We should report those to AWS.
17:34:27 <dustymabe> sayan: let's hold off on that for a second
17:34:31 <davdunc> When you do a new release, I'll submit it for review to MP.
17:34:50 <dustymabe> davdunc: ok so basically we'll have marketplace AMIs and non marketplace AMIs ?
17:35:09 <dustymabe> is there any way they could be the same AMI id ?? :)
17:35:10 <davdunc> via the personal account
17:35:26 <davdunc> exactly. We'll have two AMIs
17:35:51 <davdunc> one published from the Fedora Account and one published from the AWS Marketplace account.
17:36:21 <davdunc> the one in the marketplace will have a product code, like the ones jbrooks and KB publish for CentOS.
17:36:54 <jbrooks> We haven't started doing to for centos atomic yet, but there are regular centos images in the marketplace
17:36:57 <gholms> Are you okay with paying for the snapshots?  IIRC, the Fedora account has storage fees comped.
17:37:08 <jbrooks> I think amazon picks up the tab for the storage there?
17:37:11 <davdunc> correct. gholms
17:37:12 <jbrooks> in the marketplace
17:37:24 <dustymabe> ok, that is nice because we can reach a broader audience, but we will have to deal with it if someone comes to us and reports an issue to an image from the marketplace
17:37:26 <davdunc> gholms: I am o.k. with it.
17:37:35 <davdunc> mine will be temporary.
17:37:54 <dustymabe> thanks davdunc for offering to do this
17:38:08 <davdunc> once submitted to the AWS MP and accepted it's lifecycle is over.
17:38:14 <davdunc> absolutely!
17:38:18 <sayan> davdunc: dustymabe: would we be moving to some fedora account marketplace in the future?
17:38:32 <nzwulfin> davdunc++
17:38:32 <zodbot> nzwulfin: Karma for davdunc changed to 1 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:38:44 <sayan> davdunc++
17:38:44 <zodbot> sayan: Karma for davdunc changed to 2 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:38:56 <davdunc> sayan: it's a legal hurdle that we are working on here.
17:38:59 <maxamillion> davdunc++
17:38:59 <zodbot> maxamillion: Karma for davdunc changed to 3 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:39:03 <dustymabe> sayan: i'm not sure i understand the question
17:39:08 <dustymabe> basically nothing will change from our end
17:39:16 <dustymabe> davdunc: will publish the images when we do releases
17:39:37 <davdunc> exactly. I'll work with sayan to automate as much as possible.
17:39:41 <sayan> dustymabe: davdunc answers my question
17:40:01 <sayan> but i wanted to know will we move from davdunc's account to fedora account in future
17:40:37 <dustymabe> i don't know the answer to that
17:40:51 <davdunc> sayan, we'll work on that.
17:40:53 <dustymabe> sayan: as far as your mailing list thread you linked to
17:41:04 <dustymabe> https://pagure.io/cloud-sig/issue/282
17:41:20 <dustymabe> sayan: basically we're waiting on you to finish the work you've been doing
17:41:33 <dustymabe> we need to get that out so we can upload AMIs to new regions
17:42:05 <dustymabe> sayan: what is blocking this?
17:42:23 <sayan> dustymabe: I will push after the beta freeze
17:42:41 <dustymabe> ok, please please please let's do
17:42:55 <sayan> dustymabe: yes, it's been a long time
17:42:55 <dustymabe> if not, then let's get people involved who can unblock
17:43:03 <davdunc> let me know if I can help sayan.
17:43:07 <dustymabe> anyone else with anything for open floor?
17:43:22 <sayan> davdunc: sure
17:43:35 * ksinny wants to share an info in open floor
17:43:38 <sayan> dustymabe: btw, regarding the rogue AMIs, how are they related to new regions?
17:43:49 <dustymabe> davdunc: you might be able to help us take down the bad AMIs
17:44:12 <davdunc> definitely.
17:44:17 <dustymabe> sayan: see the issue I linked to
17:44:27 <dustymabe> https://pagure.io/cloud-sig/issue/282
17:44:43 <dustymabe> a first-line defense should be making sure we expand to these new regions right away when they come online
17:44:44 <sayan> okay
17:44:58 <dustymabe> mattdm's suggestion ^^
17:45:28 <sayan> yes, but after F26 issues, I thought it's better to rewrite the project, than patching each time
17:45:47 <dustymabe> sayan: sure. that's fine
17:45:56 <dustymabe> anyone else with anything?
17:46:01 <dustymabe> will close out soon if not
17:46:13 <ksinny> We have necessary patches commited in rawhide to fix Fedora Atomic CloudImage build on multi-arch \o/ Thanks to walters and dustymabe for helping to achieve it :)
17:46:26 <dustymabe> ksinny: :)
17:46:41 <dustymabe> #info ksinny: We have necessary patches commited in rawhide to fix Fedora Atomic CloudImage build on multi-arch
17:46:56 <dustymabe> ksinny: do you mind updating the atomic-wg ticket with links to relevant commits?
17:47:13 <dustymabe> ksinny: also, do you know if there are any outstanding things left to go in?
17:47:14 <ksinny> dustymabe: oh yes, will do after meeting
17:47:28 <dustymabe> or should what we have work (barring unforeseen issues)?
17:47:33 <maxamillion> ksinny++
17:47:33 <zodbot> maxamillion: Karma for sinnykumari changed to 3 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:47:35 <gholms> AWS really don't like it when people publish public images with built-in ssh keys.  We should report it to them.
17:47:56 <gholms> Especially since it seems to be a pretty clear-cut attempt to exploit people
17:48:03 <ksinny> dustymabe: https://pagure.io/atomic-wg/issue/299#comment-451478
17:48:38 <dustymabe> ksinny: so the 'console' issue is still outstanding?
17:48:44 <ksinny> last part console=ttyAMA0  is needed on aarch64 for getting console on aarch64 after booting
17:48:44 <dustymabe> gholms: agreed
17:48:51 <ksinny> but that is not blocker for building image,
17:49:05 <dustymabe> ksinny: cool deal
17:49:25 <ksinny> Thought of getting it in after we have successful build in nightlies
17:49:34 <dustymabe> maybe once we get image builds working (today's failed because of builder issues) we can open a new ticket for the console issue on aarch64
17:49:58 <dustymabe> a fresh ticket with narrower scope is sometimes useful
17:50:01 <ksinny> dustymabe: sure.
17:50:09 <dustymabe> ok closing out meeting in 10
17:50:36 <dustymabe> #endmeeting