serversig
LOGS
20:00:26 <sgallagh> #startmeeting Fedora Server SIG Weekly Meeting (2019-09-19)
20:00:27 <zodbot> Meeting started Tue Sep 19 20:00:26 2017 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:27 <zodbot> The meeting name has been set to 'fedora_server_sig_weekly_meeting_(2019-09-19)'
20:00:38 <sgallagh> #meetingname serversig
20:00:38 <zodbot> The meeting name has been set to 'serversig'
20:00:58 <sgallagh> #topic Roll Call
20:01:02 <sgallagh> .hello2
20:01:03 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
20:01:24 <langdon> .hello2
20:01:29 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
20:02:03 <smooge> here
20:03:01 <nirik> morning
20:04:53 * langdon notes there is discussion in #fedora-modularity about getting a modular server compose working that may be distracting sgallagh
20:05:32 <sgallagh> Well, I was allowing myself to be distracted while we gather quorum
20:06:11 <langdon> ha.. point
20:06:23 * langdon likes q words
20:06:34 <ignatenkobrain> .hello2
20:06:35 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <ignatenko@redhat.com>
20:06:36 <sgallagh> quiet, Quaid
20:06:37 <smooge> so general question.. are we also supposed to be in #fedora-modularity at times?
20:07:14 <sgallagh> smooge: There's a moderate amount of overlap these days, but I don't think it's *strictly* necessary
20:07:55 <sgallagh> #topic Night of the Living Modular Server
20:08:54 <sgallagh> For anyone who didn't see my agenda email ( https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/RGYWY5L2QXKB3UTSOXLTOMLP2TB65BW3/ ), the Council has asked us to reconsider our decision last week
20:09:07 <smooge> So after burying it.. we found it has risen from its fresh grave
20:09:11 <sgallagh> To that end, they're giving us the option to get a one month extension
20:09:41 * langdon digs!
20:10:09 <sgallagh> So our first and most important question: Are we on board with this in general terms?
20:10:23 <nirik> well, I thought that was already decided by them?
20:10:27 <sgallagh> (The follow-up questions will address the logistics)
20:10:30 <langdon> one month'ish .. if you look at my proposed scheduled, t-day in the US messes with stuff
20:11:06 <sgallagh> nirik: On the off-chance we all decided we didn't want to do it, we theoretically could.
20:11:08 <nirik> langdon: link to schedule?
20:11:27 <sgallagh> But I'm *hoping* this is going to be decided by general acclamation
20:11:51 <petervo> https://fedoraproject.org/wiki/User:Langdon/Proposed_Modular_Server_Release#Key_Milestones
20:11:52 <nirik> anyhow, Its moot. I am fine with doing modular server for f27 on a slightly different schedule. I think that allows us to make something important but not kill ourselves doing so.
20:11:59 <langdon> nirik: https://fedoraproject.org/wiki/User:Langdon/Proposed_Modular_Server_Release#Key_Milestones
20:12:14 <langdon> acclaim!
20:12:31 <sgallagh> #link https://fedoraproject.org/wiki/User:Langdon/Proposed_Modular_Server_Release#Key_Milestones
20:12:43 <sgallagh> #chair nirik langdon petervo smooge
20:12:43 <zodbot> Current chairs: langdon nirik petervo sgallagh smooge
20:12:51 <sgallagh> (sorry, I forgot to chair folks earlier)
20:13:07 <langdon> no worries.. wasn't sure if it should be in the minutes or not anyway
20:13:26 <smooge> so the items I see as problems. We have turkey day in November. We have a 1 week downtime for infrastructure at the beginning of December
20:13:44 <nirik> right ,the dec 4th date is not so great...
20:13:58 <langdon> nirik: note: "rain date"
20:14:17 <sgallagh> OK, apparently we are moving on to the logistics.
20:14:31 <sgallagh> For the record, we're voting to move forward with modularity, yes?
20:14:35 <nirik> sure, but that week we are planning on moving all our machines in the datacenter to new racks. There will be things down. Not sure we want a release that week.
20:14:36 <sgallagh> (Call the above a proposal)
20:14:37 <sgallagh> +1
20:14:40 <nirik> sure, +1
20:14:48 <langdon> ooo.. as a shed painter i get to vote!
20:14:50 <langdon> +1
20:14:56 <smooge> I am +0 as I don't see what we are doing to make it work or not
20:15:05 <sgallagh> I don't remember making you a painter :)
20:15:18 <langdon> ohh right..  :( but i still get to vote! :)
20:15:23 <sgallagh> yes
20:15:34 * langdon forgot the details and just wanted to say "shed painter" as much as possible
20:16:55 <sgallagh> #info preliminary "yea" vote on shipping Modular Server. Some members need to hear more logistic details first.
20:17:20 <smooge> sorry for combining logistics before a vote but it wasn't clear what we logistically have to do to make it ship 1 month later.. or vice versa to make it not ship
20:17:22 <sgallagh> Do we want to discuss the proposed schedule next, or ask the *other* big question?
20:17:28 <sgallagh> smooge: No, it's fair.
20:18:48 <sgallagh> ... ok, let's pick schedule
20:18:55 <sgallagh> #topic Fedora Modular Server Schedule
20:19:02 <sgallagh> Continue painting!
20:19:49 <langdon> so.. for a bit of explanation.. i tried to hit nov. 14 .. but the slip date is pretty rough
20:20:38 <langdon> we could consider releasing on a "not tuesday" but it has marketing issues.. and smaller response window before the weeked.. e.g. do the thurs of the week after t-day as the slip date
20:20:50 <langdon> which would be nov 30
20:21:29 <smooge> wait why not the 28th?
20:21:56 <nirik> I would say the 21st is better than the 17th...
20:21:58 <langdon> smooge: as i understand it.. the stuff needs to be staged x days in advance of launch.. which would probably land squarely on t-day
20:22:27 <sgallagh> Among other things, that would make our Go/No-Go decision day be Thanksgiving
20:22:29 <langdon> nirik: figured a lot of people would be out the whole week of t-day
20:22:34 <nirik> staged, time to sync to mirrors, time for websites to get ready, etc
20:22:35 <sgallagh> That seems... not ideal
20:22:38 <langdon> but i like 21
20:22:51 <smooge> ah so I figured our go/no go would be the 16th, and we ship the 28th
20:23:09 <nirik> well, for the actual release we don't need everyone.... if go was on the 16th...
20:23:20 <sgallagh> hmm
20:23:27 <langdon> smooge: yeah... i kinda thought that too.. but it, realistically, is very little slip.. as everything would need to be ready by ~20th
20:23:43 <smooge> langdon, so that is the ideal time
20:24:07 <smooge> the next date would be go/no-go on the 30th and ship on the 12th
20:24:53 <langdon> ohh.. i for one am a bit confused.. are we talking "target date" or "rain date"
20:25:52 * nirik curses his comcastic network today.
20:26:05 <smooge> so target date: GO/No-Go 2017-11-16, ship 2017-11-28. raindate GO/No-Go 2017-11-30 Ship 2017-12-12
20:27:14 <sgallagh> Why 12-12 if we had Go on 11-30?
20:27:24 <sgallagh> The extra week makes sense around Thanksgiving
20:27:24 <langdon> i can see that working.. would rather see dec 12 = dec 5
20:27:34 <sgallagh> But why at the beginning of December?
20:27:37 <smooge> because 2017-12-04 -> 2017-12-08 the cage is closed
20:27:42 <langdon> ohh
20:27:44 <nirik> we are moving all our machines that week
20:27:47 <sgallagh> .fire langdon PUNS
20:27:47 <zodbot> adamw fires langdon PUNS
20:27:52 <nirik> there will be downtime as much as we try and avoid it.
20:27:59 <langdon> yeah.. that would be inconvient
20:28:09 <langdon> i punned?
20:28:11 <smooge> I mentioned it at flock
20:28:11 <sgallagh> oh. Hmm
20:28:20 <smooge> but we have all slept since then
20:29:04 <nirik> we have released on tuesday of thanksgiving before... but I guess we would need buyin from websites mostly.
20:29:30 <langdon> nirik: that is tues AFTER t-day
20:29:47 <langdon> t-day is nov 23 this year
20:29:52 <smooge> well nirik is saying go-no on 16 ship on 2017-11-21
20:29:58 <nirik> well, talking about moving the 11-16 day
20:30:06 <smooge> versus skip a week
20:30:16 <sgallagh> I'd actually rather skip the week
20:30:32 <langdon> ohh i see. i would skip t-day week for marketing reasons
20:30:38 <nirik> releasing on friday is.. not likely to get as much attention
20:30:40 <sgallagh> Because it offers us the opportunity to slip a couple days at Go/No-Go if we needed to and not move the date
20:30:47 * langdon apparently not reading very well today
20:31:16 <nirik> sorry, let me look at a real calendar.
20:31:26 <sgallagh> Like, if we're almost there on 11-16, maybe we reconvene on the 20th and hit the Go button then.
20:31:44 <langdon> https://www.timeanddate.com/calendar/
20:31:46 <sgallagh> So the churn still happens before people leave for T-day and we still release that following Tuesday
20:32:14 <nirik> if we aren't go... some work has to take place to be go... and someone has to be there to do that work...
20:32:46 <sgallagh> If we aren't Go, I assume Langdon and I are going to be sleeping at the office that weekend...
20:32:51 <nirik> if people are there early part of t-giving week to do that and go, then the 28th could work
20:32:57 <langdon> if it is small work, we still hit the following week.. if it is big work, dec
20:33:13 <sgallagh> Right, this schedule offers us that option
20:33:20 <sgallagh> Hopefully we won't need it
20:33:34 <langdon> because "everything is awesome!"
20:34:21 <nirik> so, what is the consensus, just move the dec 5th to dec 12th and leave the rest? or ?
20:34:49 * langdon notes go/no-go wasn't in the "real" schedule either.. but i think we should mention it "somewhere"
20:35:40 <sgallagh> langdon: Mind updating your proposal on the wiki and then we can vote on it?
20:35:46 <sgallagh> Or I can, if needed
20:35:46 <langdon> sure
20:35:57 <nirik> yeah, I'd stick those in if they are not on the thursday before.
20:36:22 <langdon> so this, right? target date: GO/No-Go 2017-11-16, ship 2017-11-28. raindate GO/No-Go 2017-11-30 Ship 2017-12-12
20:37:24 <langdon> and the beta is fine?
20:37:59 <sgallagh> langdon: I kind of need to see it in an easy-to-read chart :)
20:38:08 <nirik> that sounds right to me.
20:38:24 <langdon> ha.. in progress
20:38:44 <sgallagh> OK, I managed to parse that
20:38:47 <sgallagh> That sounds about right
20:39:39 <langdon> ok i think that is right
20:40:28 <langdon> re-link: https://fedoraproject.org/wiki/User:Langdon/Proposed_Modular_Server_Release
20:41:12 <nirik> +1
20:42:01 <sgallagh> langdon: Go/No-Go date for our Beta?
20:42:15 <sgallagh> 10-12?
20:42:41 <langdon> sgallagh: yeah... that sounds about right
20:43:12 <langdon> we may also not "release" til the traditional release day.. to capitalize on marketing.. but i want to be "ready" on the 17th
20:43:29 <smooge> +1 to the proposal in https://fedoraproject.org/wiki/User:Langdon/Proposed_Modular_Server_Release
20:44:22 <langdon> ok.. i put in the beta go/no-go for the 12th as well
20:44:32 <sgallagh> langdon: You put Nov. 12 for the go/no-go :)
20:44:35 <langdon> oops
20:44:39 <langdon> just caught that too
20:44:55 <langdon> fixed..
20:45:10 <sgallagh> OK, +1 now
20:45:31 <sgallagh> #agreed https://fedoraproject.org/wiki/User:Langdon/Proposed_Modular_Server_Release is the schedule we will follow
20:45:46 <sgallagh> #topic Fedora Server Classic
20:45:48 * langdon still prefers contyk's proposal that we release before wkstn and cloud :)
20:45:58 <langdon> sorry
20:46:03 <langdon> one more note on prior topic
20:46:10 <langdon> #undo
20:46:10 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x1a3a0ad0>
20:46:25 <langdon> #action langdon to take this proposal to fesco ticket and fesco meeting
20:46:32 <sgallagh> ack
20:46:32 <langdon> unless someone else wants too?
20:46:38 <sgallagh> Be my guest
20:46:47 <langdon> \o/ meetings!
20:47:05 <nirik> probibly can just be in the ticket... as a 'does anyone have problems with this schedule'
20:47:35 <smooge> then a 'does anyone who counts have problems with this schedule'
20:47:53 <langdon> nirik: yeah.. ill try that.. but will also assume no one will read ticket and ask fesco to say "yes"
20:48:12 <sgallagh> smooge: Ha!
20:48:23 * sgallagh reads all of the tickets.
20:48:55 <sgallagh> Can we move on? I have a chicken pot pie coming out of the oven soon :)
20:49:10 <langdon> yep.. sorry.. but i wanted to "officially close"
20:49:25 <sgallagh> #topic Fedora Server Classic
20:49:28 <sgallagh> Proposal: we do *not* ship a traditional style Server Edition, but we test that upgrades from F26 work with the Everything repo.
20:49:52 * nirik would prefer to ship it as normal personally.
20:50:42 <sgallagh> I'd kind of like not having Server-specific bugs blocking the Workstation and Atomic releases
20:50:55 <sgallagh> (For example, FreeIPA is not having its best cycle in F27)
20:51:13 <nirik> yes, but adamw already spent a lot of time and energy getting those fixed up...
20:51:28 <sgallagh> Sure, until the wind blows the house of cards over again :)
20:51:29 <nirik> and they may well be things we need to fix anyhow for modular server
20:51:41 <sgallagh> Yes, but we'd have additional time for it
20:51:57 <sgallagh> They should still be identified and blockers set, just not affect the other two releases.
20:52:21 <sgallagh> The follow-up question here is that, if we *do* ship traditional media as well, on which schedule does it happen?
20:52:33 <nirik> My big fear here is people misunderstanding what it means to not ship a legacy server edition...
20:53:08 <sgallagh> Based on what metrics mattdm has managed to pull together, I'm not sure anyone would really notice
20:54:00 <smooge> well it is very hard to get an idea of what people are using. Most of the iso downloads don't seem to ever get installed
20:54:10 <nirik> I guess I could be ok with it, if we make sure the messaging is good. I think a ton of people go 'hey, I am going to install a server, let me get the server netinstall... oh no! There's no server netinstall! there must be no support for it now
20:54:24 <sgallagh> "support"
20:54:40 <langdon> sgallagh: your bitter is showing :)
20:54:58 <langdon> im with nirik .. sorta.. i think we shouldn't produce it.. but we need VERY good messaging
20:55:05 <nirik> where here support means 'doing the same thing I did last time to install a server machine'
20:55:10 <langdon> right
20:55:15 <sgallagh> I mean, the generic netinstall will still exist with the "Fedora Server Edition" env group available as a selection
20:55:24 <nirik> and it no longer works, so let me just install something else.
20:55:59 <langdon> i would propose we write some tests.. like what do we think should still work and then actually test that it does from composes..
20:56:02 <nirik> sgallagh: so you are saying we still produce and mirror it, but just don't test it?
20:56:16 <langdon> thats what i am mostly thinking too
20:56:20 <nirik> or you mean the everything netinstall?
20:56:21 <sgallagh> nirik: Not exactly
20:56:27 <sgallagh> I meant the everything netinstall
20:56:30 <langdon> but adamw says we can actually run automatic tests for "free"
20:56:40 <nirik> which has different partitioning and filesystem and default packages
20:56:50 <sgallagh> yes
20:58:15 <nirik> if the f27 server getfedora pages explain that and say here is the generic netinstall, you can use it, but it has x y z differences, then that might mitigate the issues. But it seems easier to me to just make it all and ship it and then have a 'new modular server coming soon' note.
20:58:59 <sgallagh> nirik: On the original F27 schedule?
20:59:16 <nirik> yeah.
20:59:22 * quaid hugs langdon & sgallagh quiescently
20:59:46 <sgallagh> ha!
20:59:57 <petervo> i kind of think that presence of the development server iso signals to user that the prod one is coming
21:00:04 * sgallagh did not actually notice that quaid was in this channel when he made that joke
21:00:24 <langdon> i think we may not all be talking about the same plan ...
21:00:42 <quaid> :D apparently I'm everywhere, like Schneider on the original One Day at a Time ... so, in a slightly creepy way
21:01:09 * quaid quiets down
21:01:11 <sgallagh> So, if I understand correctly, this is the current proposal on the table:
21:01:30 <langdon> so.. we build all the rpms and put them in the normal server repo places... but, we don't produce the install media.. so you would have to go get some other way to get your initial install .. then point at the server repo... i think?
21:01:41 * langdon hugs quaid :)
21:02:11 <sgallagh> Proposal: Fedora ships the Fedora 27 Server Edition as a blocking deliverable on the original schedule, with full honors. Fedora also ships Fedora 27 Modular Server Edition on the schedule agreed earlier in this meeting.
21:02:15 <sgallagh> Is that an accurate summary?
21:02:51 <sgallagh> I think langdon is describing an alternate proposal
21:03:06 <langdon> for the record, i am -1 on the above.. i think it is confusing to users to have two "official" servers
21:03:53 <sgallagh> I'm also -1 on the above, but I wanted to make sure we all understood what I didn't agree with :)
21:03:59 <langdon> ha
21:04:09 * nirik likes that one, but if I am an outlyer, thats ok too.
21:04:12 <petervo> doesn't the modular one have a different name?
21:04:24 <smooge> i think not having one is saying "we are all in for modularity."
21:04:33 <langdon> arguably that could be a way to handle it.. but it isn't making "modularity mainline"
21:04:50 <sgallagh> My counter-proposal would be this:
21:04:56 <smooge> which if we are.. that is fine with me
21:05:02 <nirik> so which is better: release f27 legacy server then modular server after or saying 'no legacy server for f27, sorry, please wait' and then releasing modular server.
21:05:18 * langdon waits for sgallagh's typing :)
21:05:33 <sgallagh> Proposal: We build and ship traditional Fedora Server as a *non-blocking* deliverable that goes to spins.fedoraproject.org instead of getfedora.org. We ship Fedora Modular Server on the schedule approved earlier as our official offering.
21:05:50 <smooge> I don't know if the tooling can do that easily
21:06:05 <nirik> that would take releng work, but might be possible. dunno
21:06:26 <smooge> the issue that will come up is even if we say "no server" releng work will be needed
21:06:38 <langdon> one more...
21:06:59 <langdon> Proposal: We build and ship traditional Fedora Server as a *non-blocking* deliverable that goes to normal repos but is only linked to from spins.fedoraproject.org instead of getfedora.org. We ship Fedora Modular Server on the schedule approved earlier as our official offering.
21:07:11 <langdon> and somewhere in f28 we move it
21:07:22 <sgallagh> langdon: How does that differ from mine?
21:07:31 <langdon> sorry... not move it.. make it in spins for real for f28
21:07:35 <smooge> he said it versus you saying it
21:07:39 <sgallagh> ah
21:07:45 <langdon> smooge: so mine is better!
21:08:01 <smooge> if you want to read it that way.. sure
21:08:02 <langdon> sgallagh: mine uses /releases (iirc?) vs /alt
21:08:04 <sgallagh> I think they're identical. I was talking about having the website front-ends for them be in a new place
21:08:18 <langdon> ahh thats what i was clarifying
21:08:19 <sgallagh> I don't actually care where it's mirrored, though our mirror operators might
21:08:29 <langdon> /alt is not really mirrored
21:08:43 <nirik> well, spins.fedoraproject.org and getfedora.org are websites.
21:08:48 <sgallagh> Yes
21:09:11 <sgallagh> From an end-user perspective, that's how we differentiate our major efforts from our community bonus stuff
21:09:21 <nirik> so really what we are nitpicking over is how to handle the getfedora.org server pages.
21:09:33 <langdon> so.. the proposal is just "build it all as normal for traditional server, non-blocking, on the normal schedule" ... but the websites change
21:09:42 <sgallagh> yes
21:10:06 <langdon> nirik: right.. to minimize changes for rel-eng
21:10:13 <sgallagh> (With that "non-blocking" part being important. So let's not miss it while focusing on the trivia)
21:10:45 <nirik> sure, and thats fine. But I'm not sure if we should try and decide the websites content here and now...
21:11:07 <nirik> I guess I could be ok with nonblocking, but note that someone needs to tell qa and update the critera
21:11:29 <langdon> nirik: we started ..
21:11:43 <langdon> at least to add the modular stuff...
21:11:53 <langdon> we can make the other changes too
21:12:07 <langdon> and adamw is at least aware of this option
21:12:08 <nirik> right, but we need to note that the server stuff is non blocking now. perhaps just blanket change it to FE's
21:12:29 <sgallagh> OK, let's at least nail this part down:
21:12:29 <sgallagh> Proposal: Whatever else we decide, any non-modular release media will not be blocking for F27
21:12:48 <nirik> I'm not disagreeing, I am just saying that as of this minute, QA still is treating server critera breakage as blocking.
21:13:00 <nirik> there's 2 IPA blocker bugs. ;)
21:13:22 <sgallagh> yes. I'll coordinate with kparal on that
21:14:33 <nirik> +1 I guess.
21:15:17 <langdon> +1
21:15:24 <sgallagh> To be clear, the criteria we decide on for the Modular Release *will* be blocking, so we will want to fix these as fast as possible.
21:15:48 <sgallagh> This is just ensuring that server-specific stuff doesn't hold up the rest of Fedora
21:15:59 <nirik> right, and we should still try and fix things...
21:16:20 <nirik> because they might affect modular and because it would be nice(tm) to have things working
21:16:26 <sgallagh> Yes
21:17:03 <sgallagh> We probably need to create a new blocker tracker bug for this stuff
21:17:17 <sgallagh> Well, that's probably more hassle than it's worth.
21:17:25 <sgallagh> A one-off policy for F27 is likely fine.
21:17:34 <sgallagh> We can just treat any Server blocker specially.
21:17:40 <nirik> so whats left to decide?
21:17:42 <nirik> yeah
21:18:03 <sgallagh> Whether we are going to produce the traditional media.
21:18:19 <sgallagh> As long as it's non-blocking, I don't much care either way. We can work out the websites stuff with Council
21:18:26 <sgallagh> smooge: Are you okay with the non-blocking decision?
21:18:31 * sgallagh wants to get that in the notes
21:18:35 <nirik> yeah, it's less effort to just keep making it.
21:18:42 <smooge> +1 with niriks concerns
21:18:52 <nirik> and gives us more options on what to decide to put on websites.
21:18:57 <nirik> but it still needs some releng work
21:20:11 <sgallagh> ok
21:20:19 <sgallagh> #agreed Whatever else we decide, any non-modular release media will not be blocking for F27
21:20:35 <sgallagh> And I'm fine with shipping the traditional media, then
21:20:39 <sgallagh> Any opposed?
21:20:40 <nirik> (so we need to file a releng ticket and ask them to unmark server as blocking... so pungi won't fail composes where those things fail to compose)
21:20:49 * sgallagh nods
21:20:58 <sgallagh> nirik: Would you mind doing that?
21:21:04 <nirik> Sure, I can
21:21:19 <sgallagh> #action nirik to file rel-eng ticket to mark server as non-blocking
21:22:11 <sgallagh> #agreed We will continue to produce the traditional media and will work with the Council and Websites team to figure out where the download links will be.
21:22:21 <sgallagh> OK, we're well over time.
21:22:27 <sgallagh> #topic Open Floor
21:22:33 <sgallagh> Anything else urgent for this week?
21:22:52 <langdon> is there anything else i need to fix? or are we covered?
21:22:58 <smooge> sgallagh, your pie is burning?
21:23:15 <smooge> beyond that no
21:23:23 <sgallagh> EEP!
21:23:49 <sgallagh> (I actually took it out a little while ago. Now it's just cold)
21:24:10 <sgallagh> OK, thanks for coming folks
21:24:15 <sgallagh> #endmeeting