fpc
LOGS
15:59:47 <geppetto> #startmeeting fpc
15:59:47 <zodbot> Meeting started Thu May 18 15:59:47 2017 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:59:47 <zodbot> The meeting name has been set to 'fpc'
15:59:47 <geppetto> #meetingname fpc
15:59:47 <geppetto> #topic Roll Call
15:59:47 <zodbot> The meeting name has been set to 'fpc'
16:00:11 <mbooth> Heya
16:00:16 <geppetto> #chair mbooth
16:00:16 <zodbot> Current chairs: geppetto mbooth
16:00:16 <tibbs> Howdy.
16:00:17 <geppetto> Hey
16:00:23 <geppetto> #chair tibbs
16:00:23 <zodbot> Current chairs: geppetto mbooth tibbs
16:00:44 <geppetto> langdon: Hey, you here for the meeting?
16:01:03 <geppetto> Ahh, double langdon's
16:01:39 <langdon_> geppetto, ha.. no.. just hanging out.. i am like quadruple booked.. i can come when we want to talk about modules though.. if you like
16:01:47 * cstratak waves
16:01:57 <langdon_> geppetto, my network is like borked at home.. not sure why
16:02:19 <geppetto> langdon_: Ask langdon, he probably knows why
16:03:15 <Kellin> ls
16:04:01 <mbooth> Kellin: bin  boot  dev  etc  home  lib  lib64  opt  proc  root  run  sbin  srv  sys tmp  usr  var
16:04:14 <geppetto> mbooth: 👍
16:06:01 * limburgher realizes what time it is.
16:06:16 <Kellin> sorry all - alt-tabbed and forgot I was on irc tab not console
16:06:23 * limburgher without assistance from Chuck D.
16:06:30 <geppetto> #chair limburgher
16:06:30 <zodbot> Current chairs: geppetto limburgher mbooth tibbs
16:07:25 <limburgher> Kellin: Could be worse, at least you didn't try to log into anything. :)
16:08:01 <geppetto> hunter2
16:08:13 <geppetto> ᕕ( ᐛ )ᕗ
16:08:37 <geppetto> Anyway … Looks like we won't be getting 5 today.
16:08:52 <geppetto> #topic Schedule
16:08:54 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/Y4VNSV76Z45ZZ4CFNKB73FI7YAP3RYMQ/
16:09:01 <geppetto> #topic #685 Enforce new naming scheme for Python binary packages
16:09:05 <geppetto> .fpc 685
16:09:07 <zodbot> geppetto: Issue #685: Enforce new naming scheme for Python binary packages - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/685
16:09:11 <limburgher> passwd Kellin
16:09:13 <limburgher> *************
16:10:23 <tibbs> So yeah, why don't we just rip out mention of the old naming scheme and use "MUST" for the naming of pythonN- packages?
16:10:38 <geppetto> Anyone have any opinions on this? tibbs has already spoken and I agree with what he said.
16:10:43 <limburgher> Seems like a fairly logical proposition.
16:11:06 * geppetto nods … I'm happy with that too, we'll need to wait to vote on it but I'm happy to give my pointless +1 ;)
16:11:10 <mbooth> +1 to tibbs' proposition :-)
16:11:17 <tibbs> I think it's kind of dumb to put in something that says "old things must be converted" and then have to just take it all out later when none of the cruft exists.
16:11:19 <limburgher> +1
16:11:43 <geppetto> yeh, we'd be putting that sentence all over the place.
16:11:45 <limburgher> tibbs: Yeah, we all know there's cruft.  And likely always will be.
16:12:28 <tibbs> Outside of that draft I put up, there are a couple of extra things we could do if we wanted.
16:13:01 <tibbs> 1) Give our blessing to the "forced conversion" of the remaining poorly-named python packages.
16:13:29 <tibbs> 2) Give the python team a blanket exemption from having to do rename reviews for cases where the base package name needs to change.
16:13:41 <tibbs> (that's it).
16:14:03 <limburgher> Python Declaration of Martial Law?
16:14:06 <limburgher> I like it. :)
16:14:48 <cstratak> on behalf of the Python team, that would be awesome :)
16:15:23 <tibbs> It's been at least five years since the python naming was cleaned up, and poorly named packages will hold up other python efforts at some point in the near future.
16:16:04 <tibbs> I'd prefer that bureaucracy not stand in the way of getting this fixed if the python folks are prepared to put in the effort to fix it.
16:16:18 <geppetto> Might be better to word the exception more "rename to pull packages into compliance with newer naming policy guidlines are except from reviews" ?
16:16:35 <limburgher> Exempt?
16:16:41 <geppetto> yeh, that too
16:16:43 <tibbs> Yeah, that was off the cuff wording.
16:16:48 <limburgher> Works for me.
16:17:05 <geppetto> words are hard
16:17:49 <geppetto> Yeh, I'm fine with it.
16:17:53 <geppetto> #topic Open Floor
16:18:07 <geppetto> Ok, anything else we want to talk about with only 4 of us?
16:18:24 <tibbs> Doh, I didn't realize we didn't have quorum.
16:18:41 <geppetto> Ahh, sorry … thought I'd made it clear.
16:18:50 <tibbs> You probably did.
16:19:00 <limburgher> I mean, I could lose a few pounds, but I'm only 1 person.
16:19:15 <tibbs> Now, as far as I'm concerned, the python team is free to go ahead without getting any blessings from us.
16:19:23 <geppetto> yeh
16:20:34 <tibbs> So we're at +4 for my diff, and I guess we're at +4 on giving them some sort of exemption assuming the wording limits it to just these python packages being changed with the help of the Python maintenance team.
16:21:17 <geppetto> yeh, I think so
16:21:23 <geppetto> Certainly on the first we are at +4
16:21:55 <tibbs> I can write up the exemption in that ticket and then collect votes there.
16:21:56 <geppetto> I don't think mbooth said he agreed with #2
16:22:17 <mbooth> Lack of dissent can be taken as silent assent, etc :-)
16:22:20 <geppetto> You can try … I'll bet $5 it only gets filled by next week ;)
16:23:09 <tibbs> I won't be taking that bet.  Sadly most of us don't get to pay much attention to the tickets until meeting time.
16:23:17 * geppetto nods
16:23:45 <tibbs> I'm trying to get my stuff together for flock.  I'm 100% going already because I'm spending a few days in Boston beforehand and already have an apartment rented.
16:24:11 <geppetto> Oh, cool.
16:24:20 <tibbs> Jennifer (my wife) has never actually been to Boston.
16:25:54 * geppetto nods … you going early, or staying late, to see things?
16:26:11 <tibbs> Going early, it turns out.
16:26:37 <tibbs> Hang out in Boston for a few days, then take the train to the cape.
16:26:43 <geppetto> cool
16:27:25 <tibbs> Should be a nice mini-vacation.
16:28:18 <geppetto> yeh
16:29:14 <tibbs> Anyway, I'm out of stuff to talk about.  Hopefully some other FPC folks can make it to Flock this year.
16:29:42 <geppetto> Maybe … I was hoping to, esp. given how close it is … but then I ended up going to devconf
16:29:52 <geppetto> So I'm less sure now.
16:30:27 <tibbs> I don't actually know where everyone is.  Besides racor being in Germany and Xavier being in Paris.
16:30:38 <geppetto> I'm near Hartford, in CT
16:30:52 <tibbs> Well that is relatively close.
16:30:57 <geppetto> So ~2.5 hours to boston itself
16:31:08 <geppetto> #chair orionp
16:31:08 <zodbot> Current chairs: geppetto limburgher mbooth orionp tibbs
16:31:36 <geppetto> orionp: How do you feel about looking at 685 and voting as the fifth person ?:)
16:31:50 <geppetto> .fpc 685
16:31:51 <zodbot> geppetto: Issue #685: Enforce new naming scheme for Python binary packages - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/685
16:32:06 <mbooth> I try to get to EU flocks, that transatlantic flight is a killer though
16:33:00 <tibbs> mbooth: I take it you're on the right hand side of the pond?
16:33:02 <orionp> so we're considering Tibb's changes?
16:33:11 <mbooth> tibbs: The UK, yeah
16:33:29 <geppetto> orionp: Yeh, also some kind of exception so that python packages can be renamed without having to go through review
16:33:50 <tibbs> mbooth: I've only been to London.
16:34:29 <orionp> geppetto: +1  - what would need to be renamed?
16:34:39 <mbooth> tibbs: My condolences :-p
16:35:03 <tibbs> orionp: http://fedora.portingdb.xyz/namingpolicy/#name-misnamed
16:35:12 <geppetto> #action Enforce new naming scheme for Python binary packages (tibbs change) (+1:5, 0:0, -1:0)
16:35:34 <tibbs> But that list doesn't tell you whether a source package would need to change names.
16:35:45 <tibbs> Mostly this is about s/python-/python2-/
16:36:04 <geppetto> mbooth:  +4 on giving them some sort of exemption assuming the wording limits it to just these python packages being changed with the help of the Python maintenance team.
16:36:22 <mbooth> +1
16:36:27 <orionp> Yeah I would expect there to be much source package renaming
16:37:03 <ishcherb> so far this is only about binary packages
16:37:34 <geppetto> #action Exemption from review, for affected python packages being changed with the help of Python team (+1:5, 0:0, -1:0)
16:37:40 <geppetto> Ok, done.
16:37:45 <pviktori_> note that "Python maintenance team" is a Red Hat entity, you probably want to say "Python SIG"
16:38:05 <geppetto> Yeh, my bad
16:38:08 <geppetto> #undo
16:38:08 <zodbot> Removing item from minutes: ACTION by geppetto at 16:37:34 : Exemption from review, for affected python packages being changed with the help of Python team (+1:5, 0:0, -1:0)
16:38:09 <tibbs> ishcherb: Well we're trying to make it easier on you when you do get down to renaming things like pyqt4.
16:38:13 <geppetto> #action Exemption from review, for affected python packages being changed with the help of Python SIG (+1:5, 0:0, -1:0)
16:39:06 <tibbs> So I will fix up the python guidelines today. Not that anyone has to wait for me in order for any of this work to proceed.
16:39:09 <geppetto> Ok, I think we are done now … unless anyone wants to bring anything up?
16:40:30 <tibbs> Nothing from me.
16:40:44 <geppetto> #endmeeting