atomic-wg
LOGS
17:00:53 <dustymabe> #startmeeting atomic-wg
17:00:53 <zodbot> Meeting started Wed May 10 17:00:53 2017 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:53 <zodbot> The meeting name has been set to 'atomic-wg'
17:00:57 <dustymabe> #topic rollcall
17:01:04 <kushal> .hellomynameis kushal
17:01:05 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:01:05 <dustymabe> .hellomynameis dustymabe
17:01:07 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:01:09 <yzhang> .hello yzhang
17:01:10 <jberkus> .hello jberkus
17:01:11 <zodbot> yzhang: yzhang 'Yu Qi Zhang' <jzehrarnyg@gmail.com>
17:01:14 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:01:19 <jbrooks> .hello jasonbrooks
17:01:20 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:01:45 <sayan> .hello sayanchowdhury
17:01:46 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:01:50 <miabbott> .hello miabbott
17:01:53 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
17:02:07 <roshi> .hello roshi
17:02:08 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:02:58 <dustymabe> #chair jberkus jbrooks sayan miabbott roshi yzhang kushal
17:02:58 <zodbot> Current chairs: dustymabe jberkus jbrooks kushal miabbott roshi sayan yzhang
17:03:06 <dustymabe> #topic previous meeting action items
17:03:18 <dustymabe> ok did we have a meeting last week or did we cancel it ?
17:03:30 <dustymabe> sorry for not being there, was busy with conference stuff
17:03:32 <yzhang> There wasn't one
17:03:43 <yzhang> As far as I can remember
17:04:04 <dustymabe> ok
17:04:10 <dustymabe> will find AI from previous meeting
17:04:11 <roshi> no meeting last week
17:04:21 <dustymabe> * jbrooks to lead writing up the new support policy and plan for rolling
17:04:24 <dustymabe> jbrooks: ^^
17:04:37 <jbrooks> https://pagure.io/atomic-wg/issue/228#comment-439326
17:05:10 <jbrooks> That can become a blog post or something
17:05:29 <jbrooks> pending feedback and whatnot
17:05:42 <dustymabe> jbrooks: reading now
17:05:48 <dustymabe> bear with me
17:06:27 <jdoss> Hola
17:06:57 <dustymabe> jdoss: hiya
17:07:01 <dustymabe> #chair jdoss
17:07:01 <zodbot> Current chairs: dustymabe jberkus jbrooks jdoss kushal miabbott roshi sayan yzhang
17:07:14 <jzb> howdy all
17:07:16 <dustymabe> jbrooks: that looks mostly good to me - maybe one nit - i'll comment in the issue
17:07:18 <jdoss> .hello jdoss
17:07:19 <zodbot> jdoss: jdoss 'None' <joe@solidadmin.com>
17:07:22 <jbrooks> cool
17:07:25 <dustymabe> jzb: hey
17:07:28 <dustymabe> #chair jzb
17:07:28 <zodbot> Current chairs: dustymabe jberkus jbrooks jdoss jzb kushal miabbott roshi sayan yzhang
17:07:29 <jzb> .hellomynameis jzb
17:07:30 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:08:04 <dustymabe> any other comments for jbrooks on that action item?
17:08:14 <jdoss> dustymabe: I have something to discuss regarding fedora cloud 25 and the lack of fedora cloud 26 alpha Vagrant/EC2 test images.
17:08:33 <dustymabe> jdoss: ok, we have open floor for that
17:08:37 <dustymabe> towards the end of the meeting
17:08:42 <dustymabe> sound good?
17:08:49 <jdoss> Kk sounds great
17:09:09 <dustymabe> #topic  fedimg: don't use 'builder' instance for uploading AMIs
17:09:14 <dustymabe> #link https://pagure.io/atomic-wg/issue/269
17:09:28 <jberkus> jbrooks: I think we'll want to add something about how support for N-1 is "best effort", as in not tested at all
17:09:33 <jberkus> even before we go to rolling updates
17:09:46 <dustymabe> sayan gave some of us an overview of fedimg yesterday
17:09:55 <jberkus> it's in the text, but I think it needs to be its own bullet point
17:10:30 <dustymabe> sayan: also gave us an update on the status of this ticket
17:10:36 <sayan> right now I am deploying the changes into dev instances to test how things are working
17:10:51 <jbrooks> jberkus, bullet 4 is solely about that, but I could repeat it at the end
17:10:53 <dustymabe> sayan: great!
17:10:55 <sayan> http://ec2-184-72-150-211.compute-1.amazonaws.com/ami/jobs/3/output
17:11:23 <dustymabe> sayan: so that is a failure?
17:11:31 <jberkus> jbrooks: more I think we need to more directly spell it out.  I'll take a stab at it
17:11:32 <sayan> dustymabe: yes, that's a broken AMI
17:11:41 <dustymabe> sayan: ok
17:11:59 <dustymabe> sayan: so one other thing, there is some other stuff pending on the libcloud update. can you give karma to that update?
17:12:36 <sayan> dustymabe: regarding that issue, the maintainer did not build for el7
17:13:00 <sayan> I dropped him an email few days back, and I was told that he would be updating that for el7 too
17:13:20 <dustymabe> sayan: and you only use it on el7?
17:13:27 <sayan> dustymabe: yes
17:13:46 <dustymabe> ok
17:13:51 <dustymabe> thanks sayan
17:14:01 <dustymabe> next topic
17:14:16 <sayan> I am planning to a scratch build and send over to the maintainer so that it's easier for him
17:14:24 <dustymabe> #topic clarify policy on atomic host support for older Fedora "number" releases
17:14:29 <dustymabe> #link https://pagure.io/atomic-wg/issue/228
17:14:39 <dustymabe> this is what jbrooks talked about earlier
17:14:48 <dustymabe> see https://pagure.io/atomic-wg/issue/228#comment-439326
17:15:06 <dustymabe> please look at that issue and comment on his suggestion
17:15:13 <dustymabe> anything else?
17:15:40 <dustymabe> .
17:15:50 <dustymabe> moving on...
17:15:58 <dustymabe> #topic  design, deploy and document Fedora OpenShift Playground (FOSP)
17:16:07 <dustymabe> #link https://pagure.io/atomic-wg/issue/153
17:16:17 <dustymabe> same state?
17:16:20 <jberkus> dustymabe: blades are getting racked.  no clear timeline on when FOSP will be available to us
17:16:26 <jberkus> dustymabe: question for the group
17:16:47 <dustymabe> i'm with the fedora infra crowd this week at a FAD
17:16:54 <dustymabe> anything you want me to ask any of them specifically ?
17:16:54 <jberkus> dustymabe: given the delays in making Openshift v3 available, I'm reconsidering whether we want to have a "playground", or whether we want running FAO hosting
17:17:19 <jberkus> dustymabe: is fedora infra involved? or is this all OSAS infra?
17:17:29 <dustymabe> no idea
17:17:39 <jbrooks> I think openshift v3 is available now
17:18:12 <dustymabe> what does v3 have anything to do with it?
17:19:19 <jbrooks> w/o v3, there's no public place to play w/ openshift
17:19:44 <dustymabe> jbrooks: are you referring to openshift online?
17:19:51 <walters> i'd just request that the deployment is on bare metal, or at least some of it is - this would help us move some of our VM-based tests into it
17:19:52 <dustymabe> openshift v3 has been out for a long time
17:20:09 <jbrooks> No
17:20:20 <jbrooks> Well, what do you mean by a long time?
17:20:24 <jbrooks> We're talking online
17:20:27 <jberkus> dustymabe: I'm referring to v3 online
17:20:35 <dustymabe> ok yeah
17:20:40 <dustymabe> please don't refer to it as just v3
17:20:45 <dustymabe> that has no meaning
17:20:48 <jberkus> dustymabe: I need somewhere to host the new pa.io site, among other things, and I'd like us to EYODF, which means FAO
17:20:56 <jbrooks> heh, I knew what he meant
17:21:10 <dustymabe> well FAO would run openshift v32
17:21:12 <dustymabe> v3*
17:21:21 <jberkus> right, but we need HW for hosting
17:21:33 <dustymabe> right - ok we're all on the same page
17:21:35 <jbrooks> jberkus, yeah, I'm on v3 online now -- just signed up
17:21:44 <jberkus> I'm suggesting that we dump the idea of a "playground" and instead have a hosted instance of FAO we can use to host things
17:21:51 <jberkus> jbrooks: you are?  I'm still waiting
17:22:08 <dustymabe> where is a hosted instance of FAO going to be hosted?
17:22:40 <jbrooks> jberkus, I am waiting for openshift.io, which I tried to sign up w/ w/ my rh acct, and that's blocking my access to regular v3 online. I just tried signing up w/ my personal acct, and that worked
17:23:17 <jberkus> dustymabe: the plans for FOSP was to host it in the OSAS cage
17:23:25 <jbrooks> Annoyingly, if you're waiting for openshift.io, you're blocked for online, since they don't want you double-dipping
17:24:08 <dustymabe> ok i thought you were sugguesting we dump the OSAS stuff
17:24:37 <dustymabe> either way, we're talking in circles. status: still waiting on hardware, but we may be able to find hosting  for pa.io in openshift online before we get FOSP
17:24:51 <dustymabe> i'll move on to next topic in 20 seconds
17:25:22 <dustymabe> #topic this weeks FAH release
17:25:27 <jberkus> that's a correct summary
17:25:38 <dustymabe> so we are delayed on this weeks release because of a bug in releng
17:25:43 <dustymabe> images aren't building
17:25:45 <dustymabe> :(
17:25:50 <jbrooks> Might as well remove the meeting bug until the hw is available
17:25:59 <dustymabe> https://pagure.io/atomic-wg/issue/273
17:27:01 <dustymabe> so hopefully we'll get that fixed soon so image builds start working again
17:27:12 <dustymabe> #topic open floor
17:27:17 <dustymabe> actually
17:27:20 <dustymabe> wait a sec
17:27:25 <dustymabe> #topic kubernetes in f26
17:27:39 <dustymabe> so.. we are getting down to crunch time for f26
17:27:54 <jberkus> so, the system container version jbrooks built works
17:28:01 <dustymabe> who has had a chance to review jbrooks' work on containerized kube?
17:28:16 <yzhang> I have as well
17:28:25 <yzhang> works as far as I can tell
17:28:41 <dustymabe> so how do we feel about this being mainstream for us?
17:28:55 <jbrooks> One thing about containerized kube is that it works whether or not kube is in the image
17:29:06 <dustymabe> jbrooks: right
17:29:07 <roshi> I don't know enough about kube to really say
17:29:12 <roshi> otherwise I'd look at it
17:29:21 <jbrooks> I guess a big thing is -- how important is the size difference in the image to us?
17:29:25 <jberkus> so here's the steps required (1) need official builds of the contianers in FLIBS (2) need doc updated (3) need an official repo of the modified ansible install, or get Kubernetes to accept it
17:29:34 <jberkus> jbrooks: size difference?
17:29:42 <dustymabe> i'm almost of the opinion that it would be good to have the f26 release to "trial" containerized kube to see if we want to remove it for f27 (in the fall)
17:29:43 <jbrooks> The biggest downside to including it in the image is that you can't rpm-ostree install a different version
17:29:48 <yzhang> if we remove the packaged kube I guess
17:30:38 <dustymabe> jbrooks: but there is only one rpm available in our repos at a given time
17:30:46 <yzhang> jbrooks: well technically if you can have other versioned images, updating the container is really easy
17:30:54 <jbrooks> dustymabe, that's true
17:31:10 <jbrooks> It's easy to use different versions w/ containers
17:31:24 <dustymabe> how does everyone feel about having containerized kube as something we promote for f26, but also leave kube in the image
17:31:30 <dustymabe> and then in f27 we can rip it
17:31:46 <dustymabe> this is kinda how we *can* use overlay2 in f25 now
17:31:50 <dustymabe> but it will be default for f26
17:32:05 <yzhang> its better than directly ripping it
17:32:11 <yzhang> or wait wasn't that the original plan
17:32:24 <jbrooks> I'm looking at centos atomic vs centos atomic continuous -- the latter is missing kube, etcd, flannel, gluster and ceph, and is 100MB smaller, the qcow
17:32:25 <dustymabe> yzhang: well right now in f26 it is *not* there
17:32:44 <dustymabe> yeah all of those binaries are large
17:33:10 <jbrooks> dustymabe, I'm +1
17:33:17 <dustymabe> jbrooks, excellent
17:33:23 <jbrooks> to promoting while we it still built in
17:33:27 <dustymabe> everyone else?
17:33:27 <jberkus> dustymabe: that seems like a good plan.  it means that we can get our users to test contianerized kube
17:33:33 <jbrooks> to shake out issues
17:33:35 <dustymabe> yes, and also give us feedback
17:33:36 <miabbott> dustymabe: seems like a good compromise +1
17:33:39 <yzhang> +1
17:33:45 <dustymabe> walters: ?
17:33:55 <walters> jbrooks, we'll be addressing the replacement case at some point; that's https://github.com/projectatomic/rpm-ostree/issues/485
17:33:56 <jberkus> also, jbrooks++
17:33:56 <zodbot> jberkus: Karma for jasonbrooks changed to 6 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:34:09 <jberkus> ... for figuring out a containerized kube that works even if you have kube installed
17:34:30 <jbrooks> walters, cool
17:34:36 <kushal> Who all are coming PyCon?
17:34:46 <dustymabe> kushal: not the venue for that question
17:34:56 <jbrooks> walters, and will users be able to install layered packages live in the f27 time frame? That'd make this even smoother
17:34:57 <kushal> oops, pressed enter too fast
17:35:16 <dustymabe> :)
17:35:37 <walters> jbrooks, we'll definitely have it under `ex livefs`, need more real world experience before saying how soon it could graduate from `ex`
17:35:47 <dustymabe> ex == experimental
17:35:50 <dustymabe> ?
17:35:52 <walters> yes
17:35:55 <dustymabe> cool
17:35:58 <dustymabe> ok moving to open floor
17:36:02 <dustymabe> well, first
17:36:21 <dustymabe> #agreed we will leave kube in the image for f26 and trial/promote containerized kube
17:36:30 <dustymabe> #topic open floor
17:36:47 * roshi only had budget for one conference, so I don't get to go to pycon this year
17:36:51 <roshi> will be at flock though
17:37:10 <dustymabe> roshi: yay - /me hopes to go to flock
17:37:21 * sayan is going to PyCon
17:37:21 <dustymabe> jdoss: did you have something for us?
17:37:29 <walters> but leave out gluster/ceph?
17:37:35 <jdoss> yea I do
17:37:47 <jdoss> This is in regards to Fedora Cloud image updates for EC2 and Vagrant.
17:37:55 <jdoss> Lack of updates on Fedora Cloud images can cause a poor end user experience. An example of this is with Fedora 25 Vagrant image it's out of date and if a user tries to create a vagrant file with an NFS mount due to this RPCbind bug https://bugzilla.redhat.com/show_bug.cgi?id=1401561. The bug has been fixed for sometime now but the current Fedora 25 base Vagrant box is out of date. My comany uses Fedora Cloud 25 for our developm
17:37:56 <jdoss> ent boxes and we have had to bake our own updated boxes (https://atlas.hashicorp.com/kennasecurity/boxes/25-cloud-base) to get things to work correctly. Most users won't have the time or skills to do this on their end.
17:38:47 <jdoss> Also, Fedora 26 Alpha Cloud images for testing are unavailable while Fedora 26 Atomic Alpha are.
17:39:02 <dustymabe> jdoss: so we have a cloud SIG group for the cloud base image
17:39:16 <jdoss> I am willing to help make these updates and images. I just need to direction on that.
17:39:18 <dustymabe> and we'd really like to get to a point where we are releasing images periodically for cloud base
17:39:36 <dustymabe> maybe we can try to do this for f26 ?
17:39:50 <dustymabe> jdoss: you are willing to help out with it ?
17:40:00 <jdoss> I am down to help out with that. Just having an updated image cuts my dev box build times down by like 10min.
17:40:07 <jberkus> sounds like jdoss can be a member of the cloud SIG
17:40:12 <dustymabe> yep
17:40:21 <jdoss> sorry if this is the wrong meeting for bringing this up
17:40:43 <dustymabe> jdoss: nope, you are fine. we don't have an official meeting for that group yet
17:40:46 <dustymabe> https://pagure.io/cloud-sig
17:41:01 <dustymabe> that is the pagure instance - i've been meaning to migrate some tickets from the atomic-wg tracker into the cloud-sig tracker
17:41:09 <jdoss> OK cool
17:41:40 <dustymabe> #action dustymabe to migrate some cloud-base tickets to the cloud-sig tracker from the atomic-wg tracker
17:41:40 <jdoss> I just feel that if we make the cloud images easier to use in production and devel people will move to Fedora over using other distros.
17:41:57 <dustymabe> :)
17:42:08 * dustymabe loves it when a new contributor starts using "we"
17:42:13 <dustymabe> jdoss: welcome to the community
17:42:31 <jdoss> I offer myself as tribute.
17:42:44 <dustymabe> haha
17:42:44 * jberkus gets out the silver knives and the incense
17:42:46 <dustymabe> nice
17:42:54 <dustymabe> anyone else have anything for open floor
17:43:07 <jdoss> My crying for the day is done.
17:43:19 <dustymabe> jdoss: thanks for hanging around
17:43:24 <jdoss> Anytime.
17:43:32 <dustymabe> ok we'll wind this down
17:43:33 <roshi> welcome jdoss :)
17:43:42 <x3mboy> Hi
17:43:46 <x3mboy> It's me again
17:43:48 <dustymabe> x3mboy: hi
17:43:50 <dustymabe> welcome
17:44:02 <x3mboy> Sorry, but Talking Points are not ready yet :(
17:44:27 <x3mboy> dustymabe, thanks :D
17:45:04 <dustymabe> jberkus: ^^
17:45:29 <jberkus> hey
17:45:37 <jberkus> x3mboy: what time zone are you in?
17:49:13 <dustymabe> did we lose him?
17:49:16 <dustymabe> x3mboy: ^^
17:49:26 <x3mboy> UTC-3
17:49:28 <deuscapturus> My network disconneted.  Did I miss open open floor?
17:49:40 <dustymabe> deuscapturus: it's open floor now
17:49:46 <dustymabe> deuscapturus: welcome back
17:50:00 <deuscapturus> excellent.  thank you.  I would like to follow up on https://bugzilla.redhat.com/show_bug.cgi?id=1423753
17:50:04 <x3mboy> dustymabe, Sorry, I'm in several meetings
17:50:09 <deuscapturus> It's still the case that I cannot copy any AMI's.. old or new.
17:50:15 <jberkus> x3mboy: can we sync up on talking points tommorrow?  work through them?
17:50:25 <x3mboy> jberkus, of course!!!
17:50:36 <dustymabe> deuscapturus: yep the issue is still open. sayan is very close to getting it fixed
17:50:43 <dustymabe> thanks for pinging us on it again
17:50:52 <deuscapturus> great thanks!
17:50:52 <x3mboy> Thanks, and sorry again, but is important to the marketing meeting
17:51:04 <x3mboy> s/meeting/team/g
17:51:07 <dustymabe> deuscapturus: do you have a specific AMI you are trying to access? Fedora Atomic or Fedora Cloud base?
17:51:19 <jberkus> x3mboy: that's fine, and it helps that you're here for reminders
17:51:33 <dustymabe> x3mboy: jberkus schedule a meeting?
17:51:37 <dustymabe> so that we don't drop it
17:51:57 <jberkus> dustymabe: yeah, bringing up a time zone converter
17:51:58 <deuscapturus> dustymabe: both.  I've tried several.  But it's the AMI generally in the 125523088429 account.
17:52:12 <x3mboy> jberkus, dustymabe No problem from me
17:52:26 <dustymabe> deuscapturus: yep. the reason I ask is because *new* images will have proper perms
17:52:35 <jberkus> x3mboy: I'm available 1800 UTC or later
17:52:42 <deuscapturus> Also, I would like to participate in this community more.  Should I register with the chat bot?
17:52:42 <dustymabe> we don't yet have a way to retroactively go back and fix old ones
17:53:04 <dustymabe> deuscapturus: thats awesome, basically just hang out in #fedora-cloud
17:53:14 <dustymabe> and come to these meetings
17:53:26 <dustymabe> and volunteer when work exists that you want to work on
17:53:27 <jberkus> dustymabe: how does he register?  with fedoraproject.org?
17:53:38 <dustymabe> register for what exactly?
17:53:54 <deuscapturus> I notice that people .hello at the beginning of this meeting
17:54:26 <dustymabe> deuscapturus: yep, do you have a FAS account?
17:54:31 <dustymabe> with Fedora?
17:54:37 <deuscapturus> I think so...
17:54:40 <deuscapturus> .hello deuscapturus
17:54:41 <zodbot> deuscapturus: deuscapturus 'Theodore Cowan' <t@theodore.me>
17:54:45 <deuscapturus> yep :)
17:54:46 <dustymabe> there you go :)
17:55:09 <dustymabe> #action x3mboy and jberkus to hold meeting tomorrow to discuss marketing talking points
17:55:17 <dustymabe> ok I think we are done with the meeting
17:55:27 <dustymabe> deuscapturus: let's chat in #fedora-cloud
17:55:32 <dustymabe> thanks for coming everyone!
17:55:35 <dustymabe> #endmeeting