fedora_atomic_wg
LOGS
17:00:20 <dustymabe> #startmeeting fedora_atomic_wg
17:00:20 <zodbot> Meeting started Wed Jan  4 17:00:20 2017 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:20 <zodbot> The meeting name has been set to 'fedora_atomic_wg'
17:00:36 <dustymabe> #topic roll call
17:00:52 <jbrooks> .hello jasonbrooks
17:00:54 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:00:54 <sayan> .hello sayanchowdhury
17:00:57 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:02:18 <coremodule> .hello coremodule
17:02:19 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
17:02:29 <walters> .hello walters
17:02:30 <zodbot> walters: walters 'Colin Walters' <walters@redhat.com>
17:02:46 <maxamillion> .hello maxamillion
17:02:47 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:03:23 <tflink> .hello tflink
17:03:25 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
17:03:34 <jberkus> .hello jberkus
17:03:35 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:03:56 * dustymabe wonders if roshi is free today to join
17:03:58 <dustymabe> :)
17:04:03 <dustymabe> sometimes we get lucky
17:04:38 <tflink> it's possible but I think that he's otherwise occupied this week
17:04:52 * gholms takes a seat in the bleachers
17:04:56 <scollier> .hello scollier
17:04:58 <dustymabe> cool deal
17:04:58 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:05:09 <dustymabe> scollier: hiya
17:05:21 <scollier> dustymabe, heya
17:05:39 <dustymabe> cool I think we have most people filtered in
17:05:49 <dustymabe> I'll get started with action items from last meeting
17:05:55 <dustymabe> #topic action items from last meeting
17:06:03 <dustymabe> * add kubernetes packages back into the base OStree for FAH 25
17:06:06 <dustymabe> * jberkus to create tickets for prerequisites for removing kube packages
17:06:07 <dustymabe> from  base ostree
17:06:09 <dustymabe> * dustymabe to follow-up on merge of UEFI patch into anaconda
17:06:11 <dustymabe> * dustymabe, walters to discuss new release process at beginning of
17:06:13 <dustymabe> calendar year 2017
17:06:16 <dustymabe> * dustymabe walters jberkus to explore overlayfs writeability issue
17:06:17 <dustymabe> * dustymabe to blog using overlayfs in Atomic
17:06:20 <dustymabe> so we did add k8s packages back to atomic host - check
17:06:40 <dustymabe> I'm still working on getting UEFI fix into F25
17:06:46 <dustymabe> that one was harder than I thought it would be
17:06:49 <jberkus> dustymabe: feh, knew I was missing something before shutdown
17:06:58 <jberkus> nothing done on the kube tickets so far
17:07:18 <dustymabe> and the rest of the items need to be re-actioned
17:07:33 <dustymabe> #action jberkus to create tickets for prerequisites for removing kube packages from  base ostree
17:07:44 <jberkus> dustymabe: kubernetes was added back in, that was completed
17:07:57 <dustymabe> jberkus: yep
17:08:20 <dustymabe> jberkus: oh, are you saying that my re-action isn't right?
17:08:28 <jberkus> no
17:08:32 <dustymabe> ok
17:08:53 <dustymabe> I'm not going to re-action the UEFI thing because we have a ticket for that
17:08:58 <dustymabe> with a tag of meeting
17:09:22 <dustymabe> #action dustymabe, walters to discuss new release process at beginning of calendar year 2017
17:09:32 <dustymabe> #action dustymabe walters jberkus to explore overlayfs writeability issue
17:09:40 <dustymabe> ^^ that probably deserves a ticket in itself
17:09:50 <dustymabe> #action dustymabe to blog using overlayfs in Atomic
17:09:58 <jberkus> dustymabe: I'm waiting on your blog post for that one
17:10:05 <jberkus> so that I can do some application testing
17:10:31 <jberkus> developers (Dan, etc.) think there shouldn't be issues, but nobody's tested
17:10:32 <dustymabe> jberkus: ok, I'll get you a draft, but actually I want to include some of the possible *problems* with it in the blog post
17:10:47 <dustymabe> so i'll get you the steps so you can set it up
17:11:00 <dustymabe> and then you can contribute to possible issues that we've seen with it
17:11:05 <dustymabe> sound good?
17:11:42 <jberkus> yes
17:11:46 <bowlofeggs> .hello bowlofeggs
17:11:46 <dustymabe> ok
17:11:46 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
17:11:51 <dustymabe> bowlofeggs: \o/
17:12:02 <dustymabe> ok, on to meeting items
17:12:15 <dustymabe> #topic November 21 ISO is not bootable on UEFI
17:12:21 <dustymabe> #link https://pagure.io/atomic-wg/issue/185
17:12:48 <dustymabe> I'm working on this with dgilmore to get our Atomic image building from the right location every night
17:13:04 <maxamillion> this happened again?
17:13:08 <dustymabe> they were actually building from an RC3 location that was just cleaned up and so...
17:13:15 <dustymabe> maxamillion: define again?
17:13:42 <dustymabe> maxamillion: well.. this is the "location" for the installer (anaconda)
17:13:50 <maxamillion> dustymabe: I feel like the issue of images are being built from the wrong sources content is a common re-occurance
17:13:54 <dustymabe> not the location of the ostree that it gets built from
17:14:11 <maxamillion> k
17:14:12 <dustymabe> maxamillion: yes, that is true
17:14:23 <dustymabe> there are many different pieces to the puzzle unfortunately
17:14:35 <dustymabe> ok, so I've got that one
17:14:48 <dustymabe> #topic  Future of Fedora Dockerfiles
17:14:54 <dustymabe> #link https://pagure.io/atomic-wg/issue/180
17:14:59 <dustymabe> anyone with anything on that one?
17:15:17 <dustymabe> scollier: ^^
17:15:21 <scollier> dustymabe, yup. looking
17:15:54 <scollier> dustymabe, i believe maxamillion has the infra set up now, and it has been blogged about to take on that work.
17:16:13 <scollier> dustymabe, i'm not sure if it's been communicated to all the package maintainers?
17:16:20 <dustymabe> scollier: do you mind updating the ticket?
17:16:36 <maxamillion> scollier: I sent it to devel list and announce list, everyone should know about it
17:16:40 <scollier> but, at any rate, for any package reflected in fedora-dockerfiles, i can point them to maxamillions wiki page
17:16:44 <scollier> dustymabe, will do
17:16:47 <scollier> maxamillion, great work on that.
17:16:47 <jberkus> we need to collectively port those files to FDLIBS, no?
17:16:51 <maxamillion> scollier: thanks :)
17:16:56 <maxamillion> scollier: it's been a massive journey
17:16:59 <jberkus> or has maxamillion already done that?
17:17:18 <maxamillion> I have not done that
17:17:25 <scollier> i don't know that any owners of any fedora-dockerfiles have taken any action
17:17:27 <dustymabe> scollier: does this mean we will not be hosting images in docker hub any longer?
17:17:37 <jberkus> scollier: don't have to be an owner
17:17:43 <jberkus> anyone can do the port
17:18:08 <scollier> dustymabe, i'm not sure.  right now, the docker hub account is attached to the fedora cloud github account
17:18:29 <jberkus> dustymabe: let's make a new issue: "organize effort for porting fedora-dockerfiles to FDLIBS"
17:18:32 <jberkus> I'll take it
17:18:33 <scollier> dustymabe, we probably need a new ticket so we can spend some time evaluating that
17:18:45 <dustymabe> maxamillion: probably has some context on that as well
17:18:59 <maxamillion> we don't yet have it setup to mirror images to docker hub (it's on the backlog) so just make note of that
17:19:10 <dustymabe> maxamillion: so it is something we want to do/
17:19:13 <dustymabe> ?
17:19:27 <dustymabe> wasn't sure of our stance on that
17:19:38 <scollier> dustymabe, i think we don't want to lose the fedora/apache image which has > 1 million downloads
17:19:40 <maxamillion> dustymabe: "it is" <--- what is "it" ?
17:20:06 <dustymabe> "it is" == mirror images built from the layred image build service to docker hub
17:20:18 <maxamillion> oh yeah, that's a plan for the future
17:20:21 <scollier> dustymabe, maxamillion, if we could preserve that by switching the backend, that would be good
17:20:27 <dustymabe> cool
17:20:33 <dustymabe> ok next ticket?
17:20:35 <maxamillion> scollier: +1
17:20:45 <scollier> dustymabe, sure
17:21:22 <dustymabe> #action scollier to update ticket on Future of Fedora Dockerfiles
17:21:32 <dustymabe> #topic Finish new Fedora Cloud PRD
17:21:37 <dustymabe> #link https://pagure.io/atomic-wg/issue/170
17:21:45 <dustymabe> jberkus: this one is listed as "on-hold"
17:21:56 <jberkus> dustymabe: not sure why
17:22:02 <jberkus> "in progress" would be more accurate
17:22:12 <dustymabe> ok, i'll remove the label
17:22:38 <jberkus> all help welcome
17:22:41 <jberkus> here: https://public.etherpad-mozilla.org/p/fedora_cloud_PRD
17:22:49 <jberkus> PRDs are long ...
17:22:59 <dustymabe> I just removed the label
17:23:29 <dustymabe> holy crap, that is a lot of text
17:24:07 <dustymabe> are we allowed to just remove a bunch of it :)
17:24:43 <jbrooks> yes
17:25:00 <jbrooks> Is this mostly the existing one, or is it mostly new?
17:25:37 <jberkus> mostly existing
17:26:09 <dustymabe> cool, jberkus when is this due?
17:26:34 <jberkus> october 2016, as I recall
17:26:47 <dustymabe> haha, well we'll never hit that deadline
17:27:04 <jberkus> so sooner rather than later
17:27:33 <dustymabe> yeah, i just don't see myself getting to this this week, a bunch of other firefighting going on right now
17:27:41 <dustymabe> unfortunately
17:27:50 <dustymabe> i'll get to those details in a bit
17:27:57 <dustymabe> does anyone have time to review the PRD?
17:29:18 <jbrooks> I can go through it -- but what are we trying to do w/ this?
17:29:26 <dustymabe> yeah good question
17:29:33 <jbrooks> Like, mainly, make it atomic host specific?
17:29:39 <dustymabe> I guess update it to try to reflect our current goals
17:29:48 <dustymabe> jberkus: ^^
17:30:00 <jberkus> yes
17:30:05 <jbrooks> I'll read it it, and make comments
17:30:10 <jberkus> given that that PRD was written when AWS was new
17:30:21 <jbrooks> Whoa
17:30:38 <dustymabe> jberkus: jbrooks: once you have done an iteration, can you then ping me and I can try to review it then
17:30:46 <jbrooks> dustymabe, yes
17:31:09 <dustymabe> #action jberkus jbrooks to do initial draft of PRD and ping dusty and group for further review
17:31:13 <dustymabe> thanks!
17:31:20 <jbrooks> Also, does anyone know which, if any, of the other fedora PRDs are considered really excellent?
17:31:44 <dustymabe> jbrooks: probably a question for mattdm
17:32:00 <jbrooks> ok, I'll hit him up
17:32:30 <dustymabe> he linked to this in the ticket from fedora server
17:32:32 <dustymabe> https://kolinahr.fedorainfracloud.org/
17:32:38 <dustymabe> not really sure what all of that is
17:32:40 <dustymabe> but...
17:33:11 <jbrooks> fancy
17:33:19 <dustymabe> #topic Ship fedora-motd in F24 atomic image
17:33:26 <dustymabe> #link https://pagure.io/atomic-wg/issue/160
17:33:30 <dustymabe> rtnpro is not here
17:33:33 <dustymabe> moving on
17:33:34 <maxamillion> f24 is dead
17:33:37 <dustymabe> haha
17:33:42 <dustymabe> yeah, I think the idea lives on though
17:33:48 <maxamillion> alright ...
17:33:54 <dustymabe> #topic Proposed website changes for Cloud Base → Atomic Host switch
17:34:00 <dustymabe> #link https://pagure.io/atomic-wg/issue/158
17:34:17 <dustymabe> So.. robyduck is almost done with the new cloud page for alt.fp.o
17:34:24 <jberkus> ok
17:34:25 <dustymabe> he sent me some really nice looking mockups
17:34:30 <dustymabe> looked awesome
17:35:00 <dustymabe> this was one of the early ones
17:35:01 <dustymabe> https://pagure.io/atomic-wg/issue/158
17:35:04 <dustymabe> sigh wrong link
17:35:06 <dustymabe> http://imgur.com/a/kHZ80
17:35:20 <dustymabe> etc etc.. it is being worked on
17:35:48 <dustymabe> i'll also ping him in that ticket
17:36:03 <dustymabe> #topic design, deploy and document Fedora OpenShift Playground (FOSP)
17:36:09 <dustymabe> #link https://pagure.io/atomic-wg/issue/153
17:36:17 <dustymabe> anybody with anything on this one?
17:36:24 <maxamillion> not I
17:36:46 <dustymabe> scollier: misc ^^
17:37:45 <walters> i've been working with the Origin folks on their https://github.com/openshift/release cluster
17:38:05 <walters> it's not the same thing, but just a FYI
17:38:36 <dustymabe> walters: so that helps them build the software and do the release easier?
17:38:41 <walters> hopefully at some point soon the FOSP isn't a playground but actually used for release and testing processes
17:38:57 <walters> hence more self hosting
17:39:38 <dustymabe> i guess we lost scollier
17:39:45 <dustymabe> i'll ping them in the ticket
17:39:59 <dustymabe> walters: thanks for the FYI, interested to see how that can tie in
17:40:59 <dustymabe> ok moving to open floor
17:41:03 <dustymabe> #topic open floor
17:41:08 <dustymabe> I have an item
17:41:10 <dustymabe> anyone else?
17:41:25 <jberkus> yes
17:41:39 <dustymabe> jberkus: shoot for it
17:42:21 <jberkus> shortly before break, mattdm submitted a contianer to FDLIBS
17:43:10 <jberkus> this is a test of the review/submission process
17:43:13 <jberkus> which means we need a process
17:43:15 <jbrooks> me too: https://bugzilla.redhat.com/show_bug.cgi?id=1404421
17:43:24 <jberkus> and folks who are going to do the review
17:43:28 <jbrooks> that's also a blocker for containerized kube
17:44:55 <dustymabe> jberkus: so what are you saying?
17:45:06 <dustymabe> that we don't have a process?
17:45:29 <jberkus> well, yes
17:45:33 <jbrooks> Well, for instance, I'm wondering what the next step is for mine
17:45:37 <jbrooks> misc reviewed it
17:45:56 <jberkus> maxamillion threw some text up, but it doesn't amount to a process.  we need to actually come up with a series of steps
17:46:36 <jberkus> incidentally, why are container reviews on bugzilla instead of paguire?
17:46:39 <maxamillion> what?
17:46:49 <maxamillion> there's a series of steps, it's exactly like the ones for creating a rpm package
17:47:23 <misc> yup, we did follow that
17:47:34 <misc> and IIRC, now, the package is approved
17:47:41 <maxamillion> jberkus: because reviews are in bugzilla, all the tooling in the Fedora Infrastructure to handle DistGit sync's is written that way
17:47:50 <jberkus> ah, ok
17:47:55 <misc> https://bugzilla.redhat.com/show_bug.cgi?id=1404421
17:48:32 <maxamillion> it's been this way for over a decade, we're just adding a new deliverable on top of it which is brand new and never before explored territory so there's certainly room to improve and iterate
17:49:16 <jberkus> maxamillion: what I'm missing (as a potential reviewer) from https://fedoraproject.org/wiki/Container:Review_Process
17:49:28 <jberkus> is: "how do I decide if the image definition is good enough"?
17:49:53 <maxamillion> jberkus: the guidelines
17:50:02 <maxamillion> jberkus: and they are sparing, so we need to make them better
17:50:23 <misc> jbrooks: so, the part missing is "At this point, you need to make an SCM admin request for your newly approved Layered Image. If you have not yet been sponsored, you will not be able to progress past this point. (You will need to make sure to request the docker namespace in PackageDB) "
17:50:25 <jberkus> yah
17:50:28 <maxamillion> jberkus: but ultimately the guidelines should be comprehensive enough that we can say "if it complies with these guidelines, then it's good enough"
17:50:34 <jberkus> we also need to decide on standards for uniqueness
17:50:35 <jberkus> like
17:50:39 <jbrooks> misc, ah, ok
17:50:48 <misc> jbrooks: I totally forgot about this one :/
17:50:51 <misc> I should have told
17:50:52 <jberkus> "how many different variations on a mysql image do we want to accept"?
17:51:01 <maxamillion> jberkus: exactly one
17:51:05 <misc> (or zero)
17:51:13 <maxamillion> jberkus: you can't overload the namespace "mysql"
17:51:21 <maxamillion> jberkus: pkgdb would conflict
17:51:30 <maxamillion> jberkus: and koji would fail the builds
17:52:07 <jberkus> maxamillion: mysql, vs mysql-galera, vs. webscalesql, vs xtradb
17:52:30 <jberkus> however, this is a much longer discussion
17:52:41 <jberkus> which we shouldn't have during a meeting
17:52:47 <dustymabe> agreed :)
17:52:53 <dustymabe> ok I have an item for open floor
17:52:57 <maxamillion> jberkus: it's the same answer to the question of "do we allow rpms of each of those things into the distro?" ... to me the answer is "yes, so long as someone is willing to maintain it"
17:53:24 <dustymabe> basically #firefighting
17:53:54 <dustymabe> Number 1 - we have a docker rpm that won't download images from gcr.io - so no kubernetes pause pod can get pulled down
17:54:04 <dustymabe> https://bugzilla.redhat.com/show_bug.cgi?id=1409873
17:54:16 <maxamillion> dustymabe: is it a rht patch causing the issue?
17:54:43 <dustymabe> maxamillion: fix coming in: https://github.com/containers/image/pull/195
17:55:05 <dustymabe> it's part of containers/image so..
17:55:16 <maxamillion> dustymabe: so yes, I believe the answer is "yes"
17:55:17 <maxamillion> fantastic
17:55:40 <maxamillion> bugs happen, life goes on
17:55:43 <dustymabe> Number 2 - we can't currently build cloud images/isos etc because of we were using the wrong install location and it got cleaned up
17:55:49 <dustymabe> https://pagure.io/pungi-fedora/blob/f25/f/fedora-atomic.conf#_325
17:55:53 <jberkus> we really need an automated test which deploys a multi-node kube cluster and launches an application
17:56:15 <dustymabe> not sure why we were using that location, but now we need to find the right place and use that instead
17:56:29 <dustymabe> I'm going to work with Dennis to get that resolved
17:56:41 <dustymabe> that is all
17:56:57 <dustymabe> oh - one other thing, we need to file f26 change requests by the end of january
17:57:31 <jberkus> hmmm
17:57:34 <maxamillion> do we have Changes queued up?
17:57:39 <jberkus> the big think would be removing kube binaries
17:57:47 <dustymabe> jberkus: yep, that is one
17:57:53 <jberkus> but seems unlikely that'll be resolved by the end of january
17:58:18 <dustymabe> the other would be overlayfs by default - at least we want to "try" to do that - we can punt on it if we find it not usable
17:58:34 <jberkus> hey, will enough people be at DevConf for us to have one or more work sessions there?
17:58:47 <dustymabe> I assume these are change requests -- the issues don't have to be resolved by that time
17:58:48 <dustymabe> right?
17:58:51 <jberkus> dustymabe: overlayfs looks more likely or not
17:59:14 <maxamillion> there will be plenty of folks at DevConf
17:59:31 <dustymabe> jberkus: yes, please plan some sessions
17:59:56 <jberkus> #action jberkus to lead planning some fedora-atomic work sessions around devconf
18:00:01 <maxamillion> let's come up with objectives that we want to accomplish, I'd rather night whiteboard for a couple hours and then lose it all in an etherpad nobody ever looks at again
18:00:05 <jberkus> this means y'all need to read the mailing list
18:00:35 <jberkus> maxamillion: I was thinking more of "let's review some images", for example!
18:00:52 <dustymabe> jberkus: which mailing list?
18:00:58 <jberkus> fedora-cloud
18:01:07 <dustymabe> k, i'm good on that
18:01:20 <dustymabe> ok we are out of time
18:01:26 <dustymabe> any last words before I close?
18:01:31 <maxamillion> jberkus: oh yeah, we could do that
18:01:36 <jberkus> <cough>
18:01:38 <maxamillion> jberkus: and improve the guidelines as we go
18:01:43 <jberkus> maxamillion: exactly
18:01:50 <maxamillion> jberkus: or hell, just have a workshop around hashing out guidelines
18:02:08 <jberkus> I think it'll work better if we have image submissions in front of us
18:02:13 <jberkus> but let's take this to #fedora-cloud
18:02:21 <maxamillion> +1
18:03:14 <dustymabe> #endmeeting