server_working_group_weekly_meeting_(2017-01-03)
LOGS
21:00:30 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2017-01-03)
21:00:30 <zodbot> Meeting started Tue Jan  3 21:00:30 2017 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:30 <zodbot> The meeting name has been set to 'server_working_group_weekly_meeting_(2017-01-03)'
21:00:31 <sgallagh> #chair nirik sgallagh mhayden dperpeet smooge jds2001 vvaldez adamw mjwolf
21:00:31 <zodbot> Current chairs: adamw dperpeet jds2001 mhayden mjwolf nirik sgallagh smooge vvaldez
21:00:31 <sgallagh> #topic roll call
21:00:31 <sgallagh> .hello sgallagh
21:00:31 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
21:00:39 <smooge> .hello smooge
21:00:40 <zodbot> smooge: smooge 'Stephen J Smoogen' <smooge@gmail.com>
21:00:41 <mhayden> .hello mhayden
21:00:43 <nirik> .hello kevin
21:00:43 <zodbot> mhayden: mhayden 'Major Hayden' <major@mhtx.net>
21:00:44 <vvaldez> .hello vvaldez
21:00:46 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
21:00:49 <zodbot> vvaldez: vvaldez 'Vinny Valdez' <vvaldez@redhat.com>
21:00:58 <jds2001> .hello jstanley
21:00:59 <zodbot> jds2001: jstanley 'Jon Stanley' <jonstanley@gmail.com>
21:01:01 <adamw> .hello adamwill
21:01:02 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
21:01:11 <adamw> ahh, server meeting starts, that means it's lunctime
21:01:36 <jds2001> adamw: means its almost time to go home! :D
21:01:52 <sgallagh> Silly left-coasters...
21:01:58 <mhayden> i'm with jds2001 ;)
21:02:02 <sgallagh> Welcome back, everyone!
21:02:25 <sgallagh> I hope everyone enjoyed whatever New Year festivities they indulge in.
21:02:41 <mhayden> i verified all of my RPMs
21:02:45 <mhayden> one of my yearly festivities
21:03:00 * jds2001 enjoyed his leap second
21:03:10 <vvaldez> sgallagh: my wife had so much work around the house to do, I’m glad vacation is over so I can be less stressed now -_-
21:03:22 <jds2001> gave me one more drink of hopscape, im sure :D
21:04:03 <sgallagh> OK, so I've put together a ridiculous pile of topics to discuss this year.
21:04:15 <sgallagh> Let's put together an agenda for today.
21:04:19 <sgallagh> #topic Agenda
21:04:26 <sgallagh> #info Agenda Item: Bikeshed on a marketing-friendly name for the modular Server
21:04:26 <sgallagh> #info Agenda Item: Check-in on the NFS Server Role
21:04:26 <sgallagh> #info Agenda Item: Feedback on the Domain Controller Role first draft
21:04:27 <sgallagh> #info Agenda Item: Official media support for Fedora Server
21:04:27 <sgallagh> #info Agenda Item: Fedora Server base image for cloud providers
21:04:28 <sgallagh> #info Agenda Item: Banner images in the installer
21:04:29 <sgallagh> #info Agenda Item: WG Membership Check-in
21:04:32 * jds2001 thought that was all for today!
21:04:42 <smooge> so I looked up the history of bike sheds and similar things. And from that I came up with the "perfect" name
21:04:58 <mhayden> Federver?
21:05:01 <smooge> Fedora Folly https://en.wikipedia.org/wiki/Folly
21:05:07 <adamw> Fedora Modular Server?
21:05:27 <adamw> (it does exactly what it says on the .iso)
21:05:35 <sgallagh> OK, before we start discussion, I'd actually like to set the agenda for today.
21:05:45 <sgallagh> Clearly we won't have time to discuss all of these topics.
21:06:12 <sgallagh> So I was hoping we could agree as a group on two to cover today (and go back to the list for more if we finish before the hour)
21:07:19 <vvaldez> sounds good, how shall we vote?
21:07:40 * jds2001 thinks that showing progress on the NFS role is important
21:07:40 <dustymabe> .hello dustymabe
21:07:43 <jds2001> but im biased :)
21:07:44 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
21:07:51 <sgallagh> I suggest everyone list the two they want to discuss most urgently and we'll take the most common answers
21:08:43 <nirik> whats official media support? which medias we will make?
21:08:51 <sgallagh> (actually, regardless of the others, I'd like to do the membership check-in over the next week; we have one seat that's been held by a person who hasn't been participating for months)
21:09:00 <nirik> or if NBC is going to interview sgallagh. ;)
21:09:06 <dustymabe> sgallagh: I guess "Fedora Server base image for cloud providers" for me
21:09:14 <sgallagh> nirik: Been there, done that. (Don't ask)
21:09:27 <vvaldez> official media support, base image for cloud providers
21:09:53 <sgallagh> Domain Controller Draft. Server image for cloud providers.
21:10:01 <geppetto> sgallagh: NFS server role, esp. as I thought you said something about other people helping
21:10:36 <nirik> NFS server role, base image for cloud providers.
21:10:39 <sgallagh> nirik: See Kamil's email to the list.
21:11:00 <sgallagh> Basically whether we specifically want QA to test all of our media, or if some versions are more blessed than others.
21:11:14 <nirik> ah. I see. That was so long ago I forgot about it. ok.
21:11:19 <sgallagh> (sorry, just realized I hadn't actually answered your original question)
21:12:19 <sgallagh> Anyone else want to weigh in? It looks like we have a rough consensus for NFS and cloud images, though
21:13:13 <dustymabe> sgallagh: is the cloud image discussion in reference to another discussion on a mailing list or something?
21:13:20 <dustymabe> if so, I missed it
21:13:55 <smooge> sgallagh, same as others.
21:13:58 <sgallagh> dustymabe: Nothing specific
21:14:11 <sgallagh> Which is mostly the reason it needs to be discussed; it's unclear where we are.
21:14:30 <dustymabe> cool
21:14:32 <sgallagh> OK, any preference which to do first?
21:15:04 * jds2001 hopes that the NFS role would be quick. Cloud might not be so quick.
21:15:35 <sgallagh> It might be, if only because dperpeet isn't around...
21:15:36 <mhayden> agreed -- NFS should take less effort than cloud
21:15:44 <sgallagh> But I'll cover what I can
21:15:55 <jds2001> oops, well then it would be really quick
21:15:59 <sgallagh> #topic Check-in on the NFS Server Role
21:16:07 <mhayden> i've ruined -- i mean, created plenty of cloud images in the past
21:16:13 <jds2001> since i havent heard anything :)
21:17:14 <sgallagh> So, shortly before the holiday break, I learned that there is an ongoing effort to develop a new set of Ansible modules that should provide a unified approach to setting up NFS shares on target machines.
21:18:04 <sgallagh> In particular, the intent is that these modules should provide the same API regardless of the distro version installed on the target machine. (So regardless of whether it's modern Fedora or older RHEL/CentOS, the same playbooks should work).
21:18:21 <nirik> cool
21:19:03 <sgallagh> I had "get the module writers, Cockpit developers and role overseers together for a meeting" on my agenda for today, but I didn't get to it in time for the Europeans to vanish.
21:19:07 <vvaldez> that sounds ideal
21:19:20 <sgallagh> I'll hopefull try to organize something tomorrow morning (my time)
21:20:28 <sgallagh> From the Cockpit side, I had a meeting with dperpeet, andreasn and mvollmer to discuss what we are looking for. It mostly amounted to brain-dumping ten years of NFS esoterica on poor Marius, but I think he understood where we need to go.
21:20:59 <sgallagh> We have a good start on the use-cases we want to address. jds2001, could you post the link?
21:21:27 <jds2001> one sec
21:21:30 <nirik> sounds like it should be pretty handy.
21:21:53 <jds2001> https://docs.google.com/document/d/1jLyKsECdHdlKltmHGgf_-iOKj-hj4Qjbh5Zgm7a-eMc/edit
21:21:56 <sgallagh> Thanks
21:22:28 <sgallagh> The plan is that Cockpit will provide a nice, human-understandable UI for creating shares and then output an Ansible playbook using the new modules.
21:22:52 <sgallagh> Where by "output" I mostly mean "will offer to execute it directly or late you save it."
21:23:35 <jds2001> sgallagh: one thing that i hadnt thuoght about until it just popped into my mind now
21:23:40 <sgallagh> Shooy
21:23:42 <sgallagh> *shoot
21:23:52 <jds2001> sgallagh: by using ansible, we're introducing a python2 dep again.
21:24:03 <sgallagh> jds2001: Not necessarily
21:24:44 <jds2001> sgallagh: i know they're working on it, but as of now....
21:24:50 <sgallagh> jds2001: Ansible upstream now has experimental Python 3 support and I suspect that the modules being created for this purpose will be compatible with both.
21:24:56 <nirik> there's been a fair pile of work...
21:25:14 <sgallagh> Most of it done by abadger1999, who deserves a medal and a long vacation.
21:26:03 <sgallagh> jds2001: Even if we ultimately have to introduce a python 2 dependency again, we don't necessarily need to install python 2 by default.
21:26:08 <nirik> we may want to make a ansible-py3 package or something.
21:26:26 <sgallagh> Our playbooks can be written to handle bootstrapping python2 if needed for this to work.
21:26:27 <nirik> or python3-ansible or whatever
21:28:21 <sgallagh> jds2001: What is your specific concern regarding py2?
21:28:58 <jds2001> sgallagh: it sort of goes counter to all the work that we did to get rid of it. That's all - and the installation by default and keeping the image size down.
21:29:00 <nirik> would need to conflict though... or use alternatives or some other anoyance.
21:29:46 <jds2001> but writing something to bootstrap py2 if needed makes sense. Even just doing 'dnf install ansible' if needed would take care of that.
21:29:59 <jds2001> but depends on working repos on the host.
21:30:25 * jds2001 is off on a tangent, we can take this up some other time.
21:30:26 <nirik> bootstrapping is pretty easy.
21:30:58 <jds2001> nirik: assuming that you are running the playbook from someplace other than localhost :)
21:31:01 <sgallagh> jds2001: https://github.com/sgallagher/avocado-ci/blob/master/ansible/python2_install/tasks/main.yml
21:31:32 <sgallagh> executed with `gather_facts: false`
21:31:45 <jds2001> and I think that a lot of the usefulness here is running from localhost (i.e. cockpit fires off ansible-playbook <blah>)
21:31:46 <sgallagh> But yeah, the bootstrapping isn't very hard.
21:31:58 <sgallagh> I think we should definitely try to avoid having python2 in the default install still
21:32:35 <sgallagh> jds2001: Why do you think it make a difference remote vs. localhost? I'm not seeing it
21:32:40 <nirik> well, if you are running from localhost you have python2 already (if you have the ansible package anyhow)
21:33:13 <sgallagh> Good point
21:33:14 <jds2001> nirik: true, i guess cockpit could install on demand or something like that
21:33:36 <nirik> yeah. More downloading, but would likely work in many cases.
21:33:45 <sgallagh> jds2001: That's another thing I keep pushing them for. It's on their roadmap; I've been trying to get them to realize it needs to be higher priority.
21:33:52 <sgallagh> It would enable so very many things.
21:34:41 <sgallagh> OK, we're down in the weeds a bit here.
21:34:46 <jds2001> again, iwant to get to the rest of the agenda and not waste time on implmenetation :D
21:35:03 * nirik can investigate a python3 ansible and we can see how usable it is for our needs
21:35:09 <sgallagh> I'd like to request that anyone who is interested, please read the link jds2001 posted above and help shore up the use-cases.
21:35:16 <sgallagh> We want to be sure to cover the important stuff.
21:35:22 <sgallagh> nirik: Thanks!
21:35:42 <sgallagh> #action sgallagh to schedule a meeting between NFS shareholders in the near future
21:36:10 <sgallagh> #action nirik to investigate Ansible on python 3
21:36:32 <sgallagh> #action Server SIG to provide feedback on use-cases and user stories for the NFS role
21:36:39 <sgallagh> Anything further on this topic today?
21:36:54 * jds2001 wnats to see mock-ups :)
21:37:00 <jds2001> but other than that.....no.
21:37:56 <sgallagh> jds2001: Andreasn had some early mock-ups before the break.
21:38:05 <sgallagh> Check with him to see if they've been updated.
21:38:14 <jds2001> k
21:38:19 <sgallagh> #topic Fedora Server base image for cloud providers
21:39:02 <sgallagh> dustymabe: Mind providing a general status so we have somewhere to start?
21:39:34 <dustymabe> sgallagh: I can take a stab at where I think we left the discussion
21:40:16 <dustymabe> so basically the concerns I had originally when moving into the server wg is that the "thin" nature of the base image would be compromised a bit
21:40:25 <dustymabe> then this base-runtime thing came out
21:40:51 <dustymabe> and my current understanding is that once we get base runtime we'll add on top of that what is needed to boot in a cloud environment
21:40:57 <sgallagh> Well, it's always been an open question whether the "thin" concept is a meaningful place to expend our efforts.
21:41:34 <sgallagh> Because the value of using Fedora (vs. one of the other distros) is questionable if it's so stripped down as to be indistinguishable.
21:42:00 <dustymabe> well, i would argue that the ecosystem is what provides the "extra" value
21:42:02 <sgallagh> If nothing else, we need a concrete story to tell users about why they would want to choose us over another distribution.
21:42:06 <dustymabe> i.e. you can get anything you want
21:42:09 <dustymabe> from the repos
21:42:24 <sgallagh> dustymabe: That's also true of Ubuntu (who already has more market share)
21:42:39 <linuxmodder> .fas linuxmodder
21:42:39 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
21:42:45 <linuxmodder> (late sorry )
21:42:51 <smooge> and actually you can probably get more there because ppa tire pile
21:43:15 <nirik> so we shouldn't make a cloud image?
21:43:20 <nirik> or shouldn't care what size it is?
21:43:28 <sgallagh> (Note: I'm not opposing the creation of a cloud image... I just want to make sure we're not wasting our effort)
21:43:59 <dustymabe> sgallagh: so is the question whether creating a cloud image is worth the server WG time?
21:44:02 <sgallagh> I'm suggesting that if the size is the only thing we are concerned with, there are already other solutions out there.
21:44:04 <smooge> personally I think if a cloud image is being made, it needs to be made in direct partnership with someone who is running a cloud
21:44:30 <sgallagh> dustymabe: No, I'm suggesting that spending our time minimizing the image might not be as valuable as providing some functionality that our competitors don't have.
21:44:34 <nirik> I don't know that it's going to cost us much effort. Since we already have a ks and work done in the past to make it.
21:44:44 <smooge> we spend a heck of a long time bikeshedding sizes etc without feedback from actual cloud vendors of what they want
21:45:04 <sgallagh> nirik: Sure, but producing something half-cocked that no one wants to use doesn't reflect well on the Project either.
21:45:05 <dustymabe> sgallagh: yeah, I'm not saying that we should minimize our existing cloud image more than we already have, i'm just saying that I don't want to add a bunch of stuff to it
21:45:06 <jds2001> smooge: vendors != users
21:45:18 <dustymabe> which I assume base runtime will actually help us rather than hurt us in that case
21:45:47 <sgallagh> dustymabe: I think you're missing my point a little.
21:45:54 <vvaldez> I do think official cloud images for certain providers would be good, e.g. for OpenStack, right now they point to the atomic host for the Fedora cloud image: http://docs.openstack.org/image-guide/obtain-images.html
21:45:57 <nirik> sgallagh: sure... I use the cloud images... but thats just one person... so yeah, I don't know how generally used they might be
21:46:00 <sgallagh> I don't think the cloud image we have today is anything more than a checkbox.
21:46:07 <sgallagh> "Yup, we have one of those too!"
21:46:21 <vvaldez> exactly
21:46:29 <nirik> vvaldez: thats going to be fixed up... just wasn't in time for release.
21:46:30 <dustymabe> sgallagh: yeah, and I kinda like it that way
21:46:45 <dustymabe> sometimes people want something that just works
21:46:54 <dustymabe> the way they expect it to
21:47:13 <sgallagh> dustymabe: In what way is the cloud image today enhancing Fedora's mission? (This isn't a challenge; I just want to hear its value)
21:47:17 <nirik> I think the cloud image is useful. I think if we didn't make them we would be saying "don't bother running on your clouds"
21:47:28 <sgallagh> nirik: I agree with that.
21:47:49 <sgallagh> But I'm not sure that the cloud image *as it is currently composed* provides a compelling story for users.
21:47:51 <nirik> and that would make me sad, because we have a fedora infra cloud using a lot of fedora images...
21:47:57 <dustymabe> sgallagh: I just think it is useful to have a cloud image that is Fedora bits so that users that want to run fedora in the cloud have an option to do so
21:48:07 <dustymabe> if they want new and shiny, use atomic, right?
21:48:29 <dustymabe> i thought that was the whole point of pushing cloud image into this wg anyway, was that the atomic wg wanted to focus on atomic
21:48:29 <vvaldez> when I was in consulting soon after installing/configuring the OpenStack install for them, the first thing we did was install cloud images just to test cloud-init could inject the ssh key and get a dhcp IP address for basic functionality testing. there is a great rhel-guest-image and the often used cirros image, would be nice to also load a fedora image to do the same
21:48:30 <jds2001> dustymabe: i dont think anyone is debating that?
21:48:42 <jds2001> dustymabe: i think we're debating the composition of that
21:49:10 <sgallagh> dustymabe: I'll say again: I am *not* saying we shouldn't produce a cloud image. I'm saying we should produce one that is in some clear way superior to the competition.
21:49:27 <sgallagh> Doing anything else is just meaningless busywork and another place the compose can fail and block us.
21:49:33 <dustymabe> sgallagh: ok, I'm definitely interested in what "improvements" can be made
21:50:01 <vvaldez> would modeling the rhel-guest-image or centos genriccloud image make sense for a fedora server cloud image?
21:50:41 <dustymabe> vvaldez: what is special about those images? i.e. what feature is there that isn't in the fedora cloud image today?
21:50:45 <dustymabe> that you are looking for
21:51:03 <mhayden> a cloud image of fedora is definitely required -- but people seem to put different values on what makes a cloud image "good"
21:51:32 <mhayden> some look at how much disk space it occupies, others look at ram usage, others look at how many features it has out of the box
21:51:39 <dustymabe> mhayden: indeed
21:52:21 <vvaldez> dustymabe: my apologies, I hvne’t analyzed what fedora cloud image has now so I can’t compare properly, but I would say the purpose is to have a small enough image with cloud-init that’s basically all
21:52:33 <jds2001> i think that what we need to do is define priorities
21:52:38 <dustymabe> vvaldez: i think we have that for you :)
21:52:46 <vvaldez> great :)
21:53:05 <jds2001> something that has a ton of features but requires 100GB of RAM is objectively not good.
21:53:07 <smooge> 'small enough' is what everyone says.. and then its all 'well that is too big' and then 'it isn't usable'
21:53:44 <jds2001> but is 1GB OK? 2? How do we prioritize that vs. size on disk vs. features?
21:53:47 <dustymabe> sgallagh: sorry, I'm not trying to be difficult. I do want to improve the cloud image if we have concrete suggestions
21:53:53 <jds2001> those are the questions that we need to answer.
21:54:04 <sgallagh> dustymabe: I don't, but I wanted to start the conversation.
21:54:18 <nirik> jds2001++
21:54:18 <zodbot> nirik: Karma for jstanley changed to 1 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
21:54:45 <nirik> I think it's always going to be tradeoffs, but not sure what they should be.
21:54:57 <dustymabe> sgallagh: cool, yeah I'm open to improvements
21:55:14 <dustymabe> but I really do see the cloud image as something that is essentially a bootstrap for what you want to make out of it
21:55:18 <nirik> a better cloud-init. ;)
21:55:19 <dustymabe> i.e. you get a stem cell
21:55:29 <dustymabe> and you can do whatever you want with that stem cell
21:55:44 <dustymabe> is that reasonable?
21:55:52 <sgallagh> dustymabe: Well, perhaps the better answer then would be for us to provide some sort of a service for people to generate cloud images to their specifications
21:55:59 <sgallagh> Rather than shipping a base image?
21:56:13 <sgallagh> (just brainstorming here)
21:56:18 <dustymabe> sgallagh: well, I could see us doing "both"
21:56:33 <sgallagh> Sure, I perhaps should not have said "rather than"
21:56:39 <jds2001> dustymabe: you're thinking docker-like? we'll provide the minimum and choose your own adventure from there?
21:56:42 <nirik> well, IMHO people don't want to think about it... making images isn't that hard, but it's anoying... having a thing you can just use is much handier.
21:56:59 <dustymabe> ok so here is how I see cloud users
21:57:06 <jds2001> dustymabe: are there things where we want curation?
21:57:12 <nirik> also updated images are handy so you don't have to update them on spin up
21:57:15 <dustymabe> 1 - someone who is going to spin up a cloud image and toy with it
21:57:19 <jds2001> i.e. a jboss image for example
21:57:25 <sgallagh> nirik: Right, but what if we had something like Bitnami, where you could go to cloud.fedoraproject.org, click "Amazon Cloud", click "Wordpress" and have it do the deployment for you.
21:57:27 <dustymabe> 2 - someone who is going to spin up a cloud image and configure it once (pet)
21:57:29 <sgallagh> (Just as an example)
21:57:44 <dustymabe> 3 - someone who is going to spin up 10,000 instances of a cloud image and do batch processing
21:58:09 <dustymabe> I think for 1 and 2 you don't need a build your custom image "role"
21:58:10 <nirik> well, that might be cool, but would be useless for my use case of my openstack cloud that I want to spin up an instance on and have ansible configure to do whatever I want to do.
21:58:18 <sgallagh> Though I suppose we're rapidly getting to where OpenShift would be a better solution...
21:58:42 <sgallagh> So maybe that's exactly the problem. What are our use-cases?
21:58:45 <dustymabe> for role #3 those people probably already spin their own base image and bake contents that they want in there
21:59:03 <mhayden> i'm sorry, but i've gotta depart :|
21:59:06 <sgallagh> What *specific* problems can we solve. And how can we do it better than, say, Ubuntu?
21:59:09 <dustymabe> mhayden: no!!!
21:59:14 <dustymabe> you are the expert here
21:59:15 <dustymabe> :)
21:59:32 <mhayden> dustymabe: i know! i have to retrieve my kiddos :|
21:59:40 <sgallagh> mhayden, dustymabe: Could I #action you too to come up with a use-case document for next week?
21:59:44 <smooge> Looks like it is time to move it ot the list
21:59:44 <mhayden> i'm between that rock and the other hard thing
21:59:46 <sgallagh> s/too/two/
21:59:55 <mhayden> sgallagh: i could be persuaded to work with dustymabe
22:00:01 <dustymabe> mhayden: :)
22:00:07 * nirik is 2.5 I guess... want a base image + ansible (petshop)
22:00:15 <dustymabe> I think we have some convincing to do
22:00:45 <sgallagh> /me is extremely open to being convinced.
22:01:10 <sgallagh> I mean, after we come up with solid use-cases, maybe the answer is that we need more than one offering.
22:01:14 <dustymabe> would anyone ever be open to having a "video conference" in the place of this meeting sometime?
22:01:16 <nirik> you devils advocate you. ;)
22:01:24 <sgallagh> That's basically what we came up with when we split Workstation and Server, for example.
22:01:58 <sgallagh> nirik: I've always disliked that expression. I mean, who looks at the devil and says "Man, that guy really needs someone on his side"?
22:02:09 <dustymabe> sgallagh: nice
22:02:09 <nirik> ha. indeed.
22:02:38 <dustymabe> ok so what is the action item here?
22:02:47 <nirik> dustymabe: its hard to send notes of a video call to a list, but we could do one in addition sometime or for a brainstorming session before a meeting?
22:02:51 <sgallagh> dustymabe: Probably not instead of this meeting, but if we wanted to set up a videocall with interested people at another time, I think that's a good idea.
22:03:13 <jds2001> dustymabe: teleprescence ftw
22:03:15 <dustymabe> yeah, i think maybe I can convince people better in non-text
22:03:42 <sgallagh> #action dustymabe and mhayden will create a first draft of a user-story document describing the needs of users in public and private clouds.
22:03:45 <dustymabe> we can also have a conversation and not talk past each other as much
22:03:48 * nirik has to run soon.
22:03:52 <dustymabe> sgallagh: deal
22:03:56 <sgallagh> Thanks!
22:04:12 <sgallagh> I also need to leave, so shall we end the meeting here?
22:04:30 <dustymabe> sounds good
22:04:34 <sgallagh> dustymabe, mhayden: Please send that document to the list when it's ready.
22:07:13 <dustymabe> k
22:07:52 <sgallagh> #endmeeting