fpc
LOGS
16:00:41 <geppetto> #startmeeting fpc
16:00:41 <zodbot> Meeting started Thu Sep 29 16:00:41 2016 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:41 <zodbot> The meeting name has been set to 'fpc'
16:00:41 <geppetto> #meetingname fpc
16:00:41 <zodbot> The meeting name has been set to 'fpc'
16:00:41 <geppetto> #topic Roll Call
16:00:47 <Rathann> hi
16:00:51 <geppetto> #chair Rathann
16:00:52 <zodbot> Current chairs: Rathann geppetto
16:00:53 <geppetto> Hey
16:01:11 <mbooth> Hi
16:01:12 <geppetto> #chair orionp
16:01:13 <zodbot> Current chairs: Rathann geppetto orionp
16:01:16 <orionp> hello
16:01:17 <geppetto> #chair mbooth
16:01:17 <zodbot> Current chairs: Rathann geppetto mbooth orionp
16:08:08 <geppetto> Well, not much going on with tickets this week ... and it doesn't look like we'll get 5
16:09:25 <geppetto> #topic Open Floor
16:09:31 <geppetto> Anything anyone wants to talk about?
16:11:50 <orionp> I don't.
16:11:57 <tibbs> Bah.
16:12:05 <geppetto> #chair tibbs
16:12:05 <zodbot> Current chairs: Rathann geppetto mbooth orionp tibbs
16:12:06 <tibbs> Sorry, I lost track of time and didn't hear a ping.
16:12:21 <tibbs> Hell, I forgot what day it was.
16:12:25 <geppetto> Sorry ... ping went to tibbs|w which doesn't exist
16:12:39 <geppetto> And the error message got eaten by xchat, so I didn't see it
16:12:44 <geppetto> :)
16:12:45 <tibbs> Ah, yeah, I switched to znc so it's just one nick now.
16:13:00 * geppetto nods
16:13:09 <geppetto> #topic Schedule
16:13:28 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/HHJT7EYH5QMCEV6FWEKB73SUBSCXUQ4C/
16:13:48 <geppetto> No new tickets
16:14:36 <geppetto> #topic #398     Tilde in version
16:14:41 <geppetto> .fpc 398
16:14:44 <zodbot> geppetto: #398 (Tilde in version) – fpc - https://fedorahosted.org/fpc/ticket/398
16:14:45 <geppetto> This has been updated
16:14:46 <tibbs> There was an update just a few hours ago.
16:15:11 <geppetto> mbooth: Last comment in the ticket is the summary of advantages
16:15:38 <tibbs> The first, second and fifth are basically the ones that work for me.
16:16:56 <tibbs> The third and sixth, meh.  And the fourth basically says that we don't have to deal with something we have already dealt with (and it really wasn't an issue then anyway).
16:17:19 <tibbs> But maybe it will help some folks come to a decision.
16:17:53 <tibbs> Otherwise I really don't have much to add.
16:18:31 <geppetto> Yeh, first and second are the major two IMO ... 4th and 5th are ok, but I'm not super excited atm
16:19:24 <geppetto> https://fedoraproject.org/wiki/PackagingDrafts/TildeVersioning
16:19:29 <geppetto> Is the current draft
16:19:48 <tibbs> For the record, I count 7193 spec files which have some sort of "complex" Release: tag.
16:19:55 <geppetto> The collapsable upgrade path boxes would still be nice
16:20:20 <tibbs> Oops, no, that includes like a billion hits in the texlive.
16:20:30 <tibbs> geppetto: Sorry, I don't get you there.
16:20:56 <tibbs> Make that 1558 specs with a "complex" Release: tag.
16:21:20 <geppetto> tibbs: We talked about having a bunch of the example data be collapsed by default, but you could still expand it if you wanted to
16:21:27 <geppetto> just to remove the visual noise from the page
16:21:38 <tibbs> I would wager that most of those would need to be checked against this change, and probably need to be checked against the current guidelines either way.
16:21:45 <orionp> I'm generaly in favor of the change.
16:21:56 <tibbs> Oh, adding the collapsible style is easy.
16:22:11 <geppetto> If you know how ;)
16:22:21 <tibbs> Yeah, let me play with it while we're talking.
16:22:27 <orionp> some of the stuff around the snapshot naming I think needs to be cleaned up, but that's somewhat orthogonal
16:22:29 <tibbs> (please take that in context)
16:22:43 <geppetto> :)
16:23:00 <tibbs> I mean, if we're going to do this then if there are other things that can make it better, we might as well do them.
16:23:12 <tibbs> Though that does, perhaps, confuse the issue.
16:23:29 <tibbs> But for the sake of everyone we should do just one change, regardless of how much we end up changing.
16:23:34 <Rathann> I don't like 1.0+p.CP1 as an upgrade to 1.0+SP1
16:23:38 <Rathann> it's just ugly
16:23:49 <tibbs> Rathann: I do agree, except...
16:24:03 <tibbs> What other rule is there which doesn't complicate the normal case (where the things sort)?
16:24:12 <geppetto> Rathann: Suggestion of something else?
16:24:28 <tibbs> The idea there was to avoid the leading digit if possible.
16:24:48 <tibbs> And only to add something if upstream decided to make things fail to sort.
16:25:15 <tibbs> And also to avoid having a rule like "if you know your upstream will use things that don't sort, then...."
16:25:30 * geppetto nods
16:25:51 <geppetto> I don't find p. to be much better than 1. .... if Rathann prefers that?
16:26:01 <geppetto> So 1.0+1.CP1
16:26:06 <tibbs> Does that sort, though?
16:26:08 <geppetto> yeh
16:26:24 <geppetto> numbers > letters in rpm land
16:26:41 <tibbs> I mean, if a digit will just work there, then I'm all for it.
16:27:02 <geppetto> % rpmdev-vercmp 1.0+1.CP1 1.0+SP1
16:27:03 <geppetto> 1.0+1.CP1 > 1.0+SP1
16:27:14 <tibbs> I thought we couldn't trust rpmdev-vercmp.
16:27:21 <geppetto> Just to make sure I'm not delusional ;)
16:27:31 <geppetto> tibbs: That was when they wanted to change the meaning of something
16:27:38 <tibbs> geppetto: Aside: did you want the whole examples section to collapse, or each example individually?
16:28:20 <geppetto> Whatever is easiest ... I assume it won't take much space anyway if each of the boxes collapses on it's own
16:29:02 <geppetto> orionp: Did you have a suggestion for changing the snapshot naming?
16:29:36 <tibbs> Yeah, while we're talking about it...
16:29:56 <orionp> not specifically, but it's inconsistent - it mentions using date as prefix, but then no examples have it
16:30:27 <tibbs> I updated the page to collapse everything, but I dislike it.
16:30:41 <orionp> and then svn/cvs have date as suffix, when at least for svn it should be <date>svn<svn revision>
16:30:58 <tibbs> Of course we can fix the examples.  If they're really wrong then... ugh.
16:31:05 <tibbs> I'm sure they've been wrong forever.
16:31:16 * geppetto nods
16:31:23 <tibbs> But we should talk about whether we want to change the format of the checkout tags.
16:31:26 <geppetto> Now is a good time to fix them though
16:31:44 <geppetto> For svn/cvs I really hope it doesn't matter anymore
16:31:47 <tibbs> Oh, I'll fix them in the current document regardless.  I guess my eyes just glaze over.
16:32:07 <tibbs> And there are still things using CVS.  It shouldn't matter because the actual string used is actually up to the packager.
16:32:27 <tibbs> There's nothing that mandates that we use "git" when it's a git checkout.
16:32:39 * geppetto nods
16:34:18 <tibbs> OK, https://fedoraproject.org/wiki/PackagingDrafts/TildeVersioning#Examples
16:34:34 <geppetto> Looks good to me
16:34:41 <tibbs> Still not really pretty, though I can fix that a bit.
16:35:08 <tibbs> We can also try to pull the examples out to a separate page, and include more verbose discussion.
16:35:22 <tibbs> If I can ever find some time I can try that too.
16:35:50 <tibbs> I also learned that you can reference fedora versions in macros, so the page just updates when F26 comes out.
16:36:36 <tibbs> And you can specify "current" and "previous" and "previous2" and such so most of our examples don't have to look archaic in five years.
16:36:43 <tibbs> But... that's a sparate thing, too.
16:37:03 <geppetto> coo
16:37:08 <geppetto> cool, even
16:38:49 <mbooth> Have to say, I'm still not sold on the change
16:39:25 <tibbs> So, at this point I'm seeing four "generally in favor" folks, one hard -1, and... I guess mbooth is still around negative.
16:39:32 <orionp> So, the link here https://fedoraproject.org/wiki/Packaging:Guidelines#Version_and_Release seems wrong. I think it should point to https://fedoraproject.org/wiki/Packaging:Versioning
16:39:36 <geppetto> Is there anything specific, or do you just feel it's too much change for the benefits?
16:39:47 <tibbs> Unless I misinterpreted Rathann's comments, which is wholly possible.
16:40:06 <Rathann> tibbs: I'm approaching "meh"
16:40:09 <tibbs> orionp: Probably.  I did split the Naming guideline and might have missed a link.
16:40:16 <tibbs> Rathann: From which direction?
16:40:21 <Rathann> from -1 ;)
16:42:30 <tibbs> Personally I don't want to advocate one position or the other.
16:43:13 <tibbs> I am, however, pretty certain that if we'd had the tilde magic back when we first came up with the hack we have now, we certainly would have used it.
16:43:40 * geppetto nods ... I think I'm enough of a +1 that I'm happy to advocate for it
16:45:08 <mbooth> Reason #1 is just moving information around, so seems like make work. #2 is dubious at best -- I think going from less than one to one or more (i.e. counting ;-) is more obvious than introducing new notation. #3 doesn't seem a good reason, won't there always be packages that get it wrong or flout the rules that cause inconsistency? If it can be enforced programatically, why not for the current way? #4 is basically "so we can simplify rpmdev-bumpsp
16:45:08 <mbooth> ec"? and #6 is just "because other people do it this way"
16:46:28 <mbooth> I don't know how true #5 is. Depends how clever the audit tool is, I guess
16:46:41 <geppetto> I think #1 is the main thing, to me ... there is a lot of "it looks/feels nicer" but having a "upstream owns X and fedora owns Y" is pretty nice.
16:46:45 <tibbs> It is nice to not require too much cleverness.
16:47:03 <tibbs> I guess.  But just like with bumpspec, we've figured out how to live with what we have.
16:47:10 <tibbs> And, again, 1558 packages.
16:47:17 <geppetto> #3 I think is more ... because of #1 is more "obvious" then people will naturally dtrt.
16:47:47 <geppetto> which I can hope, but I wouldn't bet a car on it or anything
16:48:21 <tibbs> 777 packages in rawhide have a Release containing "git".
16:49:03 <Rathann> geppetto: dtrt?
16:49:24 <tibbs> Actually, 857.  I'm being crappy with regexes today.
16:49:30 <tibbs> Rathann: Do The Right Thing
16:49:39 <Rathann> ah
16:50:00 <tibbs> Release:        %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
16:50:07 <mbooth> #2 is particularly sticky for me -- we are still discussing "but what if the upstream snapshot name does not version compare correctly and upgrades don't work" -- if the answer is prefix with a digit, then that's what we already do but in the Release tag instead :-/
16:50:21 <mbooth> So why bother changing it?
16:50:28 * mbooth shrugs
16:50:29 <Rathann> mbooth: +1
16:50:41 <Rathann> there is a number of upstreams who don't have versions at all
16:50:45 <Rathann> just snapshots
16:50:54 <tibbs> mbooth: That's sort of another of those orthogonal issues.
16:51:07 <tibbs> The rule _could_ just be "always prepend the digit" as we have now.
16:51:29 <tibbs> And we could also change our current rule to "only prepend if you have to" regardless of the rest of the proposal.
16:52:02 <tibbs> We can easily cover the "90%" case without needing the digit.
16:52:17 <mbooth> tibbs: So then it should be listed as an advantage of the new scheme
16:52:22 <mbooth> should not, even
16:52:29 <tibbs> I don't know; is it?
16:52:34 <tibbs> I didn't make the list of advantages.
16:52:49 <tibbs> And I don't think that list ngompa posted earlier mentions it, either.
16:53:38 <tibbs> Personally I'd advocate for being able to do away with the digit in the vast majority of cases right now, regardless of the rest of this proposal.
16:54:10 <mbooth> Requiring the extra digit goes against advantage #1, no? You get extraneous info the version
16:54:23 <Rathann> tibbs: example?
16:54:25 <tibbs> It's just that if you already have to cram it in Release: then the extra bit of weirdness doesn't really that big of a deal.
16:54:56 <tibbs> Rathann: Well, I'm not aware of any upstreams which currently have a prerelease naming scheme which uses "alphatags" that don't sort.
16:55:05 <tibbs> I'm sure there must be one, somewhere.
16:55:14 <orionp> You really can't get rid of the digit prefix in release now, it's needed for rel bumps
16:55:18 <tibbs> Most of the time it's just "alpha" and "beta" and "rc".
16:55:37 <tibbs> orionp: Ah, of course you're right.
16:55:55 <orionp> just ran into that recently with some package...
16:56:20 <tibbs> So yes, I guess I couldn't advocate for it outside of this proposal, because it's the moving of the stuff to version which makes it possible.
16:59:30 <orionp> ah, I see, they went and change the snapshot naming rules as well
16:59:37 <tibbs> The proposal does need a summary of disadvantages.
17:00:10 <tibbs> orionp: Hmm, really?  It might have been accidental.
17:00:51 <orionp> I don't think so, there was a brief mention in the last comment, and it is different - more like opensuse's now I think
17:00:54 <tibbs> OK, you're right; they moved the dates back.
17:01:16 <tibbs> OK, that kind of pisses me off.
17:01:52 <tibbs> There's a reasoning there (which shouldn't be in the final document) but I need more information to understand why.
17:02:24 <mbooth> "If and only if a release version changes convention in such a way that there's no way to handle an upgrade sanely, it may be necessary to use Epoch to ensure the current package is considered newer than the previous package" -- I mean, when this info is in the release tag there is no need to use the epoch hammer, right?
17:02:41 <tibbs> Not really.
17:03:03 <tibbs> Well, I mean, what you wrote is not really right.
17:03:29 <tibbs> Upstream goes from "15" to "1.0", you use epoch.
17:03:45 <tibbs> That's always been the case.
17:03:47 <mbooth> tibbs: This text is in the "Snapshot Packages" section
17:04:15 <mbooth> Under the examples
17:04:43 <tibbs> I'm not entirely sure the message is accurately placed.
17:05:14 <tibbs> I mean, it's just at the end of the "version tag" section.
17:05:35 <mbooth> Oh, I see
17:05:42 <orionp> need it's own sub-heading?
17:05:48 <tibbs> It could be at the beginning, but then it wouldn't have its own context.
17:06:04 <tibbs> It would probably look better as its own section instead of an admon.
17:06:43 <orionp> 'Upstream changes versioning scheme" or some such
17:07:09 <tibbs> Bah, I got the nesting wrong.
17:07:34 <tibbs> OK, that's better.
17:08:11 <tibbs> I do wish the document wasn't so nested.  I promised them I'd try to go over it but have yet to find the time.
17:10:18 * geppetto nods
17:12:13 <Rathann> eh, our current scheme neatly avoids having to bump epoch or even doing weird tricks like 1+SP1 -> 1+p.CP1 because you can always bump the release field
17:12:17 <tibbs> OK, so I need to better understand why they changed the rules for generating the alphatags.
17:12:50 <Rathann> that advantage is hard to beat
17:13:13 <mbooth> Rathann: Yeah, I don't this extra cognitive load it puts on the packager -- "always be on the lookout for non-sortable things"
17:13:30 <mbooth> s/don't/don't like/
17:13:51 <tibbs> If you can construct a situation where this new scheme requires an epoch where the current one doesn't, please add it.
17:14:04 <tibbs> The ticket really needs a statement of disadvantages.
17:14:32 <orionp> well, it generally is a case of when packagers mess up
17:14:33 <geppetto> "It's not what we've been using for a decade" is the only one?
17:14:44 <mbooth> tibbs: No, you correctly pointed out that I read that epoch admon with the incorrect context
17:14:46 <orionp> if they mess up in release, we can fix it in version
17:14:47 <tibbs> geppetto: I don't believe it is.
17:15:00 <geppetto> Hmmm
17:15:06 <orionp> if they mess up (badly) in version, we have to fix it in epoch
17:15:20 <orionp> I'm not sure if I can create an example though
17:15:39 <tibbs> There are surely others; it's just that you can't ask the people who are proposing the thing to provide that list and be objective.
17:16:12 <geppetto> Well, I don't think it should have any other disadvantages
17:16:13 <mbooth> But the disadvantage is still there in the remaining "non-sortable" admon blocks -- hence I don't beleive the #1 advantage listed in the ticket is (or can be) true
17:16:24 <geppetto> So if people think there are ones, then we should just change it to not have them
17:16:34 <tibbs> Well, or not change at all.
17:17:20 <geppetto> Sure, but I'm just saying that I think we should get to a point that's "it's a change, and the only downside is that it's a change"
17:17:26 <geppetto> We can still decide it's not worht it
17:17:27 <tibbs> mbooth: I do have to believe that if it simplifies the general case, then that's considered an advantage.
17:17:41 <geppetto> But I don't think we need to have other downsides
17:18:12 <tibbs> And as I wrote earlier, I'm not aware of any upstream which uses a naming scheme which would require invoking that admon about non-sortable tags.
17:18:42 <tibbs> But I am aware that it's possible for an upstream to do that, which is why I asked them to add the admon in the first place.
17:18:59 <Rathann> https://paste.fedoraproject.org/438283/
17:19:04 <geppetto> But if mbooth thinks it's a disadvantage I'm happy to just always require a number
17:19:05 <Rathann> example of what I said
17:19:35 <tibbs> Which upstream does this, though?
17:20:03 <geppetto> Rathann: yeh
17:20:15 <tibbs> That's exactly the situation I said they needed to handle.
17:20:25 <Rathann> tibbs: I don't have any specific real-world example
17:20:26 <geppetto> Rathann: But to repeat, I'm happy to require the number in the new scheme too ... if that makes you or mbooth happier
17:20:26 <mbooth> tibbs: The tags given to Eclipse snapshots.... http://git.eclipse.org/c/platform/eclipse.platform.releng.aggregator.git/log/
17:20:34 <mbooth> Good job I don't use them :-p
17:20:39 <geppetto> :)
17:21:07 <Rathann> :D
17:21:14 <tibbs> mbooth: Even given that I can't figure out what they're doing.
17:21:52 <Rathann> geppetto: actually it doesn't make any difference if it's a number or a letter
17:22:05 <Rathann> it gets confusing and ugly in either case
17:22:09 <geppetto> Rathann: number is what we use now though
17:22:33 <tibbs> To be completely fair, I would be happy having a guideline that doesn't even mention weird cases like Eclipse if it were easier for packagers to understand.
17:23:01 <tibbs> And then have people with a really weird case have to ask someone about it.
17:23:20 <geppetto> Sure
17:23:29 <tibbs> One thing that might be nice to see is if we could take the corner cases out of both documents and see what they look like.
17:24:06 <tibbs> I suspect the new one would look a heck of a lot simpler than the old one but of course I'd have to actually do the editing.
17:24:29 <tibbs> That might be a good idea for organizing the guidelines regardless of this proposal.
17:24:50 <Rathann> tibbs: +1
17:24:50 <tibbs> Because right now either way it puts the weird stuff up front.
17:25:53 <Rathann> might be worth listing the weird cases at the end
17:26:39 <tibbs> Well, I was hacking up the versioning guideline before, so I can keep hacking it up.
17:27:26 <tibbs> Rathann: It's funny in your fpaste above that you have exactly the same qualm about it that I did when I suggested it.
17:28:02 <tibbs> https://fedorahosted.org/fpc/ticket/398#comment:49
17:28:57 <tibbs> There was an assertion made much earlier in the discussion that things like epoch don't need to persist across Fedora versions.
17:29:06 <tibbs> I still have no idea if that's actually true.
17:29:24 <geppetto> tibbs: I also mentioned it in comment 12 ... 3 years ago :-o
17:30:20 <geppetto> tibbs: That's insane
17:30:25 <geppetto> tibbs: epoch is forver
17:30:59 <mbooth> Yeah, I thought epoch was forever too
17:31:12 <tibbs> Well, the argument was that when you do dnf system-upgrade...
17:31:16 <tibbs> it does a distro-sync.
17:31:19 <geppetto> In theory it could work for the tools, but there's no reason to abuse people that way
17:31:51 <tibbs> But my argument was that in order to drop epoch, rawhide has to at some point go backwards.
17:31:57 <tibbs> And that's not something we have ever allowed.
17:32:17 <tibbs> But... I don't know, really.  It's an orthogonal issue anyway.
17:32:19 <geppetto> And the tools would need to be changed if you want people to be able to do "try the package from the next release" without having to do a bunch of stupid magic excludes or locks or something
17:32:41 <geppetto> yeh, the document doesn't say that
17:32:43 <tibbs> (The original proposal used epochs pretty freely, which was shot down.)
17:32:48 * geppetto nods
17:32:52 <tibbs> Seems that "other distros" have no problem with this.
17:33:35 <tibbs> I've never quite understood how "other distros" always seem to be able to do so many things "better" than we do.
17:33:58 <geppetto> I don't think other distros. use epochs a lot
17:34:59 <geppetto> Anyway ... we've spent almost 1.5 hours on this again.
17:35:09 <geppetto> Is there anything else that needs to be said today?
17:35:20 <tibbs> Yep, but it's probably the biggest issue we've hit since SCLs.
17:35:44 <geppetto> #action Split out the really weird cases from the main policy, both old and new, to see how it looks.
17:36:02 <tibbs> More wiki editing.
17:36:03 * geppetto nods
17:36:13 <tibbs> I've figured out at least one of my problems with wiki edits.
17:36:24 <geppetto> What's that?
17:36:27 <tibbs> I tend to do some before I go home.  That's 7PM.
17:36:38 <tibbs> Which is 2400Z.
17:36:42 <geppetto> ahh
17:36:55 <tibbs> Which is when the backups run, which renders the wiki useless.
17:37:16 <tibbs> So I either give up or spend half an hour trying to submit my latest edit.
17:37:52 <Rathann> ok guys
17:37:58 <Rathann> I need to drop off
17:38:01 * geppetto nods
17:38:07 <geppetto> #topic Open Floor
17:38:11 <Rathann> thanks for the discussion and take care
17:38:16 <geppetto> See ya
17:38:42 <tibbs> Well, I have nothing.
17:38:54 <tibbs> At least nobody can say we aren't carefully considering the proposal....
17:39:04 <mbooth> :-)
17:39:15 <mbooth> Sorry for being disagreeable
17:39:27 <tibbs> I don't think you're being disagreeable.
17:39:44 <geppetto> And I don't think it's the end of the world if it fails to pass
17:39:47 <tibbs> I'm just tired enough of people telling me they don't understand the current guidelines.
17:40:10 <tibbs> Willing to try something new if only to see if people can understand it better.
17:40:29 * geppetto nods
17:40:38 <mbooth> Oh I didn't realise this was an area of misunderstanding
17:40:39 <tibbs> Plus aside from me doing some random wiki splitting, they're the first people trying to actually improve anything about  that bit of the guidelines.
17:41:07 <tibbs> mbooth: If you take a random sample of packaged snapshots, you'd see all kinds of fun things.
17:42:05 <tibbs> nfs-utils-1.3.4-1.rc2.fc24.x86_64 is really release candidate 2 of 1.3.5.
17:42:23 <tibbs> openoffice has never managed to get the fact that for prerelease packages, release has to be <1.
17:42:52 <mbooth> tibbs: Yeah you're right of course; but does adding ~ and + and moving the info from Release to Version clear up the confusion? I'd be surprised
17:43:29 <tibbs> I don't think it would be worse.
17:43:50 <geppetto> The +/- thing might well make it more obvious
17:44:00 <tibbs> Well, +/~
17:44:05 <geppetto> yeh
17:44:37 <mbooth> And that's why I will probably vote "±0" -- I could be convinced that the change does no harm, but I'm not yet convinced there will be measurable improvement
17:45:00 <tibbs> One thing I do think would be harmful is if we plan on keeping both schemes around permanently.
17:45:46 <tibbs> We really do need some automation around this regardless of what we do.  I actually have a bit of code that I'm playing with which might help.
17:45:59 <tibbs> But constructing regexps for this isn't easy.
17:46:14 <tibbs> It would be easier if we knew that Release: was a plain integer, of course.
17:49:28 <mbooth> Okay, I'm off. Have a good evening
17:49:34 <geppetto> ok
17:49:37 <geppetto> see you next week
17:49:44 <tibbs> Take care.
17:50:23 <tibbs> I still need to figure out what I was supposed to do from two meetings ago.
17:51:26 <geppetto> :-o
17:51:41 <geppetto> Is it not in the minutes?
17:53:15 <tibbs> I need to actually find the minutes and read them.
17:53:27 <geppetto> :)
17:53:35 <tibbs> I'm sure if I promised to do something that it's there for the whole world to see.
17:54:39 <geppetto> last week: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2016-09-22/fpc.2016-09-22-16.00.txt
17:55:03 <geppetto> Week before that: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2016-09-15/fpc.2016-09-15-16.01.txt
17:55:26 <geppetto> Week before that: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2016-09-08/fpc.2016-09-08-16.00.txt
17:55:31 <tibbs> Thanks.
17:55:34 <geppetto> n/p
17:55:44 <geppetto> Ok, I'm going to close the meeting now
17:55:53 <geppetto> #endmeeting