fedora_cloud_wg
LOGS
16:59:36 <trishnag> #startmeeting fedora_cloud_wg
16:59:36 <zodbot> Meeting started Wed Aug 31 16:59:36 2016 UTC.  The chair is trishnag. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:59:36 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
16:59:37 <kushal> scollier, yet to start :)
16:59:41 <trishnag> #topic Roll Call
16:59:48 <kushal> .hellomynameis kushal
16:59:48 <scollier> .hello scollier
16:59:49 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
16:59:50 <trishnag> .hello trishnag
16:59:52 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
16:59:55 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
16:59:58 <nzwulfin> .hello mmicene
16:59:59 <zodbot> nzwulfin: mmicene 'Matt Micene' <nzwulfin@gmail.com>
17:00:11 <jberkus> .hello jberkus
17:00:12 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:00:19 <jbrooks> .hello jasonbrooks
17:00:19 <bowlofeggs> .hello bowlofeggs
17:00:20 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:00:23 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
17:00:32 <vvaldez> .hello vvaldez
17:00:35 <zodbot> vvaldez: vvaldez 'Vinny Valdez' <vvaldez@redhat.com>
17:00:55 <trishnag> #chair kushal scollier nzwulfin jberkus bowlofeggs jbrooks dustymabe vvaldez sayan rtnpro
17:00:55 <zodbot> Current chairs: bowlofeggs dustymabe jberkus jbrooks kushal nzwulfin rtnpro sayan scollier trishnag vvaldez
17:01:31 <trishnag> #topic rtnpro will add test workflow (and test cases) for testing fedora-motd on F24 atomic image
17:01:34 <sayan> .hello sayanchowdhury
17:01:36 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:01:43 <walters> .hello walters
17:01:44 <zodbot> walters: walters 'Colin Walters' <walters@redhat.com>
17:01:56 <maxamillion> .hello maxamillion
17:01:57 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:02:02 <trishnag> #chair walters maxamillion gholms
17:02:02 <zodbot> Current chairs: bowlofeggs dustymabe gholms jberkus jbrooks kushal maxamillion nzwulfin rtnpro sayan scollier trishnag vvaldez walters
17:02:13 <scollier> Hi vvaldez
17:02:15 * gholms waves hello
17:02:26 <trishnag> Hi everyone :)
17:02:28 * vvaldez waves at scollier
17:02:45 <trishnag> #topic Action items from last meeting
17:02:48 <rtnpro> .fas rtnpro
17:02:49 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:03:01 <trishnag> #topic rtnpro will add test workflow (and test cases) for testing fedora-motd on F24 atomic image
17:03:19 <trishnag> rtnpro: Any update on this?
17:03:28 <rtnpro> I started working on the test cases for fedora motd using tunir
17:04:04 <trishnag> okay
17:04:11 <rtnpro> It's work in progress, and I need to discuss with kushal on how to write some test cases, e.g., assert the motd message after ssh login, etc
17:04:24 <rtnpro> I will take this week to complete it
17:04:35 <rtnpro> <eof>
17:04:50 <rtnpro> trishnag, you can add the action back again on me
17:04:57 <trishnag> rtnpro: you can add me in regarding test :)
17:04:59 <walters> was the concern about not triggering an update if one hasn't been initiated before been addressed?
17:05:00 <walters> if e.g. my systems require a proxy server, and i'm booting up a cloud VM to ssh into it the first time via ansible, we shouldn't try an update that isn't using the proxy
17:05:06 <rtnpro> trishnag, cool
17:05:11 <rtnpro> trishnag++
17:05:11 <zodbot> rtnpro: Karma for trishnag changed to 13 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:05:15 <trishnag> okay
17:05:38 <trishnag> #action rtnpro will add test workflow (and test cases) for testing fedora-motd on F24 atomic image
17:05:49 <trishnag> is this how action works?
17:06:02 <jbrooks> yep
17:06:06 <trishnag> ok :)
17:06:25 <trishnag> #topic gholms to test updated cloud-init on f24 for f25
17:06:38 <trishnag> gholms: this is for you
17:06:53 <gholms> #info cloud-init 0.7.7 now in rawhide, needs testing on more clouds than I have access to
17:07:08 <gholms> I only have eucalyptus and AWS.
17:07:13 <kushal> gholms, I am guessing you already tested on AWS, and on EUCA
17:07:17 <kushal> yup.
17:07:18 <gholms> #info It's also in f25 updates-testing
17:07:31 <kushal> gholms, I will try to test on openstack
17:07:40 <gholms> Yeah, but I tried it on f24 because 25 didn't boot.
17:07:42 <kushal> But only on Monday
17:07:50 <kushal> gholms, Okay.
17:07:58 <gholms> #action kushal to test new cloud-init on openstack
17:08:16 <sayan> kushal: can I help with that?
17:08:17 <gholms> I'm a little bummed about this bootloader stuff, but... yeah.
17:08:34 <nirik> if you mean extlinux, we figured it out.
17:08:36 <kushal> sayan, I will ping you
17:08:37 <kushal> gholms, thanks
17:09:20 <gholms> That's all I have for that topic.
17:09:21 <gholms> Thanks
17:09:24 <trishnag> ok
17:09:31 <trishnag> rtnpro: Do you want to say anything on walters query?
17:10:49 <kushal> trishnag, you can go ahead, he may have slept.
17:10:52 <trishnag> ok moving forward
17:10:57 <trishnag> #topic vvaldez to talk with misc, scollier, jberkus about how he can help with FOSP (#153)
17:11:11 <trishnag> vvaldez: Any update?
17:11:24 <trishnag> #chair misc
17:11:24 <zodbot> Current chairs: bowlofeggs dustymabe gholms jberkus jbrooks kushal maxamillion misc nzwulfin rtnpro sayan scollier trishnag vvaldez walters
17:11:26 <jberkus> trishnag: we had a meeting about FOSP setup before LinuxCon.  I don't know if there's been any changes since
17:11:42 <vvaldez> we've been mailing on a thread back and forth but so far I haven't had any specific contributions yet, there is an update to #153 since last week
17:11:48 <misc> no news since last status
17:11:55 <jberkus> one issue is getting the complete set of Fedora-based OS containers tested so that the infra team will use them
17:12:11 <scollier> misc, are you deploying Origin yet?
17:12:15 <jberkus> which I'll take a stab at as soon as I have HW again (cluster is down)
17:12:17 <scollier> misc, or still working on infra playbooks?
17:12:25 <misc> scollier: we do deploy but it fail
17:12:35 <scollier> misc, ah, i didn't realize you were that far.
17:12:45 <misc> scollier: https://github.com/openshift/openshift-ansible/issues/2294
17:12:49 <trishnag> #link https://fedorahosted.org/cloud/ticket/153
17:13:01 <misc> so I got a update on the ansible bug 2h ago, will fix my proposed patch
17:13:06 <vvaldez> that's the latest issue misc linked
17:13:56 <scollier> misc, ack.
17:14:10 <misc> (in fact, i may likely fix before the end of the meeting)
17:14:39 <trishnag> ok moving to the next
17:14:53 <trishnag> #topic #125 Fedora-Dockerfiles examples for Kubernetes
17:15:03 <trishnag> #link https://fedorahosted.org/cloud/ticket/125
17:15:21 <trishnag> scollier: jberkus This is for you
17:15:47 <jberkus> OK if I take the meeting tag off that one?  It's still on my TODO list, but having it in the meeting every week isn't useful
17:16:47 <trishnag> jberkus: ok so I am moving to the next one
17:17:06 <trishnag> #topic #136 vagrant boxes fixups
17:17:10 <trishnag> #link https://fedorahosted.org/cloud/ticket/136
17:17:11 <sayan> jberkus: right, removing the tag would be better
17:17:34 <trishnag> kushal: Update on this one?
17:18:04 <kushal> why me?
17:18:06 <sayan> that belongs to imcleod
17:18:10 <kushal> :)
17:18:22 <trishnag> oh he is not here now
17:19:01 <trishnag> moving forward
17:19:28 <trishnag> #topic #147 Don't overwrite download location for 2 week atomic images https://fedorahosted.org/cloud/ticket/147
17:20:15 <maxamillion> I need to update that ticket, but I've posted to the mailing list about this, I have a patch in for the releng script and I need to get a patch in for the websites team (waiting on a response for some guideance though)
17:20:57 <maxamillion> here's the mailing list thread https://lists.fedoraproject.org/archives/list/cloud@lists.fedoraproject.org/thread/RIVZOYPJSMTMQXHKXIWNTSWQ2CQAPNXC/
17:21:43 <trishnag> maxamillion: okay
17:21:50 <trishnag> seems dustymabe is not around
17:22:27 <kushal> https://lists.fedoraproject.org/archives/list/cloud@lists.fedoraproject.org/thread/RIVZOYPJSMTMQXHKXIWNTSWQ2CQAPNXC/
17:22:41 <kushal> trishnag, yes, he is busy (as informed in the channel).
17:22:58 <maxamillion> ticket updated
17:23:09 <trishnag> maxamillion: thanks
17:23:12 <trishnag> kushal: okay
17:23:26 <trishnag> moving next
17:23:51 <trishnag> We can ignore #153 as it is already discussed
17:23:57 <trishnag> #topic #154 make Fedora Atomic download page clearer https://fedorahosted.org/cloud/ticket/154
17:24:11 <trishnag> jberkus: Any update here?
17:24:30 <jberkus> feh, no, I'll get on that this week.
17:24:38 <jberkus> sorry, too much conference travel
17:25:06 <trishnag> okay
17:25:20 <trishnag> #topic #155 Decide on post-GA update cadence for various deliverables https://fedorahosted.org/cloud/ticket/155
17:25:44 <trishnag> jbrooks: Any update on this?
17:26:06 <jbrooks> maxamillion has a proposal for this on the rel-eng list, he's looking for +1's
17:26:14 <walters> i'd like to pull in the ADB more as a primary option too
17:26:28 <walters> (at some point do an ADB-using-AH too)
17:26:29 <jbrooks> I replied LGTM, but I think he's looking for releng affirmation
17:26:35 <maxamillion> walters: ADB?
17:26:38 <maxamillion> jbrooks: +1
17:26:56 <kushal> maxamillion, the upstream of CDK.
17:26:59 <maxamillion> kushal: ah
17:27:01 <walters> maxamillion, https://github.com/projectatomic/adb-atomic-developer-bundle
17:27:05 <maxamillion> walters: +1 thanks
17:27:06 <walters> (the name is confusing)
17:28:23 <trishnag> okay we can move to the next one
17:28:30 <trishnag> #topic #156 Need complete Kickstart docs for Atomic Host https://fedorahosted.org/cloud/ticket/156
17:28:48 <trishnag> jberkus: This one is for you :)
17:28:54 <jberkus> those are written, just being reviewed, per update
17:29:05 <maxamillion> walters: yeah, I see ADB and think of Android :)
17:29:33 <maxamillion> walters: (not entirely relevant, but for reference https://developer.android.com/studio/command-line/adb.html)
17:29:45 <walters> yeah
17:30:21 <trishnag> jberkus: okay
17:30:33 <trishnag> moving forward
17:30:39 <trishnag> #topic #160 Ship fedora-motd in F24 atomic image https://fedorahosted.org/cloud/ticket/160
17:30:51 <trishnag> I think we just discussed this. kushal ^
17:31:09 <kushal> yeah
17:31:16 <trishnag> cool
17:31:36 <trishnag> #topic #167 Decide a process about failed tests for Autocloud https://fedorahosted.org/cloud/ticket/167
17:31:48 <trishnag> kushal: Update on this one?
17:32:09 <kushal> I just did few hours back.
17:32:16 <kushal> We need comments from others.
17:32:24 <kushal> I have a related item.
17:32:33 <kushal> Like https://bugzilla.redhat.com/show_bug.cgi?id=1353688
17:32:36 <kushal> walters, ^^
17:32:52 <kushal> this is failing for some time, should we have this test as release blocker or not.
17:33:31 <walters> commented
17:33:37 <kushal> walters, thank you.
17:34:09 <kushal> walters, Thanks once again.
17:34:10 <walters> i tend to be most concerned about regressions but it does seem valid to make it a  blocker
17:34:11 <trishnag> yeah this will make all atomic images fail
17:34:30 <kushal> walters, Okay.
17:35:26 <kushal> Can others please comment to https://fedorahosted.org/cloud/ticket/167 ?
17:35:41 <maxamillion> kushal: +1
17:35:51 <sayan> kushal: sure
17:36:21 <trishnag> okay moving forward
17:36:44 <trishnag> #topic #168 Put OpenShift Origin in Container with Fedora Base https://fedorahosted.org/cloud/ticket/168
17:36:58 <trishnag> scollier: This is for you.
17:37:02 <jberkus> trishnag: regarding 167
17:37:15 <jberkus> we need a way to decide on release blockers which DOESN'T wait for this weekly meeting
17:37:15 <kushal> jberkus, yes please :)
17:37:20 <trishnag> jberkus: yes
17:37:34 <jberkus> right now, if we hit a release blocker, nothing happens until Wednesday
17:37:43 <kushal> jberkus, We are going to add fedora-cloud to the issue tracker
17:37:55 <kushal> so that we get the mails for all failures
17:38:06 <trishnag> kushal: nice
17:38:13 <maxamillion> jbrooks: likely so, yes
17:38:17 <jberkus> yah -- however, my experience is that folks don't necessarily read fedora-cloud.  so we're going to have to start reading/responding to that
17:38:26 <scollier> reading
17:38:46 <jberkus> maxamillion: do we have an ability to push stuff to IRC?
17:38:53 <scollier> trishnag, , i updated the ticket.  i think it can merge with what maxamillion is doing, we just won't block on the system containers.
17:38:57 <kushal> sayan, ^^^
17:39:18 <kushal> scollier, Okay, this is more for the host (qcow2, vagrant images) etc
17:39:34 <scollier> kushal, not for the ticket that trishnag pinged me about.
17:39:43 <kushal> oops
17:39:46 <kushal> sorry
17:39:55 <sayan> kushal: jberkus: I am not sure, but this is something I can look into
17:39:57 <trishnag> scollier: okay. thanks for the update
17:40:19 <jberkus> sayan: if not, IRC bots are simple.  the hard part is how do I pull the info that we're blocked?
17:40:21 <maxamillion> jberkus: "push stuff to irc"? ... you mean have a bot do notifications or somethign?
17:40:29 <jberkus> maxamillion: yeah, and set the /topic
17:40:46 <kushal> jberkus, that sounds better, as I do not stay on IRC all the time
17:41:22 <maxamillion> jberkus: probably with zodbot somehow, what did you have in mind?
17:41:59 <jberkus> maxamillion: whenever we have a blocker bug, we should (a) sent a notice to fedora-cloud IRC, and (b) change the topic with a link to the bug
17:42:06 <jberkus> a lot of us are logged into that channel all the time
17:42:20 <jberkus> and this team is better about responding to IRC than mail
17:42:25 <maxamillion> jberkus: what happens when there are more than one blocker bug? would it queue them or bump the latest?
17:42:36 <trishnag> or if we can do .failure zodbot which will list down notifications?
17:42:37 <jberkus> maxamillion: whatever is easier
17:42:50 <misc> maxamillion: we make the fight, and the most blocking win
17:42:54 <misc> them
17:42:54 <trishnag> like it happens for .pull zodbot or something that shows recent PRs
17:43:56 <kushal> misc, :)
17:44:30 <maxamillion> jberkus: that's not what I'm asking, we need specific definitions of what is requested ... we as a group are really bad about ambiguous requests and then having rip out a bunch of code because of misunderstandings or miscommunications ... let's draft up an actual requirements specification and someone can then make sure the solution satisfies that specification
17:44:40 <jberkus> maxamillion: sure!
17:45:25 <scollier> +1 maxamillion
17:45:37 <jbrooks> +1
17:45:40 <kushal> maxamillion, +1
17:45:49 <maxamillion> alright, who's going to take on the task of writing the requirements specification?
17:45:54 <jberkus> #action draft spec for IRC bot for blocker bugs
17:46:01 <jberkus> feh, wrong syntac
17:46:09 <jbrooks> Is there an example to consult?
17:46:09 <kushal> #undo'
17:46:10 <zodbot> Removing item from minutes: ACTION by jberkus at 17:45:54 : draft spec for IRC bot for blocker bugs
17:46:10 <jberkus> maxamillion: I'll draft an issue
17:46:22 <kushal> #action jberkus will draft spec for IRC bot for blocker bugs
17:46:23 <maxamillion> jberkus: thanks
17:46:34 <trishnag> kushal: thanks :)
17:47:01 <jberkus> I'll need people to look at it before next week, though, please
17:47:06 <jberkus> will post to fedora-cloud
17:47:26 <kushal> My laptop battery will die before this meeting :(
17:47:53 <trishnag> #topic Open Floor
17:48:29 <sayan> I am planning to move the testing part of fedimg where it tests the AMIs to AutoCloud
17:48:40 <gholms> Nice
17:48:43 <sayan> I will send a detail plan for the implementation over the mailing list
17:48:53 <maxamillion> sayan: +1
17:49:10 <kushal> sayan, +1
17:49:26 <sayan> I did a release of fedimg==0.7, which makes it compose-based
17:49:40 <sayan> I am yet to deploy it.
17:50:12 <sayan> That's all from my side :)
17:50:37 <trishnag> sayan: Thanks.
17:50:46 <trishnag> I guess I haven't missed any ticket :)
17:50:48 <jberkus> we need to finish the new cloud/atomic PRD
17:50:56 <trishnag> jberkus: +1
17:51:53 <maxamillion> sayan++
17:51:53 <zodbot> maxamillion: Karma for sayanchowdhury changed to 11 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:52:47 <jberkus> kushal, can you take this one?
17:53:19 <kushal> jberkus, I plate is full, I can comment, but can not write/add things for now.
17:53:59 <walters> i have a lot of open questions about the WG rename and all of that but it's a bit more than an open floor topic
17:54:52 <kushal> walters, feel free to send those the list, so that mattdm can also join in.
17:55:06 <jberkus> walters: I'm still not sure the WG is being renamed
17:55:12 <jberkus> discussion is on Council
17:55:34 <kushal> jberkus, Oh, I never knew that part.
17:57:48 <trishnag> ok ending the meeting then
17:57:55 <trishnag> 5
17:57:57 <trishnag> 4
17:58:01 <trishnag> 3
17:58:02 <trishnag> 2
17:58:02 <scollier> thanks trishnag
17:58:04 <trishnag> 1
17:58:07 <trishnag> #endmeeting