fedora_cloud_wg
LOGS
17:01:40 <sayan> #startmeeting fedora_cloud_wg
17:01:40 <zodbot> Meeting started Wed Aug 17 17:01:40 2016 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:40 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
17:01:48 <sayan> #topic Roll Call
17:01:52 <kushal> .hellomynameis kushal
17:01:53 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:01:53 * gholms waves
17:02:04 <sayan> .hellomynameis sayanchowdhury
17:02:05 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:02:09 <jberkus> .hello jberkus
17:02:10 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:02:11 <trishnag> .hello trishnag
17:02:11 <jbrooks> .hello jasonbrooks
17:02:12 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:02:15 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:02:38 <nzwulfin> .hello mmicene
17:02:39 <zodbot> nzwulfin: mmicene 'Matt Micene' <nzwulfin@gmail.com>
17:03:15 <kushal> I have few things to say in start.
17:04:00 <scollier> .hello scollier
17:04:01 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:04:11 <sayan> #chair trishnag kushal nzwulfin scollier jberkus gholms
17:04:11 <zodbot> Current chairs: gholms jberkus kushal nzwulfin sayan scollier trishnag
17:04:18 <kushal> sayan, can I go ahead?
17:04:29 <sayan> kushal: sure
17:04:56 <kushal> So during Flock there was some discussion about PRD(s) from different WG(s).
17:05:03 <maxamillion> .hello maxamillion
17:05:04 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:05:06 <maxamillion> sorry
17:05:24 <sayan> #chair maxamillion
17:05:24 <zodbot> Current chairs: gholms jberkus kushal maxamillion nzwulfin sayan scollier trishnag
17:05:34 <jzb> .hellomynameis jzb
17:05:35 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:05:50 <sayan> #chair jzb
17:05:50 <zodbot> Current chairs: gholms jberkus jzb kushal maxamillion nzwulfin sayan scollier trishnag
17:06:03 <kushal> One of the suggestion from mattdm was about creating a new Fedora Atomic WG. Keeping the Cloud SIG/wg as it is, and making sure we focus more focus on Atomic/openshift side (as discussed in the last cloud FAD).
17:06:11 <bowlofeggs> .hello bowlofeggs
17:06:12 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
17:06:30 <maxamillion> I don't think we have enough people or spare cycles for that, but I'm not against it
17:06:42 <sayan> #chair bowlofeggs
17:06:42 <zodbot> Current chairs: bowlofeggs gholms jberkus jzb kushal maxamillion nzwulfin sayan scollier trishnag
17:06:53 <maxamillion> however, if we do that I'll likely exit the Cloud WG and focus only on Atomic WG purely because I wouldn't have the cycles for both
17:07:04 <vvaldez> .hello vvaldez
17:07:05 <zodbot> vvaldez: vvaldez 'Vinny Valdez' <vvaldez@redhat.com>
17:07:06 <kushal> maxamillion, understood.
17:07:32 <kushal> We will have to create new PRD, and making sure we have the actual user stories for the atomic workgroup.
17:07:34 <sayan> #chair vvaldez
17:07:34 <zodbot> Current chairs: bowlofeggs gholms jberkus jzb kushal maxamillion nzwulfin sayan scollier trishnag vvaldez
17:07:57 <jbrooks> I'd probably shit to atomic wg as well
17:08:00 <jbrooks> heh
17:08:00 <kushal> One problem I personally see, that we are not using Atomic in our daily life, and that means we don't see all the problems our users can see.
17:08:02 <jbrooks> shift
17:08:08 <kushal> jbrooks, hahaha :)
17:08:14 <maxamillion> jbrooks: :)
17:08:27 <jberkus> kushal: I'm using it daily
17:08:38 <gholms> Would starting a new group solve that problem?
17:08:48 <jberkus> kushal: and after LinuxCon, I plan to switch to atomic workstation for my laptop
17:09:08 <maxamillion> kushal: I have been for the last few days and likely will in the future
17:09:10 <kushal> gholms, nope, but I am trying to identify people who are interested/users of the atomic side.
17:09:14 <jbrooks> That's interesting, would an atomic wg work on atomic workstation, too?
17:09:19 <scollier> kushal, i thought the intent was to deprecate the CLoud SIG and focus on atomic?
17:09:25 <jberkus> kushal: I thought the idea was that the remainder of Cloud WG would get folded into Server, though?
17:09:26 <kushal> jbrooks, I think nope.
17:09:27 <maxamillion> jberkus: you building your own trees or are there images somewhere being built?
17:09:49 <jberkus> maxamillion: right now, since I'm only using server and tools, I'm using the mainstream tree
17:09:57 <kushal> scollier, Deprecating Cloud SIG may send out wrong message that we don'
17:10:02 <kushal> scollier, Deprecating Cloud SIG may send out wrong message that we don't care about Cloud.
17:10:05 <jberkus> once I move to workstation, I'll be sharing a tree with gscrivano, probably
17:10:07 <kushal> Which is not true at all.
17:10:17 <gholms> It was just a shift of emphasis.
17:10:20 <jberkus> kushal: my point at the PRD session is: Cloud *is* Server
17:10:34 <scollier> would be nice to have Matt here
17:10:34 <jberkus> how many new installs of linux today are on bare metal?
17:10:38 <maxamillion> jberkus: I'll take that conversation offline but I'm interested in what you're going to do there
17:10:39 <kushal> scollier, true that.
17:10:46 <jzb> IMO, worrying about hte name is ... not really that useful
17:10:49 <jzb> the
17:11:06 <jberkus> maxamillion: Peter and Guiseppe already have a tree for laptops.
17:11:11 <jzb> of all the stuff we could spend time on whether it's called cloud or atomic seems not so important.
17:11:37 <kushal> jzb, partially true, we just should not give out any wrong message.
17:11:42 <maxamillion> jberkus: I'd likely build my own tree just because I don't really use anything standard, I normally start from a minimal install and kick off my ansible playbook
17:11:55 <kushal> jzb, because we have images to run on actual clouds.
17:12:13 <kushal> and we are not killing the base image (may not be the focus, but it is there).
17:12:18 <jzb> lemme rephrase
17:12:31 <jzb> given the amount of person-power we have and the amount of time we have to actually work on things
17:12:45 <jzb> is it a good use of time to worry about branding vs. the other things we could be doing?
17:13:07 <jzb> is one hour chasing this question down worth one hour that could be spent doing something else?
17:13:11 <kushal> jzb, I am with you in this point, getting things done are more important.
17:13:43 <maxamillion> jzb: I think some of it is seperation of duties/concerns/focus ... I assume the proposed Atomic WG wouldn't focus on, nor care about, the Cloud Base deliverable(s)
17:13:52 <jberkus> jzb: I was more interested in the substance at the PRD; the idea that eventually the server WG would take over the standard AMI images.
17:14:12 <kushal> jzb, maxamillion also cloud sig will make sure that Fedora is there on AWS, and any such place in future.
17:14:22 <kushal> jberkus, question is when?
17:14:42 <jberkus> kushal: you'll notice we didn't get an answer on that ;-)
17:14:56 <kushal> jberkus, Yes, I am also trying to find answers.
17:15:05 <jberkus> anyway, I'm saying that at the PRD session, people were not suggesting creating a fourth WG
17:15:06 <kushal> That is why I put up this idea here.
17:15:09 <kushal> #chair walters
17:15:09 <zodbot> Current chairs: bowlofeggs gholms jberkus jzb kushal maxamillion nzwulfin sayan scollier trishnag vvaldez walters
17:15:09 <walters> hey, sorry i haven't been to one of these in a while, have it on my calendar again.
17:15:17 <jberkus> which I would have been opposed to, due to lack of manpower
17:15:19 * gholms is curious what makes that a foregone conclusion
17:16:00 <kushal> jberkus, then as a WG we can decide that just change the name, and update the PRD as required.
17:16:14 <kushal> Updating the PRD is more important than the name part.
17:16:26 <maxamillion> walters: welcome :)
17:16:54 <scollier> I need to step out for a bit.  sorry. jberkus, i did send you a link to the OSE on AWS code, will follow up later.
17:17:22 <jbrooks> https://fedoraproject.org/wiki/Cloud/Cloud_PRD
17:17:27 <jbrooks> That's the current PRD?
17:17:33 <kushal> jbrooks, yes.
17:17:38 <jberkus> jbrooks: we didn't finish updating it at Flock
17:18:02 <kushal> jberkus, that is part of the problem, we had it hanging :(
17:18:13 <jbrooks> Is there a draft from flock?
17:18:39 <jberkus> kushal: here's another question of substance: who's going to handle Atomic Workstation?  Us, or Workstation WG?
17:19:09 <kushal> jbrooks, For cloud, none.
17:19:15 <kushal> jberkus, As I know, workstation
17:19:28 <kushal> But I can count it as open question.
17:19:58 <jberkus> kushal: we'll need more active collaboration, then, since things like container base images will overlap both.  not that that's a bad thing
17:20:06 <jbrooks> One thing that stands out to me is how much time we spend on rel eng stuff vs on getting this prd stuff done
17:20:15 <jberkus> (and I'll have to start hangign out in Workstation)
17:20:17 <kushal> I think better that we up all these questions in one place, and start the discussion over list, and try to find the answers. Without clear goals, it does not make sense.
17:20:26 <kushal> jberkus, Yes.
17:21:04 <jbrooks> I think we know about the deliverables we want to exist, it's not always clear who should deliver them
17:21:31 <walters> FWIW i am working on (and currently use on my laptop)  https://pagure.io/fork/walters/workstation-ostree-config/branch/f24-continuous
17:21:32 <jbrooks> An atomic wg could focus on tooling around atomic things, and work w/ other groups that have specific deliverables
17:21:53 <kushal> #link https://pagure.io/fork/walters/workstation-ostree-config/branch/f24-continuous
17:21:58 <walters> the package layering makes it practical
17:22:01 <gholms> Ah, that'd be more along the lines of the core and modularity groups.  That would make sense.
17:22:08 <jbrooks> server and workstation both seem to want to get into the atomic game, in some ways, which is good
17:22:31 <maxamillion> walters: +1 - that's cool
17:23:09 <maxamillion> jbrooks: "how much time we spend on rel eng stuff" ..... I'm not sure I follow
17:23:42 <jbrooks> maxamillion, most of each week seems to be reviewing tickets
17:23:59 <maxamillion> jbrooks: yup, and an alarming number of them are blocked on me :/
17:24:45 * dustymabe lurks
17:25:36 <vvaldez> where could someone new like myself contribute?
17:25:41 <jberkus> jbrooks: exactly, on the deliverables
17:25:50 <jberkus> vvaldez: not sure, what do you want to do?
17:26:00 <maxamillion> the number of people who show up to this meeting and are involved in the Cloud WG who actually have enough cycles to get real work done is alarmingly low (myself included a large part of the time)
17:26:09 <dustymabe> vvaldez: welcome!
17:26:14 <dustymabe> glad to have you here
17:26:51 <vvaldez> jberkus: I want to help ;) is there a taiga board with tasks or anything? I'm good with ansible if that is needed anywhere, anything else I can hopefully figure out
17:27:05 <sayan> kushal: do you plan to take this over to the mailing list? we are almost at 50%
17:27:44 <kushal> sayan, I think that is the better idea.
17:28:05 <kushal> #action kushal to start off the atomic workgroup discussion on mailing list
17:28:13 <kushal> sayan, continue please
17:28:26 <vvaldez> dustymabe: thanks!
17:28:42 <sayan> #topic Action items from last meeting
17:28:57 <sayan> * rtnpro will add test workflow (and test cases) for testing fedora-motd on F24 atomic image
17:28:59 <sayan> * kushal to write to infra for permission to update Autocloud tests while in freeze
17:29:22 <dustymabe> rtnpro: ^^
17:29:29 <jberkus> vvaldez: oh!  we could definitely use help with openshift-ansible and FAH
17:29:37 <sayan> since rtnpro is not here I will re-action the item
17:29:46 <rtnpro> dustymabe, I could not work on it last week
17:29:54 <rtnpro> dustymabe, I commit to do it this week
17:30:01 <sayan> rtnpro: welcome :)
17:30:09 <rtnpro> dustymabe, so, let's add it as an action item this week
17:30:12 <sayan> #action rtnpro will add test workflow (and test cases) for testing fedora-motd on F24 atomic image
17:30:25 <sayan> #chair rtnpro
17:30:25 <zodbot> Current chairs: bowlofeggs gholms jberkus jzb kushal maxamillion nzwulfin rtnpro sayan scollier trishnag vvaldez walters
17:30:31 <kushal> I could not do that, got pulled down in something else last week.
17:30:42 <kushal> Will make sure to do that this Friday.
17:31:38 <sayan> #action kushal to write to infra for permission to update Autocloud tests while in freeze
17:32:04 <sayan> #topic Fedora-Dockerfiles examples for Kubernetes https://fedorahosted.org/cloud/ticket/125
17:32:43 <sayan> jberkus: ^^
17:33:39 <jberkus> sayan: no updates due to conference schedule
17:33:48 <jberkus> hmmm, but I should comment on the ticket
17:33:59 <sayan> jberkus: yes, that would be better
17:34:05 <sayan> moving to next ticket
17:34:26 <sayan> #topic vagrant boxes fixups https://fedorahosted.org/cloud/ticket/136
17:35:01 <sayan> since imcleod is not around, moving to next ticket
17:35:50 <sayan> #topic Don't overwrite download location for 2 week atomic images https://fedorahosted.org/cloud/ticket/147
17:36:27 <sayan> jbrooks: update on this ticket ^
17:37:21 <jbrooks> sayan, No, it's caught between some releng rewrite of the future and dusty not wanting to link to images from the testing dir structure
17:37:23 <maxamillion> I'm going to try and get that done by next meeting at least for the release script, but I'll have to lean on someone else for fedimg/AWS
17:37:31 <jbrooks> ah, cool
17:37:39 <sayan> maxamillion: I can help with that
17:38:06 <maxamillion> the rewrite is going to take some time because we're blocked on an auto-signing implementation and I'm just not going to wait on that, we'll get a band-aid fix in for now and handle it more cleanly later
17:38:31 <jbrooks> sweet
17:39:27 <sayan> #topic design, deploy and document Fedora OpenShift Playground (FOSP) https://fedorahosted.org/cloud/ticket/153
17:39:39 <jberkus> vvaldez: I don't have a good writeup of the work which needs to be done, though.  Should we use github issues?  Or something else?
17:40:03 <sayan> jberkus: scollier ^^
17:40:40 <vvaldez> jberkus: that works
17:40:51 <jberkus> scollier: should we follow up on FOSP offmeeting?
17:41:08 <sayan> jberkus: oh! scollier stepped out of the meeting
17:42:11 <sayan> moving on to next one
17:42:26 <sayan> #topic make Fedora Atomic download page clearer https://fedorahosted.org/cloud/ticket/154
17:43:36 <sayan> jberkus: update on this ticket?
17:44:14 <jberkus> sayan: conference delays.  will get to this after LInuxcon
17:44:18 <jberkus> updating
17:44:33 <sayan> jberkus: sure
17:44:51 <sayan> #topic Decide on post-GA update cadence for various deliverables https://fedorahosted.org/cloud/ticket/155
17:45:33 <jbrooks> maxamillion and I followed up on this some w/ releng
17:45:51 <jbrooks> There was a complaint of too little specificity
17:46:07 <jbrooks> maxamillion, did that, uh, improve any?
17:47:02 <maxamillion> jbrooks: not that I know of
17:48:11 <jbrooks> maxamillion, If there's an example of the sort of spec we need, I can work on getting it filled out
17:48:23 <jbrooks> talk to ppl, send it to the list, etc
17:49:07 <jbrooks> sayan, I'll follow up more before next mtg
17:49:31 <maxamillion> jbrooks: yeah, I hope to be able to follow up on this some soon ... I've got some work closing out so I'll have a small amount of lag time before my next big project where I hope to clean up a lot of these
17:49:59 <sayan> jbrooks: ok, moving to the next ticket.
17:50:16 <sayan> #topic Need complete Kickstart docs for Atomic Host https://fedorahosted.org/cloud/ticket/156
17:51:03 <sayan> jberkus: any update on this?
17:52:32 <jberkus> sayan: updating
17:52:53 <sayan> moving to the next one
17:53:10 <sayan> #topic Ship fedora-motd in F24 atomic image https://fedorahosted.org/cloud/ticket/160
17:54:41 <sayan> skipping as he already told he did not get to work on fedora-motd
17:54:59 <sayan> #topic Decide a process about failed tests for Autocloud https://fedorahosted.org/cloud/ticket/167
17:55:05 <kushal> No update from, will work on thse next week.
17:55:18 <kushal> * from me
17:55:36 <sayan> #topic Put OpenShift Origin in Container with Fedora Base https://fedorahosted.org/cloud/ticket/168
17:55:53 <sayan> skipping this one as scollier isn't around
17:56:07 <sayan> #topic Open Floor
17:56:23 <kushal> trishnag, has started writing/updating docs
17:56:36 <kushal> ryan is helping us with a Fedora theme
17:56:52 <kushal> You can find it in this link
17:56:53 <kushal> http://fedoracloud.readthedocs.io/en/latest/
17:56:58 <trishnag> kushal: yes
17:57:06 <x3mboy> !
17:57:08 <x3mboy> .fas x3mboy
17:57:09 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
17:57:11 <gholms> Cloud-init recently did a long-awaited release, so I will test that on F24 and push it to F25 if it seems to work.  (F25 doesn't boot.)
17:57:36 <gholms> #action gholms to test updated cloud-init on f24 for f25
17:57:39 <kushal> gholms, if you have any ideas for docs need to be written, feel free to ping me and trishna :)
17:57:53 <gholms> Thanks!
17:58:13 <sayan> the docs looks good, needs some minor css fixes
17:58:24 <sayan> ryanlerch++
17:58:24 <zodbot> sayan: Karma for ryanlerch changed to 11 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:58:51 <maxamillion> ryanlerch++
17:58:51 <zodbot> maxamillion: Karma for ryanlerch changed to 12 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:59:00 <maxamillion> that's awesome, I'd love to be able to use that theme for the releng docs
17:59:07 <maxamillion> alright, what's next? we're almost at the hour
17:59:25 <nzwulfin> i've been told there's a b-day in the channel ...
17:59:26 <sayan> going ahead and closing the meeting
17:59:34 <gholms> Heh
17:59:39 <x3mboy> Hi team, i'm writting on the behalf of the Marketing Team
17:59:40 <nzwulfin> but no need to do that in meeting :)
17:59:53 <x3mboy> We are collecting the talking points for F25
18:00:03 <sayan> x3mboy: Hi :)
18:00:08 <x3mboy> And we really would like to have some about spins
18:00:12 <x3mboy> sayan, o/
18:00:39 <x3mboy> If you look in F24 https://fedoraproject.org/wiki/Fedora_24_talking_points we didn't have nothing on spins
18:00:55 <sayan> x3mboy: the best place to take this discussion to #fedora-cloud
18:01:01 <x3mboy> Ok
18:01:07 <x3mboy> sayan, thanks
18:01:19 <sayan> #endmeeting