fedora-qadevel
LOGS
14:02:03 <tflink> #startmeeting fedora-qadevel
14:02:03 <zodbot> Meeting started Mon Jul 25 14:02:03 2016 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:03 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:02:10 <tflink> #topic Roll Call
14:02:15 * mkrizek is here
14:02:39 * kparal is here
14:03:18 <tflink> kparal: aren't you on PTO this week?
14:03:39 * garretraziel is here
14:03:46 * kparal is a double agent
14:03:54 <jskladan> .
14:03:57 * jskladan is here
14:04:06 <kparal> tflink: I changed my PTO to Wed->Fri
14:04:20 <tflink> ah, ok
14:05:24 <tflink> well, let's get this party started
14:05:43 <tflink> #topic Announcements and Information
14:05:57 <tflink> #info new oauth2 based auth method has been deployed w/ recent database snapshot to qa.stg - tflink
14:06:39 <tflink> any others? it turns out that I forgot to actually click the "create" button on the wiki page last night so I'm not sure if folks tried to add stuff or not
14:06:43 <mkrizek> #info task-rpmgrill deployed to production - mkrizek
14:06:58 <kparal> #info new task-example-gzip repo to showcase simple dist-git-style task, for flock presentation
14:06:58 <mkrizek> #info task artifacts are now compressed - mkrizek
14:07:06 <kparal> #link https://bitbucket.org/fedoraqa/task-example-gzip
14:07:09 <tflink> #chair mkrizek kparal jskladan
14:07:09 <zodbot> Current chairs: jskladan kparal mkrizek tflink
14:07:21 <mkrizek> #info new libtaskotron released and deployed - mkrizek
14:07:36 <kparal> #info create_report and resultsdb directives now support 'file' as input parameter
14:07:45 <kparal> #info new much improved bash directive
14:07:54 <kparal> (now called 'shell')
14:08:16 <tflink> is all that in the newly released libtaskotron?
14:08:30 <kparal> mostly not yet
14:08:36 <kparal> we'll need another release this week
14:08:45 <tflink> k, just checking
14:09:04 <tflink> we may want to do that sooner than later so there's time for that new release to make it past updates-testing
14:09:22 <kparal> that brings us to a problem we identified today
14:09:31 <kparal> minions still pull from tflink copr repo
14:09:32 <tflink> oh?
14:09:41 <kparal> and they are also built from it
14:09:43 <tflink> ha
14:09:52 <tflink> yeah, we may want to update that
14:09:55 <kparal> so even if we push it to updates-testing or stable updates, it won't have any effect
14:10:01 <tflink> s/may want/should
14:10:15 <mkrizek> copr or infra repo?
14:10:16 <tflink> i was thinking of the workshop - I assume that you'll be having folks install libtaskotron?
14:10:21 <kparal> I'd like to do something about it this week, so that I'm able to showcase even minion execution on flock
14:10:50 <tflink> that sounds like a good plan to me - probably should have been done already
14:11:19 <kparal> mkrizek: I believe they pull from copr, for both building base images and updating libtaskotron when tasks are executed
14:11:44 <kparal> tflink: yes, I'll ask people to install libtaskotron. having it in updates-testing is probably good enough
14:12:09 <mkrizek> kparal: it must be infra, since minions are updated to 0.4.14
14:12:30 <kparal> hmm, interesting. building base images is still black magic to me
14:13:14 <mkrizek> we don't build in copr anymore but we still do put new packages into infra (so it's quicker that waiting for karma)
14:13:16 <kparal> jskladan said this is in the kickstart:
14:13:17 <kparal> repo --name="tflink-copr" --baseurl=https://copr-be.cloud.fedoraproject.org/results/tflink/taskotron/fedora-$releasever-$basearch/
14:13:48 <mkrizek> but isn't infra enabled as well?
14:13:58 <jskladan> the minions update from infra as a setup phase
14:14:16 <jskladan> when we spin them up - but that's taskotron's doing
14:14:40 <kparal> oh I see, minions in our infra are configured to update from infra on spin up
14:14:41 <tflink> either way, we should probably change that to the fedora repos, allowing for updates-testing
14:14:42 <jskladan> or, to be precise - we add the infra repo in the post-image-build steps specific to taskotron
14:14:48 <kparal> but for regular people, it pulls from copr
14:15:00 <jskladan> but libtaskotron does update on the machine startup
14:15:04 <jskladan> if nothing changed
14:15:05 <tflink> it could pull from copr
14:15:09 <jskladan> (and dnf works)
14:15:28 <tflink> if there's a newer build in the fedora repos, wouldn't it pull from there?
14:15:29 <kparal> ok, things work correctly in our infra, but won't work correctly for me (on flock)
14:15:50 <kparal> tflink: we disable fedora repos to speed up spin up time :)
14:15:52 <tflink> yeah, I think that the consensus is that it would be good to get all that updating from the same place
14:15:55 <kparal> tflink: only enable the extra copr repo
14:15:57 <mkrizek> ok, so let's remove copr from default taskotron.yaml and from minion kickstart
14:16:07 <kparal> tflink: we might need to re-evaluate that :)
14:16:32 <tflink> kparal: not adding the fedora repos or getting libtaskotron from fedora repos?
14:16:55 <kparal> I'm actually not sure what is the best solution here
14:17:15 <tflink> does anyone want to take a #action on this?
14:17:20 <kparal> whether we should pull everything from fedora repos (and which ones), or whether we should have a separate copr repo for minions
14:17:42 <tflink> i don't think that copr repo would be ok with infra
14:17:46 <mkrizek> kparal why have separate repo for minions?
14:17:59 <kparal> how are we going to test develop versions of libtaskotron?
14:18:08 <mkrizek> *-testing?
14:18:27 <mkrizek> either fedora or infra
14:18:54 <kparal> and how will the minion know whether to update libtaskotron from stable updates, or even updates-testing?
14:18:58 <tflink> i think that partially gets back to the questions of which images are produced and how folks get access to them
14:19:20 <tflink> add updates-testing as a repo in conf?
14:19:36 <kparal> I think we have 2 use cases - stable minions for production and general audience, and unstable minions for dev/stg
14:19:41 <mkrizek> well, if there's a new version that it updates it, I am not sure I follow
14:19:54 <mkrizek> *than
14:20:49 <kparal> do we still use testcloud for pre-spinup configuration of repos, or do we currently bake the information in during image creation?
14:21:03 <kparal> I know we changed it, but I don't know how
14:21:15 <mkrizek> we don't use testcloud for that afaik
14:21:23 <tflink> i thought that we were still using testcloud but it's been a while since I was in that code
14:21:48 <kparal> ok, let's look at how it's currently done and talk what to do with it
14:21:55 <kparal> *then talk
14:22:09 <tflink> is this something we want to figure out now or wait until flock when many of us will be in the same room?
14:22:25 <kparal> I would like to see ideally the same minion pulling just from updates in production env, and also from updates-testing in dev/stg env
14:22:44 <mkrizek> https://infrastructure.fedoraproject.org/cgit/ansible.git/tree/roles/taskotron/taskotron-client/templates/settings.py.testcloud.j2 - we don't anymore
14:23:04 <jskladan> we don't add repos in testcloud anymore
14:23:05 <kparal> I think this is something we can chat about in person, but I'd need at least some quick fix to make minions work well when used in public
14:23:11 <jskladan> we just add it in the postprocess
14:23:21 <kparal> by working well, I mean updating to latest libtaskotron when I spin them up
14:23:42 <jskladan> they will update to the latest libtaskotron in updates kparal
14:23:46 <kparal> the simplest fix is probably to build testcloud in our copr as well
14:24:01 <tflink> not sure what that would fix
14:24:09 <jskladan> neither am i
14:24:36 <tflink> but I'll renew my question of - is this something that we need to figure out now or can it  wait until Flock/after-flock?
14:25:03 <jskladan> I think that if I provide a minion with "latest" libtaskotron at the time for kparal
14:25:07 <kparal> quickfix now, proper fix later
14:25:14 <mkrizek> isn't the simplest fix to push libtaskotron to fedora stable?
14:25:19 <jskladan> mkrizek: it is :)
14:25:28 <tflink> then let's do that :)
14:25:30 <kparal> once again, minions ignore fedora repos at spin up time
14:25:38 <kparal> mkrizek: nope
14:25:46 <tflink> not at image build time, though
14:25:50 <kparal> ah
14:25:52 <jskladan> ^^
14:26:02 <kparal> ok, that would work
14:26:06 <mkrizek> \o/
14:26:12 <jskladan> (or to copr, as it is now)
14:26:16 <tflink> when will  the next batch of changes be ready for release?
14:26:21 <kparal> but we need to build new libtaskotron first, then build the minions, then publish them
14:26:25 <tflink> yeah, for this, copr would also work
14:27:01 <kparal> I think we're mostly ready, but we might do some last touches tomorrow and build new libtaskotron tomorrow
14:27:06 <tflink> sounds good
14:27:38 <tflink> the pkgdb group stuff is working, isn't it? ie, we aren't hung up on one person for any part of the process?
14:28:04 <kparal> the group is broken for bodhi submissions
14:28:12 <kparal> but it works for dist-git and koji
14:28:24 <tflink> have folks been added as maintainers directly, then?
14:28:38 <tflink> or is mkrizek the only one who can create updates?
14:28:53 <kparal> lmacken might have added our group into bodhi whitelist
14:28:59 * kparal checks older conversation
14:29:22 <kparal> the bug is reported here: https://github.com/fedora-infra/bodhi/issues/872
14:29:30 <tflink> either way,
14:29:48 <linuxmodder> .hello linuxmodder
14:29:49 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
14:29:50 <kparal> <lmacken> kparal: bodhi has a hardcoded list of "important_groups" that it pays attention to... currently it's:
14:29:50 <kparal> <lmacken> important_groups = proventesters provenpackager releng security_respons packager bodhiadmin virtmaint-sig kde-sig eclipse-sig infra-sig gnome-sig python-sig robotics-sig
14:29:51 <kparal> <lmacken> I can add qa-tools-sig
14:29:51 <kparal> <lmacken> fixed in ansible.
14:29:55 <tflink> #action mkrizek to add at least one more person as maintainer of libtaskotron so we have backups
14:29:55 <linuxmodder> (kinda here)
14:30:04 <kparal> I don't know if it has been deployed yet
14:30:33 <tflink> i guess we'll find out when the release is done this week :)
14:30:50 <kparal> good idea, I'll try to submit it
14:31:07 <tflink> anything more on this?
14:31:24 <mkrizek> not here
14:31:29 <kparal> probably no
14:31:33 <tflink> #action kparal to do new build and release of libtaskotron when needed-for-flock features are finished
14:32:05 <tflink> ok, moving on
14:32:12 <tflink> #topic Flock
14:32:21 <tflink> How are we doing on preparations for Flock?
14:32:31 <tflink> it sounds like most everything is on track?
14:33:12 <kparal> the simple example task that I created should be enough materials for the workshop
14:33:29 <kparal> I still need to prepare how I'm going to show it
14:33:44 <kparal> I want to have different stages, increasing complexity gradually
14:34:10 <kparal> we have picked an example that should work offline, mkrizek's idea
14:34:13 <tflink> do you see any problems with having that done in time?
14:34:31 <kparal> nope, if something's missing when I go on PTO, I simply ask mkrizek to finish it :P
14:34:47 <tflink> interesting approach :-P
14:35:24 <mkrizek> or cancel PTO
14:35:36 <kparal> I already did, partially! :)
14:35:51 <kparal> so overall I hope the workshop should be prepared
14:35:58 <tflink> kparal is apparently only a limited team player ...
14:36:01 * tflink kids
14:36:18 <tflink> sounds good
14:36:20 <kparal> I'd like to know what's the internet access is going to be like, but I guess it's going to be a surprise, as always
14:36:42 <tflink> my experience is that it's wise to count on no internet access when making presentations
14:37:15 <tflink> anything else here?
14:38:05 <jskladan> nothing here
14:38:07 * tflink assumes silence == no
14:38:16 <tflink> #topic Phabricator and qadevel
14:38:41 <tflink> so, it sounds like there are still some bugs in the oauth2 stuff I wrote for phabricator
14:39:01 <tflink> I'm going to see if I can get that figured out in the next couple of days
14:39:16 <tflink> I had been hoping to move qadevel to qa.fedoraproject.org before Flock
14:39:44 <tflink> so phab.qadevel.cloud.fedoraproject.org would become phab.qa.fedoraproject.org
14:40:18 <tflink> stg is already like that, had been waiting for auth to not be horribly broken before moving production over
14:40:49 <tflink> assuming that production ipsilon is updated in time, any objections to doing that this week?
14:41:36 <mkrizek> nope
14:41:39 <kparal> it might not be a good idea to do it on friday :)
14:42:33 <tflink> kparal: because you'll be on PTO?
14:42:38 <tflink> oh, 'not"
14:42:40 <tflink> nevermind
14:42:56 <tflink> part of it'll depend on when ipsilon is updated
14:43:09 <tflink> I'll coordinate with infra on that
14:43:43 <tflink> #info we're planning to migrate qadevel to qa.fedoraproject.org before flock
14:43:57 <tflink> #action tflink to coordinate with infra on whether this will be possible or not
14:44:06 <kparal> will we need to update links in docs?
14:44:14 <tflink> possibly
14:44:22 <kparal> because we need a new libtaskotron build to upload new docs, right?
14:44:23 <tflink> my plan is to make redirects work transparently
14:44:27 <kparal> alright
14:44:31 <kparal> in that case, no issue
14:44:42 <tflink> assuming the redirects work, yes :)
14:45:51 <tflink> anything else on this?
14:46:13 <kparal> nothing here
14:46:21 <tflink> ok, moving on
14:46:39 <tflink> #topic Docker Testing Status
14:47:19 <tflink> i feel like this may have been resolved already and I just can't find it in my notes
14:48:50 <tflink> does anyone know of any bits that we're missing to support docker image testing in taskotron?
14:48:59 <tflink> other than concrete use cases, any ways
14:49:15 <jskladan> I'm not sure about the shell directive status
14:49:17 <jskladan> kparal?
14:49:57 <kparal> lbrabec is unfortunately absent. but I'm not aware of anything particular we're missing.
14:50:08 <kparal> our shell directive is much more useful now for docker testing
14:50:16 <tflink> good to hear
14:50:50 <kparal> I guess we'll need to see some real images to play with, in order to identify what more to do about this
14:50:51 * tflink is talking with releng folks later today about that, wanted to make sure he wasn't missing anything large or obvious
14:51:00 <kparal> reporting from bash is now also reasonably easy
14:51:03 <tflink> I'm not sure what the status of that is
14:51:18 <kparal> we'll need trigger changes, of course
14:51:22 <tflink> #action tflink to check on status of OSBS integration with koji/fedmsg
14:51:35 <kparal> and probably some docker download directive
14:51:50 <kparal> but all of that waits until fedora docker infra is in place
14:51:57 <tflink> yeah, still not quite sure how that's going to work
14:52:08 <tflink> it's mostly in place as of last week, AFAIK
14:52:15 <tflink> the remaining bits may be done
14:52:32 <tflink> we're almost out of time, anything else here?
14:52:41 <tflink> so much for a quick meeting :-/
14:53:02 <kparal> nothing from me
14:53:21 <tflink> #topic python package check
14:53:40 <tflink> not sure what to call this but I was wondering what the plan was for the python check which was submitted in phab last week
14:54:11 <tflink> https://phab.qadevel.cloud.fedoraproject.org/D948
14:54:58 <tflink> is there a plan for that check?
14:55:21 <kparal> the submitter approach us last week and said he had a nice useful python check, and whether we can execute it for all newly built python packages in koji
14:55:46 <kparal> so we said "yeah sure, that's exactly what we can do" and asked him to send us the check for review
14:55:51 <tflink> ok
14:56:01 <tflink> do we know how we're going to handle triggering?
14:56:21 <kparal> for the moment, we'll probably execute it on all packages, and it will ignore non-python ones
14:56:26 <jskladan> we'll just trigger for all koji builds
14:56:31 <tflink> ok
14:56:52 <tflink> just wanted to make sure someone knew what was going on :)
14:57:05 <tflink> #topic open floor
14:57:23 <tflink> is there anything that folks wanted to bring up that we didn't cover?
14:57:48 <kparal> nope
14:57:58 <garretraziel> nothing here
14:58:10 <tflink> is anyone in need of tasks?
14:59:00 <jskladan> nope
15:00:25 <tflink> ok, if there's nothing else, I'll light the fuse and we can head over to the qa meeting
15:00:44 * tflink will send out minutes shortly
15:00:48 <tflink> thanks for coming everyone
15:00:51 <tflink> #endmeetiong
15:00:53 <tflink> #endmeeting