fpc
LOGS
16:00:55 <geppetto> #startmeeting fpc
16:00:55 <zodbot> Meeting started Thu Jun 30 16:00:55 2016 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:55 <zodbot> The meeting name has been set to 'fpc'
16:00:55 <geppetto> #meetingname fpc
16:00:55 <zodbot> The meeting name has been set to 'fpc'
16:00:56 <geppetto> #topic Roll Call
16:01:01 <orionp> hello
16:01:01 <tibbs|w> Howdy.
16:01:08 <tibbs|w> I'm actually here on time this morning.
16:01:16 <geppetto> #chair orionp
16:01:16 <zodbot> Current chairs: geppetto orionp
16:01:19 <geppetto> #chair tibbs
16:01:19 <zodbot> Current chairs: geppetto orionp tibbs
16:01:33 <geppetto> limburgher: You here?
16:02:03 <geppetto> tibbs: I changed the calendar ... so ++ to both of us ;)
16:02:27 <tibbs|w> BTW, do we need to change  our reservation to grab two hours?
16:02:50 <tibbs|w> I don't remember at all where that happens.
16:03:11 <geppetto> AFAIK the calendar is the only thing
16:03:21 <geppetto> but maybe I'm forgetting something
16:04:00 <mbooth_> hi
16:04:11 <geppetto> #chair mbooth_
16:04:11 <zodbot> Current chairs: geppetto mbooth_ orionp tibbs
16:04:54 <tibbs|w> I just noticed that my phone is updated with the proper time, and that the meeting is now set to two hours.
16:05:07 <tibbs|w> While we're waiting, some administrivia.
16:05:17 <geppetto> You are probably subscribed to the packaging calendar, which I changed
16:05:25 <racor> hi
16:05:29 <geppetto> #chair racor
16:05:29 <zodbot> Current chairs: geppetto mbooth_ orionp racor tibbs
16:05:32 <tibbs|w> I'm leaving on vacation next Wednesday.  I will not be back home until August 6th.
16:05:39 <geppetto> Wow
16:05:43 <tibbs|w> The last week of that will be at Flock in Poland.
16:06:01 <tibbs|w> The rest, well, I have no idea how much access I'll have.
16:06:08 * geppetto nods
16:06:38 <limburgher> geppetto: Yes, just got distracted. :)
16:06:40 <tibbs|w> We're starting at my wife's parent's island up by the Arctic circle in Norway, working our way south through Trondheim, Bergen and Oslo, then to Amsterdam, and then to Flock in Krakow.
16:06:46 <geppetto> #chair limburgher
16:06:46 <zodbot> Current chairs: geppetto limburgher mbooth_ orionp racor tibbs
16:07:16 <geppetto> tibbs: they live there, or own an island? :-o
16:07:56 <tibbs|w> Heh, no, they just live on an island.  The town is Sandjessjøen, if you feel like looking it up.
16:08:19 <tibbs|w> Sandnessjøen, actually.
16:08:40 <geppetto> ok, cool
16:08:48 <geppetto> #topic Schedule
16:08:51 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/4EWMA4SFNIKXAMCJVSZVUQXRV6SOJYR6/
16:09:16 <tibbs|w> The mountain range on that island is awesome.  Not in enough shape to climb any of it this time, though.
16:09:54 <geppetto> #633 is done, it looks like
16:10:43 <geppetto> #topic #629  Handling directories under /var/lock and /var/run in %files and base image
16:10:48 <geppetto> .fpc 629
16:10:51 <zodbot> geppetto: #629 (Handling directories under /var/lock and /var/run in %files and base image) – fpc - https://fedorahosted.org/fpc/ticket/629
16:10:55 <geppetto> Not sure if anything needs to be done here
16:11:07 <geppetto> I guess move this to needinfo?
16:11:31 <tibbs|w> There are a couple of cleanups I still need to do.
16:11:32 <geppetto> Waiting on what systemd and upstream container tools people tell them?
16:11:46 <tibbs|w> But I really don't think this actually has anything to do with us.
16:12:36 <geppetto> #topic #610  Packaging guidelines: Check upstream tarball signatures
16:12:44 <geppetto> #topic #610  Packaging guidelines: Check upstream tarball signatures
16:12:48 <geppetto> .fpc 610
16:12:50 <zodbot> geppetto: #610 (Packaging guidelines: Check upstream tarball signatures) – fpc - https://fedorahosted.org/fpc/ticket/610
16:13:02 <tibbs|w> Sadly I've let this one drop.
16:13:03 <geppetto> I assume nothing much changed here?
16:13:07 * geppetto nods
16:13:21 <tibbs|w> It sort of degraded into people deciding they didn't like my choice of arguments and such for the macro.
16:13:22 <limburgher> Hrm.
16:13:32 <geppetto> Didn't the code get into rawhide though, and some packages start using it?
16:13:43 <tibbs|w> No, I never committed anything for that macro.
16:13:50 <geppetto> Oh :(
16:13:55 <tibbs|w> I did do a couple of conversions to see how it worked.
16:14:15 <geppetto> Did you think it looked good/better?
16:14:38 <tibbs|w> But basically some folks want this to end up as some sort of mandatory thing where if you use it it expects every single Source: file to be signed and fails if they aren't.
16:14:49 <tibbs|w> I'm not convinced that's a case that's ever going to be useful.
16:15:01 <limburgher> s/useful/possible/
16:15:05 <geppetto> yeh
16:15:13 <limburgher> It would effectively ban VCS snapshots.
16:15:16 <tibbs|w> There's one more pull request I need to look at.  I'll probably just go ahead and push it somewhere and then see how it shakes out.
16:15:19 <geppetto> much better to have a really simple way to turn it on
16:15:30 <geppetto> and then slowly nudge as many people as possible to turn it on
16:15:33 <limburgher> I love the idea of doing it where possible. . .
16:15:44 <tibbs|w> geppetto: RIght, you just include the one macro and it figures out what it can check.
16:15:49 <limburgher> And in a consistent way. . .
16:15:52 * geppetto nods
16:16:01 <geppetto> I say you should just push that macro somewhere then
16:16:14 <limburgher> It should be if(checkable): check and die if fail
16:16:17 <tibbs|w> The problem with that is that it fails open if you don't actually include the signatures as sources.
16:16:31 <tibbs|w> Which I understand, but.... at some point we have to trust the packager.
16:16:41 <tibbs|w> They can always list explicitly the sources they want it to check.
16:16:46 <geppetto> so it lands in /etc/rpm/macros on all build environments.
16:16:56 <limburgher> We do implicitly.  We have no choice.
16:17:13 <tibbs|w> But you're right, I will at least push it to rawhide so people can try it.
16:17:24 <geppetto> Cool
16:17:42 <tibbs|w> I guess it doesn't really hurt if it gets everywhere as long as people know that it could change.
16:17:48 <geppetto> #action tibbs Push it to rawhide, so people can try using it
16:17:55 <geppetto> Yeh
16:18:01 <limburgher> Trusting packages to voluntarily and transparently further illustrate their trustworthiness is A Good Thing.
16:18:12 <tibbs|w> Doing development when the pipeline between development and use is so incredibly long is... difficult.
16:18:14 <limburgher> packagers
16:18:27 <geppetto> I mean it looked fine too me, and I can't think how it would change either ... so it's not a big risk
16:19:05 <limburgher> tibbs|w: This is why I don't develop for HURD.
16:19:07 * limburgher ducks
16:19:10 <geppetto> Yeh, anything that changes rpm tends to be a long road of change
16:19:24 <limburgher> geppetto: and should be.
16:19:31 <tibbs|w> geppetto: Fortunately we've given up worrying about coordination over redhat-rpm-config.
16:19:40 <tibbs|w> Just add the deps on your macro package and leave the rest alone.
16:19:50 <geppetto> limburgher: Kind of ... Panu would often complain about the lead times for new rpm features.
16:20:16 <tibbs|w> It means you get a load of tiny packages in the buildroot but.. .meh.  We can consolidate later if it becomes a problem. (I came around to that view eventually.)
16:20:28 <tibbs|w> The best way to handle rpm is to work around it.
16:20:43 <limburgher> geppetto: Yeah. . .it's a tough place to be.  It needs to move, but carefully.
16:20:43 * geppetto nods ... as long as it's in the dir. by default, I'm happy :)
16:20:46 <tibbs|w> If it breaks everything breaks so it's better not to break it.
16:21:12 <limburgher> tibbs|w: just like the weak nuclear force.
16:21:20 <geppetto> limburgher: ha
16:21:58 <tibbs|w> So I'll look at that one pull reques5t for the macros, convert them into the proper format for stuffing in /usr/lib/rpm/macros, and go.
16:22:08 <geppetto> sounds great
16:22:12 <tibbs|w> But that will take a package review, so I'll ping someone.
16:22:50 <geppetto> yeh, I think I can do those  ... so feel free to ping me
16:23:02 <tibbs|w> Sadly, the form used for %include'ing in a spec is not the form you use for a file in the macros directory.
16:23:07 <tibbs|w> And there's the door....
16:24:37 <tibbs|w> Back.
16:24:56 <geppetto> Cool ... anything more about 610?
16:25:21 <geppetto> #topic #558  Application/Library distinction and package
16:25:25 <geppetto> .fpc 558
16:25:26 <zodbot> geppetto: #558 (Application/Library distinction and package splitting) – fpc - https://fedorahosted.org/fpc/ticket/558
16:25:32 <geppetto> Can we just close this out?
16:25:41 <tibbs|w> Actually, it's a mess.
16:25:55 <tibbs|w> There are really a pile of different issues in there.
16:26:20 <tibbs|w> First, I need to write something about the difference between a module/plugin/whatever and an application.
16:26:41 <tibbs|w> And when you can and must split them.
16:27:03 <tibbs|w> But there's also something about the python guidelines in there.
16:27:09 <tibbs|w> At least I think it's that ticket.
16:27:29 <tibbs|w> And someone keeps PMing me at home about it and I'm never around to talk to him.
16:27:41 <geppetto> :(
16:27:56 <tibbs|w> So, first off, I do that draft.
16:28:04 <geppetto> Ok
16:28:24 <tibbs|w> Secondly, I/we look at the ticket, figure out if there are other issues there, and split them out to make sure they're addressed.
16:28:26 <geppetto> #action tibbs Draft change for difference between module/plugin/whatever and an application.
16:29:02 <tibbs|w> I welcome anyone else actually looking at the ticket.  I've really lost the context on what people aren't liking about the current python guidelines.
16:29:45 <tibbs|w> I vaguely recall that the presence of a certain section which applies in a rather specific case is confusing people into thinking that it applies in general.  But that's about all I can remember right now.
16:30:17 * geppetto nods ... I thought orionp was looking at it
16:30:25 <geppetto> But I don't remember anything specific like that
16:30:43 <tibbs|w> We
16:30:50 <tibbs|w> were doing a whole lot with pythin.
16:30:57 <tibbs|w> And then I guess I lost the plot.
16:31:13 <tibbs|w> (space and enter are directly next to each other on my keyboard, oops)
16:31:15 <orionp> I haven't been doing anything recently - but really should be back to it
16:31:27 <tibbs|w> orionp: Right, you and me both.
16:31:51 <tibbs|w> I actually understand more about macros now so I should try to jump back onto those while I'm on vacation.
16:31:58 <tibbs|w> Have to do something, after all.
16:32:24 <tibbs|w> BTW, there's a F25 feature for doing automatic python provides.
16:32:41 <tibbs|w> Which is great, but some coordination with us might be good.
16:32:57 <tibbs|w> They do have a line item to provide a draft.
16:33:22 <geppetto> cool
16:33:26 <geppetto> who owns that?
16:34:04 <tibbs|w> torsava and churchyard
16:34:25 <tibbs|w> It's a long time coming, that's for sure.
16:35:03 <tibbs|w> It should be completely automatic using the usual dep generation system.
16:35:14 <tibbs|w> The question is whether it interacts with %python_provides at all.
16:35:45 <tibbs|w> Not enough info to tell at this point.  I asked them to open an FPC ticket immediately instead of after they have a draft and everything is set in stone.
16:35:50 <tibbs|w> I'm sure we can accommodate.
16:36:05 * geppetto nods
16:36:11 <geppetto> when did you ask them that?
16:36:13 <tibbs|w> https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
16:36:20 <tibbs|w> Just now, in a reply on devel@.
16:36:40 <geppetto> ok, cool
16:37:21 <tibbs|w> They're also doing Requires:, though the feature title doesn't suggest that.
16:37:36 <tibbs|w> However, the metadata is rarely complete, so it will be something you have to check manually.
16:38:24 <tibbs|w> It could have the potential to make a mess, but the dependency format "pythonX.Ydist(CANONICAL_NAME)" means it won't conflict with any existing dependency.
16:39:20 <tibbs|w> It seems this is an upstream RPM thing, so we don't really have much choice.
16:39:45 <tibbs|w> But on the surface it all seems rational to me.
16:44:01 <tibbs|w> (I'm done, btw, but perhaps folks are reading)
16:48:17 <tibbs|w> Did I lag out?
16:48:57 <limburgher> No.
16:51:27 <orionp> I don't have anything to add
16:51:44 <geppetto> no, nothing else to add either
16:51:51 <geppetto> #topic Open Floor
16:52:06 <geppetto> Antyhing anyone wnat sto bring up before we don't see tibbs for a bit?
16:52:40 <tibbs|w> Over time I am going to go through and change things to "SHOULD" or "MUST" throughout the guidelines.
16:52:54 <tibbs|w> I did that for the GAP packaging stuff when I imported it.
16:53:14 <geppetto> ok
16:53:29 <tibbs|w> Eventually I guess we'll want to add "MAY", but I'm not going to worry about it now.
16:53:30 <geppetto> just adding one of those words where there is none?
16:53:57 <geppetto> MAY is like a SHOULD that you are freeer to ignore?
16:54:29 <tibbs|w> pretty much.  I think it's basically there to provide a suggestion instead of some level of requirement.
16:55:38 <tibbs|w> But if anyone sees any instances where that needs doing, I would suggest just doing it.
16:56:02 <tibbs|w> If questions arise as to whether some existing language translates to SHOULD or MUST, just open a ticket.
16:56:11 * geppetto nods
16:57:29 <racor> FYI: I am likely to be missing the next 3-4 meetings due to vacation.
16:58:06 <tibbs|w> Me, too.
16:58:17 <geppetto> #info racor and tibbs might not be around the next 4-5 meetings or so
16:58:19 <tibbs|w> I will try to be there if the timing works out.
16:58:52 <tibbs|w> It's basically just finding time in the evening.  I think the first Thursday will be a rest/jet lag day anyway.
17:00:25 <racor> Me, too - I'll likely be available in general, but I can't promise to be able to join the meetings
17:00:35 * geppetto nods
17:00:40 <tibbs|w> I guess I'm done.  Will try to clear my FPC todo list before I leave.
17:01:07 <tibbs|w> If anyone notices anything I've promised but not delivered, please feel free to ping me.  I should be writing all of these things down somewhere.
17:01:18 <racor> I have another (minor) topic
17:01:24 <racor> Did anybody try an f24->f23 downgrade?
17:01:33 <racor> I tried and ran into phyton->phython2 troubles.
17:01:40 <geppetto> is that supposed to work?
17:01:45 <racor> which I presume to be originate from improper Obsolete/Provides
17:02:24 <racor> geppetto: I don't know. It worked out miserable, mostly due to dnf not getting it right on many cases.
17:03:09 <tibbs|w> Python is a mess in general.
17:03:16 * geppetto nods ... my guess is not, unlike dnf devs wishes it's not magic and I dont' think anyone has tested downgrades
17:03:32 <tibbs|w> I don't think anyone would expect a downgrade to actually work.
17:04:04 <tibbs|w> I don't know if there's enough information in the dependencies for it to be reliable.
17:04:09 <racor> my point here is just one detail: I believe the python->python2 module renamer missed some Obsolete/Provides.
17:04:40 <tibbs|w> It's possible, but... do you mean the packager?  Or is there some automated process for renaming those packages?
17:04:53 <tibbs|w> I guess a couple of examples would be good.
17:05:31 <geppetto> If you know what needs to be changed then feel free to message the maintainers with the prco data to change
17:05:32 <racor> i believe this to be a systematic packaging/packager bug.
17:06:01 <geppetto> You want to do a draft about how to do prco data so downgrades will work better?
17:06:19 <tibbs|w> Well, better yet, our our existing guidelines not correct?
17:06:26 <tibbs|w> Or are people just screwing them up?>
17:07:09 <geppetto> I'd assume the guidelines don't consider it, and packagers don't test for it
17:08:12 <racor> Sorry, I  haven't checked details, yet, I was simply fighting with downgrading not being able to replace python2 modules with python* modules
17:08:37 <racor> in general, this indicates a missing Obsoletes/Provides
17:09:04 <limburgher> Ick.
17:11:30 <geppetto> Well you can't easily do obsoletes for downgrades without breaking upgrades
17:11:40 <geppetto> So I'm not sure it's easy to fix
17:11:56 <tibbs|w> I figure the ex-yum guy would know.
17:12:17 <geppetto> Also you'd need to alter old packages, which isn't possible without a time lord to help :)
17:12:47 <geppetto> There were discussions a long time ago now about having prco like data in repo metadata, so you could do stuff like this
17:13:31 <tibbs|w> dnf could do it with the history information it has, I guess, but I don't think there's anything we (FPC) can do about it.  Nor do I think we should burden maintainers with having to worry about downgrades.
17:13:39 <geppetto> But you'd need a bunch of buyin, and dnf upgrades are only just supported getting someone to sign off on downgrades will probably be really hard
17:13:51 <tibbs|w> Use LVM and take a snapshot (and tar off /boot) before upgrading if you're going to want to downgrade.
17:14:10 <geppetto> tibbs: Yeh, yum should work with just "yum history undo" so presumably dnf can too (or that's a bug)
17:14:25 <geppetto> I assume racor needed to use something more like distro-sync though
17:14:36 <geppetto> which is harder for the obsoletes case
17:15:08 <geppetto> tibbs: Everyone loves FS snapshots ... and next decade when btrfs is finished it might even be usable ;)
17:15:26 <racor> geppetto: distro-sync didn't work better, either.
17:15:35 <tibbs|w> I'm paying more attention to bcachefs.  Too bad the guy can't get any money to work on it.
17:16:51 <tibbs|w> Oh, there was one other ticket.
17:17:01 <tibbs|w> https://fedorahosted.org/fpc/ticket/628
17:17:06 <tibbs|w> The uid for cassandra.
17:17:36 <geppetto> Ahh, that was in needinfo when I looked, I think
17:17:59 <tibbs|w> Yeah, it doesn't automatically go back from needinfo.
17:18:16 <tibbs|w> So unless they do it themselves, someone has to look over them all and switch them back.
17:18:29 <tibbs|w> But he at least does give some kind of useful justification.
17:18:46 <tibbs|w> I'm +1.
17:18:53 <geppetto> #topic #628 Reserve UID/GID for cassandra
17:18:59 <geppetto> .fpc 628
17:19:00 <zodbot> geppetto: #628 (Reserve UID/GID for cassandra) – fpc - https://fedorahosted.org/fpc/ticket/628
17:19:00 <tibbs|w> Even if I do think he's kind of stretching it.
17:19:07 <geppetto> I'm happy to +1 too
17:19:33 <geppetto> racor: mbooth_ limburgher orionp: vote?
17:20:08 <orionp> I'm fine. +1
17:20:38 <mbooth_> Sure, +1
17:20:45 <racor> -1  taking care about nfs is job of the admin, not ours
17:20:48 <limburgher> +1
17:22:29 <geppetto> racor: what about the docker part?
17:24:29 <geppetto> #action  Reserve UID/GID for cassandra (+1:5, 0:0, -1:0)
17:24:50 <geppetto> Ok, going to close in a minute unless anyone has anything they need to discuss
17:24:56 <tibbs|w> Should be -1:1
17:25:10 <tibbs|w> Just a note:
17:25:28 <tibbs|w> Last night for some reason I started to split the huge naming guidelines page
17:25:30 <racor> I've never used docker - But my gut feeling is, if we accept this, we soon be back to those days, when everybody claimed to be "in dire need of fixe uid/gids"
17:25:38 <geppetto> #undo
17:25:38 <zodbot> Removing item from minutes: ACTION by geppetto at 17:24:29 : Reserve UID/GID for cassandra (+1:5, 0:0, -1:0)
17:25:41 <tibbs|w> into a Naming and a Versioning page.
17:25:42 <geppetto> #action  Reserve UID/GID for cassandra (+1:5, 0:0, -1:1)
17:25:49 <geppetto> thought I'd done that, sorry racor
17:26:32 <racor> No prob
17:26:38 <tibbs|w> And I'll be working on moving the domain-specific naming stuff to the appropriate domain-specific guidelines.
17:26:56 <tibbs|w> That should cut the page down to size.  I've been annoyed by that for a long time.
17:27:09 <tibbs|w> There will be no content changes, of course, though if I see something I'll say something.
17:27:31 <racor> anyway, my time is up for today, I need to leave now.
17:27:47 <tibbs|w> Yep.  So much to do before I leave.
17:28:53 * geppetto nods
17:28:58 <geppetto> #endmeeting