fedora_cloud_wg
LOGS
17:03:39 <sayan> #startmeeting fedora_cloud_wg
17:03:39 <zodbot> Meeting started Wed Jun 15 17:03:39 2016 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:03:39 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
17:04:02 <dustymabe> sayan++
17:04:02 <zodbot> dustymabe: Karma for sayanchowdhury changed to 9 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:04:03 <sayan> #topic Roll Call
17:04:09 <maxamillion> .hello maxamillion
17:04:09 <dustymabe> .hellomynameis dustymabe
17:04:09 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:04:12 <rtnpro> .fas rtnpro
17:04:12 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:04:15 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:04:39 <maxamillion> how many aliases do we have for that?
17:04:44 <coremodule> .hellomynameis coremodule
17:04:45 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
17:04:46 <sayan> .hello sayanchowdhury
17:04:48 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:05:11 <tflink> .hello tflink
17:05:12 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
17:05:24 <dustymabe> maxamillion: not enough :)
17:06:45 <jberkus> ok, here now
17:06:50 <jberkus> .hello jberkus
17:06:51 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:07:47 <sayan> #chair maxamillion rtnpro dustymabe tflink coremodule
17:07:47 <zodbot> Current chairs: coremodule dustymabe maxamillion rtnpro sayan tflink
17:07:50 <dustymabe> sjennings: we are at roll call
17:08:20 <sjennings> dustymabe: ack
17:08:38 <dustymabe> sjennings: try typing .hello sjennings
17:08:47 <sjennings> .hello sjennings
17:08:48 <zodbot> sjennings: Sorry, but you don't exist
17:08:52 <dustymabe> darn
17:08:54 <gholms> Heh
17:09:01 <dustymabe> sjennings: do you have a FAS account?
17:09:05 <dustymabe> it should look like this
17:09:11 <dustymabe> .hello dustymabe
17:09:12 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:09:26 <dustymabe> oh well, we'll set that up later :)
17:09:29 <sjennings> .hello sjenning
17:09:30 <zodbot> sjennings: sjenning 'Seth Jennings' <spartacus06@gmail.com>
17:09:36 <dustymabe> there you are!
17:09:40 <sjennings> :)
17:10:10 <dustymabe> sayan want to move us to next topic?
17:10:20 <sayan> #chair jberkus sjennings
17:10:20 <zodbot> Current chairs: coremodule dustymabe jberkus maxamillion rtnpro sayan sjennings tflink
17:10:34 <sayan> #topic Action items from last meeting
17:11:14 <sayan> * scollier to create ticket for migrating docker hub to org
17:11:14 <sayan> * jzb to follow up on getting fedora cloud images onto Azure and other providers
17:11:14 <sayan> * jzb take another run at legal on azure cloud issue
17:11:15 <sayan> * jzb Follow up on Ticket 143 before Cloud FAD.
17:11:26 <scollier> .hello scollier
17:11:28 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:11:33 <sayan> #topic scollier to create ticket for migrating docker hub to org
17:11:42 <sayan> #chair scollier
17:11:42 <zodbot> Current chairs: coremodule dustymabe jberkus maxamillion rtnpro sayan scollier sjennings tflink
17:11:45 <scollier> sayan, i created that ticket.
17:11:53 <scollier> sayan, that issue can be closed.
17:12:09 <sayan> okay
17:12:30 <sayan> #topic jzb to follow up on getting fedora cloud images onto Azure and other providers
17:13:07 <sayan> since jzb will be joining late I think we can discuss in open floor or once he joins in?
17:13:13 <scollier> sure
17:13:17 <dustymabe> sayan that sounds reasonable
17:13:26 <dustymabe> scollier: do you mind closing that ticket yourself?
17:13:33 <scollier> dustymabe, i did.
17:13:36 <dustymabe> perfect
17:15:37 <sayan> and same for the other action items too
17:15:55 <sayan> Moving to tickets
17:16:21 * sayan is having some network lag today :(
17:16:29 <sayan> #topic Fedora Cloud FAD (late 2015/early 2016) https://fedorahosted.org/cloud/ticket/115
17:16:45 <sayan> Shall we close this ticket?
17:16:53 <maxamillion> I think so, yes
17:16:58 <dustymabe> sayan I think so - not unless we wanted to add some final information to it first
17:17:07 <dustymabe> ok yeah. let's just close it
17:17:58 <maxamillion> we did a write up for CommOps, maybe the only thing we should do is get some of the action items into tickets so we don't lose track of them
17:18:35 <dustymabe> maxamillion I'm definitely +1 on tickets for action items
17:19:53 <sayan> #action sayan to close the ticket 115
17:20:45 <sayan> #topic Fedora-Dockerfiles examples for Kubernetes https://fedorahosted.org/cloud/ticket/125
17:21:18 <sayan> scollier: ^^
17:21:32 <jberkus> that's mostly me, but I've been busy with atomic host etc.
17:22:02 <maxamillion> jberkus: I hope to have some time today or tomorrow to help with that, I'm stuck in meetings for most of today though
17:23:00 <sayan> anything else or should I move to next ticket ?
17:23:15 <jberkus> next ticket
17:23:21 <sayan> #topic vagrant boxes fixups https://fedorahosted.org/cloud/ticket/136
17:24:11 <scollier> sayan, reading back, sorry.
17:24:18 <dustymabe> is imcleod here today?
17:24:26 <dustymabe> I don't think so
17:24:32 <dustymabe> move to next ticket
17:24:34 <scollier> sayan, they said it all.
17:24:35 <sayan> imcleod isn't here
17:24:48 <sayan> #topic Don't overwrite download location for 2 week atomic images https://fedorahosted.org/cloud/ticket/147
17:25:25 <bowlofeggs> .hello bowlofeggs
17:25:27 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <bowlofeggs@electronsweatshop.com>
17:25:33 <dustymabe> bowlofeggs: \o/
17:25:43 <dustymabe> #chair bowlofeggs
17:25:43 <zodbot> Current chairs: bowlofeggs coremodule dustymabe jberkus maxamillion rtnpro sayan scollier sjennings tflink
17:25:53 <sayan> bowlofeggs: hello :)
17:26:24 <maxamillion> bowlofeggs: welcome!
17:26:32 <bowlofeggs> heyo!
17:26:46 <dustymabe> sayan: for this ticket there were some comments in the ticket, but no progress yet
17:26:50 <dustymabe> until after F24
17:27:59 <sayan> as I am deleting the AMIs again so right now I am retaining all the AMIs for two--week atomic
17:28:19 <dustymabe> sayan: is it possible to just do that for a release?
17:28:21 <sayan> that would increase the cost
17:28:42 <dustymabe> yeah, you are right. unless we used the marketplace right
17:28:49 <dustymabe> I think marketplace AMIs don't cost us anything
17:29:01 <sayan> not sure about the cost there
17:29:02 <dustymabe> so that might be some more incentive for doing that
17:29:13 <dustymabe> ok
17:29:41 <sayan> yes, we can delete the AMIs for a release
17:30:02 * rtnpro wanted to discuss on https://fedorahosted.org/cloud/ticket/160
17:30:28 <dustymabe> rtnpro: maybe in open floor?
17:30:30 <sayan> rtnpro: yes, i'll come to that :)
17:30:38 <rtnpro> ok
17:31:02 <sayan> #topic Container "Packager" Guildelines and Naming Conventions https://fedorahosted.org/cloud/ticket/148
17:31:38 <sayan> maxamillion: ^^
17:32:40 <maxamillion> those were accepted by FESCo, we can close that
17:34:06 <sayan> can you close that ticket?
17:35:21 <maxamillion> sure
17:35:38 <sayan> moving to next ticket
17:35:42 <sayan> #topic Need owner to define basic container smoke testing requirements https://fedorahosted.org/cloud/ticket/151
17:36:00 <maxamillion> we can probably close that one too, we resolved that item at the FAD
17:36:19 <sayan> oh ok
17:36:53 <sayan> moving to next then
17:36:59 <sayan> #topic Fedora Coud Test Day for F24 https://fedorahosted.org/cloud/ticket/152
17:37:24 <jberkus> did anyone write up the smoke testing requirements?
17:37:29 <sayan> This can be close too I think :)
17:37:42 <dustymabe> tflink: ^^
17:37:43 <maxamillion> jberkus: they should be in the etherpad
17:37:56 <dustymabe> I know you and kushal talked quite a bit about this "area"
17:37:57 * maxamillion swears nobody actually read that thing ;)
17:38:38 <tflink> I'm not sure it was actually written up
17:39:05 <maxamillion> alright, we'll leave the ticket open until we have the information formally written somewhere
17:39:38 <dustymabe> tflink: do you mind updating the ticket
17:39:58 <tflink> IIRC, the conversation was more around what was being tested in tunir/autocloud, not so much the smoke testing requirements
17:40:22 <tflink> dustymabe: updating with what? the test day is over
17:40:32 * tflink feels like he's missing something
17:41:09 <dustymabe> oops
17:41:19 <dustymabe> I thought we were on the container smoke testing ticket
17:41:24 <dustymabe> sayan: yes
17:41:25 <maxamillion> dustymabe: we are
17:41:29 <dustymabe> the test day one can be closed
17:41:49 <maxamillion> fine, I'll own the smoke test requirements, assign the ticket to me and I'll add it to my TODO list
17:41:53 <dustymabe> maxamillion: if you look at the last topic
17:42:02 <dustymabe> it's actually the fedora cloud test day for f24
17:42:05 <dustymabe> not smoke testing
17:42:13 <dustymabe> which is why tflink was confused
17:42:29 <maxamillion> o.O;
17:42:39 <maxamillion> *sigh*
17:42:42 <maxamillion> indeed it is
17:42:46 <dustymabe> should we switch gears back to smoke testing
17:42:51 <dustymabe> so you guys can discuss?
17:43:11 <bowlofeggs> i prefer vape-testing…
17:43:49 <maxamillion> just assign the ticket to me, when I find time I'll take it off-meeting and get it resolved and will update the ticket
17:44:22 <dustymabe> maxamillion: ok, i'll assign to you then
17:44:28 <tflink> i think that's mostly settled
17:45:22 * jzb joins quietly
17:45:58 <dustymabe> maxamillion: turns out it's already assigned to you
17:46:11 <dustymabe> ok lets move on
17:46:45 <sayan> Also we close the ticeket regarding Fedora Cloud Test Day..
17:46:57 <dustymabe> sayan yes. will you do that?
17:47:08 <sayan> #topic design, deploy and document Fedora OpenShift Playground (FOSP) https://fedorahosted.org/cloud/ticket/153
17:47:16 <maxamillion> dustymabe: sounds about right :)
17:47:36 <sayan> dustymabe: yes
17:48:12 <sayan> misc: ^^
17:49:55 <dustymabe> misc: doesn't seem to be here
17:50:05 <jzb> I think it's a bit late in the day for misc
17:50:05 <dustymabe> and I don't think we talked about this at the FAD did we?
17:50:08 <jzb> or commute time
17:50:26 <dustymabe> We talked about openshift, but not this thing specifically?
17:50:29 <jzb> dustymabe: we did briefly, but not extensively
17:50:35 <dustymabe> ok
17:50:38 <jzb> I can give a few points of info
17:50:42 <dustymabe> cool
17:50:57 <jzb> 1) we're still in discussion about hardware and actually getting that bought, racked, and stacked
17:51:06 <jzb> 2) jberkus has agreed to be point person for this
17:51:24 <jzb> for purposes of single point of contact, not for doing _all_ the work
17:51:47 <dustymabe> should we assign this ticket to jberkus then?
17:52:06 <jberkus> sure
17:52:07 <jzb> 3) there may be a project (external to RHT) that's spinning up a very large set of nodes for testing things related to k8s
17:52:18 <dustymabe> jzb: CNCF?
17:52:19 <jzb> it's possible we can carve out several nodes for this out of that set of nodes
17:52:39 <jzb> dustymabe: I'm generally non-specific when I'm not sure the public status of things.
17:52:44 <dustymabe> cool
17:52:46 <dustymabe> I figured
17:53:08 <dustymabe> if it is CNCF they have been public about that- i've been on the public calls
17:53:11 <jzb> so - I hope to get some info on that in the not too-distant timeframe
17:53:14 <jzb> dustymabe: oh, OK
17:53:19 <jzb> I wasn't sure :-)
17:53:25 <jzb> I just found out via email
17:53:28 <jzb> anyway
17:53:46 <tflink> what's CNCF?
17:53:53 <dustymabe> Cloud native compute foundation
17:53:58 <tflink> thanks
17:54:01 <dustymabe> ok so we can move on from this ticket
17:54:10 <dustymabe> jzb: do you mind updating and maybe assign to jberkus?
17:54:10 <jzb> I think we can assign the ticket to jberkus and revisit probably before Flock but not until at least a week or two after RHT Summit.
17:54:16 <dustymabe> +1
17:54:25 <jzb> I wish there was a way to "sleep" a ticket
17:54:27 <jzb> dustymabe: yeah
17:54:29 <jzb> can do
17:54:33 <dustymabe> :) me 2
17:54:46 <dustymabe> ctrl-Z
17:54:58 <dustymabe> next!
17:55:55 <sayan> #topic make Fedora Atomic download page clearer https://fedorahosted.org/cloud/ticket/154
17:56:36 <jzb> jberkus: you opened this one, were you taking it on as well?
17:56:42 <sayan> jberkus: ^^
17:56:56 <jberkus> jzb: yes, but it became a dependancy of our other changes as of the FAD
17:57:12 <jzb> jberkus: OK, can you update this one?
17:57:15 <jzb> ticket, I mean
17:57:16 <jberkus> at this point I need to know where we're going with Foosion before I make specific design recommends
17:57:17 <jberkus> yes
17:58:08 <sayan> moving on
17:58:32 <sayan> #topic Decide on post-GA update cadence for various deliverables https://fedorahosted.org/cloud/ticket/155
17:58:43 <maxamillion> jberkus: +1
17:59:16 <jberkus> updated
17:59:56 <maxamillion> I need to drop off of here, I have a call starting now
18:00:11 <maxamillion> thanks all!
18:01:07 <dustymabe> should we just move to open floor?
18:01:12 <dustymabe> I think rtnpro wanted to talk
18:01:35 <rtnpro> dustymabe, yes, regarding https://fedorahosted.org/cloud/ticket/160
18:01:45 <scollier> dustymabe, sayan, i have another call as well. but for open floor, are there notes from the cloud FAD?
18:02:00 <rtnpro> dustymabe, how do we push fedora-motd to upcoming atomic host build?
18:02:11 <dustymabe> scollier: yes
18:02:15 <dustymabe> https://public.etherpad-mozilla.org/p/FedoraCloud-WG-FAD-2016
18:02:19 <dustymabe> ^^ very detailed notes
18:02:24 <scollier> dustymabe, thanks
18:03:04 <dustymabe> rtnpro: once f24 release is out then we'll simply change the ostree to include and the kickstart to enable it
18:03:10 <dustymabe> and ofcoure, test things
18:03:29 <dustymabe> I think that is a problem we can tackle after f24 release and summit is over
18:03:35 <dustymabe> if that is ok with you?
18:03:39 <rtnpro> all the reported issues have been fixed and tested by community folk
18:03:45 <rtnpro> folks*
18:04:01 <rtnpro> thanks to trishnag and jbrooks
18:04:11 <rtnpro> ok
18:04:20 <dustymabe> trishnag++
18:04:20 <zodbot> dustymabe: Karma for trishnag changed to 8 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:04:24 <dustymabe> jbrooks++
18:04:28 <rtnpro> sayan just called up, his network blew up
18:04:34 <dustymabe> oops
18:04:37 <rtnpro> so he's not able to connect
18:04:45 <dustymabe> do we have any other items for open floor?
18:04:55 <coremodule> Is this open floor now?
18:05:07 <rtnpro> coremodule, yes
18:05:35 <sayan> got back terrible uplink
18:06:04 <dustymabe> sayan: welcome
18:06:37 <coremodule> Just want to introduce myself, name's Geoff and I'm pretty new to cloud. Have some background in ARM and QA, but want to get better acquainted with cloud technologies so I'm here to learn and to help with whatever I can. Let me know if I can help in any way, otherwise I'll be working on EC2 and 'testcloud'testing.
18:06:49 <sayan> #topic Need complete Kickstart docs for Atomic Host https://fedorahosted.org/cloud/ticket/15
18:07:32 <sayan> jberkus: anything to be added here?
18:07:39 <dustymabe> sayan :) since we are over schedule on meeting we just went to open floor
18:07:47 <sayan> Ok
18:07:51 <sayan> #topic Open Floor
18:08:04 <dustymabe> coremodule just introduced himself
18:08:23 <dustymabe> coremodule: we are very happy to have you here
18:08:24 <sayan> dustymabe: do I re-action the items for jzb?
18:08:43 <dustymabe> sayan: jzb is here now so he might be able to talk to them
18:08:58 <dustymabe> coremodule: if you ever need anything reach out to us
18:09:03 <dustymabe> do you have any questions now?
18:09:19 <sayan> Something to share I have remove launch permission for bunch of AMIs
18:09:36 <sayan> here is the json - https://github.com/sayanchowdhury/deleteamis/blob/master/gen_lists/modifiedjson_01022016_31052016_15062016.json
18:10:07 <coremodule> Nothing right now, I'm coming up to speed on Amazon and their cloud services and once I get that, I'm going to try out openstack, so when I get there, I'm sure I will.
18:10:09 <sayan> These amis will be deleted after a week
18:10:18 <dustymabe> coremodule: great!
18:10:35 <coremodule> But I'm good for now. Just go easy on me when I ask things that seem second-nature, I'm still learning! :P
18:10:36 <dustymabe> coremodule: any chance you will be at FLOCK or Red Hat summit this year?
18:10:38 <dustymabe> would love to meet you
18:11:19 <coremodule> dustymabe, I'd love to go, it's up to RH at this point, and I think they've closed funding for FLOCK for non-speakers already, but I could be wrong.
18:11:34 <dustymabe> coremodule: ok. we'll catch you next time then
18:11:37 <dustymabe> or maybe at next FAD
18:11:46 <dustymabe> sayan: bring up jzbs action items
18:11:54 <coremodule> Yes, let's see what happens. I'll be around on IRC in the meantime.
18:12:44 <sayan> * jzb to follow up on getting fedora cloud images onto Azure and other providers
18:12:46 <sayan> * jzb take another run at legal on azure cloud issue
18:12:48 <sayan> * jzb Follow up on Ticket 143 before Cloud FAD.
18:13:21 <dustymabe> jzb: here? otherwise we'll re-action in t-minus 60 seconds
18:13:33 <jzb> dustymabe: here-ish
18:14:07 <jzb> I'm going to close 143
18:14:16 <jzb> and the other two need to re-action
18:14:25 <dustymabe> #action jzb to follow up on getting fedora cloud images onto Azure and other providers
18:14:34 <dustymabe> #action jzb take another run at legal on azure cloud issue
18:14:41 <dustymabe> cool. lets end this meeting
18:14:47 <dustymabe> sayan: want to do the honors :?
18:14:48 <sayan> cool
18:15:01 <sayan> #endmeeting