fedora-qadevel
LOGS
14:00:33 <tflink> #startmeeting fedora-qadevel
14:00:33 <zodbot> Meeting started Mon May 30 14:00:33 2016 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:33 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:00:34 <tflink> #meetingname fedora-qadevel
14:00:34 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:00:34 <tflink> #topic Roll Call
14:00:45 * mkrizek is here
14:00:49 <tflink> Who all's around for the fun of a qadevel meeting?
14:01:44 * jskladan is here
14:02:07 <tflink> welcome, welcome
14:03:23 <tflink> is it just the 3 of us today?
14:03:32 * tflink knows that kamil won't be here
14:03:48 <jskladan> seems like it garretraziel said he'll come, but he's probably still on the way
14:04:58 <tflink> ok
14:06:21 <tflink> let's get started, I guess
14:06:37 <tflink> this seems like an awful lot of process for just 3 of us, though :-/
14:06:46 <tflink> at least we'll have record of accomplishments :)
14:06:48 <jskladan> :D
14:06:58 <tflink> #topic Announcements and Information
14:07:17 <tflink> #info newest libtaskotron, resultsdb, task-abicheck, task-dockerautotest deployed to stg, prod - mkrizek
14:07:17 <tflink> #info resultsdb_api package is in Fedora - mkrizek
14:07:17 <tflink> #info task-libabigail renamed to task-abicheck
14:07:17 <tflink> #info task-abicheck now reports a single result per item, not split by arch - kparal
14:07:17 <tflink> #link https://github.com/sinnykumari/task-libabigail/pull/4
14:07:18 <tflink> #info libtaskotron is now correctly updated on minion even when the cache is outdated and an older package is already installed - kparal
14:07:21 <tflink> #link https://phab.qadevel.cloud.fedoraproject.org/T798
14:07:23 <tflink> #info koji directive and koji utils can now exclude a specific arch from downloading (to be used by task-abicheck) - kparal
14:07:26 <tflink> #link https://phab.qadevel.cloud.fedoraproject.org/D857
14:07:28 <tflink> #info openQA: we have officially first test on ARM - initial-setup test - jsedlak
14:07:53 <tflink> any questions, comments?
14:08:21 <jskladan> none here
14:08:24 <mkrizek> not here
14:08:30 <garretraziel> none
14:08:43 * garretraziel greets everyone
14:09:03 <tflink> mkrizek: are you still working on that blog post about task-abicheck and task-dockerautotest?
14:09:22 <mkrizek> tflink: yes, will post tomorrow
14:09:36 <tflink> mkrizek: cool, just wanting to make sure something gets written
14:09:45 * tflink wonders if we should post to devel@ as well
14:09:58 <tflink> not sure how many devel@ folks watch fedora planet
14:10:16 <mkrizek> sounds like a good idea to me
14:10:43 <jskladan> I do, but quite irregularly, so +1 for posting to devel
14:11:12 <tflink> mkrizek: you want an action for this or should I take it?
14:11:19 <mkrizek> tflink: does just sending a link there work?
14:11:38 <tflink> I would tailor it a bit more for a different audience
14:11:53 <tflink> and write at least some of it out
14:12:13 <mkrizek> ok, I can do it
14:13:20 <tflink> mention that it's just informative right now, there are some packages which we aren't running due to memory and others due to human bandwidth, shoutout to the libabigail folks and ask for folks to report issues they find
14:13:23 <tflink> etc.
14:13:31 <tflink> not sure what you were planning to put in the blog post
14:14:10 <tflink> #action mkrizek to write blog post and devel@ post about the new deployment changes from friday
14:14:20 <tflink> which reminds me, I should chair folks
14:14:27 <tflink> #chair mkrizek jskladan garretraziel
14:14:27 <zodbot> Current chairs: garretraziel jskladan mkrizek tflink
14:14:40 <garretraziel> mkrizek: if you'll want to help with task-dockerautotest part, just say so
14:14:47 <tflink> ok, any more questions, coments?
14:14:50 <mkrizek> I was planning to keep it short, just a note that we run those checks and that the checks are more like informative, like you said
14:15:17 <tflink> mkrizek: i think you can be a bit more expansive, this is a pretty big deal in my mind
14:15:29 <tflink> abi checking has been on the wish list for how many years?
14:16:16 <mkrizek> as long as I can remember :)
14:16:52 <tflink> longer than I've been around, definitely
14:17:45 <tflink> anyhow, if there are no more questions/comments, we can move on
14:18:02 * tflink looks at the remaining topics
14:18:27 <tflink> jskladan: do you think that the base image question can be tabled for another week?
14:18:47 <jskladan> tflink: sure
14:19:19 <tflink> that seems like a topic that kparal might want to participate in and may have some good input
14:19:56 <tflink> docker testing is a little silly without lbrabec
14:20:04 <tflink> which leaves us with
14:20:08 <tflink> #topic Packaging
14:20:15 <tflink> everyone's favorite pastime :)
14:20:30 <mkrizek> I am planning to send taskotron-trigger and libtaskotron for review this week
14:20:35 <tflink> cool
14:20:48 <mkrizek> I am waiting for resultsdb_api to be pushed to stable before sending libtaskotron for review though
14:21:01 <tflink> #info taskotron-trigger and libtaskotron will likely be submitted for review this week
14:21:15 <tflink> #info testing, karma on resultsdb_api update is needed
14:21:38 <mkrizek> note that the package is named 'python-resultsdb_api'
14:21:44 <tflink> #undo
14:21:44 <zodbot> Removing item from minutes: INFO by tflink at 14:21:15 : testing, karma on resultsdb_api update is needed
14:21:51 <tflink> #info testing, karma on python-resultsdb_api update is needed
14:21:54 * tflink forgot about that
14:22:22 <tflink> i suspect that everything is going to have the python- prefix
14:22:41 <mkrizek> hm, isn't it just for libraries?
14:22:55 <mkrizek> or API's
14:23:03 <tflink> not sure, it's been a little while since I was looking at the specifics of package naming
14:23:23 <mkrizek> we'll see
14:23:44 <tflink> on a barely related note, is there a ticket filed to make resultsdb_api python3 capable?
14:23:54 <mkrizek> I don't think so
14:24:17 * tflink has been burned by that more than once, keeps forgetting that it's py2 only
14:25:29 <tflink> mkrizek: is there anything you want/need help with?
14:25:45 * tflink saw the trigger review, planning to get to that after the meeting
14:25:58 <mkrizek> just the review I guess
14:26:15 <mkrizek> and then finding a package reviewer :)
14:27:09 <tflink> that shouldn't be too bad, several people said that they'd be willing to help out with reviews
14:27:15 <mkrizek> cool
14:27:21 <tflink> otherwise we can do swap requests on devel@
14:28:13 <tflink> anything else here?
14:28:54 * tflink assumes not, moving on
14:28:57 <tflink> #topic Tasking
14:29:02 <tflink> is anyone in need of stuff to do?
14:29:33 * mkrizek has stuff to do
14:29:49 <jskladan> I will be, most probably, later this week. I've looked at plannig, and it seems like most of the tasks are infrastructure/packaging related
14:30:16 <jskladan> what's the best to focus on, right now?
14:33:14 <tflink> jskladan: are you a packager?
14:33:22 <jskladan> tflink: not that I know
14:35:14 <tflink> I would say documentation and getting some examples together for docker image checks and package specific checks
14:35:22 <tflink> as fun as that is :)
14:35:52 <jskladan> OK, I'll get together with lbrabec, and we'll put together the docker examples
14:36:32 * tflink put "file more tickets on docker image testing, documentation" on his todo list
14:36:33 <garretraziel> tflink: I had packaged some packages
14:36:46 <garretraziel> so if you need review or something...
14:36:57 <tflink> garretraziel: if you have the cycles, I suspect that mkrizek would appreciate the help :)
14:37:13 <garretraziel> ok
14:37:31 <mkrizek> there are two or three packages left to send for review
14:37:46 <tflink> that being said, I'm gonna have to get reviews for phabricator at some point in the not-to-distant future
14:37:46 <mkrizek> execdb, resultsdb and resultsdb_frontend
14:39:37 <tflink> feel free to poke me if you're looking for a task, or just take something off of the "next tasks" list in https://phab.qadevel.cloud.fedoraproject.org/project/view/28/
14:39:51 <tflink> which brings us to
14:39:55 <tflink> #topic Open Floor
14:40:05 <tflink> any other topics to discuss?
14:40:44 <mkrizek> not here
14:41:01 <jskladan> none
14:41:18 * tflink didn't think the meeting was going to take this long :-/
14:41:32 <tflink> at least we're ~ 20 minutes early and IIRC, no qa meeting today
14:41:49 * tflink lights a very short fuse
14:42:57 <tflink> Thanks for coming, everyone
14:43:02 * tflink will send out minutes shortly
14:43:05 <tflink> #endmeeting