fpc
LOGS
16:03:54 <geppetto> #startmeeting fpc
16:03:54 <zodbot> Meeting started Thu May 12 16:03:54 2016 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:03:54 <zodbot> The meeting name has been set to 'fpc'
16:03:54 <geppetto> #meetingname fpc
16:03:54 <zodbot> The meeting name has been set to 'fpc'
16:03:54 <geppetto> #topic Roll Call
16:04:08 <geppetto> bah, other meeting was way over again
16:05:14 <tibbs|w> Howdy.
16:05:19 <Rathann|Mobile> o/
16:05:24 <racor> Hi
16:06:03 <geppetto> #chair tibbs
16:06:03 <zodbot> Current chairs: geppetto tibbs
16:06:05 <geppetto> #chair Rathann|Mobile
16:06:05 <zodbot> Current chairs: Rathann|Mobile geppetto tibbs
16:06:09 <geppetto> #chair racor
16:06:09 <zodbot> Current chairs: Rathann|Mobile geppetto racor tibbs
16:06:31 <mbooth> Hey
16:06:41 <orionp> hello
16:06:43 <geppetto> #chair mbooth
16:06:43 <zodbot> Current chairs: Rathann|Mobile geppetto mbooth racor tibbs
16:06:45 <geppetto> #chair orionp
16:06:45 <zodbot> Current chairs: Rathann|Mobile geppetto mbooth orionp racor tibbs
16:09:48 * tomspur is here, but I might leave early again...
16:09:56 <geppetto> #chair tomspur
16:09:56 <zodbot> Current chairs: Rathann|Mobile geppetto mbooth orionp racor tibbs tomspur
16:10:08 <geppetto> Ok, that's 6 … let's see what happens.
16:10:25 <geppetto> #topic Schedule
16:10:29 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/LSNMDKQ7T35KHDW4UNNK5WFAFR2YPXDB/
16:10:40 <geppetto> #topic #623 FHS 3.0 (from 2015) DOES now mention libexecdir and /run
16:10:45 <geppetto> .fpc 623
16:10:47 <zodbot> geppetto: #623 (FHS 3.0 (from 2015) DOES now mention libexecdir and /run) – fpc - https://fedorahosted.org/fpc/ticket/623
16:11:32 <tibbs|w> We should definitely update to reflect reality.
16:12:02 <geppetto> yeh, the change seemed fine to me
16:12:07 <tibbs|w> Unfortunately the draft isn't diffable. We can't see what was changed.
16:12:30 <tibbs|w> I mean, we can do a visual comparison.
16:13:04 <geppetto> the only thing I was slightly worrid about was that AFAIK we don't have anyone on FHS … and not good things had been said about it in the past, so how much do we want to point to it?
16:13:08 * geppetto nods
16:13:40 <orionp> I'd prefer a non-versioned link, perhaps http://refspecs.linuxfoundation.org/fhs.shtml  ?
16:14:27 <geppetto> seems fine to me
16:14:37 <Rathann|Mobile> +1 and we can do s/unlike previous versions/starting from version 3.0/ in the Libexecdir section
16:14:58 <Rathann|Mobile> either way, I'm +1
16:15:29 <orionp> Other than that I'm +1
16:15:41 <tibbs|w> I wonder, can we just say that we follow FHS and not say much else?
16:16:10 <tibbs|w> At least, do we really still need the libexecdir section?
16:16:21 <Rathann|Mobile> probably not
16:16:27 <racor> tibbs|w: I don't think we can
16:16:40 <Rathann|Mobile> but the /usr/target mention should stay
16:17:01 <tibbs|w> Yes, so /usr/target needs to be there.
16:17:25 <tibbs|w> Did FHS 3 clear up the issue in the admon|note block?
16:17:34 <tibbs|w> "Some interpretations of the FHS say...."
16:17:52 <racor> tibbs|w: Too much of the FHS is optional, which IMO means we should "fill" with more specific contents
16:18:11 <tibbs|w> But I'm just asking about the text as presented.
16:18:32 <orionp> "Distributions should not create new directories in the root hierarchy without extremely careful consideration of the consequences including for application portability."
16:19:12 <orionp> "Large software packages must not use a direct subdirectory under the /usr hierarchy."
16:19:55 <tibbs|w> https://fedoraproject.org/wiki/PackagingDrafts/Filesystem_Hierarchy_Standard_Version_3.0_%282015%29 removes the version-specific link and the libexec section.
16:20:27 <Rathann|Mobile> +1
16:20:38 <tibbs|w> More edits in progress.
16:21:55 <tibbs|w> Saved, but someone is at the door.
16:24:28 <orionp> Seems good to me
16:24:31 <mbooth> Not this? "Fedora does not allow new directories under / or /usr without FPC approval."
16:24:48 <mbooth> Did you intentionally lose the ban on new dirs in the root?
16:26:10 <tibbs|w> OK, back.
16:26:10 <orionp> Well, the FHS does pretty strongly discourage both (see wording above).  But I'd be fine with "/ or /usr"
16:26:30 <tibbs|w> Does FHS not already ban new dirs in the root?
16:26:52 <tibbs|w> I can make it explicit, sure.
16:27:39 <tibbs|w> Edited.  Added "directly" because someone would argue.
16:27:59 <geppetto> :)
16:28:48 <geppetto> seems fine to me
16:29:09 <geppetto> and only slightly worried that the fhs 3.1 will do something stupid we don't like ;)
16:29:53 <tibbs|w> We can make it version-specific if we really want.
16:30:17 <tibbs|w> But... I certainly haven't reviewed 3.0 to see if it does something we don't like.
16:30:23 * geppetto nods
16:30:51 <mbooth> This draft looks fine to me, short and to the point :-)
16:30:52 <mbooth> +1
16:31:04 <geppetto> +1
16:31:40 <tibbs|w> +1
16:31:51 <tomspur> +1
16:32:02 <geppetto> tomspur: orionp: racor: Rathann|Mobile: vote?
16:32:07 <Rathann|Mobile> +1
16:32:14 <orionp> +1
16:32:15 <racor> +1
16:32:29 <geppetto> ok
16:33:05 <geppetto> #action Adopt FHS3, apart from /usr/target and top level dirs. new page from tibbs (+1:7, 0:0, -1:0)
16:33:15 <geppetto> #topic #610 Packaging guidelines: Check upstream tarball signatures
16:33:18 <geppetto> .fpc 610
16:33:21 <zodbot> geppetto: #610 (Packaging guidelines: Check upstream tarball signatures) – fpc - https://fedorahosted.org/fpc/ticket/610
16:33:43 <tibbs|w> Well, I an pretty much done with the macro, modulo people testing it for bugs.
16:34:18 <geppetto> so you want us to vote on putting it in?
16:34:22 <tibbs|w> The last issue in that ticket was only a problem with the sample spec (put BuildArch: in the wrong place), not the macro itself.
16:34:50 * geppetto nods … I didn't expect order to matter that much
16:34:54 <tibbs|w> Well, I don't know who has tested it.  But if we can agree that adding and documenting that macro is the way to go, then we can do that.
16:35:17 <tibbs|w> geppetto: You wouldn't, but BuildArch: can trigger a complete spec reparse which makes for fun.
16:35:36 <geppetto> Ahh
16:36:09 <mbooth> Nuts. That's what you get for peeking behind the curtain
16:36:25 <tibbs|w> I guess I enjoy the pain.
16:37:08 <tibbs|w> In any case, I'm +1 for adding and documenting the %gpg_verify macro.  But I think FPC will want to see a draft before an actual vote.  And another week of testing won't hurt.
16:37:49 <geppetto> Isn't it automatic now … so what would the draft say?
16:38:10 <geppetto> Well, automatic only with %autosetup, I guess … and you need to put the keys and signature in Source
16:38:37 <tibbs|w> Doing this within %autosetup is pretty much another topic.
16:39:41 <tibbs|w> As implemented, it has the potential to break package builds, because it makes signature verification mandatory but has no way to auto-buildrequire gpg2.
16:40:29 <tibbs|w> Well, and the fact that there's no choice but to hang some things on filenames, because un-armored sigs and keys have no file format at all.  They're just binary data with no identifying metadata.
16:41:02 <tibbs|w> So I'll draft up %gpg_verify now and we can discuss %autosetup after I've had a chance to prep every package in Fedora to find breakage.
16:41:10 <geppetto> ok
16:42:38 <tibbs|w> So I'll get to drafting that.
16:43:00 <geppetto> Cool
16:43:03 <geppetto> #topic Open Floor
16:43:07 <geppetto> Anyuthing else?
16:43:16 <tibbs|w> One new thing came in, I think.
16:43:33 <tibbs|w> .fpc 624
16:43:34 <zodbot> tibbs|w: #624 (Drop references to /bin and /sbin) – fpc - https://fedorahosted.org/fpc/ticket/624
16:43:37 <tibbs|w> Looks easy.
16:44:00 <tibbs|w> I think we can just remove that one-line section.
16:44:04 <geppetto> #topic #624 	Drop references to /bin and /sbin
16:44:17 <geppetto> +1
16:44:22 <tibbs|w> +1
16:44:41 <tomspur> +1
16:45:07 * tomspur needs to leave. See you next week
16:45:14 <tibbs|w> We could probably also remove the "Effect of the UsrMove Fedora Feature" section.
16:45:26 <tibbs|w> It's been a done deal for a long time now.
16:45:36 <Rathann|Mobile> +1
16:46:08 <tibbs|w> But maybe not, if the dependency implications haven't been worked out.
16:46:15 <tibbs|w> I don't know if that's still a thing.
16:46:37 <orionp> Deps are still an issue I'm pretty sure
16:46:51 <orionp> +1 to #624
16:47:03 <racor> +1 to #624
16:47:10 <mbooth> +1
16:47:17 <tibbs|w> Still +1.
16:47:30 <tibbs|w> I'll leave the "Effect of the Usermove" section alone.
16:48:16 <geppetto> Ok
16:48:51 <racor> I think, the ""Effects of the UsrMov" have not fully settled ;)
16:49:14 <tibbs|w> I think we've just learned to live with the remaining problems.
16:49:15 <geppetto> #action Drop references to /bin and /sbin not linking to /usr/lib* (+1:7, 0:0, -1:0)
16:49:26 <geppetto> #topic Open Floor
16:49:37 <tibbs|w> There was one other thing which is getting discussion.
16:49:44 <geppetto> yeh?
16:49:58 <tibbs|w> .fpc 558
16:50:00 <zodbot> tibbs|w: #558 (Application/Library distinction and package splitting) – fpc - https://fedorahosted.org/fpc/ticket/558
16:50:12 <tibbs|w> I've lost track of the real issue here.
16:50:39 <tibbs|w> People keep saying the python spec is wrong, but I don't see how it is wrong (modulo a timing bug in setuptools we have to work around in the macros).
16:52:09 <tibbs|w> I think at this point orionp understands the python stuff far better than I do.
16:52:21 <tibbs|w> But if I actually need to change something there, I'm just not sure what it is.
16:53:49 <orionp> I'll try to take a look at this again, but I don't have anything at the moment.  Looks like python people have been doing some work lately..
16:54:14 <tibbs|w> Well, people are complaining and snarking about the guidelines still being wrong.
16:54:43 <tibbs|w> But as far as I can tell, that just stems from confusion about what "python3 as default" really means.
16:54:51 <tibbs|w> That phrasing has been confusing since day 1.
16:55:28 <geppetto> yeh, blame upstream for making a different and incompatible language
16:56:09 <tibbs|w> true, but then blame us for saying "python3 is default" while /usr/bin/python is going to stay python2 for ages.
16:58:44 <tibbs|w> Anyway, I guess I'm just lost there.
16:59:22 <tibbs|w> So *I'll leave it alone.  But if someone knows what the real problem is there, please let me know.
16:59:37 <tibbs|w> I guess I still owe a draft on the difference between an application and a library/module.
17:00:33 <tibbs|w> So, lots of drafting.
17:00:52 <geppetto> :(
17:01:07 <tibbs|w> There are two tickets in writeup waiting on me; one requires that I cook up another macro.  The other requires that I actually push updates to redhat-rpm-config.
17:01:34 <tibbs|w> Those will get written up once the updates worm their ways through the system.
17:02:31 <geppetto> sounds fair
17:02:48 <geppetto> anything else, or I'll close in a couple of minutes?
17:02:59 <tibbs|w> Just keeping everyone apprised of the progress, or lack thereof.
17:03:27 * geppetto nods … lots of updates/progress :)
17:03:51 <tibbs|w> I would really like to clear my list.
17:04:11 <tibbs|w> If I could just finish these two pending package reviews that have been stalled on me forever, I could move on to other fun things.
17:04:12 <geppetto> I've looked at the "macro" behind the gpg_verify stuff … lots of sacrificed chickens there ;)
17:04:26 <tibbs|w> It's not that bad.
17:04:51 * geppetto nods … just lots of work.
17:04:56 <tibbs|w> Lua is just really verbose.
17:05:16 <tibbs|w> There are plenty of WFT moments, though.
17:05:36 <tibbs|w> Like why the first line of lua output doesn't make it into the RPM.
17:05:45 <tibbs|w> But only in some circumstances.
17:06:00 <tibbs|w> There is another thing I cooked up which should be useful, and I need to draft it.
17:06:02 <geppetto> ? :-o
17:06:08 <geppetto> Cool
17:06:27 <tibbs|w> orionp pointed out that you can't use %autosetup if you have conditionally applied patches.
17:06:40 <geppetto> ahh
17:06:52 <orionp> I did?
17:07:02 <tibbs|w> So I cooked up something which removes a patch from autosetup.
17:07:08 <geppetto> :)
17:07:11 <tibbs|w> orionp: I'm wrong, it was gholms.
17:08:01 <tibbs|w> You can do it in plain lua easily enough but you have to number your patches consecutively from 0.
17:08:29 <tibbs|w> https://pagure.io/misc-rpm-macros
17:08:37 * geppetto nods … I looked at that
17:09:28 <geppetto> Ok, time for lunch
17:09:37 <geppetto> #endmeeting