server_working_group_weekly_meeting_(2016-05-10)
LOGS
15:01:40 <danofsatx> #startmeeting Server Working Group Weekly Meeting (2016-05-10)
15:01:40 <zodbot> Meeting started Tue May 10 15:01:40 2016 UTC.  The chair is danofsatx. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:40 <zodbot> The meeting name has been set to 'server_working_group_weekly_meeting_(2016-05-10)'
15:01:55 <danofsatx> #chair danofsatx nirik stefw adamw simi mhayden jds2001 mjwolf hanthana
15:01:55 <zodbot> Current chairs: adamw danofsatx hanthana jds2001 mhayden mjwolf nirik simi stefw
15:02:12 <danofsatx> #topic Agenda
15:02:14 <danofsatx> #info 1. Roll Call
15:02:15 <danofsatx> #info 1. Fedora 24 Beta released
15:02:16 * linuxmodder here
15:02:17 <danofsatx> #info 2. Wiki Gardening
15:02:18 <danofsatx> #info 3. Fedora 25 Ideas
15:02:20 <danofsatx> #topic Roll Call
15:02:22 <linuxmodder> .hello linuxmodder
15:02:22 <danofsatx> .hello dmossor
15:02:38 <hanthana> .hello snavin
15:02:53 <hanthana> .fas snavin
15:02:53 <mjwolf> .hello mjwolf
15:03:02 <linuxmodder> zodbot is  hanging itself  today
15:03:03 <linuxmodder> :(
15:03:13 <danofsatx> ping zodbot
15:03:13 <linuxmodder> hanthana,  its zodbot not you
15:04:41 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
15:05:15 <hanthana> linuxmodder, ok :)
15:05:18 <linuxmodder> 2 mins  lag on zodbot  can someone say  zodbot is  under load
15:05:30 <linuxmodder> or the bw is  one or the other
15:05:36 <danofsatx> nirik just said bunch of stuff is borked due to proxy issue
15:06:40 <zodbot> danofsatx: Something blew up, please try again
15:06:55 <danofsatx> .hello dmossor
15:07:13 * danofsatx waits for the boom
15:08:00 <mhayden> .hello mhayden
15:08:20 <danofsatx> #info zodbot is buried under a proxy.
15:08:52 <zodbot> hanthana: snavin 'Danishka Navin' <danishka@gmail.com>
15:08:55 <zodbot> hanthana: snavin 'Danishka Navin' <danishka@gmail.com>
15:09:15 <danofsatx> anyway, lets see if the meetbot controls still work and carry on...
15:09:28 <danofsatx> #topic Fedora 24 Beta Released
15:09:40 <danofsatx> #link https://fedoramagazine.org/fedora-24-beta-released/
15:09:57 <danofsatx> F24 Beta was released today. Thanks to all the devs and testers that put it together.
15:10:09 <danofsatx> Final testing can be tracked at:
15:10:22 <danofsatx> Final testing can be tracked at:
15:10:28 <danofsatx> #link https://fedoraproject.org/wiki/Test_Results:Fedora_24_Beta_1.6_Server?rd=Test_Results:Current_Server_Test
15:10:30 * linuxmodder is  seeding most of  24 beta
15:10:55 <zodbot> mjwolf: mjwolf 'Michael Wolf' <mjwolf@us.ibm.com>
15:11:04 <danofsatx> The respins seeder group is generally seeding the Betas as of this morning, also.
15:11:17 <danofsatx> At least, linuxmodder and myself are.
15:12:33 <danofsatx> #link https://qa.fedoraproject.org/blockerbugs/milestone/24/final/buglist
15:12:57 <linuxmodder> only x64 tho for me
15:13:15 <danofsatx> ^^ is the current list of Final blockers and Freeze Exceptions. Any assistance with either fixing these or testing the fixes will be greatly appreciated by the QA team.
15:13:49 <linuxmodder> danofsatx,  the full seeder group is southern was first and  nb has  picked up the desktops at least
15:14:12 * linuxmodder looks at  final blockers
15:14:50 <danofsatx> looks like only a realmd and selinux issues are the only ones affecting Server.
15:15:03 <danofsatx> https://bugzilla.redhat.com/show_bug.cgi?id=1330766
15:15:16 <zodbot> danofsatx: dmossor 'Dan Mossor' <danofsatx@gmail.com>
15:15:25 <zodbot> mhayden: mhayden 'Major Hayden' <major@mhtx.net>
15:15:36 <linuxmodder> selinux fun I'll look at that one
15:15:41 <danofsatx> oh, wow...thanks for playing zodbot
15:15:59 <danofsatx> https://bugzilla.redhat.com/show_bug.cgi?id=1314637
15:16:11 <danofsatx> anything else for F24?
15:17:53 <danofsatx> moving on...
15:18:00 <danofsatx> #topic Wiki Gardening
15:18:25 <danofsatx> #link https://fedoraproject.org/wiki/Server
15:19:03 <danofsatx> We have two new members of the WG, mjwolf and hanthana. Y'all need to add yourself to the wiki page. mizmo needs to remove herself ;)
15:19:15 <nb> linuxmodder, huh?
15:19:18 <nb> nb doesn't have a seeder
15:19:27 <hanthana> danofsatx, ok
15:19:43 <mjwolf> danofsatx ok will do
15:19:46 <nb> how does someone join the Server WG?
15:20:51 <danofsatx> nb: Anyone can join the SIG just by attending meetings, following ML, and hanging out in #fedora-server. To become a voting member of the WG, you must be elected to the position.
15:21:00 <linuxmodder> nb,  swore you did
15:21:26 <linuxmodder> nb,  usual fas route :)
15:21:31 <danofsatx> last week, mjwolf and hanthana were elected to replace our dearly departed leader, sgallagh and mizmo
15:22:11 <nb> oh
15:22:17 <sgallagh> /me isn't dead.
15:22:21 <danofsatx> in regards to the Wiki Gardening, as was brought up on the ML, we do need to create a "Joining" page for Fedora Server
15:22:40 <danofsatx> sgallagh: ;)
15:23:28 <danofsatx> Also, in perusing the Fedora Server wiki page, I noticed that it was way out of date. It needs to be updated with current info. Do we have any volunteers?
15:24:16 <linuxmodder> danofsatx, I can add that to my  roundof  docs /wiki edits
15:25:02 <danofsatx> #action linuxmodder to update the Fedora Server wiki page
15:25:24 <danofsatx> #topic Fedora 25 Ideas
15:25:33 <danofsatx> #link https://fedoraproject.org/wiki/Releases/25/Schedule
15:25:38 <linuxmodder> anyone with  specific edits in mind  find me  here or  on the ML with requests /comments
15:25:41 <danofsatx> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/NHG2IWKFMPXKTP3WCMBWQVKZ42WZAWZY/
15:26:15 <danofsatx> So, F24 is in Beta which means our planning work is pretty much done - it's all loose ends from here until release.
15:26:40 <danofsatx> In regards to nirik's recent email, we should start looking ahead to F25 at this point.
15:27:35 <danofsatx> Our major issue is that with sgallagh's reassignment, we no longer have a person dedicated to rolekit. Without someone babysitting it, I fear that it will not progress to where we want it to be.
15:27:42 * danofsatx doesn't have the required skills to do it
15:28:58 <danofsatx> The big thing to come out of the thread is "MOAR ROLES!"
15:29:44 <danofsatx> I know that sgallagh and stefw were working on building a nice API for rolekit so the roles would be extremely easy to create. I, however, do not know the current status of that.
15:30:12 <danofsatx> mattdm wants to have a role in place for "90%" of what people would deploy - the question is, how do we identify that 90%?
15:30:48 <danofsatx> We already had targets for WWW and email servers, and I beleive someone floated the idea of a DHCP/DNS server role
15:31:04 <danofsatx> oh, and a file server role was proposed, also
15:32:03 <hanthana> LDAP/SAMBA ?
15:32:23 <danofsatx> Well, LDAP is taken care of via FreeIPA.
15:32:51 <danofsatx> The file server (as proposed) was to simply set up a samba and (kerberized) nfs server.
15:33:35 <hanthana> danofsatx, shall we run a survey among Fedora (Server) users and find what exactly they need?
15:34:03 <danofsatx> Yes, that would be a good idea.
15:34:23 <danofsatx> linuxmodder: would this be a good idea to push out via Magazine?
15:34:28 <hanthana> we can target it with F24 release if possible
15:34:37 <danofsatx> F25
15:34:38 <linuxmodder> what ?   d/c 'd  briefly
15:34:59 <danofsatx> A survey to discover what roles are desired in Fedora Server
15:35:16 <danofsatx> and you need to get a bouncer ;)
15:35:25 <linuxmodder> ah the rolekit  thing sure blog pointer and  a full mag  artiicle  even
15:35:26 <hanthana> no mean, if we do an early survey we can out better F25
15:36:30 <hanthana> s/no mean/no, I mean
15:36:51 <danofsatx> oh, yes - Change proposals for F25 are due 2016-07-05
15:37:04 <sgallagh> I should also point out that Server is not required to continue using/developing rolekit. For example, maybe the requirements might be better served with something like ansible
15:37:20 <danofsatx> Which means we have roughly 7 weeks to put things together.
15:37:40 <danofsatx> sgallagh: good idea.
15:38:34 <linuxmodder> lost me on the  ansible part
15:38:44 <linuxmodder> using ansible in place of  rolekit ?
15:38:49 <sgallagh> rolekit was originally designed as it was so that it would theoretically be easy to plug into Cockpit.
15:38:56 <danofsatx> #info Server WG should investigate the retirement of rolekit and transition to a configuration management system such as ansible
15:39:07 <hanthana> moreover, we can ask user to tweet with a specific hashtag for those who really lazy to fill survey forms ;-) for example #fedoraserver
15:39:19 <sgallagh> It might be that it's worth investigating alternative approaches (keeping an eye on Cockpit as still being the primary interface for it, if possible)
15:39:59 <sgallagh> Ansible, puppet or OpenShift are all potentially-viable solutions.
15:40:20 <danofsatx> agreed - a GUI interface to deploying roles through Cockpit, using some sort of back end whether it be rolekit or ansible or puppet or chef, is one of our goal.s
15:41:12 <hanthana> +1
15:41:48 <sgallagh> Entirely unrelated to my current responsibilities (I work on OpenShift), we might want to explore that route, if only because Cockpit already has very good support for container cluster management through its Project Atomic work.
15:42:23 <danofsatx> sgallagh: have you ever tried to deploy FreeIPA using ansible or OpenShift?
15:43:06 <sgallagh> danofsatx: I have not (yet)
15:43:13 <danofsatx> roger that.
15:43:22 <sgallagh> Though I know of people who have done the former and people who are attempting the latter.
15:43:34 <danofsatx> is anyone aware of FreeIPA performance as a container?
15:43:46 * danofsatx is thinking of the entropy issue
15:44:08 <sgallagh> danofsatx: What entropy issue exists in a container that wouldn't on the RPM install?
15:44:50 <danofsatx> well, in Virtual Machines we were running into the lack of entropy during the kerberos setup. I'm not sure if that same issue exists with a container.
15:46:28 <hanthana> what if we include spacewalk for those who deploy several nodes?
15:46:51 <hanthana> is it worth?
15:46:54 <danofsatx> hanthana: as a role?
15:47:03 <hanthana> yes
15:47:25 <danofsatx> sure, we can put it out there.
15:47:33 <hanthana> cool
15:50:21 <danofsatx> The other thing that came up on list was oVirt integration. I will admit that I have never successfully deployed oVirt, either on Fedora or CentOS, so I can't speak to the viability of this idea.
15:51:25 <danofsatx> We
15:51:37 <danofsatx> We're almost to the hour mark, and it seems we've lost steam.
15:52:08 <danofsatx> hanthana: can you do the blog post for the survey?
15:52:55 <sgallagh> Sorry, I got pulled away.
15:53:03 <hanthana> ok, I can make a draft though I am not good in writing ;-)
15:53:23 <danofsatx> #action hanthana to write up a blog post survey for roles. linuxmodder and danofsatx to review/edit.
15:53:50 <hanthana> danofsatx, how about the questions?
15:53:56 <danofsatx> I'm awesome at editing - I can't create
15:54:00 <sgallagh> danofsatx: Entropy starvation is always a real issue, but it's no *worse* with a container than a VM (and likely better, since the container host is probably doing a lot more entropy-generation)
15:54:31 <danofsatx> sgallagh: gotchya.
15:55:06 <sgallagh> danofsatx: single-purpose VMs tend to be more vulnerable because they have identical hardware and often identical boot patterns.
15:55:51 <sgallagh> (Which is why the virtio-rng device exists, to feed the VMs from the host's entropy pool, which in turn gathers entropy thanks to the varied activities of all the VMs on it)
15:59:08 <danofsatx> ok, then, we're at 1 hour.
15:59:18 <danofsatx> #topic Open Floor
16:00:43 <danofsatx> going once....
16:00:50 <hanthana> Shall we make available designs for Fedora Server tickers, buttons etc
16:01:24 <danofsatx> hanthana: hmmm, good idea. One that should be taken up with marketing, though
16:01:25 <hanthana> Sonar_Gal, Ambassadors can use them during release parties and other events
16:02:01 <hanthana> I recently created a ticket for 'Powered by Fedora' sticker design
16:02:18 <danofsatx> Already have one - ot
16:02:28 <hanthana> we should market roles available with Fedora server
16:02:34 <hanthana> ok
16:02:43 <danofsatx> it's the case badge sticker
16:04:57 <danofsatx> going thrice.....
16:06:17 <danofsatx> ok, thanks for coming, folks!
16:06:21 <danofsatx> #endmeeting