fedora_cloud_wg
LOGS
17:01:09 <kushal> #startmeeting Fedora Cloud WG
17:01:09 <zodbot> Meeting started Wed Apr 27 17:01:09 2016 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:09 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
17:01:17 <kushal> #topic Roll Call
17:01:23 <jbrooks> .hello jasonbrooks
17:01:24 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:01:44 <jzb> .hellomynameis jzb
17:01:48 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:01:49 <jberkus> .hello jberkus
17:01:50 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:02:01 <kushal> .hellomynameis kushal
17:02:03 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:02:07 <trishnag> .hello trishnag
17:02:08 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:02:33 <rtnpro> .fas rtnpro
17:02:33 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:02:37 <kushal> Okay, I guess people vanished into openstack summit somehow
17:02:55 <jberkus> kushal: Dusty is at a different event
17:02:55 <jzb> I am in a video call at this time as well, so my attention is going to be split
17:03:05 <jzb> I'll try to answer any questions sent my way, though.
17:04:17 <tflink> .hello tflink
17:04:18 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
17:05:48 <maxamillion> .hello maxamillion
17:05:49 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:06:51 <maxamillion> kushal got disconnected, he just ping'd me elsewhere
17:07:04 <tflink> and nobody else is chaired
17:07:16 <maxamillion> ha
17:07:25 <maxamillion> that's *awesome*
17:07:31 <maxamillion> computers! \o/
17:07:53 <kushal> got disconnected
17:07:57 <kushal> Who has the action items from the last meeting?
17:07:59 * kushal can not find the meeting log
17:08:01 <kushal> #chair jberkus jzb tflink maxamillion rtnpro
17:08:01 <zodbot> Current chairs: jberkus jzb kushal maxamillion rtnpro tflink
17:08:08 <maxamillion> mmmmmm ... chairs
17:08:25 <maxamillion> #chair tflink
17:08:25 <zodbot> Current chairs: jberkus jzb kushal maxamillion rtnpro tflink
17:08:29 <kushal> Just in case my network goes down again
17:08:47 <kushal> maxamillion, nothing changed :)
17:08:54 <tflink> maxamillion: any particular reason you thought I needed an additional chair?
17:08:57 <maxamillion> kushal: oh, bah
17:09:01 <tflink> this isn't pro wrestling, you know
17:09:14 <maxamillion> tflink: I missed your nick in when I read it at first, I though kushal skipped you
17:09:16 <jberkus> kushal: looking for minutes online.  they were posted to list ...
17:09:17 <maxamillion> nvm me
17:09:19 * maxamillion needs more coffee
17:09:31 <kushal> #chair nzwulfin
17:09:31 <zodbot> Current chairs: jberkus jzb kushal maxamillion nzwulfin rtnpro tflink
17:09:44 <maxamillion> MOAR CHAIRS
17:09:57 <tflink> http://www.thatawesomeshirt.com/images/get/45/430x550/
17:10:01 <maxamillion> hrmmm... my network connection is doing weird things
17:10:12 <jbrooks> :)
17:10:15 <kushal> Anyway, moving to tickets first
17:10:26 <maxamillion> tflink: +1
17:10:37 <kushal> #topic Fedora Cloud FAD (late 2015/early 2016) https://fedorahosted.org/cloud/ticket/115
17:10:48 <kushal> jberkus, was my update to the page enough?
17:10:55 <jberkus> yes
17:11:23 <jberkus> kushal: just realized that the list apparently ate my posting of the mintues
17:11:48 <kushal> jberkus, no problem. We are moving to tickets.
17:12:03 <kushal> If there is no other update here, we can move to next ticket.
17:12:10 <jberkus> here we are:
17:12:14 * jberkus jzb to create Wiki page for OpenShift work (jberkus,
17:12:15 <jberkus> 17:09:58)
17:12:15 <jberkus> action items from last week (jberkus, 17:11:16)
17:12:15 * jberkus jberkus to create Kubernetes examples for Fedora.
17:12:16 <jberkus> (jberkus, 17:12:15)
17:12:16 * jberkus kushal to update ticket that we are waiting for cloud
17:12:16 <jberkus> base image monthly updates til f24 (dustymabe, 17:15:34)
17:12:16 * jberkus imcleod take ticket 136 on vagrant file fixups
17:12:17 <jberkus> (dustymabe, 17:17:53)
17:12:17 * jberkus goern][ to create ticket for Fedora OpenShift Playground
17:12:18 <jberkus> (FOSP) work (dustymabe, 17:19:16)
17:12:18 <jberkus> open tickets (jberkus, 17:21:25)
17:12:19 <jberkus> https://fedorahosted.org/cloud/report/9 (jberkus, 17:21:38)
17:12:20 <jberkus> https://fedoraproject.org/wiki/FAD_Cloud_WG_2016 (jberkus, 17:23:11)
17:12:20 * jberkus jberkus and dustymabe to submit FAD application
17:12:21 <jberkus> (jberkus, 17:27:19)
17:12:39 <kushal> #topic action items from last month
17:12:57 <kushal> I have updated the ticket for updated cloud base image release
17:15:26 <jberkus> oh, feh, I still need to add hotel info
17:15:30 <jberkus> doing right now
17:16:52 <jberkus> kushal, you still with us?
17:16:57 <jberkus> am I still connected?
17:17:03 <jbrooks> yep
17:17:17 <kushal> ANyone else any update?
17:17:24 <jberkus> oh, looks like freenode supressed my posting of the action items
17:17:29 <jberkus> lemme post them one at a time
17:17:48 * jberkus jzb to create Wiki page for OpenShift work (jberkus,
17:17:48 <jberkus> 17:09:58)
17:17:52 <jbrooks> jberkus, we did get a big list of items
17:17:57 <jberkus> ah, ok
17:18:01 <jberkus> NM then
17:21:14 <kushal> okay
17:21:17 <kushal> next meeting
17:21:37 <kushal> #topic Fedora-Dockerfiles examples for Kubernetes https://fedorahosted.org/cloud/ticket/125
17:21:55 <kushal> Anyone any update on this?
17:22:01 <kushal> jberkus, do you know anything?
17:22:14 <jberkus> not at this time.  waiting for some hardware; once I have that I'll start building.  should arrive this week.
17:22:46 <kushal> Okay
17:23:01 <kushal> #topic Don't overwrite download location for 2 week atomic images https://fedorahosted.org/cloud/ticket/147
17:23:18 <kushal> maxamillion, do you know if we have any update on this?
17:24:45 <kushal> Moving to next ticket, if nothing.
17:24:55 <kushal> #topic Container "Packager" Guildelines and Naming Conventions https://fedorahosted.org/cloud/ticket/148
17:25:28 <maxamillion> kushal: sorry, no ... that's still on the TODO list
17:25:37 <kushal> Okay
17:25:43 <kushal> maxamillion, Thanks.
17:26:43 <kushal> They again pointed the docs to us I guess.
17:27:02 <kushal> maxamillion, the next ticket is also on you.
17:27:11 <kushal> #topic Need owner to define basic container smoke testing requirements https://fedorahosted.org/cloud/ticket/151
17:27:31 <kushal> I saw the docker tests you wrote.
17:27:33 <maxamillion> yeah, I've updated those tickets, was looking for feedback
17:27:57 <kushal> maxamillion, I am wondering if we need to do only the testing of the containers, than anything on the host.
17:28:40 <maxamillion> kushal: I think a baseline is first to make sure docker is functional, I don't think we can come up with a baseline for the containers because they will all be different
17:28:51 <kushal> Okay.
17:29:00 <kushal> tflink, ^^^
17:29:19 <tflink> ?
17:29:46 <tflink> maxamillion: even something as simple as "does this container start cleanly?"
17:30:08 <maxamillion> tflink: I think we can come up with guidelines for that but how do you define "starts cleanly"?
17:30:17 <jberkus> tflink: he's got that in there with hello world
17:30:24 <jberkus> might be worth adding a simple webserver container
17:30:29 <jberkus> which would also test networking etc.
17:30:36 <jberkus> not sure how to test that without depending on curl, thoguh
17:30:41 <jberkus> is that OK?
17:30:45 <tflink> jberkus: he said that there was no way to come up with a baseline, though
17:30:54 <kushal> curl is in the system
17:30:54 <tflink> or am I misunderstanding what that baseline might be?
17:31:10 <jberkus> tflink: I'm not talking about testing the containers
17:31:13 <jberkus> in general
17:31:26 <jberkus> I'm taking about picking one webserver container we trust/control
17:31:33 <tflink> then I'm confused, what are we talking about?
17:31:36 <jberkus> and using pull/run/test of that as a test
17:31:49 <kushal> We are supposed to talk about testing containers
17:32:34 <jberkus> ah
17:32:39 <tflink> jberkus: what would that give us that running the docker-autotest suite wouldn't?
17:32:54 <jberkus> tflink: beats me, I was going off maxamillion's page
17:32:58 <maxamillion> what is the docker-autotest suite?
17:33:12 <tflink> it's the upstream unit/integration suite that docker uses
17:33:47 <tflink> http://docker-autotest.readthedocs.org/en/latest/
17:34:12 <maxamillion> alright
17:34:30 <jberkus> so for smoke tests of the containers
17:34:46 <jberkus> we'll need tests written for *each* container
17:35:07 <maxamillion> correct
17:35:10 <jberkus> a good approach would be (1) pull works, (2) run works, (3) some kind of output from the container to match
17:35:26 <jberkus> unfortunately, (2) as well as (3) are going to be container-specific
17:35:37 <tflink> note that I don't pretend to know a whole lot about docker yet
17:35:38 <maxamillion> I was asked to write a baseline of testing for docker, if the goal here is just to use docker-autotest for that and then come up with guidelines, why on earth was this requested of me?
17:35:52 <tflink> maxamillion: two different problems
17:35:59 <maxamillion> tflink: how so?
17:36:05 <tflink> the baseline that I think we're talking about here is for the containers themselves
17:36:20 <tflink> docker-autotest is for testing docker itself as a sanity/smoke test
17:36:34 <tflink> AFAIK, docker-autotest can't be pointed at a specific container
17:36:36 <maxamillion> that was not what I understood the requirement to be, if that was the desire it should have been requested explicitly
17:37:22 <tflink> FWIW, I think that the stuff you've written is not really overlapping what docker-autotest does
17:37:50 <tflink> most of that seems fedora-specific enough that it'd be worth running on top of the upstream suite
17:38:03 <tflink> s/on top of/in addition to
17:38:30 <kushal> I guess we can come back at this after meeting in the #fedora-cloud channel
17:38:57 <tflink> i think that there's some miscommunication going on here
17:39:21 <tflink> but it can be figured out outside the meeting
17:39:42 <kushal> Okay, moving next then
17:39:54 <kushal> #topic Fedora Coud Test Day for F24 https://fedorahosted.org/cloud/ticket/152
17:40:07 <kushal> 2nd May, Monday? How that sounds for the test day?
17:41:05 <kushal> any comments ^^
17:41:22 <tflink> are you coordinating with QA for the test day or doing it on your own?
17:42:00 <jberkus> kushal: WFM
17:42:20 <sayan> sounds good to me
17:42:24 <jbrooks> +1
17:42:26 <kushal> tflink, I am just trying to get the date first, then I will ping QA team for the same.
17:42:35 <tflink> testdays are not usually on mondays
17:42:51 <kushal> tflink, Uh oh, any tips on date then?
17:42:56 <tflink> tuesdays
17:43:05 <kushal> The day of the beta release :)
17:43:12 <kushal> What about 3rd then everyone?
17:43:35 * tflink looks for scheduled f24 test days
17:44:02 <jberkus> do we have FAH for f24 yet?
17:44:11 <kushal> tflink, I never organized one, so any help will be great :)
17:44:12 <tflink> actually, no more f24 test days have been scheduled ... that's odd
17:44:13 <kushal> jberkus, yes
17:45:01 <tflink> https://fedoraproject.org/wiki/QA/Test_Days
17:45:30 <kushal> tflink, I will follow it, thanks :)
17:45:52 <kushal> Moving next then.
17:45:53 <tflink> kushal: let me or pschindl know if you have questions
17:45:59 <kushal> tflink, I will.
17:46:30 <kushal> #topic design, deploy and document Fedora OpenShift Playground (FOSP) https://fedorahosted.org/cloud/ticket/153
17:46:45 <kushal> Any update from anyone?
17:46:47 <kushal> maxamillion, ^^
17:47:24 <jberkus> kushal: that belonged to jzb
17:47:29 <maxamillion> I don't know why I keep getting ping'd on this, I have nothing to do with it
17:47:42 <kushal> maxamillion, I am sorry, I mixed up with another ticket.
17:48:09 <kushal> should be pinging puiterwijk :)
17:48:24 <jzb> https://fedoraproject.org/wiki/Cloud/OpenShift_Origin_Testbed
17:49:00 <kushal> jzb, Thanks :)
17:49:09 <puiterwijk> Note that I'm on PTO. But do you need anything from me?
17:49:24 <puiterwijk> (other person for this is misc )
17:49:45 <kushal> puiterwijk, Nope, just saying loud. Go back to your PTO :)
17:49:50 <puiterwijk> Okay
17:50:08 <kushal> Moving next then.
17:50:21 <kushal> #topic make Fedora Atomic download page clearer https://fedorahosted.org/cloud/ticket/154
17:50:47 <kushal> https://getfedora.org/en/cloud/download/atomic.html is the page in question
17:51:31 <kushal> jberkus, do we expect people to run atomic on the real hardware? The image is built for cloud as I understood.
17:51:45 <jberkus> kushal: there's no ISO?
17:51:48 <jberkus> and indeed we do
17:52:06 <jberkus> kushal: in fact, that's the main use-case
17:52:18 <jberkus> hence having the iso as a sidebar link is emphasizing the wrong thing
17:52:45 <kushal> jberkus, as far as I understood from being the Atomic as the primary target for the cloud group, because we are targeting the cloud users who wants to run containers.
17:53:01 <maxamillion> yeah, we produce and ISO and it's even being testing in OpenQA -> https://openqa.fedoraproject.org/
17:53:08 <maxamillion> I didn't realize it wasn't on the download page
17:53:10 <jberkus> kushal: there's also the people who want to build a cloud using containers
17:53:21 <jberkus> that's the bare metal use case
17:53:35 <kushal> jberkus, I don't mind moving the text to ISO to the main part, but now I am confused about what is the primary target?
17:53:45 <kushal> maxamillion, yes, it is there, but in the sidebar.[
17:53:53 <maxamillion> ohhhh
17:53:55 <maxamillion> didn't even see it
17:53:56 <jberkus> ... in very small prin
17:54:06 <kushal> maxamillion, yes, that has to be fixed for sure.
17:54:23 <jberkus> the other issue is that there are 4 different images to download, and the text is very confusing as to which one the user wants
17:54:42 <kushal> maxamillion, jberkus but our whole view into Atomic is from the cloud prospective (as far as I think).
17:55:10 <jberkus> kushal: containers are one way to build a cloud.  they can be on top of vms, or they can be an *alternative to* VMs
17:55:12 <kushal> jberkus, Oh, it is following the same way we do it for cloud base image.
17:55:38 <kushal> jberkus, yes, but should it be the primary target for the Cloud WG?
17:55:39 <maxamillion> yeah, I think jberkus has a point ... you can run a PaaS cloud with OpenShift on bare metal
17:55:48 <maxamillion> it's not any less cloud than one powered by an IaaS providing VMs
17:56:10 <jberkus> kushal: this is the cloud WG, not the VM WG, no?
17:56:11 * kushal is just asking questions so that his views can be clearer.
17:56:36 <kushal> maxamillion, missed that view completely.
17:56:50 <jbrooks> There's no VM WG, is there?
17:56:50 <kushal> jberkus, the example maxamillion just now gave, makes it perfect sense.
17:56:57 <kushal> jbrooks, nope :)
17:57:03 <jberkus> but you're right that using vm images is an equally popular use case
17:57:23 <jberkus> so we just need to have the ISO in the mainline there
17:57:30 <maxamillion> +1
17:57:32 <jberkus> and distinguish qcow vs. raw better
17:57:56 <kushal> jberkus, please submit the change you want in the ticket, so that we can go ahead and review, and update that.
17:58:09 <kushal> jberkus, do you mind an action item for that?
17:58:17 <jberkus> kushal: I'll need help on the qcow vs. raw question
17:58:31 <jberkus> since *I* don't know all the things each format is used for
17:58:53 <jberkus> added hotel info to the FAD page
17:59:09 <kushal> jberkus, Okay, you can start a thread in the list with that question. I am sure we will get some help.
17:59:12 <kushal> jberkus, Thanks.
17:59:36 <kushal> #action jberkus to start a thread about text change in https://getfedora.org/en/cloud/download/atomic.html for raw vs qcow2
17:59:50 <kushal> #action jberkus To update hotel info for FAD
18:00:09 <kushal> #action kushal to update https://fedorahosted.org/cloud/ticket/154 with details from meeting
18:00:14 <jberkus> kushal: you should close that one, I just did the hotel info
18:00:23 <kushal> Okay, we are over time.
18:00:34 <jberkus> FAD being sent to the council today
18:00:38 <kushal> jberkus, Thank you :)
18:00:41 <kushal> jberkus++
18:00:41 <zodbot> kushal: Karma for jberkus changed to 5 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:00:57 <kushal> If nothing serious I can close this meeting.
18:01:14 <kushal> 11:30pm, and I want some dinner.
18:01:19 <kushal> #endmeeting