cloud_wg
LOGS
17:00:36 <dustymabe> #startmeeting cloud wg
17:00:36 <zodbot> Meeting started Wed Feb 17 17:00:36 2016 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:36 <zodbot> The meeting name has been set to 'cloud_wg'
17:00:40 <maxamillion> #hello maxamillion
17:00:44 <dustymabe> #topic roll call
17:00:47 <smdeep> .hello smdeep
17:00:48 <zodbot> smdeep: smdeep 'Sudeep Mukherjee' <smdeep@gmail.com>
17:00:51 <dustymabe> .hellomynameis dustymabe
17:00:52 <trishnag> .hello trishnag
17:00:52 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:00:54 <maxamillion> .hello maxamillion
17:00:55 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:00:57 <jsmith> .hello jsmith
17:00:58 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:01:01 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
17:01:03 <nzwulfin> .hello mmicene
17:01:04 <jzb> .hellomynameis jzb
17:01:04 <zodbot> nzwulfin: mmicene 'Matt Micene' <nzwulfin@gmail.com>
17:01:06 <jberkus> .hello trishnag
17:01:07 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:01:07 <sayan> .hello sayanchowdhury
17:01:08 <rtnpro> .fas rtnpro
17:01:09 <zodbot> jberkus: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:01:12 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:01:15 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:01:22 <jberkus> .hello jberkus
17:01:23 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:01:41 <kushal> .hellomynameis kushal
17:01:42 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:01:46 <dustymabe> #chair maxamillion jsmith jzb nzwulfin sayan rtnpro jberkus trishnag smdeep
17:01:46 <zodbot> Current chairs: dustymabe jberkus jsmith jzb maxamillion nzwulfin rtnpro sayan smdeep trishnag
17:01:48 <jbrooks> .fas jasonbrooks
17:01:49 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:01:52 <dustymabe> #chair jbrooks
17:01:53 <zodbot> Current chairs: dustymabe jberkus jbrooks jsmith jzb maxamillion nzwulfin rtnpro sayan smdeep trishnag
17:02:31 <dustymabe> #topic previous meeting action items
17:02:39 <dustymabe> jzb to update the F23 retrospective ticket #135 and close it
17:02:41 <dustymabe> kushal to create test details wiki page for updated cloud base image build
17:02:47 * mattdm is also here
17:02:48 * gholms takes a seat in the bleachers
17:02:54 * kushal is almost dead due to many meetings :(
17:02:56 <dustymabe> #chair mattdm gholms
17:02:56 <zodbot> Current chairs: dustymabe gholms jberkus jbrooks jsmith jzb mattdm maxamillion nzwulfin rtnpro sayan smdeep trishnag
17:03:05 * dustymabe forces gholms to play
17:03:08 <kushal> I did not create the page as we were missing the AMI(s).
17:03:20 <dustymabe> kushal: should I carry it forward?
17:03:27 <kushal> Now may be a good time to create the page for a build from this week.
17:03:32 <kushal> dustymabe, Yes, please.
17:03:33 <dustymabe> #action kushal to create test details wiki page for updated cloud base image build
17:04:05 <dustymabe> jzb update from you?
17:04:13 <jzb> dustymabe: ticket closed
17:04:19 * kushal has few things for open floor
17:04:22 <jzb> and y'all should see an update in your inbox.
17:04:25 <dustymabe> cool
17:04:33 <jzb> dustymabe: it does however create more things :-)
17:04:36 <dustymabe> kushal: I think there are a few people with things for open floor
17:04:44 <kushal> dustymabe, :)
17:04:53 <jzb> kushal: you'll see in the response a note about needing a "state of" for testing
17:04:55 <dustymabe> when we get to open floor we will gather topics and go on them one by one
17:05:06 <dustymabe> ok meeting items
17:05:14 <dustymabe> #topic AMI lifetimes (Cloud WG members vote needed)
17:05:16 <jzb> kushal: so - if you're amenable, can we get an email to the cloud@ list giving us a state of testing today?
17:05:20 <dustymabe> #link https://fedorahosted.org/cloud/ticket/99
17:05:29 <kushal> jzb, noted
17:05:32 <dustymabe> I think we can close this one now?
17:05:53 <dustymabe> we are cleaning up any AMIs that aren't official releases?
17:06:14 <sayan> dustymabe, yes
17:06:27 <dustymabe> sayan. do you mind if I action you to close?
17:06:46 <sayan> dustymabe, yes, you can close this
17:07:00 <dustymabe> #action sayan to close ticket 99 - AMI lifetimes (Cloud WG members vote needed)
17:07:07 <dustymabe> ok moving on
17:07:11 <nzwulfin> dustymabe: did we get an official policy landing spot?
17:07:11 <kushal> #action kushal to update the list about state of tests
17:07:27 <dustymabe> #topic make docker archived image get imported with lowercase tag
17:07:34 <dustymabe> #link https://fedorahosted.org/cloud/ticket/131
17:07:49 <dustymabe> Ian is not around :(
17:08:35 <dustymabe> anybody want to volunteer to track down this issue and make sure it is resolved
17:08:45 <dustymabe> that could involve asking Ian, etc.
17:09:03 <jzb> dustymabe: /me raises hand
17:09:17 <maxamillion> I can, I need to sync with him about docker v2 images anyways
17:09:30 <dustymabe> ok which one wants it?
17:09:36 <dustymabe> I'll add an action item
17:09:44 <jzb> I am happy to let maxamillion take it.
17:09:51 <jzb> if he's already syncing on other things.
17:09:53 <maxamillion> yeah, I'll take it
17:10:04 <dustymabe> #action maxamillion to sync with Ian on ticket 131 - make docker archived image get imported with lowercase tag
17:10:08 <dustymabe> ok moving on
17:10:38 <dustymabe> #topic vagrant boxes fixups
17:10:45 <dustymabe> #link https://fedorahosted.org/cloud/ticket/136
17:10:46 <jzb> maxamillion: I assigned the ticket to you.
17:11:16 <dustymabe> kushal: I believe I asked a question in this ticket that you might be able to answer
17:11:25 <jzb> I thought we'd resolved that one?
17:11:30 <jzb> decided it was a wontfix?
17:11:33 <mattdm> I know james shubin (purpleidea) has many, many ideas on how our vagrant boxes could be better
17:11:45 <dustymabe> mattdm: yeah he does
17:11:53 <kushal> wiat
17:11:54 <kushal> wait
17:12:16 <kushal> We can close this one
17:12:18 <maxamillion> jzb: thanks
17:12:28 <jzb> brb
17:12:31 <dustymabe> kushal: did you see my question in the ticket?
17:12:32 <kushal> This is something has to be done in the Vagrantfile level, not for our image creation.
17:12:50 <dustymabe> kushal: but there is an embedded vagrantfile that we could leverage
17:12:54 <dustymabe> one that is included in the image
17:13:03 <kushal> dustymabe, I am not sure if anyone uses that at all
17:13:05 <dustymabe> err.. in the box
17:13:13 <dustymabe> everyone uses it
17:13:22 <kushal> dustymabe, Then may be we can.
17:13:26 <dustymabe> they don't know they use it, but vagrant uses it by default
17:13:35 <dustymabe> from what I understand
17:13:40 <kushal> dustymabe, Okay, I thought people write of their own
17:13:59 <dustymabe> kushal: they write their own, but vagrant also uses the embedded one as well
17:14:04 <kushal> Okay
17:14:11 <jbrooks> When you write your own, you're overriding bits of the embedded one, as I understand
17:14:20 <dustymabe> that's why by default when you use our images you get rsync file sharing, because of what is in the embedded vagrantfile
17:14:45 <dustymabe> jbrooks: right, but if you don't "override" those bits, then it usees the embedded one right?
17:15:20 <jbrooks> dustymabe, yes, I believe so
17:15:45 <jbrooks> So the embedded vagrantfile does matter
17:15:56 <dustymabe> ok. so I'll leave the ticket open for now. kushal if you need help understanding then ask me or jbrooks or Ian ?
17:16:20 * dustymabe might be able to help, but is no expert
17:16:34 <dustymabe> ok moving on
17:16:51 <dustymabe> actually.. should we action that?
17:16:54 <dustymabe> kushal: do you mind?
17:17:10 <kushal> Okay
17:17:29 <dustymabe> #action kushal to investigate adding cdrom via embedded vagrantfile for ticket 136
17:18:03 <dustymabe> #topic Produce updated cloud base images monthly
17:18:11 <dustymabe> #link https://fedorahosted.org/cloud/ticket/138
17:18:35 <dustymabe> kushal: was your earlier action item related to this?
17:18:40 <kushal> Yers
17:18:41 <kushal> Yes
17:19:08 <dustymabe> where do we stand? do we think we are close on this one?
17:19:25 <kushal> dustymabe, No, first we should release once
17:19:35 <kushal> sorry in another meeting at the same time
17:19:52 <dustymabe> kushal right. I meant we are close on all of the processes being in place to do the releases
17:19:58 <kushal> yes
17:20:04 <dustymabe> it's mostly the same process that we use for Atomic Host 2WA
17:20:19 <dustymabe> Is there a date we are going to try to target?
17:20:31 <maxamillion> no
17:21:04 <maxamillion> the process for Atomic Host 2WA is flawed and we're looking to rewrite it, I'd vote that nothing follow along that model
17:21:19 <dustymabe> maxamillion: ahh. didn't know what
17:21:24 <dustymabe> s/what/that
17:21:28 <maxamillion> it's duct tape and bubble gum the whole way down that was thrown together in the interest of time to get something out the door
17:21:56 <dustymabe> In that case I propose we do one of two things
17:21:56 <maxamillion> the release and the tests don't even target the same data source, the mismatches have caused pain
17:22:26 <dustymabe> 1 - scratch monthly releases of cloud base image until F24 (when I hope the 2WA process has been fixed)
17:22:52 <dustymabe> 2 - choose one build of cloud base that corresponds to a 2WA release and test it and release it and don't do any more
17:23:23 <dustymabe> that way we at least one image released with updates half way in between f23 and f24
17:23:46 <dustymabe> thoughts?
17:24:39 <jzb> dustymabe: I'm unclear on 2
17:24:50 <jzb> how do you mean corresponds with 2WA?
17:24:51 <dustymabe> unclear about what I mean?
17:25:00 <jzb> since they'd be different package sets.
17:25:16 <dustymabe> well I'm just saying that it would be nice if they were from the same batch of builds
17:25:19 <dustymabe> i.e from the same day
17:25:26 <dustymabe> 20160217 for example
17:25:30 <dustymabe> doesn't have to be
17:25:40 <jzb> ah
17:26:12 <dustymabe> we could do a blog post about it too
17:26:26 <dustymabe> saying we have a goal of monthly builds, but here is an update for now
17:27:03 <dustymabe> either way I say we decide on 1 or 2 and I'll update the ticket
17:27:15 <maxamillion> the release process for that is somewhat disjoint to the 2WA release since there's the fedimg aspect of it, so I'm not sure I'm the best to comment on how much work a one-off would be
17:27:37 <jzb> in the interest of not putting more stress on maxamillion or anybody else
17:27:42 <dustymabe> maxamillion: aren't they all being built and tested nightly anyway with autocloud?
17:27:50 <dustymabe> kushal: ^^
17:27:55 <jzb> I think #1 with a post about status and inviting more help would be best.
17:27:58 <kushal> Yes
17:28:25 <dustymabe> maxamillion: ahh I see what you are saying.. the actual "release"
17:28:28 <dustymabe> not the build/test
17:29:07 <maxamillion> dustymabe: right
17:30:07 <dustymabe> maxamillion: ok
17:30:11 <dustymabe> so we will go with #1
17:30:14 <dustymabe> I will update the ticket
17:30:22 <maxamillion> all the tooling in place is catered towards an "all or nothing" kind of release for the Fedora cycle, so you get the entire GA batch of release artifacts all together .... pulling Atomic out of that was a pain and we ended up doing it wrong anyways, I don't know how difficult it would be to do that with cloud base
17:30:42 <maxamillion> we have plans to make that better, it's just a matter of finding the time to actually work on it
17:30:44 <dustymabe> #action dustymabe to update ticket 138 on updated cloud image status - push to F24
17:31:14 <dustymabe> ok moving on
17:31:30 <dustymabe> #topic Producing 2 week atomic images
17:31:36 <dustymabe> #link https://fedorahosted.org/cloud/ticket/139
17:31:46 <dustymabe> close??
17:31:49 <dustymabe> kushal: ^^
17:32:20 <kushal> Now we can close this I think.
17:32:29 <kushal> We are in a good shape
17:32:33 <kushal> and had few iterations.
17:32:38 <kushal> maxamillion, ^^^^
17:32:45 <gholms> \o/
17:32:53 <maxamillion> eh
17:32:59 <dustymabe> #action kushal to close ticket 139 - producing 2WA images.
17:33:04 <maxamillion> yeah, we can close it
17:33:09 <kushal> yay
17:33:18 <dustymabe> #topic Don't overwrite download location for 2 week atomic images
17:33:29 <dustymabe> #link https://fedorahosted.org/cloud/ticket/147
17:33:46 <dustymabe> I think some users piped up in the ticket to explain some pain points for them
17:33:58 <kushal> dustymabe, btw, you can just type the url in IRC, meetbot will add that #link automagically
17:34:07 <kushal> like
17:34:07 <kushal> https://fedorahosted.org/cloud/ticket/147
17:34:09 <dustymabe> kushal: :)
17:34:21 <dustymabe> I like explicit
17:34:44 <dustymabe> ok so I guess as part of the re-tooling this will be taken care of
17:34:48 <maxamillion> yeah, and the concept of a 'latest' would be nice
17:35:06 <dustymabe> or could we possibly get this in place before the "rewrite" ?
17:35:16 <maxamillion> if I can find the time to work on it
17:35:50 <dustymabe> maxamillion: fair
17:35:56 <maxamillion> it's unfortunately not trivial because all of that is very fragile, if you chance something in the pipeline and something else assumes that a certain directory structure or layout would be true then it breaks
17:35:57 <dustymabe> at least we have it as a goal
17:36:07 <maxamillion> s/chance/change/
17:36:22 <maxamillion> which is effectively why the rewrite is happening
17:36:27 <maxamillion> well, among other reasons
17:36:36 <dustymabe> #topic Proposals for F24 features
17:36:46 <dustymabe> #link https://fedorahosted.org/cloud/ticket/143
17:37:03 <dustymabe> jzb: kushal: anything for this?
17:37:38 <kushal> dustymabe, I will have to start pinging people for the status
17:37:47 <jzb> dustymabe: nothing new - things are moving along. I could close the ticket or update for status on features.
17:37:48 <kushal> dustymabe, add another action item on me.
17:38:13 <dustymabe> ]#action kushal jzb to update ticket 143 - F24 features
17:38:14 <jzb> I will note that there's some pushback on -devel to the idea of using changes to track features, though. :-/
17:38:17 <dustymabe> #action kushal jzb to update ticket 143 - F24 features
17:38:18 <kushal> jzb, yes, alpha is in next month, we need the rpms
17:38:55 <dustymabe> #topic Dockerfiles Tickets
17:39:06 <dustymabe> Does anyone have anything for the dockerfiles tickets?
17:39:26 <jzb> dustymabe: something *mildly* related?
17:39:29 <kushal> dustymabe, we are supposed to look back at them around 25th of this month
17:39:34 <kushal> iirc
17:39:47 <dustymabe> kushal: ok
17:39:48 <jzb> just so folks who aren't already in the conversation know
17:40:07 <kushal> jzb, dustymabe one point though, we need real dockerfile examples which people can use in production.
17:40:12 <jzb> I've put in a request for some resources for the cloud group to have a few servers to run Fedora Atomic Host + Origin
17:40:21 <jzb> so we can test work on dockerfiles
17:40:27 <jzb> and ensure the entire "stack" is working
17:40:29 <kushal> jzb, nice
17:40:42 <dustymabe> jzb++
17:40:42 <zodbot> dustymabe: Karma for jzb changed to 5 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:40:46 <jzb> I should know in a few weeks if we got it, and will keep everybody in the loop on the rollout if I'm successful.
17:41:11 <dustymabe> ok so moving on from those tickets
17:41:25 <dustymabe> #topic Fedora Cloud FAD (late 2015/early 2016)
17:41:32 <dustymabe> #link https://fedorahosted.org/cloud/ticket/115
17:41:42 <dustymabe> so kushal is working on the proposal for this
17:41:48 <kushal> Yes
17:42:02 <kushal> But I need details about what all we want to achieve in it.
17:42:11 <dustymabe> we were looking at dates in april/may - kushal would like to have it be around PyCON so he only has one trip to the US that month
17:42:15 <kushal> Please put in your ideas about what you want to get done.
17:42:28 <kushal> Yes, 3rd week of May please.
17:42:33 <dustymabe> kushal: let's create a wiki page for the proposal
17:42:37 <dustymabe> does that exist anywhere?
17:42:57 <kushal> dustymabe, It will be a wiki, I started writing it in my box, I will post it tomorrow morning my time
17:42:58 <jberkus> should we have it in Portland?
17:43:06 * jberkus gets out the company dishes
17:43:12 <kushal> jberkus, Nope, Tower please :)
17:43:18 <jberkus> :-(
17:43:25 <jzb> kushal: actually
17:43:27 <kushal> jberkus, there will be way too many things to do in portland :)
17:43:31 <jzb> kushal: if you're already going to PDX for Pycon
17:43:36 <jzb> kushal: and I am as well
17:43:48 <jzb> kushal: I don't know there's any reason to detour to Raleigh?
17:44:08 <jberkus> the other hitch for me is that I'd need the FAD to end at least a couple days before PyCon
17:44:14 <jberkus> since I have stuff to do for PyCon ..
17:44:23 <kushal> jzb, Because I am a staff member of PyCon, and I will be crazy busy during PyCon
17:44:28 <jzb> kushal: sure
17:44:32 <jzb> kushal: but there's before and after
17:44:45 <dustymabe> anybody else have any issues with doing it around pycon in May?
17:44:54 <kushal> jzb, before is good, but then we have to get all others to PDX
17:45:04 <jberkus> oh wait
17:45:06 <jzb> kushal: I'm the only person who actually lives in RDU
17:45:12 <jzb> kushal: right? :-)
17:45:14 <jberkus> Container Days Boston is may 24-25
17:45:17 <jzb> kushal: you'll already be flying to RDU
17:45:17 <kushal> I think Raleigh will be cheaper
17:45:24 <jberkus> a bunch of the Westford crew are going to that
17:45:27 <jzb> er, PDX
17:45:44 <mattdm> container days boston would be convenient for me :)
17:45:53 <kushal> jzb, jberkus I am looking at 20-22 May as dates
17:46:13 <kushal> mattdm, I know someone who lives near Boston :)
17:46:20 <jzb> kushal: when does PyCon start?
17:46:30 <kushal> jzb, 28th iirc
17:46:31 <jzb> kushal: and side question
17:46:32 <dustymabe> boston is close for me as well
17:46:32 <jberkus> I'm at an event through the 21st
17:46:38 <jzb> kushal: when are the tutorials announced?
17:46:47 <kushal> jzb, that I don't know yet.
17:46:47 <jzb> kushal: I'm trying to decide if I want to sign up for them, but I don't see any listed.
17:46:54 <jzb> which I need to know to plan travel
17:46:57 <jzb> OK
17:46:57 <kushal> jzb, you will have to wait,
17:46:58 <mattdm> Raleigh is my second choice. I'm not sure I can justify PDX, at least not from my own travel budget
17:47:12 <jzb> I can do BOS or RDU or PDX
17:47:18 <kushal> jzb, stay back for sprints if possible
17:47:27 <kushal> RDU RDU RDU
17:47:27 <jzb> kushal: that might be a bit too long
17:47:33 <kushal> jzb, :)
17:47:36 <dustymabe> ok so we'll try to orgaize around pycon and container days boston and either RDU/Boston/Portland
17:47:37 <jzb> kushal: I'm also a python newb
17:47:38 <kushal> jzb, now you know my pain
17:47:56 <dustymabe> let's push the discussion of dates til after the meeting if we want to
17:47:57 <kushal> Anything against RDU?
17:48:05 <jberkus> dustymabe, kushal: the event on the 21st is one I'm *running*, so so if it's 20-22 I can't be there
17:48:11 <maxamillion> I need to duck out, apologies ... I'll catch up in the meeting minutes
17:48:20 <kushal> jberkus, ah :(
17:48:23 <dustymabe> maxamillion: :(
17:48:37 <dustymabe> ok let's do open floor and then we can get back to dates
17:48:40 <kushal> jberkus, is it okay if we do it a bit earlier?
17:48:57 <kushal> jberkus, say around 16-18?
17:48:59 <kushal> in RDU
17:49:07 <jberkus> kushal: for me, it would need to be a lot earlier.  I'm still on the PostgreSQL core team, and pgCon is 17-21
17:49:35 <kushal> O
17:49:42 <kushal> What about after pycon then?
17:49:45 <kushal> everyone?
17:49:46 <jberkus> I'm open
17:49:54 <jberkus> dustymabe: yeah, we should do open floor
17:49:56 <dustymabe> #topic open floor
17:49:56 * kushal will be too tired then.
17:50:11 <dustymabe> jberkus: kushal I know you had some itesm
17:50:13 <dustymabe> items
17:50:27 <jberkus> GSOC: Fedora is doing GSOC this year.  We want a significant Atomic component
17:50:32 <kushal> dustymabe, yes, and now my brain is not letting me recover them.
17:50:33 <jberkus> and other Could
17:50:36 <jberkus> Cloud
17:50:47 <kushal> jberkus, which is good. Get your mentor and ideas ready :)
17:50:49 <jberkus> right now we really need stuff for the ideas list for Fedora Cloud/Atomic
17:51:02 <jberkus> and by "right now" I mean "in the next 24 hours"
17:51:35 <jberkus> we're also looking for people who want to mentor, but we have a bit longer lead time on that
17:51:39 <kushal> jberkus, Okay.
17:51:44 <jberkus> couple of weeks
17:51:54 <kushal> jberkus, actually we do need them now, as we have to write that information on the wiki
17:52:00 <kushal> Google do read that.
17:52:21 <jberkus> if you have stuff for the ideas list, please email me jberkus@redhat.com with them, or better add them to the wiki yourself
17:52:29 <kushal> jberkus, I will
17:52:40 <kushal> jberkus, do you mind to paste the link for this year's wiki?
17:52:46 <dustymabe> jberkus: so there are talks between us and the coreos guys to possibly take coreos cloudinit and make a new thing (cloud init)
17:53:00 <dustymabe> that both fedora + centos + coreos supports
17:53:16 <dustymabe> we had an effort called flamingo that was a gsoc project
17:53:16 <jberkus> https://fedoraproject.org/wiki/Summer_coding_ideas_for_2016
17:53:26 <kushal> jberkus, Thanks
17:53:33 <dustymabe> but that didn't gain much traction
17:54:02 <kushal> dustymabe, main problem I see is about keeping the new contributor in the project than vanishing away
17:54:09 <dustymabe> kushal: yeah
17:54:20 <jberkus> since we're low on time:
17:54:31 <dustymabe> any other items for open floor?
17:54:51 <mattdm> I have some things for F25. But those can wait :)
17:54:59 <dustymabe> mattdm: :)
17:55:04 <gholms> What's the best way to call for cloud-init testers?  The list?
17:55:13 <dustymabe> gholms: probably
17:55:21 <gholms> Alrighty
17:55:23 <dustymabe> do you have a specific goal?
17:55:35 <jberkus> 2. currently some of the Atomic stuff is going to RHEL first instead of showing up in Fedora first the way it should.  Many of us working on Atomic would like to change this.
17:55:40 <gholms> Testing on more than just AWS and eucalyptus
17:55:54 <gholms> I do not have access to every cloud under the sun.  ;)
17:56:04 <dustymabe> jberkus++
17:56:04 <zodbot> dustymabe: Karma for jberkus changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:56:12 <jberkus> the main obstacle, as far as I've been able to tell, is lack of CI in the Fedora release process.
17:56:46 <jzb> gholms: but, the cloud is everywhere...
17:57:01 <dustymabe> jberkus: right I believe I have talked to colin about some of this before
17:57:24 <mattdm> jberkus++
17:57:24 <zodbot> mattdm: Karma for jberkus changed to 2 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:57:41 <gholms> The Cloud is all around us.  It surrounds us, penetrates us, and binds the universe together.
17:57:58 <jberkus> AFAIK, nothing's changed.  Colins team is heavily CI-oriented, and Fedora releng is not.  Is this just an intractable problem?
17:58:32 <kushal> gholms, I am going to quote you on that :)
17:58:51 <jberkus> gholms: like duct tape?
17:58:55 <dustymabe> jberkus: so I think the person that has the most insight into all of this had to step out: maxamillion
17:59:00 <mattdm> jberkus: I don't think it is. It would be nice to have needs more specifically articulated, though
17:59:02 <gholms> kushal: Don't get too excited; it's just a Star Wars reference.
17:59:14 <mattdm> Because "CI" is _almost_ as helpful a term as gholms's "Cloud"
17:59:20 <dustymabe> unfortunately me/kushal are probably next on that list
17:59:28 <gholms> But yeah, if/when I call for cloud-init testers it's because I need people to test on stuff like DO and openstack.
17:59:31 <dustymabe> and I don't have much insight, but I am trying to gain more
17:59:36 <jberkus> ok.  is there a place to go with this where we can make actual progress on issues?
17:59:45 <kushal> We do have many tests right now running on our nightly builds.
17:59:45 <jberkus> right now we're stuck
17:59:55 <jzb> jberkus: let's discuss during 1:1
17:59:57 <jzb> or, you know, now
18:00:03 <jberkus> true!
18:00:13 <kushal> But not testing on the patches
18:00:14 <dustymabe> jberkus: it would probably need to be a joint discussion between cloud wg and releng and atomic people?
18:00:33 <dustymabe> or at least interested parties from each
18:00:41 <jzb> mattdm: it is a good question "how do we get resources once we've identified what we need"?
18:02:05 <dustymabe> ok all we have run over.. should we continue discussion on #fedora-cloud?
18:02:10 <kushal> We should start cloning people.
18:02:11 <mattdm> jzb: depends on what resources.
18:02:22 <dustymabe> kushal: 3D printing!
18:02:25 <jzb> kushal: that always turns out well in movies.
18:02:52 <dustymabe> ending meeting in 3...
18:03:01 <dustymabe> 2...
18:03:02 <mattdm> but if it's release engineering, there has been _significant_ reorginization/retooling over the past year specicially to address this
18:03:02 <kushal> 2.5
18:03:12 <dustymabe> 1...
18:03:13 <kushal> .9
18:03:14 <mattdm> specifically :)
18:03:20 <dustymabe> #endmeeting