fedora_cloud_wg
LOGS
17:00:18 <kushal> #startmeeting Fedora Cloud WG
17:00:18 <zodbot> Meeting started Wed Jan  6 17:00:18 2016 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:18 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
17:00:25 <kushal> #topic Roll Call
17:00:29 <kushal> .hellomynameis kushal
17:00:30 <dustymabe> .hellomynameis dustymabe
17:00:30 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:00:30 <rtnpro> .fas rtnpro
17:00:34 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:00:37 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:00:46 <sayan> .fas sayanchowdhury
17:00:47 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:00:48 <kushal> dustymabe, woo hoo
17:00:52 <nzwulfin> .fas mmicene
17:00:52 <zodbot> nzwulfin: mmicene 'Matt Micene' <nzwulfin@gmail.com>
17:01:05 <trishnag> .hello trishnag
17:01:06 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:01:08 <kushal> nzwulfin, ah, I missed to ping you :(
17:01:15 <mmcgrath> .fas mmcgrath
17:01:17 <zodbot> mmcgrath: absinthesyringe 'Adnan Hodzic' <havoc@foolcontrol.org-disabled-mmcgrath> - mmcgrath 'Mike McGrath' <imlinux+fedora@gmail.com>
17:01:28 <mmcgrath> o_O
17:01:31 <dustymabe> mmcgrath: \o
17:01:34 <kushal> #chair dustymabe rtnpro sayan nzwulfin trishnag mmcgrath
17:01:34 <zodbot> Current chairs: dustymabe kushal mmcgrath nzwulfin rtnpro sayan trishnag
17:01:43 <maxamillion> .hello maxamillion
17:01:44 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:01:45 <kushal> mmcgrath, .hellomynameis will work better :)
17:01:50 <kushal> #chair maxamillion
17:01:50 <zodbot> Current chairs: dustymabe kushal maxamillion mmcgrath nzwulfin rtnpro sayan trishnag
17:01:58 <dustymabe> wow.. what a turnout
17:01:59 <jbrooks> .fas jasonbrooks
17:02:00 * maxamillion throws a shoe at mmcgrath
17:02:00 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:02:02 <maxamillion> >.>
17:02:10 <kushal> #chair imcleod jbrooks
17:02:10 <zodbot> Current chairs: dustymabe imcleod jbrooks kushal maxamillion mmcgrath nzwulfin rtnpro sayan trishnag
17:02:15 <kushal> dustymabe, :)
17:02:26 <kushal> Happy new year everyone :)
17:02:32 <maxamillion> Happy new year!
17:02:40 <sayan> Happy new year :)
17:02:41 <kushal> I hope people got enough rest.
17:02:46 <trishnag> Happy new year :)
17:02:49 <kushal> Time to work again :)
17:02:55 <mmcgrath> merry new year everyone
17:03:00 <kushal> #topic Action items from last meeting
17:03:18 <kushal> * jzb will update #135 on Fedora 23 retrospective
17:04:29 <kushal> It seems jzb is bringing in guests :)
17:04:34 <kushal> Or guest rather :D
17:04:38 <jzb> kushal: just a sec
17:04:45 <kushal> jzb, no hurry
17:05:40 <lalatenduM> .fas lalatendu
17:05:41 <zodbot> lalatenduM: lalatendu 'Lalatendu Mohanty' <lmohanty@redhat.com>
17:05:50 <jzb> .hellomynameis jzb
17:05:51 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:06:02 <kushal> #chair jzb lalatenduM
17:06:03 <zodbot> Current chairs: dustymabe imcleod jbrooks jzb kushal lalatenduM maxamillion mmcgrath nzwulfin rtnpro sayan trishnag
17:06:11 <jzb> hrm
17:06:17 <jzb> kushal: I guess let's come back to the guest
17:06:17 <number80> .hello hguemar
17:06:18 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:06:27 <kushal> number80, Hi there :)
17:06:30 <kushal> #chair number80
17:06:30 <zodbot> Current chairs: dustymabe imcleod jbrooks jzb kushal lalatenduM maxamillion mmcgrath number80 nzwulfin rtnpro sayan trishnag
17:06:38 <kushal> Record turnout :)
17:06:41 <dustymabe> * jzb will update #135 on Fedora 23 retrospective
17:06:46 <dustymabe> that is what we are on right now
17:06:49 <jzb> I will?
17:06:50 <jzb> uh...
17:06:56 <dustymabe> :)
17:07:06 <kushal> jzb, action item from last meeting :)
17:07:08 <jzb> what with the holidays, I don't have any updates
17:07:21 <jzb> but I will update the ticket, I think the primary thing is - needs more testing.
17:07:23 <dustymabe> so carry action item forward?
17:07:26 <jzb> muuuuch more testing
17:07:28 <jzb> dustymabe: sure
17:07:33 <kushal> jzb, understandable
17:07:46 <kushal> jzb, trishnag and fhackdroid volunteered themselves :)
17:07:53 <kushal> jzb, so feel free to point things to them :)
17:08:03 <kushal> jzb, I think they need some help at the starting :)
17:08:38 <kushal> We have few other volunteers who can not attend the meeting
17:08:45 <dustymabe> #action jzb will update #135 on Fedora 23 retrospective
17:08:59 <trishnag> jzb, o/
17:09:03 <kushal> dustymabe, Thanks :)
17:09:09 <kushal> Moving to the tickets then.
17:09:11 <jzb> trishnag: yo
17:09:12 <jzb> :-)
17:09:26 <kushal> #topic Proposals for F24 features https://fedorahosted.org/cloud/ticket/143
17:09:31 <kushal> Pushing it to the top
17:09:39 <kushal> We don't have any traction in that.
17:10:02 <kushal> I have pushed the cloud motd change for F24, rtnpro volunteered for that change
17:10:14 <kushal> He will write and maintain the codebase, and the package
17:10:24 <dustymabe> rtnpro++
17:10:24 <zodbot> dustymabe: Karma for rtnpro changed to 2 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:10:31 <kushal> rtnpro, will also update the wiki page and the ticket :)
17:10:41 <jzb> maxamillion: did you file a change for F24 for OpenShift / Fedora?
17:10:54 <rtnpro> the initial code for cloud MOTD is here: https://github.com/rtnpro/fedora-motd
17:11:13 <rtnpro> ok
17:11:13 <kushal> 12th is the last date to submit changes iirc.
17:11:41 <kushal> dustymabe, You had few ideas iirc
17:12:07 <kushal> anyone else?
17:12:08 <dustymabe> man deadlines come at you like bullets
17:12:09 <jzb> does anyone want to volunteer to cat-herd for that?
17:12:33 <jzb> dustymabe: any container tools stuff for F24?
17:12:39 <nzwulfin> would adding glusterfs/ceph client be something big enough for F24 or would that be a separate discussion?
17:12:58 <dustymabe> jzb: not really, we are really just trying to do everything we can to get it working on one platform
17:13:00 <dustymabe> (centos)
17:13:01 <dustymabe> for now
17:13:05 <kushal> nzwulfin, sounds good for now.
17:13:17 <maxamillion> jzb: hey, sorry ... distracted all over the place
17:13:22 <mmcgrath> nzwulfin: there are efforts under way to containerize both
17:13:25 <maxamillion> jzb: yes, change is in and approved, openshift is in rawhide now
17:13:26 <lalatenduM> nzwulfin: is it a usecase used by lot of userbase of fedora cloud
17:13:30 <dustymabe> there is no reason why it can't work for F24, but that's not a focus we have
17:13:53 <kushal> maxamillion, awesome, can you please update https://fedoraproject.org/wiki/Changes/Features_for_Fedora_24_from_Cloud_SIG ?
17:13:58 <maxamillion> jzb: once AEP is officially launched with an upstream, I plan to package that also
17:13:58 <jzb> maxamillion: excellent, thanks
17:14:03 <lalatenduM> mmcgrath: maxamillion you can mount glusterfs volumes with nfs too
17:14:05 <jzb> maxamillion: +1
17:14:23 <nzwulfin> mmcgrath: for the server side yes, for k8s persistent storage support the clients need to be on the host or in a k8s container
17:14:34 <jzb> nzwulfin: a storage/container thing might be a good feature yes
17:14:43 <jzb> mmcgrath: do you have a timeline there?
17:14:46 <maxamillion> kushal: I'm not sure that I should do to this page ... just put a link to my change?
17:15:13 <kushal> maxamillion, Yes :)
17:15:15 <jbrooks> this is for fedora atomic? the ceph/gluster change?
17:15:19 <scollier> .hello
17:15:19 <zodbot> scollier: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:15:26 <scollier> .hello scollier
17:15:26 <maxamillion> kushal: on it
17:15:27 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:15:30 <kushal> #chair scollier
17:15:30 <zodbot> Current chairs: dustymabe imcleod jbrooks jzb kushal lalatenduM maxamillion mmcgrath number80 nzwulfin rtnpro sayan scollier trishnag
17:16:08 <jbrooks> There's the atomic dev mode feature that's been floating around, as well
17:16:12 <kushal> Yes
17:16:13 <maxamillion> jbrooks: +1
17:16:18 <maxamillion> it's pretty swank
17:16:20 <kushal> jbrooks, we should ask that as a change
17:16:28 <kushal> I am yet to test that though.
17:16:36 <kushal> maxamillion, good to know that :)
17:17:01 <jzb> OK
17:17:05 <jzb> can I ask a minor favor?
17:17:12 <jzb> can everybody who just committed to a feature
17:17:21 <jzb> add an #info or #link?
17:17:25 <jzb> to that?
17:17:35 <jzb> I will take the action to follow up and make sure we have that in by the deadline.
17:17:56 <maxamillion> #info OpenShift Origin F24 Feature has been approved and origin is in Rawhide currently https://fedoraproject.org/wiki/Changes/OpenShiftOrigin
17:18:00 <kushal> #info rtnpro will work on cloud motd change
17:18:38 <kushal> Anyone else?
17:18:49 <jzb> mmcgrath, nzwulfin gluster/storage/ceph?
17:19:11 <mmcgrath> jzb: those already ship in RHEL, shouldn't be too hard to replicate.
17:19:23 <mmcgrath> in RHEL Atomic Host I mean.
17:19:24 <nzwulfin> should just be adding packages to the base
17:19:28 <kushal> someone needs to own the change
17:19:31 <jbrooks> #info cloud atomic dev mode info at https://lists.fedoraproject.org/archives/list/cloud%40lists.fedoraproject.org/message/M75UQFVNUPNC6ES3RZMT5PXRHIH3FMP5/
17:19:36 <nzwulfin> ceph is big b/c of some issues
17:19:38 <jzb> jbrooks++
17:19:38 <zodbot> jzb: Karma for jasonbrooks changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:19:48 <nzwulfin> if we're good with addng them, i'll take it
17:19:48 <kushal> jbrooks++
17:19:48 <zodbot> kushal: Karma for jasonbrooks changed to 2 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:20:03 <kushal> nzwulfin, Please go ahead and file a change request
17:20:28 <jzb> nzwulfin++
17:20:30 <zodbot> jzb: Karma for mmicene changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:20:33 <jzb> nzwulfin: thanks
17:20:42 <jzb> OK, any others?
17:20:44 <nzwulfin> #info nzwulfin to add glusterfs and ceph client rpms
17:20:52 <jzb> I'll collate these and follow up this week
17:21:00 <kushal> jzb, Thank you :)
17:21:29 <jzb> kushal: ticket updated
17:21:32 <kushal> Let us move to normal tickets
17:21:33 <mmcgrath> nzwulfin: sync up w/ bchilds@redhat.com to see what pitfalls there are.  He's got that working on RHEL already, I think in containers (which keeps the base image small)
17:21:34 <kushal> jzb++
17:21:35 <zodbot> kushal: Karma for jzb changed to 4 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:21:50 <nzwulfin> mmcgrath: cool will do, thanks
17:21:58 <kushal> #topic Fedora Cloud FAD (late 2015/early 2016) https://fedorahosted.org/cloud/ticket/115
17:22:02 <maxamillion> mmcgrath: +1
17:22:07 <maxamillion> all about keeping that base image small
17:22:09 <maxamillion> <3
17:22:24 <kushal> Just a info, I will miss devconf, new rules for visa will make sure that I may not get visa on time.
17:22:32 <jzb> kushal: boo
17:22:52 <dustymabe> kushal: so let's push to after devconf
17:22:57 <dustymabe> maybe some time in march?
17:23:04 <kushal> jzb, I will make sure to attend the meetings over phone/hangout
17:23:09 <kushal> dustymabe, sounds better
17:23:09 <dustymabe> is server WG planning to have a FAD any time soon?
17:23:19 <dustymabe> mhayden: ^^
17:23:23 <kushal> dustymabe, may be in USA, then no problem of visa :D
17:23:32 <kushal> and most people are in USA anyway :)
17:23:51 <mhayden> dustymabe: ohai
17:24:25 <dustymabe> jzb: do you think some time in march would be good? are there any conferences then? or maybe we can do RDU?
17:24:26 <kushal> dustymabe, can you please update the ticket about having it in March? :)
17:24:37 <kushal> RDU sounds cool :)
17:24:50 <jzb> dustymabe: maybe, I'm not aware of any conflicts
17:24:54 <maxamillion> dustymabe: we have thoughts on location and timeframe for the FAD? ... last few days of March is a no-fly zone for me
17:25:10 <maxamillion> oooo, lets do RDU in the Tower :D
17:25:13 <dustymabe> maxamillion: probably somewhere in the middle of march?
17:25:16 <maxamillion> dustymabe: +1
17:25:29 <maxamillion> dustymabe: have you talked to anyone about funding travel?
17:25:33 <dustymabe> ok. I'll update the ticket with suggestions
17:25:38 <kushal> dustymabe, From 18th of March there is FOSSASIA in singapore, please put in within first two weeks
17:25:40 <dustymabe> maxamillion: I have not. We have to make a proposal
17:25:49 <maxamillion> dustymabe: rgr
17:25:58 <kushal> maxamillion, we should get the money from the separate FAD budget
17:26:05 <jzb> dustymabe: can you or can someone who is not me come up with a ballpark?
17:26:20 <jzb> we can propose to the council first
17:26:21 <maxamillion> kushal: I'm not entirely sure what that means
17:26:42 <kushal> maxamillion, the budget for FAD is a special one iirc
17:26:43 <dustymabe> :) - I think I would need some help. never really made a budget for this type of thing before.
17:26:57 <dustymabe> also would love to co-locate with server WG event
17:27:02 <dustymabe> so that would mean more $$$
17:27:12 <jzb> https://fedoraproject.org/wiki/How_to_organize_a_FAD#Budget
17:27:16 <dustymabe> but I think we could get some work done in trying to find some synergies
17:27:18 <maxamillion> docs!
17:27:20 <dustymabe> within the two groups
17:27:24 <maxamillion> I am a ducker for good docs
17:27:26 <maxamillion> sucker*
17:27:35 <maxamillion> I'll just stop talking now
17:27:36 <dustymabe> maxamillion: that could have been worse :)
17:27:40 <maxamillion> dustymabe: fair
17:27:46 <jzb> dustymabe: I suspect that stickster, mattdm, and decause would be able to help here too
17:27:56 <jzb> maxamillion: lol
17:28:48 <kushal> Okay, moving next
17:29:22 <kushal> #topic 	Migrate all Dockerfiles / Images to systemd where possible https://fedorahosted.org/cloud/ticket/121
17:29:29 <kushal> anything on this?
17:29:46 <jzb> kushal: the only thing I have is scollier and I spoke, and we were in a waiting pattern for $someday
17:29:58 <jzb> something something layered images, maybe hosting elsewhere
17:30:09 <jzb> kushal: but we decided we should just go back to maintaining in the current repo for now.
17:30:12 <jzb> which reminds me...
17:30:25 <mmcgrath> sorry all, I have to drop.  Conflict (will try to watch but be distracted)
17:30:33 <kushal> mmcgrath, thanks for dropping by :)
17:30:35 <jzb> mmcgrath: thanks for joining
17:30:42 <dustymabe> mmcgrath: thanks for coming
17:31:07 <jzb> I have a PR to send in for the OwnCloud Dockerfile
17:31:29 <jbrooks> sweet
17:31:41 <kushal> Nice
17:31:43 <kushal> jzb++
17:31:55 <kushal> No more cookies for you it seems :(
17:31:56 <jzb> scollier: updating the existing Dockerfiles shouldn't be that difficult, should it?
17:32:00 <jzb> scollier: see above
17:32:08 <scollier> jzb, reading
17:32:15 <jzb> kushal: what's up with that? I'm shooting for the 200 cookie badge
17:32:29 <maxamillion> jzb: the layered image build system is in a rough spot right now, OSBS upstream is in a ... "fluid" state and support for things we need is currently non-functional
17:32:37 <jbrooks> jzb, there's a systemd folder in that repo with some converted-to-systemd examples, could be used to help convert the others
17:32:46 <scollier> jzb, difficult?  devils in the details.  shouldn't be.  the main issue would be time to test.
17:33:02 <jzb> maxamillion: Yeah, I'm saying we just plow through for now and keep doing what we've been doing
17:33:07 <jzb> maxamillion: being frozen isn't helping
17:33:22 <kushal> jzb, yes
17:33:38 <jzb> scollier: I was wondering if we might be able to do some damage by doing hack day or something
17:33:49 <jzb> just schedule a day to get people online together and work through them all
17:34:09 <maxamillion> jzb: I've lost an unfortunate amount of sleep over this whole thing
17:34:20 <scollier> jzb, that would be cool
17:34:30 <nzwulfin> if there are samples then that could definitely work
17:34:41 <jzb> maxamillion: no blame, just saying we should do what we can for now
17:34:48 <jzb> maxamillion: rather than waiting on pieces that aren't done yet.
17:35:20 <maxamillion> jzb: eh, I partially blame myself but that's a pile of self loathing for a different day
17:35:26 <maxamillion> jzb: absolutely, +1
17:35:39 <jzb> maxamillion: you can put your pile next to mine
17:35:50 <jzb> I'll get the matches
17:36:11 <jzb> kushal: I think that's all for now, I may be foolish enough to volunteer to set up an online hack day
17:36:19 <maxamillion> jzb: +1
17:36:19 <jzb> kushal: can we like set a timer and revisit that ticket in February?
17:36:25 <maxamillion> jzb: http://maxamillion.sh/ThisIsFine.jpg
17:36:34 <scollier> maxamillion, haha
17:36:36 <kushal> jzb, Okay, I will update the ticket
17:36:40 <jzb> heh
17:36:44 <jzb> kushal: thanks!
17:37:00 <kushal> #action kushal will update #121 with a alarm in Feb
17:37:03 <kushal> next
17:37:24 <maxamillion> scollier: my PM literally made me stickers of that and I have on my laptop ... she's basically the absolute best --> https://twitter.com/TheMaxamillion/status/675886146866380801
17:37:24 <kushal> #topic fedora-dockerfiles: Clean up READMEs https://fedorahosted.org/cloud/ticket/122
17:38:23 <kushal> Anything?
17:38:26 <jzb> kushal: this should probably be folded into the other dockerfiles ticket?
17:38:39 <kushal> jzb, Yes, someone has to clean up those, there are too many :)
17:38:52 <jzb> kushal: just a sec, will do
17:38:52 <kushal> anyone wants to volunteer for that?
17:38:56 <kushal> ah
17:39:35 <kushal> Moving to next ticket then
17:39:45 <jberkus> kushal: I could volunteer, but realistically I won't start on it until after SCALE14
17:39:51 <kushal> #topic Document process for using Fedora-Dockerfile branches https://fedorahosted.org/cloud/ticket/123
17:40:13 <kushal> jberkus, feel free to do when ever you find time
17:40:33 <jzb> kushal: done
17:40:45 <kushal> Last maxamillion gave a +1 to this ticket, but no update after that.
17:40:51 <kushal> jzb, Thank you once again
17:41:30 <kushal> Moving to next then.
17:41:35 <maxamillion> yeah, someone asked me to review that
17:41:42 <kushal> maxamillion, Okay
17:41:47 <maxamillion> wasn't sure if there was any more action I should do beyond that
17:41:50 <dustymabe> adimania has been MIA
17:41:53 <maxamillion> I'm happy to, just not sure what was asked of me
17:41:59 <dustymabe> he asked for review
17:42:03 <scollier> maxamillion, all, maybe
17:42:14 <scollier> well, we only have the branches
17:42:24 <scollier> because of the transition to dnf, right?
17:42:39 <scollier> can we deprecate out the older branches, and move back to master?
17:42:46 <scollier> since it's all dnf now?
17:42:57 <scollier> would be much, much easier, with my level of git-fu
17:43:43 <dustymabe> scollier: seems reasonable
17:44:16 <scollier> dustymabe, if everyone is ok with that, i can work on getting everything merged into master, we'll retire the others.
17:44:33 <jzb> scollier: +1
17:44:35 <kushal> scollier, Nice
17:44:43 <number80> +1
17:44:52 <scollier> ok.  cooool.
17:45:06 <kushal> #topic Fedora-Dockerfiles examples for Kubernetes https://fedorahosted.org/cloud/ticket/125
17:45:31 <kushal> rtnpro, can you please review that?
17:45:36 <kushal> or lalatenduM or dustymabe ?
17:46:14 <jzb> kushal: may I hijack the meeting for a moment?
17:46:26 <lalatenduM> kushal: will go through teh ticket
17:46:29 <kushal> jzb, Go ahead :)
17:46:51 <maxamillion> scollier: "all" what?
17:47:01 <jzb> kushal: groovy, thansk
17:47:03 <jzb> thanks
17:47:05 <scollier> maxamillion, sorry, everyone in the room.
17:47:27 <jzb> so - I wanted to introduce somebody, who may be able to help with some of the Dockerfile work and examples
17:47:37 <scollier> drum roll
17:47:43 <dustymabe> .....
17:47:44 <jzb> jberkus <-- Josh Berkus, he started yesterday with Red Hat
17:47:50 <maxamillion> scollier: rgr
17:47:53 <jzb> he's our shiny new Project Atomic Community Lead
17:47:53 * nzwulfin claps
17:47:55 <dustymabe> jberkus: welcome
17:47:56 <jberkus> <-- me
17:48:00 <scollier> Hi jberkus
17:48:19 <jzb> he's been on the job for all of like 25 hours
17:48:37 <jzb> so he's going to need some time to dig in, but working with the Fedora Cloud Working Group is going to be a high priority
17:48:41 <kushal> jberkus, Hello there :)
17:48:54 <scollier> very cool jzb
17:48:57 <jzb> those of you attending SCALE and/or DevConf.cz will get to meet him in person
17:49:21 <kushal> Means I missed that chance :(
17:49:21 <jzb> or, I guess, if you just drop by his house, though that may be a tad creepy
17:49:23 <lalatenduM> jberkus: welcome!
17:49:39 <kushal> jberkus, Welcome on board :)
17:49:41 <jberkus> well, if anyone *is* in Portland, I plan to have a Guest Desk as soon as I'm fully moved in
17:49:48 <jzb> nice
17:49:49 <jberkus> right now my furniture is on a truck though
17:50:03 <kushal> jberkus, Great, I will be there for PyCon
17:50:04 <scollier> jberkus, in a "container" ?
17:50:07 <scollier> :)
17:50:10 <jzb> anyway - that was my hijack, please be as nice to jberkus as you would be to me.
17:50:10 <kushal> jberkus, You should attend it :)
17:50:13 <jzb> wait, maybe nicer.
17:50:23 <dustymabe> jzb: :)
17:50:27 <dustymabe> ok back to meeting
17:50:32 <dustymabe> kushal: did we discuss networkd ticket?
17:50:37 <kushal> jberkus, everything is your fault, jzb just gave everything on you.
17:50:44 <kushal> :)
17:50:51 <kushal> dustymabe, Nope
17:51:02 <jberkus> kushal: well, jzb hired me for my blame-accepting talents
17:51:14 <jberkus> scollier: in fact, yes
17:51:25 <kushal> jzb, you have talent in the team, and within :)
17:51:35 <jzb> :-)
17:51:37 <jberkus> kushal: well, it depends on whether Pycon accepts any of my talk submissions ...
17:52:13 <kushal> :)
17:52:25 <kushal> dustymabe,  we can talk about after meeting
17:52:39 <kushal> #topic vagrant boxes fixups https://fedorahosted.org/cloud/ticket/136
17:52:40 <dustymabe> seems like a meeting topic to me
17:52:49 <kushal> dustymabe, Yup, but very less time for now.
17:52:55 <kushal> dustymabe, may be at the end.
17:53:16 <dustymabe> kushal: move to next topic. no progress
17:53:24 <kushal> #topic Produce updated cloud base images monthly
17:53:37 <kushal> https://fedorahosted.org/cloud/ticket/138
17:54:02 <kushal> So I think we should do a release this month.
17:54:10 <dustymabe> I'm +1 on that
17:54:16 <kushal> All F23 nightly images are passing autocloud tests.
17:54:29 <kushal> We enabled many more tests which will run from tomorrow.
17:55:01 <kushal> #action Kushal will update #136 and drop a mail to the list
17:55:17 <kushal> #topic Producing 2 week atomic images https://fedorahosted.org/cloud/ticket/139
17:55:38 <dustymabe> kushal: we are pretty much done with this
17:55:43 <dustymabe> can probably close ticket
17:55:47 <kushal> I have made a calendar invite for the release go-no meeting
17:55:56 <dustymabe> kushal: was I on that?
17:56:03 <kushal> dustymabe, Let us do that after next two week release
17:56:09 <kushal> dustymabe, Meeting is yet to happen
17:56:11 <dustymabe> kushal: ok
17:56:20 <jzb> kushal: thanks!
17:57:11 <kushal> https://apps.fedoraproject.org/calendar/cloud/#m3212
17:57:17 <kushal> Feel free to join in that
17:57:39 <kushal> Tomorrow :)
17:57:50 <dustymabe> the only issue I have right now is the download location keeps getting overwritten on new release
17:57:52 <dustymabe> https://lists.fedoraproject.org/archives/list/cloud%40lists.fedoraproject.org/thread/T6PVY62LR43LJE7JM2SHHNTKATQZZD76/
17:58:01 <dustymabe> discussed on the list with maxamillion
17:58:02 <kushal> dustymabe, Yes, I remember the thread
17:58:21 <dustymabe> was I making a good enough case for not doing it that way?
17:58:38 <kushal> dustymabe, yes, +1 from me.
17:59:13 <maxamillion> I don't have a preference, the way it is now was the way it was requested of releng ... if that is to change, we'll need a new request in queue
17:59:16 <dustymabe> maxamillion: what do we need to do to convince other people that is a reasonable change to make?
17:59:31 <maxamillion> dustymabe: don't know
17:59:43 <dustymabe> maxamillion: so it would start with a releng ticket?
18:00:08 <maxamillion> dustymabe: I suppose just file a ticket for the next cloud SIG meeting and then vote and see if everyone wants it that way, if so then file a ticket with releng to change the process based on the decision of the Cloud SIG
18:00:29 <maxamillion> if the Cloud SIG is going to shephard the Atomic Host image then I think that's the best way to go about it
18:00:37 <dustymabe> ok
18:00:40 <kushal> We can directly vote in the ticket
18:00:44 <kushal> All WG members
18:01:01 <kushal> dustymabe, Just drop a mail to the list after you file the ticket.
18:01:14 <dustymabe> kushal: can we do networkd ticket now?
18:01:34 <kushal> yes
18:01:50 <kushal> #topic Networkd on Cloud/Atomic images
18:01:58 <kushal> dustymabe, do you want to start the discussion?
18:02:31 <dustymabe> so from the list I think the biggest sticking point for me is that Atomic Host uses NM and colin doesn't see networkd as a solution for him for now
18:03:18 <kushal> dustymabe, Yes.
18:03:32 <dustymabe> I was +1 networkd until that
18:03:36 <number80> I'd like us to keep a single way to manage network especially in regards w/ doc
18:04:00 <kushal> that case we have to move the base image also to NM
18:04:03 <number80> we can diverge from other products, but two ways w/in cloud products => no
18:04:17 <jzb> so we should table this for now?
18:04:39 <kushal> jzb, Yup, but this also means we have to do NM for base image :)
18:04:53 <dustymabe> kushal: right that is the other end of the coin.. we have two options now: leave cloud base on legacy network scripts, or move it to NM
18:04:54 <number80> I guess we'll keep NM for this release but if we keep the proposal, then we must involve Colin in the discussion
18:05:21 <dustymabe> kushal: one good thing is that NM is already being tested in cloud environments
18:05:28 <dustymabe> because our cloud atomic host is using it
18:05:40 <kushal> dustymabe, Yes.
18:05:56 <kushal> number80, I don't think he wants it in the future too.
18:06:44 <dustymabe> so what do we want to do considering this new information?
18:07:01 <jzb> maybe come back to this for F25?
18:07:04 <kushal> Open a ticket for moving to NM in the base image.
18:07:06 <jzb> looks like no change for F24
18:07:11 <kushal> jzb, Yes.
18:07:13 <dustymabe> 1. leave cloud base as is: 2. move just cloud base to networkd: 3. move cloud base to NM
18:07:17 <number80> kushal: even for F25 or later?
18:07:31 <kushal> number80, seems so from the mails, I may be wrong.
18:07:40 * kushal needs sleep.
18:07:56 <number80> dustymabe: I'm for 3. for F24, 1. is ok if we keep the discussion around networkd
18:08:19 <dustymabe> ok.
18:08:29 <dustymabe> kushal: can you update networkd ticket?
18:08:35 <kushal> dustymabe, I will
18:08:41 * dustymabe always needs moar sleep
18:08:48 <kushal> but tomorrow after some sleep :)
18:08:54 <dustymabe> kushal: kk
18:08:58 <kushal> #action Kushal to update networkd ticket
18:09:25 <kushal> We can close the meeting now.
18:09:29 <number80> yup
18:09:33 <kushal> 5
18:09:34 <kushal> 4
18:09:36 <number80> (and get some rest kushal!)
18:09:37 <kushal> 3
18:09:40 <kushal> 2.5
18:09:42 <kushal> 2
18:09:43 <kushal> 1
18:09:46 <kushal> 0.2
18:09:51 <kushal> #endmeeting