serversig
MINUTES

#fedora-meeting-1: Server SIG Weekly Meeting (2016-01-05)

Meeting started by sgallagh at 16:00:48 UTC (full logs).

Meeting summary

  1. roll call (sgallagh, 16:00:48)
  2. Agenda (sgallagh, 16:04:15)
    1. Agenda Item: systemd-networkd (sgallagh, 16:04:50)
    2. Agenda Item: Brainstorming plans for 2016 (sgallagh, 16:05:07)

  3. systemd-networkd (sgallagh, 16:06:55)
    1. ACTION: mhayden to take systemd-networkd feedback to cloud sig + systemd upstream (mhayden, 16:16:52)
    2. https://fedorahosted.org/cloud/ticket/14 (mhayden, 16:17:39)
    3. ACTION: sgallagh to research alternative DNSSEC implementations for next week (sgallagh, 16:22:24)
    4. mhayden asked whether Server might consider switching to systemd-networkd. Responses remained in favor of Network Manager at this time. (sgallagh, 16:23:07)

  4. Brainstorming plans for 2016 (sgallagh, 16:25:32)
  5. Brainstorming List - What Server Does Well (sgallagh, 16:28:49)
    1. Simple installation (sgallagh, 16:29:25)
    2. Easy to use WebUI (jds2001, 16:29:28)
    3. pre-defined roles or personas (jds2001, 16:29:59)
    4. Versatile networking features (sgallagh, 16:29:59)
    5. Wide variety of available software (sgallagh, 16:31:04)
    6. Virtualization/container tools are easy to use (mhayden, 16:31:21)
    7. Functional and useful out of the box (sgallagh, 16:32:22)
    8. A Server OS that agressively updates the included software (stefw, 16:35:51)

  6. Brainstorming List - Things Server Can Improve Upon (sgallagh, 16:36:06)
    1. Expanding the functionality of Cockpit (i.e. software management, probably lots of other things) (jds2001, 16:36:53)
    2. User-defined roles (jds2001, 16:37:09)
    3. Discoverable troubleshooting of the system (stefw, 16:37:18)
    4. Software Managemnt (updates) in cockpit (jds2001, 16:37:38)
    5. Stability guarantees between updates (sgallagh, 16:37:40)
    6. deployment of roles in cockpit (jds2001, 16:37:49)
    7. role repair tool (jds2001, 16:38:05)
    8. Change Management when (not if) APIs break (simo, 16:38:11)
    9. https://trello.com/c/7CZqL9AQ/54-rolekit-integration-for-domain-controller (stefw, 16:39:38)
    10. more user-friendly and better documented role CLI (adamw, 16:39:43)
    11. https://meetbot.fedoraproject.org/teams/rolekitweekly/rolekitweekly.2016-01-05-14.30.log.html (sgallagh, 16:43:20)
    12. No long-term support guarantees (sgallagh, 16:44:54)
    13. Better support for coexisting with Windows (sgallagh, 16:47:01)
    14. Need support for DNSSEC out of the box (sgallagh, 16:48:28)
    15. Easily build an OpenStack cloud (sgallagh, 16:50:40)
    16. We have no good story for server management (sgallagh, 16:52:38)
    17. easily set up katello (jds2001, 16:53:26)

  7. Open Floor (sgallagh, 16:59:53)


Meeting ended at 17:01:25 UTC (full logs).

Action items

  1. mhayden to take systemd-networkd feedback to cloud sig + systemd upstream
  2. sgallagh to research alternative DNSSEC implementations for next week


Action items, by person

  1. mhayden
    1. mhayden to take systemd-networkd feedback to cloud sig + systemd upstream
  2. sgallagh
    1. sgallagh to research alternative DNSSEC implementations for next week


People present (lines said)

  1. sgallagh (113)
  2. mhayden (49)
  3. simo (39)
  4. jds2001 (29)
  5. stefw (17)
  6. adamw (14)
  7. nirik (11)
  8. zodbot (10)
  9. tflink (4)
  10. kushal (1)
  11. danofsatx (0)
  12. mizmo (0)


Generated by MeetBot 0.1.4.