cloud_wg
LOGS
17:01:57 <roshi> #startmeeting cloud sig
17:01:58 <zodbot> Meeting started Wed Sep  9 17:01:57 2015 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:09 <roshi> #meetingname Cloud WG
17:02:09 <zodbot> The meeting name has been set to 'cloud_wg'
17:02:12 <dustymabe> .hellomynameis dustymabe
17:02:13 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
17:02:15 <roshi> #topic roll call
17:02:21 <rtnpro> .fas rtnpro
17:02:22 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:02:23 <roshi> who's around?
17:02:27 <roshi> .hello roshi
17:02:28 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:02:30 <rtnpro> roshi, o/
17:02:35 <roshi> \o
17:02:48 <kushal> .hellomynameis kushal
17:02:49 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:02:57 <linux-modder> .hello corey84
17:02:58 <zodbot> linux-modder: corey84 'Corey Sheldon' <sheldon.corey@gmail.com>
17:03:10 * linux-modder hanging out back row  learning
17:04:26 <roshi> best way to learn is to do :p
17:04:26 <dustymabe> linux-modder: welcome
17:04:33 <roshi> so welcome :)
17:04:46 <roshi> #topic Previous Meeting Follow-up
17:04:53 <roshi> * number80 update PRD about i686
17:04:53 <roshi> * rtnpro sayan kushal will work to create testcases and try out NM and networkd, docs on https://fedoraproject.org/wiki/Cloud/Network-Requirements
17:04:56 <roshi> * adimania will replace yum with dnf for f22 branch, and report back (for Fedora dockerfiles)
17:04:59 <roshi> * scollier will break up https://fedorahosted.org/cloud/ticket/84 into consumable tickets.
17:05:02 <roshi> * kushal will test and update the rel-eng ticket with the latest tree
17:05:12 <sayan> .hello sayanchowdhury
17:05:13 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:05:43 <kushal> No work was done in both the action items, I need to re add the both again this week
17:05:43 * roshi checks the PRD
17:06:15 <rtnpro> yes, no update on the above from my side as well :\
17:06:17 <roshi> #chair dustymabe rtnpro sayan kushal linux-modder
17:06:17 <zodbot> Current chairs: dustymabe kushal linux-modder roshi rtnpro sayan
17:06:31 <roshi> go ahead and re-action yourselves then so we can keep track
17:06:48 <roshi> would it be better if I set us on on phab to keep track of these tickets?
17:07:05 <roshi> it's got a kanban style board, ticket tracking, docs, projects, etc
17:07:09 <roshi> pretty useful
17:07:21 <scollier> hi
17:07:27 <roshi> qa uses it for a lot, and it's where I have the tickets and whatnot for testcloud
17:07:32 <roshi> welcome scollier :)
17:08:33 <dustymabe> roshi: in addition to trac?
17:08:36 <dustymabe> or to replace?
17:08:45 <dustymabe> I think I'd like to have one or the other but not both
17:08:46 <roshi> doesn't look like the PRD got updated
17:08:48 <maxamillion> .hello maxamillion
17:08:49 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:08:55 <maxamillion> (sorry I'm late)
17:08:59 <roshi> either or, depends on what people like using, I guess
17:09:16 <roshi> if we're reviewing code and whatnot for tools in addition to other tickets, I think phab wins
17:09:19 <roshi> tbh
17:09:20 <roshi> just a though
17:09:20 <jbrooks> .hello jasonbrooks
17:09:21 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:09:24 <roshi> thought, even
17:09:31 <roshi> no worries maxamillion
17:10:02 <kushal> #action rtnpro sayan kushal will work to create testcases and try out NM and networkd, docs on https://fedoraproject.org/wiki/Cloud/Network-Requirements
17:10:20 <kushal> #action  kushal will test and update the rel-eng ticket with the latest tree
17:11:13 <roshi> scollier: any action on your action item?
17:11:27 * scollier checks.
17:12:44 <scollier> roshi, that was the breaking up of one ticket into many, right?
17:12:52 <scollier> if so, no actions.  i'll try to get on that this week.
17:13:21 <roshi> yeah, it was
17:13:23 <roshi> no worries
17:13:39 <roshi> #action scollier will break up https://fedorahosted.org/cloud/ticket/84 into consumable tickets.
17:13:51 <scollier> roshi, thanks.
17:13:59 <adimania> sorry for being late.
17:14:06 <roshi> #action number80 to update the PRD with i686 details
17:14:09 <roshi> no worries :)
17:14:19 <roshi> onto the tickets!
17:14:37 * number80 around
17:14:42 <roshi> #topic (105) Missing cockpit rpms
17:14:46 <roshi> #link https://fedorahosted.org/cloud/ticket/105
17:15:44 <jbrooks> roshi, that's still the current status -- I keep getting sidetracked when I look for an appropriate spot on the wiki to put the content of my blog post
17:16:05 <roshi> jbrooks: all else fails, just put it under the cloud namespace
17:16:35 <roshi> something like .../wiki/Cloud/Tutorials/Cockpit-in-a-container
17:16:43 <roshi> it can always be moved later
17:16:51 <jbrooks> +1 thanks, I'll do it there
17:16:58 <roshi> sweet
17:17:14 <roshi> the wiki is a free space, so can't really go wrong just throwing it somewhere :p
17:17:20 <jbrooks> :)
17:17:34 <roshi> #action jbrooks to update the wiki
17:17:46 <roshi> #topic (14) Network stack
17:17:51 <roshi> #link https://fedorahosted.org/cloud/ticket/14
17:18:31 <roshi> still no real action on this one
17:18:32 <kushal> roshi, we will work on it, no updates for now
17:18:39 <roshi> kk
17:18:49 <roshi> and this is already covered under an action item...
17:18:53 <roshi> so moving on
17:19:21 <roshi> I'll also skip dockerfiles care and feeding, since that's been mentioned already
17:19:39 <roshi> #topic (94) Updated images
17:19:42 <roshi> #link https://fedorahosted.org/cloud/ticket/94
17:20:03 <roshi> kushal: waiting on you for this one too it seems
17:20:27 <kushal> roshi, we will work on it, no updates for last week, spent most of the time on autocloud
17:20:39 <roshi> kk
17:20:40 <kushal> roshi, I will ping dgilmore with the updated details
17:20:43 <kushal> this week only
17:20:48 <linux-modder> on this  one  pls  add me  to  any updates I am looking to do some local uni  cloud  tuts  this semester to help some professors
17:20:49 <roshi> ok
17:20:56 <jbrooks> roshi, is that this: http://dl.fedoraproject.org/pub/alt/fedora-atomic/images/testing/cloud/
17:21:03 <jbrooks> the updated images
17:21:09 <roshi> dunno
17:21:13 <roshi> don't think so
17:21:21 <roshi> I'd think they'd live on koji
17:21:26 <linux-modder> should be pub/atomic  not  alt/
17:21:35 <kushal> should on alt
17:21:40 <kushal> I will update with the links
17:21:45 <roshi> thanks kushal
17:21:50 <jbrooks> Oh, and there's atomic vs cloud
17:21:56 <kushal> as we will test the release trees
17:21:57 <roshi> #action kushal to update ticket with links
17:22:03 <linux-modder> then I need a  post mtg  primer on the diff
17:22:20 <linux-modder> and base cloud
17:22:32 <roshi> linux-modder: I can help you out with that after the meeting in fedora-cloud
17:23:09 <linux-modder> local uni looking to  do cloud VM ing  for linux stuffs  this semester as a pilot thing
17:23:34 <roshi> #topic (106) 32bit Cloud
17:23:40 <roshi> #link https://fedorahosted.org/cloud/ticket/106
17:24:09 <roshi> proposed #agreed - roshi to close this ticket as it seems to be resolved. Retiring this arch for cloud in F24 timeframe
17:24:21 <linux-modder> for the cloud instance that seems sane
17:24:24 <linux-modder> ack
17:24:53 <dustymabe> ack
17:25:35 <roshi> #agreed - roshi to close this ticket as it seems to be resolved. Retiring this arch for cloud in F24 timeframe.
17:25:57 <roshi> #topic (107) PRD Discussion
17:26:00 <roshi> #link https://fedorahosted.org/cloud/ticket/106
17:26:06 <roshi> #undo
17:26:06 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x23090bd0>
17:26:10 <roshi> #link https://fedorahosted.org/cloud/ticket/107
17:26:11 <linux-modder> PRD is ?
17:26:24 <roshi> Product Requirements Document
17:26:29 <linux-modder> ah
17:26:40 <roshi> each WG has to have one for what they want to do for the .next effort
17:26:47 <roshi> this is an ongoing discussion
17:27:01 <roshi> number80 is going to update it with info on i386 stuff
17:27:25 <roshi> we still need people to go through it with a fine toothed comb and make sure it has everything it needs
17:27:29 <number80> roshi: now, I have now definitivey abandoned the idea of getting dinner tonight
17:27:44 * roshi isn't sure where it is with the council
17:27:58 <number80> council + fesco for technical stuff
17:28:03 <roshi> number80: it's not worth you missing out on life essentials - go get some food :p
17:28:25 <number80> roshi: nah, I have a mountain load of stuff blocking me at home anyway
17:28:40 <roshi> ok, that's your call though :)
17:28:43 <number80> if I'm not doing that, it will be something else
17:29:20 <roshi> #action everyone to take some time to look at the PRD and come back with comments
17:30:09 <jbrooks> roshi, the PRD is linked from the ticket?
17:30:13 <roshi> #topic (108) Text for getfedora.org and Marketing
17:30:16 <roshi> #link https://fedorahosted.org/cloud/ticket/108
17:30:25 <roshi> jbrooks: I think so
17:30:35 <jbrooks> https://fedoraproject.org/wiki/Talk:Cloud/Cloud_PRD
17:30:53 <kushal> brb changing network
17:30:54 <roshi> http://fedoraproject.org/wiki/Cloud/Cloud_PRD is the PRD
17:30:55 <jbrooks> Oh, I see, now
17:31:03 <kushal> or actually this network works
17:31:39 * number80 fixed the 32 bit thing
17:31:52 <number80> quick win, I feel better (still proof-reading)
17:32:28 <roshi> nice
17:32:39 <linux-modder> can help if needed number80
17:32:43 <roshi> so, everyone go to getfedora.org and check the text they currently have there for cloud
17:33:10 <roshi> per comment #7 on this marketing ticket
17:34:39 <adimania> I would want it in slightly positive tone.
17:34:55 <roshi> it all looks good to me, the copy on getfedora.org
17:35:00 <adimania> instead of saying "nothing more", maybe we can say really light weight.
17:35:17 <roshi> adimania: you can submit a patch
17:35:37 <roshi> talk to robyduck in #fedora-mktg and he can help you find out the specifics
17:36:10 <linux-modder> +1 for s/nothing more/lightweight
17:36:33 <adimania> roshi, would it not be better if WG decides on this first?
17:37:12 <adimania> may be someone could come up with something better or may have objection to this statement.
17:37:31 <dustymabe> adimania: I would say make your changes and submit it in email to the list
17:37:33 <roshi> I figured we could review in the patch
17:37:49 <dustymabe> if you get no comments or postive comments then submit
17:37:53 <roshi> yeah
17:37:57 <linux-modder> makes sense
17:38:01 <adimania> sounds good to me. I will do that.
17:38:04 <dustymabe> adimania: thanks!
17:38:12 <roshi> thanks adimania :)
17:38:36 <adimania> no problem.
17:39:08 <roshi> #action adimania to write a patch for getfedora.org copy and submit to the list
17:39:23 <roshi> #topic (113) Firewall on by default
17:39:28 <roshi> #link https://fedorahosted.org/cloud/ticket/113
17:40:09 <roshi> I think this can be closed as well
17:40:16 <dustymabe> roshi: I think we talked about it and decided it was expected
17:40:29 <roshi> dustymabe: we should probably let places like DO to make sure they know to turn it on
17:40:33 <roshi> unless they don't want it on
17:41:01 <linux-modder> not sure i follow the issue on this one  the OP is  worried its un-configured?
17:41:04 <dustymabe> roshi: yep
17:41:13 <dustymabe> linux-modder: yeah I was the OP
17:41:20 <roshi> linux-modder: cloud ships w/o a firewall by default
17:41:23 <dustymabe> I just thought it was supposed to be on by default
17:41:38 <roshi> but places like DO don't have the same external networking that EC2 and friends have
17:41:44 <linux-modder> I assume  it  uses the  current  host network as a  de-facto then?
17:41:52 <roshi> proposed #agreed - roshi to close this ticket as resolved.
17:41:54 <dustymabe> roshi: yeah. and the next image we give them will have this fixed
17:42:00 <roshi> sweet
17:42:52 <roshi> acks?
17:43:05 <dustymabe> ack
17:43:09 <linux-modder> dustymabe,  so it will take the host  config  by default then  (even in cases like DO with non standard ones) ?
17:43:41 <roshi> linux-modder: EC2 handles all the networking ports and IPs that can get to an instance
17:43:42 <dustymabe> linux-modder: not sure what you mean.. by default the iptables service doesn't get run
17:43:50 <roshi> so there's no reason to have a firewall in that context
17:43:58 <linux-modder> ack tehn
17:44:11 <roshi> #agreed - roshi to close this ticket as resolved.
17:44:50 <roshi> #topic (115) Cloud FAD
17:44:54 <roshi> #link https://fedorahosted.org/cloud/ticket/115
17:45:00 <roshi> dustymabe: got anything for us?
17:45:11 <dustymabe> roshi: not yet. going to try to make a proposal soon
17:45:17 <dustymabe> sorry about the delay on that one
17:45:21 <roshi> sgtm
17:45:23 <roshi> no worries
17:45:29 <dustymabe> i've been riddled with PTO and Holidays :)
17:45:38 <dustymabe> and $dayjob
17:45:47 <roshi> the way I see it: the FAD is a "nice to have" not a "unbreak this now!" kinda thing
17:46:03 <linux-modder> this FAD would be  similar to test-day  yes?
17:46:21 <roshi> kinda, it's an in person thing we all go to to work together on stuff
17:46:41 <dustymabe> kinda like a little mini conference
17:46:46 <linux-modder> nice
17:47:23 <roshi> #info dustymabe will be working on the proposal for this sometime in the near future and will update the ticket when that happens
17:47:34 <dustymabe> ack
17:47:38 <roshi> #topic (116) Vagrant boxes in Atlas
17:47:41 <roshi> #link https://fedorahosted.org/cloud/ticket/116
17:48:13 <dustymabe> roshi: there was some activity on this.. we are looking at uploading cloud images to atlas
17:48:16 <jbrooks> I added the current fedora atomic images to the fedora namespace
17:48:25 <dustymabe> someone raised a good point about legal so we might need to go through them
17:48:42 <roshi> best to check with legal early
17:48:44 <jbrooks> I guess -- all it does is point to our server
17:48:54 <roshi> who's chasing that down, the legal bits?
17:49:22 <dustymabe> roshi: lalatenduM created the fedora namespace. I think I will need to go retrace his steps and see if there were any terms he agreed to
17:49:23 <maxamillion> for those of us who aren't familiar ... what is Atlas?
17:49:38 <jbrooks> It's like docker hub for vagrant
17:49:41 <dustymabe> kinda like dockerhub for vagrant boxes
17:49:42 <roshi> it's what holds the world up, aiui
17:49:48 <maxamillion> (I would have thought it would be in the ticket but it is not)
17:49:48 <maxamillion> ah ok
17:50:20 <maxamillion> I don't know because I hate vagrant and want it to fade into obscurity, but was curious for the sake of this conversation
17:50:27 * dustymabe remembers maxamillion not liking ruby :)
17:50:37 <maxamillion> dustymabe: oh no, I like ruby just fine
17:50:42 <maxamillion> dustymabe: I hate vagrant
17:50:42 * roshi has never used it past a smoke test a couple years back
17:50:43 * jbrooks used to hate vagrant, before it got w/ libvirt
17:51:02 <dustymabe> jbrooks: agreed
17:51:11 <dustymabe> I never wanted to use it before that
17:51:14 <roshi> ok, so any actions needed for this?
17:51:22 <dustymabe> roshi: no I don't think so
17:51:27 <roshi> ok, moving on then
17:51:28 <dustymabe> I think we know what needs to get done
17:51:36 <roshi> don't want to raise maxamillion'
17:51:41 <jbrooks> roshi, I do have a related q, though
17:51:41 <maxamillion> :)
17:51:44 <roshi> s ire any more than it already is
17:51:53 <roshi> go for it jbrooks
17:52:07 <jbrooks> I mentioned in the issue that the testing atomic images, the two week images, are the same as the official image w/ all updates applied
17:52:30 <jbrooks> We don't have officially updated images, but these two week images are updated
17:52:32 <roshi> jbrooks: I would think that's the intent
17:52:50 <roshi> downloading the 2-week image just means you don't have to boot, then update
17:52:52 <jbrooks> I guess, at what point are these considered non-testing
17:52:55 <roshi> it's already updated
17:53:09 <roshi> not sure - as I don't follow atomic well at all
17:53:25 <jbrooks> Because, yeah, I'd much rather start w/ the updated image, but we don't want to give ppl testing images and call them official
17:53:27 <roshi> dustymabe: ^^ ?
17:53:39 <dustymabe> jbrooks: I think we should wait 2 week atomic is official?
17:53:56 <jbrooks> Even if the pkgs there equal the official image + updates
17:54:03 <number80> may I suggest a daring move?
17:54:04 <jbrooks> dustymabe, I'll follow up w/ you
17:54:09 <maxamillion> number80: go for it
17:54:12 <dustymabe> ok
17:54:25 <number80> having atomic folks joining our meeting every 2 weeks?
17:54:33 <number80> I feel like we're two separate group
17:54:41 <number80> which is wrong
17:55:00 <maxamillion> number80: +1
17:55:04 <jbrooks> Fine w/ me, though the group just voted to make atomic the primary focus, right?
17:55:08 * maxamillion has to run, thanks everyone
17:55:13 <dustymabe> number80: who all is that cgwalters and who else?
17:55:19 <jbrooks> me
17:55:21 <dustymabe> jbrooks: right
17:55:31 <number80> jbrooks: yes
17:55:50 <dustymabe> ok. so we have some of them :)
17:56:10 <number80> #action number80 make proposal on cloud & atomic list to have joint meetings
17:56:16 * jbrooks doesn't understand why there isn't a plain core minimal fedora image
17:56:35 <number80> jbrooks: you don't want to unravel that one
17:56:44 <roshi> jbrooks: it's turtles all the way down
17:56:49 <jbrooks> number80, I'm fine leaving it ravelled :)
17:56:53 <jbrooks> if that's a word
17:56:55 <number80> :)
17:56:57 <roshi> works for me
17:57:04 <roshi> words like that keep me plenty gruntled
17:57:20 <roshi> ok, moving on :)
17:57:28 <number80> +2
17:57:36 <roshi> #topic (118) Deliverables
17:57:39 <roshi> #link https://fedorahosted.org/cloud/ticket/118
17:57:49 <roshi> #link https://fedoraproject.org/wiki/Fedora_Program_Management/ReleaseBlocking/Fedora23
17:57:56 <roshi> I updated the wiki with our list ^^
17:58:00 <roshi> check it out
17:58:26 <roshi> +1 if you want to confirm that list and I'll update the "Signed off by" line and close the ticket
17:58:31 <roshi> and we can be done with it
17:58:38 <roshi> and close out the meeting, as we're running out of time
17:59:35 <roshi> votes?
18:00:02 <dustymabe> I voted in the ticket?
18:00:09 <dustymabe> is that good enough?
18:00:31 <roshi> I mean with what I put in the wiki
18:00:57 <kushal> roshi, just now voted.
18:01:22 <dustymabe> yep. looked at that  too
18:01:30 <roshi> heh
18:01:39 <roshi> I meant to just say it here in the meeting
18:02:03 <roshi> #action roshi to update the wiki that things are signed off, and close the ticket.
18:02:08 <roshi> #topic Open Floor
18:02:16 <roshi> anybody have anything for open floor?
18:02:25 <dustymabe> did we get to all tickets?
18:02:25 <roshi> we're over time, so setting the fuse...
18:02:27 <roshi> 2...
18:02:28 <roshi> we did
18:02:31 <dustymabe> ok cool
18:02:34 <dustymabe> thanks roshi
18:02:43 <linux-modder> not sure  on status of the HAM spin for 23  but  other spins look good on that  roshi   and  everything seems  linked right
18:03:21 <roshi> 2...
18:03:31 <roshi> thanks for coming folks!
18:03:34 <roshi> 1...
18:03:38 <roshi> #endmeeting