serversig
LOGS
15:00:01 <sgallagh> #startmeeting Server SIG Weekly Meeting (2015-09-01)
15:00:01 <zodbot> Meeting started Tue Sep  1 15:00:01 2015 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:01 <sgallagh> #meetingname ServerSIG
15:00:01 <zodbot> The meeting name has been set to 'serversig'
15:00:01 <sgallagh> #chair sgallagh mizmo nirik stefw adamw simo tuanta mitr danofsatx
15:00:01 <sgallagh> #topic roll call
15:00:02 <zodbot> Current chairs: adamw danofsatx mitr mizmo nirik sgallagh simo stefw tuanta
15:00:05 <sgallagh> .hello sgallagh
15:00:06 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:00:10 <adamw> ahoy to the oy hoy
15:00:12 <danofsatx> .hello dmossor
15:00:14 <nirik> morning.
15:00:16 <zodbot> danofsatx: dmossor 'Dan Mossor' <danofsatx@gmail.com>
15:00:32 <mizmo> .hello duffy
15:00:33 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
15:00:42 * danofsatx is having a split personality day
15:01:20 <sgallagh> /me used to think he was schizophrenic. Turns out I was just imagining things...
15:02:16 <stefw> .hello stefw
15:02:18 <zodbot> stefw: stefw 'Stef Walter' <stefw@redhat.com>
15:02:48 <danofsatx> I'm dividing attention between moving data, setting up an IPA replica, researching Cyber Securty curriculum for a new degree program at my uni, and kinda-sort paying attention to the LAS podcast.
15:02:53 <danofsatx> oh yeah, and this meeting.
15:03:09 <simo> .hello simo
15:03:09 <zodbot> simo: simo 'Simo Sorce' <ssorce@redhat.com>
15:03:57 <sgallagh> OK, let's get started. Agenda:
15:04:05 <sgallagh> #topic Agenda
15:04:05 <sgallagh> #info Agenda Item: Blocking Media List
15:04:05 <sgallagh> #info Agenda Item: Default NTP service
15:04:05 <sgallagh> #info Agenda Item: Websites Update
15:04:28 <sgallagh> Does anyone else have a topic to add to the agenda?
15:05:13 <danofsatx> nothing here....lets go.
15:05:23 <sgallagh> #topic Blocking Media List
15:05:48 <sgallagh> I sent out a proposed response
15:05:52 <sgallagh> #link https://lists.fedoraproject.org/pipermail/server/2015-September/002023.html
15:06:06 * danofsatx saw it
15:06:19 <nirik> +1 to proposed list, seems fine to me.
15:06:46 <danofsatx> oh yeah, +1.
15:06:56 <jsmith> +1 from me as well
15:07:03 <simo> +1
15:07:12 <sgallagh> The only piece that I thought we might want to discuss is the ARM image. I could see an argument for blocking on it... or not.
15:07:36 <jsmith> I don't have a problem with it blocking
15:07:44 <simo> sgallagh: that's arm64 right ?
15:07:59 <sgallagh> Well, hardware with which to test it is not readily available
15:08:01 <jsmith> simo: No, that's 32-bit ARM
15:08:06 <simo> ah
15:08:12 <sgallagh> simo: armhfp is 32-bit
15:08:24 <simo> why would we block in server for arm32 when we are droppin intel32 ?
15:08:26 <adamw> i'd at least want someone to be committed to *using* it for us to block on it.
15:08:38 <simo> right
15:08:42 <jsmith> adamw: I am using it, and will be using it :-)
15:08:51 * adamw dumps all the work on jsmith
15:08:52 <adamw> +1!
15:08:53 <sgallagh> simo: ARM actually still has active kernel support. i686 doesn't
15:08:55 <jsmith> adamw: But I'm not sure that I'm enough of a use-case to justify blocking :-)
15:09:14 <adamw> simo: 32-bit ARM is still the primary case for now. it's hard and very expensive to buy 64-bit ARM hardware.
15:09:14 <sgallagh> jsmith: If you're willing to commit to testing it for release validation...
15:09:18 <jsmith> simo: There are enough active contributors in the ARM SIG that work gets done :-)
15:09:24 <jsmith> sgallagh: Sure... I can do that
15:09:25 <adamw> of course, you can't run much of a server on a 32-bit ARM box, really.
15:09:26 <simo> sgallagh: sure, but we have very little if no userspace testing for the servers bits
15:09:51 <nirik> sure, it's good for small stuff like dns/dhcp, etc
15:09:53 <adamw> testing freeipa is enough of a pain without also having to do it on frigging arm
15:09:54 <simo> adamw: that's my point
15:09:57 <simo> *server*
15:10:06 <nirik> but yeah, not sure about a freeipa server or a db server.
15:10:10 <jsmith> adamw: My servers may be small, but they're mine!
15:10:17 <danofsatx> can we use something like the provider that's donating space for ARM compiliation?
15:10:20 <jsmith> I run PostgreSQL on my arm boxes all the time :-)
15:10:22 * danofsatx may be way off base
15:10:22 <pwhalen> you can also use qemu, or internal hosts for arm server testing
15:10:25 <sgallagh> nirik: I actually have an ARM-powered MariaDB server running at home, but... meh.
15:10:30 <adamw> so unless someone's very clearly committed to doing it, i'd say -1 to ARM. i'm not realistically going to say i'd manage to get ARM testing done every milestone. sometimes i might be able to help.
15:10:48 <simo> ok
15:11:05 <simo> if we have a volunter to take care of ARM with server bits I think it may be ok
15:11:10 <jsmith> How 'bout I make a proposal...
15:11:16 <sgallagh> Proposal: Approve the proposal from the aforementioned email with one revision: we will ship the ARM image as non-blocking.
15:11:18 <simo> note that we are just talking on whether it should be blocker right
15:11:24 <adamw> right
15:11:27 <simo> or are we talking about ship/no-ship ?
15:11:38 <adamw> just blocking/not-blocking, i think. i'm fine with shipping it.
15:11:43 * nirik waits for jsmith's proposal
15:11:49 <danofsatx> heh...fedora-arm meeting is happening next door in meeting-2
15:11:49 <sgallagh> simo: See the proposal I just made and vote or request a change to it :)
15:11:50 <simo> same here
15:11:59 <simo> fine with shipping, prefer non-blocking
15:12:10 <simo> sgallagh: +1 to your proposal
15:12:45 <jsmith> sgallagh: +1 to non-blocking for F23, but I'd like to change to blocking for F24
15:12:52 <adamw> +1 to sgallagh proposal
15:12:58 <danofsatx> +1
15:13:28 <sgallagh> jsmith: Come back with at least one other person willing to commit to supporting that, please. (I don't want to take on that responsibility without covering the hit-by-a-bus case)
15:13:29 <simo> jsmith: I'd make it blocking once we have readily available arm64 hw
15:13:45 <sgallagh> ARM64 is going to be a whole new can of worms.
15:13:50 <simo> right
15:13:55 <sgallagh> (They're related by name only, really)
15:13:55 <jsmith> simo: Well, AArch64 is a bigger project -- it's still secondary arch
15:14:00 <simo> but at least it can be a primary target for server
15:14:09 <jsmith> simo: It should only be blocking once it's primary arch
15:14:18 <simo> sgallagh: well the cpu architecture is not wholly different
15:14:22 <jsmith> simo: Doesn't make sense to block on it before then, and that's going to be a ways out
15:14:26 <sgallagh> Right, there's discussion about changing the way we define primary and secondary (and merging the various Koji instances)
15:14:27 <simo> sgallagh: the devices are though ..
15:14:29 <nirik> right, but we might be changing how we do that. I think the conversation is out of scope here. ;)
15:14:36 <jsmith> nirik: +1
15:14:36 <simo> jsmith: ok
15:14:55 <sgallagh> OK, so I count +5 to my proposal (including myself)
15:15:09 * adamw is with sgallagh: i'm fine with blocking on arm when we have people willing to commit to testing/using it.
15:15:11 <sgallagh> mizmo: Do you foresee any issues with websites here?
15:15:29 <nirik> well, not only testing/using it... but also fixing it. ;)
15:15:45 <mizmo> sgallagh, wrt adding arm as an arch?
15:15:46 <adamw> MINOR DETAILS
15:15:54 <sgallagh> nirik: Well, the ARM SIG is pretty responsive, once someone notices a bug
15:16:17 <sgallagh> mizmo: We already have it
15:16:20 <sgallagh> https://arm.fedoraproject.org/
15:16:36 <nirik> anyhow, if folks want it non blocking thats ok with me...
15:16:38 <dgilmore> as sgallagh said, we are working on trying to enable things like the ServerWG promoting aarch64 as a primary arch for it while it remains secondary for WorkstationWG
15:16:43 <mizmo> sgallagh, so how would websites be affected?
15:16:50 <mizmo> is it that one is 64 bit?
15:16:58 <mizmo> so there's 2?
15:17:06 <sgallagh> mizmo: I don't know. I was asking if changing from blocking to non-blocking of that image would be relevant to you
15:17:14 <sgallagh> Right now, we aren't shipping the 64-bit version
15:17:26 <sgallagh> 64-bit isn't on the table for F23.
15:17:28 <sgallagh> So set that aside.
15:17:45 <sgallagh> In F22 we shipped the ARM32 disk image on the arm.fp.o page
15:17:47 <mizmo> so the arm image for server is no longer blocking?
15:18:09 <sgallagh> mizmo: That's what we're voting on (with +5 in favor resulting in it passing unless strong arguments change someone's mind)
15:18:26 <mizmo> i think the website just wont display it if its not available so i don't think it's a huge deal. the one bit of suckage is that fedora minimal would be the only server image we could offer then
15:18:52 <simo> why would that suck ?
15:18:58 <adamw> the image will still be built and shipped (unless generation is somehow broken), aiui
15:19:05 <mizmo> simo, cuz the website woul dhave a category for a bucket of one item :)
15:19:11 <mizmo> which would look weird
15:19:11 <simo> :)
15:19:13 <adamw> but we might want websites to play down its importance, i guess
15:19:20 <mizmo> and that is the pain part :)
15:19:27 <sgallagh> adamw: I think the point is that if it's built but jsmith's testing reveals serious breakage, we'd voluntarily not ship it too
15:19:29 <simo> let's uncathegorize the unbuckets! With unicorns
15:19:35 <adamw> oh, fair enough. sure.
15:19:44 <mizmo> any major changes to the layou tof the page means i have to email arm's lawyers for another approval
15:19:52 * jsmith sighs...
15:20:09 <simo> mizmo: meh, due to arm trademark there ?
15:20:12 <mizmo> yep
15:20:16 <simo> lovely
15:20:17 <simo> ok
15:20:23 <sgallagh> Mostly I am just crossing all my "T"s to make sure the right people know what's going on.
15:20:25 <simo> we'll cross that bridge when we get there
15:20:33 <mizmo> yep, we'll do what we gotta do
15:20:37 <simo> (or if as it may be)
15:20:59 <mizmo> sgallagh, its good to have a heads up that some changes might be needed there
15:22:27 <sgallagh> To summarize the ARM discussion: We intend to ship the 32-bit ARM Server image if it passes the validation tests, but if it fails them we will not block the release of Fedora. Further, if it fails substantial portions of the release, we will not advertise and ship the ARM image.
15:22:52 <sgallagh> Accurate?
15:23:12 <jsmith> WORKSFORME
15:23:14 <danofsatx> Accurate. +1
15:23:26 <adamw> ack
15:23:52 <sgallagh> #info We intend to ship the 32-bit ARM Server image if it passes the validation tests, but if it fails them we will not block the release of Fedora. Further, if it fails substantial portions of the release, we will not advertise and ship the ARM image.
15:24:44 <sgallagh> #agreed We approved the proposal for the deliverables described in the agenda email, with the aforementioned change in the ARM decision. (+5, 0, -0)
15:24:51 <sgallagh> #topic Default NTP service
15:25:11 <sgallagh> #undo
15:25:11 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2b1b3c90>
15:25:24 <sgallagh> Actually, I just realized that one of those +1s was jsmith who is not a WG member.
15:25:37 <sgallagh> mizmo: Would you care to vote? :)
15:25:42 <sgallagh> #undo
15:25:42 <zodbot> Removing item from minutes: AGREED by sgallagh at 15:24:44 : We approved the proposal for the deliverables described in the agenda email, with the aforementioned change in the ARM decision. (+5, 0, -0)
15:27:24 <sgallagh> Or stefw?
15:27:50 <sgallagh> Proposal was: Approve the proposal from the aforementioned email with one revision: we will ship the ARM image as non-blocking.
15:27:50 * danofsatx will vote twice if he has to
15:28:21 <stefw> +1
15:28:31 <sgallagh> Thanks
15:28:36 <sgallagh> #agreed We approved the proposal for the deliverables described in the agenda email, with the aforementioned change in the ARM decision. (+5, 0, -0)
15:28:41 <sgallagh> #topic Default NTP service
15:28:57 <sgallagh> OK, so there are two questions here:
15:29:18 <sgallagh> 1) Should we ship with a time synchronization service enabled by default?
15:29:18 <sgallagh> 2) Which one?
15:30:03 <jsmith> My smart-alec answers would be "yes" and "yes" :-)
15:30:08 <sgallagh> So let's start with 1). Proposal: All Fedora Server installations should have time-synchronization against Fedora's timeservers enabled by default.
15:30:17 <sgallagh> .fire jsmith
15:30:17 <zodbot> adamw fires jsmith
15:30:36 <jsmith> On a more serious note, I think NTP should be enabled by default
15:30:43 <adamw> what, they don't already? sure.
15:31:07 <sgallagh> adamw: I suspect it's been an oversight more than anything else, but we should at least assert a preference
15:31:12 <nirik> "fedoras time servers"?
15:31:26 <nirik> you mean the fedora.pool.ntp.org pool? or ?
15:31:34 <jsmith> nirik: I was just going to ask that... I'm assuming it's the fedora pool at ntp.org
15:31:35 <adamw> i was assuming that was the intent, yeah.
15:31:38 <sgallagh> nirik: Yes, those
15:31:45 <nirik> ok, then +1.
15:32:02 <danofsatx> fedora.pool.ntp.org
15:32:34 <simo> +1
15:33:15 <simo> I so wish HW vendors would put reasonably accurate clocks in their chips, but apparently that is never gonna happen, so NTP is the next best thing
15:33:17 <sgallagh> danofsatx, mizmo, stefw: ?
15:33:42 <sgallagh> /me wants an atomic clock on every PC and a chicken in every pot...
15:33:55 <stefw> +1 on time sync service enabled by default
15:33:57 <danofsatx> +1
15:34:23 <sgallagh> #agreed All Fedora Server installations should have time-synchronization against Fedora's timeservers enabled by default. (+6, 0, -0)
15:34:28 <sgallagh> (that included my implicit +1)
15:34:59 <sgallagh> OK, so now the harder part of the question: We have three options for how to accomplish this, with varying levels of maturity and capability.
15:35:02 <stefw> do we have a good choice on which to enable by default?
15:35:02 <adamw> sgallagh: you want ATOMIC clocks? but think of the children! you're a monster
15:35:03 <mizmo> sorry cubing
15:35:20 <simo> sgallagh: I propose we use chronyd
15:35:29 <simo> it is the current default in Fedora and is mature enough
15:35:43 <simo> has 'some' advantages over ntpd apparently
15:35:51 * danofsatx concurs with chrony
15:36:03 <sgallagh> Before we get too far; has everyone read up on the email thread?
15:36:21 <sgallagh> I'm not sure I want to try to summarize all of the points there.
15:36:38 * danofsatx jsut read it this morning
15:36:41 * stefw has read it yesterday
15:36:47 * nirik has read it
15:36:56 <sgallagh> ok
15:37:00 <adamw> adamw five minutes from now has TOTALLY read it
15:37:03 <adamw> (*reads*)
15:37:39 <sgallagh> My only original reason for going with timesyncd was because we already had it and I was unaware of its limitations compared to ntpd/chronyd.
15:37:48 * simo read 'nuf
15:38:14 <simo> sgallagh: I am totally for the new kids on the block, except when I am not :)
15:38:15 <sgallagh> Given that no one came to its defense on the mailing list, I'm prepared to knock it off the list of contenders, leaving us with the NTP vs. chronyd question. Sensible?
15:38:25 <adamw> on general principles i'd be in favour of sticking with what the project as a whole has been using for years, i.e. chronyd
15:38:37 * nirik is slightly in favor of chronyd also
15:38:38 <adamw> it's fine for products to differ when they have a good reason to, but if we don't, we shouldn't just pick one out of a hat.
15:38:39 <jsmith> Yeah, I feel the same
15:38:50 <sgallagh> Yeah, I'm leaning that way as well, particularly with mlichvar's promises to help add any features we need
15:38:50 * simo nods
15:39:18 <sgallagh> So, does anyone want to make a strong non-chronyd case
15:39:19 <sgallagh> ?
15:39:38 <simo> <crickets>
15:39:41 <sgallagh> Otherwise, I guess we'll call that consensus.
15:39:58 <simo> Proposal: stick with chrony
15:39:59 <simo> +1
15:40:03 <sgallagh> +1
15:40:28 <stefw> +1
15:40:33 <sgallagh> (Where by "stick with" we mean "install it and enable it by default"
15:41:08 <adamw> +1
15:41:13 <sgallagh> danofsatx, mizmo?
15:41:55 <mizmo> so i have a q
15:41:58 <simo> sgallagh: we decided to install and enable with the previous proposal, this one is about which one we go with :)
15:41:59 <mizmo> sorry if its a dumb one
15:42:01 <sgallagh> Go ahead
15:42:09 <sgallagh> simo: Fair enough
15:42:11 <mizmo> if freeipa needs ntpd, does using chrony by default cause any issues / redundancies
15:42:19 <simo> mizmo: no issues
15:42:22 <sgallagh> mizmo: No, FreeIPA long ago handled that
15:42:26 <simo> but you haven;t read the thread
15:42:30 <simo> gotcha :)
15:42:31 <sgallagh> It just installs ntpd and disables chronyd
15:42:39 <mizmo> ah okay
15:42:42 <mizmo> +1 then
15:42:54 <simo> mizmo: we may end up changing freeipa to just use chronyd
15:42:55 <danofsatx> +1
15:43:25 <simo> there is no inherent issue with, we just didn't get around to add configuration for it instead/as well as ntpd
15:43:29 <sgallagh> #agreed Fedora Server will use chronyd by default for time synchronization services (+6, 0, -0)
15:43:40 <sgallagh> #topic Websites Update
15:43:51 <sgallagh> mizmo: You have the floor. (Careful, it's slippery)
15:44:20 <mizmo> lol
15:44:23 <mizmo> okay so two things
15:44:34 <mizmo> #1 the majority of text updates we came up with last meeting are live on the prod site now
15:44:45 <sgallagh> #info the majority of text updates we came up with last meeting are live on the prod site now
15:44:52 <mizmo> #2 i haven't heard back from junland yet about his quote, if i dont hear back do we have a backup plan for a new quote?
15:45:14 <mizmo> (thats the only part of the text updates we came up with that hasn't been updated)
15:45:26 <sgallagh> mizmo: Ask one of our friends or family to speak the quote for us? :)
15:45:37 <adamw> Fedora Server: it's great, like bacon. only I don't eat bacon. But like people have told me bacon is great!
15:45:40 <adamw> there, a new quote for you
15:45:41 <mizmo> authenticity!
15:45:47 <mizmo> no spoon feeding!
15:45:49 <sgallagh> mizmo: We also have the option to use bracket replacement
15:46:01 <sgallagh> Like in newspapers when substituting a more complete noun.
15:46:02 <danofsatx> .fire adamw for not eating bacon
15:46:02 <zodbot> adamw fires adamw for not eating bacon
15:46:03 <mizmo> sgallagh, usually that is with approval of the speaker as well tho
15:46:09 <mizmo> for a product testimonial anyway
15:46:13 <sgallagh> OK
15:46:17 <mizmo> bacon is so 4 years ago
15:46:33 <mizmo> newspapers - well they do what they want :)
15:47:48 <mizmo> well how about this
15:47:53 <mizmo> ill see if i hear from him by next meeting
15:47:57 <sgallagh> mizmo: Perhaps send an email out to the users@ list and ask for people to tell us what cool stuff they're doing with each of the Editions?
15:48:03 <mizmo> if not next meeting we'll talk next meeting about finding another spokesperson?
15:48:04 <sgallagh> (And/or on Magazine)
15:48:11 <mizmo> two weeks seems reasonable right
15:48:21 <mizmo> sgallagh, that seems like a good plan too
15:48:24 <mizmo> ill wait until next week
15:48:25 <sgallagh> We could do this anyway; it never hurts to have extra quotes
15:48:34 <mizmo> has anyone heard from john as of late?
15:48:39 <sgallagh> Worst case, we add a "Testimonials" page
15:48:49 <danofsatx> user@ or server@ - since we're, like, you know, discussing the server page
15:49:14 <sgallagh> danofsatx: Well, not all of our users are subscribed to the server@ list, which is largely a developer audience
15:49:18 <mizmo> oh yes, the users@fpo list is.... not a happy place would stick to server
15:49:39 * mizmo tried asking for 'user' feedback on the new website on users@fpo two websites ago..... never again
15:50:02 <sgallagh> Sure, but maybe Magazine or opensource.com would provide some useful content.
15:50:02 <danofsatx> point taken.
15:50:05 <nirik> there's a lot of crumedgions on there.
15:50:19 <nirik> magazine or perhaps social media? g+ ?
15:50:26 <mizmo> yeh all much better venues
15:50:28 <sgallagh> Most of the people who talk on server@ are engaged in building it
15:50:29 <mizmo> cool thanks guys
15:50:56 <mizmo> maybe what ill do is post to magazine / social media and have a link to the magazine post sent to server for people to refer friends to
15:51:07 <sgallagh> mizmo: +1
15:51:22 <mizmo> well i'm good
15:51:35 <mizmo> anything else on agenda?
15:52:01 <sgallagh> #action mizmo to post to magazine/social media asking for cool uses of Fedora Server (and other Editions)
15:52:26 <sgallagh> #topic Open Floor
15:52:35 <sgallagh> Floor is open, mind the drop.
15:53:16 * danofsatx haz nothing
15:53:33 * simo minds the gap in his mind
15:53:33 <mizmo> oh god now im thinking about the game of thrones kid and his pit
15:54:01 <mizmo> http://acephalous.typepad.com/.a/6a00d8341c2df453ef017c33637be3970b-500wi
15:54:12 <mizmo> "open floor"
15:54:49 <sgallagh> I think that we've come to the edge of rational discussion.
15:55:05 <sgallagh> (And then retreated back into our more familiar irrationality)
15:55:12 <sgallagh> Thanks for coming, folks.
15:55:12 * danofsatx looks for rationality in the backscroll
15:55:14 <simo> hunger
15:55:18 <sgallagh> #endmeeting