i3-sig
LOGS
19:54:58 <defolos> #startmeeting i3-sig
19:54:58 <zodbot> Meeting started Wed Aug 11 19:54:58 2021 UTC.
19:54:58 <zodbot> This meeting is logged and archived in a public location.
19:54:58 <zodbot> The chair is defolos. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:54:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:54:58 <zodbot> The meeting name has been set to 'i3-sig'
19:55:12 <defolos> addchair x3mboy
19:55:24 <odilhao> .chair
19:55:24 <zodbot> odilhao: (chair <an alias, 1 argument>) -- Alias for "echo $1 is seated in a chair with a nice view of a placid lake, unsuspecting that another chair is about to be slammed into them.".
19:55:29 <x3mboy> #chair
19:55:31 <x3mboy> #chair x3mboy
19:55:37 <x3mboy> I think
19:55:40 <odilhao> .chair odilhao
19:55:42 <zodbot> odilhao is seated in a chair with a nice view of a placid lake, unsuspecting that another chair is about to be slammed into them.
19:55:52 <defolos> #chair odilhao
19:55:52 <zodbot> Current chairs: defolos odilhao
19:55:59 <defolos> #chair x3mboy
19:55:59 <zodbot> Current chairs: defolos odilhao x3mboy
19:56:07 <defolos> .hello2
19:56:08 <zodbot> defolos: defolos 'Dan Čermák' <dan.cermak@cgc-instruments.com>
19:56:27 <defolos> let's wait a bit in case anyone else shows up
19:57:57 <x3mboy> Ok
19:58:00 <x3mboy> .hello3
19:58:04 <x3mboy> .hello2
19:58:05 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
19:58:06 <x3mboy> Ooops
19:58:33 <defolos> kcwitt: ping meeting
19:58:40 <defolos> .fasinfo kcwitt
19:58:41 <zodbot> defolos: User: kcwitt, Name: None, email: kcwitt@gmail.com, Creation: 2021-01-14, IRC Nick: None, Timezone: None, Locale: None, GPG key ID: None, Status: active
19:58:44 <zodbot> defolos: Approved Groups: i3-sig cla_done cla_fpca
19:59:44 <odilhao> .hello2
19:59:45 <zodbot> odilhao: odilhao 'Odilon Junior' <odilon.junior93@gmail.com>
20:00:44 <kcwitt> hello
20:01:56 <defolos> 👋
20:02:06 <defolos> if you want to join the meeting type `.hello2`
20:02:23 <kcwitt> .hello2
20:02:24 <zodbot> kcwitt: kcwitt 'None' <kcwitt@gmail.com>
20:02:48 <defolos> Hello nameless ;-)
20:03:42 <defolos> well, let's get started
20:03:50 <defolos> we have quite the issue backlog on pagure
20:04:19 <defolos> I've picked a few that I thought are probably most important
20:04:44 <defolos> #topic Creation of traditional user directories
20:04:59 <defolos> #link https://pagure.io/i3-sig/Fedora-i3-Spin/issue/26
20:05:47 <defolos> hm, why is that not working?
20:06:25 <defolos> #chair defolos
20:06:25 <zodbot> Current chairs: defolos odilhao x3mboy
20:06:47 <defolos> #meetingtopic i3 SIG meeting
20:06:58 <kcwitt> I think we definately need a simple document to go along with the spin - there are too many deviations from a traditional desktop environment to not have any explinion. I suggest just noting the typical directories in this document and showing the user how to create them if they want.
20:07:16 <x3mboy> Topic is one of the weirdier, sometimes it works, sometimes it doesn't
20:07:39 <defolos> oh well, let's go without #topic then 🤷
20:08:37 <defolos> ok, so we do want the traditional user directories
20:08:50 <defolos> now, how do we create them properly?
20:09:29 <odilhao> #listmeetings
20:09:34 <x3mboy> xdg-user-dirs-update
20:09:35 <x3mboy> ?
20:10:21 <odilhao> x3mboy, the command is correct, and if we want a custom layout, we need to add some variables in a file at ~/.config/user-dirs.dirs
20:10:46 <odilhao> or at file in /etc/ for a global config
20:11:06 <odilhao> #recent
20:11:08 <kcwitt> I don't think of i3 as a minimilist window manager - I think of it as a "fit for purpose" window manager (ie. a minimal base for the end user to make fit for their purpose). In this way, if there is an `xdg-user-dirs-update` script we should let the end user run it deliberately.
20:11:50 <kcwitt> I should say "fit for purpose - and extremely performant"
20:11:57 <defolos> will xdg-user-dirs-update blow up if you already have the directories in place?
20:12:16 <odilhao> defolos, I don't know, let me run here
20:12:22 <x3mboy> I just run it, it doesn't give error or anything (my dirs are created)
20:12:29 <x3mboy> s/run/ran/g
20:12:37 <odilhao> x3mboy++
20:12:38 <zodbot> odilhao: Karma for x3mboy changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
20:13:23 <x3mboy> kcwitt: If you install the packages yes, but if you use the spin, no. I'm totally on favor of create them
20:13:37 <zodbot> odilhao: Error: Can't start another meeting, one is in progress.
20:13:40 <x3mboy> It's easier to a power user to delete them than to a normal user created them
20:14:26 <kcwitt> What I mean is that (for me) the purpose of the spin is to have the most minimal base. It is very different than installing gnome and then switching to i3 - people can already do that without the spin at all.
20:14:39 <odilhao> I agree with x3mboy, from a livecd POV, if someone that never used i3 looks at Thunar and theres nothing, it will be weird
20:15:10 <defolos> we could add an invocation of xdg-user-dirs-update to the Fedora branded i3 config
20:15:20 <x3mboy> +1
20:15:21 <defolos> power users will bring their own config and will not get this at all
20:16:29 <defolos> any objections to doing that?
20:16:44 <kcwitt> I guess it comes down to whether the goal is to produce an i3 spin that requires no additional explination (ie. works for a new user out of the box), or to provide a spin with some additinal explination. I am in favor of deliberately providing extra explination because the first five times I tried i3 I gave up on it because I didn't think it was installed correctly (I just didn't understand what
20:16:46 <kcwitt> it was).
20:17:22 <defolos> kcwitt: we also have a welcome app in the pipeline
20:17:34 <kcwitt> ok
20:17:36 <defolos> but it just explains how you navigate around in i3
20:17:52 <defolos> and how you can exit it, you'll have to read the docs yourself
20:18:28 <kcwitt> earlier a sent a markdown document to the mailing list with the customizations I made to i3 after I installed it. I didn't really mean for those items to be implemented in the spin - I more meant it as an example document to accompany the spin.
20:18:30 <defolos> I'll propose the current idea in the pagure ticket and unless anyone screams, I'll implement it
20:18:30 <x3mboy> how you can exit it <- we don't want to be the next most asked question in stackoverflow
20:18:38 <x3mboy> Great!
20:18:44 <x3mboy> defolos++
20:19:37 <defolos> #agreed defolos to comment on https://pagure.io/i3-sig/Fedora-i3-Spin/issue/26 and propose to add xdg-user-dirs-update to the fedora branded i3 config
20:19:56 <defolos> hm, so much for agreed…
20:20:13 <defolos> next thing: https://pagure.io/i3-sig/Fedora-i3-Spin/issue/55
20:20:22 <defolos> screen locking via xss-lock
20:20:38 <defolos> tl;dr; the user was complaining that loginctl cannot lock the i3 session
20:20:56 <defolos> this can be fixed by executing i3-lock via xss-lock
20:21:28 <defolos> same possible solution as with xdg-user-dirs-update: add the invocation to the fedora branded config
20:21:43 <x3mboy> +1
20:21:57 <defolos> that has the added benefit, that `xset s off -dpms` actually turns off the screen lock
20:22:16 <defolos> it has the downside that xss-lock is effectively abandoned…
20:22:17 <odilhao> +1
20:23:23 <x3mboy> But is still packaged?
20:23:23 <odilhao> defolos, do we have any alternative for xss-lock? I think all lock binaries that I've used for i3wm used xss-lock
20:23:41 <x3mboy> We can ship on F35 and research how to make loginctl to properly work on i3 for F36
20:23:41 <defolos> x3mboy: it is
20:24:09 <defolos> odilhao: none that I am aware off
20:24:11 <defolos> x3mboy: sounds good to me
20:25:11 <x3mboy> I have a dummy question
20:25:13 <kcwitt> i believe something has to listen to loginctl for the lock signal - but i3lock only runs when the lock is activated (ie. it doesn't listen). that is why xss-lock is needed
20:25:16 <defolos> I'll drop a note on the pagure ticket then
20:25:21 <x3mboy> This is for automating locking?
20:25:27 <kcwitt> any locking
20:25:36 <defolos> yes
20:25:49 <kcwitt> all locking should start with loginctl, which will then notify the actual widgets to enact the lock
20:26:01 <x3mboy> Because I use i3-lock, i3lock-color and i3lock-fancy
20:26:04 <kcwitt> including lid, power button, ctl, etc.
20:26:07 <x3mboy> No need on anything
20:26:25 <kcwitt> x3mboy: yes, you can run i3lock directly, but how about catching the power button, lid, etc.
20:26:58 <defolos> xss-lock listens to all types of events dispatched by systemd as kcwitt said
20:27:12 <defolos> and will then run the locker, when appropriate
20:27:37 <defolos> but it also respects your screen dimming timeouts set by xset s on/off
20:28:05 <x3mboy> Ahhh
20:28:07 <x3mboy> That makes sense
20:28:15 <x3mboy> I don't want that, so I let that to you
20:28:19 <x3mboy> I will disable it for me
20:28:41 <defolos> you won't get it anyway, because you have your own config file
20:28:42 <x3mboy> I love to close my laptop and torrents still transfer and everything continue working
20:28:43 <x3mboy> :D
20:29:20 <defolos> the nice thing about sneaking this in via the fedora config is that power users will not receive these changes
20:29:25 <defolos> only newcommers
20:30:10 <defolos> ok, so next are some package group suggestions from https://pagure.io/i3-sig/Fedora-i3-Spin/issue/60 and https://pagure.io/i3-sig/Fedora-i3-Spin/issue/64
20:31:06 <kcwitt> x3mboy: a bit off-topic; but I think the most idiomatic way to ignore the lid closing is to put an override in the '/etc/systemd/logind.conf.d/' directory to ignore the lid switch (and then you can still let loginctl do all the other things it is meant to do)
20:31:07 <x3mboy> I commented on 60
20:31:37 <odilhao> For me LibreOffice can be installed directly, without a sub-package
20:32:31 <odilhao> If the user want Libreoffice, he can install with DNF, we could mention this in the welcome app, like Most used Programs and how to install
20:32:34 <x3mboy> And there is a Package Group for it too
20:32:59 <defolos> yeah, I don't fancy dragging in LibreOffice
20:33:04 <x3mboy> LibreOffice (libreoffice)
20:33:20 <x3mboy> odilhao: +1
20:33:47 <defolos> odilhao: I don't think that this is really something for the welcome app
20:34:01 <defolos> it should be i3 specific not "this is how you install stuff"
20:34:13 <defolos> at least imho
20:34:13 <odilhao> defolos, true
20:34:54 <x3mboy> Also true
20:35:04 <kcwitt> defolos: yes, but - it would make sense to "curate" a list of packages that would encompass a complete desktop environment which work well with i3 and together
20:35:15 <x3mboy> Maybe a mention in the i3 docs pointing to the docs
20:35:48 <kcwitt> just suggestions for new users who are used to having everything already in their desktop environment - this was one of the issues that delayed my embracing i3
20:35:59 <defolos> hm
20:36:14 <defolos> you have a point there
20:36:23 <defolos> plus I always install libreoffice anyway
20:36:51 <defolos> would anyone take a look at the other editions & spins and find out how they handle office suites?
20:37:59 <defolos> flameshot from issue 60 looks pretty cool
20:38:01 <x3mboy> I will
20:38:04 <x3mboy> Action me
20:38:06 <defolos> thanks!
20:38:17 <x3mboy> flameshot?
20:38:23 <kcwitt> I definately vote against including anything directly in the spin, but definately vote for making suggestions for those who need them
20:38:38 <defolos> #action x3mboy to look into how other spins handle office suites
20:39:01 <defolos> kcwitt: eh, how is that supposed to work?
20:39:23 <defolos> I mean either libreoffice is in the installation iso or it is not
20:40:08 <x3mboy> I think is not needed
20:40:09 <kcwitt> defolos: it is not, but we provide a document listing a 'recommended' screenshot app, office suite, scanner app, etc.
20:40:32 <x3mboy> import do the work
20:40:46 <x3mboy> flameshot, I mean
20:40:52 <kcwitt> it took me a long time to figure out that the name of the scanner app from the default fedora app was the 'simple scanner' package - we could some future users some time
20:41:07 <defolos> ah
20:41:35 <defolos> I mean we could create another package group as x3mboy suggested in issue 60
20:41:55 * x3mboy < https://libera.ems.host/_matrix/media/r0/download/libera.chat/3bb0debfc9dd4b16f097c7e92d33ac8226535979/message.txt >
20:42:05 <defolos> one that includes all the "fat" end user applications like LibreOffice, inkscape, etc
20:42:15 <x3mboy> Are we shipping ImageMagick?
20:42:33 <kcwitt> I don't suggest to "obfuscate" the details behind a package group - that is part of the reason it took me so long to realize the pdf reader was `evince` - let's just say if you want to read pdf files install `evince`
20:42:34 <defolos> x3mboy: duno, but import is hardly convenient to use for newcommers
20:43:06 <x3mboy> Ok, it makes sense
20:43:23 <x3mboy> I was a superfan of Shutter, but I think is broken or abandoned
20:43:24 <defolos> kcwitt: so essentially document this stuff better then?
20:43:37 <x3mboy> So, the flame think sounds ok
20:44:14 <kcwitt> somewhere in the i3 documentation they discuss the distinction between a "desktop environment" and a "window manager", and then go on to say they are ONLY a "window manager" and don't aspire to be a "desktop environment" - I suggest we do the same (but give the end user guidance in the form of documentation how to make their custom fit for purpose "desktop environment").
20:44:48 <defolos> well… we kinda try to be a desktop environment
20:45:04 <defolos> that's the whole point of a Spin
20:45:13 <kcwitt> defolos: could be - but we could also be a desktop environment "framework"
20:45:39 <x3mboy> We are trying to give a better experience than only installing i3
20:45:46 <defolos> kcwitt: but then there is absolutely no reason to use the spin in contrast to grabing fedora minimal and installing i3
20:45:56 <x3mboy> That's the whole point of having a Spin
20:47:26 <kcwitt> i hadn't ever thought of starting with minimilist. But in the past I started with the default Gnome version, and then added i3 (which was very bloated for what I wanted). To me the spin solved this bloat problem - but adding lots of stuff back into it can make it bloated again.
20:48:03 <kcwitt> If we include things like xrdb and xss-lock it is more than the minimilist spin with i3.
20:48:27 <kcwitt> But I don't really see a need to provide much other stuff that any user can simple add with a `dnf install ...` command
20:48:28 <defolos> certainly, but I would hardly call that bloated
20:48:58 <odilhao> kcwitt, we have the minimal-package group, users can always look at the minimal-i3-package-group and remove the rest, or install from a minimal iso
20:49:38 <x3mboy> Also, we are still smaller than other distros i3 flavors
20:49:39 <defolos> kcwitt: well, one of the spin's goals is to provide sensible defaults for the most used applications
20:49:39 <x3mboy> Like Manjaro and regolith
20:49:45 <kcwitt> removing things is anathema to me (better to never have had them)
20:50:54 <defolos> kcwitt: then fedora-minimal might be the thing for you
20:51:22 <defolos> since it's getting late
20:51:28 <kcwitt> but fedora-minimal would not have xrdb and xss-lock, etc.
20:51:37 <defolos> no
20:51:44 <defolos> but you could dnf install that…
20:51:56 <defolos> as you wrote further above
20:52:26 <kcwitt> I don't want to belabor the point, but a user will know if the office suite is not installed - but the average user would have no idea to install xss-lock to fix the computer not locking issue
20:53:06 <kcwitt> the user would know `dnf install libreoffice` but would not know `dnf install xss-lock`
20:53:27 <defolos> That's true, but will the average user expect a screenshot tool to be present or not?
20:53:34 <defolos> (that's an honest question)
20:53:45 <kcwitt> another issue is compton (compositor) - MS Teams can't screen share without a screen compositor - I think this is something that should be addressed by the spin
20:54:09 <defolos> eh
20:54:12 <kcwitt> defolos: regarding screenshot - I suggest we address that in a document with our list of "recommended" apps
20:54:17 <defolos> it works on my machine…
20:54:20 <x3mboy> kcwitt: That's not tru4e
20:54:21 <x3mboy> > <@kcwitt:libera.chat> another issue is compton (compositor) - MS Teams can't screen share without a screen compositor - I think this is something that should be addressed by the spin
20:54:21 <x3mboy> * That's not true
20:54:35 <x3mboy> I use screenshare, and I don't have a compositor
20:54:35 <kcwitt> but I am not against including screenshot
20:54:36 <defolos> I can screenshare in Teams & Jitsi without any issues
20:54:50 <x3mboy> flameshot +1
20:55:02 <x3mboy> compton -1 (deprecated)
20:55:07 <kcwitt> defolos: oh, cool - last year I had an issue with teams and fixed it by running compton
20:55:14 <x3mboy> picom -1 (no need for a compositor)
20:55:31 <x3mboy> kcwitt: The error was the black screen with the red border
20:55:35 <kcwitt> yes
20:55:38 <odilhao> I'm able to screenshare on Teams without a compositor, the problem is that it requires Chromium
20:55:46 <x3mboy> It wasn't related to the compositor, was just a file that you need to move
20:56:20 <defolos> huh, never encountered that
20:56:20 <kcwitt> x3mboy: that was the css file that added the red border - (which required a compositor to show it)
20:56:25 <x3mboy> sudo mv /usr/share/teams/resources/app.asar.unpacked/node_modules/slimcore/bin/rect-overlay /usr/share/teams/resources/app.asar.unpacked/node_modules/slimcore/bin/rect-overlay.bkp
20:56:40 <x3mboy> * ```
20:56:40 <x3mboy> sudo mv /usr/share/teams/resources/app.asar.unpacked/node_modules/slimcore/bin/rect-overlay /usr/share/teams/resources/app.asar.unpacked/node_modules/slimcore/bin/rect-overlay.bkp
20:56:40 <x3mboy> ```
20:56:48 * defolos is using the teams flatpak or from chromium
20:56:58 * defolos is not putting that junk directly on the system
20:57:03 <x3mboy> I'm using the rpm fomr MS repos
20:57:13 <x3mboy> * I'm using the rpm from MS repos
20:57:32 <x3mboy> It's the work laptop, not personal laptop
20:57:39 <x3mboy> In my personal laptop I don't use team
20:57:40 <x3mboy> * In my personal laptop I don't use teams
20:57:59 <defolos> since it's getting to the top of the hour: please comment on the respective issues about the other suggestions
20:58:15 <defolos> last: what should the new default terminal be?
20:58:15 <kcwitt> is teams the only software that a user might want to use that uses composite windows? (in teams case it is the red rectangle that is composited over the screen)
20:58:20 <kcwitt> st
20:58:49 <defolos> In principle I'm in favor of that, but st sucks to configure
20:59:04 <defolos> and it has no scrollback which will annoy the heck out of newcommers
20:59:04 <x3mboy> I was thinking in package a .Xresources for urxvt
20:59:07 <x3mboy> wdyt?
20:59:07 <kcwitt> there isn't really any configuration - but it does work out of the box and looks presentable
20:59:40 <defolos> x3mboy: can you put a .xresources outside of $HOME?
20:59:41 <kcwitt> x3mboy: urxvt has some sort of issue where it can't show powerline fonts (to make the goofy symbols in the `vim` status bar)
20:59:46 <odilhao> x3mboy, just to use our color scheme?
20:59:47 * x3mboy uploaded an image: (30KiB) < https://libera.ems.host/_matrix/media/r0/download/matrix.org/wKgZWefhJVLYedqxZPOzLqVl/image.png >
20:59:57 <x3mboy> That's my urxvt
21:00:13 <x3mboy> I don't use it, but it looks way nicer than the default
21:00:29 <x3mboy> defolos: Not sure
21:01:16 <kcwitt> defolos: yes; per the st docs use tmux to provide scrollback
21:01:58 <defolos> kcwitt: yeah, but the new user does not know that
21:02:11 <kcwitt> my i3 config has the line 'bindsym $mod+Return exec st -e tmux'
21:02:19 <defolos> and tmux is not exactly obvious to use either
21:02:35 <x3mboy> Well, need to discuss that
21:02:39 <kcwitt> (again I suggest that we should add some auxiliary docs for new users describing some of this stuff)
21:02:45 <x3mboy> I'm not in favor of st, it's way too minimalist
21:03:05 <kcwitt> I don't think an i3 spin will ever be completely intuitive to new users the way that the default gnome environment is
21:03:13 <defolos> obviously
21:03:22 <x3mboy> And the problem with alacritty and kitty is that they use GPU acceleration
21:03:40 <x3mboy> What about xfce4-terminal?
21:03:49 <kcwitt> I really like xfce4-terminal
21:04:01 <x3mboy> I used to love tilix, but the giant gtk3 bar is aweful, it hurt my eyes
21:04:19 <defolos> xfce4-terminal looks ok
21:04:29 <kcwitt> xfte4-terminal has both very easy font scaling, and color schemes, and utf8 capability
21:04:44 <odilhao> +1 for xfce4-terminal
21:04:45 <defolos> I guess most power users will use their favorite anyway
21:04:53 <defolos> heh, that was simple
21:05:01 <defolos> so let's go with xfce4-terminal
21:05:13 <x3mboy> agreed then
21:05:14 <defolos> #agreed let's go with xfce4-terminal
21:05:25 <x3mboy> That was fastrer than I though
21:05:25 <defolos> before anyone objects 😛
21:05:27 <x3mboy> :D
21:05:29 <odilhao> Friday in on PTO, I can work on the PR for comps
21:05:32 <kcwitt> then it is important urxvt is NOT installed, otherwise it will have higher precedence in i3-sensible-terminal
21:05:41 <odilhao> s/in/im
21:05:44 <defolos> urgh
21:05:44 <x3mboy> Sure
21:06:16 <defolos> #note defolos to remove the suggests/recommends urxvt from i3
21:06:36 <defolos> okidoke, that covers it and we're only 7 minutes over time
21:06:43 <defolos> #endmeeting