hubs-devel
LOGS
14:05:32 <sayan> #startmeeting hubs-devel
14:05:32 <zodbot> Meeting started Tue Oct 24 14:05:32 2017 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:05:32 <zodbot> The meeting name has been set to 'hubs-devel'
14:06:01 <sayan> #topic Roll Call
14:06:30 <mizmo> .hello duffy
14:06:31 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
14:06:42 <sayan> .hello sayanchowdhury
14:06:43 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:06:50 <abompard> .hello2
14:06:51 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
14:09:05 <sayan> #chair mizmo abompard
14:09:05 <zodbot> Current chairs: abompard mizmo sayan
14:09:19 <sayan> #topic Action Items from last meeting
14:09:35 <sayan> * mizmo to upstream relevant fedora-bootstrap classes from patternlab
14:09:37 <sayan> * mizmo working on search designs for outreachy project
14:09:39 <sayan> * mizmo working on hubs devel bounties, to be posted after outreachy
14:09:41 <sayan> application period closes
14:10:44 <mizmo> i worked with ryanlerch on the fedora-bootstrap PR today, i made some edits with his feedback, i got the ok and the admin rights to merge so ill do that now actually
14:11:15 <mizmo> so we'll want to deploy & pull down the new fedora bootstrap for hubs
14:11:15 <sayan> #link https://pagure.io/fedora-bootstrap/pull-request/9
14:11:26 <mizmo> theres some css imports we'll need for the fonts too
14:11:46 <mizmo> i haven't picked up the search designs lately, need to do that
14:11:51 <mizmo> also need to work on the bounties, have not started
14:12:02 <sayan> Okay, I will reaction them
14:12:16 <mizmo> oh and it doesnt appear to be an action item but i did put together the riot.im integration mockups which we talked about last meeting
14:12:37 <mizmo> thats the one we were talkinga bout before the mtg, https://pagure.io/fedora-hubs/issue/409
14:12:55 <sayan> mizmo: the outreachy deadline for application is passed, right?
14:13:21 <sayan> #action mizmo working on search designs for outreachy project
14:13:36 <sayan> #action mizmo working on hubs devel bounties, to be posted after outreachy application period closes
14:13:42 <mizmo> sayan: no not closed yet, oct 30
14:14:21 <abompard> mizmo, sayan: the website says that the application deadline was Oct 23
14:14:35 <abompard> https://outreachy.gnome.org
14:14:38 <sayan> Yes, Oct 23 is what I knew
14:15:09 <sayan> but I got to know from a applicant of other org that their deadline was Oct 30
14:15:09 <mizmo> oh, i guess only a few projects extended
14:15:19 <sayan> Okay
14:15:21 <mizmo> sorry i saw extended deadline of oct 30 somewhere
14:15:26 <mizmo> thought it was outreachy wide
14:15:29 <mizmo> how are we doing with the applicants
14:16:24 <abompard> mizmo: we have two strong applicants, shaily and Anar
14:16:40 <abompard> So I think it's on a good track
14:16:44 <mizmo> ok great :)
14:16:59 <sayan> cool :)
14:17:32 <sayan> #topic IRC Widget
14:17:59 <sayan> #link https://pagure.io/fedora-hubs/issue/409
14:18:26 <sayan> abompard: did you see the mockup?
14:18:47 <abompard> sayan: not yet but I'm going to in a couple seconds
14:19:26 <abompard> so, the config is already done
14:19:31 <abompard> but, there's a major but
14:19:39 <shaily> hi! sorry i'm late
14:19:47 <sayan> #chair shaily
14:19:47 <zodbot> Current chairs: abompard mizmo sayan shaily
14:19:49 <abompard> the preview of the channel isn't as easily available as we thought
14:19:50 <sayan> shaily: hi :)
14:19:54 <abompard> hey shaily  :)
14:20:10 <abompard> basically on view.matrix.org there's no Freenode channel
14:20:34 <sayan> Freenode channel or network?
14:20:38 <abompard> because they are set with a permission that show history to channel members only
14:20:51 <mizmo> that can be changed tho right abompard
14:21:01 <abompard> any matrix room auto-created from a freenode channel isn't there
14:21:03 <abompard> mizmo: I asked
14:21:05 <mizmo> hubs is set to Anyone who knows the room's link, apart from guests
14:21:12 <mizmo> this channel we're in now
14:21:28 <abompard> mizmo: yeah it must be set to allow guests
14:21:37 <abompard> basically the history must be set public
14:21:56 <abompard> and I don't think anyone in the channel can do that, it looks like it's an admin operation
14:22:40 <mizmo> abompard: i wonder if simlar to how we own the #fedora namespace on freenode, could the matrix home server admins grant us admin access to the #fedora irc channels on matrix
14:23:11 <abompard> mizmo: that'd be cool, but I know they are very reluctant to give admin rights, because they can't take them away afterwards
14:23:19 <abompard> the admin has to give them up
14:23:48 <mizmo> so would we have to create new matrix.org HS rooms and map the freenode channels to them manually
14:23:51 <mizmo> ?
14:24:09 <abompard> mizmo: they recommand creating a new room and adding the irc bridge manually
14:24:22 <mizmo> ok thats not difficult
14:24:32 <mizmo> but it would change the naming scheme, we could come up with what we want for that though
14:24:41 <mizmo> since we're creating them
14:24:44 <Anar> Hi everyone, my name is Anar. I'm an applicant of an Outreachy program for fedora-hubs. abompard invited me to participate in order to get more involved. And I can't see the history of this channel too, if that's what you are talking about.
14:24:46 <abompard> but that means that two rooms will be linked to the IRC chatroom, it may be confusing to create which one
14:24:56 <abompard> Hey Anar
14:25:09 <mizmo> the matrix bridge created ones are the format #freenode_#fedora-blah:matrix.org
14:25:14 <abompard> confusing to *find* which one
14:25:17 <mizmo> we could create ones that basically removed the #freenode_ in the beginning
14:25:36 <abompard> mizmo: we could do that, yeah, but it probably has to be automatic, right?
14:25:46 <mizmo> theres an api to do it IIRC
14:25:48 <abompard> I'm kind of afraid it'll create a mess
14:26:11 <mizmo> im pretty sure they can be deleted too if there is a mess
14:26:54 <mizmo> (does that make sense? or am i missing it?)
14:27:07 <abompard> yeah probably. The other solution that the creator of the view.matrix.org generator proposed is to add a new feature to that generator, make it subscribe to the channel, so it can get the history without it being public
14:27:35 <mizmo> that seems kind of wrong though, from the pov of the admin setting their channel to public, and expecting a certain behavior
14:27:42 <mizmo> er not setting their channel to public
14:27:58 <abompard> mizmo: yeah that's right
14:28:26 <abompard> I looked into the matrix REST API but didn't find a way to add IRC integration to a room
14:28:37 <abompard> maybe it's just I didn't find it
14:28:46 <abompard> after all Riot must be using some kind of api
14:29:48 <mizmo> hmm
14:30:59 <abompard> sayan: since you're the backend guy, wanna check out if we can create rooms and bridge IRC automatically?
14:31:31 <sayan> abompard: yeah, I can look into that
14:31:37 <abompard> cool :)
14:32:00 <mizmo> so to bridge irc you have to interact with the IRC application service bot i think
14:32:56 <abompard> by the way if there's a way to get the channel history, we may want to use that to generate the channel preview.
14:33:07 <abompard> and not rely on view.matrix.org at all
14:34:13 <mizmo> get /_matrix/client/r0/rooms/{roomId}/messages
14:34:35 <mizmo> https://matrix.org/docs/api/client-server/#!/Room32participation/get_matrix_client_r0_rooms_roomId_messages
14:34:38 <abompard> right.
14:35:00 <mizmo> that doesnt rely on view.matrix does it?
14:35:58 <abompard> mizmo: nope, I think it's the other way around
14:36:26 <abompard> so all we need is to have a room with public history bridged to the configured channel
14:37:19 <mizmo> i think the bridging would have to go thru @appservice-irc:matrix.org but im unclear how to do that as of yet
14:39:06 <abompard> OK, sayan are you still OK to split the work in you doing the backend and me doing the frontend?
14:39:36 <abompard> if you think it's unfair or you would prefer differently please speak up :)
14:40:26 <sayan> abompard: yeah, that's totally fine, but it should not be a very strict restriction
14:40:40 <abompard> sayan: sure
14:41:48 <sayan> abompard: mizmo: just to clarify we are using the matrix home server, right?
14:41:58 <abompard> I think so yeah
14:42:03 <mizmo> yeh
14:42:48 <sayan> Okay
14:45:07 <sayan> abompard: mizmo: anything else to discuss?
14:45:50 * mizmo has nothing
14:45:59 <abompard> nope :)
14:46:26 <abompard> thanks for the mockups mizmo :)
14:46:39 <mizmo> npp :)
14:47:15 <sayan> #action sayan to check out on how to create rooms and bridge IRC in matrix automatically
14:47:37 <sayan> shaily: Anar: you have something to discuss?
14:48:19 <Anar> sayan: nope
14:48:44 <sayan> Cool
14:48:52 <sayan> closing the meeting in
14:48:54 <sayan> 3.
14:48:56 <sayan> 2.
14:48:58 <sayan> 1.
14:49:00 <sayan> #endmeeting