hubs-devel
LOGS
14:02:12 <sayan> #startmeeting hubs-devel
14:02:12 <zodbot> Meeting started Tue Oct 17 14:02:12 2017 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:12 <zodbot> The meeting name has been set to 'hubs-devel'
14:02:17 <sayan> #topic Roll Call
14:02:22 <sayan> .hello sayanchowdhury
14:02:23 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
14:02:41 <shaily> .hello shaily
14:02:42 <zodbot> shaily: shaily 'None' <shaily15297@yahoo.com>
14:02:54 <abompard> .hello2
14:02:54 <shillman> .hello wispfox
14:02:58 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
14:03:01 <zodbot> shillman: wispfox 'Suzanne Hillman' <wispfox@gmail.com>
14:03:23 <jonatoni> .hello2
14:03:24 <zodbot> jonatoni: jonatoni 'Jona Azizaj' <jonaazizaj@gmail.com>
14:03:29 <sayan> #chair abompard shillman shaily mizmo jonatoni
14:03:29 <zodbot> Current chairs: abompard jonatoni mizmo sayan shaily shillman
14:03:40 <sayan> hope I did not miss anybody there
14:04:03 * sayan waits for sometime
14:05:23 <sayan> #topic Action items from last meeting
14:05:29 <sayan> Action Items
14:05:32 <sayan> ------------
14:05:34 <sayan> * mizmo working on hubs devel bounties, to be posted after outreachy
14:05:36 <sayan> application period closes
14:05:38 <sayan> * mizmo working on search designs for outreachy project
14:05:40 <sayan> * abompard find a way to have textareas in the widget configuration
14:05:42 <sayan> panel without having to write a React widget
14:06:04 <sayan> ^^ updates?
14:06:13 <abompard> since mizmo will be a little late I can start
14:06:39 <abompard> I have pushed a PR to have more evolved input tags in the config dialog for simple widgets
14:06:59 <abompard> and it has been merged
14:07:07 <abompard> (https://pagure.io/fedora-hubs/pull-request/401)
14:07:11 * mizmo here now
14:07:35 * mizmo has no updates, was out last week
14:08:08 <abompard> so shaily you can use the new render_tag and render_type attributes of the WidgetParameter class
14:08:17 <abompard> to generate a textarea
14:08:25 <mizmo> abompard: is there a limit to the tag types you can use
14:08:47 <abompard> yeah you can only override the tag and / or the "type" attribute of input tags
14:08:57 <shaily> i did. it looks a little weird though
14:09:07 <abompard> if you want more then for now you'll have to create a react-based widget
14:09:16 <abompard> shaily: how so?
14:09:47 <shaily> so we want to use it for markdown, and the default number of rows is too less. i practically had to type it somewhere else and paste it because i couldn't see the whole thing without scrolling
14:10:02 <abompard> oh
14:10:49 <abompard> so you'll want to set more attributes. I had sort of thought of it but went for simpler. I guess those two parameters are not enough
14:11:06 <abompard> OK I'll find something more versatile
14:11:24 <shaily> i guess something like a key value list for more attributes
14:11:31 <sayan> but the textarea follows the text, right?
14:11:48 <shaily> follows, as in?
14:12:08 <sayan> I mean the cursor is at the end, so you can see what you are typing
14:12:21 <shaily> yeah, wait i'll post a screenshot
14:12:31 <sayan> shaily: that would be good
14:14:09 <shaily> default: https://i.imgur.com/L0yUnqG.png
14:14:20 <shaily> after using the handle at the bottom right to increase the size: https://i.imgur.com/TJsZy2f.png
14:15:02 <shaily> that could work, but i think it's possible to specify the rows attribute by adding more parameters (possibly a list, as mentioned above) to WidgetParameters
14:16:26 <shaily> like having the user to increase the size every time is kind of cumbersome when we know that it needs to be larger
14:16:44 <sayan> no, afaik, the scrollbar is always in the bottom
14:16:44 <mizmo> shaily: couldn't you set a larger default size via CSS
14:17:13 <shaily> oh, is it okay if i add a global style rule.. for all textarea elements?
14:17:31 <mizmo> should be wider too
14:17:43 <mizmo> shaily: no dont make it global
14:18:10 <mizmo> i would make a specific class for this, since it's an editor, maybe name the class textarea-editor or smtg like that
14:19:03 <sayan> shaily: can you add a overflow: scroll and see if it appears okay?
14:19:27 <sayan> shaily: yeah, don't apply globally, add a class
14:19:30 <mizmo> isnt overflow scroll the default?
14:20:00 <shaily> its on overflow: auto;
14:20:06 <shaily> and it is scrolling at that
14:20:20 <sayan> mizmo: yes
14:21:05 <sayan> shaily: just to be clear on my side, when you are typing stuffs in the textarea, you have to increase the height of the textarea to see the text?
14:21:16 <sayan> the text that is in the bottom
14:21:37 <shaily> sayan: no
14:22:04 <mizmo> sayan: i think the issue is that the textarea default size is too small (width and height)
14:22:13 <mizmo> i dont see a scrolling issue in the screenshots?
14:22:25 <sayan> ah ok
14:22:54 <mizmo> shaily: dont be afraid to made the text area wider, too. the modal should be able to handle it (if not it's a bug)
14:23:01 <sayan> in that case, we can make the default size a bit bigger
14:23:17 <sayan> ^^ for that modal
14:23:42 <mizmo> im wondering why it's showing up that small by default, where that size is inherited from
14:24:21 <sayan> height and width of the modal
14:25:05 <mizmo> the text area is set as a % by default?
14:26:12 <sayan> need to check that
14:26:36 <mizmo> anything else on this topic?
14:26:56 <shaily> yeah 1 sec
14:27:23 <shaily> btw the modal didn't increase in width - https://i.imgur.com/7jzLAhj.png
14:28:04 <shaily> also, i'm done with adding markdown to the sticky widget, but on the frontend it isn't really rendering how we would it to because there are no classes applied to it
14:28:32 <mizmo> shaily: ok we should figure out why moda lisn't increasing in width and fix
14:28:39 <mizmo> can you file a ticket for that?
14:28:46 <shaily> the lists don't look like lists because of the rules in style-patternlab.css
14:29:00 <shaily> i guess i'll have to modify the markdown parser to add bootstrap classes to the elements
14:29:05 <shaily> mizmo: okay, i'll do that
14:29:21 <mizmo> shaily: do you have the specific patternlab style thats problematic handy?
14:29:28 <abompard> mizmo: do we want to keep the patternlab css?
14:29:45 <shaily> https://i.imgur.com/NxyYj6L.png
14:30:07 <mizmo> abompard: yeh, the patternlab CSS is basically fedora bootstrap
14:30:49 <abompard> mizmo: oh ok, because it adds quite a few things on top of fedora-bootstrap, for example the alert boxes are animated in patternlab but not in F-B
14:31:21 <shaily> i guess we could work around this by having the markdown parser add bootstrap classes by default
14:31:23 <mizmo> abompard: yeh it does - so the parts we dont need are the parts that are used for the patternlab website itself...
14:31:43 <mizmo> abompard: i think - i think what i will do - i'll 'upstream' the new fedora bootstrap classes into fedora bootstrap itself, and we drop the patternlab css for now
14:31:54 <mizmo> abompard: then we wont have all the patternlab crap to deal with
14:32:11 <mizmo> shaily: would you mind making the commit to remove the patternlab css?
14:32:41 <shaily> sure, i'll do it. we want to completely remove patternlab, right?
14:32:56 <abompard> #action mizmo to upstream relevant fedora-bootstrap classes from patternlab
14:33:00 <mizmo> i'll make an issue under fedora-bootstrap's pagure to move the new pattern classes into upstream fedora bootstrap. i dont know how we will get the new ones though, i dont know how new versions of fedora bootstrap get deployed
14:33:08 <mizmo> shaily: yeh just nuke it all from fedora-hubs
14:33:32 * mizmo apologizes, this is my mess
14:33:33 <abompard> mizmo: I usually do the upgrade when I hear there's a new F-B version available :)
14:33:41 * mizmo did a lot of stuff hastily in prep for flock
14:33:47 <abompard> ("usually" = I did it twice)
14:33:59 <mizmo> abompard: oh ok great, ill give you a heads up when i get the new stuff integrated with F-B then
14:34:02 <abompard> mizmo: no problem, this stuff happens :)
14:34:20 <abompard> mizmo: cool
14:34:21 <shaily> okay, so since this won't cause problems any more... should i make a PR for adding markdown to sticky? i was waiting to discuss this with you in case we wanted to modify the markdown parser to add classes so this doesn't happen
14:34:55 <abompard> shaily: I think you can make the PR, we can discuss the issue there if we still have problems after patternlab removal
14:35:07 <shaily> okay, as of now it just renders plain html with no styles / classes
14:35:43 <abompard> shaily: it may be necessary to add a link to an external CSS when the widget is used
14:36:08 <shaily> abompard: how come
14:36:40 <abompard> shaily: oh you mean the HTML is generated *without* class attributes?
14:36:50 <shaily> abompard: yup
14:37:01 <abompard> shaily: that's weird. Which parser are you using?
14:37:08 <abompard> (well, renderer actually)
14:37:32 <shaily> abompard: https://github.com/Python-Markdown/markdown
14:38:04 <shaily> i compared it with markdown2 and mistune and it's behavior turned out to match what i was expecting most of the time
14:38:27 <shaily> i didn't compare performance though (rendering time etc)
14:39:02 <abompard> shaily: it doesn't matter much since we cache it and the text is small
14:39:12 <shaily> okay
14:39:22 <shaily> abompard: what classes should it add though
14:39:50 <abompard> shaily: I was expecting the renderer to use CSS classes in its HTML to style the result
14:40:25 <shaily> abompard: oh okay
14:40:45 <abompard> but maybe not, I havent really played with markdown parsers
14:41:52 <abompard> shaily: anyway, maybe we can use it without additional CSS, Bootstrap is already setting a lot of that
14:42:05 <shaily> i guess it's okay that it gives us only what is essential and leaves it to us to add classes
14:42:19 <abompard> I agree. OK, let's talk about that in the PR
14:42:25 <abompard> I think we should move on
14:42:27 <shaily> okay
14:43:16 <abompard> sayan: not wanting to overthrow your management of the meeting of course ;-)
14:43:25 <abompard> (but it's 43 minutes in ;-) )
14:43:55 <sayan> Yeah
14:44:48 <sayan> #topic IRC Widget
14:45:25 <sayan> abompard: stickster told me you had some thoughts to share on the complexity of the IRC widget
14:45:29 <abompard> About that topic, I'd like to have a discussion with mizmo and sayan
14:45:30 <abompard> yeah
14:45:44 <abompard> I think it's going to take more than 15 minutes to talk about
14:46:17 <abompard> So if you guys have time I'd like to discuss where we are and where we want to go
14:46:23 * stickster pops up :-)
14:46:30 <sayan> I am free to talk
14:46:34 <stickster> ah, yes
14:47:16 <abompard> when I say "with mizmo and sayan" I dont mean in private of course, just with at least you two ;-)
14:47:21 * mizmo has time
14:47:39 <abompard> Great. Let's talk about that after the meeting?
14:47:58 <sayan> sure
14:48:05 <abompard> great
14:48:36 <sayan> #topic Open Floor
14:49:16 <sayan> hi jonatoni, do you want to something to share?
14:51:50 <sayan> #action  mizmo working on search designs for outreachy project
14:51:58 <sayan> #action mizmo working on hubs devel bounties, to be posted after outreachy application period closes
14:52:24 <sayan> anyone else has to share for open floor? or else we can end the meeting
14:52:53 <abompard> nothing else from me
14:53:01 <sayan> okay, ending the meeting in
14:53:03 * mizmo me neither
14:53:04 <sayan> 3.
14:53:06 <sayan> 2.
14:53:08 <sayan> 1.
14:53:10 <sayan> #endmeeting