hubs-devel
LOGS
15:04:46 <mizmo> #startmeeting hubs-devel
15:04:46 <zodbot> Meeting started Tue Jan 31 15:04:46 2017 UTC.  The chair is mizmo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:46 <zodbot> The meeting name has been set to 'hubs-devel'
15:04:55 <mizmo> #topic roll call!
15:04:57 <mizmo> .hello dufy
15:04:58 <zodbot> mizmo: Sorry, but you don't exist
15:05:06 <mizmo> .hello duffy
15:05:09 <jcline> .hello jcline
15:05:09 <shillman> .hello wispfox
15:05:10 <zodbot> mizmo: duffy 'Máirín Duffy' <fedora@linuxgrrl.com>
15:05:12 <mizmo> "mizmo: Sorry, but you don't exist" gee thanks
15:05:13 <zodbot> jcline: jcline 'Jeremy Cline' <jeremy@jcline.org>
15:05:16 <zodbot> shillman: wispfox 'Suzanne Hillman' <wispfox@gmail.com>
15:05:20 <shillman> Yeah, I noticed that. :)
15:05:22 <jcline> Yeah that's pretty harsh
15:05:33 <abompard> .hello abompard
15:05:34 <zodbot> abompard: abompard 'Aurelien Bompard' <aurelien@bompard.org>
15:06:42 * mizmo is looking up our last meeting minutes
15:07:22 <mizmo> #topic agenda
15:07:25 <mizmo> last meeting minutes: https://meetbot.fedoraproject.org/teams/hubs-devel/hubs-devel.2017-01-24-15.01.html
15:07:55 <mizmo> okay here's what i wanna do, let's go through action items / etc from the last meeting minutes to make sure we're not forgetting anything and then maybe do a round robin status update per person?
15:08:14 <mizmo> the action items we set last meeting:
15:08:29 <mizmo> mizmo to work on the IRC mockups  (which i did)
15:08:33 <mizmo> sayan and jcline to build the first version of IRC widget to toggle, identification of IRC nick
15:08:51 <mizmo> #topic IRC widget
15:08:57 <mizmo> jcline: how did you and sayan do with the IRC widget?
15:09:18 <jcline> Yeah, so I started chipping away at that. I've got a PR open against FAS3 (https://github.com/fedora-infra/fas/pull/255) to add the necessary IRC fields.
15:09:45 <jcline> I also explored how widgets work in hubs and wrote up my findings as documentation in https://pagure.io/fedora-hubs/pull-request/302
15:10:17 <mizmo> cool looks like you filed the FAS3 PR a few days ago, i wonder if we should ping anybody to get attention to it?
15:10:32 <jcline> Yeah, I'll do that today
15:11:04 <jcline> I know a lot of people are out/busy with conferences, though
15:11:22 <mizmo> i think SmootherFrogz is the FAS3 goto person
15:11:39 <mizmo> #action jcline to ping about FAS3 PR to get review
15:12:12 <mizmo> the widget docs look good.
15:13:39 <mizmo> so widgets would be a class? are they currently modules?
15:13:40 * mizmo confused about thatpoint
15:14:25 <jcline> I think I might need to adjust it a little bit since I think abompard's recent PR expects them to be modules
15:14:44 <abompard> jcline: actually I think classes would be much better
15:15:06 <abompard> I'm not very fond of the module-based interface we have at the moment
15:15:13 <jcline> abompard, cool :)
15:15:45 <jcline> It does technically work, but I was quite surprised and I think it's tougher to grok initially
15:16:03 <abompard> jcline: yeah, and less flexible than classes too.
15:16:44 <abompard> jcline: your doc only uses static method, I think there may be a good use of using instances
15:17:03 <mizmo> what are the tradeoffs between module based and class based?
15:17:03 <abompard> jcline: this way we could have setup operations
15:17:15 <jcline> abompard, yup, I only did static instances because I thought it could be a drop-in replacement for the modules that way
15:17:26 <jcline> I'm happy to adjust things
15:17:46 <abompard> jcline: understood. mizmo: using classes is a bit more work because it requires defining an interface
15:18:18 <mizmo> abompard: it sounds like its more flexible though
15:18:40 <abompard> mizmo: yeah, classes are much more flexible
15:18:56 <abompard> mizmo: plus you can have your classe implemented anywhere (that is python-accessible)
15:18:57 <jcline> We could also provide default implementations for widgets because of inheritance
15:19:02 <mizmo> ok cool
15:19:18 <abompard> mizmo: which means that classes (and thus widgets) could be provided by external python packages
15:19:34 <abompard> mizmo: which means easier external customization and contributions ;-)
15:19:48 <jcline> \o/
15:20:20 <mizmo> sounds good to me :) i need to read up more on modules
15:20:27 <abompard> jcline: yeah, way less boilerplate
15:20:32 <mizmo> jcline: anything else on the IRC front? anything you need help with?
15:20:35 <jcline> In any case, I know you have some widget-related stuff written abompard, and I'll review your open PRs today to unblock you
15:20:47 <abompard> jcline: cool, thanks!
15:21:09 <jcline> mizmo, not yet, I spent a good bit of last week getting a feel for widgets in general
15:21:51 <mizmo> ok cool, and documenting along the way == completely awesome
15:21:53 <jcline> And I spent time implementing the db change in hubs and then changing my mind :(
15:21:59 <abompard> jcline++
15:21:59 <zodbot> abompard: Karma for jcline changed to 9 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:22:26 <mizmo> abompard: a good segue into what you've been working on? we had a back and forth  about the stream on the list
15:22:32 <jcline> I also got the API autodocs going for Hubs, I just haven't made a PR yet because it depends on my first docs PR
15:22:50 * abompard looks up the word "segue"
15:23:05 <mizmo> #info jcline got API autodocs going for hubs, no PR yet
15:23:34 <mizmo> abompard: lol
15:24:43 <abompard> Yeah, I was finding a lot of seemingly duplicated code and didn't understand the differences between the feeds, but now I get it, thanks :-)
15:25:03 <mizmo> #topic abompard update
15:25:04 <abompard> I've fixed some javascript recently, and I didn't want to oversimplify it
15:25:13 <mizmo> did you hear back from the openstack peeps?
15:25:19 <abompard> So.
15:25:36 <abompard> Nothing from the openstack folks. I think we can safely assume we're on our own here.
15:25:45 <abompard> So I went back to my widget
15:26:09 <abompard> I think I can implement a change in the hubs config that will give me the necessary info
15:26:19 <abompard> without needing to change meetbot
15:26:36 <abompard> hubs users would need to list the channels they are working on
15:26:49 <abompard> this info would be used by the halp widget to filter the halp requests
15:26:56 <abompard> but it could be used by other widgets too
15:27:07 <abompard> that's why I think it's more a hub-level config
15:27:27 <abompard> (I'm thinking of the IRC widget, but maybe also a meetings widget, etc)
15:27:47 <abompard> Would you agree it's a shared config?
15:28:08 <abompard> if the halp widget is the only consumer, I can just add it to its config
15:28:35 <jcline> abompard, what if you pulled the list of irc channels via the hubs a user was part of. The hub would set up their irc widgets and they need to provide a channel.
15:29:14 <abompard> Yeah, I wasn't sure a widget could access another widget's config
15:29:50 <mizmo> i think it should be shared - e.g., it would be nice to have notifications of the data go to the stream as well as the halp widget
15:29:52 <abompard> it may be possible currently, but do we want to allow it? And what happens if the IRC widget isn't used on this hub?
15:30:17 <mizmo> jcline: the main use case for the halp widget is the comm ops folks altho other people could use it too
15:30:27 <mizmo> jcline: the comm ops folks aren't necessarily members of the teams that are looking for help
15:30:39 <mizmo> jcline: but they try to identify which teams need help at a higher level and route helpers as needed
15:30:46 <mizmo> abompard: a good question - a few things
15:30:59 <mizmo> - If a given user doesn't have IRC activated,  they still would be interested in halp requests that have to do with teams they are a member of
15:31:13 <abompard> mizmo: right.
15:31:21 <mizmo> - we may at some point want to make it possible to monitor other info (beyond IRC) to create halp items in the widget.
15:31:31 <mizmo> - we may at some point want to make it possible to manually enter in a halp request to the halp widget
15:32:57 <abompard> So, for (1) I'll need a list of IRC chans used for each hub, and (2) and (3) don't change the decision. -> new hub config :-)
15:33:14 <jcline> Makes sense
15:33:49 <abompard> I'll just make sure my table can hold more info than just a list of IRC chans ;-)
15:34:47 <mizmo> abompard: oh we talked about this hub<=>irc channel mapping before i think, one sec
15:35:13 <mizmo> http://blog.linuxgrrl.com/2016/11/15/fedora-hubs-and-meetbot-a-recursive-tale/
15:35:37 <mizmo> so we have a complication with the #fedora-meeting-* channels in that they aren't mapped to a team? or is that an issue?
15:35:50 <abompard> mizmo: yeah that's still a complication
15:36:12 <abompard> but I don't think it changes the initial design anyway
15:36:23 <abompard> it's something that can be added later on
15:36:54 <abompard> and yeah, we talked about that before, but we were hoping to not have to do it by upgrading meetbot ;-)
15:38:26 <mizmo> abompard: well one simple thing maybe - each hub's admin could have a configuration for the hub that they could add their meetbot meetingname tags to, then you wouldn't have to upgrade meetbot
15:39:17 <abompard> mizmo: hmm, interesting, and looks simple. Will try
15:40:05 <mizmo> it makes it more manual, but if the hub admin has to do it then most users won't be burdened with it, so it might be an ok tradeoff
15:40:25 <mizmo> abompard: anything else to report?
15:40:33 <abompard> mizmo: yeah, and it doesn't change much overtime
15:40:40 <abompard> nothing else to report, thanks
15:40:57 * sayan is back
15:41:02 <sayan> .hello sayanchowdhury
15:41:03 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
15:42:03 <mizmo> cool
15:42:16 <mizmo> shillman: should we talk about the regional hubs design work?
15:42:22 <shillman> Sure!
15:42:33 <shillman> I can't remember what I talked about last week. :)
15:43:15 <mizmo> hi sayan! is your friend ok?
15:43:22 <mizmo> #topic regional hubs design work
15:43:32 <shillman> I'm currently setting up times to have people try to use my prototypes. a2batic and I did a session last night, which went well. Somewhat nerve-wracking for me, since I hadn't done one before. :)
15:44:20 <sayan> mizmo: yes, he is weak mostly because of less sleep. doc did some tests and told to report after 10 days
15:45:13 <shillman> I'm also touching up the social media/photo sharing survey. It's meant to try to get an idea of what sorts of social media/photo sharing tools people are using, with the intent to have some conversation between Hubs and those tools available.
15:46:01 <mizmo> shillman: so last week you talked about the feasability eval you did with sayan on hubs mocks
15:46:13 <shillman> I need to review the conversation that mizmo and I had around CSS last week, to make it a little easier to follow for my later use, and followup with mizmoon further CSS stuff.
15:46:54 <shillman> (mizmoon!)
15:47:15 <shillman> Right, I need to take a look at how those tasks are going relating to that eval.
15:47:51 <mizmo> lemme grab that link for you
15:48:21 <mizmo> shillman: https://meetbot.fedoraproject.org/teams/hubs-devel/hubs-devel.2017-01-26-18.58.html
15:48:22 <shillman> Also, mizmo relating to the visual design thing. The file you said I should look at wasn't findable last I looked.
15:48:27 <shillman> thanks. :)
15:49:07 <shillman> Oh, ah. I do have that link open already. :)
15:49:23 <shillman> Was thinking you meant the one relating to Sayan and I eval.
15:49:49 <mizmo> shillman_: it's in fedora-hubs/_mockups_/create-account.svg
15:50:06 <mizmo> https://github.com/fedoradesign/fedora-hubs/blob/master/_mockups_/create-account.svg
15:50:19 <mizmo> shillman: you might want to poke sparkelshare and make sure it's running so you're getting updates
15:50:50 <mizmo> shillman: okay anything else? any feedback you need or help?
15:50:54 <shillman> Yeah. I had poked it for updates. Will try again. :)
15:51:48 <shillman> Uh... Feeling a little overwhelmed by the state of the country, which isn't really a thing that y'all can help with. Will get my mind together and if I have questions, will ping you?
15:52:44 <mizmo> im in the same boat
15:52:45 <mizmo> sounds great
15:52:52 <mizmo> okay cool
15:52:53 <mizmo> #topic open floor
15:52:57 <mizmo> anything else from anybody?
15:53:14 * jcline has nothing
15:53:57 <mizmo> okay cool lets close it then :)
15:54:08 <mizmo> #endmeeting