zanata-survey
LOGS
04:38:44 <pravins> #startmeeting zanata-survey
04:38:44 <zodbot> Meeting started Fri Sep 11 04:38:44 2015 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:38:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
04:38:55 <pravins> #meetingname zanata-survey
04:38:55 <zodbot> The meeting name has been set to 'zanata-survey'
04:40:31 <aeng> the questions is basically donwe
04:40:40 <pravins> lets again see objectives
04:40:54 <pravins> #info Objective 1: Create awareness of Zanata in Fedora community
04:42:39 <pravins> As per inputs from Sankarshan on mailing list "the first objective could be considered in terms of "measurement of awareness" it will lead to the categorization of the user experience based topics of migration."
04:44:07 <pravins> #info Objective 2: Find out if any difficulty while migration from Transifex to Zanata
04:44:22 <pravins> #info Objective 3 Collect feedback from Zanata users (L10n and Developers)
04:44:45 <aeng> yup
04:45:14 <pravins> Again just for information.
04:45:37 <pravins> Input on mailing list: seems to indicate free-flowing feedback. Text blocks are useful for additional context but as this is the first survey, it would be useful to consider scoping the kind of feedback that is of immediate importance and can influence/drive the project/product vision.
04:46:04 <lukebrooker> pravins, I saw all that on the mailing list and tried to take it into account
04:46:22 <pravins> #info  * Objective 4: Get Zanata devel more involved in Fedora
04:46:29 <pravins> lukebrooker: excellent.
04:46:45 <pravins> i just thought will go through objectives once before reviewing questions. just recap :)
04:46:53 <pravins> #chair lukebrooker aeng noriko ani
04:46:53 <zodbot> Current chairs: aeng ani lukebrooker noriko pravins
04:46:57 <lukebrooker> there is a mix of both multiple choice and free form
04:47:12 <ani> yes
04:48:07 <lukebrooker> I still need a good list for "How did you first hear about the Zanata migration?"
04:48:33 <pravins> lukebrooker: sure, i think lets go through questions one by one and see how can we improve it.
04:48:43 <ani> okies.. kets go throught the questions
04:48:44 <pravins> #topic questions review
04:48:53 <lukebrooker> We can always have an other but it would be good to know how they may have been contacted
04:49:06 <ani> yup
04:49:12 <pravins> #link https://zanata.atlassian.net/wiki/display/COM/Fedora+Community+Survey
04:49:48 <pravins> #info How did you first hear about the Zanata migration?
04:50:27 <pravins> This maps with out first objectives, i.e. measurement of awareness
04:50:49 <pravins> +1 from me
04:50:57 <pravins> noriko: ani aeng how do you feel about this?
04:50:58 <aeng> its good to understand the channel of communication they used
04:51:09 <aeng> its important for future announcement
04:51:11 <lukebrooker> aeng, I was just about to say that ;)
04:51:18 <ani> yes exactly
04:51:19 <pravins> right and it will also help us in future to do better communication.
04:51:29 <lukebrooker> So how might they have heard?
04:51:35 <lukebrooker> I'll add in some options
04:51:40 <aeng> +100
04:51:44 <pravins> great
04:51:49 <pravins> so, what this question will be?
04:51:57 <pravins> multiple choice?
04:52:08 <pravins> where people can select 2 or more options?
04:52:36 <ani> Fedora mailing lists, Community , word of mouth, Transifex notifications - Could these be good options ?
04:52:59 <lukebrooker> pravins, yep
04:53:02 <lukebrooker> ani, thanks
04:53:02 <ani> noriko, ^
04:53:10 <ani> :)
04:53:24 <lukebrooker> what would "community" mean?
04:53:28 <noriko> select any?
04:53:28 <aeng> "others, please specify:"
04:53:36 <lukebrooker> aeng, yep
04:53:49 <lukebrooker> noriko, We could so one or many
04:54:01 <noriko> it is good to know which channel useful to gain more new members as well :-)
04:54:02 <ani> Community - anyone from the fedora community - but that is similar to word of mouth I guess
04:54:02 <pravins> Fedora Magazine was also one.
04:54:02 <ani> right
04:54:03 <lukebrooker> Depends if you want to find out the first place or any place
04:54:20 <lukebrooker> pravins, great
04:54:27 <ani> and yes aeng "others" too
04:54:50 <noriko> by word of mouth?
04:55:27 <pravins> Do we need to also get exact mailing list name? or just getting type mailing list will do.
04:55:27 <noriko> then have two separe entries, word of mouth and fedora magazine?
04:55:56 <lukebrooker> pravins, it might be hard for some to recall the exact one
04:56:08 <noriko> hahaha, lukebrooker yea
04:56:11 <pravins> noriko: yes, Word of Mouth and Fedora Magazine are separate.
04:56:24 <noriko> lukebrooker, 'i don't remember'
04:56:27 <lukebrooker> So far I have:
04:56:27 <pravins> yeah, just mailing list will be sufficient. No more complexity ;)
04:56:28 <lukebrooker> Fedora mailing list
04:56:28 <lukebrooker> Fedora magazine
04:56:29 <lukebrooker> Transifex notification
04:56:30 <lukebrooker> Word of mouth
04:56:31 <lukebrooker> Other
04:56:50 <ani> I liked them :)
04:57:06 <ani> if required like Pravin said simple "Mailing list" is also fine
04:57:07 <noriko> 'i don't remember' entry not helpful?? ;p
04:57:15 <ani> haha
04:57:36 <lukebrooker> Maybe a "I never heard about it"
04:57:55 <pravins> Fedora Wiki can be also one but dunno should we include it? or just be happy with "others"
04:58:00 <lukebrooker> or "I had no idea"
04:58:05 <lukebrooker> Fedora wiki is good
04:58:41 <lukebrooker> Maybe change Fedora mailing list to "A Fedora mailing list"
04:58:56 <ani> my suggestion - Mailing lists, Fedora magazine, Transifex notification, word of mouth, other
04:59:11 <ani> and if others, pls specify would do
04:59:21 <pravins> yeah, i have seen lots of people start with Wiki for contribution and from there understand we have moved to Zanata.
04:59:57 <aeng> maybe "I'm still using transifex"..lol
05:00:00 <lukebrooker> ani, I think that list is good, maybe just add the Wiki?
05:00:15 <ani> alright lets add wiki too
05:00:25 <pravins> great.
05:00:36 <pravins> We are done with first one.
05:01:11 <lukebrooker> Updated
05:01:17 <ani> aeng, instead of that maybe we can add "I didnt know/hear" ? This way we can know how did the communication go ?
05:01:35 <pravins> #info Options: Fedora Mailing list, Fedora Magazine, Transifex notification, Word of Mount, Fedora Wiki, Others.
05:01:37 <ani> so one more to the list -> "I didnt know" ?
05:01:53 <lukebrooker> ani, yep that will be good
05:02:20 <pravins> if person dont know about Zanata, how do we expect he will answer remaining questions?
05:02:32 <aeng> agree
05:02:49 <lukebrooker> haha true
05:02:52 <ani> okay so final list -> Mailing list, Fedora Magazine, Transifex Notifications, Word of Mouth, Fedora wiki, Others (pl specify with text box), I didnt hear
05:03:25 <lukebrooker> I didn't hear could be "This survey"
05:03:35 <lukebrooker> ok now we are just dragging this out
05:03:39 <aeng> ahahah
05:03:47 <lukebrooker> Maybe they can just put I didn't hear in "other"
05:03:47 <ani> he can mention that is the last section where that person can put the comments
05:03:53 <pravins> i think we need to specify while publishing survey, this is meant for which people/user
05:04:18 <ani> pravins, survey is for those who used or using it
05:04:39 <ani> so lets not worry about others. who have not used does not make sense for a survey at all
05:04:50 <ani> lets move on
05:04:54 <pravins> yes
05:05:05 <pravins> next question
05:05:11 <ani> Honestly to me rest of the questions look good
05:05:15 <pravins> #info How did you feel the migration from Transifex to Zanata went?
05:05:44 <noriko> phew good one. i really like to hear.
05:05:55 <ani> :)
05:06:33 <pravins> This maps with our 2nd objective. Difficulty users faced while migrating.
05:06:48 <ani> if all feels good lets move to next. any opinion about the options ?
05:07:09 <ani> pravins, agree
05:07:20 <aeng> yeah, its good enough
05:07:32 <pravins> but are we getting exact pain points from this question?
05:07:58 <pravins> Objective 2: Find out if any difficulty while migration from Transifex to Zanata
05:08:10 <ani> this question is good to go
05:08:29 <pravins> may be those are covered in next questions.
05:09:19 <pravins> +1 from me for second questions. Likert scale looks good.
05:09:28 <pravins> anything from others?
05:09:31 <ani> the migration question is mainly for the developers. and if anyone want to write more they can provide their comments in the last question
05:09:39 <lukebrooker> If in doubt the last question covers anything left over ;)
05:09:44 <ani> lukebrooker, :)
05:09:55 <pravins> yes
05:10:18 <ani> Last question provides place for all to put their comments - good and bad
05:10:26 <pravins> should we go through each questions  one by one, or just discuss where doubts or queries?
05:11:06 <noriko> pravins, good idea, just doubts or queries.
05:11:09 <lukebrooker> pravins I think we could discuss more broadly
05:11:18 <noriko> rely on ani for selection already.
05:11:19 <ani> guess just doubtful ones
05:11:22 <aeng> just pick those which are unsure
05:11:25 <ani> :)
05:11:25 <pravins> noriko: :)
05:11:35 <pravins> looks good to me.
05:11:43 <ani> :)
05:11:55 <lukebrooker> The first section is to get an overall feel without users having to fill out much, if they don't have time for comments at least we get that
05:12:01 <aeng> Which features could you live without? - do we need that?
05:12:17 <ani> I think we need to redraft that question
05:12:46 <aeng> I like What features could you not live without?.. make us focus on that featuer
05:12:50 <lukebrooker> sure, I'd like something like that to see what features people aren't using
05:13:33 <lukebrooker> Happy to reword it if it doesn't make sense
05:13:35 <aeng> I think that will be too broad.. and not sure what benefits we gonna get from know that
05:13:40 <ani> maybe which feature you use the most? something like that
05:13:56 <lukebrooker> aeng, heap, like what features we can get rid of in the future
05:13:57 <aeng> ani, thats covered by "features could not live without"
05:14:16 <ani> aeng, I was trying to rephrase the "live" part :D
05:14:27 <lukebrooker> ani, haha yep
05:14:29 <pravins> do we have Zanata features listed anywhere?
05:14:31 <aeng> lukebrooker, depends... feature doesnt used by 1 can be gold to another
05:14:54 <lukebrooker> aeng, yes but if lots of people say they don't use the same feature
05:14:58 <lukebrooker> pravins, yes and no
05:15:06 <lukebrooker> they are not ALL listed
05:15:22 <ani> this is survey and we would like to get different and more opinions from the people
05:15:31 <pravins> ok :) was just wondering if users will no about feature they are not using ;)
05:15:36 <noriko> i agree aeng, it can sometime be specific to language, one lang feel useful while other lang doesnt.
05:15:38 <pravins> s/no/know
05:15:48 <lukebrooker> aeng, cutting features can be as much of a UX improvement as adding them if they get in the way/confuse people
05:16:18 <lukebrooker> Happy to cut it if no one else thinks it can be answered well
05:16:33 <aeng> i just think it won't do much.
05:16:39 <lukebrooker> Might be something better to tell from user testing
05:16:47 <pravins> +1 i think we can remove "Which features could you live without?"
05:16:52 <lukebrooker> aeng, if people answered it well, it would do a lot
05:16:58 <ani> Else lets keep only What do you find most frustrating about Zanata?
05:16:58 <ani> What do you like best about Zanata? and remove the "live" and "live without" questions ?
05:17:10 <ani> is that fine ?
05:17:44 <aeng> i think thats better
05:17:46 <ani> I would still like to hear from people the feature most useful for them
05:17:49 <ani> :D
05:17:56 <ani> but I go with majority
05:18:08 <lukebrooker> ani, not live without / like best about are slightly different questions.
05:18:29 <ani> hmmm...
05:19:00 <ani> lukebrooker, how best can we rephrase them - live without questions ?
05:19:03 <aeng> i'd say keep all, but maybe rephrase Which features could you live without?
05:19:06 <pravins> lukebrooker: aeng ani if we give "Which features could you live without?" then we need to give some options i think.
05:19:28 <lukebrooker> I'm happy to remove Which features could you live without?
05:19:33 <ani> pravins, no giving options would be diffciult now
05:19:41 <lukebrooker> But leave in Which features could you not live without? and rephrase
05:19:51 <aeng> yup, agree lukebrooker
05:20:03 <ani> lets keep it open and let people provide the features. Lets get to know how much people know
05:20:14 <ani> lukebrooker, +1
05:21:05 <pravins> points is : if we want information about irrelevant feature from users, then we can provide some options to them i.e. What Zanata dev. think irrelevant question.
05:21:11 <lukebrooker> Which features are critical to your work?
05:21:40 <aeng> good one
05:21:48 <pravins> yes
05:22:00 <ani> lukebrooker, agree
05:22:04 <ani> looks good
05:22:07 <lukebrooker> Instead of What features could you not live without?
05:22:28 <ani> think think think :)
05:23:04 <pravins> looks good.
05:23:05 <ani> Which features are critical to your work? - sounds good
05:23:25 <lukebrooker> I left out Zanata in that question in case there is something critical we don't provide
05:23:48 <aeng> yup. Very good :)
05:24:05 <ani> oh ok
05:24:16 <pravins> refreshed page, looks good now.
05:24:20 <lukebrooker> BTW I'm updating the doc as we go if you refresh it
05:24:29 <ani> yess :D
05:25:00 <pravins> We can get good and useful information from this survey for future development.
05:25:32 <pravins> any further questions/doubt on "Survey Questions"?
05:25:33 <lukebrooker> I'm hoping so
05:25:58 <lukebrooker> Actually should we provide a link to give feedback/report bugs at the end too?
05:26:24 <lukebrooker> To get the community used to where they can keep reporting things
05:26:26 <aeng> just point to our jira
05:26:30 <ani> lukebrooker, that sounds good
05:26:32 <lukebrooker> that's what I mean
05:26:51 <lukebrooker> Even after they complete it
05:26:59 <pravins> +1
05:27:08 <noriko> +1
05:27:41 <ani> +1 :)
05:28:51 <pravins> i am assuming no other doubts
05:28:55 <pravins> and moving to next topic.
05:29:19 <aeng> yup
05:29:35 <pravins> #topic Making Survey live Dates and place.
05:29:58 <pravins> Where are we making this survey live?
05:30:07 <pravins> I think we discussed this earlier as well, may be just for info.
05:30:10 <aeng> magazine
05:30:11 <aeng> >
05:30:12 <aeng> ?
05:30:23 <aeng> mailing list
05:30:24 <pravins> on Magazine, we will promote
05:30:37 <pravins> i meant tools for executive survey.
05:30:46 <ani> :)
05:31:07 <lukebrooker> I will create the survey on typeform if that is ok?
05:31:13 <lukebrooker> We can link to it
05:31:48 <pravins> One action was at my end to see if Fedora infra have any survey utility. AFAIK there is not.
05:32:18 <lukebrooker> We can embed it or link to it
05:32:21 <pravins> so lets do with typeform.
05:32:24 <lukebrooker> Here is a embed example https://s3-eu-west-1.amazonaws.com/share.typeform.com/typeform_embed_widget_en.html
05:32:36 <ani> we need to do a test run among ourselves
05:32:36 <ani> before publishing it
05:32:36 <ani> mailing list. and maybe promote via magazine too
05:32:37 <ani> lukebrooker, yes
05:32:38 <ani> and do you think we can run a test survey amoung ourselves before publishing it? Just to have a look
05:32:47 <pravins> wow, looks nice.
05:32:51 <aeng> looks good
05:33:05 <pravins> +1 for typeform.
05:33:32 <pravins> #agreed Typeform for survey and will link it to other places if required.
05:33:37 <lukebrooker> Yep, I'll send it out for testing first
05:33:45 <pravins> great.
05:33:50 <pravins> last topic
05:34:03 <ani> sorry I got disconnected :(
05:34:03 <pravins> #topic Promoting Survey
05:34:10 <pravins> ani: no problem :)
05:34:19 <pravins> 1. Fedora Magazine article.
05:34:21 <ani> did you decide the dates ?
05:34:24 <pravins> 2. Mailing list.
05:34:38 <pravins> ani: ohh, good points sorry i missed it.
05:34:54 <pravins> Dates:
05:35:34 <aeng> i wonder should we post the survey in Zanata twitter...
05:35:36 <ani> date for test run and then publishing it on mailing list
05:35:43 <ani> aeng, +1
05:35:51 <pravins> to me more realistic looks 21st sept. week (39th week)
05:36:08 <pravins> aeng: good points. Zanata and Fedora twitter.
05:36:24 <aeng> we can get good feedback from openstack community too
05:36:37 <aeng> since we are official yesterday
05:36:41 <lukebrooker> aeng, this is Fedora specific though
05:36:52 <lukebrooker> aeng, We can do another similar one for them
05:36:54 <noriko> oh, aeng lukebrooker congrats!
05:36:58 <pravins> aha, congratulations. :)
05:37:00 <ani> next week lukebrooker can you send us the test link for the survey. after we all trying it on 21st (next monday) can publish it ?
05:37:13 <lukebrooker> ani, sounds good
05:37:26 <ani> coool :)
05:37:52 <ani> hey thats really a good news
05:37:55 <pravins> #info Zanata became official for Openstack community on 10th Sept. Cheers !!
05:38:00 <aeng> lukebrooker, all the questions applies to openstack too.. but if we want to separate it..
05:38:07 <ani> congratulations guys :)
05:38:24 <pravins> #info Dates for executive survey: Test run 38th Week and Actual run 39th Week.
05:38:41 <pravins> coming back to promoting survey:
05:38:46 <ani> we  need to keep the survey open for one whole week
05:38:53 <pravins> 1. Fedora Magazine: Who will write article for it?
05:39:13 <lukebrooker> aeng, I think we should keep it separate. It's easier to combine data later if we want to
05:39:55 <aeng> pravins, I dont mind helping out, but need another person to draft something out first
05:39:57 <pravins> yeah, good to keep OpenStach survey separate. Since here we are specifically targeting Fedora.
05:41:06 <lukebrooker> I could write the article, unless we need someone with a little more community involvement
05:41:22 <pravins> lukebrooker: no, its nothing like that. you can definitely do it.
05:41:32 <lukebrooker> pravins, Ok sure
05:41:39 <pravins> great, thanks lukebrooker :)
05:42:03 <pravins> 2. Mailing list - is fine.
05:42:10 <lukebrooker> pravins, when should I have something done by?
05:42:16 <pravins> 3. Social Media: twitter, g+ and FB.
05:42:51 <pravins> lukebrooker: you should join https://lists.fedoraproject.org/mailman/listinfo/marketing
05:44:01 <pravins> #link http://fedoramagazine.org/submit-an-idea-or-tip/
05:44:02 <lukebrooker> pravins, done
05:44:27 <ani> lukebrooker, if you have many things on your plate I can write the article. Feel free to let me know :)
05:44:34 <lukebrooker> pravins, I sit near ryan too so I can talk to him about it
05:44:37 <pravins> they have changes few things after flock. so above link looks like more recent.
05:44:57 <pravins> lukebrooker: aha, excellent. then no need to tell you anything.
05:45:07 <pravins> he can help from submitting idea to review and publish :)
05:45:07 <lukebrooker> ani, Thanks, I'll let you know. I usually need many plates ;)
05:45:15 <ani> lukebrooker, hahaha
05:45:31 <pravins> i think we done with all topics
05:45:32 <lukebrooker> pravins, great!
05:45:32 <ani> so next week lets do the test run
05:45:46 <pravins> #topic Open Floor
05:46:03 <ani> and before publishing lets publish the article on fed magazine ?
05:46:40 <pravins> apologies for taking some time for this meeting but unfortunately some of us was not available on particular time. :(
05:46:50 <ani> yes me too :(
05:46:50 <pravins> lets try to be on schedule for remaining activities.
05:47:07 <aeng> what else in the agenda?
05:47:12 <pravins> article and survey should go live same time.
05:47:28 <ani> yes
05:47:28 <pravins> nothing else lets close in 2 minutes :)
05:47:34 <ani> :D
05:48:06 <lukebrooker> Great, thanks everyone
05:48:33 <ani> thank you all. :)
05:48:35 <pravins> thanks lukebrooker aeng ani noriko :)
05:48:39 <aeng> thanks guys
05:48:39 <pravins> #endmeeting