"fedora_classroom_-_command_line_101"
LOGS
13:00:31 <FranciscoD> #startmeeting Fedora classroom
13:00:31 <zodbot> Meeting started Thu Aug 10 13:00:31 2017 UTC.  The chair is FranciscoD. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:31 <zodbot> The meeting name has been set to 'fedora_classroom'
13:00:43 <FranciscoD> #meetingname "Fedora classroom - Command Line 101"
13:00:43 <zodbot> The meeting name has been set to '"fedora_classroom_-_command_line_101"'
13:00:51 <FranciscoD> #topic Hello!
13:01:02 <linuxEnthusiast> Hi
13:01:09 <ankit01ojha> Hello
13:01:16 <asch_> hi
13:01:18 <ZephOne> Hi !
13:01:22 <Godoshian> hello
13:01:37 <FranciscoD> Hello everyone! Welcome to another Fedora Classroom session. While we wait for folks to sign in, please introduce yourselves. Name and timezone will do, and if you have an FAS username, please mention that too so that we can give you a badge!
13:01:58 <ankit01ojha> .hello ankit1997
13:01:59 <zodbot> ankit01ojha: ankit1997 'Ankit Raj Ojha' <ankit123rudra@gmail.com>
13:02:07 <FranciscoD> .hello ankursinha
13:02:07 <zodbot> FranciscoD: ankursinha 'Ankur Sinha' <sanjay.ankur@gmail.com>
13:02:11 <linuxmodder> .fas linuxmodder
13:02:12 <zodbot> linuxmodder: linuxmodder 'Corey W Sheldon' <sheldon.corey@openmailbox.org>
13:02:14 <linuxEnthusiast> I'm Ali from Sarajevo
13:02:18 <FranciscoD> Note - (This command will only work for Fedora contributors)
13:02:54 <linuxmodder> to all newcomers and new names WELCOME
13:02:55 <FranciscoD> Only 3 people here? I thought there were more folks around ;)
13:03:12 <FranciscoD> #chair linuxmodder ankit01ojha shantorn
13:03:12 <zodbot> Current chairs: FranciscoD ankit01ojha linuxmodder shantorn
13:03:12 <linuxmodder> two more there FranciscoD
13:03:16 <shantorn> good day all
13:03:20 <DodoSk> Dominik CEST FAS skalarock24
13:03:21 <ZephOne> I'm Erwan from France
13:03:21 <asch_> I'm André. I'm in Brazil GMT-3 and I think I'm asch on FAS. Only used it to edit the wiki once.
13:03:22 <fatek> fatek from so. cal
13:03:25 <linuxmodder> shantorn,  decided to join nice
13:03:30 <shantorn> i am not a chair thank you
13:03:31 <FranciscoD> .hello asch
13:03:32 <zodbot> FranciscoD: asch 'André Schwarz' <andreschwarz@gmail.com>
13:03:38 <sg1> JOIN
13:03:41 <FranciscoD> shantorn: too late :P
13:03:46 <Godoshian> Hi name is Arman +3
13:04:07 <FranciscoD> asch++
13:04:07 <zodbot> FranciscoD: Karma for asch changed to 1 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:04:09 <fork208> Hi there. I'm Antonin from Czech Republic.
13:04:12 <ankit01ojha> Its seems there are many people connected to channel but not introduced yet
13:04:17 <FranciscoD> there's a cookie to get your started asch_ :)
13:04:20 <shantorn> FranciscoD, hello you awnry man
13:04:34 <FranciscoD> s/your/you
13:04:36 <linuxmodder> would any newcomers not introduced please give a quick intro ?
13:04:52 <FranciscoD> we'll begin with the session in another few minutes - no worries
13:04:57 <FranciscoD> shantorn: hello - long time :)
13:05:03 <asch_> FranciscoD: ty :)
13:05:06 <fatek> i'm in the PST time zone
13:05:11 <linuxEnthusiast> FranciscoD: what is asch ?
13:05:12 <shantorn> it is a pleasure as always old friend
13:05:26 <FranciscoD> linuxEnthusiast: that's his FAS username - if you sign up for Fedora, you'll get one too
13:05:28 * Southern_Gentlem is here
13:05:35 <Godoshian> FranciscoD, i am new to Fedora
13:05:37 <FranciscoD> FAS = Fedora Account system - https://admin.fedoraproject.org/accounts/
13:05:39 <linuxmodder> Southern_Gentlem, morning
13:05:40 <Southern_Gentlem> .hello jbwilla
13:05:41 <zodbot> Southern_Gentlem: Sorry, but you don't exist
13:05:45 <asch_> linuxEnthusiast: That's me
13:05:48 <FranciscoD> Godoshian: got a Fedora username yet?
13:05:49 <Southern_Gentlem> .hello jbwillia
13:05:50 <Godoshian> i don't think I have a FAS account but i have a red hat developer account
13:05:50 <zodbot> Southern_Gentlem: jbwillia 'Ben Williams' <vaioof@gmail.com>
13:06:00 <linuxmodder> Godoshian,  welcome
13:06:01 <linuxEnthusiast> asch_:  aha sorry my bad :)
13:06:19 <FranciscoD> Godoshian: ah, ok, you'll have to get an FAS account too - all Fedora infrastructure is linked to it
13:06:33 <FranciscoD> OK, waiting 4 more minutes for any late comers
13:06:40 <hdost> +1 have a FAS account
13:06:43 <pany> .hellomynameis pany
13:06:44 <zodbot> pany: pany 'Pany' <geekpany@gmail.com>
13:06:49 <FranciscoD> In the meantime, these are the notes I've made for this session: https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8
13:06:54 <FranciscoD> .hello hdost
13:06:55 <zodbot> FranciscoD: Sorry, but you don't exist
13:06:58 <hdost> .hellomynameis hdost
13:06:59 <zodbot> hdost: Sorry, but you don't exist
13:07:00 <linuxmodder> everything from pagure and WP instance on up Godoshian
13:07:17 <FranciscoD> hdost: either you've marked your account as private, or you haven't mentioned your IRC nick in FAS
13:07:21 <FranciscoD> pany++
13:07:21 <zodbot> FranciscoD: Karma for pany changed to 1 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:07:23 <ankit01ojha> FranciscoD: that seems nice
13:07:45 <Godoshian> must i do it now
13:07:52 <hdost> .hellomynameis hdost
13:07:54 <zodbot> hdost: Sorry, but you don't exist
13:07:55 <FranciscoD> Godoshian: no, no need
13:07:59 <hdost> boo
13:08:08 <linuxmodder> but before you wish to touch fedora infra you wil
13:08:13 <FranciscoD> this session doesn't require you to have an FAS account
13:08:34 * TCMSLP waves
13:09:08 <shantorn> FranciscoD, i will have to leave at the 50min mark from now
13:09:09 <FranciscoD> hello TCMSLP - welcome to the classroom session
13:09:10 <linuxmodder> TCMSLP, welcom
13:09:20 <FranciscoD> shantorn: no worries, you probably know most of this already ;)
13:09:22 <shantorn> welcome TCMSLP
13:09:33 <FranciscoD> Right, let's get started
13:09:36 <shantorn> welcome meirc
13:09:42 <FranciscoD> #topic Pre-requisits
13:09:45 <meirc> thx
13:09:51 <shantorn> welcome mech
13:09:53 <FranciscoD> #info A linux system - preferably Fedora since that's what I'm using
13:10:04 <FranciscoD> #info A terminal emulator - any one - running bash
13:10:41 <FranciscoD> #info The only windows you'll need open will be your IRC client, and the terminal emulator - we'll try and get all our help offline!
13:11:30 <FranciscoD> #info If you have a question, please use "?" to get a chairs attention - we'll give you turns. If it's a general query, I'd suggest waiting till the end of the session to ask your question.
13:11:41 <FranciscoD> That way, the session will maintain it's flow :)
13:11:44 <baoboa> .hello baoboa
13:11:45 <zodbot> baoboa: baoboa 'None' <baoboadev@gmail.com>
13:11:51 <FranciscoD> baoboa++
13:11:51 <zodbot> FranciscoD: Karma for baoboa changed to 1 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
13:11:53 <FranciscoD> ;)
13:12:10 <FranciscoD> OK, a bit of background - to set the context up
13:12:15 <FranciscoD> #topic Introduction
13:12:46 <FranciscoD> So, you've got all your fancy hardware, and one needs a program to be able to interact with it
13:13:19 <FranciscoD> This is what the kernel does - you have your drivers and whatnot, and the kernel sends and receives information from your hardware - your input/output devices, all of it
13:13:50 <baoboa> hello to you all, that's CEST+1 for me
13:13:50 <FranciscoD> Now, for us (users) to be able to tell the kernel what to do, we need some software too - that's where the shell comes in
13:14:23 <FranciscoD> The shell is a program that provides some basic commands that permit the user to carry out various tasks
13:14:52 <FranciscoD> There is more than one shell too - we're using bash for this session, which is a pretty commonly used shell, but you also have csh, tcsh, zsh, and other variants.
13:15:14 <FranciscoD> They're similar but provide different features - please give them all a try to satisfy your curiosity :)
13:15:33 <FranciscoD> For this session, here are my notes - https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8
13:15:46 <FranciscoD> The most important section there is the "command pool" section
13:16:05 <FranciscoD> If you have a query, please say "?"
13:16:14 <FranciscoD> Else, I'll proceed with "builtins"
13:16:34 <linuxmodder> brezoi, welcome
13:16:36 * FranciscoD waits
13:16:46 <linuxmodder> notes https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8 brezoi
13:17:00 <FranciscoD> #info Notes for this session - https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8
13:17:10 <brezoi> linuxmodder: thanks
13:17:15 <FranciscoD> OK, let's move then :)
13:17:22 <FranciscoD> #topic builtins
13:17:37 <FranciscoD> These are commands that come "with the shell" - as the name says, they're built in
13:17:41 <linuxmodder> brezoi,  we are about to go into built ins if any questions give '?'  to get our attentiom
13:17:58 <FranciscoD> There are lots, and I'll come to them in due course
13:18:10 <FranciscoD> let's first see how we can get some help
13:18:26 <FranciscoD> try: man builtins
13:18:46 <FranciscoD> the manual for builtins should open up - to navigate use your up and down arrows, to quit, press q
13:18:59 <FranciscoD> this is a page from the Linux manual - most commands will have a manual
13:19:16 <FranciscoD> similarly, try: man bash
13:19:33 <FranciscoD> if you run into trouble, let us know using "!"
13:20:24 <FranciscoD> Man pages are usually quite comprehensive - they give you details on how commands work, what options you can give them, what bugs can be expected, and even examples of usage
13:20:45 <FranciscoD> And, these are offline - i.e., they're on your computer - there's no need to connect to the internet to view man pages
13:21:03 <FranciscoD> Of course, please also try: man man ;)
13:21:27 <linuxmodder> pay attention to syntax in a man page some commands have funny [ ] {} syntax for what is what
13:21:33 <FranciscoD> +1
13:22:01 <FranciscoD> if you were able to view the man pages, let us know by saying +1
13:22:09 <linuxEnthusiast> +1
13:22:10 <ZephOne> +1
13:22:13 <brezoi> +1
13:22:14 <ankit01ojha> +1
13:22:17 <fork208> +1
13:22:26 <asch_> +1
13:22:27 <mech> +1
13:22:29 <sschmidt> +1
13:22:32 <meirc> +1
13:22:34 <DodoSk> +1
13:22:35 <fatek> +1
13:22:38 <linuxmodder> #info +1
13:22:43 <Godoshian> +1
13:22:57 <FranciscoD> Great, so a quick look at "builtins" then
13:23:17 <FranciscoD> They're all mentioned in man builtins. Let's begin with some directory related ones
13:23:36 <FranciscoD> Note, that most linux commands are named so that you easily know what they do
13:23:48 <FranciscoD> for example, "cd" means "change directory"
13:23:58 <FranciscoD> so, let's do that then - try cd /
13:24:14 <FranciscoD> that's "cd" followed by a space and a "/"
13:24:38 <FranciscoD> you've changed to "/" - which is referred to as "root"
13:24:49 <FranciscoD> try the following commands and see if they do what you expect:
13:24:59 <FranciscoD> ls - list directory contents
13:25:02 <linuxmodder> note: root != /root/
13:25:11 <FranciscoD> pwd - present working directory
13:25:20 <ankit01ojha> linuxmodder: +1
13:25:28 <FranciscoD> linuxmodder: +1 /root/ is the "home folder" for the user called "root"
13:25:54 <FranciscoD> now, instead of only ls, try: ls -l
13:26:24 <FranciscoD> also, try: ls -lsh
13:26:49 <ankit01ojha> for hidden files ls- a
13:26:52 <FranciscoD> "-l" and so on are referred to as "options" or "flags"
13:26:56 <FranciscoD> ankit01ojha: will come to that ;)
13:27:04 <linuxmodder> the -l -lsh  are known as switches ( adding additional functionality or clarity to the base command)
13:27:20 <FranciscoD> most commands have a "default behaviour", and additional options can be used by specifying flags
13:27:35 <FranciscoD> if you're good till now, let me know by going +1 again :)
13:27:47 <brezoi> ls is not technically 'builtin', at least not in the builtin manpage, correct?
13:27:50 <Godoshian> +1
13:27:52 <linuxEnthusiast> +1
13:27:53 <FranciscoD> brezoi: +1
13:27:56 <meirc> +1
13:27:57 <fork208> +1
13:27:58 <brezoi> +1
13:27:59 <sschmidt> +1
13:28:00 <ankit01ojha> +1
13:28:01 <DodoSk> +1
13:28:11 <FranciscoD> brezoi: that's correct - it has it's own man page - man ls
13:28:11 <aditya_r> +1
13:28:15 <asch_> +1
13:28:18 <linuxmodder> trivia: what is ls -lsh showing ?
13:28:32 <meirc> permissions
13:28:34 <FranciscoD> and
13:28:39 <FranciscoD> ?
13:28:48 <meirc> date
13:28:49 <asch_> data sizes in human readable format.
13:28:52 <linuxmodder> open to all to answer
13:28:52 <linuxEnthusiast> ownerships
13:28:54 <FranciscoD> +1
13:28:55 <FranciscoD> +1
13:29:23 <FranciscoD> also the timestamp, but you can read more on the specifics later
13:29:28 <meirc> r=read, w=write, x=execute
13:29:33 <FranciscoD> meirc: +1
13:29:34 <linuxmodder> trivia 2: how would you show a selinux context with ls ?
13:30:07 <FranciscoD> linuxmodder: probably not worth going into if we're not going to speak about selinux ;)
13:30:14 <FranciscoD> ok, here's another great builtin: apropos
13:30:25 <FranciscoD> try: apropos builtin
13:30:31 <FranciscoD> what does it give you?
13:30:44 <linuxmodder> TheKanterist, welcome to our class notes:https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8 follow along and '?' for a question "!" for an issue you may hit
13:30:49 <brezoi> simliar commands
13:31:09 <FranciscoD> brezoi: sort of - it goes through the man page database and lists man pages that may have the term "builtin" in them
13:31:20 <FranciscoD> that's a list of man pages
13:31:30 <FranciscoD> so, it's a great way of finding man pages
13:31:39 <FranciscoD> for instance, try: man ssh
13:31:43 <FranciscoD> er.. apropos ssh
13:32:05 <FranciscoD> you'll see a list of man pages related to ssh and then you can read the one you think contains the info you're looking for
13:32:30 <FranciscoD> If apropos does not work for you, let us know by saying "-1"
13:32:42 <FranciscoD> (sometimes the mandb needs to be updated - sudo mandb_
13:32:49 <linuxmodder> jadupl2, , welcome to our class notes: https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8 follow along and '?' for a question "!" for an issue you may hit
13:32:50 <FranciscoD> (sudo mandb)
13:33:09 <baoboa> ls is the default alias in fedora \ls is from the $PATH
13:33:26 <FranciscoD> baoboa: we're coming to aliases in a minute ;)
13:33:33 <baoboa> ok
13:33:43 <FranciscoD> ok, everyone knows "clear" - go ahead and "clear your screen"
13:33:51 <FranciscoD> hit "cd" again
13:33:58 <FranciscoD> use "pwd" to see where that gets you ;)
13:34:40 <FranciscoD> you should be in your user's home directory
13:34:42 <linuxmodder> Poornima, welcome to our class notes: https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8 follow along and '?' for a question "!" for an issue you may hit
13:35:01 <FranciscoD> if you're there, use +1 to let me know, if you arent, use -1 to let me know
13:35:12 <brezoi> +1
13:35:14 <ankit01ojha> +1
13:35:21 <meirc> +1
13:35:21 <linuxEnthusiast> +!
13:35:23 <asch_> +1
13:35:23 <fork208> +1
13:35:24 <linuxEnthusiast> +1
13:35:32 <sschmidt> +1
13:35:44 <FranciscoD> Ok, great
13:35:46 <linuxmodder> good so far
13:35:49 <pany> +1
13:35:49 <FranciscoD> try another builtin: which
13:35:59 <FranciscoD> it isn't a built in actually
13:36:01 <linuxmodder> the two new comers still making sense to you ?
13:36:13 <heretical> yes
13:36:18 <FranciscoD> but, try the following - which ls; which pwd; which which; which man
13:36:34 <linuxmodder> heretical, welcome to our class notes: https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8 follow along and '?' for a question "!" for an issue you may hit
13:36:45 <Godoshian> +1
13:36:47 <linuxmodder> heretical,  we are at builtins
13:36:59 <FranciscoD> "which ls; which pwd; which which; which man" - try that in one line - see what you get
13:37:06 <FranciscoD> without the quotes, of course
13:37:18 <FranciscoD> you'll learn something about ";"
13:37:35 <FranciscoD> which tells you where a command is defined
13:37:56 <FranciscoD> did anyone see an "alias" mentioned in the output of "which ls"?
13:38:05 <aditya_r> yes
13:38:05 <linuxEnthusiast> ye
13:38:06 <brezoi> yes
13:38:08 <FranciscoD> great
13:38:11 <ankit01ojha> yep
13:38:15 <fork208> yes
13:38:17 <heretical> yes
13:38:18 <asch_> yes
13:38:25 <FranciscoD> try these two commands: "ls" and "\ls"
13:38:37 <FranciscoD> see if the output differs - it should
13:39:18 <FranciscoD> now, try this: "alias ls=ls", and check "ls" and "\ls" again - now the output should be the same ;)
13:39:29 <FranciscoD> if it is, let us know using +1
13:39:29 <DeathRowRecords> r we start yet? is this live? testing 1 . . . 2 . . . 3 ( so whats the topic 4 2day ) linux cli. OK! Question: how come in windows DiskPart "clean all" is taking 1h 30min ( HHD 250GB ) and on Fedora Desktop Utility zero all 2h 27 min ( i'm like what the hell )
13:39:40 <asch_> +1
13:39:49 <FranciscoD> DeathRowRecords: wrong channel, please go to #fedora
13:40:04 <DeathRowRecords> -_-?
13:40:08 <fork208> +1
13:40:09 <linuxEnthusiast> +1
13:40:09 <sschmidt> +1
13:40:13 <ankit01ojha> +1
13:40:17 <meirc> +1
13:40:28 <Godoshian> +1
13:40:32 <FranciscoD> great!
13:40:32 <baoboa> +1
13:40:35 <heretical> +1
13:40:43 <FranciscoD> what alias does is lets you modify the definition of a command
13:40:56 <linuxmodder> DeathRowRecords,  this is a class on cli not a help channel #fedora is
13:41:15 <FranciscoD> you can go back to the initial definition by using alias ls="ls --color=auto"
13:41:35 <FranciscoD> aliases come in handy
13:41:52 <FranciscoD> for instance, usually, rm is aliased as alias rm="rm -i"
13:42:00 <FranciscoD> quickly look at the rm man page to see what -i does!
13:42:12 <DeathRowRecords> class on cli i got ya but there is slight big differences with question ( good manners ) and please help
13:42:14 <FranciscoD> tip - to search a man page, use /blah
13:42:24 <linuxmodder> skamath, x3mboy, dominicpg, welcome to our class notes: https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8 follow along and '?' for a question "!" for an issue you may hit
13:42:32 <FranciscoD> DeathRowRecords: please go to the right channel - at present, you're disturbing the class
13:42:41 <brezoi> -i     prompt before every removal
13:42:47 <FranciscoD> brezoi: +1
13:42:53 <FranciscoD> makes rm safer ;)
13:43:19 <FranciscoD> Ok, let's go on to other commands then - we'll go through various tasks and learn that way
13:43:20 <linuxmodder> interactiveness is almost a must with a command like rm
13:43:55 <FranciscoD> NOTE - as far as possible, never run "rm" with sudo/su - it's extremely dangerous!
13:44:09 <FranciscoD> #topic Commands, hands-on fun!
13:44:18 <FranciscoD> is everyone in their home directory?
13:44:23 <FranciscoD> cd if you aren't
13:44:44 <brezoi> (cd ~)
13:44:45 <Godoshian> +1
13:44:48 <brezoi> +1
13:44:52 <asch_> +1
13:44:56 <fork208> +1
13:44:58 <meirc> +1
13:45:00 <aditya_r> +1
13:45:09 <pany> +1
13:45:10 <FranciscoD> try: tree -L 1
13:45:10 <linuxmodder> note: cd can traverse or reverse several directories like cd ../../test
13:45:22 <FranciscoD> also try: tree -L 2
13:45:24 <FranciscoD> tree -L 3
13:45:47 <FranciscoD> brezoi: ~ is optional
13:45:55 <heretical> +1
13:45:59 <FranciscoD> now, try: tree -L 1 /
13:46:12 <baoboa> +1
13:46:12 <aditya_r> +!
13:46:20 <linuxmodder> skamath, Dave__ , welcome to our class notes: https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8 follow along and '?' for a question "!" for an issue you may hit. We are at commands sections ( hand ons
13:46:21 <FranciscoD> and, tree -L 1 ../../
13:46:24 <brezoi> FransicoD: oh yeah
13:46:32 <DeathRowRecords> Well all the best and goodbye :D ( i suggest using "man" page for everything in command line :P ) everything i see here i know :( and nothing new 2 learn
13:46:35 <FranciscoD> aditya_r: is that a stray shift? :)
13:46:47 <FranciscoD> DeathRowRecords: it's a 101 session ;)
13:46:51 <Poornima> :)
13:47:05 <FranciscoD> for the last two commands, you'd get the same output
13:47:27 <FranciscoD> in tree -L 1 /, you specified an "absolute path" - you said exactly what directory you want to see
13:47:56 <FranciscoD> in the second version, tree -L 1 ../../, you specified a "relative path" - you said what path you wanted relative to where you are now
13:48:01 <FranciscoD> ".." is the parent directory
13:48:11 <FranciscoD> so ../../ means parent of parent of this
13:48:30 <linuxmodder> also if you want to ignore . .. in an ls command ls -A is handy
13:48:56 <FranciscoD> yea - try this: ls -lAsh
13:49:03 <FranciscoD> and compare if with ls -l
13:49:15 <FranciscoD> what extra files/folders do you see?
13:49:24 <linuxmodder> trivia: ls -lsh shows a .  and .. what are they?
13:49:59 <FranciscoD> you already know what .. is, you can guess what . is ;)
13:50:05 <FranciscoD> try: tree -L 1 .
13:50:35 <FranciscoD> did everyone see files/folders who's names start with a "." when using -a/-A?
13:50:49 <linuxEnthusiast> yes
13:50:51 <x3mboy> Hidden files
13:50:51 <FranciscoD> here, files/folders starting with a "." are "hidden files/folders"
13:50:55 <FranciscoD> x3mboy: +1
13:50:58 <shantorn> take care all!
13:51:03 <asch_> +1
13:51:09 <fork208> +1
13:51:14 <heretical> yes
13:51:25 <Godoshian> +1
13:51:27 <pany> +1
13:51:28 <FranciscoD> Ok, let's do some shakespeare ;)
13:51:48 <FranciscoD> try: mkdir "20170810-fedora-classroom"
13:52:01 <FranciscoD> I'll leave you to guess what mkdir does
13:52:21 <FranciscoD> then run "rmdir 20170810-fedora*"
13:52:38 <FranciscoD> use ls to confirm that these two worked as expected
13:52:53 <FranciscoD> all good? :)
13:52:58 <x3mboy> +1
13:53:01 <linuxEnthusiast> +1
13:53:02 <fork208> +1
13:53:05 <meirc> +1
13:53:13 <heretical> yes
13:53:17 <Godoshian> +1 :)
13:53:18 <FranciscoD> Great, make the directory again - just to keep things organised
13:53:30 <FranciscoD> mkdir "20170810-fedora-classroom"
13:53:37 <FranciscoD> let's download a play from Gutenburg
13:53:40 <FranciscoD> try: wget http://www.gutenberg.org/cache/epub/1120/pg1120.txt
13:54:02 <asch_> +1
13:54:15 <x3mboy> Oh, sorry, too much for android
13:54:25 <meirc> +1
13:54:34 <FranciscoD> use ls to confirm that a file was downloaded - pg1120.txt
13:54:57 <FranciscoD> copy it to the directory you created using cp: cp pg1120.txt 20170810-fedora*
13:55:07 <FranciscoD> then confirm that the copy was successful using ls 20170810-fedora*
13:55:10 <aditya_r> +1
13:55:21 <FranciscoD> TIP - try cp pg11<TAB> - it'll autocomplete the name
13:55:45 <FranciscoD> similarly, after writing 20170810-<TAB> will complete the name - makes usage much easier, and reduces typo errors
13:55:52 <asch_> +1
13:56:06 <heretical> permisssion denied
13:56:09 <heretical> haha
13:56:19 <FranciscoD> heretical: er - in your home directory?
13:56:29 <heretical> ah ok
13:56:47 <FranciscoD> now, try the rmdir command again
13:56:51 <aditya_r> +1
13:56:52 <FranciscoD> rmdir 20170810*
13:56:55 <FranciscoD> what does it say?
13:56:57 <dominicpg> dir not empty
13:57:07 <FranciscoD> dominicpg: +1
13:57:07 <linuxmodder> this should all be in your /home heretical  we only once went to /  for demo
13:57:19 <heretical> ok
13:57:24 <FranciscoD> rmdir is a safe commnd - it will only delete empty directories!
13:57:48 <FranciscoD> you can remove the copy of the file in your current directory
13:57:54 <FranciscoD> rm -i pg<tab>
13:58:12 <FranciscoD> then, enter the new directory - we'll try a few things in there
13:58:27 <FranciscoD> NOTE - looks like we'll overrun our 1 hour mark, you're free to leave whenever you want, of course :)
13:58:31 <linuxmodder> ( if not in 20170810-fedora-classroom, run that with the path or cd into that directory)
13:59:13 <FranciscoD> is everyone in the new directory, and does everyone have the downloaded file in there?
13:59:20 <fork208> +1
13:59:25 <aditya_r> yes
13:59:31 <Godoshian> +1
13:59:34 <dominicpg> +1
13:59:35 <heretical> yes
13:59:38 <FranciscoD> I'll wait a minute
13:59:46 <x3mboy> +1
13:59:50 <linuxEnthusiast> +1
13:59:53 <asch_> +1
14:00:00 <baoboa> +1
14:00:01 <FranciscoD> so far so good :)
14:00:08 <sschmidt> +1
14:00:19 <FranciscoD> let's create a new alias to make life easier
14:00:28 <FranciscoD> alias ls="ls -lAsh"
14:00:35 <FranciscoD> now run ls to see some info on the file
14:00:47 <FranciscoD> you can even do this
14:00:56 <FranciscoD> alias lash="ls -lAsh"
14:01:00 <FranciscoD> and then use "lash"
14:01:08 <linuxmodder> Poornima, welcome back
14:01:09 <FranciscoD> that way, ls remains unchanged, and you have a new handy command
14:01:32 <hdost> +1
14:01:42 <x3mboy> Am I the only crazy one that use the sort directories first parameter with ls?
14:02:06 <FranciscoD> x3mboy: -t?
14:02:11 <x3mboy> Yeap
14:02:14 <FranciscoD> let's try that
14:02:16 <FranciscoD> ;)
14:02:19 <linuxmodder> if you wish to keep any of these long term take the alias command we use and add to ~/.bashrc Or wahtever shell you prefers rc file
14:02:28 <FranciscoD> if you created the lash alias, try this now: lash -t
14:02:46 <FranciscoD> it runs this: "ls -lAsh -t"
14:03:12 <FranciscoD> so aliases aren't new commands exactly - they're replaced by whatever you defined them to be
14:03:17 <linuxmodder> which is eerily similar to tree you'll notice with more info
14:03:36 <FranciscoD> the advantage of tree is that it gives you a nicely formatted tree diagram
14:03:40 <FranciscoD> comes in handy sometimes
14:03:53 <linuxmodder> pany,  connection issues?
14:04:01 <pany> yeah
14:04:09 <x3mboy> And also info about each file or directory can be added with parameters
14:04:21 <x3mboy> To the tree command, I meant
14:04:32 <FranciscoD> +1
14:04:45 <FranciscoD> let's see if we all have fpaste installed - try: which fpaste
14:05:03 <FranciscoD> if it says /usr/bin/fpaste, try this: lash | fpaste
14:05:05 <x3mboy> -1 not on android
14:05:23 <FranciscoD> if you get two links in return, let us know using +1
14:05:29 <FranciscoD> if you don't, let us know using -1
14:05:36 <FranciscoD> to know what fpaste does, use man fpaste
14:05:49 <FranciscoD> or fpaste -h
14:05:50 <dominicpg> +1
14:05:53 <sschmidt> +1
14:05:59 <linuxEnthusiast> +1
14:06:02 <heretical> +1
14:06:03 <FranciscoD> click the link you get to see if it's correct
14:06:08 <fork208> not installed
14:06:33 <FranciscoD> fork208: not a fedora system? if you have python installed, you can just fetch the script
14:07:01 <fork208> :-) sorry, playing on production system...
14:07:05 <dominicpg> fork208,  #dnf install fpaste
14:07:08 <asch_> +1
14:07:20 <dominicpg> amen
14:07:35 <fork208> I will note it and try at home.
14:07:40 <FranciscoD> or you can do wget https://pagure.io/fpaste/raw/master/f/fpaste
14:08:47 <FranciscoD> it doesn't need admin privs
14:09:00 <FranciscoD> ok, lets get some more info on our play
14:09:06 <FranciscoD> wc pg*
14:09:28 <FranciscoD> wc = word count - tells you words, lines, all of that
14:09:33 <FranciscoD> wc -l pg*
14:09:39 <FranciscoD> also try: file pg*
14:09:41 <aditya_r> 3328  22766 141589 pg1120.txt
14:09:55 <FranciscoD> aditya_r: +1
14:10:05 <FranciscoD> everyone should get the same output ;)
14:10:22 <fork208> +1
14:10:24 <heretical> yeap
14:10:30 <linuxmodder> fork208,  on fedora ?
14:10:35 <asch_> +1
14:10:41 <FranciscoD> try the following commands
14:10:56 <linuxmodder> fork208,  is nc installed ?
14:11:08 <FranciscoD> head pg<TAB>; tail pg<TAB>; more pg<TAB>; less pg<TAB>
14:11:13 <FranciscoD> (one by one)
14:11:14 <linuxmodder> you can replace | fpaste with | nc termbin 9999
14:11:29 <FranciscoD> to get out of more and less, you hit "q"
14:11:30 <linuxmodder> you can replace | fpaste with | nc termbin.com 9999  << proper address
14:11:33 <fork208> nc + wc is installed. But fpaste not.
14:11:48 <FranciscoD> less is similar to more, but with added features
14:11:57 <aditya_r> ?
14:12:02 <FranciscoD> so you haven't used a text editor yet!
14:12:07 <FranciscoD> aditya_r: yes? :)
14:12:07 <linuxmodder> aditya_r, go ahead
14:12:09 <aditya_r> what is nc?
14:12:17 <linuxmodder> netcat
14:12:22 <FranciscoD> aditya_r: man nc ;)
14:12:33 <FranciscoD> linuxmodder: shame on you for telling him! :P
14:12:40 <linuxmodder> FranciscoD,  :(
14:12:53 <FranciscoD> aditya_r: before you ask, look up the docs :)
14:13:04 <FranciscoD> did head/tail/more/less work for everyone? :)
14:13:05 <aditya_r> ok
14:13:06 <linuxmodder> man tells how and what I didn't do all his work for him
14:13:17 <dominicpg> +1
14:13:25 <linuxEnthusiast> +1
14:13:30 <sschmidt> +1
14:13:40 <FranciscoD> try: head pg<TAB> > anewfile.txt
14:14:09 <heretical> +1
14:14:13 <FranciscoD> also try: tail pg<TAB> > anewnewfile.txt
14:14:27 <FranciscoD> then check if these files contain what you expect
14:14:45 <FranciscoD> without using editors, of course
14:15:02 <FranciscoD> try this: cat anewfile.txt
14:15:02 <linuxmodder> no  love for editors ?
14:15:07 <FranciscoD> linuxmodder: not yet
14:15:29 <FranciscoD> now, try: cat anew*
14:15:33 <x3mboy> Vim next week and emacs the next one to that
14:15:38 <x3mboy> ;)
14:15:39 <FranciscoD> x3mboy: +1
14:15:49 <FranciscoD> now, try: cat anew* > whatisthis.txt
14:15:57 <FranciscoD> then try: wc -l *
14:16:04 <FranciscoD> see if the numbers look right?
14:16:08 <heretical> good
14:16:27 <FranciscoD> cat = concatenate
14:16:36 <FranciscoD> but wait, you also have "tac"
14:16:53 <FranciscoD> now, try: tac anew* > anothercat.txt
14:17:11 <FranciscoD> run wc -l * again to see what numbers you get
14:17:17 <FranciscoD> what did tac do?
14:18:13 <FranciscoD> where cat goes line by line from top to bottom, tac goes from bottom to top
14:18:25 <FranciscoD> everyone see that? +1 for yes, -1 for anything else :)
14:18:33 <linuxmodder> +1
14:18:35 <asch_> +1
14:18:36 <sschmidt> +1
14:18:39 <bt0> +1
14:18:41 <mech> +1
14:18:45 <fork208> +1
14:18:46 <dominicpg> +1
14:19:08 <FranciscoD> what play is this then? Can you find out and tell me please?
14:19:12 <FranciscoD> again, no editors
14:19:14 <linuxmodder> pany, heretical ?  still following along?
14:19:17 <heretical> +1
14:19:23 <FranciscoD> use more/less
14:19:27 <pany> +1
14:19:36 <linuxEnthusiast> +1
14:19:55 <ankit01ojha> +1
14:20:03 <FranciscoD> the name is in the first bit - don't scroll down to quickly!
14:20:18 <FranciscoD> how about we search for the info instead?
14:20:37 <FranciscoD> try this: grep shakespeare pg<TAB>
14:20:49 <FranciscoD> you'll get nothing - if you do, let me know!
14:20:53 <linuxmodder> brian83, , welcome to our class notes: https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8 follow along and '?' for a question "!" for an issue you may hit. We are at commands sections ( hands on section
14:21:20 <FranciscoD> everyone get nothing?
14:21:31 <heretical> +1
14:21:38 <linuxEnthusiast> +1
14:21:39 <dominicpg> I got some but used -i switch with grep :)
14:21:45 <FranciscoD> how about grep Shakespeare pg<TAB>
14:21:48 <FranciscoD> with a capital S?
14:21:49 <sschmidt> +1
14:22:00 <FranciscoD> should get something now
14:22:26 <fork208> +1
14:22:31 <dominicpg> +1
14:22:38 <FranciscoD> but that doesnt tell us the name of the play, does it?
14:22:40 <linuxEnthusiast> +1
14:22:40 <bt0> +1
14:22:41 <linuxmodder> what is grep -i doing there?
14:22:45 <linuxmodder> trivia^
14:22:48 <FranciscoD> linuxmodder: i didn't do -i ;)
14:22:49 <ankit01ojha> +1
14:22:55 <FranciscoD> but try that now: grep -i shakespeare
14:23:04 <FranciscoD> dominicpg: +1
14:23:06 <linuxmodder> FranciscoD, asked as dominicpg  mentioned it
14:23:10 <FranciscoD> +1
14:23:17 <dominicpg> -i ignore case
14:23:31 <FranciscoD> dominicpg: sshh - let them read the man page and find out ;)
14:23:42 <dominicpg> \0/
14:23:44 <dominicpg> ok
14:23:46 <linuxmodder> pnakorn,  welcome to our class notes: https://gist.github.com/sanjayankur31/f40070c6925e8885394d2dd750ae4cb8 follow along and '?' for a question "!" for an issue you may hit. We are at commands sections ( hands on section
14:23:48 <fork208> I must leave. Thanks and bye...
14:24:08 <FranciscoD> try this: grep -B1 -i shakespeare pg<TAB>
14:24:17 <linuxmodder> fork208,  thanks for coming the rest of the class will be up later on the same page you found this class on
14:24:48 <FranciscoD> if the output is more than one screen, pipe it to less!
14:24:51 <FranciscoD> try this: grep -B1 -i shakespeare pg<TAB> | less
14:25:13 <FranciscoD> any luck with the name of the play with this command?
14:25:29 <FranciscoD> doesn't look like it :/
14:25:51 <FranciscoD> how about this now: grep -A1 -i shakespeare pg<TAB>
14:25:54 <FranciscoD> any luck now??
14:26:27 <FranciscoD> everyone get the name of the play from this? +1 for yes, -1 for no
14:26:38 <heretical> +1
14:26:44 <linuxEnthusiast> -1
14:27:18 <FranciscoD> what about the others?
14:27:27 <FranciscoD> (if you're still here :P)
14:27:33 <asch_> -1
14:27:44 <asch_> I know it is The Tragedy of Julius Caesar, tho.
14:27:46 <dominicpg> sorry, silent partner now onward. caring my daughter
14:27:56 <FranciscoD> dominicpg: no worries :)
14:28:02 <FranciscoD> grep -A1 -i shakespeare pg1120.txt | head -n 11 | tail -n 1
14:28:07 <asch_> -B1 does not seem to be enough :)
14:28:27 <FranciscoD> asch_: yep, gotta use -A
14:28:37 <heretical> -A1
14:28:44 <FranciscoD> does everyone understand what this command does: grep -A1 -i shakespeare pg1120.txt | head -n 11 | tail -n 1?
14:28:54 <FranciscoD> trivia - so what line number was the answer in then??
14:29:01 <FranciscoD> based on this command: grep -A1 -i shakespeare pg1120.txt | head -n 11 | tail -n 1
14:29:02 <linuxmodder> FranciscoD, thanks for the grep -A/-B as much as aI use grep never knew those
14:29:21 <FranciscoD> linuxmodder: yeh - they come in handy sometimes
14:29:27 <linuxmodder> 11
14:29:40 <FranciscoD> right - does everyone get how linuxmodder got that too?
14:29:57 <FranciscoD> again, read the man pages later to see what -A/-B do for grep, and what -n does for head and tail
14:29:59 <linuxmodder> I didn't use the head | tail tho :P
14:30:01 <asch_> yup
14:30:05 <heretical> yes
14:30:25 <FranciscoD> ok, let's find how many times the term "Caesar" is used in the text
14:30:27 <FranciscoD> use grep
14:31:04 <FranciscoD> will "grep -i caesar pg<TAB> | wc -l" give us the answer?
14:31:47 <baoboa> +1
14:31:50 <FranciscoD> gives me 272 - is that the number of times "caesar" is mentioned in the text?
14:31:57 <FranciscoD> +1 if you think yes, -1 if you don't
14:32:08 <dominicpg> +1
14:32:16 <asch_> I didn't use -i and got 233 :)
14:32:38 <asch_> -1
14:32:49 <FranciscoD> with a small "c"?
14:32:53 <FranciscoD> I get 0.
14:32:53 <heretical> 272
14:33:04 <linuxEnthusiast> I got 0 as well
14:33:19 <baoboa> 0 too
14:33:24 <FranciscoD> now, look at that command: grep -i caesar pg<TAB> | wc -l
14:33:26 <dominicpg> got 0 with lower c
14:33:31 <FranciscoD> read out to yourself what it's doing
14:33:44 <asch_> no. Caesar,. Uppercase C
14:33:45 <FranciscoD> see if you see why this is *not* the number of times "caesar" was mentioned
14:34:14 <FranciscoD> it actually is the number of lines on which the term "caesar" appears
14:34:21 <asch_> because the term may appear more than once in certain lines
14:34:24 <FranciscoD> +1
14:34:36 <FranciscoD> asch_: well done!
14:34:59 <FranciscoD> now, look at: grep -io caesar pg<TAB> | wc -l
14:35:08 <FranciscoD> do you get 282?
14:35:25 <asch_> +1
14:36:06 <linuxEnthusiast> +1
14:36:08 <aditya_r> +1
14:36:09 <heretical> +1
14:36:15 <FranciscoD> take a minute to read man grep and see what -o does
14:36:17 <sschmidt> +1
14:36:22 <FranciscoD> and see why this is the correct ansewr
14:37:07 <FranciscoD> lesson - be careful of exactly what you're doing ;)
14:37:20 <bt0> :)
14:38:08 <FranciscoD> grep -iE "caesar|cassius|brutus|casca" pg1120.txt
14:38:18 <FranciscoD> let's look at where some other characters are mentioned
14:38:19 <FranciscoD> ^
14:38:54 <FranciscoD> everyone happy with the output here? ;)
14:39:18 <FranciscoD> -E enables "extended mode"
14:39:28 <FranciscoD> the "|" operator works like an "or" operator
14:39:41 <linuxmodder> note the escape characters ARE REQUIRED for a -E usage
14:39:56 <FranciscoD> man 7 regex -> more info, but we won't go into regex now
14:40:01 <linuxmodder> the escapes here are " "
14:40:42 <FranciscoD> oh, wait, we also need -o, don't we?
14:40:52 <FranciscoD> grep -iEo "caesar|cassius|brutus|casca" pg1120.txt
14:40:58 <linuxmodder> -ioE indeed
14:41:11 <FranciscoD> everyone happier now? +1 for yes, -1 if you have a query
14:41:26 <bt0> +1
14:41:35 <linuxEnthusiast> +1
14:41:39 <dominicpg> +1
14:41:46 <linuxmodder> thanks to those who have stuck around beyond the hour time slot
14:41:50 <FranciscoD> +1
14:41:52 <asch_> +1
14:41:56 <heretical> +1
14:41:57 <sschmidt> +1
14:41:57 <dominicpg> how about -b switch with grep ? more fun
14:42:15 <FranciscoD> dominicpg: +1
14:42:25 <FranciscoD> ok, so how do we get a count of all these characters then?
14:42:42 <linuxEnthusiast> pipeline it with wc ?
14:42:57 <FranciscoD> linuxEnthusiast: try it out - what do you get
14:43:21 <FranciscoD> 948 everyone?
14:43:51 <FranciscoD> grep -iEo "caesar|cassius|brutus|casca" pg1120.txt | wc -l
14:43:51 <linuxEnthusiast> I got this : 948 948 6790
14:44:10 <FranciscoD> linuxEnthusiast: use -l to only get line counts :)
14:44:14 <linuxEnthusiast> oh forgot the flag
14:44:22 <linuxmodder> I got only the 948 once
14:45:07 <FranciscoD> +1
14:45:09 <linuxmodder> but I think that is a local issue with another alias
14:45:20 <linuxmodder> sysadmin life :P
14:45:21 <FranciscoD> but, what if we want individual counts of all characters?
14:45:33 <FranciscoD> how would we do that?
14:45:43 <asch_> wc -c ?
14:45:50 <linuxEnthusiast> wc -m ???
14:46:05 <FranciscoD> try them out, see what you get
14:46:19 <FranciscoD> you can grep for individual characters, of course
14:46:22 <FranciscoD> one by one
14:46:24 <linuxEnthusiast> I got 6790
14:46:31 <linuxmodder> oddly in this case same value
14:46:38 <FranciscoD> linuxEnthusiast: it can't be more than 948, can it?
14:46:43 <FranciscoD> that's the total of all mentions
14:47:00 <asch_> lol
14:47:01 <linuxmodder> you said characters
14:47:05 <x3mboy> -c count byters, in text files, bytes = characters
14:47:09 <asch_> man wc to see the difference
14:47:19 <FranciscoD> gah, sorry, by characters I meant the characters in the play XD
14:47:27 <FranciscoD> as in caesar, cassius, brutus..
14:47:28 <FranciscoD> :D
14:47:31 <x3mboy> The only difference should be if you have tabs, no?
14:47:44 <FranciscoD> not characters in the computers sense XD
14:47:58 <linuxmodder> or english paper either :P
14:48:42 <FranciscoD> so, to rephrase, how do we get individual counts of how many times each of these people in the play - caesar, cassius, brutus, casca were mentioned?
14:48:49 <FranciscoD> linuxmodder: clearer?
14:49:24 <ankit01ojha> sorry for being out for sometime, gone for dinner
14:49:26 <FranciscoD> https://paste.fedoraproject.org/paste/ArYumuVG8tq53VSSig6BjA/ -> like this (not yet complete)
14:49:36 <linuxmodder> yes
14:49:55 <linuxmodder> ankit01ojha, welcome back
14:50:00 <linuxEnthusiast> gotta run guys
14:50:14 <heretical> grep -ieo
14:50:16 <linuxmodder> linuxEnthusiast,  ok check the same wiki later for the rest of the logs
14:50:24 <linuxEnthusiast> thanks for the session
14:50:29 <FranciscoD> linuxEnthusiast: +1, thanks for coming
14:50:40 <linuxmodder> approaching 2 hours FranciscoD  fyi
14:50:41 <FranciscoD> we'll finish in 10 minutes
14:50:56 <FranciscoD> linuxmodder: yeh, 10more minutes - we'll just solve this one and end it
14:51:12 <linuxmodder> not an issue was more a congrats comment
14:51:19 <FranciscoD> here's a hint - man sort, man uniq
14:51:21 <FranciscoD> well, two hints
14:51:30 <linuxmodder> remember old series ( years ago) being this long nice to see that return)
14:52:01 <FranciscoD> heretical: asch_: any ideas? ;)
14:52:21 <linuxmodder> grep -iEo "caesar|cassius|brutus|casca" pg1120.txt | wc -l | sort | uniq
14:52:33 <brezoi> thanks guys, gtg
14:52:41 <FranciscoD> linuxmodder: with the wc?
14:53:01 <FranciscoD> stray wc there :)
14:53:04 <linuxmodder> that gives 948
14:53:18 <FranciscoD> grep -iEo "caesar|cassius|brutus|casca" pg1120.txt | sort | uniq -c
14:53:22 <FranciscoD> how about this?
14:53:27 <linuxmodder> doh brain fart
14:53:55 <FranciscoD> so, we find all our names, put them on individual lines, then SORT these lines, and then count them using uniq
14:54:08 <linuxmodder> Ceasar was mentioned more in that tragedy than I remember lordy
14:54:32 <FranciscoD> linuxmodder: yeh, even after they did him, they kept talking about him :P
14:54:42 <FranciscoD> asch_: heretical  - did the last command work for you?
14:54:52 <heretical> worked
14:55:52 <FranciscoD> but there's still a problem - it takes capitals and small letters as two different names :(
14:55:54 <asch_> kinda. "grep -iEo "caesar|cassius|brutus|casca" pg1120.txt | sort | uniq -c" does not show how many times each of them is mentioned.
14:56:17 <FranciscoD> asch_: what does it show?
14:56:56 <pany> Sorry guys, I gotta go, time for bed in my timezone.
14:57:08 <FranciscoD> pany: thanks for coming
14:57:16 <pany> @FranciscoD: thank you
14:57:19 <FranciscoD> How does this look asch_ heretical : grep -iEo "caesar|cassius|brutus|casca" pg1120.txt | sort | tr A-Z a-z | uniq -c
14:57:24 <asch_> now it shows how many times each of them is mentioned. mut differs Brutus from BRUTUS, Caesar from CAESAR, etc
14:57:43 <FranciscoD> asch_: precisely, try the latest command and see if the numbers add up ;)
14:58:02 <asch_> Yup, it shows the desired summed results. ty :)
14:58:09 <FranciscoD> linuxmodder: brutus is your winner ;)
14:58:27 <FranciscoD> again, man tr to see what we did there
14:58:35 <FranciscoD> could also have been done using perl or sed
14:58:40 <FranciscoD> but tr is the simplest utility
14:58:49 <FranciscoD> Let's conclude here with some takeaways
14:58:55 <FranciscoD> #topic Conclusions
14:59:02 <FranciscoD> #info We did not once use a text editor
14:59:03 <FranciscoD> did we?
14:59:13 <heretical> no :)
14:59:14 <linuxmodder> nope
14:59:17 <bt0> no
14:59:20 <FranciscoD> #info piping lets one combine lots of tools and get lots of work done
14:59:21 <asch_> nope
14:59:22 <ankit01ojha> no
14:59:37 <FranciscoD> #info there are different ways of doing the same task
14:59:45 <linuxmodder> and increasingly looks creepy/1337 :P
14:59:49 <FranciscoD> #info read the docs - always read the docs
14:59:56 <FranciscoD> linuxmodder: XD
15:00:12 <FranciscoD> any other takeaways? feel free to add them
15:00:18 <FranciscoD> #ciar heretical bt0 ankit01ojha asch_
15:00:24 <FranciscoD> #chair heretical bt0 ankit01ojha asch_
15:00:24 <zodbot> Current chairs: FranciscoD ankit01ojha asch_ bt0 heretical linuxmodder shantorn
15:00:36 <FranciscoD> you're all chairs, use the info command like I did :)
15:01:13 <FranciscoD> There's a lot more that can be done too - may be I'll do a 102 class continuing this one
15:01:35 <linuxmodder> +1 to a 102 class
15:01:37 <FranciscoD> #action FranciscoD Try to do a command line 102 class picking up where we left off here
15:01:43 <bt0> +1
15:01:48 <heretical> +1
15:01:51 <sschmidt> +1
15:01:54 <FranciscoD> Some commands for you to look into: clear, exit, man, apropos, alias, which, info, echo, env, ls, tree, pwd, cd, pushd/popd, dir, locate, updatedb, find, cp, mv, rename, touch, mkdir, rmdir, rm, free, df, du, history, cat, tac, wc, head, tail, less, more, grep, sed, cut, tr, paste, ps, kill, uniq, sort, wget, bc, rsync, dmesg, lsusb, lspci, dnf, rpm, journalctl, sl, history, ctrl n, awk,
15:02:00 <FranciscoD> fpaste, watch, for, if, &&, ||, chmod, diff, vimdiff, elinks, mpd, ncmpcpp, htop, iotop, top, nethogs, irssi, vim, emacs, gtypist
15:02:01 <linuxmodder> #action linuxmodder to offer to assistance and or co-run a 102
15:02:03 <FranciscoD> #chair sschmidt
15:02:03 <zodbot> Current chairs: FranciscoD ankit01ojha asch_ bt0 heretical linuxmodder shantorn sschmidt
15:02:03 <ankit01ojha> yeah you can take from here on 102
15:02:39 <FranciscoD> try "sudo dnf install sl; sl" if you have sudo rights
15:02:51 <bt0> :D
15:03:08 <FranciscoD> #info resource 1 - man pages
15:03:16 <FranciscoD> #info resource 2 - man info
15:03:27 <FranciscoD> #info resource 3 - use the -h switch/flag/option
15:03:35 <FranciscoD> only then do you need to go online
15:03:47 <FranciscoD> #info online resource 1 - https://rlworkman.net/howtos/rute/
15:04:00 <FranciscoD> #info online resource 2 - http://tldp.org/
15:04:16 <FranciscoD> Please try this really fun command line mystery - https://github.com/veltman/clmystery
15:04:29 <FranciscoD> there's a murder, and you must use command line tools to go through the clues and find who did it!
15:04:39 <linuxmodder> #info https://linuxjourney.com is also a good overall site for command line or scripting at the line
15:04:45 <FranciscoD> Great practice - and there are hints to help
15:05:03 <FranciscoD> OK, if there's nothing else, I'll close the session now
15:05:08 <FranciscoD> Going in 5
15:05:13 <heretical> ok I have to go. Thank you. Will this lesson be on the page?
15:05:24 <FranciscoD> heretical: yes, we'll publish the logs
15:05:26 <linuxmodder> heretical,  yes as are all previosu ones
15:05:42 <linuxmodder> much like a meeting would be
15:05:43 <FranciscoD> You can drop your feedback/comments on this page: https://fedoramagazine.org/fedora-classroom-session-3/
15:05:44 <heretical> thanks again
15:05:55 <bt0> Many thanks FranciscoD++
15:05:55 <zodbot> bt0: Karma for ankursinha changed to 4 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:06:07 <linuxmodder> those classes that use bluejeans or similar with have links to those parts as well
15:06:20 <FranciscoD> #info you can e-mail us feedback on the ML or me personally: classroom@lists.fedoraproject.org , ankursinha AT fedoraproject DOT org
15:06:23 <FranciscoD> #info You can drop your feedback/comments on this page: https://fedoramagazine.org/fedora-classroom-session-3/
15:06:24 <ankit01ojha> FranciscoD: thanks for the session
15:06:33 <mech> FranciscoD: Thanks!
15:06:33 <ankit01ojha> FranciscoD++
15:06:33 <zodbot> ankit01ojha: Karma for ankursinha changed to 5 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:06:38 <linuxmodder> FranciscoD++ ankit01ojha++ pany++ bt0++
15:06:40 <zodbot> linuxmodder: Karma for ankursinha changed to 6 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:06:41 <FranciscoD> thanks for coming everyone :)
15:06:43 <zodbot> linuxmodder: Karma for ankit1997 changed to 1 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:06:43 <linuxmodder> heretical++
15:06:46 <zodbot> linuxmodder: Karma for pany changed to 2 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:06:49 <zodbot> linuxmodder: Karma for bt0dotninja changed to 9 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:07:05 <linuxmodder> sschmidt++
15:07:10 <FranciscoD> OK, closing now
15:07:12 <FranciscoD> #endmeeting