fedora_ci_sig
LOGS
16:00:30 <bookwar> #startmeeting Fedora CI SIG
16:00:30 <zodbot> Meeting started Wed Jun 19 16:00:30 2019 UTC.
16:00:30 <zodbot> This meeting is logged and archived in a public location.
16:00:30 <zodbot> The chair is bookwar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:30 <zodbot> The meeting name has been set to 'fedora_ci_sig'
16:00:52 <bookwar> #topic Roll call
16:01:07 <bookwar> .hello2
16:01:08 <zodbot> bookwar: bookwar 'Aleksandra Fedorova' <alpha@bookwar.info>
16:01:41 <fbo> .hello2
16:01:42 <zodbot> fbo: fbo 'Fabien Boucher' <fboucher@redhat.com>
16:02:10 <bookwar> cool, it is not just me :)
16:02:26 <bookwar> i should have send the announcement to the mailing list again probably
16:03:11 <bookwar> fbo: what do you think? should it be announcement every two weeks before the meeting or calendar is enough?
16:03:12 <fbo> Hi, yes maybe a reminder
16:03:52 <bookwar> #action bookwar to send reminders before meetings
16:03:55 <fbo> before the meeting on the ml
16:04:30 <bookwar> then, since it is two of us, let's discuss my favorite topic :)
16:04:37 <bookwar> #topic Zuul in Fedora
16:04:52 <bookwar> any news?
16:05:06 <fbo> yes a lot :)
16:05:40 <bookwar> ok, it is all yours
16:06:03 <fbo> Some progress on the Zuul Pagure driver, some POC on the job run on PR and also a solution to run Jobs based on fedmsg event
16:06:36 <fbo> On the CI SIG wiki page there is a link to https://fedoraproject.org/wiki/Zuul-based-ci where everything is explained
16:06:58 <fbo> So regarding Zuul Pagure driver. It has been merged in Zuul yesterday
16:07:45 <fbo> https://opendev.org/zuul/zuul/commit/7dc1edb4cdd365b292540e6f130922db0ac7b32c
16:07:47 <bookwar> #link https://fedoraproject.org/wiki/Zuul-based-ci
16:08:21 <bookwar> so all is upstream now?
16:08:37 <fbo> Then regarding running jobs based on fedmsg, we are able to run rpmlint job each time we receive a buidsys event
16:08:45 <fbo> yes all upstream
16:09:18 <fbo> https://fedora.softwarefactory-project.io/zuul/t/fedora-staging/status here you'll see jobs when a build is done on koji
16:09:41 <fbo> https://fedora.softwarefactory-project.io/zuul/t/fedora-staging/builds?project=gateway
16:09:49 <fbo> this link is better that's the history
16:10:37 <bookwar> so we now can have pipeline runs not connected to Pagure
16:10:48 <fbo> But all the technical detail are described here https://fedoraproject.org/wiki/Zuul-based-ci#Buildsys_build_validation_via_AMQP_and_Zuul
16:10:59 <fbo> yes
16:11:46 <bookwar> are you presenting anything of it at Flock?
16:12:17 <fbo> https://pagure.io/flock/issue/129
16:12:19 <fbo> yes ^
16:12:36 <bookwar> #info Zuul at Flock https://pagure.io/flock/issue/129
16:13:08 <fbo> I should talk to that Zuul gateway amqp -> zuul job in the talk
16:13:15 <bookwar> btw, i've advertised some of your work at fedora-devel mailing list
16:13:25 <bookwar> https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/2FNDTFGP2HR4A2D7POSW6SDBNVJ27RRW/
16:14:29 <bookwar> and also i have a question on Zuul and STR's
16:14:30 <fbo> ah I haven't seen it, so i'll have a look after this meeting
16:15:00 <bookwar> #link https://pagure.io/standard-test-roles/pull-request/358
16:15:07 <bookwar> i think we have a problem there
16:15:45 <bookwar> the idea of STR is that we describe test in way which is independent from CI system which is running it
16:16:03 <bookwar> so we can not have zuul-specific role in the str
16:16:30 <bookwar> i think zuul needs to be more like an inventory provider in this case
16:17:09 <fbo> Zuul is already an inventory provider
16:18:16 <fbo> We need to see the best way to interface. For the moement in the POC we have we don't use that role I submitted as PR.
16:18:40 <fbo> But instead we mock standard-test-beakerlib
16:18:43 <bookwar> in this PR if someone specifies "- role: standard-test-zuul" in the test, it means it can not be run in the non-zuul environment
16:18:51 <fbo> with that role https://pagure.io/fedora-zuul-jobs/blob/master/f/roles/run-tests-yml
16:19:04 <bookwar> ok, i should actually take a closer look
16:19:05 <fbo> yes true, so that's not ideal :)
16:19:36 <fbo> I can show some examples
16:19:53 <bookwar> let me put my comments in the PR and continue there
16:20:09 <bookwar> so we are not limited by IRC meeting format
16:20:20 <bookwar> i'll do it after the meeting
16:20:21 <fbo> ok
16:20:31 <fbo> Also see https://stg.pagure.io/python-redis-distgit/pull-request/3
16:20:58 <fbo> python-redis-distgit is just a copy of the rpms/prython-redis from src.fedoraproject.org
16:21:06 <fbo> but on stg.pagure.io
16:21:15 <fbo> we have attach some Zuul jobs on it
16:21:32 <bookwar> looks nice indeed
16:21:55 <fbo> last comment you see Zuul respond with three job result.
16:22:10 <fbo> First job is a scratch build on Koji
16:22:29 <bookwar> #link https://stg.pagure.io/python-redis-distgit/pull-request/3
16:22:36 <fbo> Then there are two childs jobs (build job pass the build rpm to the childs jobs)
16:22:58 <fbo> first child job is rawhide-rpm-test
16:23:08 <fbo> where we mock standard-test-beakerlib
16:23:39 <fbo> But at the end the included test is well executed https://fedora.softwarefactory-project.io/logs/3/3/7d41b28e4e8004f5249043145851457746dc8e32/check/rawhide-rpm-test/bfe3d32/job-output.txt.gz
16:24:09 <fbo> Sorry this link is better https://fedora.softwarefactory-project.io/logs/3/3/7d41b28e4e8004f5249043145851457746dc8e32/check/rawhide-rpm-test/bfe3d32/job-output.txt.gz#_2019-06-19_15_29_26_208547
16:24:39 <bookwar> thanks
16:24:43 <fbo> and the second child job artifact-rpm-lint is a simple linter
16:26:01 <fbo> https://pagure.io/fedora-zuul-jobs-config/blob/master/f/zuul.d/projects.yaml#_25
16:26:46 <fbo> here is the definition of how jobs are attached to repo ^.
16:27:19 <bookwar> any next steps, what are your plans?
16:27:44 <fbo> 1/ Clarify the standard test roles
16:28:21 <fbo> 2/ See how to report back on fedmsg the Zuul jobs. It seems we only lack a valid certificat to publish on the bus
16:28:55 <fbo> 3/ Continue to improve the jobs and roles and see we you which jobs could be grate to have on PR
16:29:09 <fbo> * great *
16:29:43 <fbo> I think the POC is already quite advanced and we need feedback
16:29:49 <bookwar> fbo: if i understand correctly, nothing prevents you to participate in gating already - read a koji build messge, run tests, send result. And bodhi will already be showing it in the interface
16:30:10 <bookwar> and then developers may provide feedback from reading those results
16:31:12 <fbo> yes it seems we manage the load easily on the node and we should be pretty stable. So yes look like we are in a good shape to report result on the bus
16:31:20 <bookwar> for 3) i think raising this question on ci@ mailing list would be a good start. There were some ideas from Fedora QA about tests which might be interesting for everyone
16:32:12 <fbo> yes we should raise what have been done with Zuul on the ML and share the wiki page
16:32:43 <bookwar> ok, thanks for the overview, and that was a great progress indeed, I didn't expect it get this far so fast :)
16:33:02 <fbo> I would like to see if some people are interested to participate in that effort. We need more input now :)
16:33:36 <bookwar> #action fbo to raise thread on ci@ mailing list and get more feedback
16:33:57 <bookwar> :)
16:34:44 <bookwar> i have much smaller update
16:34:51 <bookwar> #topic STR inventory
16:35:17 <bookwar> I've pushed the pull request https://pagure.io/standard-test-roles/pull-request/362
16:35:21 <bookwar> #link https://pagure.io/standard-test-roles/pull-request/362
16:35:47 <bookwar> it is not finished yet, just to show the idea and get initial feedback if there is any
16:36:41 <bookwar> fbo: do you have any other topics to talk about?
16:37:18 <fbo> bookwar: no nothing specific. Are you going to be there at flock ?
16:37:58 <bookwar> yes, though i am very late with a talk submission. but i will be there in any way
16:38:37 <bookwar> i suggest we finish for today, and next time i do a better job announcing the meeting properly
16:39:03 <fbo> alright, for flock I'll be able to attend only thursday and friday
16:39:24 <fbo> I hope if the talk is accepted it will be the right day :)
16:39:44 <fbo> Ok so I'm fine for today too
16:39:50 <bookwar> if not - ping me, or write directly to bex, i think they can help
16:40:05 <bookwar> #endmeeting