f18-alpha-blocker-review-3
LOGS
16:00:15 <tflink> #startmeeting f18-alpha-blocker-review-3
16:00:15 <zodbot> Meeting started Thu Aug 16 16:00:15 2012 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:16 <tflink> #meetingname f18-alpha-blocker-review-3
16:00:16 <zodbot> The meeting name has been set to 'f18-alpha-blocker-review-3'
16:00:21 <tflink> #topic Roll Call
16:00:33 <adamw> yo
16:00:36 <tflink> OK, Who's here for some blocker review happy fun time?
16:01:10 * kparal me me me
16:01:50 <tflink> kparal: at least you seem excited about it :)
16:02:38 * kparal is bluffing
16:02:59 * akshayvyas is here
16:04:12 * nirik is lurking
16:04:43 <tflink> akshayvyas: welcome, welcome
16:05:12 <akshayvyas> tflink: Thanks Thanks :P
16:05:25 * tflink just watched a motorcycle drive by with a pet carrier bolted on to the back
16:05:43 * Martix is back
16:06:09 <tflink> I think we have enough for quorum so let's get started
16:06:20 <tflink> #topic Introduction
16:06:35 <tflink> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:06:53 <tflink> We'll be following the process outlined at:
16:06:54 <tflink> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:06:54 <tflink> The bugs up for review today are available at:
16:06:54 <tflink> #link https://fedoraproject.org/wiki/Current_Release_Blockers
16:06:54 <tflink> The criteria for release blocking bugs can be found at:
16:06:56 <tflink> #link https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria
16:06:59 <tflink> #link https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
16:07:05 <tflink> #link https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
16:07:28 <tflink> The list of blockers up for review today can be found at:
16:07:35 <tflink> #link http://supermegawaffle.com/blockerbugs/current
16:07:57 <tflink> #info 12 Proposed Blockers
16:07:57 <tflink> #info 2 Accepted Blockers
16:07:58 <tflink> #info 0 Proposed NTH
16:07:58 <tflink> #info 0 Accepted NTH
16:08:14 <tflink> unless there are objections, I'll start with the proposed blockers
16:09:03 <tflink> #topic (796479) firewalld conflicts with libvirt's default network
16:09:04 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=796479
16:09:04 <tflink> #info Proposed Blocker, ASSIGNED
16:09:13 <bugbot_> Bug 796479: high, unspecified, ---, laine, ASSIGNED , firewalld conflicts with libvirt's default network
16:09:49 <tflink> crap, I forgot to secretarialize last week :-/
16:10:55 <adamw> oh pants, me too :/
16:11:05 <adamw> i'll go through and do it quick
16:11:55 <robatino> https://fedoraproject.org/wiki/Current_Release_Blockers is redirected to "Final Release Blockers" for 17
16:12:06 <tflink> from last week: Due to being in the middle of branching, we don't currently have any install media to test this with. Will re-visit next week after we've had the opportunity to test it more
16:12:08 <adamw> we only agreed to punt this one, last week
16:12:22 <tflink> robatino: that page isn't being used any more
16:12:28 <adamw> i should be able to test it now, but didn't get around to switching back to firewalld on my f18 host yet
16:12:42 <adamw> tflink: you haven't updated your stock text
16:12:59 <adamw> ah - you have, but you left the old one in there too
16:13:03 <tflink> adamw: ?
16:13:05 <adamw> look up
16:13:15 <adamw> your stock text links to both current_release_blockers and supermegawaffle
16:13:44 <tflink> wow, I didn't notice that
16:13:59 <tflink> the hazards of using canned boilerplate, I guess
16:14:12 * tflink should also update the wiki page to explain what we're doing, anyways
16:14:20 <robatino> BTW i added https://bugzilla.redhat.com/show_bug.cgi?id=848631 as a proposed blocker but it's not on your page yet
16:14:34 <tflink> robatino: it gets synced every 30 minutes
16:14:39 <bugbot_> Bug 848631: unspecified, unspecified, ---, control-center-maint, NEW , repoclosure failure on 18 Alpha TC2 DVDs (control-center)
16:16:11 <tflink> bah, looks like another bug
16:16:18 <tflink> anyhow, back to the topic at hand
16:16:20 <robatino> i added it about 11 hours ago
16:16:32 <adamw> OK, I caught up the secretarializing
16:19:11 <adamw> *twiddles thumbs*
16:19:11 <tflink> has anyone gotten a working install from F18 TC2?
16:19:17 * tflink is still downloading
16:19:20 <adamw> i think only with text mode.
16:19:32 <adamw> it appears to fail to init X on any system - that's one of the bugs we'll get to in this meeting.
16:21:02 <tflink> so I think we're pretty much in the same boat as we were last week :-/
16:21:37 <kparal> it can be installed, but it's very hard
16:21:42 <kparal> lot of problems on the way
16:23:09 <tflink> proposed #agreed 796479 - Installation of F18 TC2 is still problematic and is making any work on this bug difficult, will revisit next week when we will hopefully have fewer install problems
16:23:14 <tflink> ack/nak/patch?
16:24:06 <kparal> ack
16:24:47 <adamw> oh, you were on 796479
16:25:03 <adamw> actually nack - you don't _really_ need an f18 image to test this, just a working f18 host, which i more or less have
16:25:15 <adamw> so as i said above, i ought to be able to check this now by switching to firewalld, i just didn't get around to it yet
16:25:27 <tflink> either way, punt again?
16:25:33 <adamw> yup.
16:26:35 <tflink> proposed #agreed - 796479 - This still need more testing to determine whether or not there's a problem here and whether it's a blocker
16:26:39 <tflink> ack/nak/patch?
16:26:45 <kparal> ack
16:26:48 <adamw> ack
16:26:50 <akshayvyas> ack
16:26:59 <Martix> ack
16:27:25 <tflink> #agreed - 796479 - This still need more testing to determine whether or not there's a problem here and whether it's a blocker
16:27:34 <tflink> #topic (841451) polkitd doesn't start in rawhide
16:27:34 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=841451
16:27:34 <tflink> #info Proposed Blocker, NEW
16:27:40 <bugbot_> Bug 841451: unspecified, unspecified, ---, davidz, NEW , polkitd doesn't start in rawhide
16:28:43 <adamw> so we may have got some progress on this lately
16:29:01 <adamw> i rather suspect it and https://bugzilla.redhat.com/show_bug.cgi?id=844167 are dupes, and the issue is selinux
16:29:06 <bugbot_> Bug 844167: high, unspecified, ---, mgrepl, NEW , Error in PREIN scriptlet in rpm package libvirt-daemon-0.9.11.4-3.fc17.x86_64
16:29:18 <adamw> should be easy enough to confirm when we get a minute
16:30:30 <tflink> sounds like another punt
16:30:59 <adamw> well, punt-with-progress =)
16:31:08 <adamw> we could do a conditional call
16:31:14 <adamw> assuming that turns out to be the case, i make it a beta blocker, not alpha
16:31:43 <adamw> since it would only affect upgrades - f18's selinux-policy doesn't have the bug, which is why doing a 'yum reinstall polkit' after the upgrade has finished solves the problem
16:31:57 <adamw> (or rather, in this theory it's why.)
16:31:58 <tflink> proposed #agreed 841451 - This appears to still be happening but we need a little more confirmation. We also suspect that 841451 and 844167 are dupes.
16:32:54 <Martix> ack
16:33:15 <kparal> ack
16:33:41 <adamw> or we could not!
16:33:48 <adamw> ack, sure.
16:33:51 <tflink> either way
16:34:06 <tflink> but since we have 3 acks
16:34:17 <tflink> #agreed 841451 - This appears to still be happening but we need a little more confirmation. We also suspect that 841451 and 844167 are dupes.
16:34:31 <tflink> #topic (847644) 18 Alpha TC1 install discs fail to boot, drop to emergency mode
16:34:34 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=847644
16:34:36 <bugbot_> Bug 847644: unspecified, unspecified, ---, anaconda-maint-list, VERIFIED , 18 Alpha TC1 install discs fail to boot, drop to emergency mode
16:34:37 <tflink> #info Proposed Blocker, VERIFIED
16:35:03 <tflink> sounds like this can be closed
16:35:18 <kparal> verified is verified, no?
16:35:56 <tflink> usually, yes
16:36:11 <tflink> although I believe that I'm missing your point here
16:36:31 <kparal> that we can just go on, if it is verified
16:37:05 <adamw> tflink: can't be closed until the update is pushed stable
16:37:10 <adamw> we're on the bodhi regime now
16:37:19 <kparal> ah
16:37:41 <tflink> so do we ignore, move it accepted etc.?
16:37:52 <tflink> I thought that it was still up for being a blocker since it isn't closed yet
16:37:53 <adamw> verified is the correct state.
16:38:15 <adamw> we can make it acceptedblocker, i guess. i'm assuming we all agree with that.
16:38:47 <kparal> yes
16:39:08 <Martix> ack
16:39:37 <tflink> proposed #agreed 847644 - AcceptedBlocker - Accepted as a blocker for F18 alpha due to violation of the following F18 alpha release criterion: "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially s
16:40:08 <Martix> ack
16:40:12 <adamw> ack
16:40:19 <kparal> ack
16:40:22 <tflink> #agreed 847644 - AcceptedBlocker - Accepted as a blocker for F18 alpha due to violation of the following F18 alpha release criterion: "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supp
16:41:06 <tflink> wow, my irc client just went slightly crazy
16:41:08 <tflink> fun times
16:41:19 <tflink> #topic (847683) repoclosure failure on 18 Alpha TC1 DVDs (fatrat)
16:41:19 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=847683
16:41:19 <tflink> #info Proposed Blocker, ASSIGNED
16:41:21 <bugbot_> Bug 847683: unspecified, unspecified, ---, jvcelak, ASSIGNED , repoclosure failure on 18 Alpha TC2 DVDs (fatrat)
16:42:10 <tflink> proposed #agreed 847683 - AcceptedBlocker - Accepted as a blocker for F18 alpha due to violation of the following F18 alpha release criterion " There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"
16:42:16 <Martix> propose: vote about all repoclosure bugs at once?
16:42:18 <tflink> ack/nak/patch?
16:42:24 <adamw> tflink: i see a bunch of junk characters before the 'agreed' for 847644
16:42:27 <adamw> i'm not sure it got through
16:42:50 <tflink> adamw: that's when my client went slightly crazy
16:42:53 <robatino> may as well consider https://bugzilla.redhat.com/show_bug.cgi?id=848631 now as well since it hasn't shown up in the last reload
16:42:54 <bugbot_> Bug 848631: unspecified, unspecified, ---, control-center-maint, NEW , repoclosure failure on 18 Alpha TC2 DVDs (control-center)
16:43:24 <adamw> i'm ack on all the repoclosure failures, i think we always take those as blockers
16:43:35 <tflink> adamw: yeah, the junk chars show up in the log
16:43:52 <tflink> prepare yourselves for some meetbot undos
16:43:54 <tflink> #undo
16:43:54 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x1ca081d0>
16:43:56 <tflink> #undo
16:43:56 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x24152250>
16:43:58 <tflink> #undo
16:43:58 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x24152990>
16:44:02 <tflink> #undo
16:44:02 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x29316f50>
16:44:14 <tflink> #agreed 847683 - AcceptedBlocker - Accepted as a blocker for F18 alpha due to violation of the following F18 alpha release criterion " There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"
16:44:32 <tflink> #topic (847689) repoclosure failure on 18 Alpha TC2 DVDs (libkolab)
16:44:32 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=847689
16:44:34 <tflink> #info Proposed Blocker, MODIFIED
16:44:34 <bugbot_> Bug 847689: unspecified, unspecified, ---, kanarip, MODIFIED , repoclosure failure on 18 Alpha TC2 DVDs (libkolab)
16:44:46 <tflink> ok, back to the repoclosure bugs
16:46:10 <adamw> +1 on all the repoclosures.
16:46:18 <Martix> tflink: can we vote about repoclosure bugs in one run? they violate same criterion
16:46:24 <akshayvyas> yep me 2 +1
16:46:28 <Martix> ok adamw was quicker
16:46:58 <Martix> ack all repoclosure bugs
16:47:08 <tflink> proposed #agreed 847689, 847693, 847694, 848631 - AcceptedBlocker - These bugs are accepted as blockers for F18 alpha due to violation of the following F18 alpha release criterion: "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"
16:47:13 <kparal> ack
16:47:53 <adamw> ackity ack ack
16:47:59 <tflink> #info instead of voting on all of the repoclosure bugs separately, we're voting on them all at the same time
16:48:10 <akshayvyas> ack
16:48:25 <tflink> #info the repoclosure bugs in question are 847689, 847693, 847694 and 848631
16:48:41 <tflink> #agreed 847689, 847693, 847694, 848631 - AcceptedBlocker - These bugs are accepted as blockers for F18 alpha due to violation of the following F18 alpha release criterion: "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"
16:48:48 <Martix> ack
16:49:02 <tflink> #topic (848227) anaconda fails to initialize in F18 Alpha TC1 because it uses libgssapi_krb5.so.2, which lorax purges during compose
16:49:05 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=848227
16:49:07 <bugbot_> Bug 848227: urgent, unspecified, ---, mgracik, VERIFIED , anaconda fails to initialize in F18 Alpha TC1 because it uses libgssapi_krb5.so.2, which lorax purges during compose
16:49:08 <tflink> #info Proposed Blocker, VERIFIED
16:50:13 <kparal> +1 blocker
16:50:13 <Martix> tflink: didnt you forgot #847683 as repoclosure?
16:50:27 <adamw> again, this is fixed in tc2, needs to be pushed stable before we can close it, +1 blocker
16:50:37 <tflink> proposed #agreed 848227 - AcceptedBlocker - Violates the following F18 alpha release criterion: "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods"
16:50:43 <tflink> Martix: how so?
16:50:49 <kparal> ack
16:50:51 <tflink> it's in the agreed and the info
16:51:12 <tflink> nvm, I misread the numbers
16:52:07 <tflink> #undo
16:52:07 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x22d32ed0>
16:52:08 <tflink> #undo
16:52:08 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x22d320d0>
16:52:11 <tflink> #undo
16:52:11 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x22d32e10>
16:52:13 <tflink> #undo
16:52:13 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x22d32190>
16:52:16 <tflink> #undo
16:52:16 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x14d71cd0>
16:52:37 <tflink> #info the repoclosure bugs in question are 847689, 847693, 847694, 847683 and 848631
16:53:07 <tflink> #agreed 847689, 847693, 847694, 847683, 848631 - AcceptedBlocker - These bugs are accepted as blockers for F18 alpha due to violation of the following F18 alpha release criterion: "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"
16:53:24 <tflink> #topic (848227) anaconda fails to initialize in F18 Alpha TC1 because it uses libgssapi_krb5.so.2, which lorax purges during compose
16:53:27 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=848227
16:53:28 <bugbot_> Bug 848227: urgent, unspecified, ---, mgracik, ON_QA , anaconda fails to initialize in F18 Alpha TC1 because it uses libgssapi_krb5.so.2, which lorax purges during compose
16:53:29 <tflink> #info Proposed Blocker, VERIFIED
16:53:41 <tflink> proposed #agreed 848227 - AcceptedBlocker - Violates the following F18 alpha release criterion: "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods"
16:53:45 <adamw> ack
16:53:51 <Martix> ack
16:53:54 <kparal> ack
16:54:00 <tflink> #agreed 848227 - AcceptedBlocker - Violates the following F18 alpha release criterion: "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods"
16:54:12 <tflink> #topic (848641) Fedora 18 Alpha TC2 fails to boot from USB stick (written by livecd-iso-to-disk)
16:54:15 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=848641
16:54:17 <bugbot_> Bug 848641: high, unspecified, ---, anaconda-maint-list, NEW , Fedora 18 Alpha TC2 fails to boot from USB stick (written by livecd-iso-to-disk)
16:54:17 <tflink> #info Proposed Blocker, NEW
16:55:04 <tflink> this seems like a pretty clear blocker to me
16:55:10 <tflink> unless other USB methods are working
16:55:27 <adamw> we need to check the others, yeah. can't really make a call on it yet.
16:55:35 <adamw> i was really trying to check if X started on bare metal, at the time :)
16:56:20 <tflink> proposed #agreed - 848641 - USB boot media needs to be checked with outher creation methods before we call this a blocker or not - if one of them is working, this is not a blocker for F18 alpha
16:56:26 <tflink> ack/nak/patch?
16:57:09 <kparal> ack
16:57:12 <Martix> ack
16:57:17 <akshayvyas> i am ack
16:57:26 <tflink> #agreed - 848641 - USB boot media needs to be checked with outher creation methods before we call this a blocker or not - if one of them is working, this is not a blocker for F18 alpha
16:57:37 <tflink> #topic (848682) anaconda boots into a black screen
16:57:37 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=848682
16:57:37 <tflink> #info Proposed Blocker, NEW
16:57:38 <bugbot_> Bug 848682: urgent, urgent, ---, bcl, ON_QA , anaconda boots into a black screen
16:57:55 <adamw> this is the one everyone's hitting with TC2 - X startup never appears to work
16:58:19 <adamw> there's a new lorax which ought to work a bit better. we hope.
16:58:35 <tflink> sounds like it's time for a pre-TC3
16:58:41 <adamw> yeah.
16:58:50 * adamw would dearly love to see an image that boots, at some point.
16:59:25 <tflink> proposed #agreed 848682 - AcceptedBlocker - Violates the following F18 alpha release criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods"
16:59:34 <tflink> ack/nak/patch?
16:59:43 <kparal> ack
17:00:54 <Martix> ack
17:01:42 <tflink> #agreed 848682 - AcceptedBlocker - Violates the following F18 alpha release criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods"
17:01:54 <tflink> #topic (848803) Root password is not set due to missing authconfig
17:01:55 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=848803
17:01:56 <tflink> #info Proposed Blocker, NEW
17:01:58 <bugbot_> Bug 848803: urgent, unspecified, ---, anaconda-maint-list, POST , Root password is not set due to missing authconfig
17:03:16 <adamw> what unholy sacrifices did vadim make to complete an install?!
17:03:20 <adamw> i demand to know
17:03:32 <tflink> has anyone tried ks yet?
17:03:42 * tflink is going to attempt after the meeting
17:03:46 <nirik> wasn't someone saying text worked?
17:03:53 <adamw> tflink: yes. kickstart is busted.
17:03:58 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=847831
17:03:58 <tflink> damnation
17:03:59 <kparal> worked with _obstacles_
17:04:12 <bugbot_> Bug 847831: high, unspecified, ---, wwoods, ASSIGNED , kickstart boot fails
17:04:19 <kparal> anyway, I believe this is a clear blocker
17:04:24 * tflink might just yum upgrade an f17 install, then
17:04:29 <kparal> root password must work
17:04:30 <tflink> but I digress
17:04:45 <tflink> which criterion does this violate?
17:04:57 <tflink> can you login as non-root after firstboot?
17:05:29 <adamw> it may be that we don't have a criterion
17:05:32 <adamw> but we probably ought to
17:05:38 <tflink> I suppose that we could use the updates criterion here
17:05:38 <adamw> hold on while i apply creativity
17:05:46 <tflink> since I don't think you can apply updates w/o root access
17:05:54 <kparal> I don't think we need criteria for such basics
17:06:12 <tflink> kparal: I disagree that we don't need a criterion for it
17:06:22 <kparal> that just make our decisions easier
17:06:22 <tflink> well, mostly
17:06:27 <kparal> *they
17:06:42 <tflink> and repeatable and somewhat trackable
17:06:48 <Martix> criterion is just common sense
17:07:11 <adamw> ah, an excuse to break out my favourite line again
17:07:13 <adamw> common sense: rarely either
17:07:24 <tflink> but you do have a point - if we need a criterion saying that root password must work, we may be drowning in beurocracy
17:07:29 <tflink> and spelling errors
17:07:30 <adamw> bureaucracy*
17:07:32 <adamw> =)
17:07:37 <kparal> let's ask ourselves - do we want to release Alpha without root login working?
17:07:42 <kparal> tflink: that's my point
17:07:53 <tflink> kparal: I never said this shouldn't be a blocker
17:07:53 <Martix> kparal: +1
17:07:55 <akshayvyas> kparal: +1
17:08:12 <adamw> of course not
17:08:13 <kparal> I just don't think everything has to be defined
17:08:25 <adamw> the criteria are useless unless they're comprehensive
17:08:31 <tflink> and I'm not sure where the line should be
17:08:36 <adamw> the whole point of the criteria is that we used to have to argue about judgment calls for hours
17:08:44 <adamw> so we try to remove the judgment element as far as possible: hence the criteria
17:08:58 <adamw> anyhow, i don't think we need a new one
17:09:14 <adamw> "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should boot to a state where it is possible to log in through at least one of the default virtual consoles"
17:09:31 <adamw> that's broken if you can't log in to the root account, because no other account is created during installation.
17:09:35 <Martix> adamw: but we cant remove judgment element on forever
17:09:51 <adamw> Martix: no, but we certainly can in this case
17:09:54 <tflink> adamw: yeah, that's what I was thinking as well
17:10:05 <kparal> I see criteria useful in contentious areas
17:10:09 <adamw> Martix: the objection that has been cited is not 'it's impossible to create a criterion for this', it's 'we can just say 'use common sense' instead'
17:10:15 <tflink> Martix: nobody is suggesting that we remove the human judgement from this
17:10:26 <adamw> anyhow, can we just agree to use an existing criterion and move on?
17:10:27 <tflink> if we did, there would be no point to these meetings
17:10:29 <tflink> yep
17:10:32 <Martix> adamw: ok
17:10:45 <nirik> "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops" ? since yum requires su... ?
17:11:01 <nirik> (although you could set system user and use sudo I guess)
17:11:03 <tflink> proposed #agreed 848803 - AcceptedBlocker - Violates the following F18 alpha release criterion "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should boot to a state where it is possible to log in through at least one of the default virtual consoles"
17:11:10 <kparal> ack
17:11:11 <tflink> ack/nak/patch?
17:11:16 <adamw> the fact that we can use an existing criterion to cover this issue means the criteria are doing their job: we can identify a specific expected functionality which is broken by not having access to the root account. we don't just have to declare 'not having access to the root account is bad because we say so'.
17:11:17 <Martix> ack
17:11:25 <adamw> ack
17:11:35 <tflink> #agreed 848803 - AcceptedBlocker - Violates the following F18 alpha release criterion "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should boot to a state where it is possible to log in through at least one of the default virtual consoles"
17:11:48 <tflink> #topic (848841) [TUI] anaconda crash when trying to work with empty (new) disk
17:11:51 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=848841
17:11:51 * nirik might add 'with root and user accounts' to that criteria, but I'll stop bikeshedding.
17:11:52 <bugbot_> Bug 848841: unspecified, unspecified, ---, anaconda-maint-list, POST , [TUI] anaconda crash when trying to work with empty (new) disk
17:11:53 <tflink> #info Proposed Blocker, NEW
17:12:14 <tflink> nirik: that would make it clearer, I suppose
17:12:34 <tflink> but if you don't install X, there is no firstboot and the root account is the only accont after reboot
17:12:55 <kparal> it is probable that anaconda would crash even with graphical mode
17:13:02 <kparal> but not tested
17:13:23 <tflink> but I don't think that TUI only counts as a blocker right now
17:13:48 <adamw> the bug states 'this happens only in TUI', though i can't see how petr can check that
17:13:52 <adamw> oh, using a newui image, maybe?
17:14:09 <tflink> I thought that newui was in F18 already
17:14:28 <tflink> or did you mean one of the pre-branched test images?
17:15:02 <adamw> yes.
17:15:09 <adamw> anaconda team says this is indeed TUI only, and it's a dupe.
17:15:11 <kparal> he says 'only in TUI', but I believe he means he only tested TUI
17:15:16 <kparal> alright
17:15:23 <adamw> <adamw> jlk: is https://bugzilla.redhat.com/show_bug.cgi?id=848841 really specific to TUI mode?
17:15:23 <adamw> <clumens> yes
17:15:23 <adamw> <jlk> yes, and it's a dupe
17:15:38 <kparal> do we have some TUI criteria?
17:15:39 <bugbot_> Bug 848841: unspecified, unspecified, ---, anaconda-maint-list, POST , [TUI] anaconda crash when trying to work with empty (new) disk
17:16:10 <tflink> kparal: not yet, no
17:16:43 <tflink> which is related to the discussion on whether we're even going to have a working TUI for F18
17:16:49 <kparal> https://fedoraproject.org/wiki/Fedora_Release_Criteria points to F17 criteria, hmm
17:17:05 <adamw> oh, yeah, that needs updating.
17:17:10 <kparal> anyway, I believe we discussed text mode installation should not be Alpha
17:17:13 <adamw> this is a conditional breakage anyway
17:17:18 <tflink> for now
17:17:38 <adamw> it breaks, oh, any one of a few criteria, but only in the case of a) tui and b) an uninitialized disk . so it does become a judgement call =)
17:18:01 <adamw> apparently there's a fix coming for it anyway.
17:18:14 <adamw> but i guess i'd vote -1 on the basis that we weren't requiring text mode to work at all for alpha.
17:18:38 <kparal> -1 for alpha, but propose for beta
17:18:48 <Martix> -1 alpha, +1 beta blocker
17:18:50 <tflink> it'd be nice to have the "yes it is a TUI only issue and we have a patch coming" in the bug
17:18:51 <kparal> and we can come to it later
17:19:25 <adamw> tflink: yeah, i'll put it in if they don't.
17:19:30 <adamw> kparal: sounds good to me
17:20:10 <tflink> proposed #agreed 848841 - RejectedBlocker - As there are no criterion for F18 alpha covering text mode installs and this bug is TUI specific, it is rejected as a blocker for F18 alpha and will be re-proposed as a blocker for F18 beta
17:20:24 <kparal> ack
17:20:28 <Martix> ack
17:20:30 <akshayvyas> ack
17:20:37 <tflink> #agreed 848841 - RejectedBlocker - As there are no criterion for F18 alpha covering text mode installs and this bug is TUI specific, it is rejected as a blocker for F18 alpha and will be re-proposed as a blocker for F18 beta
17:21:01 <tflink> I think that's all of the proposed blockers
17:21:16 <kparal> so fast?
17:21:39 <adamw> well, we can't find all the other blockers when the damn thing barely boots =)
17:21:40 <tflink> there were a lot of repoclosure bugs
17:22:00 <tflink> adamw: so a non-booting iso makes our metrics look better?
17:22:04 <robatino> 8 for TC1, 5 for TC2
17:22:47 <tflink> either way, on to the accepted blockers (unless there's a proposed blocker I missed)
17:23:03 <tflink> #topic (835867) systemd-journald is running as kernel_t
17:23:03 <adamw> tflink: exactly.
17:23:03 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=835867
17:23:03 <tflink> #info Accepted Blocker, MODIFIED
17:23:05 <bugbot_> Bug 835867: unspecified, unspecified, ---, systemd-maint, MODIFIED , systemd-journald is running as kernel_t
17:23:46 <adamw> i think we can probably just close this at this point. since no-one's complaining about it any more.
17:23:59 <tflink> or at least make it not a blocker
17:24:03 <adamw> we kept waiting for feedback, but it never came.
17:24:10 <tflink> it looks like there is still some discussion about how to best fix it
17:24:11 <adamw> eh, just close it. can always be re-opened if need be.
17:24:24 <adamw> nah, that's just dan giving background
17:24:56 <cpuobsessed> should i try a text install? doesn't make sense if we can't test the new ui
17:25:24 <tflink> proposed #agreed 835867 - move to CLOSED - We had been waiting for more feedback that this had inded been fixed but there has been no new confirmation. As there have been no new complaints, we assume that this has been resolved and can be closed - please re-open if the issue re-surfaces
17:26:06 <adamw> cpuobsessed: well, the text UI is new too.
17:26:09 <adamw> ack
17:26:32 <tflink> other ack/nak/patch?
17:26:42 <akshayvyas> ack
17:26:43 <Martix> ack
17:27:44 <cpuobsessed> i'm just worried that even if it installs that the new kernel and bug #845745 will still be there
17:27:46 <bugbot_> Bug https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=845745 unspecified, unspecified, ---, xgl-maint, NEW , kernel version 3.5.0-2 hangs at boot with modesetting:  "conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver"
17:28:06 <tflink> #agreed 835867 - move to CLOSED - We had been waiting for more feedback that this had inded been fixed but there has been no new confirmation. As there have been no new complaints, we assume that this has been resolved and can be closed - please re-open if the issue re-surfaces
17:28:17 <tflink> #topic (844510) FTBFS in Rawhide with gphoto 2.5.0
17:28:17 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=844510
17:28:19 <tflink> #info Accepted Blocker, ASSIGNED
17:28:21 <bugbot_> Bug 844510: urgent, unspecified, ---, mclasen, ASSIGNED , FTBFS in Rawhide with gphoto 2.5.0
17:28:44 <adamw> it seems like upstream's working on this, not sure if they'll be in time for us to get shotwell in alpha though.
17:28:59 <tflink> yep
17:29:09 <tflink> either way, not much to do from our end right now
17:30:02 <tflink> #info it seems like upstream is working on this right now but it's not clear if they'll be able to fix it in time for alpha
17:30:26 <adamw> ack
17:30:40 <tflink> #info upstream tracker: http://redmine.yorba.org/issues/5553
17:31:17 <tflink> #info there isn't anything to be done on our end at the moment, will need to make a decision on how to fix or workaround as alpha gets closer
17:31:29 <tflink> OK, I think that's it for today
17:31:35 <tflink> #topic Open Floor
17:31:45 <tflink> Anything that I missed?
17:31:58 <tflink> other than the meeting announcement for yesterday :-/
17:32:27 <tflink> the blocker tracking app is in the process of being deployed on the fedora infra
17:32:29 <adamw> can't think of anything
17:32:33 <adamw> executive summary: we're boned
17:32:41 * tflink is getting through the (hopefully) last few issues
17:32:49 <tflink> adamw: sounds like fun :)
17:32:51 <adamw> tflink: can you spin up that pre-tc3, with the new lorax?
17:32:52 <Martix> adamw: :-D
17:33:15 <tflink> adamw: yeah, I'm going to start working on getting a builder up and running right after the meeting
17:33:20 <adamw> cool.
17:33:33 <akshayvyas> tflink :)
17:33:36 <tflink> if all else fails, I still have a pre-branched rawhide VM I can use
17:34:03 <akshayvyas> well tc2 live image is 404 not found ,why ?
17:34:29 <Martix> they are doomed!
17:34:55 <tflink> Martix: wow, that's pretty broad and damning :)
17:35:27 <akshayvyas> :D
17:35:33 <tflink> anywho, if we don't have any other topics to cover ... the fuse is set for [0,5] minutes
17:36:06 <tflink> #info Next blocker review meeting will be Wednesday, 2012-08-22 @ 16:00 UTC
17:36:17 * tflink won't forget the meeting announcement this time
17:37:20 <adamw> you better not, or...you know
17:38:16 <tflink> I'll be fired again?
17:38:29 <tflink> adamw: are you planning to do the secretarialization or should I?
17:38:44 <adamw> i'll do it
17:39:26 <tflink> k, thanks
17:39:41 * tflink is hoping that a yum upgrade will work well enough to build a test iso
17:39:46 <akshayvyas> have fun with this wine https://plus.google.com/113311940092135970473/posts/jWKpuXyvWLe :P
17:40:01 <tflink> anyhow, fuse -> out -> EXPLOSION!!!!!111!!
17:40:07 <tflink> thanks for coming, everyone
17:40:15 * tflink will send out minutes shortly
17:40:17 <tflink> #endmeeting