fedora-board
LOGS
18:16:34 <ctyler> #startmeeting Fedora Board Meeting
18:16:34 <zodbot> Meeting started Mon Oct 18 18:16:34 2010 UTC.  The chair is ctyler. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:16:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:17:21 <smooge> #name fedora-board
18:17:34 <ctyler> #info This is an impromptu meeting held because of problems with a planned phone meeting
18:17:54 <ctyler> #chairs smooge jds2001 mdomsch mizmo rdieter spot
18:18:02 <ctyler> #chair smooge jds2001 mdomsch mizmo rdieter spot
18:18:02 <zodbot> Current chairs: ctyler jds2001 mdomsch mizmo rdieter smooge spot
18:18:08 <rdieter> #chair caillon
18:18:08 <zodbot> Current chairs: caillon ctyler jds2001 mdomsch mizmo rdieter smooge spot
18:18:52 <smooge> #meetingname fedora-board
18:18:52 <zodbot> The meeting name has been set to 'fedora-board'
18:18:59 <jds2001> anyhow, there's a blocker list. https://bugzilla.redhat.com/showdependencytree.cgi?id=538277&hide_resolved=1
18:19:08 <jds2001> looks pretty good as of now :)
18:19:15 <ctyler> #topic Blocker review
18:19:39 * mdomsch notes that #fedora-bugzappers has been reviewing the list for a few hours how
18:19:41 <mdomsch> now
18:20:03 <ctyler> Right. Apart from encouraging people to help clear the list, is there any action we should take here?
18:20:11 <ctyler> Seems to be an information item.
18:20:13 <rdieter> ctyler: not really
18:20:15 <rdieter> yeah
18:20:15 <mizmo> the final change deadline is today!
18:20:16 <mizmo> take note!
18:20:22 <ctyler> make it happen!
18:20:26 <mdomsch> mizmo: only if we don't want to slip :-)
18:20:30 <rdieter> make it so
18:20:38 * mizmo blows barrel of finger gun and holsters it
18:20:43 <jds2001> slipping would be bad, mmmkkay?
18:20:44 <jds2001> :)
18:20:51 <ctyler> ok, next...
18:21:11 <ctyler> Open Tickets (#82 - Community Working Group charter)
18:21:16 <ctyler> #topic Open Tickets (#82 - Community Working Group charter)
18:21:22 <ctyler> rdieter?
18:21:31 <mdomsch> #info the board commends everyone who has been fixing bugs, especially in the run-up to release candidate
18:21:53 <rdieter> oh goodie, here's the draft so far, http://fedoraproject.org/wiki/User:Rdieter/Draft_Fedora_Community_Working_Group
18:22:22 <rdieter> was a bit of feedback on fab list, wondering of the scope of this group a bit.
18:22:25 <jds2001> so as for composition, i really dont think that anyone from the board should be *on* the CWG
18:22:54 <jds2001> the scope is conflict resolution, and empowered to take whatever action may be deemed required.
18:23:25 <mizmo> would being on both groups  be a problem?
18:23:28 <rdieter> jds2001: agreed
18:23:37 <jds2001> mizmo: i think so.
18:23:45 <rdieter> or perhaps limit it to just at most 1
18:23:45 <mizmo> why?
18:24:16 <jds2001> the CWG should *report* to the Board, not *be* the Board
18:24:24 <ctyler> jds2001: "whatever action may be deemed required" is pretty sweeping mandate
18:24:27 <mdomsch> can we start at the top?
18:24:30 <rdieter> in practical terms, I think we'll be able to find enough good candidates outside the board, that it's a moot point
18:24:38 <ctyler> mdomsch: +1
18:24:45 <mizmo> but i still dont get the rationale jds2001
18:24:53 <jds2001> ctyler: it is, but i also don't want to limit them.
18:25:02 <mdomsch> rdieter, first, thanks for drafting and posting this, and responding to the feedback so far.
18:25:23 <mdomsch> mizmo: +1
18:25:25 <mdomsch> so, lets start there
18:26:10 <mdomsch> rdieter, the problem you are trying to solve is (and pardon my rewriting): our diverse community sometimes has difficulty communicating effectively
18:26:13 <mdomsch> inside itself
18:26:24 <smooge> that is my reading of it
18:26:25 <rdieter> <nod>
18:26:38 <mdomsch> sometimes discussinos become heated and non-productive, and occasionally even worse
18:27:21 <mizmo> i would think having someone on both the board and the cwg would help facilitate discussion so i dont understand blocking that as an option
18:27:23 <mdomsch> while we've had the Hall Monitors for a while to deal with the far end of the spectrum, you see a need that could be filled, before it gets to HM status
18:27:29 <walters> most of this draft is very meta
18:27:46 <walters> i'm more interested in the practical aspects of how a CWG would handle a sample problem
18:27:58 <mizmo> walters +1
18:27:58 <rdieter> mdomsch: yeah, a large proactive role is involved as well
18:28:35 <mdomsch> as well, or that _is_ the role?  Does HM become a part of CWS?
18:28:37 <rdieter> walters: that's largely part of the cwg initial task, is to come up with their own ideas of how to best deal with issues
18:28:57 <walters> rdieter: ah, okay
18:29:35 <rdieter> perhaps that can and should be made more clear in "Tasks for the Working Group" section
18:29:51 <smooge> it seems to work better when doing it that way as the people on the CWG and hopefully the community feel more buy-in
18:30:28 <mizmo> if they understand clearly that it's their task to do
18:30:32 <mizmo> rather than leaving it nebulous
18:30:52 <rdieter> mizmo: point taken, I'll add some verbiage to that section to make that clearer
18:31:01 <mdomsch> rdieter, and does the IRC monitors fall under this too?
18:31:11 <walters> rdieter: what it seems like we need to decide is the scope of the CWG's power
18:31:31 <walters> can people be removed for repeatedly violating a CoC?
18:31:39 <jds2001> well, the KDE CWG has the autohirty to remove people
18:31:39 <walters> etc
18:31:43 * mdomsch is still trying to define the problem space...
18:31:45 <rdieter> good question.  is there any similar documents about what hall monitors are and what they do, so I can compare?
18:31:52 <jds2001> that is a very important power IMO.
18:32:10 <jds2001> the CWG *must* have teeth, or it's doomed to failure.
18:32:17 <ctyler> So there's some basic questions about any new group: composition and selection mechanism; reporting; authority; scope. I don't see the answers to those basics here yet.
18:32:33 <mdomsch> http://fedoraproject.org/wiki/Hall_Monitor_Policy
18:32:36 <mdomsch> #link http://fedoraproject.org/wiki/Hall_Monitor_Policy
18:32:37 <rdieter> walters: I'd envision that they can propose a death penalty of sorts, yes.
18:33:28 <jds2001> sometimes the action could be to revoke commit for a period of time, turn off mailing list memebership for awhile, etc
18:33:49 <jds2001> the death penalty is truly the last resort (and normally means that you havent tried hard enough)
18:33:59 <walters> hm, i don't like calling it death penalth
18:34:15 <mdomsch> walters: agreed
18:34:22 <jds2001> me either, rdieter started it :)
18:34:28 <rdieter> ok, indeed there is some overlap with Hall monitors.  I'd propose this would include that and more (and hall monitors go away)
18:34:49 <mdomsch> and the IRC helper folks (nirik leads?)
18:34:56 * mdomsch looks for the name of that group
18:34:58 <smooge> nearly permanent exile
18:35:12 <jds2001> they are welcomed to become part of the CWG.
18:35:23 <jds2001> in fact, we should actively recruit some.
18:35:30 <rdieter> fwiw, I already asked nirik if he'd be tentatively interested in participating in this group
18:35:32 <mdomsch> #link http://fedoraproject.org/wiki/IRC_helpers_code_of_conduct
18:35:50 <smooge> I believe at this point the only mailing list hall-monitor is Spot.
18:35:59 <mizmo> who is on the board...
18:36:07 <walters> hm, in that case it's unfortunate to discuss this without him
18:36:19 <mdomsch> IRC Support Channel
18:36:26 <mdomsch> #link http://fedoraproject.org/wiki/Communicate/IRC/Support_Channel_Meeting
18:37:19 <walters> so i guess one thing that would help me is an example case that's motivating this
18:37:43 <jds2001> can we get anywhere on this without spot
18:37:45 <jds2001> ?
18:37:55 <jds2001> i really think he needs to be around.....
18:38:00 <rdieter> the kde cwg folks recommended the group be relatively small, 4-6 people at most
18:38:14 <ctyler> I think this document, if it's to be a charter, should start with the scope/goal, and focus less (or not at all) on strategy and tasks.
18:38:15 <jds2001> and an odd number is important
18:38:33 * nirik looks up
18:38:39 <rdieter> seriously, I think we're making this much harder than it has to be.
18:39:01 <nirik> I haven't had a chance to look at the proposal/page...
18:39:58 <rdieter> at every stage leading up to the last board election, one of the major topics and issues was 'community health'  yada yada, but I'm getting the impression from some they don't see a problem worth solving here. ?
18:40:15 <rdieter> frankly, I thought that was just a given at this point
18:40:24 <smooge> rdieter, I agree.
18:40:42 <rdieter> if we can't agree on that, we're not going to get very far
18:41:09 <nirik> FWIW, the irc folks wouldn't want/like a 'community council' thats not involved in irc telling them what to do... ;) That said, I think if we get buyin and have people who are in each of the communities it might be ok... I can ask at our next meeting.
18:41:49 <jds2001> nirik: folks that are involved in every medium needs to be represented.
18:41:51 <smooge> Community health seems to come up every release cycle and then forgotten until the flame wars come up again .. right around elections and release cycles
18:41:55 <jds2001> if not, it's fail.
18:42:05 <mdomsch> I haven't seen a lot of flame wars lately, or even threads of doom
18:42:08 <rdieter> now, so far, I definitely do agree some wordsmithing is in order, to improve the scope of the proposal, and making the initial tasks clearer.
18:42:35 <mdomsch> but then again, I tend to batch-read the lists, so they don't flood my phone every few minutes
18:42:36 <rdieter> are there other concrete complaints or suggestions?
18:43:32 <rdieter> comments, hints, allusions ?
18:43:54 * nirik is busy at $dayjob and hasn't read the proposal. Can provide feedback when I get to.
18:43:57 <jds2001> dont ru n across the street in traffic. :)
18:44:34 <rdieter> ok, how about we wait another week for comment on list, and for jsmith and spot to get back.
18:44:47 <rdieter> and I'll revise the proposal asap with suggestions so far.
18:44:56 <mdomsch> rdieter, I agree having folks like the IRC helpers are valuable.  I wish we didn't need the Hall Monitors, but we have needed them somewhat.
18:44:56 <walters> that sounds good to me!
18:44:59 <jds2001> WORKSFORME
18:45:06 <ctyler> +1
18:45:08 <smooge> ugh ok.
18:45:42 <mdomsch> and I really like the approach of IRC helpers.  Maybe we simply need the same extended to the users@ list?
18:46:13 <jds2001> well, this isnt entirely about the user community only.
18:46:15 <mdomsch> but I'm not sure I see a need for a group of enforcers before the Hall Monitors stage
18:46:26 * nirik notes the irc-support-sig has their own mailing list.
18:46:57 <jds2001> this shouldnt e thought of as "enforcers". but rather "enablers" imho.
18:47:12 * jds2001 hopes that this group can reduce the amou nt of "enforcement" required.
18:47:25 <smooge> I don't think the CWG is meant to be enforcers as much as working on what makes things better
18:48:51 <jds2001> anyhow
18:49:09 <jds2001> for the name thinf, i think that a quick meeting on Thursday is the right thing.
18:49:21 <ctyler> #topic F15 Naming
18:50:11 <mdomsch> jds2001: in the past we've put all the names into the election tool, and each board member voted, and the top X were then reviewed in a meeting and sent to Legal
18:50:29 <jds2001> WORKSFORME
18:50:49 <mdomsch> gotta love a range vote of 0-300
18:50:52 <walters> no objections to that
18:50:55 <rdieter> do eet.
18:51:06 <ctyler> mdomsch: but that was after some basic pruning, iirc
18:51:07 <jds2001> do we ave someone with the wherewithal to run the election tool?
18:51:25 <mdomsch> ctyler: ah that could be; I never did that part myself
18:51:39 <smooge> I would love to have something other than range voting
18:51:43 <mdomsch> but I think you're right that Paul would do a basic sanity check
18:52:14 <mdomsch> if the search "Name AND software" turned up anything relevant, it got pitched out
18:52:55 <ctyler> trying to remember if we gave a shortlist to legal then voted on what came back, or the other way around
18:53:04 <mdomsch> both
18:53:16 <mdomsch> we vote to get to a short list to hand to legal
18:53:21 <ctyler> "highly recursive algorithm"
18:53:24 <mdomsch> so we don't overload them
18:53:24 <jds2001> giving a shortlist to legal lessens the burden on them, which is good.
18:53:48 <ctyler> istr some lists came back entirely vetoed by legal
18:54:14 <mdomsch> yeah....
18:54:25 <mdomsch> Spot's still not sure how Zod made it through
18:54:38 <mdomsch> but there seem to be no negative repurcussions
18:54:41 <ctyler> so what's our direction forward here? review via the web page, and discuss during office hours on Friday?
18:54:46 <smooge> an anonymous pack of Franklins
18:54:51 <ctyler> or set a mtg on Thu?
18:55:24 <mdomsch> I can meet thurs
18:55:29 <mdomsch> I'm on a plane all day Friday
18:56:05 <ctyler> Thurs work for the rest of us?
18:56:13 * ctyler is available >10 am EDT
18:56:19 <mdomsch> 2pm EDT Thurs ?
18:56:32 <ctyler> wfm
18:56:45 <rdieter> ok
18:56:53 <smooge> ok
18:57:05 <mizmo> does someone own the basic pruning?
18:57:14 <ctyler> usually fpl
18:57:32 <mdomsch> I suppose he could delegate, or we could split it up here
18:57:55 <mdomsch> mizmo: you get a-e; ctyler f-j, ...
18:58:10 * mdomsch claims q & z
18:58:18 <smooge> goes to fill that up
18:58:33 <mizmo> are you being serious?
18:58:42 * mizmo honest question
18:58:57 <mdomsch> the q&z part, no.  The rest; I don't care.  If jsmith wants to do it, I'd let him.
18:59:11 <mdomsch> it's just a suggestion
18:59:20 <ctyler> mizmo: Sanity check ("Initial Approval") is pretty straightforward
18:59:38 <mizmo> okay so should i go ahead and do that for a-e?
19:00:00 <ctyler> Sure. mdomsch, can you mail out a divvy-up list via fab?
19:00:06 <mdomsch> sure
19:00:21 <ctyler> sold!
19:00:23 <mdomsch> there's 10 of us on the board, so that's 2-3 letters apiece
19:01:04 <mdomsch> #action mdomsch to send list of names to vette per board member for initial approval
19:01:09 <ctyler> Ok. We're at 3:00, can we squeeze in this EMEA media thing?
19:01:18 <mdomsch> +1 from me
19:01:29 <ctyler> #topic EMEA Media question
19:01:34 <mdomsch> I think it's clever, and if they've got the finance worked out, great.
19:01:46 <ctyler> So I think the question here is whether a disc full of spins can be called Fedora
19:02:00 <ctyler> I think that as long as all of the contents are spins (not remixes), we should say "Yes"
19:02:41 <ctyler> And that should be a standing "Yes" for any disc containing multiple spins, as long as the software used to select the spin is Fedora-acceptable and packaged for Fedora as well
19:02:59 <ctyler> What say ye?
19:03:19 <smooge> If all the Spins were Fedora already.. then I would believe a Spin of Spins would also constitute Fedora as long as the code to run/select spins met standards
19:03:58 <smooge> which is what you just said
19:04:19 <mizmo> +1
19:04:20 <mdomsch> yep
19:04:31 <ctyler> rdieter? jds2001?
19:04:47 <walters> hm, the branding seems to be different if they're calling the desktop one "Gnome"
19:04:49 <rdieter> I think I'd prefer to see it in action first though.
19:05:11 <rdieter> or do we already have assurances that it works well?
19:05:33 <mizmo> the desktop spin shouldn't be called gnome
19:05:34 <walters> conceptually this seems like it's encoding get-fedora-options#desktops in the boot menu?
19:05:47 <ctyler> Ok, we're open to approving this, but would like to see the product first?
19:06:03 <jds2001> +1, also think the desktop spin should not be called gnome
19:06:09 <rdieter> ctyler: for me at least, unless we can see or hear some testamonials
19:06:12 <jds2001> ctyler: yep
19:06:17 <ctyler> ok, sounds good
19:06:22 <ctyler> I'll write 'em back?
19:06:26 <mizmo> we should tell them, don't call it gnome, call it desktop, and we can give approval after there's something to look at?
19:07:55 <ctyler> ok,  the board is open to having a disc-of-spins use the Fedora name as long as the spin-selection software is Fedora-acceptable and packaged for Fedora, the spins use the same name as on the spins page, and we see a prototype for approval?
19:07:58 <mdomsch> the "look at" part is simply a syslinux boot screen with multiple options, AFAICT
19:08:02 <walters> well, in general to sync with the web design
19:08:51 <mizmo> ctyler, the desktop spin isn't on the spins page
19:08:53 <walters> (to be clear, my comments here are "please" not "must")
19:09:25 <ctyler> ok, draft 2: the board is open to having a disc-of-spins use the Fedora name as long as the spin-selection software is Fedora-acceptable and packaged for Fedora, the spin naming is consistent with the Fedora web site, and we see a prototype for approval?
19:09:41 <mizmo> the fedora website is changing
19:09:45 <mizmo> so that is probably a bad point of reference
19:09:49 <mizmo> i would say...
19:10:03 <ctyler> better point of reference?
19:10:04 <mizmo> "the spins should use the same name as on the spins website, with the exception of the desktop spin which should be called the desktop spin"
19:10:32 <ctyler> sold!
19:10:35 <mizmo> :)
19:11:54 <ctyler> #action ctyler to communicate to EMEA that the board is open to having a disc-of-spins use the Fedora name as long as the spin-selection software is packaged for Fedora, the spins use the same name as on the spins website, with the exception of the desktop spin which should be called the "desktop spin", and we see a prototype for approval
19:11:59 <ctyler> anything else?
19:12:10 <mizmo> looks good
19:12:12 <smooge> open floor or other tickets
19:12:13 <ctyler> I think that's a wrap for today...
19:12:15 <smooge> wait
19:12:44 <smooge> I hate to bring this up but Robyn's email to the board about the Vision Statement is outstanding
19:13:17 <smooge> There has not been an announced one, and no description of the vote. [I wasn't available for that meeting either.]
19:13:25 <ctyler> We really should get everyone in the same room to +1.
19:13:39 <mizmo> our meeting minutes aren't being updated on that wiki
19:13:40 <mizmo> that is bad
19:13:45 <walters> yes - we have a wiki page but it hasn't been publicised
19:14:07 <mizmo> walters, do you have the url
19:14:15 <mizmo> ill add the category to it
19:14:45 <walters> mizmo: http://fedoraproject.org/wiki/Vision_Statement  but i think it still needs work
19:14:54 <mdomsch> I think ctyler is right - we held off on a formal vote till we could get everyone in one place at one time
19:14:57 <mizmo> oh i mean the meeting minutes
19:15:01 <mdomsch> but have failed to do so
19:15:03 <mizmo> the meeting minutes are not on the wiki
19:15:09 <ctyler> mizmo: from when?
19:15:11 <mizmo> we agreed on the vision statement two meeitngs after the sept 27th one
19:15:16 <mizmo> ctyler, no october meeting minutes are in the wiki
19:15:22 <mizmo> the last set of meeting minutes are from 9-27
19:15:31 <mizmo> as listed here http://fedoraproject.org/wiki/Category:Board_meetings
19:16:11 * rdieter sees some wet noodle lashings for meeting secretaries not getting the job done
19:16:29 <mizmo> we did vote and agree on the vision statement, i know we did
19:16:40 <ctyler> I missed the meeting on the 4th due to a family situation, and didn't see minutes float by that I can recall.
19:16:58 <rdieter> mizmo: <nod>
19:17:02 <ctyler> I just assumed that I'd missed them somehow...
19:17:06 <mizmo> http://mairin.wordpress.com/2010/10/01/fedora-board-meetings-27-sept-2010-1-oct-2010/
19:17:12 <mizmo> we finalized the vision the  meeting after oct 1
19:17:17 <mizmo> which is the one we are missing the minutes for
19:17:20 <mizmo> should be oct 4
19:17:31 <mizmo> we didn't have a meeting last week because of the same problem we had this week, no phone code
19:17:38 <mizmo> this is a big problem
19:18:05 <ctyler> So we're missing 1 meeting's notes. Might they be on Jared's box, the one that runs gobby?
19:18:16 * mizmo isnt sure
19:18:29 <ctyler> We'd have to ask him, they're not in the gobby doc list
19:19:13 <ctyler> Shall we take this to advisory-board and wrap this meeting?
19:19:54 <rdieter> think so
19:20:05 <smooge> gobby deletes notes once everyone leaves a meeting
19:20:18 <ctyler> smooge: depends on the options the server was started with
19:20:38 <smooge> ah ok. everyone I have dealt with does it so I thought it was routine
19:21:01 <ctyler> annnnd... that's a wrap in 5
19:21:06 <ctyler> 4
19:21:07 <smooge> ok move to close in 4
19:21:19 <ctyler> seconded
19:21:20 <ctyler> 3
19:21:23 <mizmo> +1
19:21:34 <ctyler> 2
19:21:39 <ctyler> 1
19:21:44 <ctyler> #endmeeting