f38-blocker-review
MINUTES

#fedora-blocker-review: F38-blocker-review

Meeting started by bcotton at 16:00:59 UTC (full logs).

Meeting summary

  1. Roll Call (bcotton, 16:01:21)
  2. Roll Call (adamw, 16:06:02)
  3. Introduction (adamw, 16:07:05)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:23)
    2. We'll be following the process outlined at: (adamw, 16:07:28)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:07:32)
    4. The bugs up for review today are available at: (adamw, 16:07:36)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:07:40)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:07:43)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:07:46)
    8. https://fedoraproject.org/wiki/Fedora_38_Beta_Release_Criteria (adamw, 16:07:51)
    9. https://fedoraproject.org/wiki/Fedora_38_Final_Release_Criteria (adamw, 16:07:53)
    10. for Final, we have: (adamw, 16:08:00)
    11. 5 Proposed Blockers (adamw, 16:08:33)
    12. 5 Accepted Blockers (adamw, 16:08:35)
    13. 2 Proposed Freeze Exceptions (adamw, 16:08:36)
    14. 4 Accepted Freeze Exceptions (adamw, 16:08:46)
    15. coremodule will secretarialize (adamw, 16:08:57)

  4. Proposed Final blockers (adamw, 16:09:05)
  5. (2177725) Combo boxes in GTK4 can't be opened (adamw, 16:09:58)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2177725 (adamw, 16:09:59)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1091 (adamw, 16:09:59)
    3. Proposed Blocker, gtk4, VERIFIED (adamw, 16:09:59)
    4. Ticket vote: FinalBlocker (+2,0,-0) (+bcotton, +geraldosimiao) (adamw, 16:10:01)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=2177725 (frantisekz, 16:12:25)
    6. AGREED: 2177725 - AcceptedBlocker (Final) - this would affect basic functionality of many GTK4 apps, combo boxes are a standard UI element (adamw, 16:16:53)

  6. (2176766) Dragging files is Nautilus doesn't work as expected, quick movements result in a selection box instead (adamw, 16:17:13)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2176766 (adamw, 16:17:16)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1085 (adamw, 16:17:23)
    3. Proposed Blocker, nautilus, NEW (adamw, 16:17:24)
    4. Ticket vote: FinalBlocker (+4,2,-2) (+catanzaro, +nielsenb, +geraldosimiao, +bcotton, kparal, sgallagh, -frantisekz, -lruzicka) (adamw, 16:17:26)
    5. Ticket vote: FinalFreezeException (+2,0,-0) (+frantisekz, +sgallagh) (adamw, 16:17:28)
    6. AGREED: 2176766 - AcceptedBlocker (Final) - this is accepted as a violation of the "basic functionality" criterion for nautilus, in the case of impatient people who like to move the mouse real fast (adamw, 16:35:43)

  7. (2113005) Live image made with BOOTX64.EFI from latest shim-x64-15.6-2 fails to boot on some boards (adamw, 16:35:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2113005 (adamw, 16:36:00)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1087 (adamw, 16:36:03)
    3. Proposed Blocker, shim, POST (adamw, 16:36:07)
    4. Ticket vote: FinalBlocker (+3,0,-3) (+geraldosimiao, +kparal, +bcotton, -frantisekz, -nielsenb, -sgallagh) (adamw, 16:36:09)
    5. Ticket vote: FinalFreezeException (+4,0,-0) (+frantisekz, +nielsenb, +lruzicka, +sgallagh) (adamw, 16:36:13)
    6. AGREED: 2113005 - AcceptedBlocker (Final) - this is accepted as a conditional violation of "All release-blocking images must boot in their supported configurations" when booting in native UEFI mode on affected hardware. (adamw, 17:02:23)

  8. (2177784) Sound volume is sometimes 0% after login (a race condition) (adamw, 17:02:39)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2177784 (adamw, 17:02:42)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1092 (adamw, 17:02:44)
    3. Proposed Blocker, wireplumber, NEW (adamw, 17:02:47)
    4. AGREED: 2177784 - RejectedBlocker (Final) AcceptedFreezeException (Final) - this isn't serious enough to be considered a criteria violation. The criterion says "The installed system must be able to play back sound with gstreamer-based applications"; if affected by this bug you can play sound, you just have to turn the volume up first. It is bad polish, though, so we grant an FE (adamw, 17:12:19)

  9. (2177853) Logout/reboot/poweroff timeout leaves the session in a broken state, doesn't perform the action (adamw, 17:14:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2177853 (adamw, 17:14:27)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 17:14:50)
    3. https://fedoraproject.org/wiki/Fedora_38_Beta_Release_Criteria#Shutdown,_reboot,_login,_logout (kparal, 17:16:40)
    4. AGREED: 2177853 - AcceptedBlocker (Final) - this is accepted as a conditional violation of "Shutting down [etc]...must work using...the mechanisms offered (if any) by all release-blocking desktops" in the case where you wait for the automatic action to happen after the timeout (adamw, 17:22:33)

  10. Proposed Final freeze exception issues (adamw, 17:22:47)
  11. (2176732) delete an album and undo the delete operation makes the album is not shown in the "Add to album" list (adamw, 17:23:02)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2176732 (adamw, 17:23:02)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1083 (adamw, 17:23:03)
    3. Proposed Freeze Exceptions, gnome-photos, NEW (adamw, 17:23:06)
    4. Ticket vote: FinalBlocker (+0,0,-5) (-frantisekz, -catanzaro, -nielsenb, -geraldosimiao, -lruzicka) (adamw, 17:23:08)
    5. Ticket vote: FinalFreezeException (+1,0,-0) (+lruzicka) (adamw, 17:23:11)
    6. AGREED: 2176732 - AcceptedFreezeException (Final) - this is accepted to improve final release polish, so long as the proposed fix does not present any risk to anything more important (adamw, 17:29:09)

  12. (2177722) systemd-oomd extremely aggressive in killing non-DE logins (sshd or console) and any commands running in them (adamw, 17:29:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2177722 (adamw, 17:29:27)
    2. https://pagure.io/fedora-qa/blocker-review/issue/1090 (adamw, 17:29:30)
    3. Proposed Freeze Exceptions, systemd, NEW (adamw, 17:29:35)
    4. AGREED: 2177722 - punt (delay decision) - it's hard to make any decision here without some details of any proposed fix. we will leave this until there's actually a necessary decision to make (i.e. a proposed fix during the freeze period) (adamw, 17:40:30)

  13. Open floor (adamw, 17:40:51)


Meeting ended at 17:42:26 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (170)
  2. kparal (54)
  3. lruzicka (50)
  4. geraldosimiao (36)
  5. bcotton (29)
  6. frantisekz (21)
  7. zodbot (17)
  8. marcdeop[m] (14)
  9. Eighth_Doctor (13)
  10. andi89gi (9)
  11. robatino (5)
  12. aleasto (4)
  13. marcdeop (2)
  14. coremodule (2)


Generated by MeetBot 0.4.