f37-blocker-review
LOGS
16:01:20 <adamw_> #startmeeting F37-blocker-review
16:01:20 <zodbot> Meeting started Mon Oct 24 16:01:20 2022 UTC.
16:01:20 <zodbot> This meeting is logged and archived in a public location.
16:01:20 <zodbot> The chair is adamw_. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:01:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:20 <zodbot> The meeting name has been set to 'f37-blocker-review'
16:01:24 <adamw_> #meetingname F37-blocker-review
16:01:24 <zodbot> The meeting name has been set to 'f37-blocker-review'
16:01:24 <bcotton_> .hello bcotton
16:01:24 <lruzicka> hoyathere
16:01:26 <zodbot> bcotton_: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:01:27 <adamw_> #topic Roll Call
16:01:29 <lruzicka> .hello lruzicka
16:01:30 <bcotton_> ah, too quick!
16:01:30 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
16:02:03 <adamw_> for anyone over on chat.fedoraproject.org side, when you see this in two minutes - we are running the meeting on IRC side as the bridge is not working properly, please join libera.chat IRC directly and join #fedora-blocker-review to participate in the meeting
16:02:08 <geraldo-simiao> .hello geraldosimiao
16:02:09 <zodbot> geraldo-simiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
16:02:14 * coremodule is here, willing to act as secretary.
16:07:54 <adamw_> thanks coremodule
16:07:58 <adamw_> #chair bcotton lruzicka
16:07:58 <zodbot> Current chairs: adamw_ bcotton lruzicka
16:08:06 <adamw_> boilerplate alert!
16:08:11 <adamw_> #topic Introduction
16:08:11 <adamw_> Why are we here?
16:08:11 <adamw_> #info Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs.
16:08:11 <adamw_> #info We'll be following the process outlined at:
16:08:12 <adamw_> #link https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting
16:08:14 <adamw_> #info The bugs up for review today are available at:
16:08:16 <adamw_> #link http://qa.fedoraproject.org/blockerbugs/current
16:08:18 <adamw_> #info The criteria for release blocking bugs can be found at:
16:08:20 <adamw_> #link https://fedoraproject.org/wiki/Basic_Release_Criteria
16:08:22 <adamw_> #link https://fedoraproject.org/wiki/Fedora_37_Beta_Release_Criteria
16:08:24 <adamw_> #link https://fedoraproject.org/wiki/Fedora_37_Final_Release_Criteria
16:08:28 <adamw_> #info for Final, we have:
16:08:29 <adamw_> #info 2 Proposed Blockers
16:08:30 <adamw_> #info 2 Accepted Blockers
16:08:33 <adamw_> #info 17 Accepted Freeze Exceptions
16:10:21 <adamw_> #info coremodule will secretarialize
16:10:30 <adamw_> let's start with:
16:10:35 <adamw_> #topic Proposed Final blockers
16:10:48 <adamw_> #topic (2136471) Settings crashes when trying to edit WPA2 Enterprise wifi without a stored password
16:10:51 <adamw_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2136471
16:10:55 <adamw_> #link https://pagure.io/fedora-qa/blocker-review/issue/981
16:10:58 <adamw_> #info Proposed Blocker, gnome-control-center, VERIFIED
16:11:00 <adamw_> #info Ticket vote: FinalBlocker (+6,0,-3) (+catanzaro, +lruzicka, +nb, +imsedgar, +ahmedalmeleh, +nielsenb, -bcotton, -geraldosimiao, -kparal)
16:11:16 <adamw_> so this one is already taken as an FE (I read blocker +1 as implicit FE +1 for that purpose), included in RC3, and verified fixed
16:11:18 <adamw_> so it's a bit academic
16:11:21 <adamw_> but we can make a call if we like...
16:12:01 <bcotton_> i maintain my -1. editing such a connection is not a common action as evidenced by the fact this has existed for a while. but i'm happy to give a retroactive +1 FE
16:12:34 <geraldo-simiao94> I'll keep my FE+1
16:12:39 * adamw_ brb
16:13:32 <lruzicka> +1 fe
16:18:33 * Penguinpee sneaks in
16:18:35 <adamw_> as things stand, i guess we'd accept this on a bare +3 split
16:18:49 <Penguinpee> .hello gui1ty
16:18:50 <zodbot> Penguinpee: gui1ty 'Sandro .' <gui1ty@penguinpee.nl>
16:19:57 <adamw_> proposed #agreed 2136471 - AcceptedBlocker (Final) - while there's some disagreement, there's a majority of 3 for accepting this as a violation of the "basic functionality" requirement for the control center
16:20:11 <bcotton_> ack
16:20:39 <Penguinpee> ack
16:20:57 <lruzicka> ack
16:21:08 <geraldo-simiao94> ack
16:21:51 <adamw_> #agreed 2136471 - AcceptedBlocker (Final) - while there's some disagreement, there's a majority of 3 for accepting this as a violation of the "basic functionality" requirement for the control center
16:22:28 <adamw_> #topic (2137322) After disabling Fedora Flatpaks repo, a confusing "Enable third-party repo?" dialog is shown even when installing a Fedora RPM
16:22:28 <adamw_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2137322
16:22:28 <adamw_> #link https://pagure.io/fedora-qa/blocker-review/issue/985
16:22:28 <adamw_> #info Proposed Blocker, gnome-software, NEW
16:22:28 <adamw_> #info Ticket vote: FinalBlocker (+0,0,-4) (-adamwill, -lruzicka, -catanzaro, -kparal)
16:22:38 <adamw_> so, we have -4 for this this morning...anyone want to vote the other way?
16:22:51 <geraldo-simiao94> -1 too
16:22:54 <bcotton_> no, but i'll add my -1
16:23:07 <lruzicka> no, -1
16:23:46 <Penguinpee> I'd add an additional FinalBlocker -1
16:25:02 <adamw_> alrighty, that seems definitive
16:25:34 <adamw_> proposed #agreed 2137322 - RejectedBlocker (Final) - there is strong agreement that this does not constitute a violation of the criteria
16:25:39 <bcotton_> ack
16:25:55 <Penguinpee> ack
16:26:01 <lruzicka> ack
16:26:06 <geraldo-simiao94> ack
16:26:28 <adamw_> #agreed 2137322 - RejectedBlocker (Final) - there is strong agreement that this does not constitute a violation of the criteria
16:26:48 <adamw_> #info there are no proposed FEs
16:26:56 <adamw_> #topic Accepted Final Blocker review
16:27:08 <adamw_> as always, we're checking in here, not re-voting, unless otherwise decided
16:27:15 <adamw_> #topic (2135772) Editing the recurring event freezes Calendar.
16:27:15 <adamw_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2135772
16:27:15 <adamw_> #link https://pagure.io/fedora-qa/blocker-review/issue/977
16:27:15 <adamw_> #info Accepted Blocker, gnome-calendar, NEW
16:27:28 <adamw_> so, this one is a bit hopeless. i'm expecting we'll waive it at go/no-go
16:27:32 <adamw_> this is upstream's take on it:
16:27:59 <adamw_> "After !266 (merged) I'm pretty positive nothing about recurrent events has ever worked properly. There's a lot more that needs to be done to make it work reliably, and I'm considering how to do that, but yeah, it's just stupidly broken."
16:28:27 <adamw_> so, i'm expecting we're not going to magically get a fix for everything about recurring events by tomorrow, so we'll just have to conclude it's not reasonably fixable in the timeframe
16:29:05 <bcotton_> agreed. and i don't think this is enough to warrant removing Calendar from the image if WS wants to keep it
16:29:11 <lruzicka> adamw_, Yeah. I agree. We should make sure some gets fixed as updates and f38
16:29:48 <adamw_> #info we are not hopeful of getting a fix for this in reasonable timeframe so we are expecting to propose waiving it for release
16:30:19 <geraldo-simiao94> Ack
16:30:31 <lruzicka> ack
16:30:37 <Southern_Gentlem> ack
16:30:57 <King_InuYasha> ack
16:31:02 <King_InuYasha> also hi
16:31:05 <Penguinpee> ack
16:31:06 <King_InuYasha> .hello ngompa
16:31:07 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:32:31 <adamw_> that's an info, it didn't need acking. :P
16:32:40 <adamw_> #topic (2136234) No video on Raspberry Pi 4 with kernel 5.19.15 and 5.19.16 (testing)
16:32:40 <adamw_> #link https://bugzilla.redhat.com/show_bug.cgi?id=2136234
16:32:40 <adamw_> #link https://pagure.io/fedora-qa/blocker-review/issue/982
16:32:41 <adamw_> #info Accepted Blocker, kernel, ON_QA
16:32:51 <adamw_> fix for this is in RC1.3 and looks to be confirmed from comments on the bug report
16:32:56 <adamw_> we could probably kick this to VERIFIED
16:33:21 <King_InuYasha> yeah
16:33:36 <King_InuYasha> looks like folks indicated the new kernel fixes the issue
16:33:40 <Penguinpee> monkey see, monkey do... ;)
16:33:51 <adamw_> #info fix for this is in RC 1.3 and looks to be verified, no further work should be needed
16:33:59 <adamw_> #topic Open floor
16:34:23 <adamw_> it has been pointed out that an old uboot-tools is in RC 1.3, this is yet another snafu thanks to the override mechanism
16:34:34 <adamw_> i'm trying to find out from pbrobinson how big of a problem this is
16:34:47 <King_InuYasha> how old?
16:35:28 <bcotton_> fwiw, peter is on vacation and I have threatened him with Severe Trouble™ if I see him on IRC :-)
16:35:49 <King_InuYasha> also, recomposing with _just_ that component shouldn't be a big deal
16:35:56 <King_InuYasha> all the rest of the stuff would remain unchanged, no?
16:36:09 <adamw_> yes, but we would still need to do all the smoke tests again.
16:36:25 <adamw_> and technically we're not supposed to compose only for FEs. composing for an FE that got left out is...an unconsidered scenario.
16:36:47 <adamw_> the one that's in there is uboot-tools-2022.10-0.5.rc4.fc37
16:37:10 <dustymabe> sorry i'm late :(
16:37:15 <adamw_> it should have been uboot-tools-2022.10-1.fc37
16:37:26 <adamw_> so we're missing "- Update SMBIOS patch" and then the GA release
16:38:07 <King_InuYasha> yikes
16:38:34 <King_InuYasha> but it was in RC2 compose, right?
16:38:51 <King_InuYasha> or the RC1 compose?
16:38:52 <adamw_> probably not. it won't have been in any compose, i don't think.
16:38:58 * King_InuYasha sighs
16:39:07 <adamw_> the problem is the rc4 build was put in the override tag for the beta compose
16:39:13 <adamw_> then the override tag wasn't emptied after the beta compose
16:39:22 <adamw_> things that are tagged as override get pulled in regardless how old they are
16:39:30 <King_InuYasha> right, I remember how Koji does this
16:40:18 <geraldo-simiao94> So, what to do now?
16:40:38 <geraldo-simiao94> A new compose and redo relval?
16:41:25 <adamw_> we are trying to work that out.
16:41:39 <adamw_> it depends how important it is to have the final version.
16:42:09 <adamw_> https://paste.centos.org/view/fed2cebf should be the changelog
16:42:11 <King_InuYasha> considering the nature of ARM boot, sadly I think it's quite important
16:42:28 <adamw_> King_InuYasha: i need specifics, not just "it's an important package"
16:42:39 <adamw_> the kernel is an important package, but that doesn't mean it's release-threatening if we have an older one
16:43:07 <adamw_> #info RC 1.3 was inadvertently built with uboot-tools-2022.10-0.5.rc4.fc37 instead of the current stable uboot-tools-2022.10-1.fc37 , we are attempting to figure out how big of a problem this is
16:43:26 <geraldo-simiao94> So if that doesn't affects other architecture, we can import results from rc1.3 release validation, as done before.
16:43:33 <King_InuYasha> it looks like the GA version has several fixes for booting on iMX8 systems and UEFI "emulation"
16:43:42 <geraldo-simiao94> For the other architectures
16:44:32 <King_InuYasha> the only other significant thing in there is that the Purism Librem 5 is supported, but for GA that doesn't matter
16:47:28 <adamw_> our supported hardware list only says i.MX6, but i guess it might be...old
16:47:31 <adamw_> https://fedoraproject.org/wiki/Architectures/ARM#Supported_Hardware_and_Devices
16:47:46 <King_InuYasha> adamw_: the other difference between uboot and the kernel is that we do respins for x86, and we don't for any other arch
16:47:46 <adamw_> that's 32-bit arm, so, yeah.
16:47:50 <adamw_> someone needs to update that list.
16:48:06 <King_InuYasha> so we literally don't have a way to give people updated images for ARM right now
16:48:28 <King_InuYasha> IMO, it would be less critical if we did regular recomposes for updates like we respin for x86
16:48:34 <King_InuYasha> but unfortunately, we currently don't
16:52:18 <adamw_> i guess i'll request another compose. we can always choose which one to ship
16:52:35 <adamw_> #info RC 1.4 will be requested with correct uboot-tools version, we can decide which to ship at go/no-go on Thursday
16:53:12 <Penguinpee> sounds like a plan
16:53:28 <geraldosimiao> Oh, bot is alive again? Good.
16:54:13 <geraldosimiao> adamw_: Good idea
16:57:05 <adamw_> yeah, looks like the bridge came back.
16:57:08 <adamw_> alright, i think that's everything
16:57:11 <adamw_> anyone got anything else?
16:57:18 <Penguinpee> nope
16:57:48 <geraldosimiao> No
16:57:48 <bcotton_> nothing here
16:58:08 <lruzicka> no, not here.
16:58:37 <King_InuYasha> nothing else here
16:59:50 <adamw_> alrighty, thanks folks
16:59:52 <adamw_> #endmeeting