f37-blocker-review
MINUTES

#fedora-blocker-review: F37-blocker-review

Meeting started by adamw at 16:01:06 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:01:09)
  2. Introduction (adamw, 16:09:03)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:09:10)
    2. We'll be following the process outlined at: (adamw, 16:09:13)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:09:17)
    4. The bugs up for review today are available at: (adamw, 16:09:20)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:09:24)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:09:28)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:09:31)
    8. https://fedoraproject.org/wiki/Fedora_37_Beta_Release_Criteria (adamw, 16:09:34)
    9. https://fedoraproject.org/wiki/Fedora_37_Final_Release_Criteria (adamw, 16:09:44)
    10. for Beta we have: (adamw, 16:10:02)
    11. 3 Proposed Blockers (adamw, 16:10:05)
    12. 1 Accepted Blockers (adamw, 16:10:10)
    13. 1 Proposed Freeze Exceptions (adamw, 16:10:11)
    14. for Final we have (numbers subject to change): (adamw, 16:10:18)
    15. 10 Proposed Blockers (adamw, 16:10:29)
    16. 4 Accepted Blockers (adamw, 16:10:33)
    17. coremodule will secretarialize (adamw, 16:14:45)

  3. (1907030) "dnf update" runs out of memory on swapless 0.5 GiB RAM machine (adamw, 16:15:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1907030 (adamw, 16:15:59)
    2. https://pagure.io/fedora-qa/blocker-review/issue/841 (adamw, 16:16:03)
    3. Proposed Blocker, dnf, NEW (adamw, 16:16:05)
    4. Ticket vote: BetaBlocker (+0,2,-3) (bcotton, kparal, -jmracek, -adamwill, -geraldosimiao) (adamw, 16:16:11)
    5. Ticket vote: FinalBlocker (+0,0,-1) (-jmracek) (adamw, 16:16:15)
    6. AGREED: 1907030 - punt (delay decision) - this is a difficult call as it really depends on a subjective evaluation of how much RAM we're comfortable with requiring for basic packaging operations on a minimal Fedora environment. we will solicit input from various teams and re-consider this at a later time (adamw, 16:33:08)

  4. (2117859) FreeIPA client enrolment fails due to DNS issues with openssl-pkcs11-0.4.12-2.fc37 on server (adamw, 16:33:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2117859 (adamw, 16:33:35)
    2. https://pagure.io/fedora-qa/blocker-review/issue/852 (adamw, 16:33:44)
    3. Proposed Blocker, openssl-pkcs11, NEW (adamw, 16:33:45)
    4. Ticket vote: BetaBlocker (+3,0,-0) (+kparal, +lruzicka, +bcotton) (adamw, 16:33:45)
    5. we'll circle back to 2117859 at the end of the meeting and see if the upgrade test is done by then (adamw, 16:45:02)

  5. (2103835) failed to install server iso with virt-install due to the missing of isolinux in the media (adamw, 16:45:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2103835 (adamw, 16:45:21)
    2. https://pagure.io/fedora-qa/blocker-review/issue/833 (adamw, 16:45:30)
    3. Proposed Blocker, osinfo-db, NEW (adamw, 16:45:31)
    4. Ticket vote: BetaBlocker (+3,0,-0) (+kparal, +lruzicka, +bcotton) (adamw, 16:45:31)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=2118152 (TheExorcist[m], 16:52:26)
    6. AGREED: 2103835 - AcceptedBlocker (Beta) - accepted as a violation of the virtualization criteria per kparal's comment on the ticket. We also note its impact on important test systems (anaconda CI and fedora-release-autotest) (adamw, 17:03:08)

  6. Proposed Beta freeze exceptions (adamw, 17:03:27)
  7. (2117256) Obsolete packages that used to require Python 3.10 but are gone in Fedora 37 (adamw, 17:03:30)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2117256 (adamw, 17:03:35)
    2. https://pagure.io/fedora-qa/blocker-review/issue/847 (adamw, 17:03:45)
    3. Proposed Freeze Exceptions, fedora-obsolete-packages, ASSIGNED (adamw, 17:03:46)
    4. Ticket vote: BetaFreezeException (+4,0,-0) (+bcotton, +kparal, +kalev, +lruzicka) (adamw, 17:03:48)
    5. this already has sufficient votes, marking accepted (adamw, 17:04:01)

  8. Proposed Final blockers (adamw, 17:04:23)
  9. (2119762) Evince does not use utf-8 in search strings (adamw, 17:05:31)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2119762 (adamw, 17:05:35)
    2. https://pagure.io/fedora-qa/blocker-review/issue/858 (adamw, 17:05:44)
    3. Proposed Blocker, evince, NEW (adamw, 17:05:46)
    4. Ticket vote: FinalBlocker (+0,0,-2) (-catanzaro, -kparal) (adamw, 17:05:47)
    5. recent investigation upstream indicates this is a bug in the PDF, not in evince, so we will close the bug and not consider it (adamw, 17:06:36)

  10. (2111025) Making a screencast does not work (adamw, 17:07:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2111025 (adamw, 17:07:20)
    2. https://pagure.io/fedora-qa/blocker-review/issue/839 (adamw, 17:07:30)
    3. Proposed Blocker, gnome-shell, NEW (adamw, 17:07:31)
    4. Ticket vote: FinalBlocker (+1,1,-0) (+lruzicka, kparal) (adamw, 17:07:34)
    5. AGREED: 2111025 - AcceptedBlocker (Final) - accepted as a violation of "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use", on the basis it shows an icon in the panel when you trigger a recording (adamw, 17:12:17)

  11. (2115202) update 2.06-45 breaks windows boot manager (adamw, 17:13:43)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2115202 (adamw, 17:13:47)
    2. https://pagure.io/fedora-qa/blocker-review/issue/846 (adamw, 17:13:49)
    3. Proposed Blocker, grub2, ASSIGNED (adamw, 17:13:59)
    4. Ticket vote: FinalBlocker (+1,0,-0) (+lruzicka) (adamw, 17:14:00)
    5. AGREED: 2115202 - AcceptedBlocker (Final) - accepted as a violation of "The installer must be able to install into free space alongside an existing clean Windows installation and install a bootloader which can boot into both Windows and Fedora." (adamw, 17:18:54)

  12. (2119757) F37 images don't boot in BIOS mode on Thinkpad T480s (adamw, 17:19:16)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2119757 (adamw, 17:19:17)
    2. https://pagure.io/fedora-qa/blocker-review/issue/857 (adamw, 17:19:20)
    3. Proposed Blocker, lorax, NEW (adamw, 17:19:27)
    4. AGREED: 2119757 - RejectedBlocker (Final) - it's clear images boot in both BIOS and UEFI mode on most systems, and this system is not blocked because you can simply boot in UEFI mode. With only this one UEFI-capable system definitely affected, this clearly is not severe enough to violate the criteria (adamw, 17:38:54)

  13. Proposed Beta blockers (redux) (adamw, 17:40:20)
  14. (2117710) Open in Disks link is not working in root directory properties window. (adamw, 17:40:21)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2117710 (adamw, 17:40:21)
    2. https://pagure.io/fedora-qa/blocker-review/issue/859 (adamw, 17:40:21)
    3. Proposed Blocker, nautilus, NEW (adamw, 17:40:47)
    4. AGREED: 2117710 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) RejectedBlocker (Final) - there are no relevant criteria for Beta. For Final, we agreed this does not meet the "basic functionality' bar. But it's accepted as a Beta FE as it's a visible bug in a core component that can be used on live images so a safe fix would be reasonable (adamw, 17:58:59)

  15. (2117859) FreeIPA client enrolment fails due to DNS issues with openssl-pkcs11-0.4.12-2.fc37 on server (adamw, 17:59:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2117859 (adamw, 17:59:27)
    2. https://pagure.io/fedora-qa/blocker-review/issue/852 (adamw, 17:59:30)
    3. Proposed Blocker, openssl-pkcs11, NEW (adamw, 17:59:33)
    4. Ticket vote: BetaBlocker (+4,0,-0) (+kparal, +lruzicka, +bcotton, +bittin) (adamw, 17:59:44)
    5. AGREED: 2117859 - punt (delay decision) - we agreed to delay the decision here so adamw can do some more research and get the story of what exactly is affected and what needs doing sorted out. (adamw, 18:06:40)

  16. Accepted Beta blocker review (adamw, 18:06:48)
  17. (2110801) Logout from KDE session on Rawhide goes to console, not SDDM (adamw, 18:06:59)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2110801 (adamw, 18:07:02)
    2. https://pagure.io/fedora-qa/blocker-review/issue/837 (adamw, 18:07:05)
    3. Accepted Blocker, sddm, POST (adamw, 18:07:12)
    4. https://src.fedoraproject.org/rpms/sddm/pull-request/5 (LunaJernberg[m], 18:08:12)
    5. Ben Cotton (he/him) points out this may be resolved by switching SDDM back to X11, which will happen in the next compose (adamw, 18:08:45)
    6. ACTION: adamw to check whether this bug goes away once SDDM is on X11 again (adamw, 18:08:58)

  18. Open floor (adamw, 18:09:13)
    1. https://gitlab.gnome.org/GNOME/gnome-calendar/-/issues/858 (lruzicka, 18:10:54)


Meeting ended at 18:21:37 UTC (full logs).

Action items

  1. adamw to check whether this bug goes away once SDDM is on X11 again


Action items, by person

  1. adamw
    1. adamw to check whether this bug goes away once SDDM is on X11 again


People present (lines said)

  1. adamw (263)
  2. cmurf (72)
  3. LunaJernberg[m] (64)
  4. bcotton (46)
  5. lruzicka (42)
  6. TheExorcist[m] (23)
  7. zodbot (18)
  8. jednorozec (14)
  9. coremodule (9)
  10. SumantroMukherje (7)
  11. geraldosimiao (6)
  12. Southern_Gentlem (5)
  13. MichaelCatanzaro (3)
  14. AllanDay[m] (1)
  15. bittin (1)
  16. sgallagh (1)


Generated by MeetBot 0.4.