f33-blocker-review
MINUTES

#fedora-blocker-review: F33-blocker-review

Meeting started by adamw at 16:00:06 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:00:06)
  2. Introduction (adamw, 16:08:41)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:08:41)
    2. We'll be following the process outlined at: (adamw, 16:08:41)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:08:41)
    4. The bugs up for review today are available at: (adamw, 16:08:44)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:08:45)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:08:47)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:08:49)
    8. https://fedoraproject.org/wiki/Fedora_33_Beta_Release_Criteria (adamw, 16:08:51)
    9. https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria (adamw, 16:08:53)
    10. for Final, we have: (adamw, 16:08:55)
    11. 3 Proposed Blockers (adamw, 16:08:57)
    12. 6 Accepted Blockers (adamw, 16:08:59)
    13. 3 Proposed Freeze Exceptions (adamw, 16:09:01)
    14. 10 Accepted Freeze Exceptions (adamw, 16:09:05)
    15. coremodule will secretarialize (adamw, 16:09:16)

  3. Proposed Final blockers (adamw, 16:09:22)
  4. (1886187) bcm283x-firmware-20200928-2.f0eab3a.fc33.aarch64 fails to boot on Raspberry Pi 3 Model B (adamw, 16:10:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1886187 (adamw, 16:10:48)
    2. https://pagure.io/fedora-qa/blocker-review/issue/160 (adamw, 16:10:48)
    3. Proposed Blocker, bcm283x-firmware, ON_QA (adamw, 16:10:48)
    4. we'll circle back to this one later in the meeting, coremodule is going to see if he can reproduce it (adamw, 16:17:19)

  5. (1885479) Google account: Credentials have expired (adamw, 16:17:32)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1885479 (adamw, 16:17:32)
    2. https://pagure.io/fedora-qa/blocker-review/issue/142 (adamw, 16:17:32)
    3. Proposed Blocker, gnome-online-accounts, ASSIGNED (adamw, 16:17:32)
    4. currently -3 in the ticket, from mcatanzaro, kparal and adamw: https://pagure.io/fedora-qa/blocker-review/issue/142 (adamw, 16:19:13)
    5. AGREED: 1885479 - RejectedBlocker (Final) - this is now rejected with the information that it only happens when user password is changed in a certain way (that is fairly unlikely to be encountered on first boot or in live usage) (adamw, 16:26:36)

  6. (1887367) Gnome applications cannot be forwarded via ssh. (adamw, 16:26:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1887367 (adamw, 16:26:56)
    2. https://pagure.io/fedora-qa/blocker-review/issue/161 (adamw, 16:26:56)
    3. Proposed Blocker, gnome-session, NEW (adamw, 16:26:56)
    4. we have -2 in the ticket currently, from kparal and adamw (adamw, 16:28:20)
    5. AGREED: 1887367 - RejectedBlocker (Final) - we don't think this really meets the criterion cited or any other, ssh X forwarding does not seem like basic functionality (adamw, 16:38:47)

  7. Proposed Final freeze exceptions (adamw, 16:42:16)
  8. (1863531) fawkes: FTBFS in Fedora rawhide/f33 (adamw, 16:42:22)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1863531 (adamw, 16:42:22)
    2. https://pagure.io/fedora-qa/blocker-review/issue/159 (adamw, 16:42:22)
    3. Proposed Freeze Exceptions, fawkes, ON_QA (adamw, 16:42:22)
    4. we have +2 in the ticket from kparal and adamw (adamw, 16:42:35)
    5. AGREED: 1863531 - AcceptedFreezeException (Final) - accepted as we conventionally accept FTBFS bugs to try and make the frozen final repo as installable as possible (adamw, 16:48:31)

  9. (1886561) RPM spec file syntax highlighting is not working (adamw, 16:48:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1886561 (adamw, 16:48:38)
    2. https://pagure.io/fedora-qa/blocker-review/issue/153 (adamw, 16:48:38)
    3. Proposed Freeze Exceptions, nano, VERIFIED (adamw, 16:48:38)
    4. AGREED: 1886561 - AcceptedFreezeException (Final) - we think it makes sense to maintain continuity here and we disagree with upstream's rationale for moving these in the first place. it would be good to get kdudka's clear ack before pushing this, though (adamw, 17:07:26)

  10. (1770599) os-prober very slow - taking up to 20 minutes (adamw, 17:07:36)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1770599 (adamw, 17:07:36)
    2. https://pagure.io/fedora-qa/blocker-review/issue/158 (adamw, 17:07:36)
    3. Proposed Freeze Exceptions, os-prober, ON_QA (adamw, 17:07:36)
    4. we have +2 in the ticket from kparal and adamw (adamw, 17:08:07)
    5. AGREED: 1770599 - AcceptedFreezeException (Final) - this is a sensitive thing to touch, but the bug is pretty bad for affected folks. We think it makes sense to accept a fix if we're confident about its safety, to save affected folks from a 10-20 minute delay during install (adamw, 17:13:54)

  11. Proposed Final blockers (redux) (adamw, 17:14:08)
    1. circling back to the one we delayed earlier (adamw, 17:14:14)

  12. (1886187) bcm283x-firmware-20200928-2.f0eab3a.fc33.aarch64 fails to boot on Raspberry Pi 3 Model B (adamw, 17:14:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1886187 (adamw, 17:14:24)
    2. https://pagure.io/fedora-qa/blocker-review/issue/160 (adamw, 17:14:25)
    3. Proposed Blocker, bcm283x-firmware, ON_QA (adamw, 17:14:25)
    4. AGREED: 1886187 - AcceptedBlocker (Final) - Raspberry Pis up to series 3 are on the ARM supported hardware list, and we have confirmation of the bug from coremodule, so accepting as a clear violation of Basic criterion "All release-blocking images must boot in their supported configurations" (adamw, 17:17:14)

  13. Accepted Final blockers (adamw, 17:26:33)
  14. (1884260) cheese creates invalid and extremely long video files, each app restart making them longer (adamw, 17:26:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1884260 (adamw, 17:26:56)
    2. https://pagure.io/fedora-qa/blocker-review/issue/136 (adamw, 17:26:56)
    3. Accepted Blocker, cheese, ASSIGNED (adamw, 17:26:56)
    4. this is waiting on a code fix, basically. nothing much we can do here unless someone wants to dive in and fix it (adamw, 17:27:23)
    5. ACTION: adamw to ping desktop team to see if they can help fix #1884260 (adamw, 17:29:35)

  15. (1883681) [abrt] gnome-calendar: on_calendar_monitor_completed_cb(): gnome-calendar killed by SIGABRT (adamw, 17:29:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1883681 (adamw, 17:29:47)
    2. https://pagure.io/fedora-qa/blocker-review/issue/156 (adamw, 17:29:47)
    3. Accepted Blocker, gnome-calendar, NEW (adamw, 17:29:47)
    4. ACTION: adamw to ping desktop team to see if they can help fix #1883681 also (adamw, 17:33:25)

  16. (1874117) 5.8.3-300.fc33.aarch64 kernel panic on boot (X-Gene PMU) (adamw, 17:34:37)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1874117 (adamw, 17:34:37)
    2. https://pagure.io/fedora-qa/blocker-review/issue/145 (adamw, 17:34:37)
    3. Accepted Blocker, kernel, ON_QA (adamw, 17:34:38)
    4. this is fixed and fix submitted for stable, should go out in the next stable push request (adamw, 17:35:15)

  17. (1882718) Server crashes after one connection attempt, all subsequent attempts will fail (adamw, 17:35:23)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1882718 (adamw, 17:35:23)
    2. https://pagure.io/fedora-qa/blocker-review/issue/131 (adamw, 17:35:23)
    3. Accepted Blocker, libvncserver, ASSIGNED (adamw, 17:35:23)
    4. jadahl and I are currently working on this one (adamw, 17:35:32)

  18. (1861700) login stuck when changing users repeatedly (log out, log in a different one) (adamw, 17:41:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1861700 (adamw, 17:41:45)
    2. https://pagure.io/fedora-qa/blocker-review/issue/16 (adamw, 17:41:45)
    3. Accepted Blocker, sddm, ASSIGNED (adamw, 17:41:45)
    4. still waiting on someone to try bberg's proposed fix here (adamw, 17:43:58)

  19. (1883609) Secure Boot fails to boot F33 Beta image (adamw, 17:46:14)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1883609 (adamw, 17:46:15)
    2. https://pagure.io/fedora-qa/blocker-review/issue/135 (adamw, 17:46:15)
    3. Accepted Blocker, shim, NEW (adamw, 17:46:15)
    4. there's still a lot of confusion about who's running into what problem here, but it seems we're broadly treating this bug as being about a scenario where the Secure Boot key that our initial bootloader (shim) is signed with gets revoked somehow (due to the BootHole vulnerability) (adamw, 17:57:41)
    5. FESCo has agreed to treat this problem as a FESCo blocker - https://pagure.io/fesco/issue/2479#comment-694834 - but stipulates that the resolution "does not necessarily have to be technical" (adamw, 17:58:19)
    6. so we're broadly waiting on FESCo and pjones to decide what to do about this (adamw, 17:58:35)

  20. Open Floor (adamw, 17:59:43)


Meeting ended at 18:11:14 UTC (full logs).

Action items

  1. adamw to ping desktop team to see if they can help fix #1884260
  2. adamw to ping desktop team to see if they can help fix #1883681 also


Action items, by person

  1. adamw
    1. adamw to ping desktop team to see if they can help fix #1884260
    2. adamw to ping desktop team to see if they can help fix #1883681 also


People present (lines said)

  1. adamw (249)
  2. cmurf (76)
  3. Eighth_Doctor (47)
  4. Southern_Gentlem (25)
  5. bcotton (23)
  6. lruzicka (20)
  7. coremodule (18)
  8. zodbot (12)
  9. Ilgaz (9)
  10. sgallagh (4)
  11. zbyszek (2)
  12. jforbes (1)


Generated by MeetBot 0.1.4.