f33-blocker-review
MINUTES

#fedora-blocker-review: F33-blocker-review

Meeting started by adamw at 16:17:31 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:17:31)
    1. https://images.app.goo.gl/mCnbdKfXwLqAJEvg7 (cmurf, 16:18:12)
    2. coremodule will secretarialize (adamw, 16:21:35)

  2. Introduction (adamw, 16:21:49)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:21:49)
    2. We'll be following the process outlined at: (adamw, 16:21:49)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:21:51)
    4. The bugs up for review today are available at: (adamw, 16:21:51)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:21:53)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:21:55)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:21:57)
    8. https://fedoraproject.org/wiki/Fedora_33_Beta_Release_Criteria (adamw, 16:21:59)
    9. https://fedoraproject.org/wiki/Fedora_33_Final_Release_Criteria (adamw, 16:22:01)
    10. for Beta, we have: (adamw, 16:22:10)
    11. 4 Proposed Blockers (adamw, 16:22:10)
    12. 2 Accepted Blockers (adamw, 16:22:10)
    13. 1 Proposed Freeze Exceptions (adamw, 16:22:14)
    14. for Final, we have: (adamw, 16:22:18)
    15. 1 Accepted Blockers (adamw, 16:22:28)

  3. Proposed Beta blockers (adamw, 16:23:40)
  4. (1830343) Network manager started stuck when I tries connecting to VPN (openconnect) after upgrade gnome-shell to 3.37.1-1.fc33 version (adamw, 16:23:48)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1830343 (adamw, 16:23:48)
    2. Proposed Blocker, gnome-shell, NEW (adamw, 16:23:48)
    3. ACTION: adamw to send out testing call for #1830343 (adamw, 16:28:12)
    4. AGREED: 1830343 - punt (delay decision) - we still didn't get any further info on this yet, so need to punt again. we will send out a call for testing to try and get more info (adamw, 16:36:15)

  5. (1866570) FreeIPA deployment fails in current Rawhide due to various issues with Java 11 (adamw, 16:36:25)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1866570 (adamw, 16:36:25)
    2. Proposed Blocker, resteasy, NEW (adamw, 16:36:25)
    3. AGREED: 1866570 - AcceptedBlocker (Beta) - clear violation of Basic criterion "It must be possible to configure a Fedora Server system installed according to the above criteria as a FreeIPA domain controller, using the official deployment tools provided in the distribution FreeIPA packages..." (adamw, 16:40:09)

  6. (1861700) login stuck when changing users repeatedly (log out, log in a different one) (adamw, 16:41:55)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1861700 (adamw, 16:41:55)
    2. Proposed Blocker, sddm, NEW (adamw, 16:41:55)
    3. we agreed in the QA meeting today that we will accept one of the proposed criteria relating to this, or a similar one which still requires "log out as A, log in as B" to work (adamw, 16:46:42)
    4. we can treat this bug as violating that to-be-accepted criterion (adamw, 16:46:59)
    5. AGREED: 1861700 - AcceptedBlocker (Beta) - this is accepted as a violation of the in-progress but accepted-in-principle logout criterion, see thread https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/PTRPHWTMVEKLTCMVDBGIWYYMYVIBAJYB/ (adamw, 16:49:28)

  7. (1862686) SELinux is preventing systemd-machine from 'create' accesses on the sock_file io.systemd.Machine. (adamw, 16:49:42)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1862686 (adamw, 16:49:42)
    2. Proposed Blocker, selinux-policy, NEW (adamw, 16:49:43)
    3. AGREED: 1862686 - punt (delay decision) for Beta, AcceptedBlocker (Final) - this is a pretty clear violation of Final criterion "All system services present after installation with one of the release-blocking package sets must start properly...", so we accept it as at least a Final blocker. we're less sure about whether it breaks virtualization, so we will delay the decision on Beta blocker status to look into that some more (adamw, 16:57:40)

  8. Accepted Beta blocker review (adamw, 16:59:37)
  9. (1860616) abrt-server errors when processing zstd compressed core dumps produced by systemd-246~rc1-1.fc33 (adamw, 17:00:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1860616 (adamw, 17:00:11)
    2. Accepted Blocker, libreport, NEW (adamw, 17:00:11)
    3. a PR that's alleged to help with this is merged upstream, but there has been no new release or backport (adamw, 17:01:33)
    4. ACTION: adamw to ping team to backport patch or cut a new release, do it himself if necessary (adamw, 17:02:00)

  10. (1857043) FreeIPA server deployment fails in Fedora-Rawhide-20200714.n.0 due to pki-tomcat failing to run with "java.lang.ClassNotFoundException: org.apache.tomcat.util.modeler.modules.MbeansDescriptorsIntrospectionSource" (adamw, 17:04:10)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1857043 (adamw, 17:04:10)
    2. Accepted Blocker, tomcat, MODIFIED (adamw, 17:04:10)
    3. we think this is probably fixed, but it's hard to tell for sure due to the Java 11 changes complicating things (adamw, 17:04:24)
    4. we'll continue to monitor it as part of the broader Make FreeIPA Work Again...thing (adamw, 17:04:46)

  11. Open floor (adamw, 17:08:00)
  12. (1862686) SELinux is preventing systemd-machine from 'create' accesses on the sock_file io.systemd.Machine. (adamw, 17:09:05)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1862686 (adamw, 17:09:05)
    2. Proposed Blocker, selinux-policy, NEW (adamw, 17:09:05)
    3. circling back to this as cmurf says he can reproduce the 'VM won't run' element (adamw, 17:09:19)
    4. AGREED: 1862686 - AcceptedBlocker (Beta) - accepted as a violation of "The release must be able host virtual guest instances of the same release", since both adamw and cmurf have reported being unable to launch VMs with SELinux in enforcing mode. this overrides earlier acceptance as a Final blocker (adamw, 17:16:41)

  13. Open floor (adamw, 17:17:01)


Meeting ended at 17:20:39 UTC (full logs).

Action items

  1. adamw to send out testing call for #1830343
  2. adamw to ping team to backport patch or cut a new release, do it himself if necessary


Action items, by person

  1. adamw
    1. adamw to send out testing call for #1830343
    2. adamw to ping team to backport patch or cut a new release, do it himself if necessary


People present (lines said)

  1. adamw (157)
  2. cmurf (44)
  3. michel_slm (30)
  4. zodbot (22)
  5. lruzicka2 (16)
  6. coremodule (16)
  7. kparal (11)
  8. bcotton (8)
  9. pwhalen (4)
  10. tablepc (2)
  11. mclasen (2)
  12. Southern_Gentlem (1)


Generated by MeetBot 0.1.4.