f30-blocker-review
MINUTES

#fedora-blocker-review: F30-blocker-review

Meeting started by adamw at 16:03:56 UTC (full logs).

Meeting summary

  1. Roll Call (adamw, 16:03:56)
  2. Introduction (adamw, 16:07:46)
    1. Our purpose in this meeting is to review proposed blocker and nice-to-have bugs and decide whether to accept them, and to monitor the progress of fixing existing accepted blocker and nice-to-have bugs. (adamw, 16:07:46)
    2. We'll be following the process outlined at: (adamw, 16:07:46)
    3. https://fedoraproject.org/wiki/QA:SOP_Blocker_Bug_Meeting (adamw, 16:07:46)
    4. The bugs up for review today are available at: (adamw, 16:07:49)
    5. http://qa.fedoraproject.org/blockerbugs/current (adamw, 16:07:51)
    6. The criteria for release blocking bugs can be found at: (adamw, 16:07:53)
    7. https://fedoraproject.org/wiki/Basic_Release_Criteria (adamw, 16:07:55)
    8. https://fedoraproject.org/wiki/Fedora_30_Beta_Release_Criteria (adamw, 16:07:57)
    9. https://fedoraproject.org/wiki/Fedora_30_Final_Release_Criteria (adamw, 16:07:59)
    10. 5 Proposed Blockers (adamw, 16:08:15)
    11. 4 Accepted Blockers (adamw, 16:08:15)
    12. 6 Proposed Freeze Exceptions (adamw, 16:08:19)
    13. 2 Accepted Freeze Exceptions (adamw, 16:08:19)
    14. coremodule will secretarialize (without pay, obvs) (adamw, 16:08:55)
    15. let's get started with the proposed blockers (adamw, 16:09:24)

  3. (1699280) Fedora 30 beta install fails with Error in <unknown> scriptlet in rpm package breeze-icon-theme (adamw, 16:09:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1699280 (adamw, 16:09:57)
    2. Proposed Blocker, breeze-icon-theme, MODIFIED (adamw, 16:09:57)
    3. https://fedoraproject.org/wiki/Fedora_30_Beta_Release_Criteria#Kickstart_delivery (coremodule, 16:18:48)
    4. AGREED: 1699280 - RejectedBlocker AcceptedFreezeException (Beta) - rejected as the current criteria do not really cover this, the existing requirement in historical context covered the pre-Fedora.next default install which was GNOME. We believe the criterion could be revisited, but as this bug is fixed anyway, we will handle that separately (adamw, 16:26:20)

  4. (1693409) gdm/X start fails on 'nomodeset' UEFI boot on multiple bare metal systems: "Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices" (adamw, 16:26:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1693409 (adamw, 16:26:47)
    2. Proposed Blocker, gdm, NEW (adamw, 16:26:47)
    3. https://everymac.com/systems/apple/macbook/specs/macbook-core-2-duo-2.4-black-13-early-2008-penryn-specs.html (coremodule, 16:32:38)
    4. AGREED: 1693409 - AcceptedBlocker (Final) - accepted as a violation of "The generic video driver option ('basic graphics mode' - as described in the Basic criteria) on all release-blocking installer and live images must function as intended (launching the installer or desktop and attempting to use a generic driver)...", as current feedback indicates this affects almost all tested systems (adamw, 16:43:58)

  5. (1699099) gnome-initial-setup 3.32.0+ crashes due to SELinux denials (adamw, 16:44:07)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1699099 (adamw, 16:44:08)
    2. Proposed Blocker, gnome-initial-setup, ASSIGNED (adamw, 16:44:08)
    3. AGREED: 1699099 - AcceptedBlocker (Final) - clear violation of " A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility" for all Workstation installs (adamw, 16:50:11)

  6. (1698550) Fedora install media error out with SecureBoot or Grub error in UEFI-only mode on T450s (adamw, 16:51:34)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1698550 (adamw, 16:51:34)
    2. Proposed Blocker, shim, NEW (adamw, 16:51:35)
    3. AGREED: 1698550 - RejectedBlocker (Final) AcceptedFreezeException (Final) - for now this appears to be too specific to justify accepting as a blocker, we only know that it affects one laptop model with one specific non-default firmware configuration. However, for affected users it's a critical bug, so we would consider a safe fix for post-freeze inclusion. This decision may be changed based on further investigation (adamw, 17:19:25)

  7. (1697591) modesetting driver on some Intel hardware fails to start after kernel 4.20.13 update (adamw, 17:23:20)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1697591 (adamw, 17:23:20)
    2. Proposed Blocker, xorg-x11-server, ASSIGNED (adamw, 17:23:20)
    3. https://gitlab.freedesktop.org/xorg/xserver/merge_requests/36 (jforbes, 17:28:56)
    4. AGREED: 1697591 - punt (delay decision) - we are very concerned about this bug and quite inclined to accept it, but we would like ajax's input on how wide the scope is and how practical it would be to fix before we make a final decision (adamw, 17:57:57)

  8. Proposed freeze exceptions (adamw, 17:59:11)
  9. (1698529) crash early in initialize_network() (adamw, 17:59:24)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1698529 (adamw, 17:59:24)
    2. Proposed Freeze Exceptions, anaconda, ASSIGNED (adamw, 17:59:24)
    3. AGREED: 1698529 - AcceptedFreezeException (Final) - this causes install to fail on s390, clearly cannot be fixed with an update (adamw, 18:06:33)

  10. (1699280) Fedora 30 beta install fails with Error in <unknown> scriptlet in rpm package breeze-icon-theme (adamw, 18:06:47)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1699280 (adamw, 18:06:47)
    2. Proposed Freeze Exceptions, breeze-icon-theme, MODIFIED (adamw, 18:06:47)
    3. we already accepted this (adamw, 18:06:57)

  11. (1677379) Changes/MongoDB Removal (adamw, 18:07:01)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1677379 (adamw, 18:07:01)
    2. Proposed Freeze Exceptions, Changes Tracking, MODIFIED (adamw, 18:07:02)
    3. AGREED: 1677379 - AcceptedFreezeException (Final) - accepted as the package not being properly retired causes problems for upgrades, and may mean a non-free package being kept in the final release package set which we would not want. (adamw, 18:12:00)

  12. (1699977) Package group Fedora Eclipse contains obsolete package eclipse-recommenders (adamw, 18:12:11)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1699977 (adamw, 18:12:12)
    2. Proposed Freeze Exceptions, comps, NEW (adamw, 18:12:12)
    3. AGREED: 1699977 - AcceptedFreezeException (Final) - this package remaining in the group causes issues on upgrade for systems with the group installed, would be good to fix that during freeze (adamw, 18:16:43)

  13. (1698504) No seamless upgrade to fc30 because of eclipse (adamw, 18:16:50)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1698504 (adamw, 18:16:50)
    2. Proposed Freeze Exceptions, eclipse, ON_QA (adamw, 18:16:50)
    3. AGREED: 1698504 - AcceptedFreezeException (Final) - this is another typical 'packaging issue affects upgrade' bug, we always like to fix these during freeze so upgrades work (adamw, 18:19:18)

  14. (1699852) No seamless upgrade to fc30 because of httpcomponents-client (adamw, 18:19:27)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=1699852 (adamw, 18:19:27)
    2. Proposed Freeze Exceptions, httpcomponents-client, NEW (adamw, 18:19:27)
    3. AGREED: 1699852 - AcceptedFreezeException (Final) - this is another typical 'packaging issue affects upgrade' bug, we always like to fix these during freeze so upgrades work (also seems different from 1698504) (adamw, 18:25:31)

  15. Accepted blockers (adamw, 18:25:46)
    1. 1683197, 1691909 - halfline is aware of these and working through them (adamw, 18:26:14)
    2. 1690429 - desktop team is aware of this and doing its best, though it's not a straightforward fix and they have other things to work on too (adamw, 18:26:36)
    3. 1688462 - dnf team is working on this and the elements of the fix are landing at present (adamw, 18:26:56)

  16. Open floor (adamw, 18:30:11)


Meeting ended at 18:34:22 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (245)
  2. cmurf (82)
  3. jlanda (70)
  4. coremodule (54)
  5. lruzicka (37)
  6. frantisekz (31)
  7. kparal (29)
  8. bcotton (25)
  9. zodbot (19)
  10. pwhalen (18)
  11. jforbes (18)
  12. sumantro (4)
  13. nirik (2)
  14. tablepc (2)
  15. mclasen (1)


Generated by MeetBot 0.1.4.